メニューエントリの登録 

用途

既存の分野メニューにメニューエントリを追加します。

前提条件

分野メニュー更新トランザクションが編集モードになっています。

手順

  1. メニューノードを選択します。新規メニューの場合は、見出しを選択します。
  2. 編集 メニューエントリ挿入 1 つ低いレベル を選択するか、または 編集 メニューエントリ挿入 同レベルに挿入を選択します。

次に表示されるダイアログで、複数の新規メニューエントリを一括入力することができます。メニューエントリには、トランザクション、レポート、フォルダ、別の分野メニューへのリンクがあります。

トランザクションの挿入

メニューにトランザクションを追加する場合には、トランザクションコードとメニューエントリテキストを入力する必要があります。トランザクションコードを入力してテキストを入力しないと、トランザクション名称はテキストとして使用されます。入力したトランザクションコードが現行システム内に存在していない場合には、このトランザクションコードはテキストとして使用されます。

レポートの挿入

分野メニューにレポートを挿入するには、レポート押ボタン を選択します。

次に表示されるダイアログで、挿入するレポートを選択します。レポートタイプを選択します。選択したタイプの入力項目が表示されます。

トランザクションコードの自動登録

ダイアログを閉じると、選択されているレポートに対応するトランザクションコードが生成されます。開発クラスを指定する必要があります。また、場合によっては移送依頼を指定する必要もあります。選択されているレポートに既にトランザクションコードが割り当てられている場合には、このトランザクションコードが使用されます。

トランザクションコードのマニュアル割当

レポートのトランザクションコードを指定するには、他オプション照会を選択します。表示される 2 つの入力項目に、トランザクションコードとテキストを指定します。 2 つの入力項目チェックボックス ( 自動生成レポートテキストコピー ) をオフにしてください。

フォルダの入力

フォルダを入力するには、テキストだけを入力します。トランザクションコードは入力しません。自動的にこのテキストがフォルダとして解釈されます。

下位メニューへの参照の挿入

分野メニューに、他の分野メニュー ( 旧リリースでのレポートツリーも含む ) への参照を挿入することができます。他のメニューへの参照を分野メニューに挿入することで、個別に管理される複数の下位メニューから 1 つのメニューを構成することができます。

メニューエントリ登録ダイアログのメニュー参照チェックボックスをオンにします。トランザクションコードを入力する代わりに、分野メニュー名称を入力するか、または F4 ヘルプでメニュー名称を選択することができます。

メニューエントリ登録ダイアログが表示されていない場合には、編集 他構造の参照 下位レベル / 同レベルを選択します。表示されるダイアログボックスで、他の分野メニューとメニューエントリテキストを指定することができます。

照会モードでは、参照される下位メニューは分野メニューの一部として表示されます。