# TABLE OF CONTENTS

| DOCUMENT HISTORY .................................................................................................................. 3 |
| 1. INTRODUCTION ....................................................................................................................... 4 |
| 1.1 Overview............................................................................................................................... 4 |
| 1.2 About this Document ............................................................................................................ 4 |
| 2. TECHNICAL SYSTEM LANDSCAPE ......................................................................................... 5 |
| 3. INSTALLATION ....................................................................................................................... 6 |
| 3.1 Installation of SAP HANA Appliance Software ....................................................................... 6 |
| 3.1.1 How to Set Up the SAP HANA Appliance Software .............................................................. 6 |
| 3.2 Installation of Application Server ABAP (AS ABAP) .................................................................. 6 |
| 3.3 Update of Application Server ABAP and Installation of SAP CPS as an Add-On .................. 7 |
| 4. POST INSTALLATION.............................................................................................................. 8 |
| 4.1 Configuration for HTTPS ...................................................................................................... 8 |
| 4.2 Configuration of the Secure Sockets Layer Protocol ............................................................... 8 |
| 4.3 Configuration in the SAP HANA Database .......................................................................... 9 |
| 4.4 Technical Configuration Steps ............................................................................................ 10 |
| 4.5 Configuration of SAP NetWeaver Gateway ......................................................................... 10 |
| 4.6 Configuration of OData Services .......................................................................................... 11 |
| 4.7 Configuration of Web Services ............................................................................................ 12 |
| 4.8 Generating Authorization Profiles for the User Interface ..................................................... 13 |
| 4.9 Installing the SAP Online Documentation .......................................................................... 13 |
| 5. APPLICATION CONFIGURATION AND CUSTOMIZING .......................................................... 14 |
| 5.1 Preliminary Steps ................................................................................................................ 14 |
| 5.2 Customizing with SAP Solution Manager ........................................................................... 14 |
| 5.3 Creating Productive Tariffs ................................................................................................. 15 |
| 5.4 Using Customer Attributes ................................................................................................. 15 |
| 5.5 Performance Optimization ................................................................................................. 15 |
| 5.6 Data Provider ........................................................................................................................ 16 |
## DOCUMENT HISTORY

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>2015-11-13</td>
<td>Initial Version</td>
</tr>
<tr>
<td>2.0</td>
<td>2015-12-10</td>
<td>Updated Version</td>
</tr>
<tr>
<td>3.0</td>
<td>2016-07-29</td>
<td>Updated Version</td>
</tr>
</tbody>
</table>
1. INTRODUCTION

1.1 Overview

SAP Hybris Billing, pricing simulation (SAP CPS) is an event-based simulation on a large volume of usage data.

A company can use SAP CPS to rerate its historical usage data for its current pricing models or alternative ones or generate usage data using customer behavior modeling.

Usage data is the event-based fine granular data that customers produce by using the service provided by the company. Examples of usage data include a single phone call or a single multimedia service (MMS) in a telecommunications company or a single ticket from a truck passing a control point for tollage fee rating. All these usage events generate historical usage data. This can be used as a data basis for a pricing simulation if it is stored in a data store.

During a pricing simulation, existing or new pricing models can be applied to the usage data to view the effect of the pricing models on the usage. If SAP CPS uses the single event as a starting point, the usage data volume can increase to a tremendous number of records. It is only possible to rerate this mass data within a realistic time frame by using the powerful capabilities available in SAP HANA (fast data access, parallelization on multiple cores, fast script language (L-Script) for imperative logic).

Reliable statements can be made about the rerated data, since they are based on actual usage data. You can accurately predict the outcome of the configurations made for a pricing model that is applied to the usage data. Therefore, SAP CPS enables a company to use its massive volume of historical usage data to optimize its current pricing models and/or develop new pricing models. It helps the company to make a statement about what would happen if the usage were rated using alternative pricing models. This provides insights into its existing pricing structure and pricing models and creates the opportunity to evaluate expected revenues and the profitability of the pricing models and optimize these as required.

This installation guide describes how to install the high-performance application SAP Hybris Billing, pricing simulation.

For more information on the SAP Hybris Billing, pricing simulation, see the SAP Help Portal at http://help.sap.com/hana_psi → Application Help → SAP Library (English).

Before starting the installation, make sure that you are aware of all required installation steps that have to be executed before the actual installation of the application. The prerequisites are mentioned in this document.

1.2 About this Document

This guide is relevant for consultants and system administrators who intend to install the SAP Hybris Billing, pricing simulation.

Integration

SAP CPS is based on the SAP HANA appliance software, specifically the SAP HANA database, and SAP NetWeaver 7.5.

The SAP HANA database must be available and configured with the latest revision of the current support package before starting the actual installation of SAP CPS. For more information about how to obtain the latest revision of the SAP HANA database, see the SAP HANA Master Update Guide at http://help.sap.com/hana_appliance → Installation and Upgrade Information → SAP HANA Update Guides.

Browser Recommendations

For a recommendation about the appropriate browser platform to run the application, see the Product Availability Matrix (PAM) at service.sap.com/pam.

Constraints

This guide provides you with the main application-specific installation and configuration steps. The installation and configuration of the associated SAP HANA appliance software is not specifically described in this installation guide, but in separate documentation, that is referenced where necessary.
2. TECHNICAL SYSTEM LANDSCAPE

SAP CPS is an event-based simulation for a large volume of usage data. It consists of two components:

- Software component CC_PSI
  This is the component for the back end server
- Software component CC_PSIUI
  This is the component for the front end server

With this approach, you can install the UI component on a central hub for UI applications. But both components must be on the same support package level. You cannot upgrade only the UI component or only the back end component.

- SAP HANA 1.0, SPS11
- SAP NetWeaver 7.5, SP03 (including SAP NetWeaver Gateway)
- SAP UI Add-on

The following SAP CC releases are supported:

- SAP CC 4.0, SP10 or higher
  If you want to use the functionality for counter pooling you have to install patch 11 for SP10 or a higher SP
- SAP CC 4.1, SP1 or higher
  For SP01, at least patch 5 is needed

The following figure shows the technical system landscape of SAP CPS:

The components mentioned above are embedded in a shell (home screen) that is based on HTML5 (SAPUI5). Some administrative tasks, such as Customizing tasks, are also based on the traditional SAP GUI technology, which is not explicitly shown in the diagram.

The communication of the front-end components with the back end, which is an SAP NetWeaver 7.5 application server, is based on HTTPS. The Web applications are embedded in a shell that ensures secure session management. All clients and servers run within the firewall.
The requests made by the stateless Web applications to the back end are based on OData (read and write) using HTTPS.

The main reused components of the application server are those from SAP NetWeaver 7.5, for example user management, authentication, and authorization. SAP Gateway handles the requests from the front end using OData channel services.

The underlying database for SAP CPS is SAP HANA 1.0. To leverage the capabilities of the SAP HANA database, parts of the segmentation, search capabilities, and analysis are performed directly in the database using stored procedures and SAP HANA information views, such as calculation views, attribute views, and analytical views. All database access takes place using the SAP NetWeaver 7.5 application server using ABAP Managed Database Procedures (AMDP) or the ABAP Database Connectivity (ADBC) interface from ABAP to the SAP HANA database. You only require user management from SAP NetWeaver and a technical user within the SAP HANA database is required for the access.

Data from SAP Hybris Billing, charging (SAP CC) is replicated to SAP CPS. Therefore, any replication tool can be used. With release 2.0 SP02, a direct integration using SAP HANA Smart Data Access is available in the application to replicate SAP CC master data. This includes not the replication of usage events from a data store to SAP CPS. Therefore we recommend using the BusinessObjects Data Services tool which is also described in the Data Replication Guide under service.sap.com/instguides → SAP Hybris Billing, pricing simulation. This configuration guide also contains information about the tables that are required for SAP CPS and the setup of the smart data access. The SAP NetWeaver role and authorization framework is used with SAP CPS.

SAP CPS is only deployed using a side-by-side approach. This means that the application runs on a separate application server with a separate SAP HANA database. The data is replicated from your source systems to the SAP HANA database.

More Information
For more information about the SAP HANA database system landscape, see the SAP Help Portal at help.sap.com → SAP In-Memory Computing → SAP HANA → SAP HANA Platform → Security Information → English → SAP HANA Security Guide.

You find installation and implementation information for SAP In-Memory Appliance (SAP HANA™) on the SAP Help Portal at help.sap.com/hana_appliance.

3. INSTALLATION

3.1 Installation of SAP HANA Appliance Software

Since SAP CPS runs on the SAP HANA appliance software and, in particular, the SAP HANA database, you need to set up the database first. The NetWeaver ABAP AS system on which the application runs must be deployed on SAP HANA and uses SAP HANA as its primary and only database.

3.1.1 How to Set Up the SAP HANA Appliance Software

To set up the SAP HANA appliance software, follow the procedure described in the corresponding installation guide on the SAP HelpPortal at help.sap.com/hana_appliance → Installation and Upgrade Information → SAP HANA Master Guide.

3.2 Installation of Application Server ABAP (AS ABAP)

The SAP CPS application is based on a SAP NetWeaver 7.5 application server SP03. To install this AS ABAP, follow the procedure described below.
Installation of SAP NetWeaver 7.5

The AS ABAP installation is executed using the software provisioning manager, a tool that is part of the software logistics toolset (SL toolset), which is a product-independent delivery channel which delivers up-to-date software logistics tools. The software provisioning manager performs software provisioning processes such as installation, deinstallation, or system copy.

To install the AS ABAP, follow the instructions in the installation guide for your operating system: (SAP Systems Based on the Application Server ABAP of SAP NetWeaver on <Your Operating System>: SAP HANA Database Using Software Provisioning Manager 1.0). You find the installation guide in the SAP HelpPortal under Installation and Upgrade Information → Installation Guides → SAP HANA Database → <Your Operating System> → ABAP.

Note: Make sure that the time zone of the AS ABAP and the server of the SAP HANA database are compatible.

Note: The installation must be done at least with the Software Provisioning Manager (SWPM) 1.0 SP06 PL7.

3.3 Update of Application Server ABAP and Installation of SAP CPS as an Add-On

Since your application is based on support package (SP) 03 of SAP NetWeaver 7.5 application server ABAP (AS ABAP), you must ensure that you are using SP03 of this AS ABAP version. The update to SP03 is executed in combination with the deployment of SAP CPS using the SAP Solution Manager. The deployment has been implemented as an add-on installation. All additionally required components are installed with the add-on automatically. To ensure a successful installation process, execute the steps below.

Note: Make sure that you are using SAP Solution Manager 7.1, Support Package 05 or higher, since lower versions do not support SAP HANA scenarios.

Executing the Maintenance Procedure

The following documentation describes the planning and execution of the maintenance procedure for the update of the AS ABAP to SP03 of SAP NetWeaver 7.5 and the deployment of the SAP CPS add-on. The maintenance procedure is executed using the maintenance optimizer in SAP Solution Manager. It ensures that all required components are automatically identified and provided for installation with the add-on.

For information about the specific steps to be executed, see the SAP Help Portal at help.sap.com/ solutionmanager → SAP Solution Manager 7.1 → Application Help → SAP Solution Manager 7.1 SP05 → SAP Solution Manager → Maintenance Management → Maintenance Optimizer → Maintenance Procedure Scenarios → Upgrade.


Deploying the SAP CPS Add-on

The current deployment of SP03 of SAP NetWeaver 7.5 and the SAP CPS add-on is executed using the software logistics toolset (SL toolset) and, specifically, the latest version of the Software Update Manager (SUM). For information about the specific steps to be executed, see the SAP Service Marketplace at service.sap.com/ sltoolset → Software Logistics Toolset 1.0 → Documentation → Software Update Manager (SUM) → Updating SAP Systems Using Software Update Manager 1.0 → Update of SAP Systems Using Software Update Manager (ABAP Systems) → SAP HANA DB.

Caution: Make sure that you always use the latest available version of the Software Update Manager (SUM).
Note: If you initially update the AS ABAP and install the add-on, use the resource-minimized update strategy (see section 3.9, Update Strategy Parameter, in the document mentioned above).

4. POST INSTALLATION

After you have installed all required components to run the SAP CPS application, you must perform some technical configuration steps. You find these steps listed in the following sections.

Note: Ensure that you execute all post-installation steps in the sequence given in this section and in the same client in which you want to run the SAP CPS.

4.1 Configuration for HTTPS

The communication of the AS ABAP with the Internet has been implemented using HTTPS; HTTP is not supported.

To prepare the AS ABAP for HTTPS communication, you must configure the following parameters in the instance profile of the AS ABAP, so that all HTTP requests are redirected to HTTPS:

- `icm/HTTP/redirect_<xx>`
- `icm/server_port_<xx>`
- `login/ticket_only_by_https`

You can execute this configuration according to the following example:

- # Definition of the ports
- `icm/server_port_0 = PROT=HTTP, PORT=1080`
- `icm/server_port_1 = PROT=HTTPS, PORT=1443`
- `icm/HTTP/redirect_0 = PREFIX=/, FROM=*", FROMPROT=HTTP, PROT=HTTPS, HOST=<fully qualified domain name>`
- `login/ticket_only_by_https = 1`

For more information, see the SAP Help Portal at help.sap.com/NW75 → Application Help → Function-Oriented View → Application Server/Application Server Infrastructure → Components of SAP NetWeaver Application Server ABAP → Internet Communication Manager (ICM) → Administration of the Internet Communication Manager → ICM Parameters → Shared Profile Parameters of ICM and Web Dispatcher.

4.2 Configuration of the Secure Sockets Layer Protocol

To secure HTTP connections to and from the AS ABAP, you use the Secure Sockets Layer (SSL) protocol. To configure SSL for AS ABAP, follow the instructions in the documentation in the SAP Help Portal at help.sap.com/NW75 → Application Help → Function-Oriented View → Security → Network and Transport Layer Security → Transport Layer Security on the AS ABAP → Configuring the AS ABAP for Supporting SSL.
4.3 Configuration in the SAP HANA Database

Creating database schema SAP_CC
All database tables, types, procedures, etc. are generated in database schema SAP_CC. So you have to create a corresponding database schema.

Settings for Activation of SAP HANA Content
To ensure activation and execution of the SAP HANA information models in the SAP HANA database, you need to make the following configuration settings for the required system:

1. Log on to the SAP HANA studio with the SYSTEM user and choose the Modeler perspective in the top right corner
2. In the Navigator section on the left, double-click the folder for the required system
3. In the center section, choose the Configuration tab, expand the indexserver.ini node, the repository node, and double-click the sqlscript mode entry
4. Enter Unsecure in the New Value field of the System section, and save your entry

Authorization Enhancement for SAP<SID> User
To ensure that the system can generate database tables, table types and procedures in the database schema SAP_CC for SAP CPS, (see the corresponding tasks of the technical configuration in the chapter Technical Configuration Steps), you must assign a certain SQL privilege to the SAP<SID> user. To do so, proceed as follows:

1. Log on to the SAP HANA studio with the SYSTEM user and choose the Modeler perspective in the top right corner
2. In the Navigator section on the left, expand the folder for the required system
3. Expand the corresponding Security folder and the Users folder
4. Double-click the SAP<SID> user
5. In the center section, choose the Object Privileges tab and then +
6. In the following Select Catalog Object dialog box, search for the SAP_CC SQL object
7. Check the privilege CREATE ANY, DROP, EXECUTE, SELECT. For EXECUTE and SELECT, set the option Grantable to others to Yes
8. Add the catalog object _SYS_BIC using +
9. Check the privilege EXECUTE, SELECT
10. Save the SAP<SID> user

Execute steps 4 to 7 also for user _SYS_REPO to grant privileges for schema SAP_CC and set the option Grantable to others to Yes for all privileges.

If you use SAP HANA Smart Data Access to replicate your master data from SAP CC, user SAP<SID> needs additionally the privilege for CREATE REMOTE SOURCE.

Schema Mapping
This task includes the schema mapping from the ABAP schema SAP_CC_PSI to the SAP<SID> schema in the SAP HANA modeler (which is a SAP HANA studio perspective for technical users).
All data and data objects from SAP CC is created in schema SAP_CC.
For more information about the schema mapping, see the SAP HANA Developer Guide, section Mapping the Authoring Schema to Physical Schema at the Target at help.sap.com/hana_appliance → Development Information → SAP HANA Developer Guide.
More Information
For more information about granting privileges to users, see the SAP HANA Developer Guide on the SAP Help Portal at help.sap.com/hana → SAP HANA → SAP HANA Platform → Development Information under Setting Up Roles and Authorizations → Privileges → Granting Privileges to Users.

4.4 Technical Configuration Steps

All database tables, table categories and procedures for the SAP CPS application are generated in the SAP_CC database scheme.

Prerequisites
For the first generation, you must execute the following step:
Log on to the ABAP system and execute the transaction Start Generation for System Set up under SAP Customizing Implementation Guide → SAP Convergent Pricing Simulation. This transaction generates the necessary tables, table types, and database procedures in the SAP CC database scheme.

4.5 Configuration of SAP NetWeaver Gateway

SAP CPS is based on the AS ABAP add-on SAP NetWeaver Gateway, a development framework that enables people-centric applications to consume business data through popular devices and platforms using a straightforward and standards-based approach. Gateway has been installed together with the SAP CPS add-on.

To ensure a proper configuration of SAP NetWeaver Gateway, you must execute the configuration procedure that is described below.

Definition of Connection From SAP NetWeaver Gateway to Your System

If you are already using SAP Fiori Apps on a central server, you can install the UI component on this server. Otherwise, you can also install both components on the same application server instance as a local Gateway installation.

You must therefore set up an RFC connection with a destination that points to your AS ABAP to connect your system to the Gateway. To do so, you can use the following procedure in the SAP NetWeaver Customizing settings:

1. Log on to the AS ABAP system
2. Access the transaction SPRO and choose SAP Reference IMG
3. Make your settings in the following Customizing activity:

SAP NetWeaver → Gateway → OData Channel → Configuration → Connection Settings → SAP NetWeaver Gateway to SAP System → Manage RFC Destinations.

For more information, see the SAP Help Portal at help.sap.com/nwgateway → Configuration and Deployment Information → Configuration Guide → SAP NetWeaver Gateway Configuration Guide → OData Channel Configuration → Connection Settings on the SAP NetWeaver Gateway Hub System → Connection Settings: SAP NetWeaver Gateway to SAP Systems.

Setup of System Alias

For a complete configuration of SAP NetWeaver Gateway, you need to define a system alias for the required OData services. To do so, execute the following Customizing activity in the SAP NetWeaver implementation guide (IMG):

1. Log on to the AS ABAP system
2. Access the transaction SPRO and choose SAP Reference IMG
3. Make your settings in the following Customizing activity:

SAP NetWeaver → Gateway → OData Channel → Configuration → Connection Settings → SAP NetWeaver Gateway to SAP System → Manage SAP System Aliases.
Note: Ensure that the following entries for a proper configuration of a local gateway are made:

- SAP system alias field: LOCAL (recommended, other entries are possible)
- Description field: Local Gateway, (example)
- Local App field: Must definitely be selected (Local GW field deselected)
- RFC destination field: Enter the RFC destination you defined in the previous step
- Software version field: DEFAULT

Note: If you are using a central server, you must create a system alias that points to your backend server.

For more information, see the SAP Help Portal at help.sap.com/nwgateway → Configuration and Deployment Information → Configuration Guide → SAP NetWeaver Gateway Configuration Guide → OData Channel Configuration → Connection Settings on the SAP NetWeaver Gateway Hub System → Connection Settings: SAP NetWeaver Gateway to SAP Systems → Creating the SAP System Alias for Applications.

Activation of SAP NetWeaver Gateway

When you have made the required settings, you must activate SAP NetWeaver Gateway. To do so, execute the following Customizing activity in the SAP NetWeaver Customizing settings:

1. Log on to the AS ABAP system
2. Access the transaction SPRO and choose SAP Reference IMG
3. Make your settings in the following Customizing activity:
   SAP NetWeaver → Gateway → OData Channel→Configuration → Connection Settings → Activate or Deactivate SAP NetWeaver Gateway.

For more information, see the SAP Help Portal at help.sap.com/nwgateway → Configuration and Deployment Information → Configuration Guide → SAP NetWeaver Gateway Configuration Guide → OData Channel Configuration → Activating SAP NetWeaver Gateway.

Definition of Virus Scan Profiles

For security reasons related to SAP NetWeaver Gateway, you must define a virus scan profile. To do so, follow the instructions in the corresponding documentation on the SAP Help Portal at help.sap.com/nwgateway → Application Help → Support Package 06 → SAP NetWeaver Gateway → SAP NetWeaver Gateway Security Guide → Data Protection and PrivacyVirus Scan.

4.6 Configuration of OData Services

You must add the required OData services to the service catalog. Make the relevant settings in Customizing under SAP NetWeaver → Gateway → OData Channel → Administration→General Settings → Activate and Maintain Services, or run the transaction /IWFD/MAINT_SERVICE, then enter the client to maintain cross-client settings.

Add services choosing the Add Service button, enter the following technical service names, and select the service. Use the system alias of your local or central system when activating the following services:

- /UI2/PAGE_BUILDER_PERS
- /UI2/PAGE_BUILDER_CUST
- /UI2/PAGE_BUILDER_CONF
- /UI2/INTEROP
- /UI2/LAUNCHPAD
- /UI2/TRANSPORT
  - PSI_APPL_GW_SERVICE_ANALYSIS
  - PSI_APPL_GW_SERVICE_ATTR
  - PSI_APPL_GW_SERVICE_AUTH
  - PSI_APPL_GW_SERVICE_CATA
You must activate the services in transaction SICF:
- default_host → sap → bc → ui5_ui5 → sap
- default_host → sap → opu → odata → sap

For more information about activating OData services, see Activating OData Services on the Help Portal under help.sap.com/nw-uiaddon20 → Application Help → Configuration and Operations → Activating OData Services.

4.7 Configuration of Web Services

The connection to the SAP CC system for compiling charge plans can be set up using a Web service. Before you can use a Web service, proceed as follows:

1. Start transaction SOAManager
2. Set up a logical port for the consumer proxy CO_PSI_EXPORTING_SERVICES
3. If you have connected several SAP CC systems or you want to access different owners of a SAP CC system, set up an own port for every system. This port is later stored in Customizing of the catalog (see chapter 5).
4. Set up a logical port for the consumer proxy CO_PSI_CATALOG_SERVICES.
5. If you are using SAP CC release 4.1 you additionally have to set up a logical port for the consumer proxy CO_PSI_V1_CATALOG_SERVICES

Note: All logical ports used for the same catalog of the same SAP CC system must use the same logical port name.

For more information, see Working with the SOA Manager [external document].
4.8 Generating Authorization Profiles for the User Interface

In the SAP CPS, two standard single roles are available:

- **SAP_PSI_ADMIN**
  For the administrator to generate database procedures, administrate products, and manage and reorganize simulation results. Also to define some technical settings for charge plans and setting up service components.

- **SAP_PSI_PRICING_MANAGER**
  For the pricing manager to execute a simulation and to create own simulation products. Also to create their own customer profile models to generate usage events for a simulation.

To initially generate an authorization profile in your AS ABAP system and assign it to a user, you must copy the required role and configure it according to your requirements. To do so, proceed as follows:

1. Log on to your AS ABAP system and enter TA PFCG.
2. Enter SAP_PSI_PRICING_MANAGER (example) in the Role field and choose Copy.
3. In the appearing dialog box, enter a self-defined name for your role and choose Copy all.
5. On the Change Roles screen, choose the Authorizations tab and choose Propose Profile Name in the Information About Authorization Profile section. The system enters a profile name and a profile text.
7. On the Change Role: Authorizations screen, maintain all authorizations that require maintenance (yellow status) according to your requirements.
8. To generate the authorization profile, choose Generate menu option from the Authorizations menu or choose Generate.
9. Assign the newly generated authorization profile to a user in TA SU01.
10. Repeat step 2 to 9 for all required authorizations roles.

4.9 Installing the SAP Online Documentation

SAP provides an HTML-based solution for the online documentation, including the application help, glossary, Customizing, and release notes. You can display the documentation with a Java-compatible Web browser on all front-end platforms supported by SAP.

**Prerequisites**

You have installed and set up the SAP Library in the SAP NetWeaver AS ABAP System on which the application runs. For more information, see the installation guide on the SAP Service Market Place at service.sap.com/instguides → SAP NetWeaver → SAP NetWeaver 7.5 → Installation. Then choose Installation Clients Installing SAP Library using SW Prov.Mgr. 1.0 in the table at the bottom of page 4.

**Integration**

Install the SAP online documentation in your SAP system as described in the README.TXT file contained in the root directory of the online documentation media, delivered as part of the installation package. In general, the new help files of the application can simply be added to the existing documentation directory.
5. APPLICATION CONFIGURATION AND CUSTOMIZING

5.1 Preliminary Steps

Before you can execute Customizing, you must upload master data and usage data from the SAP CC system. This is necessary, because Customizing checks whether some of the entries made in the existing data are valid.

To do so, proceed as follows:

1. Load the master data and usage data from SAP CC
2. Enrich the usage data using the report PSI_DATA_LOAD_AND_ENRICH. You can start the report in the SAP Menu under SAP Convergent Pricing Simulation → Administration → Enrich CDRs.
   
   Choose a source system and start the report. If you use data from different source systems, you must start the report for each system separately.

5.2 Customizing Settings

You can make the relevant settings in Customizing under SAP Convergent Pricing

- Define Source System
  
  Make your setting in SAP Customizing under SAP Convergent Pricing Simulation → Define Source Systems. Here you define for each used SAP CC system a corresponding source system with the information which kind of data replication is used

- Define Catalogs
  
  Make your setting in SAP Customizing under SAP Convergent Pricing Simulation → Define Catalogs.

  If you are using several SAP CC systems or if you want to access different owners of a SAP CC system, you can store the logical port for the SAP CC system here (see chapter 4.9 Configuration of Web Services).

- You can maintain custom default values (for example the number of products) in the SAP Customizing settings under SAP Convergent Pricing Simulation → Custom Default Values for Pricing Simulation.

  By default SAP CC release 4.0 is supported. If you are using a higher patch of release 4.0 or release 4.1 you have to make an entry here.

  You can optionally define here the structure of the used consumption detail records (CDR), used mapping tables and used range tables to improve the performance.

- Optional: You can maintain custom fields for the consumption detail records (CDR) selection (for example, charging contract) in Customizing under SAP Convergent Pricing Simulation → Define Custom Fields.

- Optional: You can implement a value help for custom fields in Customizing under SAP Convergent Pricing Simulation → Business Add-Ins (BAdIs) → BAdl: Retrieve Value Help for Custom Fields.

- Optional: You can define your own aggregation groups and add them to an overall scenario in Customizing under SAP Convergent Pricing Simulation → Scenarios → Define Aggregation Groups for Simulation Result.

- Optional: You can define your own scenarios in Customizing under SAP Convergent Pricing Simulation → Scenarios.

- Optional: You can change the date range for web service LEXPORTING in Customizing under SAP Convergent Pricing Simulation → Business Add-Ins (BAdIs) → BAdl: Change Values for Web Service LEXPORTING_MASS.
5.3 Creating Productive Tariffs

The usage data contains the assigned tariffs for each catalog, which you can set to productive using the report PSI_PRODUCT_CREATE_EXISTING. You find the report in the SAP Menu under Convergent Pricing Simulation → Administration → Create Productive Tariffs from CDR Table.

Note: You can only use this report if you have filled the database table SAP_CC.CONTRACTS with the assignment of a contract to a tariff and then executed the report PSI_DATA_LOAD_AND_ENRICH to enrich usage data with tariffs.

5.4 Using Customer Attributes

Customer-specific attributes, such as gender, age, or year of birth can be stored in the table SAP_CC._SUAC_ATTRIBUTES. This table contains the following generic fields:
- Ten fields for numeral values (fields AN_01 – AN_10)
- Ten fields for alphanumeric values (fields AS_01 – AS_10)
- Five fields for dates (fields AD_01 – AD_05)

Make an entry for each subscriber in this table. When you do so, these values can be used for both the consumption detail records (CDR) selection and the result analysis.

Note: If the table SAP_CC._SUAC_ATTRIBUTES does not provide a sufficient number of fields, you can use a customer-specific table that is used in a view according to the database view SAP_CC.CDR_VIEW as a join with the table SAP_CC.CDR. This view must be stored in Customizing under SAP Convergent Pricing Simulation → Custom Default Values for Pricing Simulation.

Use for the CDR Selection

Make an entry for each field to be used in Customizing under SAP Convergent Pricing Simulation → Define Custom Fields.

If an input field is provided, you must make an implementation in Customizing for the Business Add-In (BAdI) PSI_VALUE_HELP_BADI under SAP Convergent Pricing Simulation → Business Add-Ins (BAdIs) → BAdI: Retrieve Value Help for Custom Fields.

Use for Result Analysis

If you want to use customer attributes in result analysis, you must define a segment model in the system and fill in SUAC_ATTRIBUTES-AS_01 the segment model Guid and in SUAC_ATTRIBUTES-AS_02 the segment GUID for each subscriber.

5.5 Performance Optimization

The best performance depends on the best parallelization of SAP HANA database procedures. Since a lot of criteria has an impact, such as hardware, complexity of charge plans, etc., you can use report PSI_PARTITION_SIZE_DETERMINE in the SAP Menu under Convergent Pricing Simulation → Administration → Determine Partition Size to automatically find the best value for parallelization.

The report also measures the memory consumption. Make sure that the HANA statistic server is active in the HANA studio under Configuration → nameserver.ini → statisticserver and set active = true. For more information, see the report documentation.

Another option to improve the performance is to define how many fields are used for the consumption detail records (CDR). The system provides a lot of generic fields (40 string fields, 40 numeric fields and 10 date fields) in database table SAP_CC.CDR. You can define in Customizing how many of these fields are really required. Also for mapping tables and range tables you can define how many input / output fields are really required. These settings are made in SAP Customizing under SAP Convergent Pricing Simulation → Custom Default Values for Pricing Simulation.
5.6 Data Provider

During system setup the delivered data providers are created automatically. But they are only created in the logon language. If you need texts in the data provider also in other delivered languages, you have to logon in the corresponding language and execute ABAP report PSI_CREATE_ANA_DEF for all data providers.