Integration of SAP TM and SAP CRM
SAP Transportation Management
# Content

1. **Integration of SAP TM and SAP CRM** .......................................................... 5
2. **Settings in SAP TM** ............................................................................. 7
   2.1 Defining RFC Connection to SAP CRM System ...................................... 7
   2.2 Defining Logical System for SAP CRM System ...................................... 7
   2.3 Assigning RFC Destination to Logical Systems ...................................... 8
   2.4 Definitions for RFC Connections ....................................................... 8
   2.5 Assigning Logical System to System Name ........................................... 9
   2.6 Selecting Item Types .......................................................................... 9
3. **Assigning Item Types to Service Products** ............................................ 10
4. **Prerequisites for SAP CRM** ................................................................. 11
5. **Settings in SAP CRM** ........................................................................ 12
   5.1 Activating the Business Function .......................................................... 12
   5.2 Defining the RFC Connection to SAP TM .............................................. 12
   5.3 Defining the Logical System for SAP TM .............................................. 13
   5.4 Assigning an RFC Destination to Logical Systems ................................. 13
   5.5 Creating Sites .................................................................................... 14
   5.6 Defining Transaction Launcher Logical Systems and URLs .................... 14
   5.7 Maintaining Categories and Hierarchies ................................................ 14
   5.8 Assigning Hierarchies to Applications .................................................. 15
   5.9 Assigning Product Categories for the Service Product Download ............ 15
6. **Starting the Initial Download to the SAP CRM System** ....................... 16
1 Integration of SAP TM and SAP CRM

You can use service products from the SAP Transportation Management (SAP TM) system in opportunities in SAP Customer Relationship Management (SAP CRM). Subsequently, you can create forwarding agreement quotations from the opportunities. This enables sales agents from carriers or logistics service providers (LSPs) to sell service products to prospective customers such as shippers or other LSPs. The sales agent can process a request from a customer in an opportunity in SAP CRM and then send the price quotation to the customer in the forwarding agreement quotation in SAP TM.

Activities

In the SAP CRM system, you can use the Start CRM WebClient transaction (CRMUI), to perform the following activities:

- Create, edit, and display the following SAP TM documents under Sales Cycle:
  - Forwarding agreements
  - Forwarding agreement quotations
  - Forwarding quotations
  - Service products or service product catalogs
  - Estimate forwarding charges

- Create, edit, and display the following SAP TM documents of a corporate account under Account Management:
  - Forwarding agreements
  - Forwarding agreement quotations
  - Forwarding quotations
  - Forwarding orders
  - Forwarding settlement documents

More Information

- For more information about integration of SAP CRM with SAP TM, see SAP Library on SAP Help Portal at help.sap.com/crm. Choose a release and under Application Help, choose SAP Customer Relationship Management ➤ Sales ➤ Opportunity Management ➤ Integration with SAP Transportation Management.

- For more information about SAP CRM opportunities, see SAP Library on SAP Help Portal at help.sap.com/crm. Choose a release and under Application Help, choose SAP Customer Relationship Management ➤ Sales ➤ Opportunity Management.

- See SAP Library for SAP TM on SAP Help Portal at help.sap.com/tm. In SAP Library, choose the following:
  - SAP Transportation Management (SAP TM)
  - Integration ➤ Integration with SAP Customer Relationship Management
  - Agreement Management ➤ Forwarding Agreement Quotation
○ Master Data ➔ Charge Management and Service Product Catalogs ➔ Setup of MD for Charge Management and SP Catalogs ➔ Service Product Catalogs

○ Agreement Management

○ Forwarding Order Management ➔ Forwarding Order

○ Forwarding Order Management ➔ Forwarding Quotation

Integration of SAP TM and SAP CRM
2 Settings in SAP TM

This section describes the configuration settings you need to make to integrate the SAP TM system with the SAP CRM system.

2.1 Defining RFC Connection to SAP CRM System

The remote function call (RFC) connection to SAP CRM and the definition of the logical system serve as base definitions for connecting all systems to the SAP Transportation Management (SAP TM) system. You can use this procedure to define which of the connected systems is a SAP CRM system.

Procedure

1. Go to the transaction SM59 (RFC Destinations (Display/Maintain))
2. Choose Create, and enter the following data:
   ○ RFC destination (for example, CRMCLNT001)
   ○ Connection type: 3 (Connection to ABAP System)
   ○ Description for your RFC connection
3. On the Technical Settings tab page, enter the following data:
   ○ Target Host
     This is the host name of your SAP CRM system (for example, ldcicrm.wdf.sap.corp).
   ○ System Number
     This is the SAP system number of your SAP CRM system (for example, 29).
4. Save the RFC connection.

i Note
You must have relevant authorization to both SAP TM and SAP CRM systems.

2.2 Defining Logical System for SAP CRM System

Procedure

1. Go to the transaction BD54 (Maintaining Logical Systems).
2. Choose New Entries, and enter the following data:
   ○ Logical System
Enter your logical system (for example, CRMCLNT001).

- **Name**
  - Enter the name of your logical system.
- Save your entries.

### 2.3 Assigning RFC Destination to Logical Systems

**Procedure**

1. Go to the BD97 transaction *(Assign RFC Destination to Logical Systems).*
2. Choose the logical system (for example, CRMCLNT001).
3. Choose **Standard BAPI Destination**.
4. Enter the RFC destination for BAPI calls.
5. Save your entries.

### 2.4 Definitions for RFC Connections

You use this procedure to specify the parameters to indicate the RFC destinations which receive data. The required parameters include, for example, consumer, client, object name, and download type.

**Procedure**

1. Go to transaction SM30 *(Call View Maintenance).*
2. In the **Table/View** field, enter the table name CRMRFCPAR.
3. Choose **Maintain New Entries**, and enter the following data:
   - For initial download:
     - **User**: CRM
     - **Object Name**: TM_SERVICE_PROD
     - **Destination**: RFC destination (for example, CRMCLNT001)
     - **Load Type**: Initial Download
     - **Send XML**: Mixed Mode (Optimized)
   - For delta download:
     - **User**: CRM
     - **Object Name**: TM_SERVICE_PROD
     - **Destination**: RFC destination (for example, CRMCLNT001)
     - **Load Type**: Delta Download
     - **Send XML**: Mixed Mode (Optimized)
   - For document reference:
2.5 Assigning Logical System to System Name

Procedure

1. In Customizing for Transportation Management, choose Integration ➤ Assign Logical System to System Names.
2. Choose New Entries.
3. Assign a name to a CRM logical system:
   - **Name** (for example, CRMTEST)
   - **Logical system** (for example, CRMCLNT001)

   **Note**
   You can connect only one SAP CRM system to the SAP TM system.

4. Save your entries.

2.6 Selecting Item Types

Procedure

1. In Customizing for Transportation Management, choose Master Data ➤ Agreements and Service Products ➤ Define FWA and Service Product Item Types.
2. Choose an Item Type that you want to use in the CRM system.
3. Select the Enable CRM checkbox and enter a name in the System Name field.
4. Save your entries.
3 Assigning Item Types to Service Products

You use this procedure to enter the service products that you want to use in the SAP Customer Relationship Management (SAP CRM) system in a service product catalog.

Procedure

1. In SAP NetWeaver Business Client, under Master Data > Charge Management and Service Product Catalogs > Service Product Catalogs, create or edit an existing catalog.
2. At item level, choose Insert > Service Product.
3. Enter the item type for which you have enabled CRM in Customizing. For more information, see Selecting Item Types [page 9]
4. Save your entries.
4 Prerequisites for SAP CRM

You have imported business partners and sales organizations from the SAP ERP system to both the SAP Customer Relationship Management system and the SAP Transportation Management system.
5 Settings in SAP CRM

This section describes the configuration settings that you need to make in the SAP Customer Relationship Management system to integrate with the SAP Transportation Management system.

5.1 Activating the Business Function

You activate the business function to enable the user to convert opportunities in SAP Customer Relationship Management to forwarding agreement quotations in SAP Transportation Management.

Procedure

2. Under ENTERPRISE_BUSINESS_FUNCTIONS, choose CRM_TM_O2A.
3. Select the Planned State checkbox for the business function you want to activate.
4. The system informs you about any missing software components or support packages.
5. Choose Activate Changes.
6. Save your entries.

5.2 Defining the RFC Connection to SAP TM

The RFC connection to the SAP Transportation Management (SAP TM) system and the definition of the logical system serve as base definitions for connecting all systems to the SAP Customer Relationship Management system (SAP CRM) system.

You use this procedure to define which of the connected systems is an SAP TM system.

Procedure

1. Go to the transaction SM59 (RFC Destinations (Display/Maintain)).
2. Choose Create.
3. Enter the following data:
   ○ RFC destination (for example, TM1CLNT001)
   ○ Connection type: 3
   ○ Description for your RFC connection
4. On the Technical Settings tab page, enter the following data:
Target host
This is the host name of your SAP TM system (for example, ldcitml.wdf.sap.corp).

System number
This is the host SAP system number of your SAP TM system (for example, 29).

5. Save your entries.

Note
You must use the role SAP_S_RFCACL in both the SAP TM and SAP CRM systems. In SAP TM, you must use the role customer settlement specialist /SCMTMS/CUSTOMER_SETTLEMENT_SP.

5.3 Defining the Logical System for SAP TM

You use this procedure to define the logical system in which SAP Transportation Management (SAP TM) is found.

Procedure

2. Choose New Entries and enter the logical system for SAP TM, (for example, TM1CLNT001) and the name of the logical system.
3. Save your entries.

5.4 Assigning an RFC Destination to Logical Systems

You use this procedure to assign an SAP Transportation Management (SAP TM) RFC destination to an SAP TM logical system in SAP Customer Relationship Management (SAP CRM).

Procedure

1. Go to the transaction BD97 (Assign RFC destination to Logical Systems).
2. Choose the logical system (example TM1CLNT001).
3. Choose Standard BAPI destination.
4. Enter the RFC destination for Business Application Programming Interface (BAPI) calls.
5. Save your entries.
5.5 Creating Sites

You use this procedure to create a site required for initially downloading all the service products from SAP Transportation Management (SAP TM).

Procedure

1. In Customizing for SAP Customer Relationship Management, choose » CRM Middleware and Related Components » Communication Setup » Create Sites and Subscriptions ».
2. Choose the object type Sites and create a site, for example:
   - Name: TM_TM1_001
   - Description: As appropriate
   - Type: R/3
3. Choose the Site Attributes pushbutton and select an existing RFC destination (for example, TM1CLNT001)
4. Save your entries.

5.6 Defining Transaction Launcher Logical Systems and URLs

You use this procedure to enable the system to display SAP Transportation Management (SAP TM) user interfaces and access SAP TM data.

Procedure

1. Go to transaction SM30 (Call View Maintenance).
2. In the Table/View field, enter the table name CRMV_IC_BORADM.
3. Assign the logical system name (for example, TM1CLNT001) to the Mapping field with the entry as TM.
4. Save your entries.

5.7 Maintaining Categories and Hierarchies

Procedure

1. Go to transaction Maintain Categories and Hierarchies (transaction COMM_HIERARCHY).
2. Choose New Hierarchy or edit an existing hierarchy.
3. Enter a hierarchy ID (for example, TM01).
4. Choose New Category or edit an existing category.
5. Enter **Root Category** as the category ID and add description in the short text field.

6. Enter **Service** as the product type.

7. Choose **ROOT**

8. Choose **New Category**

9. Enter **SRV_** as category ID and add a description in the short text field.

10. Enter **Service** as product type.

11. Save your entries.

### 5.8 Assigning Hierarchies to Applications

**Procedure**

1. Go to transaction **Assign Hierarchies to Applications** (COMM_PRAPPLCAT).

2. Choose **New Entries**.

3. In the **Application** field, enter **Product** and the hierarchy ID you specified earlier (for example, **TM01**).

4. Go to the **Assgmt per Product Type for Application 'Product'** screen.

5. In the **Product Type** field, enter **Service** and the hierarchy ID you have specified earlier (for example, **TM01**).

6. Save your entries.

### 5.9 Assigning Product Categories for the Service Product Download

**Procedure**

1. In Customizing for SAP Customer Relationship Management, choose **Transactions** > **Settings for Opportunities** > **Integration with SAP Transportation Management** > **Assign Product Category for Service Product Download**.

2. Choose **New Entries**.

3. Enter the hierarchy ID you have specified earlier (for example, **TM01**).

4. Enter the category ID you have specified earlier (for example, **SRV_**).

5. Save your entries.
You can use this procedure to download all the service products that you selected for download in the SAP Transportation Management (SAP TM) system.

**Procedure**

1. Go to transaction COMCPRLOGSYS and specify an entry.
2. Go to transaction Start Initial Load (transaction R3AS).
3. Specify the following data:
   - **TM_SERVICE_PROD** in the Load Object field.
   - Enter Source Site (Sender) as specified in the chapter Creating Sites [page 14] (for example, TM_TM1_001).
4. Enter CRM as the destination site.
5. Choose Execute.

The system downloads all the service products to SAP Customer Relationship Management (SAP CRM) master data.

**Note**

The system automatically performs a delta download (downloads the service products after the initial download), when you enter a service product in a service product catalog. For more information, see Entering a Service Product in a Service Product Catalog [page 10].

If you delete a service product in the SAP TM system, the SAP CRM system automatically gives the service product the status of To Archive. The service product cannot be used in an opportunity.

After downloading the service products, you can use the products in opportunities and subsequently create forwarding agreement quotations.
## Typographic Conventions

Table 2

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Example&gt;</td>
<td>Angle brackets indicate that you replace these words or characters with appropriate entries to make entries in the system, for example, “Enter your &lt;User Name&gt;”</td>
</tr>
<tr>
<td>Example Example</td>
<td>Arrows separating the parts of a navigation path, for example, menu options</td>
</tr>
<tr>
<td>Example</td>
<td>Emphasized words or expressions</td>
</tr>
<tr>
<td>Example</td>
<td>Words or characters that you enter in the system exactly as they appear in the documentation</td>
</tr>
<tr>
<td><a href="http://www.sap.com">www.sap.com</a></td>
<td>Textual cross-references to an internet address</td>
</tr>
<tr>
<td>/example</td>
<td>Quicklinks added to the internet address of a homepage to enable quick access to specific content on the Web</td>
</tr>
<tr>
<td>123456</td>
<td>Hyperlink to an SAP Note, for example, SAP Note 123456</td>
</tr>
<tr>
<td>Example</td>
<td>• Words or characters quoted from the screen. These include field labels, screen titles, pushbutton labels, menu names, and menu options. • Cross-references to other documentation or published works</td>
</tr>
<tr>
<td>Example</td>
<td>• Output on the screen following a user action, for example, messages • Source code or syntax quoted directly from a program • File and directory names and their paths, names of variables and parameters, and names of installation, upgrade, and database tools</td>
</tr>
<tr>
<td>EXAMPLE</td>
<td>Technical names of system objects. These include report names, program names, transaction codes, database table names, and key concepts of a programming language when they are surrounded by body text, for example, SELECT and INCLUDE</td>
</tr>
<tr>
<td>EXAMPLE</td>
<td>Keys on the keyboard</td>
</tr>
</tbody>
</table>
SAP and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered trademarks of SAP SE (or an SAP affiliate company) in Germany and other countries. Please see www.sap.com/corporate-en/legal/copyright/index.epx#trademark for additional trademark information and notices.

Some software products marketed by SAP SE and its distributors contain proprietary software components of other software vendors. National product specifications may vary.

These materials are provided by SAP SE or an SAP affiliate company for informational purposes only, without representation or warranty of any kind, and SAP SE or its affiliated companies shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP SE or SAP affiliate company products and services are those that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional warranty.

In particular, SAP SE or its affiliated companies have no obligation to pursue any course of business outlined in this document or any related presentation, or to develop or release any functionality mentioned therein. This document, or any related presentation, and SAP SE’s or its affiliated companies’ strategy and possible future developments, products, and/or platform directions and functionality are all subject to change and may be changed by SAP SE or its affiliated companies at any time for any reason without notice. The information in this document is not a commitment, promise, or legal obligation to deliver any material, code, or functionality. All forward-looking statements are subject to various risks and uncertainties that could cause actual results to differ materially from expectations. Readers are cautioned not to place undue reliance on these forward-looking statements, which speak only as of their dates, and they should not be relied upon in making purchasing decisions.