How to Work with User-Defined Objects

Release Family 8.8

Applicable Release:
SAP Business One 8.82

All Countries
English
February 2012
# Table of Contents

**Introduction**..................................................................................................................................... 3

**Example: Creating a Sales Plan via UDO**.......................................................................................... 4
  - Step 1: Creating User-Defined Tables and User-Defined Fields .................................................. 5
  - Step 2: Creating User-Defined Objects (UDOs)......................................................................... 11
  - Step 3: Creating User-Defined Values ...................................................................................... 17
  - Step 4: Adding Choose from Lists and Link Buttons ................................................................. 20

**Other Reference Material: Queries** .................................................................................................. 28

**Copyrights, Trademarks, and Disclaimers** .................................................................................... 30
Introduction

In SAP Business One, you can use User-defined objects (UDOs) to create forms without writing code and implement your own business logic. This document describes how to use UDOs to create your own sales plan.

For more information about user-defined fields (UDFs), user-defined tables (UDTs), and user-defined values, see the following help documentation, which you can download from the documentation area of SAP Business One Customer Portal at http://service.sap.com/smb/sbocustomer/documentation:

- SAP Business One online help
- SDK Help Center
- How to Create User-Defined Fields and Tables
- How to Define and Use User-Defined Values
Example: Creating a Sales Plan via UDO

A sales plan comprises the sales targets that a company developed based on its historical sales records, its business development, and the reality of the market. Companies use sales plans to recommend appropriate sales, production, procurement, and other business activities within a certain period of time. A sales plan can be divided into three dimensions: customer, item/item group, and sales employee, making it easier for the system administrator or sales employee to get the overview of the sales completion progress at any time. It can also provide a basis for developing the sales plans for the next time period.

 Procedures
The UDO features in SAP Business One enable you to implement the business logic of the sales plan. You can perform the following process to create your sales plan:

1. Create user-defined tables and user-defined fields
2. Create UDOs using the user-defined object registration wizard
3. Create user-defined values
4. In the Screen Painter add-on, edit the UDO layout, and add choose from lists and link buttons
Step 1: Creating User-Defined Tables and User-Defined Fields

According to the business requirements of the sales plan, you need to create the following tables:

- SPLAN – main table for the sales plan (a master data type table)
- SPLAN_C – child table for the customer dimension (a master data lines child table)
- SPLAN_I – child table for the item group dimension (a master data lines child table)
- SPLAN_E – child table for the sales employee dimension (a master data lines child table)

The user-defined tables contain the following user-defined fields:

### Table SPLAN

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>From</td>
<td>Start date of the sales plan</td>
<td>Date</td>
</tr>
<tr>
<td>To</td>
<td>Finish date of the sales plan</td>
<td>Date</td>
</tr>
<tr>
<td>Target</td>
<td>Sales targets</td>
<td>Amount</td>
</tr>
<tr>
<td>Done</td>
<td>Completed sales amount</td>
<td>Amount</td>
</tr>
<tr>
<td>Owner</td>
<td>ID of the responsible person</td>
<td>Alphanumeric</td>
</tr>
<tr>
<td>Ownername</td>
<td>Name of the responsible person</td>
<td>Alphanumeric</td>
</tr>
</tbody>
</table>

### Table SPLAN_C

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>CardCode</td>
<td>Code of the business partner</td>
<td>Alphanumeric</td>
</tr>
<tr>
<td>CardName</td>
<td>Name of the business partner</td>
<td>Alphanumeric</td>
</tr>
<tr>
<td>Pro_C</td>
<td>Completion percentage</td>
<td>Percents</td>
</tr>
<tr>
<td>Linetotal_C</td>
<td>Sales targets for the customer</td>
<td>Amount</td>
</tr>
<tr>
<td>Done_C</td>
<td>Completed sales amount</td>
<td>Amount</td>
</tr>
</tbody>
</table>

### Table SPLAN_I

<table>
<thead>
<tr>
<th>Field</th>
<th>Description (optional)</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>GroupCode</td>
<td>Code of the item group</td>
<td>Alphanumeric</td>
</tr>
<tr>
<td>GroupName</td>
<td>Name of the item group</td>
<td>Alphanumeric</td>
</tr>
<tr>
<td>Pro_I</td>
<td>Completion percentage</td>
<td>Percents</td>
</tr>
<tr>
<td>Linetotal_I</td>
<td>Sales targets for the item group</td>
<td>Amount</td>
</tr>
<tr>
<td>Done_I</td>
<td>Completed sales amount</td>
<td>Amount</td>
</tr>
</tbody>
</table>

### Table SPLAN_E

<table>
<thead>
<tr>
<th>Field</th>
<th>Description (optional)</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>SlpCode</td>
<td>Code of the sales employee</td>
<td>Alphanumeric</td>
</tr>
<tr>
<td>SlpName</td>
<td>Name of the sales employee</td>
<td>Alphanumeric</td>
</tr>
<tr>
<td>Pro_E</td>
<td>Completion percentage</td>
<td>Percents</td>
</tr>
</tbody>
</table>
How to Work with User-Defined Objects

<table>
<thead>
<tr>
<th>Field</th>
<th>Description (optional)</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linetotal_E</td>
<td>Sales targets of the sales employee</td>
<td>Amount</td>
</tr>
<tr>
<td>Done_E</td>
<td>Completed sales amount</td>
<td>Amount</td>
</tr>
</tbody>
</table>

**Procedure**

To create the user-defined tables and add the user-defined fields, perform the following steps:

1. In the menu bar, choose **Tools → Customization Tools → User-Defined Tables - Setup**.
2. Enter information about the new table in a new row.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Name</td>
<td>The table name.</td>
</tr>
<tr>
<td>Description</td>
<td>A description for the table.</td>
</tr>
<tr>
<td>Object Type</td>
<td>The type of table.</td>
</tr>
</tbody>
</table>

3. Choose the **OK** button.

   The user-defined table appears under the **User Tables** category in the **User-Defined Fields – Management** window.

   To access the window, in the menu bar, choose **Tools → Customization Tools → User-Defined Fields – Management**.
4. In the User-Defined Fields - Management window, select the user table to which you want to add a field, and choose the Add button. The Field Data window appears.

5. Specify the name and type of field by entering the following fields in the Field Data form:
   - **Title**: The field name. The Title value cannot contain spaces or special characters. A field is added to the database with the prefix U followed by the field name specified here. The full name, with the prefix, is displayed in the query generator when you view a table’s list of fields.
   - **Description**: The field display name.
How to Work with User-Defined Objects

- **Length**: The size of the field.
  
  If the field type is *Alphanumeric*, the length is the maximum number of characters. If the field is *Numeric*, the length is one more than the maximum number of digits. For example, to allow you to enter up to 10 digits, specify 11.

- **Type and Structure**: Describes the type of data to be contained in the field.
  
  The type and structure determines the type of data that can be entered into each field and how it is displayed. The following table describes the *Type* field options and the *Structure* field options for each type:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description / Structure Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alphanumeric</strong></td>
<td>A series of characters.</td>
</tr>
<tr>
<td></td>
<td>The following are the structure options for this type:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Regular</strong>: Lets you enter up to 254 characters.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Address</strong>: For future use.</td>
</tr>
<tr>
<td></td>
<td>Telephone No.: If automatic dialing is set up, lets you dial the number by clicking it.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Text</strong>: Lets you enter:</td>
</tr>
<tr>
<td></td>
<td>o 2 GB of text in header fields</td>
</tr>
<tr>
<td></td>
<td>o 255 KB of text in row fields</td>
</tr>
<tr>
<td><strong>Numeric</strong></td>
<td>Integers up to 10 digits long.</td>
</tr>
<tr>
<td></td>
<td>There are no structure options for this type.</td>
</tr>
<tr>
<td><strong>Date/Time</strong></td>
<td>Date or time.</td>
</tr>
<tr>
<td></td>
<td>The following are the structure options for this type:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Date</strong>: Lets you enter a date.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Time</strong>: Lets you enter a time.</td>
</tr>
<tr>
<td></td>
<td>The display format for dates and time is determined by system initialization settings, located in Administration ➔ System Initialization ➔ General Settings ➔ Display tab.</td>
</tr>
</tbody>
</table>

![Display settings](image-url)
How to Work with User-Defined Objects

### Units and Totals

Integer and decimal numbers. The following are the structure options for this type:
- **Rate**
- **Amount**
- **Price**
- **Quantity**
- **Percents**
- **Measure**

The structures are identical except for the display format. The formats are determined by system initialization settings on the **Display** tab in **Administration → System Initialization → General Settings**.

```plaintext
<table>
<thead>
<tr>
<th>Display Options</th>
<th>Description / Structure Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amounts</td>
<td>2</td>
</tr>
<tr>
<td>Rates</td>
<td>4</td>
</tr>
<tr>
<td>Quantities</td>
<td>5</td>
</tr>
<tr>
<td>Percents</td>
<td>3</td>
</tr>
<tr>
<td>Unit</td>
<td>3</td>
</tr>
</tbody>
</table>
```

### General

Links and images. The following are the structure options for this type:
- **Link**: Lets you enter a link to a file or to a Web address
- **Image**: Lets you enter a link to a picture

When you add a link to a file/picture, the file/picture is copied to folders specified in the initialization settings. You must specify these folders on the **Path** tab in **Administration → System Initialization → General Settings**.

Specify a folder for files (attachments) and another for pictures.

```plaintext
<table>
<thead>
<tr>
<th>Path Options</th>
<th>Description / Structure Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachments Folder</td>
<td>1</td>
</tr>
</tbody>
</table>
```

© SAP AG 2012
6. Choose the Add button.

Note

The following message is displayed:

The database structure has been modified. In order to resume the process, all open windows will be closed. Do you want to continue adding the user-defined field?

To add the field, click the Yes button.

Result

The following occurs when you add a user-defined table:

- Information about the new table is stored in the OUTB table (User Tables).
- The prefix @ is added to the name of the table in the database table, indicating that it is a user-defined table.
- You can use this table in queries.
- If this table is linked to a user-defined field, then in the Query Generator, the user-defined field appears in bold in this table, indicating it is related to another table. You can drag this user-defined field to use the user-defined table for the query.

The following occurs when you add a user-defined field:

- Information about the new field (such as its name, its size, and the table to which it was added) is stored in the CUFD table (user field definition table).
- The field is added to the relevant table. The prefix U_ is added to the name of the field in the database table, indicating that it is a user-defined field.
- If you enter valid values, they are added to the UFD1 table.
Step 2: Creating User-Defined Objects (UDOs)

Define or register your new object and add it to the SAP Business One objects collection.

Procedures

To register your UDO, perform the following steps:

1. In the menu bar, choose Tools → Customization Tools → Objects Registration Wizard. Choose Next to continue to a series of windows (choose Finish at any step if no additional settings are required).
2. In the Selecting the Registration Mode window, select Add a New Object.
3. In the Defining Basic Settings window, enter the unique ID and the UDO name, select a type for the UDO, and specify the database table for the UDO.

![User-Defined Object Registration](image)

4. In the Setting Services window, select the services to be available for your object.

SAP Business One provides the following built-in services that you can add to your object:

<table>
<thead>
<tr>
<th>Service</th>
<th>User Action and Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Enables you to add a new record to the object's user tables.</td>
</tr>
<tr>
<td>Update</td>
<td>Enables you to update an existing record in the object's user tables.</td>
</tr>
<tr>
<td>Find</td>
<td>Enables the Choose From List dialog box in the application (Find mode).</td>
</tr>
<tr>
<td>Delete</td>
<td>Enables you to delete data from user tables of master data type.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Enables you to cancel a record.</td>
</tr>
<tr>
<td>Close</td>
<td>Enables you to close a record without creating a posting. Available in document type only.</td>
</tr>
<tr>
<td>Log</td>
<td>Creates a history log table in the database.</td>
</tr>
</tbody>
</table>
How to Work with User-Defined Objects

<table>
<thead>
<tr>
<th>Service</th>
<th>User Action and Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Series</td>
<td>Enables document numbering.</td>
</tr>
<tr>
<td></td>
<td>Available in document type only.</td>
</tr>
<tr>
<td>Year Transfer</td>
<td>Enables year transfer, which copies user tables to a new</td>
</tr>
<tr>
<td></td>
<td>database.</td>
</tr>
<tr>
<td>Data Archive</td>
<td>Enables archiving of UDO records.</td>
</tr>
<tr>
<td></td>
<td>Requires implementation DLL.</td>
</tr>
<tr>
<td></td>
<td>Available in document type only.</td>
</tr>
</tbody>
</table>

**Note**

Make sure you have selected the *Find* mode to display the fields in the *Choose From List* style.

In the *UI Settings* window, specify the fields to create a default form for the UDO.

You can choose the UDO form styles:

- **Header Line Style** - creates a form with a header area and a lines area (new style).
  - The *Header Line Style* enables you to present the main table fields in the top area of the form, and the child tables below (for multiple child tables, each child table is located on a separate tab).
- **Matrix Style** - creates a form with a matrix only (old style).
  - The *Matrix Style* can include only one child table.

To modify the location of the form that appears in the SAP Business One Main Menu, proceed as follows:

a. Select the *Menu Item* checkbox.

b. Specify the caption of the menu.

c. Click the browse button of the *Parent Menu ID* field, and specify the menu ID of the UDO menu's father menu.

d. Specify the position of the UDO menu under its father menu.
e. Specify the UID of the UDO menu.

To view the form, from the menu bar of the SAP Business One application, select Tools → Default Forms, and then select the name of your form.

If you specified the Menu Item as above, you can access the window from the SAP Business One Main Menu:

6. In the Setting the Fields for Find window, select the fields to display by default in the choose from list style and set the order of the fields.
   This window appears only if the Find service is selected
   To filter the list to view only your selected fields, select the View Checked Columns Only checkbox.
   To rearrange the fields, select a field and then choose the up/down arrows.
7. In the Setting Fields for Default Form window, select the fields to display in the default form. This window appears only if the Default Form service is selected. To filter the list to view only your selected fields, select the View checked fields only checkbox. To rearrange the fields, select a field and then choose the up/down arrows.

Note
The following fields are mandatory when choosing the fields to display in the default form:
- For document type objects, you must select the DocEntry field of the child table.
- For master data type objects, you must select the key of the main table.

8. In the Linking Child User Tables window, select the child (user) tables related to the main table, and define their order.

![User-Defined Object Registration](image)

9. In the Setting Fields for a Child Table Default Form window, set the fields of a child (user) table for the default child form.

This window appears only if the Default Form service is selected, and a child table was selected.

![User-Defined Object Registration](image)

10. Finish the steps in the user-defined objects registration wizard.
Result
You can access the new UDO from the main menu.
The style of the UDO window is very similar to the system window.
Step 3: Creating User-Defined Values

To facilitate filling out documents and entering data into windows, you can set up user-defined values, that is, your own valid values for different fields. The user-defined values are also known as format search in SAP Business One.

For a specific field, you can use user-defined values to do the following:

- Display a list of values from which the user can choose.
  The list of values can be static, or it can be derived from a query that is run each time the user edits the field.
- Automatically fill in a field whenever another field (the trigger field) is changed. For example, you can automatically fill in the correct Zip code based on the address that was entered.

**Note**

You cannot add user-defined values to a field that is not editable.

Example: Creating user-defined values for the *Done* field

The *Done* field represents the completed sales amount. If the application takes deliveries as the criteria of sold successfully, and takes the delivery amount as the completed sales amount, then the user-defined value for the *Done* field is the total completed sales amount during the whole period of the sales plan.

**Procedure**

To create user-defined values, perform the following steps:

1. In the SAP Business One menu bar, choose *Tools → Queries → Query Generator*.
2. Write the following queries in SQL for the *Done* field, and save the queries in SAP Business One:
   
   ```sql
   SELECT sum(T0.[DocTotalSy]-T0.[VatSumSy]) FROM ODLN T0 where 
   T0.DOCDATE >= $[@SPLAN.U_From.Date] 
   AND T0.DOCDATE <= $[@SPLAN.U_To.Date]
   ```
3. Place the cursor in the *Done* field of the *Sales Plan* window, and press Alt+Shift+F2. Alternatively, you can place the cursor in the *Done* field, and in the menu bar, choose *Tools → Customization Tools → User-Defined Values - Setup*. The *User-Defined Values - Setup* window appears.
4. Select *Search in Existing User-Defined Values according to Saved Query*.
5. Choose the Open Saved Query button. The Query Manager window opens.

![Query Manager Window]

6. Select the query from which to derive the list of values for this field, and choose the OK button. The query name is entered in the field in the User-Defined Values – Setup window.

**Note**

To select a different query, choose the Open Saved Query button again.

7. Set whether users will select a value from the list generated by a query, or whether the value returned by the query will be entered into the field automatically when another field’s value changes.

Selecting the Auto Refresh When Field Changes checkbox causes the value of the field to be set automatically with the value returned by the query. The user does not need to place the cursor in the field, press Shift+F2 and select a value.

![User-Defined Values - Setup Window]

For more information about the queries, see Other Reference Material: Queries.
For more information about the user-defined values, see the online help, as well as the document *How to Define and Use User-Defined Values*, which you can download from the documentation area of SAP Business One Customer Portal at http://service.sap.com/smb/sbocustomer/documentation.
Step 4: Adding Choose from Lists and Link Buttons

To add choose from lists and link buttons for UDOs, you can use the Screen Painter add-on.

**Prerequisite**

You have installed and registered the Screen Painter add-on.

To install the Screen Painter add-on, see the *Add-On Installation* section of *SAP Business One Administrator’s Guide*, which you can download from the documentation area of SAP Business One Customer Portal at [http://service.sap.com/smb/sbocustomer/documentation](http://service.sap.com/smb/sbocustomer/documentation)

**Procedures**

To add choose from lists and link buttons, perform the following steps:

1. From the menu bar, choose *Tools* → *Screen Painter*.

2. In Screen Painter, choose the (Open User-Defined Object List) icon. The *List of UDO* window appears.

3. Select the *Sales Plan* UDO and choose the *Edit Form* button. The *Sales Plan* window appears in design mode.

4. Adjust the location and the size of UDO fields according to your requirements, and add choose from lists or link buttons.

   In the *Sales Plan* window, you can add choose from lists and link buttons for the following fields and columns:
   - The *Owner* field in the general area
   - The *CardCode* column in pane 1
   - The *EmployeeID* column in pane 2
   - The *GroupCode* column in pane 3

   The following examples describe how to add choose from lists and link buttons in the general area and pane area.
Example 1: Adding a Choose from List and Link Button for the *Owner* Field in the General Area

For the *Owner* field, to add a choose from list to open the *List of Employees* window and a link button to open the *Employee Master Data* window, proceed as follows:

a. In the *Sales Plan* window, select the *Owner* text field.

   ![Image of Sales Plan window with selected Owner field]

   **Note**

   To combine the *Owner* text field and the *OwnerName* field, change the size of the two text fields, move the *OwnerName* text field, and hide the *OwnerName* label field.

b. To add a *Choose From Lists* collection for the *Owner* text field, choose the *New* button on the *Collection* tab of the *Properties* window. In the *Object Type* field, enter 171, which represents employee information. For more information about object types, see *BoObjectTypes Enumeration* in SDK Help Center.

   ![Image of Properties window with Choose From Lists collection]

c. To connect the choose from list with the *Owner* text field, copy the unique ID on the *Collection* tab, select the *Items* tab, and paste the unique ID in the *ChooseFromListUID* field.

   Specify the *ChooseFromListAlias* field and the *ChooseFromListAutoFill* field according to your requirements.
d. To add a link button for the Owner text field, in the toolbar, click (Link Button) and drag the link button to the Owner text field. In the LinkedObject field of the Items tab, enter 171.

e. To connect the link button with the Owner text field, select the Owner text field and copy the unique ID on the Items tab. Select the link button and paste the unique ID in the LinkTo field on the Items tab.

f. To save your changes, click (Save Form to Database).
**Example2: Adding a Choose from List and Link Button in a Column of the Pane Area**

To specify the `CardCode` column in the matrix as link button type to open the *List of Business Partners* window and the *Business Partner Master Data* window, proceed as follows:

a. In the *Sales Plan* window, select the `PLAN_C` pane.

b. On the *Items* tab of the *Properties* window, make sure that the `AutoPaneSelection` field is set to `True`.

c. In the menu bar, choose *Form Design* → *Pane Level* → 1.

d. In the `PLAN_C` pane, select the `CardCode` column of the matrix.

e. To add a Choose From Lists collection for the column, choose the *New* button on the *Collection* tab of the *Properties* window. In the *Object Type* field, enter 2, which represents business partners. For more information about object types, see *BoObjectTypes Enumeration* in SDK Help Center.

f. To connect the choose from list with the `CardCode` column, copy the unique ID on the *Collection* tab, select the *Columns* tab, and paste the unique ID in the `ChooseFromListUID` field. Specify the `ChooseFromListAlias` field and the `ChooseFromListAutoFill` field according to your requirements.
g. To add a link button for the CardCode column, in the Columns tab, specify the Type field as `it_LINK_BUTTON` and in the LinkedObject field enter 2.

![Image of properties with CardCode column settings]

h. To save your changes, click  

(Save Form to Database).

Result

In the main menu, you can access the updated UDO window and use the choose from lists and link buttons that are added in Screen Painter.

To use the sales plan, proceed as follows:

1. Add a new sales plan.

![Image of Sales Plan window with data entered]
2. Add new delivery documents, and specify the Customer, Item and Sales Employee fields.

3. In the Sales Plan window, you can view the completion status.
Tips

You can add a user-defined field in the Delivery window and link it to the Sales Plan UDO. The UDF has the choose from list and link button functions to open the Sales Plan UDO and review your data. Proceed as follows:

i. In the menu bar, choose Tools → Customization Tools → User-Defined Fields – Management.

ii. In the User-Defined Fields - Management window, select the Marketing Documents category, and choose the Add button.

The Field Data window appears.

iii. In the Field Data window, specify the name and the type of the field, select the Link to UDO checkbox and link the Sales Plan UDO.

iv. Choose the Add button.

The user-defined field Sales Plan is added.

v. To view the UDF, open the Delivery window and in the menu bar, choose View → User-Defined Fields.
You can use the choose from list and link button for the Sales Plan UDO.
Other Reference Material: Queries

The queries related to the fields in the Sales Plan window are listed for your reference:

- **Done**
  
  ```sql
  SELECT sum(T0.[DocTotalSy]-T0.[VatSumSy]) FROM ODLN T0 where 
  T0.DOCDATE >= [@SPLAN.U_From.Date] 
  AND T0.DOCDATE <= [@SPLAN.U_To.Date]
  ```

- **OwnerName**
  
  ```sql
  SELECT FirstName FROM OHEM T0 where 
  T0.EMPID = [@SPLAN.U_owner.NUMBER]
  ```

- **CardName**
  
  ```sql
  SELECT CardName FROM OCRD where CardCode=$[@SPLAN.C.U_CardCode]
  ```

- **Pro_C**
  
  ```sql
  SELECT $[@SPLAN_C.U_linetotal_C.number]*100/$[@SPLAN.U_target.number]
  ```

- **Linetotal_C**
  
  ```sql
  SELECT $[@SPLAN.U_Target.number]*$[@SPLAN_C.U_C_Pro.number]/100
  ```

- **Done_C**
  
  ```sql
  SELECT sum(T0.[DocTotalSy]-T0.[VatSumSy]) FROM ODLN T0 where 
  t0.cardcode=$[@SPLAN_C.U_CardCode] 
  AND T0.DOCDATE >= [@SPLAN.U_From.Date] 
  AND T0.DOCDATE <= [@SPLAN.U_To.Date]
  ```

- **Groupname**
  
  ```sql
  SELECT ITMSGRPNAM from OITB WHERE ITMSGRPCOD=$[@SPLAN_I.U_GROUPCode]
  ```

- **Pro_I**
  
  ```sql
  SELECT $[@SPLAN_I.U_linetotal_I.number]*100/$[@SPLAN.U_target.number]
  ```

- **Linetotal_I**
  
  ```sql
  SELECT $[@SPLAN.U_Target.number]*$[@SPLAN_I.U_pro_I.number]/100
  ```

- **Done_I**
  
  ```sql
  SELECT sum(T0.[LINETOTAL]) FROM DLN1 T0 
  INNER JOIN OITM T1 
  ON T1.ITEMCODE=T0.ITEMCODE 
  INNER JOIN OITB T2 
  ON T1.ITMSGRPCOD=T2.ITMSGRPCOD 
  where 
  t2.ITMSGRPCOD=$[@SPLAN_I.U_GROUPCODE.NUMBER] 
  AND T0.DOCDATE >= [@SPLAN.U_From.Date] 
  AND T0.DOCDATE <= [@SPLAN.U_To.Date] 
  group by T1.ITMSGRPCOD
  ```

- **Name**
  
  ```sql
  SELECT slpname from oslp where slpcode=$[@SPLAN_E.U_empID]
  ```

- **Pro_E**
  
  ```sql
  SELECT $[@SPLAN_E.U_linetotal_E.number]*100/$[@SPLAN.U_target.number]
  ```

- **Linetotal_E**
SELECT [@SPLAN.U_Target.number]*[@SPLAN_E.U_pro_E.number]/100

- **Done_E**

SELECT sum(T0.[DocTotalSy]-T0.[VatSumSy]) FROM ODLN T0 where
  t0.SLPCODE=$[@SPLAN_E.U_EMPID.NUMBER]
  AND T0.DOCDATE >= $[@SPLAN.U_From.Date]
  AND T0.DOCDATE <= $[@SPLAN.U_To.Date]
  group by T0.SLPCODE