Welcome to the topic on approval procedures in SAP Business One.
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After completing this topic, you will be able describe the business process flow
when an approval procedure is used, and set up a new approval process in SAP
Business One.
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In the business scenario shown here, there is a requirement to approve expenses
over a certain limit. These expenses should be approved by the accounting
department.
You can use an approval procedure whenever the work procedure requires an
approval before a user can generate certain documents, for example, purchase
orders.
If the value of the expense document exceeds the limit, the approval procedure
will block the document until it is approved.
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Let us look at the workflow for an approval procedure:
• The person who creates the document is the originator.
• When the originator adds a document to the system, the system checks if there
are any approval conditions.
• If the document meets the condition for an approval, the originator is notified
that the document requires approval.
• The system saves the document as a draft, allowing the user to continue
working on other documents.
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The approval process is launched:
• Immediately an internal request is sent to the first approval stage. This request
appears in the Messages/Alerts Overview window and the approver can view
the document. If the mobile application is integrated, approvals can be done
from a mobile phone.
• If the approver rejects the document, an internal message goes back to the
originator with a link to the rejected document.
• The originator can generate an amended document, and if the approval
condition is no longer met, the document can be added to the system. If the
approval condition is still met, another approval procedure will start.
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If the document is approved at the first approval stage, the approval process
continues:
• An approval request is sent to the next approval stage (if applicable).
• If the document is approved at the final approval stage, an internal message
goes back to the originator with a link to the draft document. The originator can
now add the document.
This is an example of a fairly straightforward approval procedure. In real life,
approval procedures can be more complex, requiring multiple conditions to be
checked, and more layers of approval.
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To set up an approval procedure, you need to:
1. Activate the approval process in the system. To do this, choose Administration
> System Initialization >General Settings. Choose the BP tab and select the
Activate Approval Procedures checkbox.
2. Define one or more approval stages.
3. Create an approval template.
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An approval stage is a list of users who can approve the document at the same
approval level.
All approvers must first be defined as users in SAP Business One.
In our scenario, we have two purchasing users who can approve a purchasing
document before it goes for final approval to the purchasing manager, but we only
need an approval from one of them.
Therefore two authorizing users have been defined for the first stage, but only one
approval is required to allow the process to move on to the next stage. Either user
can approve it. This allows the approval process to move on in case of holidays
and staff absences.
At the second (and final stage) we have defined one approver – the purchasing
manager who is the final approver. Note that this can be a bottleneck if the
purchasing manger is absent, therefore ideally you would include another user at
this stage.

8

An approval template models the business requirements to implement an approval
process. The approval template combines four elements that define the process:
originators of the documents, the names of the approvers at each stage, the
documents subject to approval, and the document conditions that require and
approval. Therefore you must define the approval stages first before you can
include them in the approval template.
You can define an approval template that relates to a specific document type, or
you can define a template that can apply to multiple document types with similar
conditions for approval.
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On the Originators tab, select the users who create the documents that need
approval. All originators must be first defined as users in SAP Business One.
Only users specified here are subject to an approval process.
The system prevents a user from modifying a template if they are selected as an
originator in the template.
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In the Documents tab, you select the document types for approval. The approval
process will apply to every document type that is selected here.
Both sales and purchasing document types can be selected in one template;
however, when you add stages to the template the named approvers will be
identical for all the documents. Therefore if you need different approvers for sales
and purchasing documents, use separate approval templates so you can include
different approvers in each template.
The system will not allow you to select sales and purchasing document types with
inventory or payment document types in the same template. You will need to
create additional templates for these document types.
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In the Stages tab, you include one or more of the predefined stages in the
template.
The sequence that the stages are listed in the template becomes the order for a
multi-level approval process.
You can rearrange the sequence using the up and down arrows.
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In the Terms tab, you set the conditions for the approval. You have three options:
• You can choose to apply no terms or conditions to the selected document
types. The selected document types will always be subject to approval.
• You can choose a predefined term. The predefined terms available in the
template depend on the document types selected, but they cover common
situations, such as a quantity or a total that exceeds a stated amount. In this
example, we have specified the condition that the document total must be over
5000.
• You can choose to add your own conditions using a user query. This allows you
to model more complex approval processes.
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When using a predefined term, you can select an operator such as “greater than”
or “equal”, and enter a value for comparison.
You can also select “In range” or “Not in range” as the ratio, and enter two values
for the range, from low to high, separated by a hyphen.
Note that an approval procedure will apply if just one of the predefined terms is
met. In the example shown here, that means if the total amount of the document is
greater than 5000, or the quantity is between 5 and 200.
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In this demo, you will see how to create an approval procedure based on
predefined terms.
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You can use queries as the terms for an approval procedure. This allows you to
develop customized approval scenarios.
You can use a query instead of the predefined terms, or you can combine
predefined terms with a query.
Be aware that the approval process will start if just one of the conditions is met. In
other words, the conditions are evaluated using OR logic.
If you need multiple conditions to be met, use a query instead of predefined terms
and write the query conditions linked with the AND operator.
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When you use a query in an approval procedure, the query must use the SELECT
DISTINCT ‘TRUE’ clause, so that the result is a TRUE statement if the conditions
of the query are met. A TRUE statement will trigger an approval procedure; a
FALSE statement will not.
An example is shown above, where two conditions must be met for an approval the customer account balance is over 10,000 and the order total is higher than
2500. The query will select from the sales order table ORDR and the business
partner master data OCRD.
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When you write a query for an approval procedure, you will need to reference the
current document in the active window. The active window is the one the originator
is working in. This is in contrast to standard queries where you select information
from the database.
To refer to a field in the active window, you must include a $ sign in front of the
field.
In the query shown here, a $ sign is used with the CardCode and DocTotal fields
in the active sales document.
The $ sign is not needed for fields that are stored in the database, such as the
balance field from the master data record.
Note that you can only use this query for sales orders, since the table and field
name used here are unique to the sales order table ORDR.
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If you use a query in an approval template with multiple document types selected,
you must write the query using the item and column number syntax. This syntax
allows you to use the same query across multiple document types.
To find the item and column number for a field, choose View > System Information
and move your mouse over the field in the active document.
The item number for a field is common across all document types that have the
same structure, such as sales and purchasing documents. In these documents,
the item and column numbers are the same, but the table names are different. In
the example shown here, the item number for CardCode is 4 and the item number
for DocTotal is 29.
To use the item number syntax, add a second $ sign in front of the item number,
within the brackets, to indicate that the item syntax is used. The column number is
always 0 in approval procedure queries, since the query can only refer to fields in
the header of a document.
The item number query syntax returns a string value. Therefore if you need the result in a
different format, you need to specify the format in the last part of the syntax:
If set to 0, the field is retrieved as a string. This is the default.
If set to number, the field is retrieved as a number and can be used in calculations.
If set to currency, only the currency symbol is retrieved from a field that contains both an
amount and the currency symbol.
If set to date, the field is retrieved as a date field for date calculations.
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To test the syntax of a query that refers to the active window, create a document
that meets the conditions. Keep this document in the active window and run the
query from the Tools menu. The query will return a true or false result.
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In this demo, you will see how to create an approval procedure using a query to
specify the conditions.
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When you specify multiple approvers at the same stage, they have equal
authorization level.
You need to consider the effect of multiple approvers at the same stage.
In this example, the minimum required number of approvers is 1.
One of the approvers approves the document. Later on, another approver rejects
the same document.
But this rejection has no effect if it happens after the first approval. Since only one
approval is required, the document is approved and can be added to the system.
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In the second scenario, one of the approvers rejects the document. The document
is held as pending until the other approvers respond.
If all the approvers reject the document, the originator is alerted that the document
has been rejected.
But if another approver approves the document, and the minimum number of
required approvers is reached, then the document is approved and the
originator can add the document to the system.
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Imagine you are the originator of a document that needs approval; however you
have not had a response back from the approvers. You can see the document’s
approval status using the Approval Status Report.
You, or the approver, can cancel the approval request for the document by
selecting the row in the report, and choosing Cancel from the Data menu.
The status in the report can show one of the following values:
Pending – The document is waiting for approval.
Approved – The document is approved and converted from a draft to a regular
document.
Rejected – The document was not approved and remains a draft.
Cancelled – An approval procedure was cancelled from the Approval Status
Report. In this case, the draft document cannot be converted to a regular
document. This status is also reflected in the document itself.
If you are an approver, you can use the Approval Decision Report to see all
documents that require your approval.
Using this report you can directly approve or reject multiple documents at the
same time.
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This demo will show you the reports for originators and authorizers.
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Here are some key points to take away from this course. Please take a minute to
review these key points:
• To set up an approval procedure, you first activate approval procedures in the
General Settings, then define approval stages and create approval templates.
• To create a multi-level approval procedure, combine multiple predefined stages
in the approval template.
• You can set conditions for an approval procedure:
If you choose “always”, the procedure will start for every document type
selected in the template.
You can select a predefined condition, or,
Add your own user query containing the conditions.
• When you use a query in an approval template, you must write the query to
return a true or false result.
• If the query only needs to reference a specific document type, you can use the
table and field name syntax. To reference fields in the active window, include a
$ sign in front of the square brackets.
• If the query needs to work with multiple document types with the same
structure, use the item and column number syntax and include an additional $
sign within the square brackets.
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You have completed the topic for approval procedures. Thank you for your time!
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