Welcome to the topic on User-Defined Values.
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On completion of this topic, you will be able to add user-defined values to form
fields to automate data entry in forms and documents. You will learn how to add a
list of values as user-defined values, and how to use a query as user-defined
values.
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Here are two examples of requirements that can be met by adding user-defined
values to form fields:
• In the first example, the company wants to have the delivery date, which is a
mandatory field, automatically calculated in sales orders, so that the
salesperson does not have to manually enter the date. In the business process
the delivery date is not used, since sales orders are dispatched immediately for
delivery.
• In the second example, the salesperson needs the ability to instantly view a
customer’s up-to-date account balance when processing a new sales order
over the phone. With user-defined values, the salesperson does not have to
manually drill-down to the master data.
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You can add UDVs to any editable header field in documents and forms, to row
level fields in documents and forms, and to user-defined fields added to objects
such as documents and master data.
User-defined values can assist and automate data entry for users.
If added at the row level, user-defined values apply to each row.
User-defined values can be added to a field as:
• List of values. The user chooses from a list of predefined values for the field.
• User query. When the query runs, the query results are stored in the field. In
the example, a query has been added to the delivery date field. The query will
calculate a valid date for the delivery. Using a query is the most flexible option
as the query can be set up to run manually or automatically:
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A magnifying glass icon indicates that user-defined values have been added to the
field.
Users can toggle the display of this icon on and off, using the menu View >
Pickers Display > User-Defined Values.
In the example, we can see that user-defined values have been added to the
Delivery Date field, and to a user-defined field in the document header.
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To add user-defined values to a field, select the field in the document or form and
press the key combination Alt+Shift+F2, or choose the menu path Tools >
Customization Tools > User-Defined Values - Setup.
Only authorized users can add UDVs. The authorization is located in the General
Authorizations window by navigating to Customization Tools > User-Defined
Values – Setup.
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In the setup window for user-defined values, you select one of three options.
The first option, Without search in user-defined values, can be used to remove
previously added user-defined values from the field.
There are no restrictions on removing user-defined values from a field. After you
remove the user-defined values, documents saved in the system retain the values
entered.
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The second option, Search in existing user-defined values, allows you to define a
list of values for the field.
When defining the values, make sure that the value does not exceed the field
length as defined in the database.
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To select from the list of values, the user can select the magnifying glass indicator
or press Shift+F2 in the field.
The list of values can be maintained directly by the user, and the user can add
new values to the list by choosing New. Note: this contrasts to a list of values
added for a user-defined field using the User-Defined Fields – Management
window. In this case, the user cannot add new values to the list and the list is
maintained from the User-Defined Fields – Management window.
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This demo will show you how to add a list of values as user-defined values.
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The last option, Search in existing user-defined values according to saved query,
lets you attach a query to the field.
This option is very powerful, since the field is populated with the results of the
query.
The query can set a value in the field, or store the results of a calculation in the
field, or fetch another field value from the database to go in the field.
The query can prompt the user for a parameter, and use the parameter to
calculate the results.
In the example shown here, you can use a query to calculate the delivery date
based on the current date. The query adds 7 days to the current date and stores
the result as the delivery date.
When you use a query, make sure the query result matches the field type in the
document, and does not exceed the size of the field. For example, do not return
an alphanumeric string result into a field that is defined as numeric.
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In many situations, the query needs to reference a field in the active window. In
the example shown, you have added user-defined values to a field in the sales
order. The query will fetch the customer’s account balance from the master data
record and show the balance in the sales order field. The sales order is the active
window because the user is working on it.
The query matches the CardCode from the active window to the CardCode in the
master data.
Whenever you refer to a field in the active window, you must include a $ sign in
front of the field name to reference the active window. Fields that are stored in the
database, such as the balance field from the master data record, do not need the
$ sign.
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To test a query that references the active window, keep the document as the
active window and run the query by choosing Tools > Queries > User Queries
then select the category and query name from the menu.
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When you select the option to use a query as user-defined values, you can decide
if you want the query to automatically run without user involvement.
The Auto Refresh When Field Changes checkbox determines if the query runs
automatically.
If you do not select this checkbox, the query is not automatic and only runs when
the user clicks the magnifying glass or presses Shift+F2 in the field.
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If you select the Auto Refresh When Field Changes checkbox, you are prompted
to select a dependent field. The query runs automatically when the dependent
field changes in value or the user enters a value in the dependent field.
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Here is an example to illustrate how the auto refresh function works.
A query is added to a field in the sales order using user-defined values. The
Customer/Vendor Code is selected as the dependent field. When the user selects
the business partner code in a sales order, this action triggers the query to run.
This is typically the first action when a user processes a new marketing document.
Therefore it is a common practice to use the Customer/Vendor Code as a
dependent field to trigger the query to run.
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There are two rules for selecting dependent fields.
For a query added to a header field in a document, you can only select another
header field as the dependent field. This includes all fields in the document that
are not in the row table.
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For a query added to a row-level field, you can select either a header or a rowlevel field as the dependent field.
To select a header field as the dependent field, select When Field Changes from
the dropdown list.
To select another row-level field as the dependent field, select When Exiting
Altered Column from the dropdown list.
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Note that, when you add user-defined values to a specific marketing document
type, such as a sales order, other similar document types such as deliveries and
invoices are unaffected. In other words, user-defined values behave differently to
user-defined fields and are not inherited by other document types. Therefore you
need to add user-defined values to each specific document type as required.
However, the value entered in a field with user-defined values is transferred to a
target document using the Copy To/ Copy From function.
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When you choose Auto Refresh When Field Changes, two further options appear.
These options determine if the query runs only once, or if the query runs
whenever the dependent field changes.
The default option is Display Saved User-Defined Values and is recommended
since it maintains the initial result of the query. The query runs once when the
dependent field changes, and will not run again even if the dependent field
changes.
An example is a query added to the Delivery Date in a document. The query
calculates a delivery date based on the system date. You only want the query to
run once. If the query ran multiple times, the delivery date might be incorrectly
updated.
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If you choose Refresh Regularly, the query will run each time the dependent field
changes or is selected in a document.
You should use this option with caution since it can result in the field value
changing when not expected.
The query will run when you browse through records, or drill-down to open a
document that contains a query. When the query runs, the document status will
change to Update mode, and you must save the changes if you want to record the
new query results.
An example of using Refresh Regularly is a query that shows the up-to-date
account balance of a business partner. You want the query to run whenever you
browse or open the document so you can always see the latest balance. However,
you will still be prompted to update the document if you want to save the query
results.
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This demo will show you how to add a saved query as user-defined values.
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Here are some points to take away regarding user-defined values. Please take a minute
to review these key points:
• User-defined values (UDVs) automate data entry for users.
• You can add UDVs to editable header and row level fields, and to any user-defined
field. To add UDVs, select the field, then press Alt+Shift+F2.
• A magnifying glass indicator shows if user-defined values exist for a field. You can
enable this from the View > Pickers Display menu.
• User-defined values can be set up as a list of values, or, more commonly, as a user
query.
• If a list of values is used, the user opens the list by selecting the magnifying glass
indicator or pressing Shift+F2 in the field.
• If a query is used, the results of the query are saved in the target field. To set the query
to run automatically with no user involvement, use the the auto refresh option and
select a dependent field. Two further options are available for running the query:
• If you select Refresh Regularly, the query will run each time the dependent field
changes or is selected, or when browsing records. This could lead to inconsistent
results, depending on the query, or could cause a performance degradation when
browsing through records.
• If you select Display Saved User-Defined Values, the query will run once and
retain the result in the field. This option is recommended since it maintains the
initial value of the field, but the choice of this option depends on the business
need and the query.
• Queries should be written to reference the active window, where needed.
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You have completed the topic for user-defined values. Thank you for your time!
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