Show TOC

Server Version Check for SAPUI5 Runtime LibrariesLocate this document in the navigation structure

When you develop SAPUI5 apps, the code completion and app preview features are based on SAPUI5 runtime libraries installed in your Eclipse. However, after you have deployed the app to the ABAP server and executed it there, it uses the SAPUI5 runtime libraries installed on the ABAP server.

We therefore recommend that you always have the same library version installed in Eclipse and on the ABAP server. If this is not the case, for example, if the local version is higher than the one on the server, the following could happen:

  • You may use features during development that are not yet available on the server.
  • When you test your app in Eclipse, the app may behave differently, for example, because in the newer runtime version some issues are fixed which still occur on the server.

Please refer to the compatibility rules which apply to SAPUI5 runtime libraries (see Compatibility Rules).

When you share an SAPUI5 application project with the SAPUI5 ABAP repository (or start the submit wizard), the version of the local libraries is compared with the server. If the versions differ, a warning message shows the current versions. If you want to proceed, you can ignore this warning message. In this case, we recommend that you do the following:

  • Check the JavaScript documentation of the used controls and their methods for @since tags. They indicate which version has introduced a new feature which you are going to use.
  • When testing in Eclipse you should configure it to use the runtime libraries located on the server instead of the local ones, see SAPUI5 Library Location Used for Testing.
  • Always test your app on the server after submitting changes.
Note

SAP Web IDE uses a similar check. For more information, see Server Version Check for SAPUI5 Runtime Libraries.