## Content

1. **History of changes.** ................................................................. 5
2. **Work Manager Overview.** .......................................................... 6
3. **Accessing Work Manager.** .......................................................... 7
   3.1 To launch Work Manager. .......................................................... 7
   3.2 To log in to Work Manager. ....................................................... 8
   3.3 Security in Work Manager.
      - Establishing Work Manager Security. ........................................ 8
      - Work Manager Security Settings. ............................................... 9
   3.4 To Log out of Work Manager. .................................................... 9
   3.5 Closing down Work Manager. ................................................... 9
   3.6 Changing Work Manager screen viewing options. .......................... 10
   3.7 Installation. .............................................................................. 10
4. **Building a Process Definition.** .................................................. 11
   4.1 To create a Process Definition. ................................................... 12
   4.2 Designing a process definition chart.
      - Process definition design tools. ................................................. 13
      - Changing the appearance of individual chart objects. .................. 15
      - Globally changing the appearance of chart objects. ....................... 16
      - To zoom on the Design area. ...................................................... 17
      - Grouping objects in a chart. ...................................................... 17
   4.3 Creating process definition script.
      - To produce Creation script using the Creation Script wizard. ............. 18
      - Creating Connection Event Scripts. ............................................. 19
      - To produce connection event script using the Script Wizard. ............. 20
   4.4 Making changes to a process definition.
      - Opening a process definition. .................................................... 24
      - Process definition versions. ...................................................... 25
      - Editing in the design pane. ....................................................... 25
   4.5 Configuring Object Properties.
      - Workflow Object properties. ..................................................... 26
      - Creating custom properties. ...................................................... 27
   4.6 Storing process definition changes.
      - To save a process definition to the database. ............................... 30
      - To export a process definition to a file on disk. ............................ 31
      - To import an exported process definition. .................................... 32
To save a process definition as the default template. .................................................. 32

4.7 Locking and unlocking process definitions. .............................................................. 33
   Automatically unlocking process definitions on closing the application. ........................ 33
   To manually unlock an individual process definition. .................................................. 33

4.8 Printing a process definition. .......................................................... 34
   Accessing Print Preview options. .............................................................................. 34

5 Making a workflow available for operation. ................................................................. 37
5.1 To publish a process definition. ................................................................................ 37
5.2 Configuring Security. ............................................................................................... 38
5.3 Creating Books. ....................................................................................................... 38

6 Monitoring and debugging Workflow operation. ......................................................... 40
6.1 To monitor a process workflow. ................................................................................ 40
   The Monitor Toolbar. ................................................................................................. 40
   The Process Monitor screen. ...................................................................................... 41
   The Process Instance List. .......................................................................................... 41
   Filtering the Process Instance List. ............................................................................ 42
6.2 To create workflow test data. .................................................................................... 42
6.3 The Event Log. .......................................................................................................... 43
6.4 The Audit Log. .......................................................................................................... 43
   Configuring auditable events. ...................................................................................... 43
   Filtering audited events. ............................................................................................. 44

7 Customizing Work Manager Scripts. ......................................................................... 45
7.1 Using Work Manager functions. ................................................................................ 45
   The Workflow Type. ................................................................................................. 45
   The Workflow Identifier. ........................................................................................... 45
   Expiry Timeout Values. .............................................................................................. 45
7.2 Managing Console jobs. ............................................................................................ 46
   Console Template Command File. ............................................................................. 46
   Console Job Execution Script. .................................................................................... 46
   Console Error Handling. ............................................................................................ 47
7.3 Example scripts. ......................................................................................................... 47
   Global variables. ........................................................................................................ 47
   Creation scripts. ......................................................................................................... 48
   Connection scripts. ..................................................................................................... 49
   Sample Book scripts. ................................................................................................ 50
   Sample Links. ............................................................................................................ 51

8 Troubleshooting Tips. .................................................................................................... 52
8.1 Installation & Configuration. ..................................................................................... 52
8.2 Integrating with E-mail Services. ............................................................................. 52
8.3 Designing New Processes ............................................................... 53
8.4 Using the Event Log ................................................................. 53
  Scripting error messages ......................................................... 53
  User-defined debug messages ............................................... 54
  System-generated error information ....................................... 54
8.5 Common Work Manager errors .............................................. 54
1 History of changes

The current version of this document is version 1.0. The following table provides an overview of the most important changes to prior and current versions of this document:

<table>
<thead>
<tr>
<th>Version</th>
<th>Important Changes</th>
</tr>
</thead>
</table>
2 Work Manager Overview

Profitability and Cost Management Work Manager comprises the Work Manager Client application and Work Manager Server. Together, these applications enable you to automate business processes within a timeframe. The client application allows business architects to model business processes (workflows) using a graphical user interface that offers a drawing board for mapping out a process definition. A unique version of the process definition is then published, and the Work Manager Server will execute its instructions. Workflow progress may be tracked through a monitoring functionality in the Work Manager Client application.

Each finished process definition can be made available so that users can interact with the process, making decisions and progressing through the stages of the workflow. Workflows will usually contain a step that requires users to interact with information published in a book (that can be accessed either through the user’s Internet browser or via Book Viewer). Functionality within these books will in turn, allow users to interact with the workflows, so moving the process on.

The workflows are created by the business architect, or designer, who draws out the stages of the process, links them together, and then creates scripts to move from one stage to another. Workflows can send email communications so that participants can be notified of progress, or reminded about time-critical and impending events. The emails may also contain links (URLs) to take recipients directly to the relevant books.

Processes can be made to operate locally within small groups of users, or across entire organizations worldwide. Data is held in a common database ensuring that everyone is working from the same data set, and that changes can be seen by everyone involved in the process immediately.

Security settings defined by process designers ensure that only the information that is appropriate to that user is seen.
3  Accessing Work Manager

The Work Manager Server application is initiated by Profitability and Cost Management Configure.

The Work Manager Client application can be launched either from the Windows Start menu or from within Model Builder.

3.1  To launch Work Manager

Procedure

To start Work Manager:

○ from the Windows Start menu, select Start → Programs → SAP BusinessObjects → Profitability and Cost Management → Work Manager.

○ from within Model Builder, select Tools → Launch → Work Manager.

Results

On launching the application from the Start menu you will be presented with a Login dialog box.

If you launch Work Manager from within Model Builder, the Work Manager application opens immediately and you do not need to log in.

Related Information

Security in Work Manager [page 8]
To log in to Work Manager [page 8]
3.2 To log in to Work Manager

Procedure

1. On launching the Work Manager application, you will be presented with a Login dialog box. To login to Work Manager in other circumstances, select File > Login from the main menu bar or click on the Login icon in the top left hand corner. The Login dialog is displayed.

2. Enter your User Name and Password. Your Username is not case-sensitive but remember that your Password is. The first login for a new installation must use the predefined user Administrator who has the ability to operate any Work Manager function.

Results

After logging in you will see the Work Manager main screen, consisting of a set of toolbars, a Process Definition List, and a Process Designer area.

Related Information

Security in Work Manager [page 8]

3.3 Security in Work Manager

Integrated security within Work Manager consists of creating user groups specific to the application, then restricting the access of those groups for the Work Manager security descriptor (Process Definition Security).

3.3.1 Establishing Work Manager Security

Security is controlled via the Model Builder application and can be accessed after logging on to Model Builder via Tools > Security. In order to create or remove user accounts you will need an account with Administrator access.

Establish which accounts will be used during your Work Manager process. The minimum requirement is one user account belonging to a user group. There are no restrictions on the naming of accounts, but sensible naming will make the use of these accounts in script easier.
Every account has a user property called *E-mail address*. A valid e-mail address must be entered for all accounts. Each account must also be part of the built-in *ENDUSERS* group in order to permit access to books.

**Related Information**

Work Manager Security Settings [page 9]

### 3.3.2 Work Manager Security Settings

Configure the access level of each group (including ENDUSERS) for the Process Definition Security descriptor. *FULL ACCESS* is required for anyone who will be involved in creating Work Manager process definitions (designers, script writers, publishers). Other access settings are for users, and will prevent unauthorized changes being made to process definitions. Other security descriptors may be set as required.

Default Book Assignments are not usually required for Work Manager. Instead users are directed to specific books via URLs.

**Related Information**

Add link to Book [page 21]

### 3.4 To Logout of Work Manager

Select `File ➤ Logout` from the Windows toolbar or click on the *Logout* icon in the top left hand corner to log out of the Work Manager application. You will be prompted to save any pending changes to your process definitions.

### 3.5 Closing down Work Manager

Select `File ➤ Exit` or click the *Close* icon on the Work Manager toolbar to close down Work Manager. Additionally, closing Work Manager will log out the current user.

If you have any process definitions locked then the process of logging out will prompt you to decide whether to unlock any of them.
Related Information

Automatically unlocking process definitions on closing the application [page 33]

3.6 Changing Work Manager screen viewing options

The View functions that can be selected from the View menu enable you to change your Work Manager screen viewing options:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Toolbar</td>
<td>When selected the Main Toolbar is visible, otherwise it is hidden.</td>
</tr>
<tr>
<td>Show Status Bar</td>
<td>When selected the Status bar at the bottom of the screen is visible, otherwise it is hidden.</td>
</tr>
<tr>
<td>Process Definitions</td>
<td>This toggles the appearance of the list of process definitions. This window can be repositioned (docked) as required.</td>
</tr>
<tr>
<td>Style</td>
<td>Provides several display styles for toolbar icons.</td>
</tr>
<tr>
<td>Lock Toolbar</td>
<td>This toggle function prevents changes to the functions available from the toolbar. To allow changes to be made to the toolbar this setting should be unchecked.</td>
</tr>
</tbody>
</table>

If you have one or more Process Definitions open, you can use the standard Windows functions to arrange the Design windows to suit your viewing requirements or open and close windows. These functions are available on the Window menu on the main menu bar.

3.7 Installation

Work Manager installation occurs as part of the main installation package. Details of the installation procedure, its prerequisites, and the configuration options available during installation are all detailed in the SAP BusinessObjects Profitability and Cost Management Installation Guide.

Related Information

Installation & Configuration [page 52]
4 Building a Process Definition

Process Definitions are created in the main part of the screen, in the **Design** area. Objects from the Work Manager Toolbar can be drawn in this space, linked together, and then coded to perform actions when events are triggered.

The first step required is to create a new process definition. Next the state objects are drawn, and then you can add the connections. This produces a chart for the workflow.

An example of a Process Definition chart is shown below:

The final step in creating a process definition is to add scripting that will control the workflow operation.

When you have an existing process definition, you may edit it by opening it and altering the design or script as required.
4.1 To create a Process Definition

Procedure

1. You may use either of the following options to create a Process Definition:
   ○ Select File > New Process Definition.
   ○ Click the New Process Definition icon.
   ○ In the Process Definition List, select New Process Definition from the context menu.

   This action adds a new process to the Process Definition List bar. The process definition is automatically locked and it will initially have the predefined name; Process Def1.

2. Change the predefined process name if required, by pressing F2 or by selecting Rename from the context menu.

Results

Work Manager also creates a Start Object for the new Process Definition and opens the Design pane ready for the process design to be added. By default, the Start Object appears as a pale yellow oval with the text “Created”.

You may continue adding to the Process Definition now or at a later time.

4.2 Designing a process definition chart

Once the initial process definition has been created, draw as many State objects as is required to fulfill each possible state in the process. It is helpful to amend the name of the states to something meaningful because this will make it easier to place the states in order when connecting them.

Add connections between objects using the Connecting Tool. Connections can be made by dropping the ends of the connection onto the State objects. Connections between States define the Events that are the triggers for activating connection scripts.

The process definition chart provides a visual representation of the workflow. It comprises:

- A single Start object
- One or more State objects
- One or more Connections
- Notes as required

To add these items, you will need to use the tools on the Work Manager Toolbar.

You can also change the appearance of the chart using a range of different functions. You can change chart objects individually or you can globally change the appearance of chart objects. Functionality is also provided to change the colors used on objects. To assist with working on your chart, there are functions that allow you to zoom in on the chart, and also grouping facilities for moving more than one object simultaneously.
Related Information

To change object colors [page 16]
To create a Process Definition [page 12]

4.2.1 Process definition design tools

You can use the tools provided on the Work Manager Toolbar to create a process definition chart.

Tool functionality is described in the following table:

<table>
<thead>
<tr>
<th>Toolbar icon</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Pointer</strong></td>
<td>Sets the cursor to a pointer so that objects can be selected.</td>
</tr>
<tr>
<td>![Pointer Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Connecting Tool</strong></td>
<td>Sets the cursor to a crosshair for drawing a connection line that can then be anchored to other objects.</td>
</tr>
<tr>
<td>![Connecting Tool Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Start Object</strong></td>
<td>Sets the cursor to a crosshair for drawing a Start object. Only one Start object can be part of a process definition. A start object called “Creation” is included in the default template for new processes.</td>
</tr>
<tr>
<td>![Start Object Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>State Object</strong></td>
<td>Sets the cursor to a crosshair for drawing a State object.</td>
</tr>
<tr>
<td>![State Object Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Notes</strong></td>
<td>Sets the cursor to a crosshair for drawing a Note object. Note objects are text labels.</td>
</tr>
<tr>
<td>![Notes Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Object Font</strong></td>
<td>Allows you to select the font for the currently selected object.</td>
</tr>
<tr>
<td>![Object Font Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Font Size</strong></td>
<td>Sets the font size in pixels.</td>
</tr>
<tr>
<td>![Font Size Icon]</td>
<td></td>
</tr>
<tr>
<td>Toolbar Icon</td>
<td>Effect</td>
</tr>
<tr>
<td>----------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Sets the style of any selected text to bold.</td>
</tr>
<tr>
<td>![Bold Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Sets the style of any selected text to italic.</td>
</tr>
<tr>
<td>![Italic Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Underline</strong></td>
<td>Sets the style of any selected text to be underlined.</td>
</tr>
<tr>
<td>![Underline Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Font Color</strong></td>
<td>Sets the color of the font for the selected object.</td>
</tr>
<tr>
<td>![Font Color Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Line Color</strong></td>
<td>Sets the color of the border for the selected object.</td>
</tr>
<tr>
<td>![Line Color Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Fill Color</strong></td>
<td>Sets the color of the background for the selected object.</td>
</tr>
<tr>
<td>![Fill Color Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Zoom Out</strong></td>
<td>Makes all objects in the graphical designer area reduce in size by 10%.</td>
</tr>
<tr>
<td>![Zoom Out Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Zoom In</strong></td>
<td>Makes all objects in the graphical designer area enlarge in size by 10%.</td>
</tr>
<tr>
<td>![Zoom In Icon]</td>
<td></td>
</tr>
<tr>
<td><strong>Zoom To</strong></td>
<td>Sets the increase or decrease in object size to a specific ratio.</td>
</tr>
<tr>
<td>![Zoom To Icon]</td>
<td></td>
</tr>
</tbody>
</table>
4.2.2 Changing the appearance of individual chart objects

You may change the properties of an individual object in the designer area using the Object Inspector panel. This can be used to change any feature of an object such as color, text or position. If you need only to change the object’s colors, this can additionally be done using the Format menu or the toolbar icons.

4.2.2.1 Changing object properties using the Object Inspector

Having selected the required object, the Object Inspector panel can be made visible or hidden by using either of the following toggle options:

- Select View Object Inspector from the main menu bar or
- Press the F11 function key.

The Object Inspector is displayed with two tabs provided for your viewing preference – Alphabetic or Categorized.

The Object Inspector window can be made to be a floating panel, or repositioned (docked) against either the left or right-hand edges of the Designer Area.

The general object properties are:

<table>
<thead>
<tr>
<th>Property</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>You can change the name of an Object by editing the Object Name box in its General Object properties. Names longer than 256 characters will be truncated to fit.</td>
</tr>
<tr>
<td>Font</td>
<td>You can change the font style and size of an object through its General Object properties. Click on the Font button to display a list of currently installed fonts. Changes can be made to that will apply only to this object. Use ‘Shape Setup’ to apply changes to all fonts in the designer.</td>
</tr>
<tr>
<td>Script</td>
<td>You can add, remove or amend the VBScript associated with an object through its General Object Properties. Not all objects have this property.</td>
</tr>
<tr>
<td>Height</td>
<td>The height of the current object in pixels.</td>
</tr>
<tr>
<td>Width</td>
<td>The width of the current object in pixels.</td>
</tr>
<tr>
<td>VertTextPos</td>
<td>Positions the object’s descriptive text.</td>
</tr>
<tr>
<td>Line Width</td>
<td>Determines the thickness of the object’s border in pixels.</td>
</tr>
<tr>
<td>Background Color</td>
<td>Use this option to select the color of the object from the presented palette.</td>
</tr>
<tr>
<td>Transparent</td>
<td>Makes the object transparent, with only the text and border remaining visible.</td>
</tr>
</tbody>
</table>
4.2.2.2 To change object colors

Context

As well as using the Object Inspector, you may use the Format menu from the Main toolbar or icons on the Work Manager toolbar to change an object’s colors.

Procedure

1. Select the required object.
2. Either select the required function from the Format menu or select the required icon:
   - Fill Color
   - Line Color
   - Font Color
3. Apply the color change as required.

4.2.3 Globally changing the appearance of chart objects

Each of the objects available from the Work Manager toolbar can be configured for a range of properties by choosing Tools Shape Setup from the main toolbar. The Creation Defaults dialog box is displayed.

The Creation Defaults dialog box lists the objects on the right-hand side and the object properties relating to appearance on the left-hand side.

You can amend the following properties for shapes:

- Shape Color - the default color of the shape outline and shadow
- Background Color - the default color of the shape background (fill)
- Font - the font of the text within a shape
- 3D Object Look - places a drop shadow behind the object for a 3-dimensional look
- Default Height - the height of the shape in pixels
- Default Width - the width of the shape in pixels
- Round Rect Radius - configures the size of the curved edges of the object.

For connection objects you can amend the following properties:

- Line Color - the default color of the line connecting two objects
- Arrow Color - the default color of the arrowheads at the end of the connection line
- Font - the font of the text labeling the connection
- Line Style - the style of the line drawn between two objects
- Source Style - the style of the point from which the connection line emerges.
4.2.4 To zoom on the Design area

Context

The zoom functions allow you to enlarge or reduce the appearance of items in the Design area.

Procedure

- To make all objects enlarge in size by 10%, either select View > Zoom In from the main toolbar or click the Zoom In icon on the Work Manager toolbar.
- To make all objects reduce in size by 10%, either select View > Zoom Out from the main toolbar or click the Zoom Out icon on the Work Manager toolbar.
- To set an increase or decrease in object size to a specific ratio, enter a value in the Zoom To list on the Work Manager toolbar.

4.2.5 Grouping objects in a chart

You can group together selected objects in the Design area so that you can move all the objects within a group without affecting other items in the process definition chart. The functionality for this is provided via the Unions menu on the main menu bar:

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Union</td>
<td>This creates a new grouping of objects. All currently selected objects within the design area will be grouped together.</td>
</tr>
<tr>
<td>Add To Union</td>
<td>This adds the selected object to an existing union. You will be prompted to choose which existing union to add the object to.</td>
</tr>
<tr>
<td>Remove From Union</td>
<td>This removes the selected object from an existing union. You will be prompted to choose which existing union to remove the object from.</td>
</tr>
<tr>
<td>Clear Union</td>
<td>This ungroups all of the objects in the existing selected union (or the union of which the selected object is currently a member).</td>
</tr>
<tr>
<td>Clear All Unions</td>
<td>This ungroups all of the objects currently displayed in the graphical designer area.</td>
</tr>
</tbody>
</table>

4.3 Creating process definition script

Once the process definition has been designed, the next stage is to add the scripts. The process definition requires a Creation script that is used to initiate the process. It also requires Connection Event scripts to define what actions should be taken as a consequence of the change from one connecting state to another.
You will also need additional script to be placed behind a button in a Book, to initiate the workflow process. When producing the Creation script, the Creation Script Wizard generates Book script that you can copy, save, or add to the book later.

### 4.3.1 To produce Creation script using the Creation Script wizard

**Context**

By default the template for a new process will include a *Creation* object. A Creation Script is required to initiate the process. Its purpose is to establish the status of any variables you may have defined; to execute functions that are particular to starting a process (for example, sending an e-mail to everyone notifying them that a new process is under way); and to move the process on to the first user-defined state.

The Creation Script Wizard can be used to produce the Creation Script.

**Procedure**

1. To initiate the Creation Script Wizard:
   - either double-click the Creation object (the default Start Object)
   - or right-click the Creation object and select *Run creation script wizard* from the context menu.

   The Welcome screen is presented.

2. If you wish to view the script that will be generated on completion of the wizard, select the View generated script check box.

3. Click Next to continue.

   The Creation Data screen appears.

4. To choose a model, select the Model name check box, then click the Browse (...) button.

   The Select a model name property dialog box will be displayed, from which you can choose a model.

5. To choose a manager, select the Manager name check box, then click Browse (...) to select a Manager.

   The manager ID is a Profitability and Cost Management user that has been set up in the system already.

6. Click either the A User Group or List of Users option, then click Browse (...) to select a user group or single user(s).

   The User Group holds Profitability and Cost Management users that have been set up in the system already. When choosing your Users, you can choose to select a predefined group, or to create a custom list of users from any or all available of the user accounts. Users that intend to make use of the e-mailing facilities within Work Manager should have an e-mail address set against their user account.

7. Click Next when you are happy with your selections.

   The starting function script will be created with a default function name of EPOWorkflow_CreateWorkflow and the book script (Button_OnClick) is also created. The Script Preview screen will be displayed if you had selected View generated script on the Welcome screen. If you left this check box clear, the Completing screen will be displayed, and you should go to the final step.
The Script Preview screen gives you the opportunity to preview the script behind the Creation Object and see how it is going to look once the wizard has completed. You can amend the script at this point, or continue now, with the option of amending it at another time.

8. Click Next to go to the Book Script preview screen.

The Book Script Preview screen shows the script created by the wizard that will initiate the workflow process from a Book. You should copy or save this script to place it behind a button (it can be amended to suit any book control) on the click event.

- If you wish to save the script to a text file, click Save as to bring up a dialog box for you to specify the file name.
- If you wish to place the script into the clipboard, click Copy, so that it can be pasted into a book.

9. Click Next when you are satisfied with the script.

This will present the Completing screen.

10. Click Finish.

This concludes the wizard process for the Creation Script.

Related Information

Establishing Work Manager Security [page 8]
Creation scripts [page 48]
Creating process definition script [page 17]

4.3.2 Creating Connection Event Scripts

Once connection lines have been drawn between all of the State Objects, then the code that defines each of the events can be created. Each event defines what actions should be taken as a consequence of the change from one connecting state to another.

Examples of events include:

- Referring a budget to a spending authority
- Completing a unit of work
- Filling out a timesheet

You can write your own script to trigger events, respond to actions, and communicate with your Work Manager process users. However Work Manager also has a Script Wizard that allows you to create the script automatically for common Work Manager events such as:

- Sending an e-mail to a Profitability and Cost Management user
- Setting an expiry time for the event
- Triggering another event
- Writing debug messages to the Event Log
- Completing a Work Manager process
4.3.3 To produce connection event script using the Script Wizard

Context

The Work Manager Script Wizard allows you to create the script automatically for common Work Manager events such as:

- Sending an e-mail to a Profitability and Cost Management user.
- Setting an expiry time for the event.
- Triggering another event.
- Writing debug messages to the Event Log.
- Completing a Work Manager process.

To initiate the Work Manager Script Wizard for an event:

Procedure

1. Double-click the event connection line or select Run script wizard from the context menu on the event connection line. The Welcome screen will be presented.
2. If you wish to view the script that will be generated on completion of the wizard, select the View generated script check box.
3. Click Next to continue. The Script Options screen will appear.
4. By default, the Function Name displays the existing connection name as the function name. You can choose to accept any default name, or enter a function name of your own. The Function Name box will not accept special characters, and any spaces you enter will be replaced automatically by underscore characters.
5. The Script Options pane offers the following check boxes: Send an e-mail, Set an expiry, Trigger next event, Debug message, and Complete. Select the check boxes as required, depending on which tasks are to be carried out by this function. Only the screens relevant to the selections will appear next in the wizard. Options that are not selected are not included in the script created in the final wizard screen.
6. Select Next to continue. The screens that are appropriate for your selected options will be displayed. (Refer to the relevant topics for further information.)
7. Having completed the options, click Next to continue.
If you have selected the View generated script check box on the Script Wizard Welcome screen, the Function Preview screen will be displayed.

### 4.3.3.1 E-mail Options

The e-Mail Options screen will appear if you have selected Send an e-mail in the Script Wizard Script Options screen:

In this screen you can select existing Profitability and Cost Management users as the sender and recipient(s) of a Work Manager e-mail. To do this, you use the To, From, and CC buttons to access the Select user id property dialog box, which displays a list of managers and users. The list of users and managers corresponds to the information that was passed into the process by the Creation Script (specifically the lists contained within the Creation Data arrays).

You also need to type a suitable subject line in the Subject box.

You type the body of the e-mail in the pane at the bottom of the screen. Within the body of the message you can access several in-built properties, and also your own custom properties that you may have created, by right-clicking the body area to display the context menu. This will reveal options to insert the InstanceID for the current process, the Date, and any properties that you have defined using the Creation Wizard (or have defined yourself using the ObjectProperty method).

Click Next to continue. The Add link to Book screen will be displayed.

### Related Information

- Creation scripts [page 48]
- To produce Creation script using the Creation Script wizard [page 18]

### 4.3.3.1.1 Add link to Book

The Add link to Book screen appears if you have selected Send an e-mail in the Script Wizard Script Options screen:

The e-mail event allows a link to a book to be included with the e-mail. This can be in the form of a hyperlink that allows books to be opened directly in a browser or as a WAIS link or an attached EBK file that can be used to open the same book in Book Viewer. While the former will open Book Viewer directly from the email, you need to be using Outlook 2000 or higher. The EBK file allows earlier and simpler email clients such as Outlook Express to use the same functionality. In this case, Book Viewer is launched by either opening the attachment from within the e-mail or saving it on the computer and double-clicking the file.

This screen presents you with the following check boxes:

- Append e-mail body with a URL to open a book
- Append e-mail body with a Book Viewer link
You have the option of appending a URL link, a WAIS link, an EBK attachment, or all three to the e-mail constructed in the previous wizard screen. This hyperlink will be specific for each process instance; it will be specific to each user and each version of the process. Certain settings can be customized within the script. See “Work Manager Process Functions” in the SAP BusinessObjects Profitability and Cost Management Modeling Reference Guide.

You can type the name of a model into the Model Name field, or choose the ModelName property by selecting it from the list of properties presented when you click the Select a property button.

You can type the name of a book into the Book Name field, or choose to select a book from the list of available models and their books presented when you click Browse.

Related Information

To produce connection event script using the Script Wizard [page 20]

4.3.3.2 Set An Expiry

The Set an expiry screen appears if you have selected Set an expiry in the Script Wizard Script Options screen. When the screen opens, the Create an expiry check box is selected by default.

This screen allows you to specify either a specific time or a time interval after which the expiry event will be triggered.

First, select a connected event to trigger when the expiry time is exceeded in the Expiry Event list. Secondly, decide whether the expiry needs to be set to occur after an interval or at a specific time.

If you click the Expire after a certain interval option, you can set the time interval using the Days, Minutes, and Hours spin boxes.

If you click the Expire at fixed time option, you can set the time using the Date and Time spin boxes.

Related Information

To produce connection event script using the Script Wizard [page 20]

4.3.3.3 Trigger Next Event

The Trigger next event screen appears if you have selected Trigger next event in the Script Options screen.
When the screen appears, the *Trigger next event* check box is selected by default. Select a connected event from the *Event Name* list to set the event that will be triggered as a consequence of the current event completing. Using this function you can chain a sequence of events to occur as a consequence of a single action.

**Related Information**

To produce connection event script using the Script Wizard [page 20]

### 4.3.3.4 Debug Messages

The *Debug messages* screen appears if you have selected *Debug messages* in the *Script Options* screen of the Script Wizard. When this screen appears, the *Write debug message* checkbox is selected by default.

In this screen you can type a message in the edit box that will be written to the Work Manager Event Log (and also the Windows Event Log). This can be useful for checking that your process does what you think it should before publishing it to a wider audience.

All of the properties that you have created, including some in-built properties such as the process `InstanceID` and the `Date`, can be included in the message by right-clicking with the mouse to display the context menu and selecting the appropriate property from the list presented.

**Related Information**

To produce connection event script using the Script Wizard [page 20]

Workflow Object properties [page 27]
Using the Event Log [page 53]

### 4.3.3.5 Complete Process Instance

The *Complete Process Instance* screen will appear if you have selected *Complete* in the *Script Options* screen.

There is only one option on this screen, which is whether or not you want to set this process to conclude at this point. If the *Complete Process Instance* check box is selected then the process instance will be completed and any users being monitored will be removed from the monitor.

**Related Information**

To produce connection event script using the Script Wizard [page 20]
4.3.3.6  Function Preview

The Function Preview screen will be displayed if you have selected the View generated script check box on the Welcome screen.

In this screen you are shown the script that the wizard has created for you based upon the choices you have made in the previous screens.

The script can be amended in this window if required, or you can amend it later, using the editing functionality. A full description of all functions available in these scripts can be found in the SAP BusinessObjects Profitability and Cost Management Modeling Reference Guide, “Work Manager Process Functions” section.

Select Next to go to the Completing screen.

Select Finish to close the wizard. The Design pane will display the code for this function.

Related Information

Connection scripts [page 49]
Making changes to a process definition [page 24]
To produce connection event script using the Script Wizard [page 20]

4.4  Making changes to a process definition

Process definitions that you have created can be opened and edited to apply any changes that you require. Once you start editing, the process definition will be locked so that it cannot be accessed by other users until you unlock it.

Related Information

Locking and unlocking process definitions [page 33]

4.4.1  Opening a process definition

For each process definition, you may have one or more additional versions that you have previously published. Normally, you would want to edit the last published version, which is always the one that is available as the Unpublished Version.

If you are editing a new process that does not have any published versions, or if you wish to edit the unpublished version anyway, then you may open the process definition for editing by double-clicking it in the Process Definition List, and you will automatically open the unpublished version.
Alternatively, you may use one of the following methods, which will display a list of previously published versions for selection, as well as the unpublished version, and you will be able to select the one you require:

- Select File > Open from the Main menu then select the required process definition or
- Click the File Open icon on the Work Manager toolbar then select the required process definition or
- Select Open from the Definitions context menu in the Process Definition List then select the required process definition or
- Select the required process definition in the Process Definition List and select Open from the context menu

If you choose to work on a published version Work Manager provides an unpublished version of it for you to edit. The Unpublished version of a process is always the process that is being edited. The process definition is opened for editing in the Design pane.

An opened process definition becomes locked by the user that has the process open for editing. This ensures that no one can edit the same process definition at the same time and the definition retains its integrity. When the process is closed by the same user it can be unlocked again.

**Related Information**

- Editing in the design pane [page 25]
- Locking and unlocking process definitions [page 33]
- Process definition versions [page 25]

### 4.4.2 Process definition versions

Multiple versions of the same process can be opened simultaneously (as each version is a unique process definition). Versions of each process are listed in the Open command sub-menu with the version currently being edited known as the Unpublished version. Versions get named during the Publication process. An unpublished version is never available for use outside of the Work Manager application, but must be published before the events and states become available for referencing by book scripts.

Double-clicking a process definition will open an unpublished version. If there is more than one published version, this will be the last one to have been published. If you select an earlier published version to edit, then any changes that you make to it in the Work Manager application will cause it to become the unpublished version.

**Related Information**

- To publish a process definition [page 37]

### 4.4.3 Editing in the design pane

Each process definition opens a discrete designer area window when being edited. The process currently on view also has its name displayed in the title bar area at the top of the screen. Standard Windows functions are provided
that may be accessed via the Window menu. You may also use this menu to select which open window you wish to view or close.

If you edit the process definition script, this will open in a separate window. The open chart and code windows for a process definition are identified by having either (Chart) or (Code) after the process name.

A number of standard editing functions are available that you may use to manipulate your text and chart objects.

All of the following functions are found on the Edit menu of the main menu bar. Some functions may also be selected from the right-click context menu, depending upon whether they are applicable to chart or code editing.

<table>
<thead>
<tr>
<th>Function</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>This will reverse your previous actions. Actions that can be undone are limited to actions within the graphical designer area, and some actions (such as changing object styles, or publication) cannot be undone. Up to 200 prior actions may be reversed using this function.</td>
</tr>
<tr>
<td>Redo</td>
<td>This will repeat the previous action.</td>
</tr>
<tr>
<td>Cut</td>
<td>This will remove an object or script text from the graphical designer area and place it onto the clipboard for later use. Cutting text will make the Paste option become available.</td>
</tr>
<tr>
<td>Copy</td>
<td>Use this function to copy an object to the clipboard without removing it from the graphical designer area. This creates a temporary copy of the selected object that can be pasted onto the graphical designer area at a later time.</td>
</tr>
<tr>
<td>Paste</td>
<td>When an object or script text has been cut or copied to the clipboard it becomes available for pasting into a process definition. Clicking on Paste will display the object or text last copied to the clipboard.</td>
</tr>
<tr>
<td>Delete</td>
<td>This will remove an object or text from the graphical designer area. This action can be undone using the Undo function.</td>
</tr>
<tr>
<td>Find</td>
<td>This function opens a dialog in which you can specify text to search for.</td>
</tr>
<tr>
<td>Replace</td>
<td>This function opens a dialog in which you can specify text to be replaced as required.</td>
</tr>
<tr>
<td>Select All</td>
<td>This selects all of the text or objects currently visible in the graphical designer area.</td>
</tr>
<tr>
<td>Bring to Front</td>
<td>This will overlay any number of selected objects on top of other objects in the graphical designer area.</td>
</tr>
<tr>
<td>Send to Back</td>
<td>This will place any number of selected objects beneath other objects in the graphical designer area.</td>
</tr>
</tbody>
</table>

4.5 Configuring Object Properties

Each of the objects in the designer area has properties that can be configured to change their appearance. Right-click the object and select Edit Script to view configurable properties. State and Notes objects do not have associated script properties.
4.5.1 Workflow Object properties

There are some in-built Workflow Object properties that you can call upon to use. These are the Workflow Type, the Workflow Identifier, and the Date.

The Workflow Object can have any number of user-defined properties assigned to it. These properties can then be accessed and viewed in various windows within Work Manager such as the Process Instance List in the Process Monitor screen, and are available for selection when using the Creation Script Wizard.

Default Workflow Object properties are created as part of the Creation Script Wizard process – these are the Model Name, Manager and User Group properties. The properties have been defined as items in a Creation Data array, as part of the book script that initiates a workflow process.

Each State object in your workflow has an associated text string that can be specified when it is created. Each instance of a workflow process has a State property that identifies which State object has been reached by a user of that process instance. This can be read and altered in both book and workflow script.

You can also create your own properties with the ObjectProperty function in your Creation Script (EPOWorkflow_CreateWorkflow - see the "Creating custom properties" topic for more details). The following example shows you how to create and specify an Address property in a workflow process instance:

ObjectProperty (InstanceID, "Address") = "99, Example Lane, Samplesbury."

This function can also be used to retrieve property values:

CurrentState = ObjectProperty (InstanceID, "State")

Note

Properties can be set and retrieved in book script using the GetProperty function of the Workflow object.

Related Information

The Process Instance List [page 41]
The Process Monitor screen [page 41]
The Workflow Identifier [page 45]
To produce Creation script using the Creation Script wizard [page 18]
Creating custom properties [page 28]
4.5.2 Creating custom properties

Work Manager has the ability to store any user-defined data against a process instance. This is done through the use of properties. When designing a process definition, the Creation Script Wizard automates the setting of standard properties, such as Model Name, Manager Name, and User Name, that can be used internally or when monitoring the process remotely.

It is a simple task to add custom properties. As an example, there is a new property called RC in the example creation function shown here. The property has a NAME and a VALUE. The value of the property can be updated in the process definition or in a book over the web.

If we had created a book called Waiting for Budget Submission it may include a DimensionTree control labeled Choose a Resource Center listing a series of Responsibility Center dimension items:
In the Submit Budget button’s On_Click event we have made a call to the Workflow object’s SetProperty method to set the process instance’s RC property to be the value selected in the Resource Center (Responsibility Center) drop down box (DimensionTree.SelectedValue).

The following example shows how this might look in an example Button On_Click script:

```
SAP BusinessObjects Profitability and Cost Management Work Manager User Guide
Building a Process Definition
```
You can view the new property is included in the monitoring list by selecting Properties to Monitor from the context menu and selecting the new property.

Related Information

To produce Creation script using the Creation Script wizard [page 18]

4.6 Storing process definition changes

Once you are satisfied with a process definition you may store it on the database or you may save it to a file on disk, using the Export procedure. A process definition can also be saved as the default template to be used for new processes.

4.6.1 To save a process definition to the database

Context

To commit the current process to the database either:
Procedure

- Select File > Save from the main menu or
- Click the Save Process icon on the toolbar.

Results

If you edit a published version, then saving it will result in the version becoming the unpublished version, overwriting any previously stored unpublished version. To save the process to a file on disk you should use the Export function.

Related Information

To export a process definition to a file on disk [page 31]

4.6.2 To export a process definition to a file on disk

Context

To save the currently selected process definition to a file on disk:

Procedure

Select File > Export from the main menu.
A standard dialog box will be displayed allowing you to navigate to the place that you wish to store the file. Files can only be exported as .wmc files

Results

To retrieve an exported process definition, use the Import procedure.

Related Information

To import an exported process definition [page 32]
4.6.3 To import an exported process definition

Context

Files that have been saved as Work Manager process files (with a .wmc extension) can be loaded into Work Manager using the Import facility. Only files of this type can be loaded. To load an exported process definition:

Procedure

1. Select File \Import from the main menu.
2. A standard dialog box will be displayed allowing you to locate the file you wish to import.
3. Click the Open button to load the file into Work Manager.
   A loaded process will then appear in the Process Definitions list bar.

Results

Imported definitions will overwrite their destination process, so to produce a new process definition, rather than replace an existing process, .wmc files should be imported into a blank definition.

Related Information

To export a process definition to a file on disk [page 31]

4.6.4 To save a process definition as the default template

Context

Initially, the default.wmc file forms the template for the default structure of new processes. You can save any process definition as the default template by saving it as a .wmc file. The new template will then be used for all subsequent new processes. To save a process definition as the new default template:

Procedure

Select File \Save as default from the main menu.
A standard dialog box will be displayed allowing you to navigate to the place that you wish to store the template file.

4.7 Locking and unlocking process definitions

A process definition is locked by the user who opens it. It is shown as locked in the Process Definition List by a padlock symbol when viewed by the user who has it locked. It is shown with a cross in a red circle when viewed by other users. Locked process definitions can only be edited by the user who has locked them.

4.7.1 Automatically unlocking process definitions on closing the application

The Work Manager application can be set to check whether any process definitions open at the time of closure need to be unlocked before the application exits. To set this function, select Tools ➤ Check Locked on Close.

When this option is set, the application will display the Unlock dialog box before closing if there are any processes locked by the user on logging out.

The dialog box lists all locked process definitions and asks you to select which processes to unlock. To unlock a process, clear its adjacent check box. You can also use the Unlock All, Unlock None, and Toggle commands to manage locking and unlocking process definitions.

You can prevent this dialog box displaying by selecting the Don’t show this again check box on the Unlock screen itself.

Related Information

Closing down Work Manager [page 9]

4.7.2 To manually unlock an individual process definition

Context

To manually unlock an individual process:
Procedure

1. Select the process definition in the Process Definition List.
2. Select Unlock from the context menu.
   If the process is still open for editing, it will be automatically closed, and if you have made any changes you will first be asked if you wish to save them.

4.8 Printing a process definition

The currently open process definition can be printed to any installed printer or print device. A number of printing options are also available via the Print Preview function.

To open the print dialog for an open process definition:

- Either select File > Print from the Main menu
- or select the Print icon from the Work Manager toolbar

Selecting this function will open a standard print dialogue window where numerous printer options are provided.

4.8.1 Accessing Print Preview options

By selecting to preview a process definition print job (File > Print Preview) a number of printing options are presented in the Print Preview toolbar:

<table>
<thead>
<tr>
<th>Toolbar icon</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Print</strong></td>
<td>If you are satisfied with the layout and style of the print preview shown use this function to print the page(s) immediately.</td>
</tr>
<tr>
<td><strong>Print Dialog</strong></td>
<td>Displays the standard Print dialog box, allowing you to set printer preferences.</td>
</tr>
<tr>
<td><strong>Page Setup</strong></td>
<td>Displays a dialog box allowing you to change the paper type, orientation and other associated print layout parameters.</td>
</tr>
<tr>
<td><strong>Zoom to 100%</strong></td>
<td>Sets the view of the printable document to actual size.</td>
</tr>
<tr>
<td>Toolbar icon</td>
<td>Effect</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Zoom Page Width</td>
<td>Sets the view of the printable document to the full width of the screen.</td>
</tr>
<tr>
<td>Whole Page</td>
<td>Sets the document view so that the whole page can be seen on screen.</td>
</tr>
<tr>
<td>Two Pages</td>
<td>Sets the document view so that two pages can be seen on screen.</td>
</tr>
<tr>
<td>Multiple Pages</td>
<td>Sets the document view so that up to six pages can be seen on screen at the same time.</td>
</tr>
<tr>
<td>Zoom</td>
<td>Sets the view of the printable document to a user-defined custom size.</td>
</tr>
<tr>
<td>Shrink To Page</td>
<td>Sets the most appropriate zoom level (page size) so that the page fits the selected printer page size.</td>
</tr>
<tr>
<td>First Page</td>
<td>Navigates to the first page to be printed.</td>
</tr>
<tr>
<td>Previous Page</td>
<td>Navigates to the previous page to be printed.</td>
</tr>
<tr>
<td>Next Page</td>
<td>Navigates to the next page to be printed.</td>
</tr>
<tr>
<td>Last Page</td>
<td>Navigates to the last page to be printed.</td>
</tr>
<tr>
<td>Toolbar Icon</td>
<td>Effect</td>
</tr>
<tr>
<td>--------------</td>
<td>--------</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the <em>Print Preview</em> window and returns to the Work Manager application.</td>
</tr>
<tr>
<td>Close</td>
<td></td>
</tr>
</tbody>
</table>
5 Making a workflow available for operation

In order to make a process definition available to other users, the process must be published to the database. For the process definition to operate, it will also require the correct security levels to be configured, and the web books must contain scripting for it to interact with.

The Publishing wizard guides you through the publication process.

5.1 To publish a process definition

Context

Process definitions are published by using the Publishing Wizard.

Procedure

1. To initiate the wizard, open the required process definition.
2. Either:
   ○ Select File Publish from the main menu or
   ○ Click the Publish icon on the Work Manager toolbar.
   The Welcome screen will be displayed.
3. Click Next to continue.
   The Publish Process Definitions screen will be displayed.
4. You may choose which of the currently open process definition versions to publish by selecting or deselecting any of the definitions listed, or their associated versions.
   At least one version must be selected.
5. Click Next.
   The Version screen will be displayed.
6. Enter a description or name for the version of the process definition(s) that you have selected.
   If more that one process is being published then this Version Description will be given to all of the selections.
7. Click Next to continue.
   The Publish Now screen is displayed.
8. You now have your last opportunity to cancel publication, or to confirm your selections by clicking the Finish button.
   Once you click Finish, the wizard will close.
Results

The chosen version of the process definition is now available for reference in your scripts.

5.2 Configuring Security

Use the Model Builder application to establish security for your process. There must be at least one user group containing one user. Additionally you can create as many user or manager accounts or groups as you wish. The security settings required are:

- Users and Groups - There must be at least one group of users, and one manager account. All Work Manager specific accounts should also be members of the ENDUSERS group (NB: members of the ADMINISTRATORS group already have EndUser access).
- Group/Descriptor Assignments - Access can be granted to values and dimensions by user and manager group. It is recommended that access to the Process Definition Security descriptor is reserved to those with a role of process design, for example a single process administrator.
- Group/Default Book Assignments - Set the default books that users and managers will start with when they view the books via their browsers.

Note

If the list of security descriptors does not give you everything you need for your security setup you can create your own security descriptor that is tailored to your particular requirements.

5.3 Creating Books

Using the Model Builder application you can create the user interface for your Work Manager system. Application controls such as charts, grids, text, graphics, buttons and more can be added to a book to guide users through the process you have designed.

Using VBScript behind your books you can capture events such as clicking buttons in order to direct the process along the paths that you have defined in your process definitions. The Creation Script Wizard offers you the opportunity to create and copy script designed to initiate your Work Manager process.

Published books will be available via your web server. Each process can be uniquely referenced by building a URL or WAIS string to direct users (via e-mail) to a specific book used by the current published Work Manager process.

Related Information

Sample Book scripts [page 50]
Sample Links [page 51]
To produce Creation script using the Creation Script wizard [page 18]
6 Monitoring and debugging Workflow operation

Several Work Manager processes may be underway at any given time, and the participants may be at several disparate locations. The Work Manager application provides a mechanism to allow process administrators to stay abreast of changes to process states, and to monitor the number of users who are at a particular stage in the process.

It provides two in-built means of testing whether your process works as you expect: by creating and monitoring test data, and by tracking event debug messages in the Event Log.

The Audit Log provides a list of changes that have been made to processes by users and administrators.

6.1 To monitor a process workflow

Context

The process workflow is monitored in Monitor Mode.

Procedure

1. To switch to Monitor Mode click the Monitor button in the Work Manager toolbar. Only published processes are monitored and these will then be listed in the side list bar.

2. Select the required process to monitor either by double-clicking on the process or by selecting the required version from the right-click context menu. The workflow status is shown in the monitoring area at the bottom of the screen.

6.1.1 The Monitor Toolbar

The monitoring toolbar contains five buttons as listed below:

- **Monitor** - The monitor button toggles the graphic display screen between Design mode and Monitor mode.
- **Refresh** - To see the impact of any changes to the process status click the Refresh button.
- **Auto Refresh** - To have the monitoring process continually updated click on the Auto Refresh toggle button. Turning on Auto Refresh will update the status of any monitored processes at 10-second intervals until the feature is turned off.

- **Show Totals** – In the Monitor display screen this shows the number of users at each stage of the process in relation to the total number of process users.
- **Choose Properties** - To choose the property columns to add or remove from the process monitor list, click the Choose Properties button. These are the same properties listed in the Process Instance List.

### 6.1.2 The Process Monitor screen

In Monitor Mode the screen is divided into two views: the process flow diagram at the top showing the number of users at any stage, and the monitor list below the process diagram showing a list of users and the stage they are at in the process.

### 6.1.3 The Process Instance List

At the bottom of the Process Monitor screen is the Process Instance List. This is a list of the instances of a process that are currently in existence. Details of the instances are listed under columns such as Instance ID, State, Model Name, and User Name.

The users listed in the Process Instance List are those users who are active in the current process. Users that have completed the process (that is, those that have triggered an event containing the WorkflowComplete function – see “Work Manager Process Functions” in the Profitability and Cost Management Modeling Reference Guide) are removed from the list automatically.

The amount of information that is provided in this list is configurable, because columns can be added or removed. The columns available are those that have been defined in code within the process being monitored (by use of the ObjectProperty function – see Work Manager Process Functions in the Profitability and Cost Management Reference Guide).

To add a Property to the list select Choose Properties to monitor from the context menu.

A Filter option is also available to provide control over the instances that are displayed.

Instances (identified by their Instance ID) can be tracked as they move around the process. To bring up the Monitor Instance(s) screen, double-click any State Object in the process designer that has a user against it.

The dialog box that displays has an Instances tab that displays all instances that are in the currently selected state, and shows the same information as you have configured to see in the Process Instance List.

To move a user instance from one state to another you can trigger the appropriate event by selecting the event from the Trigger Event list and then clicking the Trigger Event Now button. If you want to follow a particular instance from one state to another, select the check box named Follow Instance(s). This will move the focus of the Monitor Instances screen to the state that the selected user is now in after the event has been triggered.

### Related Information

- Configuring Object Properties [page 26]
- Filtering the Process Instance List [page 42]
6.1.4 Filtering the Process Instance List

In the Process Instance List the Show all instances option is selected by default. This allows you to see all of the process instances that are running at the time. To reduce the listed items to a subset, you can apply a filter using criteria from any of the currently visible columns. The columns that appear in the list can be changed by right-clicking in the list area and selecting Choose properties to monitor.

- **Set Filter** - Clicking the Set Filter button in the Process Instance List opens up the Filter dialog box. In this box you can select any of the currently available columns in the Properties pane on the left-hand side, and in the adjacent Value edit box you can then set a value that you want the data in the list to match. Wild card characters, such as the asterisk, are not currently recognized.

- **Clear Filter** - To clear any currently applied filters, click the Clear button in the Process Instance List. This has the effect of showing all instances without any filtration.

6.2 To create workflow test data

Context

In order that your process definition functions as you have designed it, you should create some test instances that you can move through the process from state to state, testing each of the events.

Procedure

1. In Monitor mode select the Created object.
2. From the right-click context menu select Create Test Data to initiate the Create Test Data wizard. The Welcome screen will be displayed.
3. Click Next to continue. The Creation Data screen will be displayed.
   - This screen is the same as the Creation Script Wizard’s Creation Data screen.
4. Select a model from the current list of available models.
   - Both the Manager ID and the User Group are users that have been set up in the system already. When choosing your user group you can choose to select a predefined group, or to create a custom list of users from any or all available user accounts.
5. Click Next to continue. The Completing screen completes the Create Test Data Wizard.
6. Click Finish.
   - A confirmation message will inform you about the creation of the test data.
Results

The test instances will be displayed in the Monitor list at the bottom of the Monitor window. The test instances can now be used to ensure that each event performs correctly, and that the users move around from state to state as expected without the requirement to initiate and trigger the process from a book.

6.3 The Event Log

The Event Log displays any system messages that arise as a result of running the Process Definitions you have defined. In addition, it displays any Debug Messages that you have created, or inserted into your script.

To view the Event Log select View Event Log from the Main menu bar.

Messages can be cleared using the Clear Events function, available by invoking the right-click context menu. If you wish to keep a record of the messages you can save them to a text file (*.txt) using the Save events to file function from the same context menu.

Related Information

Debug Messages [page 23]
Using the Event Log [page 53]

6.4 The Audit Log

To see a list of changes that have been made to processes by users and administrators you can call up the Audit Log screen (View View Audit). The Audit Log is a list of the events that have been triggered during the execution of a Work Manager process.

The details of the events are listed in columns such as Id, Definition Name, Version Name, Instance ID, Action Description, User Name, and Update Date. You can select which process definitions and versions to display from the Process Definition and Version drop-down lists.

The type of event logged can be configured using the Profitability and Cost Management Configure program, and the Audit Log can be filtered to show only the events that you choose.

6.4.1 Configuring auditable events

To choose which system-defined Work Manager events you want to track start the Profitability and Cost Management Configure program and choose to reconfigure Work Manager.
Running through the configuration program whilst the Work Manager application is open will involve restarting the WM service with possible undesirable consequences for any open process definitions. It is therefore recommended that you close Work Manager before reconfiguring.

After selecting to reconfigure Work Manager the Work Manager Options screen is displayed.

In the screen, click the Configure button described as Auditing options. The Set Work Manager Audit options dialog box displays a list of WorkManager events as follows:

- Create Workflow
- Get Property
- Set Property
- Get ID from Name
- Is Valid Workflow
- Send Event
- Create Instance
- Instance Complete

Select the check box for an event to have Work Manager audit that event. The events selected in this screen will be shown as columns in the Audit Log screen.

The events listed in this screen correspond to the object methods available to anyone who scripts a Work Manager process (for more information on these methods, refer to “Work Manager Process Functions” in the SAP BusinessObjects Profitability and Cost Management Modeling Reference Guide).

Related Information

The Audit Log [page 43]

6.4.2 Filtering audited events

The list of events shown in the Audit Log screen can be filtered to show only those events that match your chosen criteria. This can be done using the two lists and the three filter buttons presented at the head of the list. The lists allow you to quickly select the process definition and version of events that you want to be shown. The filter buttons can then be used to set further criteria for reducing the events shown.

Clicking the Choose Filter button will present the Filter screen for this purpose.

In the Fields pane, you can select any of the currently available columns, and in the adjacent edit box you can then set a value that you want the data in the list to match. Wild card characters, such as the asterisk, are not currently recognized.
7 Customizing Work Manager Scripts

Work Manager makes full use of the VBScript capabilities that are built into the product, allowing designers full control over their actions, processes, and events.

7.1 Using Work Manager functions

Some of the parameters of the Work Manager functions have a particular context of use. The Work Manager functions are all fully described in the SAP BusinessObjects Profitability and Cost Management Modeling Reference Guide - “Work Manager Process Functions”.

7.1.1 The Workflow Type

The Workflow Type identifies a specific Workflow Process Definition.

7.1.2 The Workflow Identifier

The Workflow identifier (referred to in Work Manager as the Instance ID) is an identifying number that provides a unique reference to a specific Workflow process. It can be addressed from external code such as a book script, or a URL, or used internally to reference the current workflow instance in use.

7.1.3 Expiry Timeout Values

Any state in a Work Manager process can have a timeout value associated with it. This means that states can be set to expire after a set period of time. An example of this might be that a user has to complete a timesheet before 5:00pm on Friday. An event can then be coded to perform an action as a consequence of an expiry, or a different action if the timeout was not exceeded.

The functions concerned with setting and clearing timeout values are: SetTimeoutDelta and ClearStateTimeout. To set an expiry time call the SetTimeoutDelta function within an event that subsequently actions a change in state. This new state will then have an expiry value set against it. A new event is then triggered if the timeout expires. If a timeout value has not expired you will need to clear the timeout relating to the current state before moving to a new state. This is achieved using the other timeout function ClearStateTimeout. This must be enacted before moving to the new state because the timeout value relates to the current state.
7.2 Managing Console jobs

If you wish to execute processes as part of a user workflow, you can create script that runs a job in SAP BusinessObjects Profitability and Cost Management Console. The script instructs Console to initiate a command file, using values that have been passed from Work Manager. These values can be input into a book by a user, and passed through Work Manager to the Console job.

A template Console command file is also required, to work in conjunction with the script. The Work Manager functionality copies the template command file to create a temporary file, substituting the contents of the current Work Manager instance's properties for required Console parameters. It passes the Work Manager Instance ID to Console and instructs it to run the temporary command file. It deletes the temporary file after use. The Work Manager server must have write access to the directory where the template command file is held.

7.2.1 Console Template Command File

The Console template command file contains Console commands and parameters to execute the required processes. It also includes commands for Console to communicate with Work Manager. For information on all Console commands and how to create a command file, refer to SAP BusinessObjects Profitability and Cost Management Console User Guide.

In the template file, parameters to be substituted are denoted by #property:Propertyname# where Propertyname = the current Work Manager instance's property to be substituted as the Console parameter.

**Note**
The property Propertyname is case sensitive.

**Example**
If the property MODELNAME contains the value Model1, the template command newmodel=#property:MODELNAME# would be replaced by newmodel=Model1 in the temporary Console file.

7.2.2 Console Job Execution Script

To initiate a Console job, the function startConsoleJob is required (see SAP BusinessObjects Profitability and Cost Management Modeling Reference Guide for details).

The instance properties must also be specified to enable property replacement in the temporary command file.

Each workflow instance may execute only one console job at any one time: each job must be finished (either completed successfully or with an error) before another can be initiated.
7.2.3 Console Error Handling

The Console job can send workflow events to Work Manager, to enable you to track progress if more than one process is executed. If Console encounters an error while executing a command, it generates an error text containing a specific number reflecting the command type. If a valid Work Manager connection and Instance ID both exist, then the event ConsoleError is sent to the Work Manager instance, and the property ConsoleErrorText is populated with the error text. (The text format and error numbers are detailed in SAP BusinessObjects Profitability and Cost Management Console User Guide - “Console error messages”.)

```plaintext
Dim ConsoleError
ConsoleError = ObjectProperty (InstanceId, "ConsoleErrorText")
```

7.3 Example scripts

Examples of each of the objects in Work Manager that can be scripted are:

- Global variables
- Creation scripts
- Connection scripts
- Example Book scripts
- Example URL

**Note**

A full description of all functions available in these scripts can be found in the SAP BusinessObjects Profitability and Cost Management Modeling Reference Guide - “Work Manager Process Functions”.

7.3.1 Global variables

Global variables and functions should be placed at the head of any previously defined functions, as these will be initialized first and will become generally available to all your other functions.

In this example a number of constants are defined so that you can then refer to them by name throughout the scripting process:

```plaintext
Const WebServer = "http://mymachinename/
Const blankString = ""
Const EstimateBook = "Estimate Budget"
Const ReviseBook = "Revise Budget"
Const ApproveBook = "Approve Budget"
```
The server specified in the example above is a web server. If you are using IIS as your web server, then the example would be:

```
Const WebServer = "http://mymachinename/PCM"
```

Any functions that you want to be available generally should be defined (outside of any function or subroutine).

### 7.3.2 Creation scripts

The Creation Script is always performed within an **EPOWorkflow_CreateWorkflow** function that informs the Work Manager that a new instance of the process should be created.

This example also shows how to send debug information to the Event Log, the use of a list of users to send to multiple e-mail addresses, and how to set the next event in the process.

```vbs
Sub EPOWorkflow_CreateWorkflow (WorkflowType, CreationData)
    'WorkflowType - this is the number identifying the process definition
    'CreationData - this is a Variant Array of Variants containing data for creating specific process instances
    'Declare temporary variables explicitly
    Dim ModelName, ManagerName, GroupName
    Dim GroupUserIDList, UserName
    Dim i, iMin, iMax, InstanceId
    DebugLogEvent True, "Creating process instances for workflow type : " & WorkflowType & " at " & Now()
    'Model Name is passed in as parameter 0
    ModelName = CreationData(0)
    'Manager Name is passed in as parameter 1
    ManagerName = CreationData(1)
    'List of users is passed in as parameter 2
    'Determine how many users have been specified
    If IsEmpty (CreationData) = False Then
        iMin = lbound (CreationData)
        iMin = iMin + 2
        iMax = ubound (CreationData)
    'Iterate for all users in group and create a process instance
    For i=iMin to iMax
        InstanceId = CreateWorkflowObject(workflowType)
        'Write this data back to database as properties so that can reference them in other event functions
        ObjectProperty (InstanceId, "ModelName") = ModelName
        ObjectProperty (InstanceId, "ManagerID") = GetIDForUserName(ManagerName)
        ObjectProperty (InstanceId, "ManagerName") = ManagerName
        UserName = CreationData(i)
        ObjectProperty (InstanceId, "UserID") = GetIDForUserName(UserName)
        ObjectProperty (InstanceId, "UserName") = UserName
        'Trigger next event to proceed to next state
        SetNextEvent InstanceId, "Email Users Budget"
    Next
End If
End Sub
```
### 7.3.3 Connection scripts

The purpose of connection scripts is to define the event that triggers the movement from one state to another. This trigger may be a timeout value (a state expires after a set length of time), or it may be the action of a user (such as clicking a button on a book).

In the example below, a new budget process has been started which causes an e-mail to be sent to all the users asking them to check their budget figures. This example also demonstrates how to set an expiry value so that if the user does not take an action within a specified time then a further action will result.

**Sub Email_Users_Budget(InstanceId)**

'InstanceId - this is the unique number that identifies this process instance
Send an e-mail to a PCM user

Dim SendTo, SendFrom, SendCC, Subject, Body
SendTo = EmailAddressForProperty(InstanceId, "UserID")
'E-mail to the user id specified in Property UserID
SendFrom = EmailAddressForProperty(InstanceId, "ManagerID")
'Create E-mail as if it was sent by this user specified in
property ManagerID

E-mail information is specified in the subject and body

Subject = "Please complete your budget"
Body = "Dear #Property:UserName#, & vbCRLF
Body = Body & "" & vbCRLF
Body = Body & "A new budget
process has started (#InstanceId#)." & vbCRLF
Body = Body & "Please complete
your budget by going to the web book below:" & vbCRLF

Append this e-mail with a URL to a book

Dim  ModelName, BookName
ModelName = ObjectProperty (InstanceId, "ModelName")
'Model Name is specified in property ModelName
'URL is to launch PCM webserver open book User Sets Budget.
'BuildBookURL will create link that will open book in web browser whilst
'BuildBookViewerString will create link or attachment that will work though
Outlook.
BookName = "User Sets Budget"
Body = Body & vbCRLF & BuildBookURL (InstanceId, WebServerRoot, ModelName, BookName)
Body = Body & vbCRLF & BuildBookViewerString (InstanceId, office
wfEmailAttachmentAndWais,
"ebklinkname", ModelName, BookName, "optional string")
'The type of link created by the BuildBookViewerString is 'determined by one of
three constants;
'wfEmailWais WAIS link only
'wfEmailAttachment Attachment in form of .ebk file only
'wfEmailAttachmentAndWais Both WAIS link and attachment

Now use the built in function to send email SendEmail ID, To, CC, From, Subject, Body

SendEmail InstanceId, SendTo, SendCC, SendFrom, Subject, Body

Create an expiry that expires after a certain interval, 0 days 0 hours 10 minutes

SetTimeoutDelta InstanceId, 0, 0, 10, 0 , "Incomplete Budget"
7.3.4 Sample Book scripts

The scripts behind books capture the actions of users and managers (clicking buttons, amending data, and so on) and initiate Work Manager events on the basis of these actions. Events that may be used include: OnClick, OnLoad, OnChange and OnDoubleClick.

Here is an example of how to start a Work Manager process from a book script:

```
'Example Book Creation Function
Sub Button_OnClick()
    'Declare variant array to pass data in with
    Dim  CreationData(3)
    'Pass in Model Name
    CreationData(0) = "General Test"
    'Pass in Managers Name
    CreationData(1) = "MTAdmin"
    'Pass in User Group
    CreationData(2) = "ENDUSERS"
    EPOWorkflow.CreateWorkflowByName "Sample Process", CreationData
    MsgBox("Work Manager process started")
End Sub
```

In this script we create an array of data that we wish to pass as parameters to the Workflow Service (the service dealing with workflow communications). We pass the array to the named workflow using the StartWorkflowByName method of the EPOWorkflow object (see note below).

**Note**

You MUST have a Workflow Object included in the list of controls on your book in order to communicate with the workflow service.

In the example below the budget has been revised by the user and is ready to be sent back to the manager for checking. Users click on a *Ready* button in the web book that invokes the *Revise Estimated Budget* event within Work Manager:

```
Sub Button_OnClick()
    Dim msg
    'Enter Work Manager code here to send the budget back
    EPOWorkflow.sendEvent "Revise estimated budget"
    Msg = "Your budget figure has been sent to your manager."
    Msg = Msg & vbCrLf & "Please await a reply."
    MsgBox msg
End Sub
```
7.3.5 Sample Links

It is possible to link a user directly from a Work Manager e-mail to a book in a number of ways. Functions within the scripts will create either an embedded Uniform Resource Locator (URL) which opens a specific book in a web browser or either a WAIS link or EBK file attachment that will do the same in Book Viewer. URLs are constructed by the function BuildBookURL (see example 1) whilst the function BuildBookViewerString does the same for WAIS links and or attached EBK files (example 2).

**Example 1**
http://mymachinename/?B=Revise%20Budget&M=WM1&WF=13

**Example 2**
waiss:B=Revise%20Budget&M=WM1&WF=13

http:// is the standard prefix for browser addresses;

waiss prefix used to denote a Book Viewer link;

mymachinename replace with the name of your web server;

? denotes the start of the parameters (separated by an ampersand);

B= is the parameter for the book name;

M= is the parameter for the model name;

WF= is the parameter for the Workflow Identifier

It is possible to add additional parameters to both types of links that control on what server and how a book will open. These are comprehensively documented in the Profitability and Cost Management User Help (see Book Navigation or URL Format). Additional parameters added to the URL using the BuildBookURL function should be concatenated to the end of the BookName variable before being passed to the function. However the BuildBookViewerString requires any additional parameters to be passed, in string format, as the last parameter in the function.

Related Information

The Workflow Identifier [page 45]
8 Troubleshooting Tips

Some of the areas of the Work Manager application that you may need additional help in setting up are:

- Installation & configuration
- Integrating with e-mail services
- Designing new processes
- Debugging with using the Event Log
- Common Work Manager errors

Help on these topics is also available in the following documentation:

- SAP BusinessObjects Profitability and Cost Management Installation Guide

8.1 Installation & Configuration

Work Manager is installed as part of the Profitability and Cost Management application. Before you can begin to design a Work Manager process, several prerequisite components must be in place:

- Access to a dedicated Oracle or SQL Server database
- Access to a supported mail server
- Security must be configured to allow access to the application

For detailed instructions on how to install Work Manager, please refer to the SAP BusinessObjects Profitability and Cost Management Installation Guide.

**Note**

Reconfiguring Work Manager will shut down and restart the Work Manager service. This will terminate any currently running processes on the server machine. It is recommended that you close the Work Manager application prior to any reconfiguration.

8.2 Integrating with E-mail Services

In order to be able to communicate between users of the Work Manager system you will need to configure a mail server. Work Manager mail supports integration with any mail system that is capable of using the SMTP protocol for sending and receiving messages.
8.3 Designing New Processes

Some common problems associated with creating, designing and publishing Work Manager process definitions are:

- **Locked Process Definition** - If a process definition cannot be opened, and an error message states that it is locked by another user, then the process is currently being edited by the user specified in the error message. It can be unlocked only by the person who is currently editing it.
- **Cannot open a Process Definition** - Either the process is locked by another user (see above) or you do not have sufficient access rights configured. See your Profitability and Cost Management Administrator for a resolution, or check the Security settings.

8.4 Using the Event Log

The Work Manager Event Log is a dockable window that provides a view of any messages that arise as a consequence of running a Work Manager process instance. The following types of messages may appear in the Event Log window:

- Scripting error messages
- User-defined debug messages
- System-generated error information

Related Information

The Event Log [page 43]

8.4.1 Scripting error messages

Any error messages that result from an attempt to execute the script behind a Work Manager process will appear in the Event Log window.

Error messages are specific to the process instances that generated them, so if you have several process instances that are generated from a single process definition you may see several similar error messages.

Double-clicking an error message will open up the script at the point where the error was reported, allowing you to debug the script quickly and easily. A full list of VBScript error messages can be found at the Microsoft VBScript Site.

The Work Manager process instance will display error messages as they are encountered. It is recommended you use the Create Test Data feature to ensure that your process works at each stage.
Related Information

To create workflow test data [page 42]
Microsoft VBScript web site

8.4.2 User-defined debug messages

There are two methods for getting more information concerning the status or value of variables in your scripts: Debug messages and Message Boxes.

Work Manager scripts have a function called DebugLogEvent. This can be used to place helpful status messages into the Work Manager Event Log. These messages will appear when the script containing the function has been called. If you do not see these messages in the Event Log then you know that the script containing the Debug function has not been executed yet – possibly due to an error occurring before the call, or because the event is not being triggered as you expected.

Book scripts have a function called MsgBox that will display a visual message in a popup box. This is useful for immediate feedback within the Model Builder application.

8.4.3 System-generated error information

Error messages will appear in the Alerts screen of the Model Builder application, and can be useful in determining the source of problems associated with the status of calculation, assignments and rules within a model.

8.5 Common Work Manager errors

In the case of any function not working as expected you are advised to first check the server’s Event Log. Listed are some of the most frequent messages you may encounter and their resolutions:

- The Remote Procedure call failed and did not execute.
  This occurs whenever the Work Manager Service (PCMWorkManagerService) is not available. This may be due to a connection problem between the client and server, or that the service did not start properly.

- The RPC Server is unavailable.
  If the PCMServer service is not running this message will appear upon most actions within Work Manager. This can be confirmed by a message in the server’s Event Log stating PCM Main : Server Quit Message Posted. The service must be restarted before Work Manager will respond.

- No e-mails are received when a new process is started.
  Use the Profitability and Cost Management Configure process to check your Work Manager e-mail server settings (SMTP) for the correct IP address and port settings. Ask your System Administrator about any known e-mail server problems. See the “Integrating with E-mail Services” topic.

This means that the mailbox to which you are trying to send a message is not recognized. One of the reasons for this may be that you have not correctly configured the SMTP Server name or IP address. Use the Profitability and Cost Management Configure process to check and/or correct this. Any changes made to settings will require the Work Manager application to be restarted.

Related Information

Integrating with E-mail Services [page 52]
Important Disclaimers and Legal Information

Coding Samples

Any software coding and/or code lines / strings ("Code") included in this documentation are only examples and are not intended to be used in a productive system environment. The Code is only intended to better explain and visualize the syntax and phrasing rules of certain coding. SAP does not warrant the correctness and completeness of the Code given herein, and SAP shall not be liable for errors or damages caused by the usage of the Code, unless damages were caused by SAP intentionally or by SAP’s gross negligence.

Accessibility

The information contained in the SAP documentation represents SAP’s current view of accessibility criteria as of the date of publication; it is in no way intended to be a binding guideline on how to ensure accessibility of software products. SAP in particular disclaims any liability in relation to this document. This disclaimer, however, does not apply in cases of wilful misconduct or gross negligence of SAP. Furthermore, this document does not result in any direct or indirect contractual obligations of SAP.

Gender-Neutral Language

As far as possible, SAP documentation is gender neutral. Depending on the context, the reader is addressed directly with "you", or a gender-neutral noun (such as "sales person" or "working days") is used. If when referring to members of both sexes, however, the third-person singular cannot be avoided or a gender-neutral noun does not exist, SAP reserves the right to use the masculine form of the noun and pronoun. This is to ensure that the documentation remains comprehensible.

Internet Hyperlinks

The SAP documentation may contain hyperlinks to the Internet. These hyperlinks are intended to serve as a hint about where to find related information. SAP does not warrant the availability and correctness of this related information or the ability of this information to serve a particular purpose. SAP shall not be liable for any damages caused by the use of related information unless damages have been caused by SAP’s gross negligence or wilful misconduct. All links are categorized for transparency (see: http://help.sap.com/disclaimer).