Developer

Environment Prerequisites

Set up your development environment to build and run applications that rely on extensibility features.

  • An Intel-based Mac with Mac OS X Lion or (preferably) Mountain Lion
  • The latest official iOS SDK (as of this writing, version 7.1 with Xcode 5.1)
  • (Optional) To install and run the app on a real device, you need a developer account and the iOS developer certificates that are available in the MAC OS X keychain.
  • Before you create an application, identify the screens you want customers to customize, or extend by configuration.