SAP® Transportation Management 9.4
Setting Up the SAP TM collaboration portal
Caution
Before you start the implementation, make sure you have the latest version of this document. You can find the latest version at the following location: service.sap.com/instguides > Installation & Upgrade Guides > SAP Business Suite Applications > SAP TM > Using SAP TM 9.4

The following table provides an overview of the most important document changes.

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>2016-11-11</td>
<td>Initial Version</td>
</tr>
</tbody>
</table>
# Content

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Introduction</td>
</tr>
<tr>
<td>2</td>
<td>SAP TM collaboration portal</td>
</tr>
<tr>
<td>3</td>
<td>System Landscape and Deployment Options</td>
</tr>
<tr>
<td>3.1</td>
<td>Products and Components Overview</td>
</tr>
<tr>
<td>3.2</td>
<td>Deployment Options</td>
</tr>
<tr>
<td>3.3</td>
<td>Important SAP Notes</td>
</tr>
<tr>
<td>3.4</td>
<td>System Requirements</td>
</tr>
<tr>
<td>4</td>
<td>Installation</td>
</tr>
<tr>
<td>4.1</td>
<td>Installation Sequence</td>
</tr>
<tr>
<td>4.2</td>
<td>Installation of SAP Gateway</td>
</tr>
<tr>
<td>4.3</td>
<td>Installation of Software Component Version SAPTMUI 150</td>
</tr>
<tr>
<td>4.4</td>
<td>Installation of Reverse Proxy / SAP Web Dispatcher</td>
</tr>
<tr>
<td></td>
<td>OData and HTTP Methods</td>
</tr>
<tr>
<td></td>
<td>URL Rewriting</td>
</tr>
<tr>
<td></td>
<td>SAP Web Dispatcher</td>
</tr>
<tr>
<td>5</td>
<td>Configuration</td>
</tr>
<tr>
<td>5.1</td>
<td>Configuring SAP Business Suite Components</td>
</tr>
<tr>
<td>5.2</td>
<td>Configuring SAP NetWeaver Gateway 2.0 Components</td>
</tr>
<tr>
<td>5.3</td>
<td>Adding Customer Enhancements</td>
</tr>
<tr>
<td>5.4</td>
<td>Activating ICF Nodes</td>
</tr>
<tr>
<td>5.5</td>
<td>Configuring Map Display</td>
</tr>
<tr>
<td>5.6</td>
<td>Setting Up File Upload</td>
</tr>
<tr>
<td>5.7</td>
<td>Integration into the SAP NetWeaver Portal</td>
</tr>
<tr>
<td>5.8</td>
<td>Defining a Theme for the SAP TM collaboration portal</td>
</tr>
<tr>
<td>5.9</td>
<td>Making Default Settings for Carriers</td>
</tr>
<tr>
<td>6</td>
<td>Security</td>
</tr>
<tr>
<td>7</td>
<td>Monitoring</td>
</tr>
<tr>
<td>8</td>
<td>Support</td>
</tr>
</tbody>
</table>

© Copyright 2016 SAP SE or an SAP affiliate company. All rights reserved.
1 Introduction

Welcome to the SAP Transportation Management collaboration portal (SAP TM collaboration portal), an easy-to-use Web application. This application is designed as a Web application running on a desktop or a tablet device, accessed using a URL.

You can now start setting up your solution.

About this Document

Use the Administrator’s Guide as the central starting point for your implementation and monitoring activities.

This document provides information about the following topics:

- An overview of the SAP TM collaboration portal
- An overview of the system landscape and the relevant software components
- How to set up your solution
- System security
- Monitoring system tasks after you go live
- Support

Target Audience

This guide is intended for anyone who performs administrative functions for companies that are in the process of setting up the SAP TM collaboration portal.

It is also relevant for consultants assisting companies during the initial setup.

Important Documents

The following table lists all the important documents mentioned in this guide and their location:

<table>
<thead>
<tr>
<th>Document</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latest versions of installation and upgrade guides</td>
<td>service.sap.com/instguides</td>
</tr>
<tr>
<td>Sizing, calculation of hardware requirements such as CPU, disk and memory resource – with the Quick Sizer tool</td>
<td>service.sap.com/quicksizer</td>
</tr>
<tr>
<td>Released platforms and technology-related topics such as maintenance strategies and language support</td>
<td>service.sap.com/platforms</td>
</tr>
<tr>
<td></td>
<td>To access the Platform Availability Matrix directly, enter service.sap.com/pam.</td>
</tr>
<tr>
<td>Network Security</td>
<td>service.sap.com/securityguide</td>
</tr>
<tr>
<td>High Availability</td>
<td><a href="http://www.sdn.sap.com/irj//sdn//ha">www.sdn.sap.com/irj//sdn//ha</a></td>
</tr>
<tr>
<td>Performance</td>
<td>service.sap.com/performance</td>
</tr>
<tr>
<td>Document</td>
<td>Location</td>
</tr>
<tr>
<td>-------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>patch level requirements</td>
<td></td>
</tr>
<tr>
<td>Information about Unicode technology</td>
<td><a href="http://www.sdn.sap.com/irj/sdn//i18n">www.sdn.sap.com/irj/sdn//i18n</a></td>
</tr>
<tr>
<td>General information about freight order management</td>
<td>help.sap.com/tm &gt; SAP Transportation Management &gt; SAP Transportation Management 9.4 &gt; Application Help &gt; SAP Transportation Management &gt; Freight Order Management</td>
</tr>
<tr>
<td>Freight Tendering</td>
<td>help.sap.com/tm &gt; SAP Transportation Management &gt; SAP Transportation Management 9.4 &gt; Application Help &gt; SAP Transportation Management &gt; Freight Order Management</td>
</tr>
</tbody>
</table>

**Further Useful Links**

**Table 3**

<table>
<thead>
<tr>
<th>Content</th>
<th>Location on SAP Service Marketplace</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP Notes search</td>
<td>service.sap.com/notes</td>
</tr>
<tr>
<td>SAP Software Distribution Center (software download and</td>
<td>service.sap.com/swdc</td>
</tr>
<tr>
<td>ordering of software)</td>
<td></td>
</tr>
<tr>
<td>SAP Online Knowledge Products (OKPs) – role-specific</td>
<td>service.sap.com/rkt</td>
</tr>
<tr>
<td>Learning Maps</td>
<td></td>
</tr>
</tbody>
</table>
2 SAP TM collaboration portal

With the SAP Transportation Management collaboration portal (SAP TM collaboration portal), portal users can view and process SAP TM business documents from their desktop and tablet devices. The solution enables them to do the following:

- Access freight requests for quotation and create freight quotations
- Check freight invoices created by the shipper and accept or reject them
- Process disputes with freight invoices
- Create credit memos for existing invoices
- Process freight agreement RFQs
- View freight agreements and request rate changes for calculation sheet items
- Access freight orders for execution and report events or discrepancies
- Confirm freight orders and provide driver and vehicle information

Supported Browsers on Windows

- Microsoft Internet Explorer 8 or higher
- Mozilla Firefox
- Google Chrome

Supported Browsers on Mac OS

- Apple Safari

Supported Tablets with Supported Browsers

- Safari on Apple iPad

More Information

For more information about Web browser platforms, see SAP Service Marketplace at [service.sap.com/pam](http://service.sap.com/pam). Enter **SAP NetWeaver 7.4** in the search field, then choose **SAP NetWeaver 7.4 > Technical Release Information > Web Browser Platforms**.
3 System Landscape and Deployment Options

This section provides an overview of the high-level system landscape and key components required for the SAP Transportation Management collaboration portal (SAP TM collaboration portal).

3.1 Products and Components Overview

This section provides details about the products and components that comprise the system landscape for the SAP Transportation Management collaboration portal (SAP TM collaboration portal).

**SAP Business Suite**

- **SAP TM 9.4**
  An SAP TM 9.4 system is required to run the underlying transportation management scenarios. In this guide, it is assumed that you already run such a system within your SAP Business Suite environment, as well as a SAP NetWeaver AS ABAP 7.40.

- **SAP TM software component SAPTMUI**
  The SAP TM software component SAPTMUI, deployed on the application back-end system or Gateway system provides the user interface and front-end logic of the SAP TM collaboration portal.
  The software component SAPTMUI must have the same support package (SP) level as that of the underlying SAPTM component.

- **SAP NetWeaver Component SAP_GWFND**
  The SAP NetWeaver component SAP_GWFND (SAP Gateway Foundation 7.40), deployed on the application back-end system, establishes the communication between the Gateway system and the application back end for the purpose of OData provisioning and push functions.

- **SAP NetWeaver Component SAP_UI**
  The SAP NetWeaver component SAP_UI (User Interface Technology 7.40) deployed on the application back-end system provides the relevant libraries to render the user interface for the Web interface.

**SAP Gateway**

The Gateway system uses OData services to provide back-end data and functions. It also processes HTTP(S) requests for OData services.

**Demilitarized Zone (DMZ)**

A Demilitarized Zone (sometimes referred to as a perimeter network) is a physical or logical subnetwork that contains and exposes an organization’s external-facing services to a larger untrusted network, usually the Internet. The purpose of a DMZ is to add an additional layer of security to an organization’s LAN as an external attacker only has access to equipment in the DMZ, rather than any other part of the network.
Reverse Proxy / ABAP Web Dispatcher

The ABAP Web Dispatcher is needed to translate the traffic from the internet to the internal system landscape. As modern browsers check for violations of the Same-origin-Policy, the Web dispatcher acts as a single point of access and dispatches the calls to the Gateway services and to the UI sources respectively. It also acts as a URL filter to only allow through the URLs needed for the SAP TM collaboration portal.

Example Architecture

The SAP TM collaboration portal is another consumption channel of existing SAP TM back-end functionality. The back-end users of the company hosting the portal (customers of SAP TM) are working in the SAP TM Web Dynpro application to tender their freight orders or to create freight invoices. These business objects can be accessed by the portal user of the carrier (business partner of the SAP TM customers) in the SAP TM collaboration portal. It can be accessed through the internet from a desktop or tablet browser and enables the carrier to respond to freight requests for quotations.

The browsers render the SAP UI5 sources which are stored as Business Server Pages (BSP) in the Gateway system. The BSP application just acts as a container. The business data itself is stored in the SAP TM back-end system and is accessed through the Gateway. To be able to consume the data in an appropriate way, the consumption model is defined in the Gateway adapter.

3.2 Deployment Options

The SAP Transportation Management collaboration portal (SAP TM collaboration portal) is deployed as a Web application using a browser and is launched from the browser using an internet scenario. It can be launched from a desktop computer or a tablet device.
SAP Gateway: Central Hub or Embedded Deployment

You can install the Gateway components together with your back-end components as follows, either in a standalone system separated from your back-end system components (central hub deployment) or in one system (embedded deployment):

- **Central Hub Deployment**
  The Gateway core components can be deployed in a standalone system, either behind or in front of the firewall. In addition, you can install the optional components for central hub deployment in your standalone system.

- **Embedded Deployment**
  The core components for SAP Gateway and any optional back-end components are deployed together in the SAP Business Suite back-end system. For this deployment option, you need a back-end system only, without a dedicated Gateway central hub system.

For more information, see SAP Library for SAP NetWeaver Gateway 2.0 Support Package Stack (SPS) 09 or higher on SAP Help Portal at help.sap.com/nwgateway20 > Application Help > Support Package Stack 09 > SAP NetWeaver Gateway > SAP NetWeaver Gateway Master Guide > Deployment Options and Embedded Versus Hub Deployment.

**Deployment Option 1: Central Hub Deployment in DMZ, SAPTMUI on central hub**

This is the recommended deployment option. The SAPTMUI component is installed on the Gateway server and the Gateway server is placed in the DMZ.
Deployment Option 2: Central Hub Deployment behind Firewall, SAPTMUI on central hub

Similar to deployment option 1, the SAPTMUI component is installed on the Gateway server and the Gateway server is placed in the corporate network.

Deployment Option 3: Central Hub Deployment behind Firewall, SAPTMUI on SAP TM back end

Figure 3: Deployment Option 2: Central Hub Deployment behind Firewall, SAPTMUI on central hub

Figure 4: Deployment Option 3: Central Hub Deployment behind Firewall, SAPTMUI on SAP TM back end
The SAPTMUI component is installed on the SAP TM back end and the Gateway server is placed in front of the TM system.

Deployment Option 4: Embedded Deployment, SAPTMUI on SAP TM back end

All components are installed on the SAP TM instance.

### 3.3 Important SAP Notes

This section provides an overview of the notes relevant for the SAP Transportation Management collaboration portal (SAP TM collaboration portal).

<table>
<thead>
<tr>
<th>SAP Note Number</th>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1697835</td>
<td>Consulting note for tendering</td>
<td>Contains consulting instructions on how to set up tendering</td>
</tr>
<tr>
<td>1930822</td>
<td>UI5 Text Repository: field symbol not assigned</td>
<td>Contains corrections for retrieving front-end texts from the ABAP back end</td>
</tr>
<tr>
<td>1893788</td>
<td>Conversions in SAP NetWeaver Gateway Framework</td>
<td>Contains corrections for conversion exit handling in SAP Gateway</td>
</tr>
<tr>
<td>1932303</td>
<td>740SP05: $batch with several PUT changesets</td>
<td>Contains corrections for batch handling in personalization</td>
</tr>
<tr>
<td>SAP Note Number</td>
<td>Title</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>1952232</td>
<td>Conversion errors</td>
<td>Contains corrections for conversion exit handling in SAP Gateway</td>
</tr>
<tr>
<td>1969521</td>
<td>Message T9032 for date “0”</td>
<td>Contains corrections for date handling in Gateway</td>
</tr>
<tr>
<td>1963962</td>
<td>HTTP logon page messed up due to a Long Title for Corbu theme</td>
<td>Contains corrections of the logon page</td>
</tr>
<tr>
<td>2032138</td>
<td>Collaboration Portal: Reading list of quotations causes HTTP error</td>
<td>Contains corrections for retrieving quotations in the Tendering workset</td>
</tr>
<tr>
<td>2140741</td>
<td>Collaboration Portal: Sorting and filtering issues</td>
<td>Contains corrections for retrieving freight RFQs, freight quotations and freight orders for execution.</td>
</tr>
<tr>
<td>2154643</td>
<td>Pagebuilder UI AddOn 1.0 SP13 + 2.0 SP00</td>
<td>Contains corrections for personalization service</td>
</tr>
<tr>
<td>2171017</td>
<td>Collaboration Portal: Start of portal is slow</td>
<td>Contain performance corrections for the SAP TM collaboration portal.</td>
</tr>
<tr>
<td>2190055</td>
<td>Remove buffering for node index</td>
<td>Contains corrections for default settings. For more information about default settings, see section Making Default Settings for Carriers [page 30].</td>
</tr>
<tr>
<td>2238445</td>
<td>Integration of Supply Chain Execution Platform Applications to SAP S/4HANA, on-premise edition</td>
<td>Contains information about the integration of SAP TM with SAP S/4HANA, on-premise edition.</td>
</tr>
</tbody>
</table>

### 3.4 System Requirements

There are no special hardware requirements specifically for the SAP Transportation Management collaboration portal (SAP TM collaboration portal). The recommendations of the other components involved are applicable.
4 Installation

This chapter provides the details required for setting up the required system landscape:

- General installation information
- Installation sequence
- Required components to be installed

Downloading

You can download the required components from the SAP Software Download Center on SAP Service Marketplace at service.sap.com/swdc > Installations and Upgrades > A-Z Index > SAP Transportation Management 9.4 > Installation.

Installation Tool

SAP recommends use of the Software Update Manager for the installation of the required components. This tool facilitates SAP NetWeaver-based application system upgrade, enhancement package installation, and installation of support packages. These various tools are consolidated into a common tool called the Software Update Manager with a harmonized user interface. The Software Update Manager is shipped as part of the software logistics toolset (SL Toolset) 1.0 – independently of the applications.

You can download the tool from the SAP Software Download Center on SAP Service Marketplace at service.sap.com/swdc > SAP Software Download Center > Search for Software Downloads > Software Update Manager.

Note

Transaction SAINT
Alternatively, you can use the add-on installation tool (transaction SAINT) for the installation.

For more information on using SAINT, read the appropriate SAP documentation on SAP Service Marketplace at help.sap.com > SAP NetWeaver > SAP NetWeaver 7.4 > Application Help > Function-Oriented View > Solution Lifecycle Management > Software Logistics > Add-On Installation Tool.

4.1 Installation Sequence

You need to set up your system landscape to be able to use the SAP Transportation Management collaboration portal (SAP TM collaboration portal). The installation process of the required system components has to be carried out in a specific sequence.

Prerequisites

Before you start the installation process, ensure that the following components have already been installed on your SAP Business Suite component server:
• SAP TM 9.4
• SAP NetWeaver AS ABAP 7.40

Procedure

The installation sequence for the SAP TM collaboration portal is as follows:

1. Installation of SAP Gateway
   - Install SAP NetWeaver Gateway 2.0 Support Package Stack (SPS) 09 or higher according to your SAP NetWeaver installation.

2. Installation of software component version SAPTMUI 150

3. Installation of the Reverse Proxy / ABAP Web Dispatcher

4.2 Installation of SAP Gateway

For the SAP Transportation Management collaboration portal (SAP TM collaboration portal), SAP Gateway needs to be included in your system landscape. The installation depends on the product version of your SAP NetWeaver installation.

Caution

The installation location (server) for SAP Gateway depends on your deployment of SAP Gateway (see Deployment Options [page 9]).

Prerequisites

The following installations of SAP Gateway are required depending on the product version:

<table>
<thead>
<tr>
<th>Table 5</th>
<th>Required SAP Gateway Installation</th>
<th>Components Automatically Installed with SAP Gateway</th>
</tr>
</thead>
</table>
| SAP NETWEAVER 7.0 (AS ABAP) | SAP NETWEAVER GATEWAY 2.0 (Gateway Server Core NW 700/701) | • GW_CORE 190  
• SAP IW FND 240 |
| **EHP1** FOR SAP NETWEAVER 7.0 (AS ABAP) | SAP NETWEAVER GATEWAY 2.0 (Gateway Server Core NW 702) | • GW_CORE 200  
• SAP IW FND 250  
• SAP WEB UIF 7.01 |
| **EHP2** FOR SAP NETWEAVER 7.0 (AS ABAP) | SAP NETWEAVER GATEWAY 2.0 (Gateway Server Core NW 703/731) | • GW_CORE 200  
• SAP IW FND 250  
• SAP WEB UIF 7.31 |
| SAP NETWEAVER 7.4 (AS ABAP) | All required components are included in the SAP NetWeaver installation. | All required components are included in the SAP NetWeaver installation. |
Procedure

1. Install SAP NetWeaver Gateway 2.0 Support Package Stack (SPS) 09 or higher as described in the SAP Library for SAP NetWeaver Gateway 2.0 SPS 09 or higher on SAP Help Portal at help.sap.com/nwgateway20 Application Help Support Package Stack 09 SAP NetWeaver Gateway SAP NetWeaver Gateway Installation Guide.

2. Install the following Gateway components as described in SAP Library for SAP NetWeaver Gateway 2.0 SPS 09 or higher on SAP Help Portal at help.sap.com/nwgateway20 Application Help Support Package Stack 09 SAP NetWeaver Gateway SAP NetWeaver Gateway Installation Guide Installing SAP NetWeaver Gateway Components.

   Ensure that the following SAP notes are in place:
   - JSON – IWFND 2.50 (NW 7.02) SP 04 with SAP Note 1648418
   - JSON – IWFND 2.40 (NW 7.00) on 7.20 Kernel with SAP Note 1648418

   Note that JSON – IWFND 2.40 (NW 7.00) on 7.00 Kernel is not supported – Atom feeds only.

   For a list of technical prerequisites for installing SAP NetWeaver Gateway 2.0, see SAP Library for SAP NetWeaver Gateway 2.0 SPS 09 or higher on SAP Help Portal at help.sap.com/nwgateway20 Application Help Support Package Stack 09 SAP NetWeaver Gateway SAP NetWeaver Gateway Installation Guide Installation Prerequisites.

4.3 Installation of Software Component Version SAPTMUI 150

For the SAP Transportation Management collaboration portal (SAP TM collaboration portal), you need to install the software component version SAPTMUI 150 according to your chosen deployment option. This software component contains the relevant front end components.

Procedure

See SAP Note 1850848.
4.4 Installation of Reverse Proxy / SAP Web Dispatcher

For the SAP Transportation Management collaboration portal (SAP TM collaboration portal), you need to install a reverse proxy or an instance of the SAP Web Dispatcher.

4.4.1 OData and HTTP Methods

Open Data Protocol (OData) is a standardized protocol for creating and consuming data APIs. OData builds on core protocols like HTTP and commonly accepted methodologies like REST. The result is a uniform way to expose full-featured data APIs.

RESTful Web services rely on HTTP semantics. Thus they use PUT and DELETE HTTP methods for update and delete operations. If a reverse proxy is used, it must be configured to allow those HTTP methods for the SAP Gateway OData services.

4.4.2 URL Rewriting

SAP Gateway OData services may return absolute URLs to Gateway. When these services are accessed through a reverse proxy, these URLs may be invalid and/or disclose system information (protocols, hostname, port numbers).

Therefore, it is recommended to configure the URL rewrite rules at the reverse proxy level. The data to process can be identified through its Content-Type HTTP header. The following content must be processed:

- text/html
- application/xml
- application/json

4.4.3 SAP Web Dispatcher

For more information about how to set up the SAP Web Dispatcher, see SAP Library for SAP NetWeaver 7.4 on SAP Help Portal at help.sap.com/nw. In SAP Library, choose SAP NetWeaver > SAP NetWeaver Platform > SAP NetWeaver 7.4 > Application Help > Function-Oriented View > Application Server > Application Server Infrastructure > Components of SAP Web Dispatcher > SAP Web Dispatcher.

SAP Web Dispatcher needs to be configured as a URL filter. Only the following URLs are allowed to be maintained in the white list:

- URLs of Internet Communication Framework (ICF) services for the SAP Transportation Management collaboration portal (SAP TM collaboration portal)
- URLs of the Gateway services for the SAP TM collaboration portal
- URLs of supporting services

Otherwise, external users could access internal services for which they are not authorized.

For more information, see SAP Library for SAP NetWeaver 7.4 on SAP Help Portal at help.sap.com/nw. In SAP Library, choose SAP NetWeaver > SAP NetWeaver Platform > SAP NetWeaver 7.4 > Application Help > Function-
The relevant paths are:

- `/sap/public/bc/ur/nw5/*`
- `/sap/public/bc/ur/nw7/*`
- `/sap/public/bc/ur/Login/*`
- `/sap/public/bc/icf/logoff`
- `/sap/public/bc/UI2/services/sap/ui2/srvc/*`
- `/sap/opu/odata/sap/VBI_APPL_DEF_SRV/`
- `/sap/bc/TM_CP_DOCU`
- `/sap/bc/ui2/*`
- `/sap/public/bc/ui2/shell-api/sap/ui2/shell/*`
- `/sap/opu/odata/UI2/PAGE_BUILDER_PERS/`
- `/sap/opu/odata/UI2/PAGE_BUILDER_CUST/`
- `/sap/opu/odata/SCMTMS/TENDERING/`
- `/sap/opu/odata/SCMTMS/USER/`
- `/sap/opu/odata/SCMTMS/GENERAL/`
- `/sap/opu/odata/SCMTMS/INVOICING/`
- `/sap/opu/odata/SCMTMS/FRT_PROCUREMENT`
- `/sap/opu/odata/SCMTMS/EVENT_NOT`
- `/sap/opu/odata/SCMTMS/INVOICE_SUBMISSION`
- `/sap/opu/odata/SCMTMS/FO_CONFIRMATION`
- `/sap/bc/ui5_ui5/tmui/coll_portal/`
5 Configuration

Once the complete infrastructure for the SAP Transportation Management collaboration portal (SAP TM collaboration portal) has been installed, you must perform the required configuration activities for these components. The required configuration activities for each of the available deployment options are described in this chapter.

Configuration Overview

1. Configuring SAP Business Suite Components (relevant for either embedded or hub deployment option)
   1. How to access the portal URL
   2. Define Users and Authorizations
   3. Specify Connection Settings: Back-End System to SAP Gateway
   4. Change ICT file compression settings

2. Configuring SAP NetWeaver Gateway (NW GW) 2.0
   1. Activate SAP NetWeaver Gateway 2.0
   2. Specify Connection Settings: SAP Gateway to Back-End System
   3. Specify Settings for Standard Mode (oData) on the SAP Gateway System
   4. Define Users and Authorizations for SAP Gateway
   5. Specify Language Settings
   6. Virus Scan Interface

3. Adding Customer Enhancements

4. Activating Gateway and ICF Services in SICF

5. Configuring Map Display

6. Setting Up File Upload

7. Integration into the SAP NetWeaver Portal

   \[\text{i} \quad \text{Note}\]
   This is an optional step.

8. Defining a Theme for the SAP TM collaboration portal

   \[\text{i} \quad \text{Note}\]
   This is an optional step.

9. Making Default Settings for Carriers

   \[\text{i} \quad \text{Note}\]
   This is an optional step.
5.1 Configuring SAP Business Suite Components

Procedure

1. **How to Access the Portal URL**
   
   With the installation of the software component SAPTMIU 140, a predefined ICF node is provided which grants access to the portal page.

   The URL is built in the following way: https://<server>:<port>/sap/bc/ui5_ui5/tmui/coll_portal/. If you want to find out the specific URL for your deployment, follow the steps below:

   1. Start transaction **SICF**.
   2. Choose **Execute** (F8).
   3. Open path **default_host > sap > bc > ui5_ui5 > tmui**.
   4. Right-click on node **coll_portal** and choose **Activate service**.
   5. Right-click on node **coll_portal** and choose **Test service**.

   The internal server names must not be visible in the URL. Thus, there is the possibility to create a system alias which will also be used for sending the URL of the SAP Transportation Management collaboration portal (SAP TM collaboration portal) in tendering mails:

   As part of the tendering process in the SAP TM back-end system, e-mails can be generated and sent to the carriers which contain a link to the carrier’s work list. If the SAP TM collaboration portal is in place, this link needs to represent the URL to the SAP TM collaboration portal. For information about how to set up a system alias to secure the URL that is sent out via e-mail, see the security guide for **SAP Transportation Management**, chapter **Security Aspects of Data Flow and Processes > E-Mail-Based Tendering Scenario > Recommendation**. You can see the security guide for SAP TM on SAP Service Marketplace at `service.sap.com/instguides > SAP Business Suite Applications > SAP TM`.

   If you decide not to maintain a system alias, the URL that is sent to the carrier will contain the server name and port of the server on which the SAP TM collaboration portal is running. For deployment options where software components SAPTMIU and SAPTMI are not deployed on the same server, it is still required to create an alias in transaction **SM59** in your SAP TM system, according to the recommendation in the security guide. However, maintain <host>:<port> of your Gateway server as the target in this alias, instead of the system alias. For deployment options where software components SAPTMIU and SAPTMI are deployed on the same server, and you are not using a system alias, this is not required.

   If the SAP TM collaboration portal is running on a server with multiple clients, you need to add the correct client to the URL that is sent to the carrier. The correct client can be added automatically if you maintain the client in transaction **SM59**, as follows:

   1. In transaction **SM59**, create an RFC Destination.
   2. On the **Logon & Security** tab page, specify the client in the **Logon Procedure** group box.

   Note that you do not need to add the client to the URL if the SAP TM collaboration portal is running on a server with only one client.

   If you use the SAP TM system with the old Web UI for tendering (POWLOverview Tendering for Carriers) and not the SAP TM collaboration portal, you must change the following option in Customizing. The option allows you to define whether the URL target in e-mails is the **SAP TM collaboration portal** or **Overview Tendering for Carriers**. The default is the **SAP TM collaboration portal**.

   For more information, see Customizing for **Transportation Management** under **Freight Order Management > Tendering > Define General Settings for Tendering > E-Mail and SMS Content**.
2. Define Users and Authorizations

The SAP TM collaboration portal adopts the user management and authentication mechanisms provided by the SAP NetWeaver platform, specifically SAP NetWeaver Application Server ABAP.

To access the SAP TM functionality, you must create a business partner and assign it the **Internet User** role. The business partner acts as a contact person for the carrier. You can assign the *Internet User* role to the business partner as follows:

1. On the **Maintain Business Partner** (transaction **BP**) screen, create a person.
2. Enter the name of the contact person in the **Business Partner** field.
3. Enter *Internet User* in the **Create in BP role** field.
4. Open the **Internet User** tab page and enter the relevant details in the **Logon Data** group box.

Set up users and assign authorizations to your users in the back-end system. For the Gateway Hub Deployment, also set up users and assign user authorizations for the Gateway server.

The SAP TM collaboration portal is shipped with the following role templates:

<table>
<thead>
<tr>
<th>Role</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>/TMUI/COLL_PORTAL_DEMO</td>
<td>Demo user for the SAP TM collaboration portal</td>
</tr>
<tr>
<td>/TMUI/COLL_PORTAL</td>
<td>User for Gateway services in the SAP TM collaboration portal</td>
</tr>
<tr>
<td>/SCMTMS/COLL_PORTAL</td>
<td>User for the SAP TM collaboration portal</td>
</tr>
</tbody>
</table>

For more information about the users mentioned above, see SAP Library for Supply Chain Management on SAP Help Portal at [help.sap.com](https://help.sap.com) > **SAP Transportation Management** > **SAP Transportation Management (SAP TM)** > **Basic Functions** > **Roles**.

For more information about tendering setup, see SAP Note 1697835.

Proceed as follows:

1. Copy the application-specific SAP roles mentioned above into the customer namespace and maintain the authorization values correctly.
2. Assign the new role(s) to the application users.

For more information about users and authorizations, see the security guide for SAP TM on SAP Service Marketplace at [service.sap.com/instguides](https://service.sap.com/instguides).

To restrict the visibility of worksets for a specific user, proceed as follows:

1. Open the application-specific role for `/TMUI/COLL_PORTAL` or `/TMUI/COLL_PORTAL_DEMO` created above in transaction **PFCG**.
2. Go to tab **Menu**.
3. Delete the workset folders that you don’t want a certain user to see.

The following table shows the relation between the workset folders and the worksets in the portal:

<table>
<thead>
<tr>
<th>PFCG Folder</th>
<th>Workset in the Portal</th>
</tr>
</thead>
<tbody>
<tr>
<td>/SCMTMS/HOME</td>
<td>Home</td>
</tr>
<tr>
<td>/SCMTMS/FRM</td>
<td>Freight Order Management</td>
</tr>
<tr>
<td>/SCMTMS/FRM – /SCMTMS/TENDERING</td>
<td>Freight Requests for Quotation and Freight Quotations</td>
</tr>
</tbody>
</table>
If you delete a workset folder from role /TMUI/COLL_PORTAL, you must also restrict the Gateway service authorizations by removing the IWSV object from role /SCMTMS/COLL_PORTAL. The following table shows the corresponding IWSV objects of the workset folders:

<table>
<thead>
<tr>
<th>PFCG Folder</th>
<th>Workset in the Portal</th>
</tr>
</thead>
<tbody>
<tr>
<td>/SCMTMS/FRM – /SCMTMS/EVENT_NOT</td>
<td>Freight Orders for Execution</td>
</tr>
<tr>
<td>/SCMTMS/FRM – /SCMTMS/FO_CONF</td>
<td>Freight Orders for Confirmation</td>
</tr>
<tr>
<td>/SCMTMS/FRS</td>
<td>Freight Settlement</td>
</tr>
<tr>
<td>/SCMTMS/FRS – /SCMTMS/SELF_BILLING</td>
<td>Freight Orders for Self-Billing</td>
</tr>
<tr>
<td>/SCMTMS/FRS – /SCMTMS/INV_SUBMISSION</td>
<td>Freight Orders for Invoice Submission and Invoices</td>
</tr>
<tr>
<td>/SCMTMS/FRA</td>
<td>Freight Agreement Management</td>
</tr>
<tr>
<td>/SCMTMS/FRA – /SCMTMS/FRT_PROCUREMENT</td>
<td>Freight Agreement RFQs and Freight Agreements</td>
</tr>
<tr>
<td>/SCMTMS/FRM – /SCMTMS/RATE_CHANGE</td>
<td>Freight Agreements for Rate Changes</td>
</tr>
</tbody>
</table>

Also, you must delete the corresponding IWSG object in role /TMUI/COLL_PORTAL.

To access the portal in demo mode, the URL must be in the following format: https://<server>:<port>/sap/bc/ui5_ui5/scmtms/coll_portal/?demo=x

**Note**

If you do not use the workflow for invoice submission or the self-billing of freight orders, you must remove the delivered authorization object S_WF_WI in transaction SU24.

3. Specify Connection Settings: Back-End System to SAP Gateway

Specify the settings that can be used by the OData Channel and the Gateway component to establish the connection from your ERP back-end system to SAP Gateway.

Depending on your underlying SAP NetWeaver release, the configuration settings for OData Channel and the structure in the Customizing may differ. See OData Channel Configuration for more details.

For more information on connection settings, see SAP Library for SAP Gateway on SAP Help Portal at help.sap.com/nwgateway20 ➤ Application Help ➤ Support Package Stack 09 ➤ SAP NetWeaver Gateway ➤ SAP NetWeaver Gateway Configuration Guide ➤ OData Channel Configuration ➤ Connection Settings on the Backend System ➤.

4. Change ICT File Compression Settings
The SAP TM collaboration portal applies file compression when processing data from the back end. To ensure the settings are optimal for Web applications, change the profile parameter `ict.exclude_compression` as follows:

1. Remove `*.css`
2. Add `*.jpg, *.jpeg and *.png`

For more information about changing settings for file compression, see SAP Note 1037677.

### 5.2 Configuring SAP NetWeaver Gateway 2.0 Components

#### Procedure

1. **Activate the Gateway**
   
   Before starting with the configuration for SAP Gateway itself, you need to collect some information about the SAP Gateway host. For more information, see the SAP Library for SAP Gateway on SAP Help Portal at [help.sap.com/nwgateway20](http://help.sap.com/nwgateway20) → Application Help → Support Package Stack 09 → SAP NetWeaver Gateway Configuration Guide → Basic Configuration Settings.

   You must activate the SAP Gateway before you can use it. For more information, see the SAP Library for SAP Gateway on SAP Help Portal at [help.sap.com/nwgateway20](http://help.sap.com/nwgateway20) → Application Help → Support Package Stack 09 → SAP NetWeaver Gateway → SAP NetWeaver Gateway Configuration Guide → OData Channel Configuration → Activating SAP NetWeaver Gateway.

2. **Specify Connection Settings: SAP Gateway to Back-End System**

   You must configure settings for Gateway components and define how these settings interface with your existing SAP Business Suite system (back-end system). However, only the following steps are required for the mobile system landscape in SAP Business Suite:
   - Defining Trust Between the SAP Gateway Host and Your SAP System
   - Creating a Type 3 RFC Destination on SAP Gateway Host to SAP
   - Configuring SAP System to Accept Assertion Tickets from SAP Gateway
   - Configuring the SAP Gateway Host to Accept Assertion Tickets
   - Creating the SAP System Alias for Applications


3. **Specify Settings for Standard Mode (OData) on the Gateway System**

   When setting up the Gateway services for applications, you must register and activate data retrieval services (OData services) from your back-end system.

   **Note**

   Configuration and use of OData services are mandatory for this application.

   The following table shows the relevant OData services for the SAP Transportation Management collaboration portal (SAP TM collaboration portal):
### Table 9

<table>
<thead>
<tr>
<th>Workset</th>
<th>Technical Service Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>/SCMTMS/USER</td>
<td></td>
</tr>
<tr>
<td>/SCMTMS/GENERAL</td>
<td></td>
</tr>
<tr>
<td>/UI2/PAGE_BUILDER_PERS</td>
<td></td>
</tr>
<tr>
<td>VBI_APPL_DEF_SRV</td>
<td></td>
</tr>
<tr>
<td>Freight Order Management – Freight Requests for Quotation and Freight Order Management – Freight Quotations</td>
<td>/SCMTMS/TENDERING</td>
</tr>
<tr>
<td>Freight Order Management – Freight Orders for Execution</td>
<td>/SCMTMS/EVENT_NOT</td>
</tr>
<tr>
<td>Freight Order Management – Freight Orders for Confirmation</td>
<td>/SCMTMS/FO_CONFIRMATION</td>
</tr>
<tr>
<td>Freight Settlement – Freight Orders for Self-Billing</td>
<td>/SCMTMS/INVOICING</td>
</tr>
<tr>
<td>Freight Settlement – Freight Orders for Invoice Submission, Freight Settlement – Invoices, and Freight Settlement – Credit Memos</td>
<td>/SCMTMS/INVOICE_SUBMISSION</td>
</tr>
<tr>
<td>Freight Agreement Management – Freight Agreement RFQs, Freight Agreement Management – Freight Agreements, and Freight Agreement Management – Freight Agreements for Rate Changes</td>
<td>/SCMTMS/FRT_PROCUREMENT</td>
</tr>
</tbody>
</table>

As previously described, you can disable specific worksets for a given user. If you do not want to use a workset at all, you can disable that workset by not activating the Gateway service above. All Gateway services without a workset always have to be activated as they cover basic functionality.

If you want to use the map, you must activate the Gateway service VBI_APPL_DEF_SRV.

**Note**

In hub deployment, when you configure the Gateway services /UI2/PAGE_BUILDER_PERS and VBI_APPL_DEF_SRV, you must specify the system in which the component SAPTMUI is installed.

**Caution**

You should not use transaction SEGW (Gateway Service Builder) to change the Gateway services of the SAP TM collaboration portal. If you do so and you have already applied some correction notes, the generation of the *MPC* and *DPC* classes will overwrite the changes from the notes.

For more information, see SAP Library for SAP Gateway on SAP Help Portal at help.sap.com/nwgateway20 ➔ Application Help ➔ Support Package Stack 09 ➔ SAP NetWeaver Gateway ➔ SAP NetWeaver Gateway Developer Guide ➔ OData Channel ➔ Basic Features ➔ Service Life-Cycle ➔ Activate and Maintain Services ➔.

4. **Define Users and Authorizations for SAP Gateway**

   For each application user that you define in the back-end system, you must create a corresponding user with the same name in the Gateway system. It requires specific authorizations that allow the services of the application to be triggered in the back-end system.
Maintain the authorizations for the users of the SAP TM collaboration portal using the activated service names. All the authorizations are pre-maintained in role /TMUI/COLL_PORTAL. If you use the delivered technical service names, for example, ZTENDERING, all authorizations work out-of-the-box. If you change the technical service names, you have to adapt the derived role from /TMUI/COLL_PORTAL.

Assign a standard SAP user role with the authorization S_RFCACL to all users in SAP Gateway, as well as in all connected SAP systems.

5. Specify Language Settings

You must specify the settings for supported languages in the Gateway system, for example, default and logon languages.

- **Note**
  The Gateway system must provide the same default language as the back-end system, for example, English.
  The Gateway system must provide the same logon language as the back-end system. If this is not the case, ensure that the Gateway system has a subset of the languages of the back-end system.

Setting the logon language for the ABAP Application Server works as follows:

- If the **Mandatory Logon Data** indicator has been activated for a service in transaction SICF, the system uses the language that was entered there.
- If this is not the case, but the HTTP request contains the language in the HTTP header (as a header or a form field), you log onto the system using this language.
- The browser settings of the calling client are then used. The system selects as the logon language the first language from the list that is maintained in the browser, and which is also installed in the SAP system.

You specify the language list using the HTTP header field `accept-language`.

- **Note**
  With Internet Explorer, you can, for example, set the language you require by choosing Tools > Internet Options > Languages.

- If no language is defined by this process, the classic SAP system mechanisms are used.

The logon language is based on the user settings (in transaction SU01) and if nothing is entered here, the default language of the SAP system is used automatically.

For more information, see SAP Library for SAP Gateway on SAP Help Portal at help.sap.com/

6. Virus Scan Interface

All changing calls to SAP Gateway (such as sending freight quotations, or uploading attachments) require the configuration of the virus scan interface.

For more information, see SAP Library for SAP Gateway on SAP Help Portal at help.sap.com/
5.3 Adding Customer Enhancements

You can extend the shipped SAP Transportation Management collaboration portal (SAP TM collaboration portal).

More Information


5.4 Activating ICF Nodes

Procedure

To activate the required Gateway services, go to the required transaction, and check if the services are active:

1. In your Gateway system, go to transaction SICF.
2. Select Execute.
3. Navigate to sap > opu > odata > scmtms.
4. Check that all the following Gateway services for the SAP Transportation Management collaboration portal (SAP TM collaboration portal) are active:
   - Right-click each service. Activate Service should be inactive (grayed out).
   - If Activate Service is active, right-click each service and select Activate Service.
5. Navigate to sap > bc > ui5_ui5 tmui.
6. Check that all the ICF nodes shown for the application are active:
   - Right-click each service. Activate Service should be inactive (grayed out).
   - If Activate Service is active, right-click each service and select Activate Service.
7. Navigate to sap > public > bc > ui2.
8. Check that the ICF node is active:
   - Right-click the service. Activate Service should be inactive (grayed out).
   - If Activate Service is active, right-click each service and select Activate Service.
9. Navigate to sap > bc > ui2 start_up.
10. Check that the ICF node is active:
    - Right-click the service. Activate Service should be inactive (grayed out).
    - If Activate Service is active, right-click each service and select Activate Service.
11. Navigate to sap > public > bc > ur.
12. Check that the ICF node is active:
    - Right-click the service. Activate Service should be inactive (grayed out).
    - If Activate Service is active, right-click each service and select Activate Service.
13. Navigate to sap > public > bc > icf > logoff.
14. Check that the ICF node is active:
   ○ Right-click the service. **Activate Service** should be inactive (grayed out).
   ○ If **Activate Service** is active, right-click each service and select **Activate Service**.

15. Navigate to sap > bc > TM_CP_DOCU

16. Check that the ICF node is active:
   ○ Right-click the service. **Activate Service** should be inactive (grayed out).
   ○ If **Activate Service** is active, right-click each service and select **Activate Service**.

17. Navigate to sap > opu > odata > sap > vbi_appl_def_srv

18. Check that the ICF node is active:
   ○ Right-click the service. **Activate Service** should be inactive (grayed out).
   ○ If **Activate Service** is active, right-click each service and select **Activate Service**.

### 5.5 Configuring Map Display

The SAP Transportation Management collaboration portal (SAP TM collaboration portal) is capable of displaying a map in pre-defined areas of the user interface. This map shows, for example, the source and destination location of a transport. Each user can display or hide the map by activating or deactivating this in the personal user settings in the SAP TM collaboration portal. You cannot activate or deactivate this centrally for all users.

The map is provided by SAP Visual Business and you need to make the following settings in the SAP TM back-end system:

- You register and activate the data retrieval service (OData service) VBI_APPL_DEF_SRV.
  For more information, see **Configure SAP NetWeaver Gateway 2.0 Components** [page 23].
- You have to change the default SAP TM collaboration portal (TM_COLL_PORTAL) Visual Business application which provides the required map configuration.

You have to change this application to meet your specific configuration needs, for example, using a different map provider for the SAP TM collaboration portal. The Visual Business application used by the SAP TM collaboration portal (TM_COLL_PORTAL) uses the map layer stack DEFAULT_COLL_PORTAL as the default map layer stack, and this has no map product assigned by default. If you want to use the map feature in the SAP TM collaboration portal, you must assign a corresponding map product to this map layer stack.

For more information, see the installation and configuration guide for SAP Visual Business on SAP Service Marketplace at service.sap.com/instguides [Installation & Upgrade Guides > SAP NetWeaver > SAP Visual Business > Release 2.1 > Installation and Configuration Guide].

- To display the correct location information on the map in the SAP TM collaboration portal, you maintain the geographical data in the location master data in the SAP TM back-end system.
  You can define master data for locations in SAP TM in SAP NetWeaver Business Client by choosing **Master Data > Transportation Network > Locations > Define Location**.

If you access the SAP TM collaboration portal in demo mode, you cannot use the map display.

### 5.6 Setting Up File Upload

The worksets **Freight Settlement**, **Freight Order Management (Freight Orders for Execution and Freight Orders for Confirmation)**, and **Freight Agreement Management (Freight Agreement RFQs and Freight Agreements for Rate**
Changes) provide file upload capabilities. The uploaded files are stored in an attachment folder in the back end. You must configure the attachment folder to specify the types of files that can be uploaded.

Proceed as follows:

1. In Customizing for Cross-Application Components, choose > Processes and Tools for Enterprise Applications > Reusable Objects and Functions for BOPF Environment > Dependent Object Attachment Folder > Maintain Attachment Type Schema.

2. Double-click the Assign Schema to BO Nodes structure and assign the attachment type schema Attachment (ATCMT) to the following business object nodes:

<table>
<thead>
<tr>
<th>Workset</th>
<th>Business Object</th>
<th>Node</th>
</tr>
</thead>
<tbody>
<tr>
<td>Freight Settlement – Freight Orders for Self-Billing</td>
<td>/SCMTMS/SUPPFREIGHTINVREQ</td>
<td>ROOT</td>
</tr>
<tr>
<td>Freight Settlement – Freight Orders for Invoice Submission</td>
<td>/SCMTMS/SUPPFREIGHTINVREQ</td>
<td>ROOT</td>
</tr>
<tr>
<td>Freight Settlement – Invoices</td>
<td>/SCMTMS/SUPPFREIGHTINVREQ</td>
<td>ROOT</td>
</tr>
<tr>
<td>Freight Settlement – Credit Memos</td>
<td>/SCMTMS/SUPPFREIGHTINVREQ</td>
<td>ROOT</td>
</tr>
<tr>
<td>Freight Agreement Management – Freight Agreement RFQs</td>
<td>/SCMTMS/FREIGHTAGREEMENT</td>
<td>ROOT</td>
</tr>
<tr>
<td>Freight Agreement Management – Freight Agreements for Rate Changes</td>
<td>/SCMTMS/FREIGHTAGREEMENT</td>
<td>ROOT</td>
</tr>
<tr>
<td>Freight Order Management – Freight Orders for Execution</td>
<td>/SCMTMS/TOR</td>
<td>ROOT</td>
</tr>
<tr>
<td>Freight Order Management – Freight Orders for Confirmation</td>
<td>/SCMTMS/TOR</td>
<td>ROOT</td>
</tr>
</tbody>
</table>

You maintain the following settings:

- File attachments allowed
- Default as the attachment schema

3. Double-click the MIME Type dep on BO & Node structure and maintain the MIME types for the above business object nodes.

For more information about how to configure the file upload securely, see the security guide for SAP TM on SAP Service Marketplace at service.sap.com/instguides.

5.7 Integration into the SAP NetWeaver Portal

If you want to run the SAP Transportation Management collaboration portal (SAP TM collaboration portal) within the installation of the SAP NetWeaver Portal, you can create an SAP NetWeaver Portal iView that hosts the SAP TM collaboration portal.

For information about how to set up roles, worksets, and pages, see SAP Help Portal at help.sap.com/NW74 > Application Help > SAP NetWeaver Portal > Portal > Managing the Portal > Content Administration.
Procedure

You can run the SAP TM collaboration portal as an SAP NetWeaver Portal application as follows:

2. Right-click UI5 to copy the UI5 template.
3. Right-click on the user interface and in the context menu, choose Paste as PCD Object to paste the copied template to a location under Portal Content.
4. Set the following properties:
   - HTTP Request Method: HTTP GET
   - Hand Over Portal Stylesheet: False
   - System: Enter the alias of the system in which the component SAPTMUI is installed
   - UI5 Relative Path: /sap/bc/ui5_ui5/tmui/coll_portal/index.html?
   - Launch in New Window: Display in separate headerless portal window (standard mode)
5. Save the iView.
6. Run the iView.

For more information, see SAP Note 1708020.

5.8 Defining a Theme for the SAP TM collaboration portal

You can design your own theme and apply it to the SAP Transportation Management collaboration portal (SAP TM collaboration portal). If you are using SAP NetWeaver 740, you do not need to install additional components.

Prerequisites

You have made the relevant settings.

For more information, see SAP Library for SAP NetWeaver on SAP Help Portal at help.sap.com/NW74. In SAP Library, choose Application Help > UI Technologies in SAP NetWeaver > Theming and Branding > Developer Guide for UI Theme Designer > Getting Started.

Procedure

2. On the initial screen, open a theme, for example, SAP Blue Crystal, as the base of your theme for the SAP TM collaboration portal.
3. In the Link to Application field, enter the following link to the SAP TM collaboration portal: <server>:<port>/sap/bc/ui5_ui5/tmui/coll_portal/?sap-client=<sap_client> and choose the Add button.
4. Adapt the theme according to your needs.
5. Build your theme by choosing Theme > Save & Build and entering your theme ID in sentence case.
6. Apply your theme to the SAP TM collaboration portal using URL
7. To apply your own logo to the top left of the SAP TM collaboration portal screen, change parameter sapUiGlobalLogo to your own value and provide the following CSS code:

```
/* Syntax */
.sapUiUx3ShellHeader > img[id$='-logoImg'] {
    display: inline-block;
    -moz-box-sizing: border-box;
    box-sizing: border-box;
    background: url(../../../../../../Base/baseLib/custom_bluecrystal/img/misc/sapCompanyLogo.png);
    background-size: 30px 18px;
    background-repeat: no-repeat;
    height: 18px;
    width: 30px;
    padding-left: 30px;
}
```
8. To apply your own logo to the screen when you log out the SAP TM collaboration portal, provide the following CSS code:

```
/* Syntax */
#logoff_image {
    display: inline-block;
    -moz-box-sizing: border-box;
    box-sizing: border-box;
    background: url(../../../../../../Base/baseLib/custom_bluecrystal/img/misc/sapCompanyLogo.png);
    background-size: 72px 36px;
    background-repeat: no-repeat;
    height: 36px;
    width: 72px;
    padding:18px;
}
```

If you use tendering emails, you must specify the theme in Customizing for Transportation Management under
Freight Order Management ➔ Tendering ➔ Define General Settings for Tendering. You can specify the theme in the dialog structure Email and SMS Content under General Settings. This is only relevant if the complete SAP TM collaboration portal URL is not masked with an alias on the web dispatcher.

### 5.9 Making Default Settings for Carriers

As a shipper, you can make personalization settings for your carriers beforehand. The settings you make are saved as default settings for your carriers when they log on to the SAP Transportation Management collaboration portal (SAP TM collaboration portal).
To make the settings, you need an administrator’s user in the SAP TM collaboration portal. Apart from assigning the roles for accessing and using the SAP TM collaboration portal, you need to assign the following roles to the administrator’s user:

- `/TMUI/COLL_PORTAL_ADMIN`
- `/SCMTMS/COLL_PORTAL_ADMIN`

For more information about defining roles and authorizations, see Configuring SAP Business Suite Components [page 20].

The default settings are stored as Customizing objects. Thus, you have the following options to provide default settings:

- If you want to provide the default settings locally in your productive system, you must change the client settings to allow changes to client-specific objects.
- If you want to transport the default settings from your development system to all the subsequent systems, you must create a transport request in the Customizing client and specify it in user parameter `/UI2/WD_TRKORR_CUST` for the administrator’s user for the SAP TM collaboration portal. When you make personalization changes in the SAP TM collaboration portal, these are recorded in the transport request.

**Note**

To make sure the personalization settings you make are applied in the system after logon by carriers, you must make the settings before your carriers access the SAP TM collaboration portal and make their own settings. You must avoid making changes to the settings afterwards.

**Prerequisites**

If you want to use the default settings for carriers, you have to activate the Gateway service `/UI2/PAGE_BUILDER_CUST` as described for the other Gateway services in section Configuring SAP NetWeaver Gateway 2.0 Components [page 23].
6 Security

For more information, see the security guide for SAP TM on SAP Service Marketplace at service.sap.com/instguides.
After you go live with the SAP Transportation Management collaboration portal (SAP TM collaboration portal), you must manage the day-to-day activities, such as monitoring. This chapter describes regular monitoring tasks you perform as part of regular system administration.

For more information, see the applications operations guide for SAP TM on SAP Service Marketplace at service.sap.com/instguides.
8 Support

System administrators are the single point of contact for SAP Support to supply your company with solutions to issues that arise in your system. The SAP Transportation Management collaboration portal (SAP TM collaboration portal) provides all the tools that you as a system administrator require to manage support of your users.

**Support Desk Management**

Support Desk Management enables you to set up an efficient internal support desk for your support organization that seamlessly integrates your end users, internal support employees, partners, and SAP Active Global Support specialists with an efficient problem resolution procedure. For support desk management, you need the methodology, management procedures, and tools infrastructure to run your internal support organization efficiently.

**Remote Support Setup**

SAP support needs to be able to work remotely to achieve the highest efficiency and availability. Therefore, all required support tools must be remotely accessible for SAP support. For more information about how to set up remote connections, see the SAP Support Portal on SAP Service Marketplace at [service.sap.com/access-support](service.sap.com/access-support) » Available Connection Types ».

**Note**

For SAP Gateway and SAP back-end systems, the following connection types are a good starting point:

- HTTP Connect – URLAccess
- R/3 Support
- Connection types enabling the access to the operating system

**Problem Message Handover**

When creating a message, use the standard application component hierarchy. You find all the relevant components for the SAP TM collaboration portal below the component TM-CP.
## Typographic Conventions

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
</table>
| `<Example>` | Angle brackets indicate that you replace these words or characters with appropriate entries to make entries in the system, for example, “Enter your `<User Name>`”.
| 🔄 Example ➤ Example ➤ | Arrows separating the parts of a navigation path, for example, menu options
| Example | Emphasized words or expressions
| www.sap.com | Textual cross-references to an internet address
| `/example` | Quicklinks added to the internet address of a homepage to enable quick access to specific content on the Web
| 123456 | Hyperlink to an SAP Note, for example, SAP Note [123456](#)
| Example | - Words or characters quoted from the screen. These include field labels, screen titles, pushbutton labels, menu names, and menu options.
| | - Cross-references to other documentation or published works
| Example | - Output on the screen following a user action, for example, messages
| | - Source code or syntax quoted directly from a program
| | - File and directory names and their paths, names of variables and parameters, and names of installation, upgrade, and database tools
| EXAMPLE | Technical names of system objects. These include report names, program names, transaction codes, database table names, and key concepts of a programming language when they are surrounded by body text, for example, `SELECT` and `INCLUDE`
| EXAMPLE | Keys on the keyboard