Prerequisites

SAP NetWeaver Releases

  • SAP NetWeaver 7.5 SP01, or higher
  • No specific database is required, but SAP HANA DB is recommended.

Development Environment

  • We recommend to use the latest version of ABAP Development Tools for SAP NetWeaver (in short: ADT).

SAP Gateway

Authorizations

To reproduce the steps described in this guide, the user on SAP NetWeaver Application Server with the following roles assigned is required:

  • SAP_BC_DWB_ABAPDEVELOPER
  • SAP_BC_DWB_WBDISPLAY
  • /IWFND/RT_DEVELOPER (for SAP Gateway service development).

Knowledge

Basic knowledge of

  • ABAP Core Data Services (CDS)
  • BOPF programming model
  • SAP Gateway (transaction SEGW).