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1 Core Features Quick Reference

SAP® PowerDesigner® is a graphical enterprise architecture and design solution supporting standard
methodologies and notations and providing automated code reverse engineering and generation through
customizable templates. PowerDesigner provides powerful reporting capabilities, is highly extensible, and
offers a scalable enterprise repository solution with strong security and versioning capabilities to aid multi-user

development.
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Creating Models and Projects

Models are the basic working unit in PowerDesigner, and contain one or more diagrams. Projects contain one
or more models and can also include a framework diagram or matrix to guide how your project should be
modeled:

To create a new model, select | File » New Model J.

To create a new model by importing an Excel, Word, ERwin, XMI, Rational Rose, or SIMULS file, select |# File
» Import ¥ <t ype> 1.

To create a new model by reverse-engineering a database, process or object language files, or an XML

schema, select | File » Reverse Engineer ¥ <t ype> 4.

To create a new project, select [ File » New Project .

Setting Up Your Modeling Environment

To connect to a repository, select | Repository ¥ Connect 3.
To set model options including naming conventions for your objects, select | Tools » Model Options 3.

To control the look of and information displayed on your diagram symbols, select |+ Tools # Display

Preferences 3.
To set general options for dialog boxes, editors, variables, etc, select | Tools j General Options 3.

To customize the commands in your menus and tools in your toolbars, select ||p Tools » Customize Menus
and Tools 3.

The PowerDesigner Interface

These core features are available in all or many models:

4

To create an object in a diagram, select the appropriate tool in the Toolbox and then click in the diagram.
To create an object in the Browser, right-click the model or a package and select [# New » <Qbj ect

Type> 1.

To open an object property sheet, double-click its Browser entry or diagram symbol.

To add a diagram to your model, right-click the model node in the Browser and select |+ New » <Di agr am
Type> 1.

To find objects, select | Edit ¥ Find Objects J (or press + [F).

To find the Browser entry for an object symbol, right-click the symbol and select Find in Browser.

To find the diagram symbol for an object in the Browser, right-click the Browser item and select Find in
Diagram.

To check the validity of your model, select | Tools » Check Model 3 (or press|[F4)).
To add a dependency matrix to your model, right-click the model node in the Browser and select [ New

» Dependency Matrix 3.
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* To create a report on your model, select | Report ¥ Report Wizard 3 (or press + [FL2]).

* To enable the use of the glossary in your model, select [ Tools # Model Options 3, choose the Naming
Convention category, and select Use glossary for autocompletion and compliance checking .

Linking and Syncing

These features help you to create and review connections in and between your models:

¢ To create a connection from one object to any other object, open its property sheet and click the
Traceability Links tab.

* To generate one model from another (where available), select | Tools # Generate <t ype> Model 3.

* To generate objects from one model to another, select ||p Tools » Generate Objects ¥ Define New Object
Generation 3.

¢ To create a shortcut to an object in another model or package, right-click on the target object in the
Browser (or its symbol in a diagram) and drag and drop it into the diagram where you want to create the
shortcut (or onto a model or package in the Browser). Release the right mouse button, and select Create
Shortcut(s) Here.

* To create a synchronized replica of an object in another model or package, right-click on the target object
in the Browser (or its symbol in a diagram) and drag and drop it into the diagram where you want to
create the replica (or onto a model or package in the Browser). Release the right mouse button, and select
Replicate Here.

* To create or review mappings between two models (where available), select |+ Tools  Mapping Editor 3
*  To compare two models, select | Tools ' Compare Models 3 (or press + [Fe)).
* To merge two models, select || Tools  Merge Models 3 (or press + [Fe).

* To analyze the impact of a change to an object, select [ Tools » Impact and Lineage Analysis 3 (or press

Q] + )

Documentation

For detailed documentation, see Core Features Guide .

1.1 Manipulating Symbols

You can select symbols in a PowerDesigner diagram using standard gestures. You can edit properties of the
selected symbol's object or it's sub-objects, and resize the symbol by clicking and dragging on its handles.

Click on a symbol with the default Pointer tool to select it. To select:

* Additional symbols, press and hold while clicking them.
¢ All symbolsinan area, click and hold while dragging the pointer over the area.
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* All symbols connected to a symbol, click the symbol and then select | Edit » Select Connected Symbols 3
* All symbols in the diagram, press + , click the Grabber tool, or select |» Edit » Select All

In the following example, the Cust oner table is selected, and can be moved by dragging or resized by dragging
on one of its handles:

. Sul.:ucnn.trac't.

® Note

To resize all the symbols in a diagram at once, click the Grabber tool and then drag one of the handles.

When a symbol is selected, clicking on one of its object properties lets you edit its value. Now, the table name is
selected for editing:

.Sul.:-cnn.tra-::t.

When an object property is selected for editing, you can navigate through its editable properties and on into its
sub-object properties by pressing the|Tab|or|[shift | + [Tab|keys.

® Note

You can control the object and sub-object properties that appear on a symbol using display preferences
(I Tools ¥ Display Preferences ).

When a symbol is selected, clicking on one of its sub-objects selects that sub-object. Now, the Cust oner
acti vi ty column sub-object is selected:
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-Sul.:ucnn-tr.ac't.

You can navigate up and down in the list of sub-objects by pressing the Up Arrow or Down Arrow keys. When a
sub-object is selected, clicking on one of its properties lets you edit its value. Now the Cust oner activity
column name is selected for editing:

.Sul.:-c-:-n.tra-:'t.

To create a new sub-object at the end of the list, press + [N]. Toinsert a new sub-object above
the selected sub-object, press + [1]. To delete the selected sub-object, press el | Right-clicking a
sub-object opens a contextual menu offering useful commands.

When a sub-object property is selected for editing, you can navigate right and left along the line of its editable
properties by pressing the [ Tab|or|shift | + [Tab|keys.

® Note
The following kinds of properties are not editable via object symbols:

* Boolean properties, such as the Abstract property on OOM class symbols.
* Custom indicators, such as those used to identify keys and indexes on PDM table symbols.
* Certain calculated properties, such as Domain or Datatype on PDM table symbols.
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1.2 Manipulating Link Symbols

You can add and remove corners to and from link symbols, and change the objects that they connect.

Procedure

1. Draw a link between two objects:

8

Class A

Clas= B

Press Ctrl and click a point on the line to create a handle where you want to insert a corner:

Class A

Claz= B

You can add a second handle, or as many as you need:

Class A

Clas= B

To create a corner, click and hold the handle and then drag it to where you want the corner to be:

Class A

Clas= B

" /A\a% "

You can drag the other handles too:

Class A Clas= B

To remove a handle (and corner), press Ctrl and click on the handle to remove:
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Clasz A Clas=z B

® Note

To move an extremity of a link symbol from one object to another, click to select the link, and then drag
the end handle to the new object.
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2 Glossary Quick Reference

The glossary model (GLM) helps you capture and organize the terminology to be used for naming your model

[¢]

bjects. An administrator deploys the glossary, and users enable it in their models to provide autocompletion

for object names and model checks to ensure compliance. The glossary appears in the Browser Glossary tab

a
p

nd updates are pushed to users each time they connect to the repository, or on demand. Only one glossary is
ermitted per repository.
Fitter: IE Eiter: gh IE
I'_‘: Glossary Root - IZ: Glossany Root
=-*[ 8 Glossary * ||| =8 Glossary *

----- 3 abstract {74 object

""" 74 abstract data type %} ohject allocation map (OAM)

..... {3 abstraction (%4 ohject identifier (QI0)

""" £ actor (%4 ohject queue 1D {0GID)

""" €79 actors = %4 ohject request broker (JRE)

----- £ actual parameter 1 {4 problem domain

Administering the Glossary

An administrator performs the initial deployment of the glossary to the repository by adding terms to it and
checking it into the repository:

U

10

To control access to the glossary, right-click the Glossary node, and select Permissions. By default, all users
have Read permission on the glossary.

To import terms from the names of objects from a PowerDesigner model open in your workspace, right-
click the Glossary node, and select Import from Model.

To import terms from an Excel or CSV file, right-click the Glossary node, and select Import from Excel File.

To create a glossary terms list, right-click the Glossary node, and select |» New » Glossary Terms List 4.

sing the Glossary

To consult the glossary, click the Browser Glossary tab.

To enable the use of the glossary in your model, select |+ Tools  Model Options 3, then click Naming
Convention in the category list and select Use glossary for autocompletion and compliance checking.

To check glossary compliance, select [ Tools » Check Model 3 and select the Name/Code contains terms
not in glossary and Name/Code contains synonyms of glossary terms for the types of objects whose names
you want to verify.
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Documentation

For detailed documentation, see Core Features Guide > Modeling with PowerDesigner > The Browser > The
Glossary .
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3 Requirements Model Quick Reference

A requirements model (RQM) helps you analyze any kind of written requirements and link them with users and
groups who will implement them and with design objects in other models. You can use an RQM to represent
any structured document (e.g. functional specification, test plan, business goals, etc.) and import and export
hierarchies of requirements as MS Word documents.

dd )l m | mE| e o [SEE|[=|Em 4 2@ X |0 % 4.

=L Warkspace - . .
JEjEO E_l,lerFrin:Ige = 1 Title |1 - Full Descnptl-on - 1F'n0r|t_l,l
N [ 1. Project Description of
----- [E Scenario / Use case Ta rget System

=14 Requirements
@ 1. Project Description of T arget Systern
2. Scenario Descriptions

The CyberFridge project s to use Internet
comnectvity, viston and mechamical systems to

3 Functional Fequirsments create an mteligent and productive refrigerator.
4. MorFunctional Requirerents Many of our daly tasks revolve around the
@ 5. Development and Target Platforms 2 . . . 1
@ . Risk Anayeis =2. Scenario Descriptions
4 Files 3 - 1
) cybefiidge. 2.1 Scenario 1

An haz had a horrible day. On the way to work

Creating an RQM

* Tocreate anew RQM - Select |» File » New Model Z, and choose Requirements Model.
* To create a new RQM by importing a Word document - Select ||» File » Import » Word Document
The following types of views are available:
* Arequirements document view displays a list of written requirements in a hierarchic grid. Multiple views

can be created with different filters to display various subsets of requirements.

¢ Atraceability matrix view displays the links between requirements and objects from other types of models,
external files or other requirements.

* Auser allocation matrix view displays the links between requirements and the users and groups who will

fulfill them.

Linking Requirements with Design Objects and External Files

You can link requirements to objects from other types of models, external files, and other requirements on the
Requirement Traceability Links tab of the requirement property sheet.
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Documentation

For detailed documentation, see Requirements Management .
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4 Enterprise Architecture Model Quick

Reference

An enterprise architecture model (EAM) helps you analyze and document your organization, its capabilities
and processes, the applications and systems that support them, and the physical architecture on which they

are implemented.
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* Tocreate a new EAM - Select ¢ File » New Model 1, and choose Enterprise Architecture Model.

* To create a new EAM by importing an Excel file - Select |+ File » Import » Excel File 3.

* Tocreate a new EAM by importing a Visio diagram - Open your diagram in Visio and select

|» PowerDesigner » Export to PowerDesigner Model 3.
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The following types of diagrams are available:

A process map provides a graphical view of your business architecture, and helps you identify your
business capabilities and high-level processes, independent of the people and business units who fulfill
them.

An organization chart provides a graphical view of your organization as a tree structure, and helps
you analyze and display the relationships between organization units (divisions, groups, teams, etc),
individuals, and roles.

A business communication diagram provides a graphical view of your organization, and helps you analyze,
the relationships, flows, and other connections between business capabilities, organization units, roles,
and sites.

A city planning diagram provides a graphical view of the big picture of your enterprise architecture, using
the metaphor of planning the infrastructure of a city to represent the organization of capabilities, systems,
applications, etc into areas.

A service-oriented diagram provides a graphical view of your business and application services and the
relationships between them, and helps you associate applications and other application layer objects with
business services and processes to assist with SOA design.

An application architecture diagram provides a high-level graphical view of the application architecture,
and helps you identify applications, sub-applications, components, databases, services, etc, and their
interactions.

A technology infrastructure diagram provides a high-level graphical view of the physical architecture
required to support the application architecture.

A timeline diagram provides a calendar-style overview of your enterprise architecture programs and
projects in relation to your goals, or to the assets that they impact or are in other ways related to.

Exporting and Importing Objects to and from Other Models

The EAM provides wizards to export EA objects to lower-level models and to import implementation objects to

be represented in the EAM:

To export EAM objects to another model - Select [ Tools » Export Objects Wizard 3
To import objects from other models into an EAM - Select | Tools ¥ Import Objects Wizard 3

Documentation

For detailed documentation, see Enterprise Architecture .

Quick Reference
Enterprise Architecture Model Quick Reference PUBLIC 15



5 Business Process Model Quick Reference

A business process model (BPM) helps you identify, describe, and decompose business processes. You can
analyze your system at various levels of detail, and focus alternatively on control flow (the sequence of
execution) or data flow (the exchange of data). SAP® PowerDesigner® supports Analysis, SOA, DFD, SAP®
Solution Manager, BPMN (including for SAP BPM), and BPEL process languages, and process simulation
through SIMULS.
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Change CC

[Booking ermror2]

7
. ;(\'x Motify customer F)
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Creating a Business Process Model

* To create a new, empty BPM, select | File » New Model 3, and choose Business Process Model.
* Toreverse engineer a new BPM from process language files, select ||+ File » Reverse Engineer  Process
Language 3.
The following types of diagrams are available:
* Abusiness process diagram (or process flow diagram) provides a graphical view of the control flow (the

sequence of execution) or data flow (the exchange of data) between processes at any level in your system.
* A process hierarchy diagram (or functional decomposition diagram) provides a graphical view of the
functions of a system and helps you decompose them into a tree of sub-processes.
* A process service diagram provides a graphical view of the services, operations, and interfaces available in
your system.
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Working with Data in a BPM

PowerDesigner provides various methods for linking data in your BPM to data items, entities, tables or classes
in other PowerDesigner models:

¢ Tolink datain a BPM with other PowerDesigner objects, use the Definition field on the General tab of the
data property sheet.

* Toexport data in a BPM to other PowerDesigner objects, select | Tools » Data Export Wizard 3.
* Toimport other PowerDesigner objects as data in a BPM, select |» Tools » Data Import Wizard 3.

Working with Process Language Definitions

The process language definition file defines features specific to the language being modeled:

* To open the process language definition file in the Resource Editor, select ||p Language » Edit Current

Process Language 3.

* To change the process language to model with, select | Language » Change Current Process Language 3.

Documentation

For detailed documentation, see Business Process Architecture .
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6 Conceptual and Logical Data Model Quick

Reference

A conceptual data model (CDM) helps you analyze the conceptual structure of an information system, to
identify the principal entities to be represented, their attributes, and the relationships between them. A CDM is
more abstract than a logical (LDM) or physical (PDM) data model.

A logical data model (LDM) helps you analyze the structure of an information system, independent of any
specific physical database implementation. An LDM has migrated entity identifiers and is less abstract than
a conceptual data model (CDM), but does not allow you to model views, indexes and other elements that are

available in the more concrete physical data model (PDM).
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Creating a CDM or LDM

* Tocreate anew CDM, select |} File » New Model
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* Tocreate a new LDM, select |} File » New Model J, and choose Logical Data Model.

* To create anew CDM or LDM by importing one or more ERwin files, select |» File » Import » ERwin File J or
| File » Import » Multiple ERwin Files 3.

Specifying a Modeling Notation and Other Options

* To specify a modeling notation and set other model options, select [ Tools » Model Options 3.

Generating Other Models

You can generate other PowerDesigner models from a CDM or LDM by selecting Tools >:

* Generate Conceptual Data Model (or press[ctrl | + +[2)

* Generate Logical Data Model (or press[ctrl | + + L]

* Generate Physical Data Model (or press[ctrl | + + [P

e [CDM only] Generate Object-Oriented Model (or press + + [0

Documentation

For detailed documentation, see Data Architecture .
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7

Physical Data Model Quick Reference

A physical data model (PDM) helps you to analyze the tables, views, and other objects in a database, including
multidimensional objects necessary for data warehousing. A PDM is more concrete than a conceptual (CDM)
or logical (LDM) data model. You can model, reverse-engineer, and generate for all the most popular DBMSs.
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Creating a Physical Data Model

* Tocreate a new, empty PDM, select

* Toreverse engineer a new PDM from a live database connection, select

Database

Start date (par) date
End date (par) date
File » New Model

¢ To create a new PDM by importing one or more ERwin files, select

Import

Multiple ERwin Files

The following types of diagrams are available:
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A physical data diagram provides a graphical view of your database structure, and helps you analyze its
tables (including their columns, indexes, and triggers), views, and procedures, and the references between
them.

A multidimensional data diagram provides a graphical view of your datamart or data warehouse database,
and helps you identify the facts and dimensions that will be used to build its cubes.

Specifying a Modeling Notation and Other Options

To specify a modeling notation, column, reference, and ownership defaults and set other model options,
select |p Tools » Model Options 3.

Interacting with Databases

To connect to a database, select |+ Database » Connect 3.
To generate a database, select |» Database » Generate Database 3.
To modify a database, select [ Database » Apply Model Changes to Database 1.

To reverse engineer from a live database connection into an existing PDM, select |» Database # Update
Model from Database 3.

To generate test data to a database, select | Database ¥ Generate Test Data 3.

To estimate the size of a database, select | Database » Estimate Database Size 3

Generating Other Models

You can generate other PowerDesigner models from a PDM by selecting Tools >:

Generate Conceptual Data Model (or press[ctrl | + + [2)
Generate Logical Data Model (or press[ctrl | + + L]
Generate Physical Data Model (or press[ctrl | + + [P
Generate Object-Oriented Model (or press[arl | + + [0
Generate XML Model (or press[ctrl | + +[c)

Working with DBMS Definitions

The DBMS definition file defines features specific to the DBMS being modeled:

To open the DBMS definition file in the Resource Editor, select | Database » Edit Current DBMS .
To change the DBMS to model with, select |+ Database  Change Current DBMS J.
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* To set default DBMS-specific physical options, select | Database » Default Physical Options 3.

Documentation

For detailed documentation, see Data Architecture .
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8 Data Movement Model Quick Reference

A data movement model (DMM) provides a global view of the movement of information in your organization.
You can analyze and document where your data originates, where it moves to, and how it is transformed on the
way, including replications and ETL.

%y Suip Admin Accounts

1 DataProjedction. 1

Login  A3D 20 = . r'.
Admin Sl Login A1D0 100 $
not Admin = 1 G
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Creating a Data Movement Model

e To create a new, empty DMM - Select |+ File » New Model 3, and choose Data Movement Model.
¢ Toreverse engineer replication processes into a DMM from a consolidated database connection - Select
|» Tools » Reverse Engineering Replication Server .
* Toimport an SAP Data Services XML file into a DMM - Select [ Tools » SAP Data Services 4.2 ¥ Import
SAP Data Services XML File 3.
The following types of diagrams are available:
* Adata movement diagram provides a high-level graphical view of the movement of your information,

including data sources, replications, and ETL operations.

¢ Adatatransformation diagram provides a graphical view of the inputs, outputs, and steps involved in a
data transformation task.

* Atransformation control flow diagram provides a graphical view of the order in which a series of data
transformation tasks is linked together in a control flow.

Creating Replication and Transformation Environments

¢ To create an environment to replicate data from one or more databases to one or more databases, select
|# Tools » Replication Wizard 3.

* To create a transformation process to transform data from databases, XML documents, business
processes, and flat files, select |+ Tools » ETL Wizard 3.

* To create a transformation process from existing PDM-to-PDM mappings, select | Tools » Convert
Mappings to ETL Wizard 3.
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Documentation

For detailed documentation, see Data Movement Architecture .
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9 Object-Oriented Model Quick Reference

An object-oriented model (OOM) helps you analyze an information system through use cases, structural and
behavioral analyses, and in terms of deployment, using the Unified Modeling Language (UML). You can model,
reverse-engineer, and generate for Java, .NET and other languages.
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Creating an Object-Oriented Model

¢ Tocreate a new, empty OOM - Select

* Toreverse engineer a new OOM from a object language files - Select

Language

* Toimport a Rational Rose model into an OOM - Select

¢ Toimport an XMl file into an OOM - Select
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File » New Model Z, and choose Object Oriented Model.

File

The following types of diagrams are available:

Import

File

File
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* Ause case diagramis a UML diagram that provides a graphical view of the requirements of your system,
and helps you identify how users interact with it.

¢ Aclass diagramis a UML diagram that provides a graphical view of the classes, interfaces, and packages

that compose a system, and the relationships between them.

* Anobjectdiagramis a UML diagram that provides a graphical view of the structure of a system through
concrete instances of classes (objects), associations (instance links), and dependencies.

¢ A composite structure diagram is a UML diagram that provides a graphical view of the classes, interfaces,
and packages that compose a system, including the ports and parts that describe their internal structures.

* A package diagram is a UML diagram that provides a high-level graphical view of the organization of your
application, and helps you identify generalization and dependency links between the packages.
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* Asequence diagram is a UML diagram that provides a graphical view of the chronology of the exchange
of messages between objects and actors for a use case, the execution of an operation, or an interaction
between classes, with an emphasis on their chronology.

* A communication diagram is a UML diagram that provides a graphical view of the interactions between
objects for a use case scenario, the execution of an operation, or an interaction between classes, with an
emphasis on the system structure.

* Aninteraction diagram is a UML diagram that provides a high-level graphical view of the control flow of
your system as it is decomposed into sequence and other interaction diagrams.

* Anactivity diagram is a UML diagram that provides a graphical view of a system behavior, and helps you
functionally decompose it in order to analyze how it will be implemented.

¢ A statechart diagram is a UML diagram that provides a graphical view of a State Machine, the public
behavior of a classifier (component or class), in the form of the changes over time of the state of the
classifier and of the events that permit the transition from one state to another.

* A component diagram is a UML diagram that provides a graphical view of the dependencies
and generalizations among software components, including source code components, binary code
components, and executable components.

¢ Adeployment diagram is a UML diagram that provides a graphical view of the physical configuration of
run-time elements of your system.

Generating Other Models

You can generate other PowerDesigner models from an OOM by selecting Tools >:

* Generate Conceptual Data Model (or press[ctr! | + +[2)
* Generate Physical Data Model (or press[ctrl | + + [P

* Generate Object-Oriented Model (or press[ctrl | + + [op)
* Generate XML Model (or press[arl | + + [M)

Working with Object Language Definitions

The object language definition file defines features specific to the language being modeled:

* To open the object language definition file in the Resource Editor, select | Language ¥ Edit Current Object
Language 3.
* To change the process language to model with, select |» Language » Change Current Object Language 3.

Documentation

For detailed documentation, see Object-Oriented Architecture .
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10 XML Model Quick Reference

An XML model (XSM) helps you analyze an XML Schema Definition (.XSD), Document Type Definition (.DTD) or
XML-Data Reduced (.XDR) file. You can model, reverse-engineer, and generate each of these file formats.
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Creating an XML Model

* To create a new, empty XSM - Select | File » New Model , and choose XML Model.

¢ Toreverse engineer a new XSM from an XML schema definition - Select |j¢ File » Reverse Engineer » XML
Definition
Generating Other Models

You can generate other PowerDesigner models from an XSM by selecting Tools >:

* Generate Physical Data Model (or press[ctri ] + + [P]
*  Generate XML Model (or press[arl | + + [M)

Working with XML Language Definitions

The XML language definition file defines features specific to the language being modeled:
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* Toopen the XML language definition file in the Resource Editor, select |» Language » Edit Current
Language 3.
* To change the XML language to model with, select [ Language » Change Current Language 3.

Documentation

For detailed documentation, see XML Architecture .
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11 Free Model Quick Reference

A free model (FEM) provides a context-free environment for modeling any kind of objects or systems. You can

use it to sketch simple visualizations or create entirely new forms of model by defining your own concepts and
graphical symbols through an extension file.
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Creating a Free Model

To create a new, empty FEM - Select ||» File » New Model 3, and choose Free Model.

Changing a Symbol Image

PowerDesigner provides a library of high-quality symbols to use in your models. To change the image
associated with a symbol, right-click the symbol and select Change Image.
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Industry

Finance Educaticn

Documentation

See the Extensions Quick Reference [page 33]. For detailed documentation, see Customizing and Extending
PowerDesigner > Extension Files .
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12 SAP Platform Support Quick Reference

PowerDesigner provides support for various components in the SAP platform.

SAP HANA

PowerDesigner supports round-trip reverse-engineering and generation of HANA tables and other catalog
objects directly or via CDS entities for SAP HANA® 1.0 and 2.0 databases. In addition, for SAP HANA®

1.0 environments, PowerDesigner supports initializing and reverse-engineering graphical calculation views
(including the XML definition and projection list) for inclusion in impact analysis.

For detailed documentation, see Data Architecture > DBMS Definition Reference > SAP HANA .

SAP HANA Core Data Services (CDS)

PowerDesigner supports modeling and generation of CDS artifacts to SAP HANA® 1.0 Classic Repository and
SAP HANA® 1.0 and 2.0 HDI environments.

For detailed documentation, see Data Architecture > DBMS Definition Reference > SAP HANA .

SAP Business Suite

An SAP Business Suite installation is built on a complex database structure, which comprises many thousand
tables with often cryptic names, and may include large numbers of customizations. In certain environments,
there may be multiple servers, each with different customizations. PowerDesigner allows you to browse the
application component and package hierarchy and to import them and their supporting logical objects for
analysis, comparison, and merging of data dictionaries, and can also help you prepare a HANA table structure
to allow consolidated reporting on one or more SAP® Business Suite installations.

PowerDesigner supports importing any recent version of SAP® Business Suite.

For detailed documentation, see Data Architecture > DBMS Definition Reference > SAP Business Suite .

SAP BusinessObjects

PowerDesigner supports generation of a SAP® BusinessObjects™ universe from your PDM for editing in
the BusinessObjects Universe Design or Information Design tools, or for direct consumption by the Web
Intelligence rich client. Generating a universe from your PDM gives you access to table, view, and column
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names and comments and more reliable cardinality information than if you create a universe directly from your
database.

To generate universes, you must have SAP® BusinessObjects™ SBOP BI Platform Clients 4.0 SP04 Patch
3(v14.0.4.819) or higher installed on your workstation. On Windows Vista or Windows 7 machines, if
PowerDesigner fails to recognize a valid BusinessObjects installation, it may be necessary separately to launch
the Universe Design tool one time with administrator privileges to enable the BusinessObjects SDK.

For detailed documentation, see Data Architecture > Building Data Models > Generating and Reverse-
Engineering Databases > Generating an SAP BusinessObjects Universe .

SAP Solution Manager

PowerDesigner supports round-trip importing and exporting of SAP® Solution Manager v7.1 SPO7 to SP13
projects through the desktop client. You can import SAP® Solution Manager v7.2 process diagrams via the
PowerDesigner Web client and export changes to those diagrams back to the Solution Manager v7.2 server.

For detailed documentation, see Business Process Architecture > SAP Solution Manager and PowerDesigner
Web > Business Processes > Importing SAP Solution Manager 7.2 Process Diagrams .

SAP NetWeaver

PowerDesigner supports round-trip importing and exporting of SAP BPM v7.3 and higher BPMN 2.0 files.
PowerDesigner Web makes your process models available for browsing and importing directly into the SAP
NetWeaver Developer Studio Process Composer v7.3 EHP1 SP15 or higher.

For detailed documentation, see Business Process Architecture > BPMN 2.0 Descriptive and Executable >
Importing and Exporting BPMNZ Files .

SAP Data Services

PowerDesigner supports round-trip importing and exporting of SAP Data Services v4.2 and higher XML files.

For detailed documentation, see Data Movement Architecture > ETL Modeling > SAP Data Services .

SAP Information Steward

PowerDesigner can be used as a metadata integrator with SAP Information Steward v 4.2 SPO1 and higher.

For detailed documentation, see the Information Steward documentation at https://help.sap.com/docs/
SAP_INFORMATION_STEWARD.
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13 Extensions Quick Reference

Extensions files (*. xem) allow you to customize and extend the PowerDesigner metamodel to support your
exact modeling needs. You can define additional properties for existing objects or specify entirely new types of
objects, modify the PowerDesigner interface (reorganizing and adding property sheet tabs, Toolbox tools and
menu items), and define additional generation targets and options.
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Creating Extensions from a Property Sheet

To create an extended attribute directly from an object property sheet, click the menu button, and select
New Attribute.

To create a new collection directly from an object property sheet, click the menu button, and select New
List of Associated Objects.
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Working with Extension Files

* To attach an existing extension file to a model, select |p Model » Extensions 3, and click the Import tool.

e To create a new extension file, select | Model ¥ Extensions 3, click the Add a Row tool, enter a name for
the file, and then click the Properties tool.

Types of Extension

You can extend the metamodel in the following ways:

¢ Create or sub-classify new kinds of objects:
* Metaclasses - drawn from the metamodel as a basis for extension.
¢ Stereotypes [for metaclasses and stereotypes only] — sub-classify metaclasses by stereotype.
¢ Criteria — sub-classify metaclasses by evaluating conditions.
¢ Add new properties and collections to objects and display them:
* Extended attributes - to add metadata.
¢ Extended collections and compositions — to enable manual linking between objects.
¢ (Calculated collections — to automate linking between objects.
* Dependency matrices — to show dependencies between two types of objects.
* Forms - to modify property sheets and add custom dialogs.
¢ Custom symbols — to change the appearance of objects in diagrams.
¢ Add constraints and validation rules to objects:
* Custom checks - to test the validity of your models on demand
¢ Event handlers — to perform validation or invoke methods automatically.
* Execute commands on objects:
* Methods — VBScripts to be invoked by menus or form buttons.
* Menus [for metaclasses and stereotypes only] — to add commands to PowerDesigner menus.
* Generate objects in new ways:
¢ Templates — to extract text from object properties.
* Generated Files - to assemble templates for preview and generation of files
¢ Transformations — to automate changes to objects at generation or on demand.
* Map correspondences between different metamodels:

¢ Object generations - to define mappings between different modules in the PowerDesigner metamodel
for model-to-model generation.

* XML imports - to define mappings between an XML schema and a PowerDesigner module to import
XML files as models.

Documentation

For detailed documentation, see Customizing and Extending PowerDesigner > Extension Files .
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14 Shortcut Keys

PowerDesigner provides many shortcut keys to accelerate your workflow.

Toolbox Shortcuts

Shortcut

Action

+ (or double-click Pointer tool)

Select all symbols in diagram.

Double-click Delete tool

Delete selected symbols (with confirmation).

Double-click Grabber tool

Zoom to whole diagram.

Double-click any object tool

Select all symbols of this type.

Shi ft [+Double-click any object tool

Retain current selection and add all symbols of this type.

Right-click

Release tool and select pointer.

Browser Shortcuts

Shortcut

Action

(number pad)

Expand all nodes.

(number pad)

Expand subnodes.

D(number pad)

Collapse subnodes.

Rename selected item.

[ari] + [snite] + [F]

Find selected item in Diagram.

Diagram Shortcuts

Action

Delete object with confirmation dialog.

[%2]
=2
o
It
i
(2]
c
~+

Shi ft

Delete object directly, without confirmation.

+ |Ente

Open object property sheet.

HiE
+
+
&
=

Paste as shortcut.
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Action

[on selected link] Force link to horizontal.

[on selected link] Force link to vertical.

Bring symbol to front.

Send symbol to back

Crl | + Align selection on vertical axis.
+ Align selection on horizontal axis.
+ Open Symbol Format dialog.

+[3]

Auto-resize the symbol to display all the text it contains (up to the value

specified for word wrapping in the diagram).

while dragging a symbol handle

Resize object while keeping same center point.

+ While dragging a symbol han-

dle

Resize object while keeping same center point and proportions.

(or +Right-c|ick on Name)

Rename object.

Double-click (or + (plus sign)

[on package or other composite symbol] Open subdiagram.

+ [yl

Go to parent diagram.

Drag and Drop Shortcuts

Shortcut Action
+Drag and drop Move object.
+Drag and drop Copy object.

+ +Drag and drop

Create shortcut of object.

+Drag and drop

Create replica of object.

Right-click+Drag and drop

Open menu to choose an action.

Window and General Shortcuts

[%2]
=2
o
=
-
[2]
c
=

Action

T
N

Check model.

Zoom to actual size.

Zoomiin.

Zoom out.

m ||| |
| [N]||O]|||0

Zoom to whole diagram.
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Shortcut Action
Previous view.
F10 Display used pages.
+ Redisplay.
Next view.

(231N
EAES
—- ||| ==
|||~
+
=

Shi ft [+Click item

Select consecutive items.

+

Show/hide Browser.

+

Show/hide Output view.

+

Show/hide Result List view.

Show/hide Welcome page.

+

Cycle between active windows.

HEEEE
+
HEREEE

+
—
@

o

Cycle between property sheet tabs.

[Crl | + [Page Up|/[Ctrl| + [Page Down| Cycle between property sheet tab subtabs.
+ / + + Cycle between property sheets.
+ Find selected object in Browser.
+ |§| Select diagram.

+ Open list of reports.

crl | + Find objects.

+ Close diagram.

+ + Close model.

+ Open workspace.

+ Save workspace.

+ Close workspace.

List Shortcuts

Shortcut Action

Select text for edit.
Select cell to add text.
[arl | + [shift]| + [Spacebar Select line.

+ Select all.

+ + Deselect all.

crl | + Add entry.

+ |I| Insert entry.

Quick Reference
Shortcut Keys

PUBLIC

37



Shortcut

Action

[art] + [o]

Delete entry.

Code Preview Tab Shortcuts

Shortcut Action

Next bookmark.
Find next.

+ Menu.

Insert/Remove bookmark.

a

r

+

+ [F2]
1]

Insert file.
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Important Disclaimers and Legal Information

Hyperlinks

Some links are classified by an icon and/or a mouseover text. These links provide additional information.
About the icons:

®  Links with the icon o : You are entering a Web site that is not hosted by SAP. By using such links, you agree (unless expressly stated otherwise in your
agreements with SAP) to this:
®  The content of the linked-to site is not SAP documentation. You may not infer any product claims against SAP based on this information.
®  SAPdoes not agree or disagree with the content on the linked-to site, nor does SAP warrant the availability and correctness. SAP shall not be liable for any
damages caused by the use of such content unless damages have been caused by SAP's gross negligence or willful misconduct.
L]

Links with the icon ’h": You are leaving the documentation for that particular SAP product or service and are entering an SAP-hosted Web site. By using
such links, you agree that (unless expressly stated otherwise in your agreements with SAP) you may not infer any product claims against SAP based on this
information.

Videos Hosted on External Platforms

Some videos may point to third-party video hosting platforms. SAP cannot guarantee the future availability of videos stored on these platforms. Furthermore, any
advertisements or other content hosted on these platforms (for example, suggested videos or by navigating to other videos hosted on the same site), are not within
the control or responsibility of SAP.

Beta and Other Experimental Features

Experimental features are not part of the officially delivered scope that SAP guarantees for future releases. This means that experimental features may be changed by
SAP at any time for any reason without notice. Experimental features are not for productive use. You may not demonstrate, test, examine, evaluate or otherwise use
the experimental features in a live operating environment or with data that has not been sufficiently backed up.

The purpose of experimental features is to get feedback early on, allowing customers and partners to influence the future product accordingly. By providing your
feedback (e.g. in the SAP Community), you accept that intellectual property rights of the contributions or derivative works shall remain the exclusive property of SAP.

Example Code

Any software coding and/or code snippets are examples. They are not for productive use. The example code is only intended to better explain and visualize the syntax
and phrasing rules. SAP does not warrant the correctness and completeness of the example code. SAP shall not be liable for errors or damages caused by the use of
example code unless damages have been caused by SAP's gross negligence or willful misconduct.

Bias-Free Language

SAP supports a culture of diversity and inclusion. Whenever possible, we use unbiased language in our documentation to refer to people of all cultures, ethnicities,
genders, and abilities.
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