Content

1 Document History. .............................................................. 4

2 Introduction to the translation management tool. ........................................ 5
   2.1 Introduction to the translation management tool. .................................. 5
   2.2 Which resources can you translate? ....................................................... 6
   2.3 About translating Web Intelligence reports. .............................................. 6
   2.4 About translating universes from the universe design tool. ....................... 7
   2.5 About translating universes from the information design tool. .................. 8
   2.6 Terminology used in the translation management tool. ............................ 8
   2.7 About authentication and security. ....................................................... 10

3 Getting started with the tool. ................................................…… 11
   3.1 To logon ............................................................................................... 11
   3.2 To change your login password. .............................................................. 11
   3.3 About the translation management tool window. .................................... 12
       About the Translation Editor view. ......................................................... 12
       About the Language Management view. ................................................ 13
       About the Text Editor view. ................................................................. 14
       About the Filter view. ................................................................. 15
       About the Cell Properties view. ............................................................ 15
       About the Help view. ................................................................. 16
   3.4 Customizing the translation management tool window. ......................... 16
   3.5 Setting preferences. .............................................................................. 16
       To set the product language. .............................................................. 17
       To set default folder locations. ............................................................ 17
       To set the locale to add automatically. ................................................. 18
       To set frequently used languages. ....................................................... 18
       To set Auto-fill options. ........................................................................ 18
       To set sample data for formats. ........................................................... 19

4 Translation workflows. ............................................................. 20
   4.1 About translation workflows. ................................................................. 20
   4.2 How translated locales are managed. .................................................. 20
   4.3 About security and translation rights. .................................................... 21
   4.4 About concurrent translation ............................................................... 22
   4.5 About translating a resource from the CMS repository. ................. 22
       To import content to translate from a resource in the CMS repository. .... 23
       About exporting the translations to the source resource in the CMS repository. 24
The following table provides an overview of the most important document changes.

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP BusinessObjects BI platform 4.1</td>
<td>May 10, 2013</td>
<td>First release of this document.</td>
</tr>
<tr>
<td>SAP BusinessObjects BI platform 4.1 Support Package 4</td>
<td>June 2014</td>
<td>Translation support has been added for Analysis, edition for OLAP.</td>
</tr>
<tr>
<td>SAP BusinessObjects BI platform 4.2</td>
<td>November 2015</td>
<td>Updated the guide with branding changes.</td>
</tr>
</tbody>
</table>
Introduction to the translation management tool

2.1 Introduction to the translation management tool

The translation management tool provides a framework to support the localization requirements for international deployments of BusinessObjects Enterprise.

Users can work in their respective languages with the following types of documents:

- Resources stored locally or in the repository: Web Intelligence document, universe design tool universe (.unv).
- Resources stored locally or in the Shared Projects folder (in the repository): the Business Layer and Data Foundation for universes generated by the information design tool.
- Resources stored only in the repository: workspaces created by Analysis, edition for OLAP, dashboards created by Dashboard Design and workspaces created by BI workspace, Crystal Reports for Enterprise documents, and most InfoObjects.

For a multilingual audience, a universe or report designer can create one document and translate it in multiple languages with the translation management tool instead of creating a universe or document in each language.

The translations are saved in the universe and report documents, and displayed in the reader’s language at reporting time.

For importing from the repository the content to translate, the tool uses the Translation Server to communicate with the other modules. Refer to the Administration Guide for more information about the translation server. Content that is imported is stored locally in the TMGR format. The TMGR format file is also used to manage the exchanges between the translation management tool and the translation server.

Features of the tool include:

- Ability to translate metadata in most SAP BusinessObjects resources: Analysis workspaces, universes, Web Intelligence reports, and Crystal Reports for Enterprise documents.
- An interface designed for in-house translations.
- A format editor to easily define custom date, time, and number formats.
- Ability to manage approximately 130 locales.
- Enterprise deployment, with full integration with SAP BusinessObjects Enterprise including support for all Central Management Server (CMS) authentication modes and a standalone mode.
- Mid Market (Small-scale) or Local deployment with no repository.
- Collaboration with external translators using XLIFF (XML Localization Interchange File Format) files. This format is used by professional translators and is compatible with many translation tools.
- Ability to perform concurrent and offline translation.
- Support of the translation status throughout the translation process.

Note

The translation management tool runs on Windows platforms, though it can connect to Central Management Server running on other platforms.
2.2 Which resources can you translate?

You can translate the following resources:

Table 1: Translatable resource types

<table>
<thead>
<tr>
<th>Resource type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analysis workspaces</td>
<td>Stored in the CMS repository and saved in Analysis, version 4.1 SP4 and higher.</td>
</tr>
<tr>
<td>Web Intelligence reports</td>
<td>Stored locally or in the CMS repository</td>
</tr>
<tr>
<td>Universes created by the universe design tool</td>
<td>Stored locally or in the CMS repository</td>
</tr>
<tr>
<td>Data Foundations or Business Layers created with the information design tool</td>
<td>Stored locally or in the Shared Projects folder of the CMS repository</td>
</tr>
<tr>
<td>Crystal Reports for Enterprise documents</td>
<td>Stored in the CMS repository and created with BI 4</td>
</tr>
<tr>
<td>Dashboards created with Dashboard Design</td>
<td>Stored in the CMS repository and created with BI 4</td>
</tr>
<tr>
<td>Workspaces created with BI workspace and most InfoObjects</td>
<td>Stored in the CMS repository</td>
</tr>
</tbody>
</table>

Restriction

- The translation management tool does not support documents created with Crystal Reports 2011 or 2013.
- The translation management tool can translate only the following previous-version resources: Web Intelligence documents (wid), Universe Designer universes (unv), and general InfoObjects.
- The translation management tool does not translate query names.

2.3 About translating Web Intelligence reports

You can use the translation management tool to translate report metadata (.wid files) created with Web Intelligence XI 3.0 or later. This metadata includes:
• Report names
• Query names or data provider names
• Prompt texts
• Local variable names
• Alerter names and descriptions
• Content in a Web Intelligence formula (for example in a table cell), an alerter message, or a report variable (if requested using the GetLocalized function).

By default, the content of report formulas in Web Intelligence reports is not translated. To make strings in a report formula available for translation in the translation management tool, the report designer must use the GetLocalized function when designing the report. For more info about the GetLocalized function, see the Using Functions, Formulas and Calculations in SAP BusinessObjects Web Intelligence Guide.

Related Information

About translating universes from the information design tool [page 8]

2.4 About translating universes from the universe design tool

You can translate

• The universe name and description
• Context names and descriptions
• Class names and descriptions
• Object names, descriptions and formats
• Filter names and descriptions
• Custom hierarchy names
• Prompt texts
• Input columns (identified as prompts in the translation management tool)

Derived universes

When you use the translation management tool to open a derived universe based on one or more core universes, only the content of the derived universe needs to be translated. When a user reports in a derived universe, the translations from the core universes and the derived universe are used. If the derived universe contains objects that are located in a class folder of a core universe, these objects are displayed in an unnamed folder.

When the reporting application displays the content for a derived universe, the translations available include the languages defined for the derived universe as well as the languages defined for its core universes. The application determines the Fallback language for a derived universe using the following set of rules.
1. If a Fallback language is defined for the derived universe, then the application uses this Fallback language.
2. If no Fallback language is defined for the derived universe, then the application looks in the core universes for a Fallback language.
3. If no Fallback language is defined for any core universe, the universe has no Fallback language.

### 2.5 About translating universes from the information design tool

Universes generated by the information design tool are not directly translated. Translation management tool can independently translate the data foundations or business layers created by the information design tool. These resources can be located on local information design tool projects or on shared information design tool projects stored in the CMS repository.

Once these resources are translated, use the information design tool to republish the universe that will contain these translations.

#### Related Information

- Translation status [page 35]
- Terminology used in the translation management tool [page 8]
- About the Language Management view [page 13]
- To set the fallback language [page 26]

### 2.6 Terminology used in the translation management tool

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
</table>
| Locale    | A locale defines a language and a geographical area. A language can be associated with several countries. For example, French (fr) is a language spoken in France (FR), Belgium (BE), and Switzerland (CH). The locale for the French spoken in Switzerland is French (Switzerland) or fr-CH.  
A locale also defines the way data is sorted and how dates and numbers are formatted. |

**Note**

In the translation management tool, the terms language and locale are used interchangeably.
<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
</table>
| Locale abbreviations     | Locale abbreviations consist of the language abbreviation followed by the country abbreviation. The locale abbreviation appears differently depending on your operating system or the application you are using. For example:  
  - Windows: French (France)  
  - Java: fr_FR  
  - Sun Solaris: fr_FR.ISO8859-1  
  - InfoView 6.5.1: French (France) [fr-FR] |
| Dominant locale          | The dominant locale is a pre-defined locale that is used as the substitution language when no substitution language is defined for the document. One dominant locale is defined for every language. |
| Product language         | The product language is the language in which the application interface appears. |
| Preferred Viewing Locale (PVL) | The Preferred Viewing Locale is the user’s preferred language for viewing report and query objects in an application. |
| Source language          | Each time you export a document to XLIFF (XML Localization Interchange File Format), you define a source language that is identified as the source language in the resulting XLIFF file. |
| Fallback locale          | A fallback locale can be defined to display when viewing a translated document and no translation in the user’s Preferred Viewing Locale (PVL) is available. |

**Note**
Because you can define only one fallback locale in a document, in most cases it is more flexible to leave the fallback locale undefined and rely on the default substitution of the dominant locale.

| Translation status       | All strings in every language are associated with a translation status. The status indicates if the string has been translated, reviewed, or changed. The status also determines if the translation is ready to be displayed in reports. |

**Related Information**

- List of locales and their dominant locales [page 43]
- Translation status [page 35]
- About translating universes from the information design tool [page 8]
- To set the product language [page 17]
- To set the fallback language [page 26]
2.7 About authentication and security

The tool controls access using login information and application rights configured in the Central Management Console (CMC).

You log into the translation management tool using one of the following login modes:

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected Mode</td>
<td>There are three authentication types: Enterprise, LDAP, and Windows AD. These authentication types let you connect to the CMS repository, import from and export documents to the CMS, and change your CMS login password. You can also open and translate unsecured resources saved in a local directory.</td>
</tr>
<tr>
<td>Standalone Mode</td>
<td>No authentication is required to use the tool in standalone mode. You can only translate unsecured resources saved in a local directory. You cannot open documents imported from the CMS repository unless they are unsecured and have been saved for all users.</td>
</tr>
</tbody>
</table>

To log into the translation management tool in connected or offline mode, you need the right Log into the Translation Manager and display it as an object in the CMC granted for the translation management tool.

Access to folders and objects in the Central Management Server (CMS) repository is controlled by rights granted by the SAP BusinessObjects Enterprise administrator. To open documents and edit translations, you must have the following rights:

- To open and edit translations in a universe, you must have the rights View objects and Edit objects granted for a universe.
- To open and edit translations in a Web Intelligence document, you must have the rights View objects, Edit objects, and Download files associated with the object granted for the document.
- You also need the View objects right granted for the folders containing the universe and report objects.

For more information on the description and definition of user rights, see the SAP BusinessObjects Enterprise Administrator’s Guide.

Related Information

To logon [page 11]
3 Getting started with the tool

3.1 To logon

To use the tool connected to the Central Management Server (CMS), you must have a user name, password, and the appropriate rights set up by your administrator. No authentication is necessary to use the translation management tool in standalone mode.

The translation management tool is automatically installed with SAP BusinessObjects Enterprise client tools.

1. Start the tool if it is not already started. From the Windows Start menu, select All programs > SAP BusinessObjects XI 4.0 > SAP BusinessObjects Enterprise Client Tools > Translation management tool. The User Identification dialog box appears.
2. In the Authentication box, select the authentication type. To use the tool in standalone mode, select Standalone and click OK.
3. For all other authentication types, enter or select in the System box, the system name where the CMS is located.
   For more information about authentication type, see the related topic.
4. Enter your user name and password in the User Name and Password boxes.
5. Click OK.

Note
Once you are logged in, your CMS session information displays in the status bar in the lower right corner of the translation management tool window. You can select the command Tools > Login As to log in using a different user name or authentication type.

Related Information

About authentication and security [page 10]

3.2 To change your login password

Once you are logged in and connected to the CMS, you can change your CMS login password within the translation management tool.

2. Enter your old password in the Old Password box.
3. Enter your new password in both the New password and Confirm new password boxes. The entries must match exactly.
4. Click OK. Your new password is saved in the CMS.

### 3.3 About the translation management tool window

When the tool starts for the first time, the window displays the three most commonly used views: the Translation Editor, Text Editor, and Language Management views.

You can customize the window to display other views when you need them: the Cell Properties, Filter, and Help views.

The menu bar contains the command menus:
- **File** with commands to open, save, import, and export files.
- **Edit** with commonly used text editing commands.
- **Tools** with commands to re-enter login information and change password.
- **Window** with commands to open and close views and set application preferences.
- **Help** with commands to display the translation management tool help in a separate window, and to open the Help view.

A toolbar below the menu bar contains icons:
- for command shortcuts that let you perform menu commands with a single click
- for commonly used text editing commands
- to display the different translation management tool views

The function of each icon displays as a tool tip when you hover the pointer over the icon.

A status indicator at the bottom of the translation management tool window shows the status of the connection to the Central Management Server.

### Related Information

Customizing the translation management tool window [page 16]

### 3.3.1 About the Translation Editor view

The Translation Editor view lets you translate strings in a document. For information on the tasks you can perform in the Translation Editor view, see the Related Topics below.
When you open a document, a new tab opens in the Translation Editor view. A table displays the document object names in the left column, the original content in the next column, and the languages to translate in subsequent columns.

You can view the table in two ways:

- The Category view displays by default and shows the document organized by the hierarchy structure.
- The List view displays the document as a flat list with no hierarchy information. The object names and their icons appear in the left column. The List view lets you sort, find, replace, and filter strings.

For each object, the translation management tool displays the content that can be translated: either a string (for example, a name, description, or prompt) or a format (a date or number).

You can edit the content of the cells to enter translations.

![Note](image)

You cannot edit the cells in the Source language column.

The appearance of the cell content changes depending on the XLIFF translation status.

Properties are associated with the content in each cell. To see the properties of a cell, use the Cell Properties view.

### Related Information

- To translate strings in the Translation Editor [page 27]
- To sort strings in the Translation Editor [page 28]
- To search and replace strings in the Translation Editor [page 29]
- To set default formats in the Translation Editor [page 30]
- To filter the List view by status [page 36]
- Translation status [page 35]

### 3.3.2 About the Language Management view

The Language Management view lets you add and manage the languages in your document. For information on the tasks you can perform in the Language Management view, see the Related Topics.

The list of Available Languages on the left of the Language Management view displays all languages supported by the tool and lets you select languages to add to your document. In the application preferences, you can define frequently used languages so that they appear at the top of the list.

The Selected Languages table on the right lists the languages that you have selected for your document. By default, a column for each selected language displays in the Translation Editor view.

The following information applies to each language that you add to the document:
<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>The View check box lets you select whether or not to display the language in a column in the Translation Editor view.</td>
</tr>
<tr>
<td>Translated</td>
<td>The Translated column displays the percentage of the content that has been translated (cells that have a status of NEEDS_REVIEW_TRANSLATION, NEEDS_REVIEW_L10N, NEEDS_REVIEW_ADAPTATION, TRANSLATED, SIGNED_OFF, or FINAL).</td>
</tr>
<tr>
<td>Visible</td>
<td>The Visible check box lets you define that the language is ready to be viewed in reports. Before a language can be viewed, it must be exported back to the original document.</td>
</tr>
<tr>
<td>Fallback</td>
<td>The Fallback option lets you define the language to display when a translation is not available in the Preferred Viewing Language. You must set the language to Visible before you can set it as the fallback language. You can define only one substitution language in a document.</td>
</tr>
</tbody>
</table>

**Related Information**

To add and remove languages in your document [page 26]
To set the fallback language [page 26]
To set frequently used languages [page 18]
Terminology used in the translation management tool [page 8]

### 3.3.3 About the Text Editor view

The Text Editor view lets you translate a string which is too long to be viewed in the Translation Editor cell. The Text Editor view appears by default on the right in the translation management tool window.

When you select a cell in the Translation Editor view:

- The content of the cell displays in the Translation box of the Text Editor view where you can edit it.

  **i Note**

  You cannot edit the original content.

- The associated source language content displays in the Source box of the Text Editor view and cannot be edited.
- For Web Intelligence documents, comments for the translator appear in the Notes box. You cannot edit the comments.
Related Information

To translate strings in the Text Editor [page 28]

3.3.4  About the Filter view

The Filter view lets you filter the rows that display for a language in the Translation Editor list view.
For each language in the document (one language at a time), you can choose to display strings with one status, all, or a combination of statuses.
When the Filter view is activated, the Translation Editor displays in list view.

Related Information

To filter the List view by status [page 36]
Translation status [page 35]

3.3.5  About the Cell Properties view

The Cell Properties view displays the properties of a cell in the Translation Editor view, and lets you change the status of a cell.

The Cell Properties view displays the following properties of the current cell in the Translation Editor view:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (Description, Format)</td>
<td>The contents of the cell: the text string or format definition.</td>
</tr>
<tr>
<td>Status</td>
<td>The XLIFF translation status of the selected cell. A drop-down list lets you change the status.</td>
</tr>
<tr>
<td>Last Updated</td>
<td>The date and time the contents or status of the cell was last changed.</td>
</tr>
</tbody>
</table>

Related Information

To change cell properties [page 37]
Translation status [page 35]
3.3.6 About the Help view

To open the Help view and display help for a particular topic, press F1, or select Help Related Topics.

The Help view lists a link to a topic most related to the current view or dialog box. The Dynamic Help section lists links to other related topics, and the results of a search.

Using the icons at the bottom of the view, you can list all topics, search the help content, and bookmark a topic for future reference.

3.4 Customizing the translation management tool window

You can customize how views display in the translation management tool window. The customization applies every time you log into the translation management tool, regardless of your login information.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open view</td>
<td>To open a view, select it from the Window menu, or click the icon on the translation management tool toolbar.</td>
</tr>
<tr>
<td>Close view</td>
<td>To close a view, click the close button in the view title bar, or click the view icon on the translation management tool toolbar.</td>
</tr>
<tr>
<td>Move view</td>
<td>To move a view within the translation management tool window, click in the view’s title bar, and drag the view to a new location.</td>
</tr>
<tr>
<td>Detach view</td>
<td>To open a view in a new window, drag the view outside the translation management tool window, or right-click in the view’s title bar and select Detached.</td>
</tr>
<tr>
<td>Re-Attach view</td>
<td>To move a detached view back into the translation management tool window, right-click the view’s title bar and deselect Detached.</td>
</tr>
<tr>
<td>Resize view</td>
<td>To make a view larger or smaller, drag the edges of the view. To minimize and maximize a view, use the icons in the upper right corner of the view.</td>
</tr>
</tbody>
</table>

Related Information

About the translation management tool window [page 12]

3.5 Setting preferences

You can set preferences for:
The product interface language when using the tool
The default folders for documents and XLIFF files.
The language to add automatically to a new resource to translate. This locale is added when the strings to translate are retrieved from the resource in the translation management tool.
The languages you use frequently in your document. These languages appear at the top of the list of available languages in the Language Management view.
The Auto-fill options define if a new locale must be added by copying the content of another locale.
The date-time and number values to use when displaying format examples in the tool.

The preferences settings apply every time you start the tool, regardless of your login information.

Related Information

To set default folder locations [page 17]
To set frequently used languages [page 18]
To set the product language [page 17]
Terminology used in the translation management tool [page 8]

3.5.1 To set the product language

Use this procedure to change the translation management tool interface language.

1. Select Window Preferences Set Product Language.
2. Select a language in the list of available Product Languages.

i Note
For a language to be in the list of available product languages, the language pack must be selected when installing the translation management tool.

3. Click Apply to apply the changes, or click OK to apply the changes and close the Preferences dialog box.

Restart the translation management tool for the interface to display in the new language.

Related Information

Terminology used in the translation management tool [page 8]

3.5.2 To set default folder locations

You can define the default file folders for two types of files:
The translation management tool wizards use these default folders when saving files.

1. Select Window > Preferences > Set Default Folders.
2. To set a default folder for other documents, enter or browse to the folder in the Default User Document Folder box.
3. To set a default folder for XLIFF files, enter or browse to the folder in the Default XLIFF Folder box.
4. Click Apply to apply the changes, or click OK to apply the changes and close the Preferences dialog box.

### 3.5.3 To set the locale to add automatically

Use this procedure to automatically add a language in the list of locales to translate.

1. Select Window > Preferences > Set Language Management Options.
2. Check the Automatically add a locale checkbox.
3. In the list of available locales, select the locale to add.
   The selected locale will be automatically added when the resources are opened.
4. Click Apply to apply the changes, or click OK to apply the changes and close the Preferences dialog.

### 3.5.4 To set frequently used languages

1. Select Window > Preferences > Set Language Management Options.
2. Select a language in the Available list and click the right arrow.
   The language moves to the Frequently Used list. The languages in the Frequently Used list appear at the top of the list of available languages in the Language Management view.
3. When you have finished adding frequently-used languages, click Apply to apply the changes, or click OK to apply the changes and close the Preferences dialog.

### Related Information

About the Language Management view [page 13]

### 3.5.5 To set Auto-fill options

1. Select Window > Preferences > Set Language Management Options.
2. Select Fill new column with text from Autofill source language if you want a new locale to be automatically filled when it is added to the list of supported locales.
3. Select the locale to add from the dropdown menu.
4. Select *Add blank column* if you do not want the new locale to be initialized.
5. When you have finished adding frequently-used languages, click *Apply* to apply the changes, or click *OK* to apply the changes and close the *Preferences* dialog.

### 3.5.6 To set sample data for formats

1. Select *Window > Preferences > Set Sample Data for Formats*.
2. To define a particular date to use when displaying date-time formats:
   a. Select *Custom Date-Time*.
   b. In the *Date* box, select a date from the calendar.
   c. In the *Time* box, select the hours, minutes, or seconds and then change the number by selecting or typing the new number.
3. To define a particular number to use when displaying numeric formats, enter the new number in the sample number box.
4. Click *Apply* to apply the changes, or click *OK* to apply the changes and close the *Preferences* dialog box.
4 Translation workflows

4.1 About translation workflows

You can translate documents in the following ways:

- Translate internally (in-house) using the translation management tool to import content to translate from a local resource or a resource saved in the repository.
- Translators can add their translation language, translate their strings, and export them back to the original resource file. The translation is merged with the original file.
- Translators can save the translation metadata locally for offline work in a .tmgr file.
- Once you have extracted the strings to translate, you may also export them in an XLIFF format file distributing the file for translation with any XLIFF-compliant translation tool (see Chapter 8).

Note

You cannot translate documents within the repository. You must import the translatable content and work on it.

Related Information

About translating a resource from the CMS repository [page 22]
About concurrent translation [page 22]

4.2 How translated locales are managed

The translation management tool exports back only locales:

- That have been added by the translators with the translation management tool (the locale is added to the resource)
- That have been modified by the translator with the translation management tool (the locale is updated if there are no synchronization issues)

When the translation management tool retrieves translatable properties from a source, the source is not locked. If the source changes during translation, when the tool exports the new translation to the source, checks are performed to validate the synchronization/consistency between the source and the translated document.

When inconsistencies are found, the tool proposes three options:

- Update the content stored in the translation management tool with the source (recommended).
- Cancel the whole export. In this case, nothing is done. There is no change in the metadata opened in the translation management tool, and no change in the source.
- Force the export of the translated strings.

Table 2: The different publication options

<table>
<thead>
<tr>
<th>Status</th>
<th>Update</th>
<th>Cancel</th>
<th>Force locales publication</th>
</tr>
</thead>
<tbody>
<tr>
<td>A translation unit has been removed from the source.</td>
<td>Removed translation units are also removed from the translation metadata in the translation management tool.</td>
<td>No change.</td>
<td>Removed translation units are removed from the translation metadata in the translation management tool.</td>
</tr>
<tr>
<td>A new translation unit has been added into the source and must be translated.</td>
<td>The new units are added to the translation metadata in the translation management tool. Their status is NEW.</td>
<td>No change</td>
<td>The new translatable property is added, with the NEW status, but no translation is available.</td>
</tr>
<tr>
<td>A translation unit has been modified in the source. (An ongoing translation might be out of date).</td>
<td>The modified translation unit is imported with the NEEDS_REVIEW_TRANSLATION or NEEDS_REVIEW_LOCALISATION statuses.</td>
<td>No change</td>
<td>Text source is updated in the translation management tool but the translation is published anyway with the XLIFF statuses coming from the translation management tool.</td>
</tr>
<tr>
<td>One or more translations of a translation unit has been changed in the source.</td>
<td>Modified translations are imported in the translation management tool with the NEEDS_REVIEW_TRANSLATION or NEEDS_REVIEW_LOCALISATION statuses.</td>
<td>No change</td>
<td>Modified translations are published in the resource with the XLIFF statuses coming from the translation management tool.</td>
</tr>
</tbody>
</table>

4.3 About security and translation rights

Translating objects published in the CMS repository implies that you have the granted authorizations to do so. These authorizations are given through CMC rights that can be defined at the resource level or translation management tool level.

To use the translation management tool, you must have the Log into translation management tool right granted.

To translate a specific resource, you need to have the following rights granted:
- Translate objects
- Edit objects

When the user has logged into the system, the translation management tool, the rights assigned to the user define whether or not objects can be edited or translated.

Table 3: How edit rights are managed

<table>
<thead>
<tr>
<th>Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>At system level, in the CMS.</td>
<td>The CMS prevents the translation management tool user from updating any InfoObject multilingual information if the Edit rights are not granted.</td>
</tr>
</tbody>
</table>
### 4.4 About concurrent translation

Translating documents concurrently allows you gain time in the translation process. Different translators can work in different locales at the same time. It is recommended that only one translator can work on a specific locale. If two translators try to submit the same locale, the last translator changes may remove the changes of the other translators. There are two ways you can translate documents:

- Translate internally (in-house) using the translation management tool to import a locally stored file and add the locale to translate. Translate the content and export the file back to the source file. The translation is merged with the original file.
- Translate externally by exporting the .tmgr file as an XLIFF format file distributing the file for translation with any XLIFF-compliant translation tool.

When translations are imported back into the original source, the translation management tool exports back only locales:

- That have been added by the translators with the translation management tool (the locale is added to the resource).
- That have been modified with the translator with the translation management tool (the locale is updated if there are no synchronization issues).

Thus, strings to translate can be sent to different translators who can translate them in parallel. When translators export back their translations in the original resource, their export does not overwrite translations from other translators since they are supposed to work on different locales.

### 4.5 About translating a resource from the CMS repository

You can translate metadata (document content) and document names in the CMS. To translate a resource that is stored in the repository:

- You must have the rights to access the repository.
- You must have the rights to translate the document, otherwise you cannot import the translation back into the source document.
- You must import the resource to the translation management tool and save the .tmgr file locally.

---

<table>
<thead>
<tr>
<th>Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>At translation management tool level, before opening an object</td>
<td>The translation management tool checks the effective value of this right for the current user. If it is denied, then a warning message is displayed. The object is opened. The translator can open the source in the translation management tool and edit it but it won’t be able to save it later.</td>
</tr>
<tr>
<td>At translation management tool level, before saving a new translation in a source located in the CMS</td>
<td>The translation management tool checks the edit rights of the current user. If the rights are denied, then an error message is displayed and the translation is not saved. This is situation for XLIFF import, XLIFF Bulk import or when importing translation metadata into the source.</td>
</tr>
</tbody>
</table>
Export the translation back into the source document on the repository.

In addition to translating the content, you can translate filenames in the repository. Browse to the file in the repository, click the file and select Add.

### 4.5.1 To import content to translate from a resource in the CMS repository

You can import all translatable content from the resource and open it locally. You can import a resource and translate it before exporting it, or you can import a resource and save it for working locally. When you use the translation management tool to open a resource in the repository, the user rights are verified in order to check if the user has can edit or translate the document.

Translation metadata is retrieved from the selected object. The object is not actually saved in the file system, it is not actually extracted from the repository. This prevents the import of the whole document, when only a subset of the document content is needed for translation. Once this translation metadata is available from the translation management tool, the translator can work on them.

Only required information is retrieved. The user can work on them or temporarily save the translation metadata locally for offline work. When the translation is done, use the translation management tool to export the translated content into the resource in the repository, after checking the user has the appropriate application rights.

1. Run the translation management tool using your SAP BusinessObjects credentials.
2. In the File menu, select File ➤ Import content to translate from ➤ From the repository
3. In the dialog box, navigate to and select the folder that contains the resources you want to translate. The available documents display in the pane on the right.
4. In the pane, select a resource and click Add. The resource file name appears in the import pane below the Add button. You can add more resources in the same way.
5. To remove a resource from the list of resources to import, click the resource name and click Remove.
6. If you want the imported files to replace existing local resources of the same name, select Overwrite existing documents.
7. Click Import. If the import fails for a resource, a warning appears in the Import status column of the Import pane. Successfully imported documents are saved in the local default folder as defined in the Preferences option. If all documents import successfully, the wizard closes.
8. The translation management tool checks user’s rights and raises a warning if the Edit objects or Translate objects rights is not granted, otherwise the translation management tool retrieves the translation metadata from the source (import translation metadata). Translation metadata is displayed in the translation management tool.
9. Add a locale to the document and save the translations locally.

The translated file is saved locally and can be reopened for editing. When you have finished translating the file, export it back to the original resource in the repository.
4.5.2 About exporting the translations to the source resource in the CMS repository

Once the resource content has been translated in the needed locales, these translations must be exported back to the resource in the repository so they can be available for users. The translations must have been set to the NEEDS_REVIEW_TRANSLATION, NEEDS_REVIEW_L10N, NEEDS_REVIEW_ADAPTATION, TRANSLATED, SIGNED_OFF, or FINAL status, and the locales must be set to Visible.

To export translated content to the source resource:

- You must be connected to a CMS repository containing the resource.
- You must have the necessary security rights granted by the administrator.

The translated metadata must be assigned the status visible and exported to the repository so the translations can be used in documents.

4.6 About translating a local resource

For resources that are saved for all users and stored locally, you can extract the metadata from the local resources and translate the metadata. You can use the translation management tool to translate resources located on a file system, but the tool can only translate unsecured resources.

The resources that can be translated are:

- Web Intelligence reports
- Universes created by the universe design tool
- Data Foundations and Business Layers created by the information design tool

As for resources located in the CMS repository, to translate a local resource, you need to extract the content to translate with the translation management tool and save the files locally and translate them in the same way you translate local resources.

4.6.1 To import content to translate from a local resource

To import content to translate:

1. Select File > Import content to translate from > From a local resource
2. In the dialog box, navigate to, and select the folder that contains the document you want to import.
3. Select the resource to translate and click OK.

When the strings have been imported you can add locales and translated the strings in these locales, or you can export these strings to XLIFF for external translation.
4.6.2 To export translations to the locally stored resource

Once the resource content has been translated in the needed locales, these translations must be exported back to the resource so they can be available for users. The translations must have been set to the NEEDS_REVIEW_TRANSLATION, NEEDS_REVIEW_L10N, NEEDS_REVIEW_ADAPTATION, TRANSLATED, SIGNED_OFF, or FINAL status. The locales must be set to Visible.

Select File Export translated content

Translated content is exported back to the local resource.

4.7 About the TMGR format

When you translate strings coming from a local resource or a resource saved in a CMS repository, you may save your work locally in the translation management tool proprietary file format called TMGR (the file is saved as <filename>.tmgr). This file contains all strings to translate, their current translations in the different locales, and their statuses. You can open this file later and continue to work on it before finally exporting the translations back to the resources.

Saving current translations can be useful for offline work where you can still work on translations of a CMS repository resource without being connected to it. Just select File Save to save the translations locally. Once you have the translations, you can close the translation management tool. You can start the tool at a later date and open the .tmgr files and continue translating the content.
5 Translating documents

5.1 To add and remove languages in your document

Before you add a language, decide if you want to change the Autofill option or the autofill source language.

1. Import the content to translate from a resource.

2. Open the Language Management view if it is not already open. Select Window Language Management View.

3. To add a language, select the language in the Available Languages list and click the right arrow. The language is added to the Selected Languages list. A new column for the language is added to the Translation Editor view. If the Autofill option is turned on, the translation management tool fills the column with content in the Autofill source language.

4. To hide the column for the new language in the Translation Editor view, clear the View check box.

   i Note
   The language remains in the document even though it is not displayed.

5. To remove a language from the document, select the language in the Selected Languages list and click the left arrow. The translation management tool asks you to confirm the remove action.

   ! Caution
   When you remove a language, all translated content for the language is lost.

You can start translating the newly added language.

Related Information

About the Language Management view [page 13]

5.2 To set the fallback language

For a description of fallback language, see the terminology topic in the related topics.

1. Open the Language Management view if it is not already open. Select Window Language Management View.
2. In the Language Management view, select Visible for the language.
3. Click the Fallback option for the language.
4. Select File Save.

Export the document to the repository for the language to be available to the query and reporting applications as a fallback language.

Related Information

Terminology used in the translation management tool [page 8]

5.3 To translate strings in the Translation Editor

You can translate short strings in the Translation Editor view. To translate longer strings, use the Text Editor view.

Before you start translating, you must:

- Import the content to translate from a resource.
- Add at least one language to translate.

1. In the Translation Editor, in the column with the language to translate, click the cell containing the content you want to translate.

   If the language was added with the Autofill option on, the cell contains the Autofill source language content. Otherwise the column is blank.

2. Enter the translation by typing over the previous string.

   When you click the cell, the content appears in the Text Editor view. Once you enter the translation, the status of the cell is automatically set to TRANSLATED.

   **Note**

   You cannot type into cells that contain date and numeric formats. To set a format, right click the cell and select a default format, or use the Format Editor to create a custom format.

3. To move to the next cell to translate, click the cell.

   **Tip**

   While you are translating, in addition to the standard editing commands on the Edit menu, you can press Escape to cancel the current translation and Ctrl + Z to undo the last translation.

4. Select File Save.
Related Information

To set default formats in the Translation Editor [page 30]
About the Translation Editor view [page 12]
To translate strings in the Text Editor [page 28]
Translation status [page 35]

5.4 To translate strings in the Text Editor

Use the Text Editor view to translate strings that are too long to translate in the Translation Editor cell.

1. Import the content to translate from a resource.
2. Open the Text Editor view if it is not already open. Select Window > Text Editor View.
3. In the Translation Editor view, click the cell of the content you want to translate.

The source appears in the Source box of the Text Editor. This content cannot be edited.

Existing translated content appears in the Translation box.
4. Edit the content in the Translation box.

**Note**

You cannot edit original content.

5. To apply what you have translated in the Translation Editor view, click Apply.
6. To cancel the changes, click Reset.
7. Select File > Save.

Related Information

About the Text Editor view [page 14]

5.5 To sort strings in the Translation Editor

1. Import the content to translate from a resource.
2. Open the List view by clicking the tab on the left side of the Translation Editor view.
3. Click the column header to sort the list by the strings in that column.

Change the sort from ascending to descending order by clicking the column header again.
5.6 To search and replace strings in the Translation Editor

1. Import the content to translate from a resource.
2. Open the List view by clicking the tab on the left side of the Translation Editor view.
3. Select Edit > Find/Replace.
4. In the Find and Replace dialog box, enter the string to search for in the Find box.

   **Note**
   The translation management tool searches starting from the selected cell in the List view.

5. To search a selected section of the List view:
   a. Click the row at the start of the section you want to search.
   b. Hold down \[Shift\] and click the row at the end of the section.
   The section is highlighted.
   c. In the Find and Replace dialog box, select the Selected Lines option for the scope.

   **Note**
   You can select the section before selecting Edit > Find/Replace and the Selected Lines option is selected automatically.

6. To change the direction of the search, select the Forward or Backward option.
7. Select other options by selecting the appropriate check boxes:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Case-sensitive</td>
<td>The search finds only strings that match the string in the Find box, respecting upper- and lower-case.</td>
</tr>
<tr>
<td>Whole Word</td>
<td>The search finds only strings that match the entire string in the Find box.</td>
</tr>
<tr>
<td>Wrap Search</td>
<td>The search continues searching from the beginning of the document when it reaches the end.</td>
</tr>
<tr>
<td>Incremental</td>
<td>The search starts finding strings as you enter characters into the Find box.</td>
</tr>
</tbody>
</table>

8. Click Find (except if you have selected the Incremental option).
   The translation management tool highlights the cell where it finds the search string. The Replace and Replace/Find buttons are available. If no string is found, these buttons are unavailable.

9. When the translation management tool finds an instance of the string:
   ○ To find the next instance, click Find.
   ○ To replace the string, enter the replacement string in the Replace With box and click Replace, or, to replace the string and find the next instance, click Replace/Find.

10. When you are finished searching, click Close.
6 Setting Formats

6.1 To set default formats in the Translation Editor

Use the Translation Editor view to set the format of number and date-time values to default formats.

**Note**
You can also use the Format Editor to select a default format. To define a custom format, you must use the Format Editor.

1. In the **Translation Editor**, right-click the cell of either a number or a date-time format object. A shortcut menu displays.
2. From the shortcut menu, select the default format you want to use. The new format appears in the cell.

**Note**
The application uses the current system date and time and the numeric value 987,654,321 to display format examples. In the application preferences, you can define your own number and date-time values to use when displaying formats.

3. Select **File > Save** to save the formats.

Related Information

To set sample data for formats [page 19]
About the Format Editor [page 30]

6.2 About the Format Editor

The Format Editor lets you define the format used to display date-time and numeric values. You can select default formats or define custom formats. For metadata objects in your document, you can define a format for each locale. The formats are saved in the document as part of its localization.

The application uses the current system date and time and the numeric value 987,654,321 to display formats. In the application preferences, you can define your own number and date-time values to use when displaying formats.
Default Formats

Default formats are available based on Common Locale Data Repository (CLDR) recommendations, managed by the UNICODE consortium. Microsoft standards, whenever they differ from the CLDR recommendation, are followed. There are 15 default formats for date and time values, and four default formats for numbers.

The Format Editor lists the default formats available for each category of data.

Custom Formats

If the default formats available do not meet your needs, you can create formats using the Custom Format Editor. You can delete a custom format even if it is used in the document. The next time you start the Format Editor for an object using the deleted format, a custom format is automatically re-created.

A custom format consists of text and tokens. A token is a pre-formatted part of a number or date. For example, **Day: 1-31** is a token that displays the day part of the date as a number between 1 and 31. For more information about tokens, see the related topics.

The Custom Format Editor lists the possible token categories. You define a format by typing text in the **Format Definition** box, and dragging tokens from the **Tokens** box. Tokens appear in the format definition with a rectangle border and a gray background. As you define the format, a preview shows the resulting appearance.

You can define a display color for each custom format. When no color is defined, the client application (for example, Web Intelligence) manages the color to display.

In the **Format for undefined values** box, you can define text and a color to display if no value is returned at reporting time. By default, in the case of an undefined value, no text is displayed.

When defining a numeric format, you can enter a different format to be displayed when the value is negative or equal to zero. If you do not enter a format, the format defined for positive values is used.

**Note**

As the “Format” field is not available in the .unx universes, you cannot enter/edit numeric information, such as Date or Time. However, in .unv universes the “Format” field is available to enter/edit the numeric information.

Related Information

To start the Format Editor [page 32]
To start the Custom Format Editor [page 32]
To delete a custom format [page 33]
Date and time format tokens [page 49]
Number format tokens [page 47]
To set sample data for formats [page 19]
6.3 To start the Format Editor

1. In the Translation Editor, right-click the cell of either a number or a date-time format object. A shortcut menu displays.
2. From the shortcut menu, select Other formats (Format Editor)....

Related Information

To create a custom format [page 32]
About the Format Editor [page 30]

6.4 To start the Custom Format Editor

You can create a custom format from scratch, or use an existing format (default or custom) as the basis for the new format.
1. Start the Format Editor if it is not already open. The possible format categories are listed in Format Categories.
2. If more than one category of format is possible for the object, select a category in Format Categories. The default formats and any previously-defined custom formats are listed in Available Formats.
3. To create a format from scratch, open the Custom Format Editor by clicking Custom Format.
4. To use a format as the basis for a new custom format, first select the format in the Available Formats list, then open the Custom Format Editor by clicking Custom Format.

Related Information

To create a custom format [page 32]

6.5 To create a custom format

1. Start the Custom Format Editor if it is not already open.
2. In the Tokens list, select a token category or an individual token, and add it to the Format Definition box using one of these methods:
   ○ Double-click the token or token category.
   ○ Drag the token or token category to the Format Definition box.
Tip
A description of each token appears as a tool tip when you place the cursor over the token in the Tokens list. For more information on tokens, see the related topics.

3. To select a different token in the category, click the arrow on the token just added to the Format Definition box.

4. Enter additional tokens in the same way. To add text to a definition, type directly in the Format Definition box.

Tip
Edit the contents of the Format Definition box using the Copy (Ctrl+C), Paste (Ctrl+V), Cut (Ctrl+X), and Delete keys.

5. To set the color of the format definition, select the color from the list next to the format definition box.

An example of the appearance of the format displays in the Preview box.

6. For number formats, to define a format to display if the value is negative or zero, add tokens and text in the Format for negative values and Format for values equal to zero definition boxes.

Note
If you do not define these formats, the format defined in the Positive box displays for negative and zero values.

7. For both date-time and number objects, to define text to display when the database returns no value, enter text in the Format for undefined values box.

8. To save the format definition, click OK.

The Custom Format Editor dialog box closes.

The custom format you have just defined appears in the Available Formats list in the Format Editor dialog box. To use the format, select it and click OK.

Related Information

To start the Custom Format Editor [page 32]
Date and time format tokens [page 49]
Number format tokens [page 47]
About the Format Editor [page 30]

6.6 To delete a custom format

1. Start the Format Editor if it is not already open.

   The possible format categories are listed in Format Categories.

2. If more than one category of format is possible for the object, select a category in Format Categories.

   The default formats and any previously-defined custom formats are listed in Available Formats.
3. Select the custom format in the Available Formats list.
4. To delete the format, click Delete.
   The format is removed from the list.
5. To confirm the deletion, click OK.

You can delete a custom format even if it is used elsewhere in the document. The next time you start the Format Editor for an object using the deleted format, a custom format is automatically re-created.

**Related Information**

To start the Format Editor [page 32]
7 Managing status

7.1 Translation status

A status is assigned to the content of each cell to be translated in every language. The translation management tool uses the ten standard XML Localization Interchange File Format (XLIFF) statuses, grouped into two categories.

Table 4:

<table>
<thead>
<tr>
<th>Category</th>
<th>XLIFF status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Needs Translation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>(This content is not displayed to the end-user)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Needs Translation</td>
<td>NEW</td>
<td>Indicates that the content is new. For example, content that was added to or edited in a previously translated document.</td>
</tr>
<tr>
<td>Needs_TRANSLATION</td>
<td></td>
<td>Indicates that the content needs to be translated.</td>
</tr>
<tr>
<td>Needs_ADAPTATION</td>
<td></td>
<td>Indicates only non-textual information needs adaptation.</td>
</tr>
<tr>
<td>Needs_L10N</td>
<td></td>
<td>Indicates text needs translation and non-textual information needs adaptation.</td>
</tr>
<tr>
<td>Translation Visible</td>
<td></td>
<td></td>
</tr>
<tr>
<td>(This content can be displayed to the end-user)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Needs_REVIEW_ADAPTATION</td>
<td></td>
<td>Indicates only non-textual information needs review.</td>
</tr>
<tr>
<td>Needs_REVIEW_L10N</td>
<td></td>
<td>Indicates translation and adaptation of non-textual content needs review.</td>
</tr>
<tr>
<td>Needs_REVIEW_TRANSLATION</td>
<td></td>
<td>Indicates that translated content needs to be reviewed.</td>
</tr>
<tr>
<td>TRANSLATED</td>
<td></td>
<td>Indicates that the content has been translated.</td>
</tr>
<tr>
<td>SIGNED_OFF</td>
<td></td>
<td>Indicates that changes are reviewed and approved.</td>
</tr>
<tr>
<td>FINAL</td>
<td></td>
<td>Indicates the terminating state.</td>
</tr>
</tbody>
</table>

i Note

In BI launch pad, users are able to see the translation in BI launch pad, even when the status of that particular translation is "Needs Translation".

i Note

Localization (L10N) refers to the translation of text and the adaptation of non-textual content (for example, date formats).
You can use some or all of these statuses, depending on your organization and process. The translation management tool sets statuses automatically and changes the display in the editor at certain stages in the translation process.

- When you add a language, the cells have a status in the **Needs Translation** category. The content appears in blue italic font in the Translation Editor.
- Content that has been added to or edited in a previously translated document has an XLIFF status of **NEW**. The content appears in blue italic font in bold.
- Once you have translated the content of a cell, the status automatically changes to **TRANSLATED**, which is in the **Translation Visible** category. The content appears in black normal font.
- When you set a language to **Ready for use** and export the document to the Content Management Server, strings with a status in the **Translation Visible** category are visible in the client query and reporting tools.

Filtering cells displayed in the List view by status can help you manage the translation workflow.

Use the Cell Properties view to see the status of a cell.

For more information about XLIFF, see the XLIFF standards available on the OASIS Consortium web site.

---

**Related Information**

To filter the List view by status [page 36]
To change cell status [page 38]
To change cell properties [page 37]
About the Cell Properties view [page 15]
OASIS Consortium at http://www.oasis-open.org/

---

### 7.2 About metadata translation history

The tool may save with the metadata the date that the metadata was last edited. This feature is supported by

- Web Intelligence documents (.wid)
- universe design tool universes (.unv)
- information design tool data foundation and business layers (.dfx and .blx)

**Note**

This is not supported by Crystal Reports for Enterprise documents or by Analysis, edition for OLAP.

### 7.3 To filter the List view by status

1. Import the content to translate from a resource.
2. Open the List view by clicking the tab on the left side of the Translation Editor view.

3. Open the Filter view if it is not already open. Select Window \ Filter View.

4. Select the language to filter in the list of languages.

5. Select the category you want to filter in the list of status categories.

6. To filter on individual XLIFF statuses, select More... in the list of categories.

   The list of all XLIFF statuses appears. Select the check boxes of the statuses you want to filter on.

   The filter is applied to the display in the List view.

**Related Information**

Translation status [page 35]
About the Filter view [page 15]

### 7.4 To change cell properties

1. Import the content to translate from a resource.

2. Select Windows \ Cell Properties View to open the Cell Properties view.

3. In the Translation Editor view, click the cell you want to change the status of.

   The properties of the cell appear in the Cell Properties view.

4. To change the XLIFF status, in the Cell Properties view, select the status in the list in the Value column for the Status property.

   **Note**
   
   To change the XLIFF status for a group of cells, use the Change Status dialog box.

5. To change the approved status, select True or False in the list in the Value column for the Approved property.

   **Note**
   
   The translation management tool does not use the Approved property. Using the XLIFF translation status is recommended.

6. Select File \ Save

**Related Information**

To change cell status [page 38]
About the Cell Properties view [page 15]
7.5 To change cell status

1. Import the content to translate from a resource.
2. In the Translation Editor view, click the row of the cell you want to change the status of.
3. To select all cells in a section, click the first row in the section. Hold down `Shift` and click the row at the end of the section.
4. Right-click the selected row or section, and select Change Status.
5. In the Change Status dialog box, select the language in the Language list.
6. Select the new status in the Status box and click OK.
7. Select [File] > [Save].

Note

You can also change the status of a cell in the Cell Properties view.
8 Using XLIFF to exchange document translations

8.1 About XLIFF files

The translation management tool creates an XLIFF file for each target language you select when you export. You can select one source language and any number of alternate translation languages for export.

Each XLIFF file is created with the source and target languages in the file name, for example:

<Document_name>.unv_en_US_DE.xlf is a universe file for a US English file that will be translated into German.

For an Web Intelligence document, the file format is:


The XLIFF file contains:

- Document information:
  - Full document name, including the Central Management Server name
  - Source locale
  - Target locale
  - Document type

- For each string:
  - String identifier
  - String in the source language
  - String, translation status, and locale for each alternate translation language
  - Notes for the translator

Note

The translation management tool follows XLIFF specification version 1.2.

For more information about XLIFF file formats, see the XLIFF standards available on the OASIS Consortium web site.

Related Information

OASIS Consortium at http://www.oasis-open.org/
8.2 Exporting and Importing XLIFF files

If you send translations to third-party translators or vendors, you can use XLIFF (XML Localization Interchange File Format) files to exchange documents.

Use the following workflow with the translation management tool to outsource the translations of a document using XLIFF files. See the related topics for more information on the steps in this workflow.

- Open or import the document from the Central Management Server (CMS).
- Export the document to XLIFF using the Export to XLIFF wizard.
- When you receive completed XLIFF files from the third-party, import them to the translation management tool document using the Import from XLIFF wizard.
- You can use the translation management tool to display and edit the translations, manage status, and import the document to the CMS.

Related Information

- To export to XLIFF - select source [page 40]
- To export to XLIFF - select target [page 41]
- To import from XLIFF files [page 42]

8.3 To export to XLIFF - select source

The document you want to export must be open in the Translation Editor view. Open the Export to XLIFF wizard if it is not already open. Select File > Export to XLIFF file.

1. Select the document you want to export in the document list.

   i Note
   You can only export one document at a time.

2. Check the boxes next to the languages you want to export on the list of languages that are available for the document. You can export one or more languages.
   You can add other locales if they are not already in the .tmgr file.

   i Note
   You must export at least one language.

3. Select the source option for one of the export languages.
   The language you select is the source language in the XLIFF file. Any other languages exported are included in the XLIFF file as alternate translations.

4. If you export the original content, you must select the language of the original content in the list of languages.
5. Click **Next** to select the target languages and continue the export.

Related Information

- To export to XLIFF - select target [page 41]
- About XLIFF files [page 39]

### 8.4 To export to XLIFF - select target

You have started the Export to XLIFF wizard and have selected the source languages. To continue with the export:

1. Select a target language in the **Available Languages** list and click the right arrow.
2. Add more target languages in the same way.
   
   The translation management tool creates an XLIFF file for each target language.
3. To remove a target language, select it in the **Selected Languages** list and click the left arrow.
4. The translation management tool creates the XLIFF files in the local default folder. To change the folder, enter or browse to a new folder in the XLIFF file folder box.
5. Click **Finish**.

**Note**

The **Finish** button is unavailable if you have not completed the required information. Make sure you selected at least one target language. Use the **Back** button, if necessary, and make sure you have completed the steps in the **Export to XLIFF - select source** dialog box.

**Note**

If you choose a target language that you have already translated or added to your document, the third-party translator will see your translation and might modify it. This will result in a warning message when you import the XLIFF file.

Related Information

- To export to XLIFF - select source [page 40]
- About XLIFF files [page 39]
8.5 To import from XLIFF files

Open the Import from XLIFF wizard if it is not already open. Select File > Import from XLIFF file.

1. Select the document to import the XLIFF files to.
2. Enter or browse to the XLIFF folder where the translated XLIFF files are located.
   All the XLIFF files in the folder are listed. If you want to filter by the same name as the document, check Filter by document name.
3. Check the boxes next to the XLIFF files you want to import.
   The Matching Status column provides information about the XLIFF file you are about to import:
   ○ A warning message appears if the language in the XLIFF file exists in the document. You can proceed with the import, but any previous translations are overwritten.
   ○ A message appears if the XLIFF file was not exported from the same document. You can proceed with the import, but some content may be corrupted.
   ○ The message OK appears if no problems are found when matching the document to the XLIFF file.
4. Click Finish.

The translated languages are added to the Translation Editor and the Language Management views.

Related Information

About XLIFF files [page 39]
9 Reference

9.1 List of locales and their dominant locales

Table 5:

<table>
<thead>
<tr>
<th>Locale</th>
<th>Locale Abbreviation</th>
<th>Dominant Locale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Afrikaans (South Africa)</td>
<td>af_ZA</td>
<td>af_ZA</td>
</tr>
<tr>
<td>Albanian (Albania)</td>
<td>sq_AL</td>
<td>sq_AL</td>
</tr>
<tr>
<td>Arabic (Algeria)</td>
<td>ar_DZ</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Bahrain)</td>
<td>ar_BH</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Egypt)</td>
<td>ar_EG</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Iraq)</td>
<td>ar_IQ</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Jordan)</td>
<td>ar_JO</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Kuwait)</td>
<td>ar_KW</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Lebanon)</td>
<td>ar_LB</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Libya)</td>
<td>ar_LY</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Morocco)</td>
<td>ar_MA</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Oman)</td>
<td>ar_OM</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Qatar)</td>
<td>ar_QA</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Saudi Arabia)</td>
<td>ar_SA</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Syria)</td>
<td>ar_SY</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Tunisia)</td>
<td>ar_TN</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (United Arab Emirates)</td>
<td>ar_AE</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Arabic (Yemen)</td>
<td>ar_YE</td>
<td>ar_SA</td>
</tr>
<tr>
<td>Armenian (Armenia)</td>
<td>hy_AM</td>
<td>hy_AM</td>
</tr>
<tr>
<td>Azerbaijani (Azerbaijan)</td>
<td>az_AZ</td>
<td>az_AZ</td>
</tr>
<tr>
<td>Basque (Spain)</td>
<td>eu_ES</td>
<td>eu_ES</td>
</tr>
<tr>
<td>Belarusian (Belarus)</td>
<td>be_BY</td>
<td>be_BY</td>
</tr>
<tr>
<td>Bengali (India)</td>
<td>bn_IN</td>
<td>bn_IN</td>
</tr>
<tr>
<td>Bosnian (Bosnia and Herzegovina)</td>
<td>bs_BA</td>
<td>bs_BA</td>
</tr>
<tr>
<td>Bulgarian (Bulgaria)</td>
<td>bg_BG</td>
<td>bg_BG</td>
</tr>
<tr>
<td>Catalan (Spain)</td>
<td>ca_ES</td>
<td>ca_ES</td>
</tr>
<tr>
<td>Chinese (China)</td>
<td>zh_CN</td>
<td>zh_CN</td>
</tr>
<tr>
<td>Locale</td>
<td>Locale Abbreviation</td>
<td>Dominant Locale</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Chinese (Hong Kong SAR China)</td>
<td>zh_HK</td>
<td>zh_TW</td>
</tr>
<tr>
<td>Chinese (Macao SAR China)</td>
<td>zh_MO</td>
<td>zh_TW</td>
</tr>
<tr>
<td>Chinese (Singapore)</td>
<td>zh_SG</td>
<td>zh_CN</td>
</tr>
<tr>
<td>Chinese (Taiwan)</td>
<td>zh_TW</td>
<td>zh_TW</td>
</tr>
<tr>
<td>Croatian (Croatia)</td>
<td>hr_HR</td>
<td>hr_HR</td>
</tr>
<tr>
<td>Czech (Czech Republic)</td>
<td>cs_CZ</td>
<td>cs_CZ</td>
</tr>
<tr>
<td>Danish (Denmark)</td>
<td>da_DK</td>
<td>da_DK</td>
</tr>
<tr>
<td>Dutch (Belgium)</td>
<td>nl_BE</td>
<td>nl_NL</td>
</tr>
<tr>
<td>Dutch (Netherlands)</td>
<td>nl_NL</td>
<td>nl_NL</td>
</tr>
<tr>
<td>English (Australia)</td>
<td>en_AU</td>
<td>en_US</td>
</tr>
<tr>
<td>English (Belize)</td>
<td>en_BZ</td>
<td>en_US</td>
</tr>
<tr>
<td>English (Canada)</td>
<td>en_CA</td>
<td>en_US</td>
</tr>
<tr>
<td>English (Ireland)</td>
<td>en_IE</td>
<td>en_US</td>
</tr>
<tr>
<td>English (Jamaica)</td>
<td>en_JM</td>
<td>en_US</td>
</tr>
<tr>
<td>English (New Zealand)</td>
<td>en_NZ</td>
<td>en_US</td>
</tr>
<tr>
<td>English (Philippines)</td>
<td>en_PH</td>
<td>en_US</td>
</tr>
<tr>
<td>English (South Africa)</td>
<td>en_ZA</td>
<td>en_US</td>
</tr>
<tr>
<td>English (Trinidad and Tobago)</td>
<td>en_TT</td>
<td>en_US</td>
</tr>
<tr>
<td>English (U.S. Virgin Islands)</td>
<td>en_VI</td>
<td>en_US</td>
</tr>
<tr>
<td>English (United Kingdom)</td>
<td>en_GB</td>
<td>en_US</td>
</tr>
<tr>
<td>English (United States)</td>
<td>en_US</td>
<td>en_US</td>
</tr>
<tr>
<td>English (Zimbabwe)</td>
<td>en_ZW</td>
<td>en_US</td>
</tr>
<tr>
<td>Estonian (Estonia)</td>
<td>et_EE</td>
<td>et_EE</td>
</tr>
<tr>
<td>Faroese (Faroe Islands)</td>
<td>fo_FO</td>
<td>fo_FO</td>
</tr>
<tr>
<td>Finnish (Finland)</td>
<td>fi_FI</td>
<td>fi_FI</td>
</tr>
<tr>
<td>French (Belgium)</td>
<td>fr_BE</td>
<td>fr_FR</td>
</tr>
<tr>
<td>French (Canada)</td>
<td>fr_CA</td>
<td>fr_FR</td>
</tr>
<tr>
<td>French (France)</td>
<td>fr_FR</td>
<td>fr_FR</td>
</tr>
<tr>
<td>French (Luxembourg)</td>
<td>fr_LU</td>
<td>fr_FR</td>
</tr>
<tr>
<td>French (Monaco)</td>
<td>fr_MC</td>
<td>fr_FR</td>
</tr>
<tr>
<td>French (Switzerland)</td>
<td>fr_CH</td>
<td>fr_FR</td>
</tr>
<tr>
<td>Galician (Spain)</td>
<td>gl_ES</td>
<td>gl_ES</td>
</tr>
<tr>
<td>Georgian (Georgia)</td>
<td>ka_GE</td>
<td>ka_GE</td>
</tr>
<tr>
<td>German (Austria)</td>
<td>de_AT</td>
<td>de_DE</td>
</tr>
<tr>
<td>German (Germany)</td>
<td>de_DE</td>
<td>de_DE</td>
</tr>
<tr>
<td>Locale</td>
<td>Locale Abbreviation</td>
<td>Dominant Locale</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>German (Liechtenstein)</td>
<td>de_LI</td>
<td>de_DE</td>
</tr>
<tr>
<td>German (Luxembourg)</td>
<td>de_LU</td>
<td>de_DE</td>
</tr>
<tr>
<td>German (Switzerland)</td>
<td>de_CH</td>
<td>de_DE</td>
</tr>
<tr>
<td>Greek (Greece)</td>
<td>el_GR</td>
<td>el_GR</td>
</tr>
<tr>
<td>Gujarati (India)</td>
<td>gu_IN</td>
<td>gu_IN</td>
</tr>
<tr>
<td>Hebrew (Israel)</td>
<td>he_IL</td>
<td>he_IL</td>
</tr>
<tr>
<td>Hindi (India)</td>
<td>hi_IN</td>
<td>hi_IN</td>
</tr>
<tr>
<td>Hungarian (Hungary)</td>
<td>hu_HU</td>
<td>hu_HU</td>
</tr>
<tr>
<td>Icelandic (Iceland)</td>
<td>is_IS</td>
<td>is_IS</td>
</tr>
<tr>
<td>Indonesian (Indonesia)</td>
<td>id_ID</td>
<td>id_ID</td>
</tr>
<tr>
<td>Italian (Italy)</td>
<td>it_IT</td>
<td>it_IT</td>
</tr>
<tr>
<td>Italian (Switzerland)</td>
<td>it_CH</td>
<td>it_IT</td>
</tr>
<tr>
<td>Japanese (Japan)</td>
<td>ja_JP</td>
<td>ja_JP</td>
</tr>
<tr>
<td>Kannada (India)</td>
<td>kn_IN</td>
<td>kn_IN</td>
</tr>
<tr>
<td>Kazakh (Kazakhstan)</td>
<td>kk_KZ</td>
<td>kk_KZ</td>
</tr>
<tr>
<td>Konkani (India)</td>
<td>kok_IN</td>
<td>kok_IN</td>
</tr>
<tr>
<td>Korean (South Korea)</td>
<td>ko_KR</td>
<td>ko_KR</td>
</tr>
<tr>
<td>Latvian (Latvia)</td>
<td>lv_LV</td>
<td>lv_LV</td>
</tr>
<tr>
<td>Lithuanian (Lithuania)</td>
<td>lt_LT</td>
<td>lt_LT</td>
</tr>
<tr>
<td>Macedonian (Macedonia)</td>
<td>mk_MK</td>
<td>mk_MK</td>
</tr>
<tr>
<td>Malay (Brunei)</td>
<td>ms_BN</td>
<td>ms_MY</td>
</tr>
<tr>
<td>Malay (Malaysia)</td>
<td>ms_MY</td>
<td>ms_MY</td>
</tr>
<tr>
<td>Malayalam (India)</td>
<td>ml_IN</td>
<td>ml_IN</td>
</tr>
<tr>
<td>Maltese (Malta)</td>
<td>mt_MT</td>
<td>mt_MT</td>
</tr>
<tr>
<td>Marathi (India)</td>
<td>mr_IN</td>
<td>mr_IN</td>
</tr>
<tr>
<td>Mongolian (Mongolia)</td>
<td>mn_MN</td>
<td>mn_MN</td>
</tr>
<tr>
<td>Northern Sami (Norway)</td>
<td>se_NO</td>
<td>se_NO</td>
</tr>
<tr>
<td>Norwegian Bokmål (Norway)</td>
<td>nb_NO</td>
<td>nb_NO</td>
</tr>
<tr>
<td>Norwegian Nynorsk (Norway)</td>
<td>nn_NO</td>
<td>nn_NO</td>
</tr>
<tr>
<td>Persian (Iran)</td>
<td>fa_IR</td>
<td>fa_IR</td>
</tr>
<tr>
<td>Polish (Poland)</td>
<td>pl_PL</td>
<td>pl_PL</td>
</tr>
<tr>
<td>Portuguese (Brazil)</td>
<td>pt_BR</td>
<td>pt_BR</td>
</tr>
<tr>
<td>Portuguese (Portugal)</td>
<td>pt_PT</td>
<td>pt_BR</td>
</tr>
<tr>
<td>Punjabi (India)</td>
<td>pa_IN</td>
<td>pa_IN</td>
</tr>
<tr>
<td>Romanian (Romania)</td>
<td>ro_RO</td>
<td>ro_RO</td>
</tr>
<tr>
<td>Locale</td>
<td>Locale Abbreviation</td>
<td>Dominant Locale</td>
</tr>
<tr>
<td>------------------------------</td>
<td>--------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Russian (Russia)</td>
<td>ru_RU</td>
<td>ru_RU</td>
</tr>
<tr>
<td>Serbian (Bosnia and Herzegovina)</td>
<td>sr_BA</td>
<td>sr_BA</td>
</tr>
<tr>
<td>Serbian (Serbia And Montenegro)</td>
<td>sr_CS</td>
<td>sr_BA</td>
</tr>
<tr>
<td>Slovak (Slovakia)</td>
<td>sk_SK</td>
<td>sk_SK</td>
</tr>
<tr>
<td>Slovenian (Slovenia)</td>
<td>sl_SI</td>
<td>sk_SK</td>
</tr>
<tr>
<td>Spanish (Argentina)</td>
<td>es_AR</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Bolivia)</td>
<td>es_BO</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Chile)</td>
<td>es_CL</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Colombia)</td>
<td>es_CO</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Costa Rica)</td>
<td>es_CR</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Dominican Republic)</td>
<td>es_DO</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Ecuador)</td>
<td>es_EC</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (El Salvador)</td>
<td>es_SV</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Guatemala)</td>
<td>es_GT</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Honduras)</td>
<td>es_HN</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Mexico)</td>
<td>es_MX</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Nicaragua)</td>
<td>es_NI</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Panama)</td>
<td>es_PA</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Paraguay)</td>
<td>es_PY</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Peru)</td>
<td>es_PE</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Puerto Rico)</td>
<td>es_PR</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Spain)</td>
<td>es_ES</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Uruguay)</td>
<td>es_UY</td>
<td>es_ES</td>
</tr>
<tr>
<td>Spanish (Venezuela)</td>
<td>es_VE</td>
<td>es_ES</td>
</tr>
<tr>
<td>Swahili (Kenya)</td>
<td>sw_KN</td>
<td>sw_KN</td>
</tr>
<tr>
<td>Swedish (Finland)</td>
<td>sw_FI</td>
<td>sv_SE</td>
</tr>
<tr>
<td>Swedish (Sweden)</td>
<td>sv_SE</td>
<td>sv_SE</td>
</tr>
<tr>
<td>Syriac (Syria)</td>
<td>syr_SY</td>
<td>syr_SY</td>
</tr>
<tr>
<td>Tamil (India)</td>
<td>ta_IN</td>
<td>ta_IN</td>
</tr>
<tr>
<td>Telugu (India)</td>
<td>te_IN</td>
<td>te_IN</td>
</tr>
<tr>
<td>Thai (Thailand)</td>
<td>th_TH</td>
<td>th_TH</td>
</tr>
<tr>
<td>Tswana (South Africa)</td>
<td>tn_ZA</td>
<td>tn_ZA</td>
</tr>
<tr>
<td>Turkish (Turkey)</td>
<td>tr_TR</td>
<td>tr_TR</td>
</tr>
<tr>
<td>Ukrainian (Ukraine)</td>
<td>uk_UA</td>
<td>uk_UA</td>
</tr>
<tr>
<td>Uzbek (Uzbekistan)</td>
<td>uz_UZ</td>
<td>uz_UZ</td>
</tr>
</tbody>
</table>
### 9.2 Number format tokens

**Number format definitions**

A number format definition is made of sections:

- the sign (optional)
- the integer value before the decimal separator
- a grouping separator, to be added in the integer value
- the decimal separator (optional)
- the decimal value after the decimal separator (optional)
- the exponential symbol followed by the exponential value (optional)

Two tokens are used to define the number of significant digits to display in the integer, decimal, and exponential values. Each token in the format definition represents a digit to display:

- The mandatory digit token, 0, displays the digit if it is significant, otherwise displays a zero.
- The optional digit token, #, only displays the digit if it is significant.

When determining the significant digits, the integer value and exponential value are evaluated from right to left, and the decimal value is evaluated from left to right. The last 0 or # token is mapped to the remaining digits, if any.

#### Example

**Number format display**

This example shows how the value -1,234 is displayed using different formats defined in the Format Editor.

<table>
<thead>
<tr>
<th>Format defined with tokens:</th>
<th>Preview display:</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Sign] [#]</td>
<td>-1234</td>
</tr>
<tr>
<td>[Neg. start] [0] [0] [0] [0] [0] [0] [Neg. end]</td>
<td>(001234)</td>
</tr>
<tr>
<td>[Sign always] [#] [Dec. Sep.] [0] [0]</td>
<td>-1234.00</td>
</tr>
<tr>
<td>[Sign] [#] [Decimal separator] [0] [0] [E+] [0] [0] [0]</td>
<td>-1.23E+003</td>
</tr>
<tr>
<td>Revenue: [Sign always] [#] [Decimal separator] [0] [0]</td>
<td>Revenue: -1234.00 €</td>
</tr>
<tr>
<td>[Boolean]</td>
<td>true</td>
</tr>
</tbody>
</table>

Translation Management Tool User Guide

© 2015 SAP SE or an SAP affiliate company. All rights reserved.
### List of number format tokens

Table 6:

<table>
<thead>
<tr>
<th>Category</th>
<th>Token</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Signs</td>
<td>Sign</td>
<td>Negative sign if the value is negative. Nothing if the value is positive or zero.</td>
</tr>
<tr>
<td></td>
<td>Sign always</td>
<td>Negative sign if the value is negative. Positive sign if the value is positive or zero.</td>
</tr>
<tr>
<td></td>
<td>Negative start</td>
<td>Open parenthesis if the value is negative. Nothing if the value is positive or zero.</td>
</tr>
<tr>
<td></td>
<td>Negative end</td>
<td>Closing parenthesis if the value is negative. Nothing if the value is positive or zero.</td>
</tr>
<tr>
<td>Digits</td>
<td>#</td>
<td>Optional digit. Displays digit only if significant.</td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>Mandatory digit. Displays digit if significant, otherwise displays zero.</td>
</tr>
<tr>
<td>Separators</td>
<td>Decimal separator</td>
<td>The symbol used to separate the integer and decimal parts of the number. The symbol used is determined by the locale. The decimal separator can be used only once in an expression.</td>
</tr>
<tr>
<td></td>
<td>Grouping</td>
<td>By default, digits are grouped using the rule and the separator defined by the locale. The grouping symbol can be used only once in an expression. It must appear before the decimal separator.</td>
</tr>
<tr>
<td>Exponents</td>
<td>E+</td>
<td>Exponent sign in upper case, always signed. Can be used only once in an expression.</td>
</tr>
<tr>
<td></td>
<td>E-</td>
<td>Exponent sign in upper case, signed only if the value is negative. Can be used only once in an expression.</td>
</tr>
<tr>
<td></td>
<td>e+</td>
<td>Exponent sign in lower case, always signed. Can be used only once in an expression.</td>
</tr>
<tr>
<td></td>
<td>e-</td>
<td>Exponent sign in lower case, signed only if the value is negative. Can be used only once in an expression.</td>
</tr>
<tr>
<td>Percent</td>
<td>Percent</td>
<td>The value multiplied by 100.</td>
</tr>
<tr>
<td></td>
<td>Percent %</td>
<td>The value multiplied by 100 followed by the percent sign (%). Can be used only once in an expression.</td>
</tr>
<tr>
<td>Boolean</td>
<td>Boolean</td>
<td>Localized value of true if the numerical value is not zero; localized value of false if the numerical value is zero.</td>
</tr>
<tr>
<td></td>
<td>True</td>
<td>Always displays the localized value of true.</td>
</tr>
<tr>
<td></td>
<td>False</td>
<td>Always displays the localized value of false.</td>
</tr>
</tbody>
</table>
9.3 Date and time format tokens

Example

Date and time format display

This example shows how the date, Wednesday March 5th 2008, is displayed using different formats defined in the Custom Format Editor.

<table>
<thead>
<tr>
<th>Format defined with tokens:</th>
<th>Preview display:</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Day name], [Month name] [Day 01-31] [Year 0000-9999]</td>
<td>Wednesday, March 05 2008</td>
</tr>
<tr>
<td>[Month 01-12] / [Day 01-31] / [Year 0000-9999]</td>
<td>03/05/2008</td>
</tr>
<tr>
<td>[Capitalized short day name] [Day 01-31] [Capitalized short month name]</td>
<td>Wed 05 Mar</td>
</tr>
<tr>
<td>[Day name], week [Week of year 01-53]</td>
<td>Wednesday, week 10</td>
</tr>
<tr>
<td>The current date is [Day name], [Month name] [Day 01-31] [Year 0000-9999]. Day name is</td>
<td>The current date is Wednesday, March</td>
</tr>
<tr>
<td>[Upper case day name]. Month name is [Lower case month name]. The year is [Year 00-99]..</td>
<td>05 2008. Day Name is WEDNESDAY. Month</td>
</tr>
<tr>
<td></td>
<td>name is march. The year is 08.</td>
</tr>
</tbody>
</table>

List of date and time tokens

Table 7:

<table>
<thead>
<tr>
<th>Category</th>
<th>Token</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Day</td>
<td>Day 01-31</td>
<td>Day in the month with two digits from 01 to 31.</td>
</tr>
<tr>
<td></td>
<td>Day 1-31</td>
<td>Day in the month with one or two digits from 1 to 31.</td>
</tr>
<tr>
<td></td>
<td>Day name</td>
<td>Day name according to the locale, for example, Monday.</td>
</tr>
<tr>
<td></td>
<td>Short day name</td>
<td>Short day name with capitalization according to the locale, for example, Mon.</td>
</tr>
<tr>
<td></td>
<td>Day of year 001-366</td>
<td>Day in the year with three digits from 001 to 366.</td>
</tr>
<tr>
<td></td>
<td>Day of year 01-366</td>
<td>Day in the year with two or three digits from 01 to 366.</td>
</tr>
<tr>
<td></td>
<td>Day of year 1-366</td>
<td>Day in the year with one, two, or three digits from 1 to 366.</td>
</tr>
<tr>
<td></td>
<td>Day of week in month</td>
<td>Day of the week in the month according to the locale, for example, 3 for the 3rd Monday of June.</td>
</tr>
<tr>
<td></td>
<td>Upper-case day name</td>
<td>Day name in upper case, for example, MONDAY.</td>
</tr>
<tr>
<td></td>
<td>Lower-case day name</td>
<td>Day name in lower case, for example, monday.</td>
</tr>
<tr>
<td></td>
<td>Capitalized day name</td>
<td>Capitalized day name, for example, Monday.</td>
</tr>
<tr>
<td></td>
<td>Upper-case short day name</td>
<td>Short day name in upper case, for example, MON.</td>
</tr>
<tr>
<td>Category</td>
<td>Token</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Category</td>
<td>Lower-case short day name</td>
<td>Short day name in lower case, for example, mon.</td>
</tr>
<tr>
<td></td>
<td>Capitalized short day name</td>
<td>Capitalized short day name, for example, Mon.</td>
</tr>
<tr>
<td>Month</td>
<td>Month 01-12</td>
<td>Month in the year with two digits from 01 to 12.</td>
</tr>
<tr>
<td></td>
<td>Month 1-12</td>
<td>Month in the year with one or two digits from 1 to 12.</td>
</tr>
<tr>
<td></td>
<td>Month name</td>
<td>Month name with capitalization according to the locale, for example, June.</td>
</tr>
<tr>
<td></td>
<td>Short month name</td>
<td>Short month name with capitalization according to the locale, for example, Jun.</td>
</tr>
<tr>
<td></td>
<td>Upper-case month name</td>
<td>Month name in upper case, for example, JUNE.</td>
</tr>
<tr>
<td></td>
<td>Lower-case month name</td>
<td>Month name in lower case, for example, june.</td>
</tr>
<tr>
<td></td>
<td>Capitalized month name</td>
<td>Capitalized month name, for example, June.</td>
</tr>
<tr>
<td></td>
<td>Upper-case short month name</td>
<td>Short month name in upper case, for example JUN.</td>
</tr>
<tr>
<td></td>
<td>Lower-case short month name</td>
<td>Short month name in lower case, for example, jun.</td>
</tr>
<tr>
<td></td>
<td>Capitalized short month name</td>
<td>Capitalized short month name, for example, Jun.</td>
</tr>
<tr>
<td>Year and Era</td>
<td>Year 00-99</td>
<td>Year with two digits from 00 to 99.</td>
</tr>
<tr>
<td></td>
<td>Year 0000-9999</td>
<td>Year with four digits from 0000 to 9999.</td>
</tr>
<tr>
<td></td>
<td>Japanese Imperial period and year</td>
<td>Japanese Imperial period and year number, for example, 平成 20.</td>
</tr>
<tr>
<td></td>
<td>Japanese Imperial period (English) and year</td>
<td>Japanese Imperial period (English abbreviated) and year number, for example, H20.</td>
</tr>
<tr>
<td></td>
<td>Japanese Imperial year number 01-99</td>
<td>Japanese Imperial year number with two digits.</td>
</tr>
<tr>
<td></td>
<td>Japanese Imperial year number 1-99</td>
<td>Japanese Imperial year number with one or two digits.</td>
</tr>
<tr>
<td></td>
<td>Japanese Imperial period</td>
<td>Japanese Imperial period.</td>
</tr>
<tr>
<td></td>
<td>Japanese Imperial year</td>
<td>Deprecated. Returns the same result as Japanese Imperial year number 0-99 token.</td>
</tr>
<tr>
<td></td>
<td>Era</td>
<td>Era abbreviation, for example, AD or BC.</td>
</tr>
<tr>
<td>Week</td>
<td>Week of month</td>
<td>Week in the month with one digit from 1 to 6.</td>
</tr>
<tr>
<td></td>
<td>Week of year 01-53</td>
<td>Week in the year (ISO week) with two digits from 01 to 53.</td>
</tr>
<tr>
<td></td>
<td>Week of year 1-53</td>
<td>Week in the year (ISO week) with one or two digits from 1 to 53.</td>
</tr>
<tr>
<td></td>
<td>Year of week of year 0000</td>
<td>ISO year number (consistent with ISO week) with four digits from 0000 to 9999.</td>
</tr>
<tr>
<td></td>
<td>Year of week of year 00</td>
<td>ISO year number (consistent with ISO week) with two digits from 00 to 99.</td>
</tr>
<tr>
<td>Quarter and Semester</td>
<td>Quarter number 1-4</td>
<td>Quarter number with one digit from 1 to 4.</td>
</tr>
<tr>
<td></td>
<td>Short quarter name</td>
<td>Quarter short name from Q1 to Q4.</td>
</tr>
<tr>
<td>Category</td>
<td>Token</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Quarter name</td>
<td></td>
<td>Quarter name from 1st quarter to 4th quarter.</td>
</tr>
<tr>
<td></td>
<td>Semester 1-2</td>
<td>Semester number from 1 to 2.</td>
</tr>
<tr>
<td>Hour</td>
<td>Hour 00-23</td>
<td>Hour in 24-hour format with two digits from 00 to 23.</td>
</tr>
<tr>
<td></td>
<td>Hour 0-23</td>
<td>Hour in 24-hour format with one or two digits from 0 to 23.</td>
</tr>
<tr>
<td></td>
<td>Hour 01-12</td>
<td>Hour in 12-hour format with two digits from 01 to 12.</td>
</tr>
<tr>
<td></td>
<td>Hour 1-12</td>
<td>Hour in 12-hour format with one or two digits from 1 to 12.</td>
</tr>
<tr>
<td></td>
<td>Hour 01-24</td>
<td>Hour in 24-hour format with two digits from 01 to 24.</td>
</tr>
<tr>
<td></td>
<td>Hour 1-24</td>
<td>Hour in 24-hour format with one or two digits from 1 to 24.</td>
</tr>
<tr>
<td></td>
<td>Hour 00-11</td>
<td>Hour in 12-hour format with two digits from 00 to 11.</td>
</tr>
<tr>
<td></td>
<td>Hour 0-11</td>
<td>Hour in 12-hour format with one or two digits from 0 to 11.</td>
</tr>
<tr>
<td>Minute</td>
<td>Minutes 00-59</td>
<td>Minutes with two digits from 00 to 59.</td>
</tr>
<tr>
<td></td>
<td>Minutes 0-59</td>
<td>Minutes with one or two digits from 0 to 59.</td>
</tr>
<tr>
<td>Second and sub-second</td>
<td>Seconds 00-59</td>
<td>Seconds with two digits from 00 to 59.</td>
</tr>
<tr>
<td></td>
<td>Seconds 0-59</td>
<td>Seconds with one or two digits from 0 to 59.</td>
</tr>
<tr>
<td></td>
<td>Milliseconds 000-999</td>
<td>Milliseconds with three digits from 000 to 999.</td>
</tr>
<tr>
<td></td>
<td>Hundredths of a second 000-999</td>
<td>Hundredths of a second with two digits from 00 to 99.</td>
</tr>
<tr>
<td></td>
<td>Tenths of a second 0-9</td>
<td>Tenths of a second with one digit from 1 to 9.</td>
</tr>
<tr>
<td>Time Zone</td>
<td>Time zone</td>
<td>The offset from Coordinated Universal Time, for example, GMT+00:00.</td>
</tr>
<tr>
<td>AM/PM</td>
<td>AM/PM</td>
<td>Morning/afternoon abbreviation, capitalized according to locale, for example, AM or PM. Recommended.</td>
</tr>
<tr>
<td></td>
<td>Upper-case AM/PM</td>
<td>Morning/afternoon abbreviation in upper-case, for example, AM or PM.</td>
</tr>
<tr>
<td></td>
<td>Lower-case am/pm</td>
<td>Morning/afternoon abbreviation in lower-case, for example, am or pm.</td>
</tr>
<tr>
<td></td>
<td>Capitalized Am/Pm</td>
<td>Capitalized morning/afternoon abbreviation, for example, Am or Pm. Not recommended.</td>
</tr>
<tr>
<td>Separator</td>
<td>Date separator</td>
<td>Deprecated. This token was used as a date separator in Desktop Intelligence and is not recommended. Type the character you wish to use as a date separator directly into the format description, or use a default format.</td>
</tr>
<tr>
<td></td>
<td>Time separator</td>
<td>Deprecated. This token was used as a time separator in Desktop Intelligence and is not recommended. Type the character you wish to use as a time separator directly into the format description, or use a default format.</td>
</tr>
</tbody>
</table>
9.4 Types of InfoObject supported by the translation management tool

You can translate either the description, or name and description of most types of InfoObjects. The tool supports the following types of InfoObject:

Table 8:

<table>
<thead>
<tr>
<th>Object Type</th>
<th>Translatable Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agnostic</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Calendar</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Category</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>CustomRole</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>EnterpriseNode</td>
<td>SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Event</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Excel</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>FavoritesFolder</td>
<td>SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Folder</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Inbox</td>
<td>SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Manifest</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>ObjectPackage</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Pdf</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>PersonalCategory</td>
<td>SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Profile</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Program</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Publication</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>QaaWS</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>RemoteCluster</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Replication</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Rtf</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Server</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>ServerGroup</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Shortcut</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Txt</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>User</td>
<td>SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Object Type</td>
<td>Translatable Properties</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td>UserGroup</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Word</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION</td>
</tr>
<tr>
<td>Universe (.unv)</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION, Universe content</td>
</tr>
<tr>
<td>Data Foundation</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION, Data Foundation content</td>
</tr>
<tr>
<td>Business Layer</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION, Business Layer content</td>
</tr>
<tr>
<td>Web Intelligence Document</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION, Web Intelligence document content</td>
</tr>
<tr>
<td>Crystal Reports for Enterprise Document</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION, Crystal Reports for Enterprise document content</td>
</tr>
<tr>
<td>Xcelsius</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION, Xcelsius document itself</td>
</tr>
<tr>
<td>Dashboard</td>
<td>SI_ML_NAME, SI_ML_DESCRIPTION, some properties saved in the InfoObject</td>
</tr>
<tr>
<td>Analysis, edition for OLAP</td>
<td>Workspace names and descriptions, analysis and sub-analysis names, sheet names</td>
</tr>
</tbody>
</table>
Important Disclaimers and Legal Information

Coding Samples

Any software coding and/or code lines / strings ("Code") included in this documentation are only examples and are not intended to be used in a productive system environment. The Code is only intended to better explain and visualize the syntax and phrasing rules of certain coding. SAP does not warrant the correctness and completeness of the Code given herein, and SAP shall not be liable for errors or damages caused by the usage of the Code, unless damages were caused by SAP intentionally or by SAP's gross negligence.

Accessibility

The information contained in the SAP documentation represents SAP’s current view of accessibility criteria as of the date of publication; it is in no way intended to be a binding guideline on how to ensure accessibility of software products. SAP in particular disclaims any liability in relation to this document. This disclaimer, however, does not apply in cases of wilful misconduct or gross negligence of SAP. Furthermore, this document does not result in any direct or indirect contractual obligations of SAP.

Gender-Neutral Language

As far as possible, SAP documentation is gender neutral. Depending on the context, the reader is addressed directly with "you", or a gender-neutral noun (such as "sales person" or "working days") is used. If when referring to members of both sexes, however, the third-person singular cannot be avoided or a gender-neutral noun does not exist, SAP reserves the right to use the masculine form of the noun and pronoun. This is to ensure that the documentation remains comprehensible.

Internet Hyperlinks

The SAP documentation may contain hyperlinks to the Internet. These hyperlinks are intended to serve as a hint about where to find related information. SAP does not warrant the availability and correctness of this related information or the ability of this information to serve a particular purpose. SAP shall not be liable for any damages caused by the use of related information unless damages have been caused by SAP's gross negligence or wilful misconduct. All links are categorized for transparency (see: http://help.sap.com/disclaimer).