## Contents

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>About this document</td>
<td>7</td>
</tr>
<tr>
<td>1.1</td>
<td>Who should read this document</td>
<td>7</td>
</tr>
<tr>
<td>1.2</td>
<td>Document History</td>
<td>7</td>
</tr>
<tr>
<td>2</td>
<td>Getting Started with Live Office</td>
<td>9</td>
</tr>
<tr>
<td>2.1</td>
<td>About Live Office content</td>
<td>9</td>
</tr>
<tr>
<td>2.1.1</td>
<td>Live Office concepts</td>
<td>9</td>
</tr>
<tr>
<td>2.1.2</td>
<td>Live Office object types</td>
<td>11</td>
</tr>
<tr>
<td>2.2</td>
<td>Connecting to the Business Intelligence platform</td>
<td>11</td>
</tr>
<tr>
<td>2.3</td>
<td>Upgrading content from previous versions</td>
<td>13</td>
</tr>
<tr>
<td>2.3.1</td>
<td>To upgrade content from previous versions of Live Office</td>
<td>13</td>
</tr>
<tr>
<td>2.4</td>
<td>Live Office toolbar</td>
<td>13</td>
</tr>
<tr>
<td>2.5</td>
<td>Live Office ribbon menu</td>
<td>16</td>
</tr>
<tr>
<td>2.6</td>
<td>Live Office Panel</td>
<td>18</td>
</tr>
<tr>
<td>2.7</td>
<td>Live Office shortcut menu</td>
<td>19</td>
</tr>
<tr>
<td>2.8</td>
<td>Setting Live Office Options</td>
<td>19</td>
</tr>
<tr>
<td>2.8.1</td>
<td>To set General options</td>
<td>20</td>
</tr>
<tr>
<td>2.8.2</td>
<td>To set View options</td>
<td>21</td>
</tr>
<tr>
<td>2.8.3</td>
<td>To set BI platform options</td>
<td>22</td>
</tr>
<tr>
<td>2.8.4</td>
<td>To set Live Office Panel options</td>
<td>24</td>
</tr>
<tr>
<td>3</td>
<td>Working with SAP Crystal Reports Content</td>
<td>27</td>
</tr>
<tr>
<td>3.1</td>
<td>Inserting Crystal Reports content</td>
<td>27</td>
</tr>
<tr>
<td>3.1.1</td>
<td>To start the Live Office Insert Wizard</td>
<td>27</td>
</tr>
<tr>
<td>3.1.2</td>
<td>Insert Wizard: Choose Document</td>
<td>28</td>
</tr>
<tr>
<td>3.1.3</td>
<td>Insert Wizard: Specify Parameter Values</td>
<td>29</td>
</tr>
<tr>
<td>3.1.4</td>
<td>Insert Wizard: Choose Data</td>
<td>29</td>
</tr>
<tr>
<td>3.1.5</td>
<td>Insert Wizard: Set Filters</td>
<td>31</td>
</tr>
<tr>
<td>3.1.6</td>
<td>Insert Wizard: Summary</td>
<td>32</td>
</tr>
<tr>
<td>3.3</td>
<td>Modifying Crystal Reports content</td>
<td>33</td>
</tr>
<tr>
<td>3.3.1</td>
<td>Adding custom content to Live Office objects</td>
<td>33</td>
</tr>
<tr>
<td>3.3.2</td>
<td>Modifying fields</td>
<td>33</td>
</tr>
<tr>
<td>Section</td>
<td>Title</td>
<td>Page</td>
</tr>
<tr>
<td>---------</td>
<td>------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>3.3.3</td>
<td>Modifying filters</td>
<td>34</td>
</tr>
<tr>
<td>3.4</td>
<td>Accessing secured databases</td>
<td>36</td>
</tr>
<tr>
<td>Chapter 4</td>
<td>Working with Web Intelligence content</td>
<td>37</td>
</tr>
<tr>
<td>4.1</td>
<td>Inserting Web Intelligence content</td>
<td>37</td>
</tr>
<tr>
<td>4.1.1</td>
<td>To start the Live Office Insert Wizard</td>
<td>37</td>
</tr>
<tr>
<td>4.1.2</td>
<td>Insert Wizard: Choose Document</td>
<td>38</td>
</tr>
<tr>
<td>4.1.3</td>
<td>Insert Wizard: Specify Keydates</td>
<td>39</td>
</tr>
<tr>
<td>4.1.4</td>
<td>Insert Wizard: Specify Query Contexts</td>
<td>39</td>
</tr>
<tr>
<td>4.1.5</td>
<td>Insert Wizard: Specify Prompt Values</td>
<td>40</td>
</tr>
<tr>
<td>4.1.6</td>
<td>Insert Wizard: Choose Data</td>
<td>41</td>
</tr>
<tr>
<td>4.1.7</td>
<td>Insert Wizard: Summary</td>
<td>41</td>
</tr>
<tr>
<td>4.2</td>
<td>Modifying Key Date values</td>
<td>42</td>
</tr>
<tr>
<td>4.3</td>
<td>Adding more Web Intelligence report parts</td>
<td>42</td>
</tr>
<tr>
<td>Chapter 5</td>
<td>Working with queries</td>
<td>45</td>
</tr>
<tr>
<td>5.1</td>
<td>Inserting queries</td>
<td>45</td>
</tr>
<tr>
<td>5.1.1</td>
<td>To start the Live Office Insert Wizard</td>
<td>45</td>
</tr>
<tr>
<td>5.1.2</td>
<td>Insert Wizard: Choose Universe</td>
<td>46</td>
</tr>
<tr>
<td>5.1.3</td>
<td>Insert Wizard: Specify Query</td>
<td>46</td>
</tr>
<tr>
<td>5.1.4</td>
<td>Insert Wizard: Specify Query Context</td>
<td>56</td>
</tr>
<tr>
<td>5.1.5</td>
<td>Insert Wizard: Specify Prompt Values</td>
<td>57</td>
</tr>
<tr>
<td>5.1.6</td>
<td>Insert Wizard: Summary</td>
<td>58</td>
</tr>
<tr>
<td>5.2</td>
<td>Modifying queries</td>
<td>58</td>
</tr>
<tr>
<td>5.2.1</td>
<td>To modify a query definition</td>
<td>58</td>
</tr>
<tr>
<td>5.2.2</td>
<td>To modify a query context</td>
<td>58</td>
</tr>
<tr>
<td>5.2.3</td>
<td>To modify key date values in queries</td>
<td>59</td>
</tr>
<tr>
<td>Chapter 6</td>
<td>Using the Live Office Panel</td>
<td>61</td>
</tr>
<tr>
<td>6.1</td>
<td>Understanding the Live Office Panel relationship network</td>
<td>61</td>
</tr>
<tr>
<td>6.2</td>
<td>Searching the SAP BusinessObjects Business Intelligence platform repository</td>
<td>61</td>
</tr>
<tr>
<td>6.3</td>
<td>Using Live Office Panel favorites</td>
<td>62</td>
</tr>
<tr>
<td>6.3.2</td>
<td>To view Live Office favorites</td>
<td>62</td>
</tr>
<tr>
<td>6.3.3</td>
<td>To search Live Office favorites</td>
<td>63</td>
</tr>
<tr>
<td>6.3.4</td>
<td>To delete Live Office favorites</td>
<td>63</td>
</tr>
<tr>
<td>6.3.5</td>
<td>To rename Live Office favorites</td>
<td>63</td>
</tr>
<tr>
<td>6.4</td>
<td>Viewing related objects</td>
<td>64</td>
</tr>
<tr>
<td>6.4.1</td>
<td>To view related objects</td>
<td>64</td>
</tr>
<tr>
<td>6.5</td>
<td>Inserting documents in email messages</td>
<td>64</td>
</tr>
<tr>
<td>6.5.1</td>
<td>To insert links to documents</td>
<td>64</td>
</tr>
</tbody>
</table>

Contents
<table>
<thead>
<tr>
<th>Section</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.5.2</td>
<td>To insert documents as Live Office objects</td>
</tr>
<tr>
<td>6.6</td>
<td>Associating objects with Outlook activities</td>
</tr>
<tr>
<td>6.7</td>
<td>Suggested documents</td>
</tr>
<tr>
<td>6.7.1</td>
<td>To access suggested documents</td>
</tr>
<tr>
<td>Chapter 7</td>
<td>Sending Excel data to SAP BusinessObjects Explorer</td>
</tr>
<tr>
<td>Chapter 8</td>
<td>Working with Live Office objects</td>
</tr>
<tr>
<td>8.1</td>
<td>Refreshing data used in objects</td>
</tr>
<tr>
<td>8.1.1</td>
<td>To manually refresh Live Office objects</td>
</tr>
<tr>
<td>8.1.2</td>
<td>Configuring data refresh options</td>
</tr>
<tr>
<td>8.2</td>
<td>Modifying Live Office object properties</td>
</tr>
<tr>
<td>8.2.1</td>
<td>To configure object properties</td>
</tr>
<tr>
<td>8.2.2</td>
<td>Connecting to a different system</td>
</tr>
<tr>
<td>8.2.3</td>
<td>Modifying prompt and parameter settings</td>
</tr>
<tr>
<td>8.3</td>
<td>Publishing files to SAP BusinessObjects Business Intelligence platform</td>
</tr>
<tr>
<td>8.3.1</td>
<td>To publish Office 2003 documents</td>
</tr>
<tr>
<td>8.3.2</td>
<td>To publish Office 2007 documents</td>
</tr>
<tr>
<td>8.3.3</td>
<td>To view published documents</td>
</tr>
<tr>
<td>8.4</td>
<td>Copying Live Office Objects</td>
</tr>
<tr>
<td>8.4.1</td>
<td>To copy Live Office objects without data connectivity</td>
</tr>
<tr>
<td>8.5</td>
<td>Saving Live Office data locally</td>
</tr>
<tr>
<td>8.6</td>
<td>Opening local documents without data connectivity</td>
</tr>
<tr>
<td>8.8</td>
<td>Adding security to your documents</td>
</tr>
<tr>
<td>8.8.1</td>
<td>To conceal data in documents</td>
</tr>
<tr>
<td>Chapter 9</td>
<td>Troubleshooting Live Office</td>
</tr>
<tr>
<td>9.1</td>
<td>Enabling logging for Live Office</td>
</tr>
<tr>
<td>9.1.1</td>
<td>To configure logging for Live Office</td>
</tr>
<tr>
<td>9.1.2</td>
<td>Sample Live Office log files</td>
</tr>
<tr>
<td>9.2</td>
<td>Troubleshooting Live Office components</td>
</tr>
<tr>
<td>9.2.1</td>
<td>Live Office menu missing</td>
</tr>
<tr>
<td>9.2.2</td>
<td>Object refresh failed</td>
</tr>
<tr>
<td>9.2.3</td>
<td>Object sort and filter settings missing after refreshing</td>
</tr>
<tr>
<td>9.2.4</td>
<td>Access to universe denied</td>
</tr>
<tr>
<td>9.2.5</td>
<td>Live Office object size limitations</td>
</tr>
<tr>
<td>Chapter 10</td>
<td>Reference</td>
</tr>
<tr>
<td>10.1</td>
<td>Backward compatibility</td>
</tr>
<tr>
<td>10.1.1</td>
<td>Unsupported features</td>
</tr>
<tr>
<td>Appendix A</td>
<td>More Information</td>
</tr>
<tr>
<td>------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Index</td>
<td></td>
</tr>
</tbody>
</table>

Contents

- Appendix A
- More Information

- Index

- 91

- 93
Welcome to the SAP BusinessObjects Live Office User Guide. With Live Office, you can retrieve business information, create queries, perform calculations, and share answers to business questions without having to understand complex database languages and structures. You can also embed up-to-date SAP Crystal Reports or Web Intelligence information into Microsoft® Office documents, spreadsheets, emails, and presentations.

This guide provides comprehensive information and procedures to help you perform the following business tasks from within the Microsoft Office application environment:

- Create queries and summary reports, based on real-time information stored in SAP BusinessObjects Business Intelligence platform.
- View, modify, and refresh existing queries and report objects.
- Share the results with your colleagues securely over the web or intranet.

1.1 Who should read this document

This document is intended for business users of Microsoft Office applications who want to work with SAP BusinessObjects Business Intelligence platform data within the Microsoft Office application environment. This document assumes you are familiar with Microsoft Office Excel, Word, Outlook, and PowerPoint, and that you have some familiarity with the BI platform.

1.2 Document History

The following table provides an overview of the most important document changes.

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP BusinessObjects 4.1</td>
<td>January 2013</td>
<td>First release of this document.</td>
</tr>
<tr>
<td>SAP BusinessObjects 4.1 SP1</td>
<td>August 2013</td>
<td>Updated for SAP BusinessObjects 4.1 SP1 release.</td>
</tr>
</tbody>
</table>
Getting Started with Live Office

SAP® BusinessObjects™ Live Office (Live Office) is an add-on for Microsoft Office applications that gives you access to up-to-date information stored in SAP BusinessObjects Business Intelligence platform.

With Live Office, you can insert content from Web Intelligence, Crystal Reports, and Universe Queries in your Microsoft Office documents (PowerPoint, Word, Excel, or Outlook). When you insert an object, a reference to the SAP BusinessObjects Business Intelligence platform location is also inserted. When you open the document later using the Microsoft Office application, you can refresh the objects and see the current data in your document.

Note:
In this release, Live Office does not support SAP Crystal Reports for Enterprise 4.1. Also, Live Office supports only legacy universes (.UNV) created using Universe Designer and Web Intelligence documents created using the legacy universes. However, universes created with Information Designer (.UNX) and Web Intelligence documents based on universes created using Information Designer are not supported in Live Office 4.1. This version of the software also does not support Web Intelligence documents based on BEx Query data that is accessed directly.

Note:
To use Live Office, you must be able to connect to the BI platform and access data in the system. If you do not have the appropriate rights to access the data, contact your system administrator.

2.1 About Live Office content

Before you start working with Crystal Reports or Web Intelligence content in Live Office, you need to understand how Live Office content works.

Related Topics
- Live Office concepts
- Live Office object types

2.1.1 Live Office concepts
To understand how Live Office data can answer your business questions, you need to be familiar with the following key concepts:

**Report objects**
A report is a document you create containing information presented in tables, charts, and graphs. A report object supplies the data to the report. In Live Office, you work with report objects because they are connected to the most up-to-date content stored in databases.

When a report object is created with the Crystal Reports or Web Intelligence designer, its information may come from various databases. The report object returns data from the underlying data source, either on-demand from the database or based on the refresh option chosen.

**Report instances**
A report instance is a version of a report object created by SAP BusinessObjects Business Intelligence platform when users modify the source document or schedule reports. Each instance contains data that is current at the time the source report is processed.

Essentially, a report instance is a report object that contains data retrieved from one or more databases. Typically, report objects are designed so users can schedule several instances with varying characteristics. For example, if users run a report object containing parameters, they can schedule one instance that contains report data from a particular department, and schedule another instance that contains information from another department, even though both instances originate from the same report object.

**Report parts**
Report parts are sections of a report that are displayed by themselves, without the rest of the report page. More precisely, report parts are objects that use hyperlinks to point from a source report object to a destination Live Office object. Report parts include objects such as text or charts.

**Parameters**
In Crystal Reports, a parameter is a question that you answer before generating a report. The information you enter, or the way you respond, determines what information appears in the report. For example, in a report used by sales people, a parameter might ask for a sales region. The report would then return the results for the specified region, instead of returning the results for all regions. Parameters are similar to Web Intelligence prompts. Parameters may be mandatory or optional.

**Prompts**
In Web Intelligence, a prompt is a dynamic filter that displays a question every time you refresh the data in a report. You respond to prompts by typing or selecting the prompt values you want to view before you refresh the data. Prompts are similar to Crystal Reports parameters. Prompts may be mandatory or optional.

**Universe**
A universe is an abstraction of a database and presents data in non-technical terms for business users. A universe is a collection of data objects representing the information available in a database. Business users of Web Intelligence and Crystal Reports can connect to a universe and run queries against the database. For example, a database may contain a universe for sales data, and another for customer service data. Users can perform data analysis and create reports using the objects in the universe,
without seeing, or having to know anything about, the underlying data structures in the database. Universes are created by universe design specialists.

**Context**

A universe context indicates what type of business questions are answered by the same universe objects. For example, a universe for sales data might have a context for store sales, another for partner sales, and so on.

Because contexts may share objects that are in the same universe, specifying a universe context helps to ensure your query retrieves the right data. For example, data on expenses from an employee expense account may be stored in the same database as data on expenses from marketing a product. Choosing the right universe context ensures that you get the appropriate expense data. Therefore, when you select a universe, you may have more than one universe context to choose from.

**Note:**
Contexts are defined by the system administrator.

### 2.1.2 Live Office object types

Live Office supports three types of data objects: Crystal Reports, Web Intelligence, and Universe queries. The following table shows how Live Office supports fields and report parts, such as charts and text, for each data type.

**Note:**
Embedded Crystal Reports sub-reports are not supported.

<table>
<thead>
<tr>
<th>Live Office content type</th>
<th>Fields</th>
<th>Report parts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crystal Reports</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Web Intelligence</td>
<td>Not applicable</td>
<td>Yes</td>
</tr>
<tr>
<td>Universe query</td>
<td>Yes</td>
<td>Not applicable</td>
</tr>
</tbody>
</table>

### 2.2 Connecting to the Business Intelligence platform
To use Live Office to access corporate data, you must connect to the SAP BusinessObjects Business Intelligence platform repository where documents are stored. When you attempt to search for, add, view, modify, or publish Live Office objects from a Microsoft Office application, if you are not already logged on to the BI platform, you are prompted to log on.

You can configure Live Office to connect to SAP BusinessObjects Business Intelligence platform automatically each time Microsoft Office Excel, PowerPoint, Outlook, or Word is loaded. Live Office supports Single Sign-on (SSO) to the BI platform. If SSO is enabled, when users request report data, Live Office uses their SAP BusinessObjects Business Intelligence platform logon credentials to access the data source rather than requiring another logon.

### 2.2.1 To log on to SAP BusinessObjects Business Intelligence platform

You can enter your logon information to connect to an SAP BusinessObjects Business Intelligence platform Central Management System (CMS) once or select additional options to automatically sign in using those credentials each time the Microsoft Office application is opened.

1. Open a Microsoft Office application.
2. On the Live Office ribbon menu, click **Live Office > Application Options**.
3. On the "Options" dialog box, select the **BI platform** tab and enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use specified logon criteria</td>
<td>If you want Live Office to automatically connect to the BI platform using this information when the Microsoft Office application is started, select this option.</td>
</tr>
<tr>
<td>User name</td>
<td>Enter your BI platform logon name.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter your BI platform password.</td>
</tr>
<tr>
<td>Web Services URL</td>
<td>Enter or verify the server location for the SAP BusinessObjects Business Intelligence platform web service you want to connect to, for example, <a href="http://businessobjects02:8080/dswsboje/services/Session">http://businessobjects02:8080/dswsboje/services/Session</a></td>
</tr>
<tr>
<td>System</td>
<td>Enter or verify the Central Management System (CMS) you want to connect to, for example, businessobjects01.</td>
</tr>
<tr>
<td>Authentication Method</td>
<td>Select the method used to check your logon credentials.</td>
</tr>
<tr>
<td>Enable Active Directory Single Sign On</td>
<td>When enabled, Live Office uses these logon credentials to connect to the data source whenever the user requests report data rather than requiring another logon. For more information about SSO, see the SAP BusinessObjects Business Intelligence Platform Administrator Guide available on the SAP Help Portal.</td>
</tr>
</tbody>
</table>

4. Click **Log On**.
Live Office connects to SAP BusinessObjects Business Intelligence platform using the specified settings.

### 2.2.2 To connect to a different CMS

If the Live Office objects you need to access are stored in a different SAP BusinessObjects Business Intelligence platform repository than where you are currently connected, you can change the **Web Service URL** and **System** settings to log on to the required Central Management System (CMS).

1. On the Live Office menu, click **Options**.
2. On the "Options" dialog box, click the **BI platform** tab.
3. Type the information for the new CMS in the **System** and **Web Services URL** fields.

   For example, if the Web Intelligence document you want to insert is on a CMS called businessobjects01, you must type the following text in the **Web Services URL** field:

   ```
   http://businessobjects01:8080/dswsbobje/services/Session
   ```

### 2.3 Upgrading content from previous versions

This version of Live Office is compatible with the earlier versions and allows you to upgrade content to the current Live Office version.

#### 2.3.1 To upgrade content from previous versions of Live Office

1. Open the Microsoft Office document that contains content created by a previous version of Live Office.
2. Click **Refresh All** and if necessary, log on to SAP BusinessObjects Business Intelligence platform. You are prompted to upgrade.
3. Click **OK** to convert the document to the current version of Live Office.

### 2.4 Live Office toolbar
In Microsoft Office 2003 applications, the SAP BusinessObjects Live Office toolbar is available in Microsoft Excel, PowerPoint, Word, and Outlook. In Outlook, it provides quick access to some of the most common commands for creating and modifying Live Office objects in these programs, as well as running queries in the SAP BusinessObjects Business Intelligence platform repository.

The toolbar contains the following buttons:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Insert Crystal Reports Content](image) | Insert Crystal Reports Content  
For more information about the objects that you can insert, see [Inserting Crystal Reports content](#). |
| ![Insert Web Intelligence Content](image) | Insert Web Intelligence Content  
For more information about the options you can use, see [Inserting Web Intelligence content](#). |
| ![Insert Universe Query](image) | Insert Universe Query  
For information about the options that you can use, see [Inserting queries](#). |
| ![Open from Repository](image) | Open from Repository  
Opens the Microsoft Office documents (Excel, Word, or PowerPoint) from the Repository Explorer and allows you to select published documents, Crystal reports or Web Intelligence documents for insertion. See [To view published documents](#). |
| ![Save to Repository](image) | Save to Repository  
For information about the options that you can use, see [Publishing files to SAP BusinessObjects Business Intelligence platform](#). |
| ![Save As New to Repository](image) | Save As New to Repository  
For information about the options that you can use, see [Publishing files to SAP BusinessObjects Business Intelligence platform](#). |
| ![Refresh All Objects](image) | Refresh All Objects  
Updates the data of all objects in the document against their source reports. |
<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Image](image1.png) | Open Properties For All Objects  
Opens the Object Properties dialog box so you can set object properties. |
| ![Image](image2.png) | Open Options  
Opens the "Options" dialog box so you can configure settings for Live Office. |
| ![Image](image3.png) | Go to Object  
Allows you to navigate to any Live Office object in the document. |
| ![Image](image4.png) | Explore Excel Selection  
Uploads the current selection in Microsoft Excel to SAP BusinessObjects Explorer so you can explore the data further. |
| ![Image](image5.png) | Explore Excel Sheet  
Uploads the current Excel spreadsheet to SAP BusinessObjects Explorer so you can explore the data further. |
| ![Image](image6.png) | Help  
Displays the Online Help for Live Office. |

### 2.4.1 To hide or show the Live Office toolbar

- Right-click any toolbar and select **SAP BusinessObjects Live Office**.  
  You can also show or hide the toolbar by navigating to **View > Toolbars**.  
  The toolbar appears or disappears.
2.5 Live Office ribbon menu

In Microsoft Office 2007 applications, the SAP BusinessObjects Live Office ribbon menu is available to help you create and modify reports or run queries to answer your business questions.

The toolbar contains the following buttons:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Insert Crystal Reports Content](image) | Insert **Crystal Reports Content**  
For more information about the objects that you can insert, see [Inserting Crystal Reports content](#). |
| ![Insert Web Intelligence Content](image) | Insert **Web Intelligence Content**  
For more information about the options you can use, see [Inserting Web Intelligence content](#). |
| ![Insert Universe Query](image) | Insert **Universe Query**  
For information about the options that you can use, see [Inserting queries](#). |
| ![Go to Object](image) | **Go to Object**  
Allows you to navigate to any Live Office object in the document. |
| ![Modify Object](image) | **Modify Object**  
Modify the object by inserting or deleting rows and columns, deleting the object or adding more data from the same report source. |
| ![Refresh Object](image) | **Refresh Object**  
Updates the data for the selected object against the source reports. |
| ![Refresh All Objects](image) | **Refresh All Objects**  
Updates the data of all objects in the document against their source reports. |
<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Button] | **Send the current selection to SAP BusinessObjects Explorer**  
Uploads the current selection in Microsoft Excel to SAP BusinessObjects Explorer so you can explore the data further. |
| ![Button] | **Send the current sheet to SAP BusinessObjects Explorer**  
Uploads the current Excel spreadsheet to SAP BusinessObjects Explorer so you can explore the data further. |
| ![Button] | **Create Snapshot**  
Saves a static version of the document to preserve the current Live Office data. |
| ![Button] | **Save to Repository**  
For information about the options that you can use, see [Publishing files to SAP BusinessObjects Business Intelligence platform](#). |
| ![Button] | **Save as New to Repository**  
For information about the options that you can use, see [Publishing files to SAP BusinessObjects Business Intelligence platform](#). |
| ![Button] | **Open from Repository**  
Opens the Repository Explorer and allows you to select published documents, Crystal reports or Web Intelligence documents for insertion. See [To view published documents](#). |
| ![Button] | **Object Properties**  
Opens the "Live Office Object Properties" dialog box so you can set object properties. |
| ![Button] | **Refresh All Objects**  
Updates the data of all objects in the document against their source reports. For more information, see [Refreshing data used in objects](#). |
2.6 Live Office Panel

In Microsoft Outlook, Live Office helps improve productivity by collecting, organizing, and processing previous user behavior and building a network of relationships between email content, business activity, people, and documents. Based on this network, Live Office can suggest relevant content whenever the user opens or composes an email message. Users manage the network of relationships and see suggested content through the Live Office Panel.

**Note:**
The Live Office Panel is not available in Microsoft Word, Microsoft Excel, or Microsoft PowerPoint.

The Live Office Panel allows users to search the SAP BusinessObjects Business Intelligence platform repository and insert documents into email messages. In addition, on the Live Office Panel, users can add documents to a favorites list for easy future access, associate documents with email messages to build the relationship network within Live Office, and view a list of suggested documents that are based on the existing relationship network.

When an email message is open in Microsoft Outlook, the Live Office Panel appears to the right of the email message window.

**Note:**
You can configure the Live Office options so the Live Office Panel does not appear automatically when you open a message. If the Live Office Panel is not visible when an email message window is open, you can open the panel from the Live Office menu by clicking Show/Hide Live Office Panel.

**Related Topics**
- Using the Live Office Panel
2.6.1 To show or hide the Live Office Panel

By default, when you open or compose an email message, the Live Office Panel appears to the right of the message window. If you hide the panel, Live Office retains that setting for all messages until you choose to show the panel again.

**Note:**
If you hide the Live Office Panel, you can set the Live Office Panel options to still display the panel or display a message when you open an email message that contains associated or suggested objects. For more information, see [To set Live Office Panel options](#).

1. If the Live Office Panel is visible, do one of the following to hide it:
   - In the "Live Office Panel" heading bar, click the Close Window button.
   - In the Live Office menu, click **Show/Hide Live Office Panel**.
2. If the Live Office Panel is hidden, in the Live Office menu, click **Show/Hide Live Office Panel**.

2.7 Live Office shortcut menu

For added convenience, Live Office provides a shortcut menu for working with Live Office objects. When you right-click a Live Office object in a Microsoft Office document, the shortcut menu opens. To perform a task in the list, click any available item.

When you set up Live Office, you can configure the shortcut menu to show only the Live Office options, to show both Live Office options and Microsoft options, or to show only Microsoft options and exclude the Live Office options. For more information about configuring the shortcut menu, see [To set General options](#).

2.8 Setting Live Office Options

You can set several options that control how Live Office connects to SAP BusinessObjects Business Intelligence platform and how Live Office looks and works in each Microsoft Office application. For Microsoft Outlook, you can also configure the options for Live Office Panel.

When you set Live Office options, those settings apply only to the Microsoft application you are currently using. This behavior allows you to set different Live Office options for Word, Excel, PowerPoint, and Outlook.

The "Options" dialog box has four tabs:
• **General** – to set general options for the shortcut menus, refresh options, and prompts and messages.
• **View** – to set options for how Live Office objects are formatted in the Microsoft application.
• **Panel** – to set options for the Live Office Panel in Microsoft Outlook.
• **BI platform** – to set connection options with SAP BusinessObjects Business Intelligence platform.

### 2.8.1 To set General options

1. Open the Microsoft Office product you want to set the Live Office options for.
2. Click **Live Office > Application Options**.
3. In the **Options** dialog box, click the **General** tab and set the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>&quot;Shortcut Menu&quot;</strong></td>
<td>The shortcut menu appears when you right-click a Live Office object in a Microsoft Office document. Select an option to set how the shortcut menu appears in the Office product:</td>
</tr>
<tr>
<td></td>
<td>• Replace &lt;application&gt; menu – the application (Word, Excel, PowerPoint) options are not available on the shortcut menu.</td>
</tr>
<tr>
<td></td>
<td>• Add to &lt;application&gt; menu – Both the application options and Live Office options are available on the shortcut menu.</td>
</tr>
<tr>
<td></td>
<td>• Use &lt;application&gt; menu only – Live Office options are not available on the shortcut menu.</td>
</tr>
<tr>
<td>Prompt before overwriting Live Office cells</td>
<td>If a cell in Microsoft Excel contains Live Office data, when you try to enter other data in the cell, a warning appears.</td>
</tr>
<tr>
<td>Refresh Live Office object when binding cell changes</td>
<td>When a Live Office object in a Microsoft Excel document is bound to a cell and the cell binding changes, the object is automatically refreshed and updated.</td>
</tr>
<tr>
<td>Refresh Live Office object on document open</td>
<td>When a Microsoft Office document is opened, Live Office objects inserted in the document are refreshed and updated with the current data in BI platform.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Copy and paste with Live Office connectivity</td>
<td>If you select this option, when a Live Office object is copied to a Microsoft Office application, the server connectivity is maintained. &lt;br&gt;  &lt;br&gt; If you plan to distribute documents with embedded Live Office objects and are concerned about data access and security, you can disconnect the BI platform connectivity to objects embedded in Office applications. &lt;br&gt;  &lt;br&gt; To disconnect copied objects from the data in the BI platform, deselect this option. &lt;br&gt; <strong>Caution:</strong> &lt;br&gt; When objects are disconnected, they are unable to establish a connection through Live Office and the information in the object is not updated.</td>
</tr>
<tr>
<td>Update formulas to include/exclude cells when refreshing</td>
<td>If you select this option, the Live Office object will update formulas automatically when cells are added or removed. &lt;br&gt;  &lt;br&gt; Deselect this option to preserve the original formula and values.</td>
</tr>
<tr>
<td>&quot;Message Box&quot;</td>
<td>Click Restore Defaults to enable all warning messages that you disabled by selecting Do not show me this message again on the error message dialog box.</td>
</tr>
</tbody>
</table>

### 2.8.2 To set View options

1. Open the Microsoft Office application.<br>2. Click Live Office > Application Options.<br>3. In the Options dialog box, click the View tab and set the following options:
<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Insert report part with report format</strong></td>
<td>Select this option to include the report format settings (font, color, and so on) when report data is inserted into your office document. If this option is not selected, only the report data is inserted.</td>
</tr>
<tr>
<td><strong>Show filters as comments</strong></td>
<td>When Crystal Reports Field objects in Microsoft Excel have filters, select this option to show the filters as comments in the column heading for the field.</td>
</tr>
<tr>
<td><strong>Alert the user when a potentially time consuming operation occurs</strong></td>
<td>When this option is selected, a warning dialog box opens in Microsoft Word and Outlook to inform users when a large or time consuming operation has been selected. Users are also given the option to reduce the performance impact by limiting the amount of data retrieved for the operation. If you select this option, you can set the number of cells that an operation must affect to trigger this dialog box.</td>
</tr>
</tbody>
</table>
| **"Default cell values"**                    | Set the default error messages and strings that appear in the cells of your document when there is no available data. Enter a default value in the following fields:  
  - **No Data**: enter the value to use when the cell has no data. The default is blank.  
  - **Data Error**: enter the value to use when the cell data contains an error. The default is: #DataError  
  - **Concealed Data**: enter the value to use when the cell data is hidden. The default is: #Concealed |
| **"Column heading"**                         | Select one of the following options to specify the information that appears in column headings for inserted objects:  
  - **Field Name**  
  - **Field Description**  
  - **Both** |

### 2.8.3 To set BI platform options

1. Open the Microsoft Office product you want to set the Live Office options for.  
2. Click **Live Office > Application Options**.  
3. In the **Options** dialog box, click the **BI platform** tab and set the following options:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use specified logon criteria</td>
<td>Select this option to allow automatic logon to the specified location.</td>
</tr>
<tr>
<td>Username</td>
<td>Type the username to be used for logging on to the repository.</td>
</tr>
<tr>
<td>Password</td>
<td>Type the password to use for logging on to the repository.</td>
</tr>
<tr>
<td>Web Services URL</td>
<td>Type the web address for the web services server that will access the repository. Use the following format: <a href="http://localhost:port/webappname/services">http://localhost:port/webappname/services</a></td>
</tr>
<tr>
<td></td>
<td>Where localhost is the system name, port is the port number, and webappname is the name of the web application as configured for the web service.</td>
</tr>
<tr>
<td>System</td>
<td>Type the name of the system or local host.</td>
</tr>
<tr>
<td>Authentication</td>
<td>The authentication method used by the web service. When you type the Web Services URL, the options available on the specified server are added to the list.</td>
</tr>
<tr>
<td>Enable Windows Active Directory</td>
<td>If Single Sign-On (SSO) is configured on the BI platform, select this option to allow SSO for Live Office. If SSO is enabled, when users request report data, Live Office uses their BI platform logon credentials to access the data source rather than requiring another logon.</td>
</tr>
</tbody>
</table>
### Option | Description
--- | ---
**Specify URL for sending data to SAP BusinessObjects Explorer** | If SAP BusinessObjects Explorer is deployed on a different system than the BI platform, select this option to specify the web address for sending Live Office data to SAP BusinessObjects Explorer.

Use the following format: http://localhost:port/explorer

Where `localhost` is the system name and `port` is the port number.

**Specify OpenDocument URL for viewing object in web browser** | The OpenDocument URL provides a standard way of opening documents and reports that have been published to the BI platform. To view objects in a web browser, specify the OpenDocument URL defined in the BI platform.

If your system uses a reverse proxy, specify the reverse proxy URL. For example, http://ReverseProxyServer:ReverseProxyServerPort/ProxiedLaunchpad/opendoc/openDocument.jsp

Where `ReverseProxyServer` is the reverse proxy server, `ReverseProxyServerPort` is the reverse proxy listen port, and `ProxiedLaunchpad` is the virtual path for BI launchpad.

**Select preferred viewing locale** | The viewing locale setting affects the display format for date, time, and number type data for Live Office objects.

**Note:**
The viewing locale setting is not available on Crystal Reports field objects.

---

### 2.8.4 To set Live Office Panel options

1. Open Microsoft Outlook.
2. Click **Live Office > Options**.
3. In the **Options** dialog box, click the **Panel** tab and set the following options:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Association&quot;</td>
<td>Enter the number of days that associations between objects and messages should be retained. Click <strong>Remove</strong> to delete associations older than the specified number of days.</td>
</tr>
<tr>
<td>&quot;Search&quot;</td>
<td>Sets the number of items that appear in a single page of the search results panel.</td>
</tr>
</tbody>
</table>
| "Notification"      | If the Live Office Panel is closed when you select an email message that has inserted, associated, or suggested Live Office objects, the software can provide a notification. To enable notifications, select one or both of the following options:  
  - In the email message window, open Live Office Panel: if you select this option, the Live Office Panel is displayed when an email that has Live Office content is opened in a separate window.  
  - In the message list and Reading Pane, display a Desktop Alert: if you select this option, a desktop alert appears when an email that has Live Office content is selected in the message list. |
| Import user data into Live Office Panel | If you previously exported your Live Office data including favorites and associations, you can import it into the Live Office Panel.  
**Note:** Importing user data replaces the current Live Office user data. Existing associations not in the imported file and imported associations for email messages not in the current inbox are lost. The Live Office favorites are merged, but conflicting items are overwritten with the imported data. |
| Export user data from Live Office Panel | You can export your Live Office user data including favorites and associations as a backup. If you need to reinstall or revert your data to an earlier version, you can import the exported user data using the **Import** button. |
Working with SAP Crystal Reports Content

With Live Office, you can leverage the power, convenience, and reliability of SAP Crystal Reports functionality from within the Microsoft Office applications you use everyday to make better business decisions. With point and click ease, you can easily monitor regional sales trends or analyze quarterly sales figures from within Microsoft Office Excel, Word, Outlook, or PowerPoint, and share that analysis with your colleagues for improved decision making.

With Live Office, you have the comfort of knowing that the data you are accessing to make business decisions is reliable, up-to-date, and easily refreshed on demand from the database. Data accuracy is no longer a concern.

With the Live Office Insert Wizard, you can insert Crystal Reports report parts or fields into your Microsoft Office documents.

Note:
In this release, Live Office does not support SAP Crystal Reports for Enterprise 4.1.

3.1 Inserting Crystal Reports content

Crystal Reports content can be added from the Live Office menu or from the Live Office toolbar. Both methods start the Live Office Insert Wizard, which guides you through choosing a report, selecting Crystal Reports data objects, and inserting those objects into your Microsoft Excel, PowerPoint, Outlook or Word applications as Live Office objects.

3.1.1 To start the Live Office Insert Wizard

1. Open a Microsoft Office document and place your cursor where you want to insert the Live Office object.
2. Click Live Office > Insert > Crystal Reports content in a Microsoft Office 2003 application or Live Office > Crystal Reports in a Microsoft Office 2007 application.

The "Live Office Insert Wizard" opens to guide you through the process of inserting a Crystal Reports object. If you have not already logged on to SAP BusinessObjects Business Intelligence platform, you are prompted to do so.
3.1.2 Insert Wizard: Choose Document

The "Choose Document" page displays the SAP BusinessObjects Business Intelligence platform repository so you can navigate to the report you want to use. It displays all Crystal reports that you can access, including reports contained within publications.

To insert a report instance into Live Office, the instance must be stored in the BI platform repository. Instances sent directly to a BI Inbox are not stored in the repository and cannot be inserted into Live Office.

**Tip:**
You can also use the search functionality to search by title, keywords, content or all fields to locate a specific report quickly. If you are importing content to an email in Microsoft Outlook, the search dialog defaults to a content search based on the subject line of your email.

**Note:**
If you select a secured report that requires a database logon, you are prompted to enter your database logon credentials. See [Accessing secured databases](#).

3.1.2.1 To locate documents in the repository

1. On the "Choose Document" page of the Live Office Insert Wizard, do any of the following to navigate to the file you want use:
   - To change the tree view to a list of folders, click the **Show Folders** button ( ).
   - To change the tree view to a list of categories, click the **Show Categories** button ( ).
   - To view reports contained within a publication, in the folder list, double-click the publication instance.
   - To update the list of objects available from the repository, click the **Refresh** button ( ).
   - To search for a specific report, in the toolbar, select the field you want to search in the field list, enter the term you want to search for in the search box, and click the **Search** button.
   - To sort the list of available reports in the search results, click the column heading you want to sort on.
   - To view a list of suggested reports in Microsoft Outlook, expand the **Suggestions** folder.

   **Tip:**
The items included in the **Suggestions** folder are based on the subject entered for the message.
- To find a report you recently created or modified in Live Office, expand the Recent folder.

2. Select a report and click **Next**.

   If the selected report contains parameters, the "Specify Parameter Values" page opens. Otherwise, the "Choose Data" page opens.

### 3.1.3 Insert Wizard: Specify Parameter Values

The "Specify Parameter Values" page opens when the selected report contains parameters.

The "Specify Parameter Values" page allows you to specify the parameters to use for the report. The parameters defined for a report may be mandatory or optional. For mandatory parameters, you must define values before continuing. Optional parameter values can be defined later.

Parameters can be used to populate dynamic picklists. For example, an “Activities by Location” report object that a sales manager uses to monitor regional sales activity, could have one parameter called “Select Region” with a value list containing “East” and “West”.

After you insert the report as a Live Office object, you can bind the list of parameter values to particular cells in your Microsoft Office Excel spreadsheet for easy updating. For information about parameter binding and modifying parameter values, see [Modifying prompt and parameter settings](#).

#### 3.1.3.1 To specify parameter values

1. On the "Specify Parameter Values" page, for each defined parameter, specify the parameter value.
   
   **Note:**
   
   You can choose not to specify values for optional parameters.

2. Click **Next**.

   The "Choose Data" page opens.

### 3.1.4 Insert Wizard: Choose Data

The "Choose Data" page in the Live Office Insert Wizard allows you to select the parts or fields of the report to include in the Live Office object. To switch between the parts view and the fields view, click the **Switch to Fields** and **Switch to Parts** buttons.
3.1.4.1 To select parts as your data set

1. On the "Choose Data" page, if the fields view is selected, click the **Switch to Parts** button.

2. To modify the parameter values of a report with interactive parameters, click the **Toggle Parameter Panel** button ( ).
   The report parameters are listed in this pane, along with the values that you have specified for each parameter.
   - To add a parameter value, click the blank parameter value area beneath the parameter name and type a value.

   **Note:**
   If you specify invalid parameter values, such as blank values, a warning icon appears for the parameter and you cannot update the report. You must specify a proper value or delete the value.
   - To change a parameter value, click the value beneath the parameter name and type a new value.

   **Note:**
   Some values can be changed only from the "Enter Parameter Values" dialog box.

   - To choose parameter values from the "Enter Parameter Values" dialog box, select the parameter and click the **Show the Advanced dialog box** icon. This dialog box shows more options for some parameters. Specify the values and click **Ok**.
   - To remove a parameter value, select the value and click **Delete**.
   - To update the report based on the new parameter values, click **Apply**.

3. Locate the data that you want to include in the report.
   - If the report has multiple pages, you can use the navigation arrows to view different pages.
   - To find specific content in the report, you can search for text by clicking the **Find Text** button ( ). The search function finds text on the report page that you are currently viewing.
   - To view a pane that lists the groups of data in the report, click the **Toggle Group Tree** button ( ). You can click the groups to highlight the data in the report.

4. In document viewer, click the report parts or objects that you want to insert. To select multiple objects, drag a box around the objects or hold **CTRL** as you select the objects. You can also use **ALT + Click** to select an entire column of data.

   **Note:**
   To copy the current selection as static content, click the **Copy** button ( ). You can paste the content to your Office document when you finish working with the Live Office Insert Wizard.
5. Click Next.
The “Summary” page opens.

### 3.1.4.2 To select fields as your data set

1. On the "Choose Data" page, if the Parts view is selected, click the Switch to Fields button.
2. In the "Available Fields" list, click a field that you want to include in the Report object, and then click the right arrow (>) to move it to the "Selected Fields" list.
3. Use the up and down arrows to the right of the "Available Fields" list to change the order of the included fields, as required.
4. Click Next.
The "Set Filters" page opens.

### 3.1.5 Insert Wizard: Set Filters

If you inserted your data as fields, the "Set Filters" page opens in the Live Office Insert Wizard so you can apply filters to the fields included in the Live Office object to restrict the amount of data in your report. Filters restrict the data in your report, even if the fields do not appear in your document.

**Note:**
In Microsoft PowerPoint, the Live Office object can show only 50 rows and 50 columns of data. If you insert a Report View that contains more data than this, the data will be truncated. You can reduce the number of fields shown in the report object or add filters to reduce the data to fewer than 50 rows and columns.

#### 3.1.5.1 To filter the data

1. On the Set Filters page, select the field that you want to filter.
2. Select an operator from the Operator list.
   **Note:**
   - If you want to include or exclude null values, you can use the *is null* or *is not null* operators in combination with other operators. The *is not equal to* operator also filters out null values.
   - Live Office cannot retrieve the calculated values from the underlying database.
3. If one or more Value fields appear after you select the operator, specify the appropriate values for the filter.
The filter is configured.

4. To configure more filters, repeat the previous steps.
   You can configure multiple filters for each field. To remove a filter, select it and click **Remove Filter**.

5. Click **Next**.
   The "Summary" page opens.

### 3.1.6 Insert Wizard: Summary

The "Summary" page in the Live Office Insert Wizard shows the object name, number of objects selected, and the path to the objects. If desired, you can enter a different name for the Live Office object.

To finish the process and insert the object, click **Finish**.

### 3.2 Adding more report parts from the same data source

You can quickly add additional report parts from the same data source into your Microsoft Office document.

**Note:**
The information in this section does not apply to Live Office objects embedded in a received email.

1. Select the source Live Office object.
2. Click **Live Office > Modify Object > New Object from Same Report**.
   The "Insert from Same Source" dialog box opens. Like the "Choose Data" page of the Live Office Insert Wizard, this dialog box allows you to select report parts to insert.
3. In the Microsoft Office application, place the cursor where you want to insert the content.
4. Select the additional report parts and click **Insert**.
5. Repeat steps 3 and 4 as necessary to add more report parts to your document.
6. Click **Close**.

**Related Topics**
- To select parts as your data set
3.3 Modifying Crystal Reports content

There are many features in SAP BusinessObjects Live Office that allow you to easily modify your existing Crystal Reports objects.

Related Topics
- Modifying Live Office object properties

3.3.1 Adding custom content to Live Office objects

Live Office objects inserted as tables are comprised of rows and columns. You can insert rows or columns to add custom content to the object. The custom content is retained when the object's data is refreshed.

1. Go to the Live Office object.
2. Select the cell adjacent to where you want to insert a column or row.
   - When you add rows, they are inserted above the selected cell. Columns are inserted to the left of the selected cell.
3. Right-click, point to Live Office, and click Insert Row or Insert Column.
4. Repeat until you have inserted the desired number of rows or columns.

To remove a row or column of custom content, select a cell in the row or column. Right-click, point to Live Office, and click Remove Row or Remove Column.

3.3.2 Modifying fields

You can add or remove fields from a report object that is based on a Crystal Reports document or document instance.

Note:
This function does not apply to report parts.
3.3.2.1 To add or remove fields

1. Click a cell in the Live Office object.
2. Click Live Office > Modify Object > Add/Remove Fields.
3. On the "Choose Data" dialog box, do any of the following:
   • To add a field, in the "Available Fields" list, click the field and move it to the "Selected Fields" list.
   • To remove a field, in the "Selected fields" list, click the field and move it to the "Available Fields" list.
   • To change the order of the fields, in the "Selected fields" list, select the field and use the up and down arrows to move it within the list.
4. Click OK.

Related Topics
• To select fields as your data set

3.3.3 Modifying filters

You can add, modify, and remove filters from your document. You can apply filters to any field, except calculated fields in the source Crystal Report document, even if the field is not displayed.

3.3.3.1 To add or modify a filter

1. Click any cell in the report that you want to modify.
2. Click Live Office > Modify Object > Filter Settings > Add/Modify.
3. On the "Set Filters" page, add, remove, or modify the filters for the report as necessary.
   
   Note:
   If you format individual cells in a report object and then change the filters, the formatted cells may disappear.
4. Click OK to apply the changes.

Related Topics
• To filter the data
### 3.3.3.2 To remove a filter

1. Select a cell in your document that contains the filter you want to remove.
2. Click Live Office > Modify > Filter Settings > Add/Modify.
3. On the "Filter Settings" page, select the filter that you want to delete.
4. Click Remove Filter, and click OK.

### 3.3.3.3 Choosing specific field values as filter settings

To narrow the data included in a report, you can focus on or filter out a particular set of field values.

For example, if your report data contains information for a range of bicycles, you might have three fields containing the following information: Size, Color, and Price. The bicycles might come in four colors: red, black, blue, and green. To display the size and price for the black bicycles only, you can use the "Focus On Value filter" setting for the color field to return only that information. Alternatively, you can use the "Exclude Value" to exclude specific values.

#### 3.3.3.3.1 To focus on a field value

1. Click the cell that contains the field value you want to include as a filter.
2. Click Live Office > Modify Object > Filter Settings > Focus On Value.

The report includes only data pertaining to the selected filter value.

#### 3.3.3.3.2 To exclude a field value

1. Click the cell that contains the value you want to exclude.
2. Click Live Office > Modify Object > Filter Settings > Exclude Value.

Rows for that field that contain the selected value are removed from the report.

**Note:**
To restore the default view, remove the filter.

**Related Topics**
- To remove a filter
3.4 Accessing secured databases

For security purposes, your system administrator may have password protected certain Crystal Reports documents and repositories. When you access or refresh these documents or repositories, you are prompted to enter your database logon credentials.

3.4.1 To access secured databases

1. Log on to SAP BusinessObjects Business Intelligence platform.
2. Click Live Office > Insert Crystal Reports content.
   The Live Office Insert Wizard starts.
3. On the "Choose Document" page, navigate to a secured document that requires database logon credentials.
4. When prompted, enter your logon credentials.

Related Topics
• To log on to SAP BusinessObjects Business Intelligence platform
• Insert Wizard: Choose Document
Working with Web Intelligence content

SAP BusinessObjects Web Intelligence provides access to business information over intranets and extranets for creating ad hoc queries and using Web Intelligence.

With Live Office, you can compile, analyze, and manipulate Web Intelligence data from within the Microsoft Office Excel, PowerPoint, Outlook, and Word documents and use this data for making collaborative decisions.

4.1 Inserting Web Intelligence content

Web Intelligence content can be added from the Live Office menu or by using the Live Office toolbar. Both methods start the Live Office Insert Wizard, which guides you through choosing a report, selecting Web Intelligence data objects, and inserting those objects into Microsoft Office Excel, PowerPoint, Outlook, or Word applications as Live Office objects.

4.1.1 To start the Live Office Insert Wizard

1. Open a Microsoft Office document and place your cursor where you want to insert the Live Office object.
2. Click Live Office > Insert > Web Intelligence content in a Microsoft Office 2003 application or Live Office > Web Intelligence in a Microsoft Office 2007 application.

The Live Office Insert Wizard opens to guide you through the process of inserting a Web Intelligence object. If you have not already logged on to SAP BusinessObjects Business Intelligence platform, you are prompted to do so.

Related Topics
- To log on to SAP BusinessObjects Business Intelligence platform
4.1.2 Insert Wizard: Choose Document

The "Choose Document" page displays the SAP BusinessObjects Business Intelligence platform repository so you can navigate to the report you want to use. It displays all Web Intelligence documents that you can access.

To insert a report instance into Live Office, the instance must be stored in the BI platform repository. Instances sent directly to a BI Inbox are not stored in the repository and cannot be inserted into Live Office.

**Tip:**
You can also use the search functionality to search by title, keywords, content or all fields to locate a specific report quickly. If you are importing content to an email in Microsoft Outlook, the search dialog box defaults to a content search based on the subject line of your email.

4.1.2.1 To locate documents in the repository

1. On the "Choose Document" page of the Live Office Insert Wizard, do any of the following to navigate to the file you want use:
   - To change the tree view to a list of folders, click the Show Folders button ( ).
   - To change the tree view to a list of categories, click the Show Categories button ( ).
   - To view reports contained within a publication, in the folder list, double-click the publication instance.
   - To update the list of objects available from the repository, click the Refresh button ( ).
   - To search for a specific report, in the toolbar, select the field you want to search in the field list, enter the term you want to search for in the search box, and click the Search button.
   - To sort the list of available reports in the search results, click the column heading you want to sort on.
   - To view a list of suggested reports in Microsoft Outlook, expand the Suggestions folder.

   **Tip:**
   The items included in the Suggestions folder are based on the subject entered for the message.

   - To find a report you recently created or modified in Live Office, expand the Recent folder.

2. Select a report and click Next.

The next page of the Live Office Insert Wizard opens.
4.1.3 Insert Wizard: Specify Keydates

If the data in the selected Web Intelligence document is based on a key date variable, the "Specify Keydates" page opens.

In some databases, date-dependent attributes and hierarchies are evaluated through a key date variable (KEY DATE). For example, financial results might be posted on a specific date or at the start of new fiscal years. You can use Live Office to insert and update data containing key date settings.

4.1.3.1 To specify key dates

1. On the "Specify Keydates" page, specify how you want to set the key dates.
   - For a Web Intelligence report with a single key date, the following options are available:
     
     | Option                  | Description                                                                 |
     |-------------------------|-----------------------------------------------------------------------------|
     | Use the default date    | Select this option to set the key date value based on the default value assigned for the object. |
     | Set a date              | Select this option to specify the key date value.                           |

   - For a Web Intelligence report with multiple key dates, the following options are available:
     
     | Option                        | Description                                                                 |
     |-------------------------------|-----------------------------------------------------------------------------|
     | Use the default date for all queries | Select this option to set the key date values based on the default values assigned for the object. |
     | Set date for all queries      | Select this option to specify a single key date value to be used by all queries. |
     | Set a date for each query     | Select this option to set the key date for each query individually.         |

2. Click Next.
   The next page in the Live Office Insert Wizard opens.

4.1.4 Insert Wizard: Specify Query Contexts
A context is a defined group of data objects that share a common business purpose in a universe. If the selected data is included in more than one context, the "Specify Query Context" page opens so you can specify the context you want to use.

### 4.1.4.1 To specify context

1. From the "Specify Query Contexts" page, from the list, select a context.
2. Click Next.

If the Web Intelligence report you select contains prompts, the "Specify Prompt Values" page opens; if the report does not contain prompts, the "Choose Data" page opens.

### 4.1.5 Insert Wizard: Specify Prompt Values

If the document that you selected contains prompts but does not have saved data or instances, the "Specify Prompt Values" page opens.

The "Specify Prompt Values" page allows you to specify the parameters to use for the report. The prompts defined for a report may be mandatory or optional. For mandatory prompts, you must define values before continuing. Optional prompts values can be left undefined and can be specified when the object is refreshed.

### 4.1.5.1 To specify prompt values

1. On the "Specify Prompt Values" page, do one of the following for each prompt value you want to specify:
   - To search for a prompt value from a pre-selected list of options, type a value in the search field. Click the Search icon (🔍) to specify Ignore case or Case sensitive for the search string. Click > to add it to your selected values.
     **Note:**
     If the list of available values is empty or needs to be updated, click the Refresh List icon (🔄).
   - To add a displayed value to the list of selected values, double-click the value.
   - To add a specific prompt value to the list of values, type it and click >.
2. Click Next.
The "Choose Data" page opens.

### 4.1.6 Insert Wizard: Choose Data

The "Choose Data" page in the Live Office Insert Wizard allows you to select the parts of the report to insert in the Microsoft Office document.

This page includes a toolbar with the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Zoom in and out buttons" /></td>
<td>The <strong>Zoom in</strong> and <strong>Zoom out</strong> buttons allow you to change the zoom level.</td>
</tr>
<tr>
<td><img src="image" alt="Find button" /></td>
<td>The <strong>Find</strong> button opens a dialog box that allows you to search the current page for a text string.</td>
</tr>
<tr>
<td><img src="image" alt="Find Next button" /></td>
<td>Click the <strong>Find Next</strong> button to highlight the next instance of the text string that you searched for in the &quot;Find&quot; dialog box.</td>
</tr>
<tr>
<td><img src="image" alt="Navigation arrows" /></td>
<td>Click the navigation arrows to move between pages in a report.</td>
</tr>
<tr>
<td><img src="image" alt="Hide or display navigation map" /></td>
<td>Click this button to hide or display the navigation map for the report.</td>
</tr>
<tr>
<td><img src="image" alt="Quick Mode button" /></td>
<td>Click <strong>Quick Mode</strong> to view the report on a single page, or <strong>Page Mode</strong> to allow report content to be displayed on multiple pages.</td>
</tr>
</tbody>
</table>

### 4.1.7 Insert Wizard: Summary

The "Summary" page in the Live Office Insert Wizard shows the object name, number of objects selected, and the path to the Web Intelligence document. If desired, you can enter a different name for the Live Office object.

To finish the process and insert the object, click **Finish**.
4.2 Modifying Key Date values

After you insert a Live Office object based on Web Intelligence content, you modify the Key Date setting and value like any other prompt.

1. Right-click the Live Office object and click Live Office > Properties. The "Live Office Object Properties" dialog box is displayed.
2. Click the Prompts tab.
3. From the list under the Prompts heading select the key date that you want to modify and then click Key date. The "Specify keydates" dialog is displayed.
4. Specify values for the key dates.
5. Click OK to continue editing the Web Intelligence content.

Related Topics
• To specify key dates

4.3 Adding more Web Intelligence report parts

After you create a Live Office object from a Web Intelligence document, you can easily add more report parts.

4.3.1 To add report parts from the same source

1. Select the source Live Office object.
2. Click Live Office > Modify Object > New Object from Same Report. The "Insert from Same Source" dialog box opens. Like the "Choose Data" page of the Live Office Insert Wizard, this dialog box allows you to select report parts to insert.
3. In the Microsoft Office application, place the cursor where you want to insert the content.
4. Select the additional report parts and click Insert.
5. Repeat steps 3 and 4 as necessary to add more report parts to your document.
6. Click Close.
Related Topics

- Insert Wizard: Choose Data
A query is used to answer a business question from data stored in one or more databases. A query can be simple, such as total sales last year, or, depending on your business need, it can be more complex, such as total sales, for Product A, in the US state of California, in the first quarter of last year.

Traditionally, queries are sent to databases in a language called Structured Query Language (SQL) and can be designed only by an expert in IT or database languages. However, the Live Office Insert Wizard presents the information available in the database as objects that have familiar names and meanings and queries are built by selecting objects and filters, so you do not need to know SQL or any complex programming languages.

The data is arranged in table format that you can add to Microsoft Office documents.

5.1 Inserting queries

Queries can be added from the Live Office menu or from the Live Office toolbar. Both methods start the Live Office Insert Wizard, which guides you through choosing a universe, selecting data objects, and inserting the content into Microsoft Excel, PowerPoint, Outlook or Word applications as Live Office objects.

5.1.1 To start the Live Office Insert Wizard

1. Open a Microsoft Office document and place your cursor where you want to insert the Live Office object.
2. Select Live Office > Insert > Universe Query.

If you have not already logged on to SAP BusinessObjects Business Intelligence platform, you are prompted to do so.

The Live Office Insert Wizard opens to guide you through the process of inserting a Universe Query object.

Related Topics

- To log on to SAP BusinessObjects Business Intelligence platform
5.1.2 Insert Wizard: Choose Universe

The "Choose Universe" page displays the SAP BusinessObjects Business Intelligence platform repository so you can navigate to the data source you want to use. It displays all Universes that you can access.

5.1.2.1 To select your data source

1. On the Insert wizard "Choose Universe" page, do any of the following to navigate to the universe you want to use.
   • To update the list of objects available from the repository, click the Refresh button ( ⚙).
   • To search for a specific universe, in the toolbar, enter the field you want to search in the Search box, enter the term you want to search for in the Search box, and click the "Search" button.
   • To sort the list of available universes in the search results, click the column heading you want to sort on.
   • In Microsoft Outlook, to view a list of suggested universes, expand the "Suggestions" folder.
     **Tip:**
     The items included in the "Suggestions" folder are based on the subject entered for the message.
   • To find a universe you recently accessed from Live Office, expand the "Recent" folder.

2. Select the universe you want to use and click Next.

The "Specify Query" page in the wizard opens.

5.1.3 Insert Wizard: Specify Query

After you select a universe, the "Specify Query" page allows you to build a query to define the data that will answer your business questions. You can then insert the results into a Microsoft Office application.

This page includes a toolbar with the following options:
### 5.1.3.1 Understanding query object types

On the Live Office Insert Wizard "Specify Query" page, the folders and objects available in the selected universe are listed in the manager pane at the left of the window. When you expand the folders, the

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Show/Hide the manager pane" /></td>
<td>The <strong>Show/Hide the manager pane</strong> button shows or hides the manager pane on the left of the window. The manager pane shows a tree view of the folders and objects available in the selected universe.</td>
</tr>
<tr>
<td><img src="image" alt="Show/Hide the filter pane" /></td>
<td>The <strong>Show/Hide the filter pane</strong> button shows or hides the &quot;Filter Objects&quot; pane at the bottom of the window. The &quot;Filter Objects&quot; pane displays the filters currently applied to the query.</td>
</tr>
<tr>
<td><img src="image" alt="Show the option dialog" /></td>
<td>The <strong>Show the option dialog</strong> button opens the &quot;Options&quot; dialog box so you can configure query options. For more information, see Configuring query options.</td>
</tr>
<tr>
<td><img src="image" alt="Add a ranking" /></td>
<td>The <strong>Add a ranking</strong> button allows you to filter the query results by creating a ranking based on the object selected in the manager pane. For more information, see Ranking query objects.</td>
</tr>
<tr>
<td><img src="image" alt="Add a subquery" /></td>
<td>The <strong>Add a subquery</strong> button adds a subquery filter based on the object selected in the manager pane. For more information, see To filter using a subquery.</td>
</tr>
<tr>
<td><img src="image" alt="Manage Sorts" /></td>
<td>The <strong>Manage Sorts</strong> button opens the &quot;Sort Dialog&quot; dialog box so you can set how objects are sorted in the query. For more information, see To sort query objects.</td>
</tr>
<tr>
<td><img src="image" alt="Move Result to the Left Button" /> and the <img src="image" alt="Move Result to the Right Button" /></td>
<td>The <strong>Move Result to the Left Button</strong> and the <strong>Move Result to the Right Button</strong> move the selected object to the left or right in the &quot;Result Objects&quot; pane.</td>
</tr>
<tr>
<td><img src="image" alt="Move Filter Up Button" />, <img src="image" alt="Move Filter Down Button" />, <img src="image" alt="Move Filter Outside Button" />, and <img src="image" alt="Move Filter Inside Button" /></td>
<td>The <strong>Move Filter Up Button</strong>, <strong>Move Filter Down Button</strong>, <strong>Move Filter Outside Button</strong>, and <strong>Move Filter Inside Button</strong> allow you to arrange the filters in the &quot;Filter Objects&quot; pane.</td>
</tr>
</tbody>
</table>
Objects are listed with an icon to indicate the object type. You can drag the objects to the "Result Objects" or "Filter Objects" panes to build your query.

Objects can be one of the following types:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Object Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Dimension object</td>
<td>A dimension object represents data that provides the basis for analysis in</td>
</tr>
<tr>
<td></td>
<td></td>
<td>a report. Dimension objects typically retrieve character-type data, for ex-</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ample; customer names, resort names, or dates.</td>
</tr>
<tr>
<td></td>
<td>Detail object</td>
<td>A detail object provides descriptive data about a dimension. A detail is al-</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ways attached to the dimension for which it provides additional information.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For example, [Age] is a detail object that is associated with the [Customer]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>dimension.</td>
</tr>
<tr>
<td></td>
<td>Measure object</td>
<td>A measure object retrieves numeric data that is the result of calculations</td>
</tr>
<tr>
<td></td>
<td></td>
<td>on data in the database. For example, [Revenue] is the calculation of the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>number of items sold multiplied by item price.</td>
</tr>
<tr>
<td></td>
<td>Precondition ob-</td>
<td>A precondition object is a predefined filter and can only be placed in the</td>
</tr>
<tr>
<td></td>
<td>jects</td>
<td>&quot;Filter Objects&quot; pane. For example, [This Year] is a predefined filter to</td>
</tr>
<tr>
<td></td>
<td></td>
<td>restrict the data set to the current year.</td>
</tr>
</tbody>
</table>

5.1.3.2 To add objects to queries

You add objects to build queries by dragging objects from the manager pane to the "Result Objects" or "Filter Objects" panes. Objects in the "Result Objects" pane form the columns of the Live Office object. For example, a query might include the Year, Sales Rep, Customer Name and Dollar Amount. Objects in the "Filter Objects" pane restrict the results of the data set. For example, you might filter by year to show only the values for the specified year.

In some databases, date-dependent attributes and hierarchies are evaluated through a key date variable (KEY DATE). For example, financial results might be posted on a specific date or at the start of new fiscal years. In Live Office, the Key Date is treated as a prompt setting. If you select a universe that contains a Key Date variable, on the "Specify Query" page, the [KEYDATE] prompt and its current value are displayed on the right above the "Result Objects" pane. You can change the key date value in the "Keydate Properties" dialog box. This dialog box opens when you click the key date button on the top right corner of the "Specify Query" page.

**Note:**
All objects except Precondition objects can be added to both the "Result Objects" and "Filter Objects" lists. Precondition objects can be added as filter objects only.
After you add objects to the query, you can refine the query by setting filter types, ranking objects, and sorting the data set.

When you are finished defining the query, click Next.

Related Topics
• Ranking query objects
• To sort query objects
• To filter query objects
• Configuring query options

5.1.3.3 Ranking query objects

Ranking is a method of restricting the data returned by a query. When you insert queries, you can add ranking to dimensions or objects that are based on defined measures. For example, you could set a ranking to limit the Customer Name dimension to the top seven results based on the Sum of Last Year Sales.

Note:
Not all universe objects support ranking. For example, you cannot rank on an object whose values depend on the data order because the Live Office ranking function changes the data order.

5.1.3.3.1 To rank query objects

1. On the "Specify Query" page, in the manager pane, select the dimension that you want to use to rank the query results.

2. Click the Add a ranking button ( ).
   A ranking is added to the "Result Objects" pane.

3. In the ranking, select the ranking qualifier from the list next to the Add a ranking icon ( ). Choose one of the following qualifiers:
   • Top
   • Bottom
   • % Top
   • % Bottom

4. In the box next to the selected qualifier, set the number or percent of results that the ranking will include.

5. Drag a measure to the "Based on" area.
   The results will be ranked by the value of this measure.

6. If necessary, drag an object to the "For each" area.
The ranking will be applied to each of the results for this object. For instance, if you drag a Country dimension to this area, the ranking will be applied separately to the results for each country.

7. Repeat steps 1-6 to set up another ranking or continue building your query.

### 5.1.3.4 To sort query objects

You can apply a specific sort order to the objects included in a query. The sort order is reflected in the results retrieved for your query.

1. On the "Specify Query" page of the Live Office Insert Wizard, click the Manage Sort button ( ).
2. In the "Sort" dialog box, from the **Available objects** list, select an object and move it to the "Query Sorts" list.

   **Note:**
   You cannot select an entire folder for sorting.

3. Select an object in the **Query sorts** list and do any of the following:
   - To specify the sort order select the **Ascending** or **Descending** button.
     By default, objects are sorted in ascending order.
   - To prioritize the objects that will sort the query, use the **Move up** and **Move down** buttons to move objects within the **Query sorts** list.
4. When you are finished defining the sort, click **OK**.

### 5.1.3.5 To filter query objects

When you add objects to the "Filter Objects" pane on the "Specify Query" page, you can choose a filter type and one of four selection types. The type of filter (for example, **In list**, **Between**, **Is null**, and so on) affects the fields and selection types available for the object.

**Note:**
You cannot add a filter to Precondition object types.

1. On the "Specify Query" page, from the manager pane, select an object and drag it to the "Filter Objects" pane.
2. In the "Filter Objects" pane, from the Filter Type list beside the name of the filter object, select one of the following options:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal to/Not equal to</td>
<td>The filter includes items that include/exclude the specified value.</td>
</tr>
<tr>
<td>Greater than/Greater than or equal to</td>
<td>The filter includes items whose value is greater than/greater than or the same as the specified value.</td>
</tr>
<tr>
<td>Less than/Less than or equal to</td>
<td>The filter includes items whose value is less than/less than or the same as the specified value.</td>
</tr>
<tr>
<td>Between/Not Between</td>
<td>The filter includes items whose value falls between/outside of two specified values.</td>
</tr>
<tr>
<td>Note:</td>
<td>Each value must be specified separately and you can choose different selection types for each value.</td>
</tr>
<tr>
<td>In List/Not In List</td>
<td>The filter includes items whose value is included/not included in a specified list of items.</td>
</tr>
<tr>
<td>Is null/Is not null</td>
<td>The filter includes items whose value is Null/Not Null.</td>
</tr>
<tr>
<td>Both</td>
<td>The filter includes items that contain both specified values.</td>
</tr>
<tr>
<td>Note:</td>
<td>Each value must be specified separately and you can choose different selection types for each value.</td>
</tr>
<tr>
<td>Except</td>
<td>The filter includes all items except items that contain the specified value.</td>
</tr>
</tbody>
</table>

3. On the filter object, from the Selection Type list, select the method you want to use to specify filter values from one of the following options:

   **Note:**
   The Selection Type list is not available for objects on OLAP universes or when the following filter types are selected: **In list, Not in list, Is null and Is not null.**
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constant</td>
<td>This option allows you to type the filter value in a box to the left of the Selection Type list.</td>
</tr>
<tr>
<td>List of Values</td>
<td>This option allows you to select the filter values from a list of values defined for the filter object. When you select this option, the &quot;List of Values&quot; dialog box opens so you can select the values. You can also click the List of Values button to open the dialog box.</td>
</tr>
<tr>
<td>Prompt</td>
<td>This option allows you to define a prompt to specify the filter value whenever the query runs or refreshes. To configure the prompt settings, you can click the Prompt button ( 🎨 ).</td>
</tr>
<tr>
<td>Object</td>
<td>This option allows you to specify an object to use as a filter.</td>
</tr>
</tbody>
</table>

**Note:**
The Object selection type is not available for objects on OLAP universes or when the following filter types are selected: In list, Not In list, Is null and Is not null.

4. Repeat these steps to add additional filters if required.
   To organize multiple filters, you can select filters and use the Move Filter buttons to the right of the "Filter Objects" pane. You can group filters together and double-click And or Or to change the operator that links a group of filters.

5. When you are finished defining filters, click **Next**.

**Related Topics**
- To select filter values from a list
- To set up filter selection prompts
- To set up objects as filters

5.1.3.5.1 To select filter values from a list
   To define filter values, you must first add a filter object. When you select **List of Values** from the Selection Type list, the "List of Values" dialog box opens.
   1. On the "List of Values" dialog box, do any of the following:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type the values to be used</td>
<td>In the <strong>Type a Value</strong> box, type the value to use and move it to the &quot;Selected Value&quot; list.</td>
</tr>
<tr>
<td>Select the values from a list of available values for the object</td>
<td>In the list of values on the left, select the values you want to use and move them to the &quot;Selected Value&quot; list.</td>
</tr>
<tr>
<td>Change the sort order of the list of values between ascending and descending</td>
<td>At the top of the list of values, click the name of the filter object.</td>
</tr>
<tr>
<td>Retrieve updated values from the data source</td>
<td>Click the Refresh button ( ).</td>
</tr>
<tr>
<td>Search for filter values</td>
<td>In the Search box, type the text to look for and press Enter. <strong>Note:</strong> To change the case options for the search, click the Search Ignore Case button ( ) to change to case sensitive search or the Search Case Sensitive button ( ) to change to ignore case search.</td>
</tr>
</tbody>
</table>

2. Click **OK**.

5.1.3.5.2 To set up filter selection prompts

   Before setting up a prompt, you must add an object to the "Filter Objects" pane and set the operator for the filter.

   Filter prompts allow users to specify the values for a filter when they refresh the Live Office object. You can set options for a prompt in the "Define a Prompt" dialog box.

   1. From the Selection Type list for the filter, select **Prompt**.
   2. Click the **Prompt** icon ( ) for the filter to open the "Define a Prompt" dialog box.
   3. Set the following options:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt Text</td>
<td>Type the text you want to appear to as the request for the values to use for the filter.</td>
</tr>
<tr>
<td>Prompt with List of Values</td>
<td>Select this option to select filter values from a list of possible options.</td>
</tr>
<tr>
<td>Select only from list</td>
<td>If Prompt with List of Values is selected, select this option if you want to restrict selections to items in the list. If this option is not selected, users can also type the value to use for the filter.</td>
</tr>
<tr>
<td>Keep last value(s) selected</td>
<td>Select this option to default the filter selection to the values used the last time the object was refreshed. If this option is not selected, when the object is refreshed, the previous filter values are cleared and no values are entered by default.</td>
</tr>
<tr>
<td>Optional prompt</td>
<td>Select this option if the filter value is optional and the object can be refreshed without entering a filter value.</td>
</tr>
<tr>
<td>Set default value(s)</td>
<td>Select this option to set a default filter value to be used whenever the object is refreshed. If this option is selected, additional options are available to enter default prompt values by doing any of the following: • In the <strong>Type a Value</strong> box, type a default value and move it to the &quot;Selected Values&quot; list. • In the list, select a value and move it to the &quot;Selected Values&quot; list. • Click the Refresh button to update the values in the list. • In the Search box, enter a value to search for in the available list and press <strong>Enter</strong>. • To set the search option to ignore or consider case, click the Search button and select <strong>Ignore Case</strong> or <strong>Case Sensitive</strong>.</td>
</tr>
</tbody>
</table>

4. Click **OK**.

5.1.3.5.3 To set up objects as filters

To set up objects to define filter values, you must first add a filter object. When you select **Object** from the Selection Type list, the "Objects and Variables" dialog box opens.

1. On the "Objects and Variables" dialog box, under "Available Objects and Variables", select any universe object.

   **Note:**
   You cannot select a predefined universe filter or folder.

2. Click **OK**.

5.1.3.5.4 To filter using a subquery

Subqueries allow you to create more complex filters. You can add multiple objects to a subquery, and refine the results further by adding filters to the subquery.
1. On the "Specify Query" page, from the manager pane, select an object and click the **Add a subquery** button ( ).
   A subquery filter based on the selected object is added to the "Filter Objects" pane.

2. To base the filter on multiple objects, drag additional objects from the manager pane to the left of the Filter Type list.

3. In the "Filter Objects" pane, from the Filter Type list beside the name of the filter object, select the type of filter.
   The available options are the same as for a regular filter object.

4. From the manager pane, select the object that will define the filter values and drag it to the right of the Filter Type list.
   You can use multiple objects to set the filter values by dragging additional objects from the manager pane to the right of the Filter Type list.

5. If necessary, select **Any** or **All** to determine whether the additional objects broaden or narrow your subquery.

6. To add filters to the subquery, drag objects below the subquery definition and configure the filters.
   Filters in subqueries can be grouped using the **Move Filter** buttons. You can double-click **And** or **Or** to change the operator that links filters in a group.

7. When you are finished configuring filters, click **Next**.

### 5.1.3.6 Configuring query options

After you add a query object, you can set options to improve performance and data quality including eliminating duplicate rows in the result set, setting a time limit for the query to run, and limiting the amount of data that the query returns.

#### 5.1.3.6.1 To configure query options

1. On the "Specify Query" page, in the toolbar, click the Query Options button ( ).

2. On the "Options" dialog box, set the following options:
### Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate rows</td>
<td>Select this option to allow duplicate rows in the query result. For example, if you query for Year values and duplicate rows are allowed, the query returns separate rows for all records even if they have the same year value. If you do not select this option, the query result returns distinct years only.</td>
</tr>
<tr>
<td>Max. Fetched Time</td>
<td>To limit the amount of time the query can run, select this option and specify the number of seconds in the corresponding list. To specify no time limit, set the value to -1.</td>
</tr>
<tr>
<td>Max. Row Fetched</td>
<td>To limit the number of rows of data the query can return, select this option and specify the number of rows in the corresponding list. To specify no limit, set the value to -1.</td>
</tr>
<tr>
<td>Sample Result Set</td>
<td>To retrieve a random data set within the current selection criteria as a sample, select this option and specify the number of rows to return in the corresponding list.</td>
</tr>
<tr>
<td>Fixed</td>
<td>If Sample Result Set is selected, you can select this option to include the same rows in the sample set with each data refresh. If you do not select this option, at each data refresh, the query returns a different set of sample rows.</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### 5.1.4 Insert Wizard: Specify Query Context

If the selected query has more than one context, the "Specify Query Context" page opens so you can specify the context you want to use when you add and define the query.

A context is a defined group of objects that share a common business purpose. In universes, contexts are used to avoid ambiguous queries such as queries that contain objects that return more than one type of information.

**Note:**
You can also modify the query context on the "Live Office Object Properties" dialog box.

#### 5.1.4.1 To specify query context

1. On the "Specify Query Contexts" page, from the **Available Contexts** list, select the context you want to use for your query.
Tip:
The current context is listed under the **Selected Value(s)** heading.

2. Click **Next**.
   If your query contains prompts, the "Specify Prompt Values" page opens; otherwise, the "Summary" page opens.

### 5.1.5 Insert Wizard: Specify Prompt Values

If the query contains prompts, the "Specify Prompt Values" page opens.

Prompts are either mandatory or optional. If all the prompts listed on the page are optional, you do not have to specify a prompt value at this stage. To specify prompt values when refreshing, click **Next**.

#### 5.1.5.1 To specify prompt values

1. On the "Specify Prompt Values" page, do one of the following for each prompt value you want to specify:
   - In the **Type a value** field, type a value and move it to the "Selected Values" list.
   - In the available values list, select a value and move it to the "Selected Values" list.

   **Tip:**
   If the list of available values is empty or needs to be updated, click the **Refresh Values** button ( ).
   - To search the list of available values, type a value in the search box and press **Enter**.

   **Tip:**
   To change the case options for the search, click the **Search Ignore Case** button ( ) to change to case sensitive search or the **Search Case Sensitive** button ( ) to change to ignore case search.

2. Click **Next**.
   The "Summary" page opens.
5.1.6 Insert Wizard: Summary

The "Summary" page in the Live Office Insert Wizard shows the object name, number of objects selected, and the path to the object. If desired, you can enter a different name for the Live Office object.

To finish the process and insert the object, click Finish.

5.2 Modifying queries

This section explains how to view and modify existing Live Office objects.

5.2.1 To modify a query definition

1. From your Microsoft Office document, right-click the existing query.
2. Select Live Office > Edit Universe Query.
3. On the "Specify Query" page, make the changes you want to the definition of your query, and click OK.

Related Topics
- Insert Wizard: Specify Query

5.2.2 To modify a query context

1. From your Microsoft Office document, right-click the existing query and select Live Office > Properties.
2. On the "Live Office Object Properties" dialog box, click the Prompts tab to display the current query context.
3. Click Query Context.
4. On the "Specify Query Contexts" window, select the new context from the "Available Contexts" list.
5. Click OK to submit your change.
6. On the "Live Office Object Properties" window, click OK to return to your Microsoft Office document.
The Live Office object is refreshed and the data reflects the new query context.

**Related Topics**
- Insert Wizard: Specify Query Context

### 5.2.3 To modify key date values in queries

To reset a key date value in a query, you need to edit your query.

1. From your Microsoft Office document, right-click the existing query.
2. Select **Live Office > Edit Universe Query** to run the Live Office Insert Wizard.
3. On the "Specify Query" page, click the **Keydate Properties** icon to display the "Keydate Properties" dialog box.
4. In the "Keydate Properties" dialog box, use the options provided to modify the key date settings.
   - **Use the default date**: select this option to use the default key date.
   - **Set a date**: select this option to specify the key date.
5. Click **OK** to save your new key date value.
6. Click **OK** to close the "Specify Query" page and refresh the query.

**Note:**
You can also modify the key date on the "Live Office Object Properties" dialog box.

**Related Topics**
- To add objects to queries
Using the Live Office Panel

The Live Office Panel provides an easy way to access Live Office within Microsoft Outlook. In addition to searching and inserting Live Office objects in messages, the Live Office Panel offers several tools to find and view relevant documents in the SAP BusinessObjects Business Intelligence platform repository.

Related Topics
- Live Office Panel
- To set Live Office Panel options

6.1 Understanding the Live Office Panel relationship network

As you use Microsoft Outlook in your daily business activities, the Live Office Panel builds a relationship network between your contacts, email topics, and referenced documents. Then, when you open or compose an email message, the Live Office Panel is able to suggest documents that are relevant to your current task based on this relationship network.

Similar to a social network, the relationship network evolves as your business activity grows. The network is based on the documents you associate with the business activity using the associate objects task.

Each time you initiate a business activity in Microsoft Outlook, the Live Office Panel analyzes the current context of the activities (for example, associated documents) to identify documents related to the current activity and context.

6.2 Searching the SAP BusinessObjects Business Intelligence platform repository

When working in Microsoft Office, you can use the search field on the Live Office Panel to find relevant documents in the SAP BusinessObjects Business Intelligence platform repository. You can find documents created in the following applications:
- Crystal Reports
- Web Intelligence
- Microsoft Office
The search results are ranked by relevance to the search term so the most likely items appear near the top of the list.

6.3 Using Live Office Panel favorites

If you frequently use certain objects in SAP BusinessObjects Business Intelligence platform when working in Outlook, you can add them to your favorites lists in the Live Office Panel so you can find them easily. If you have many items in your favorites folder, you may also want to search within the folder for a specific item or organize the folder so items are easier to find.

6.3.1 To add Live Office objects to favorites

1. In the Live Office Panel, right-click the object you want to add to favorites and click Add to Favorites. The Add Favorites dialog box opens.
2. In the Name box, modify the object name, if desired.
3. Select the folder you want to save the favorite in and click OK.

   **Tip:**
   To create a new folder, click **New Folder**.

   The object is added to your favorites list.

6.3.2 To view Live Office favorites
1. On the Live Office Panel, click the button to the left of the Search box and, from the list, click the Favorites button.
   The panel shows the objects in the favorites list.
2. To view a list of objects in a folder, double-click the folder.

**Tip:**
From the list, right-click an object to see a list of actions available for the object.

### 6.3.3 To search Live Office favorites

1. On the Live Office Panel, click the button to the left of the Search box and, from the list, click **Favorites**.
   The panel shows the objects in the favorites list.
2. At the bottom of the panel, click **Search Favorites**.
3. Type your search criteria and click **OK**.

### 6.3.4 To delete Live Office favorites

1. On the Live Office Panel, click the button to the left of the Search box and, from the list, click the Favorites button.
   The panel shows the objects in the favorites list.
2. Right-click an object and select **Delete**.
3. Click **OK**.
   The object is removed from the favorites list.

### 6.3.5 To rename Live Office favorites

1. On the Live Office Panel, click the button to the left of the Search box and, from the list, click **Favorites**.
   The panel shows the objects in the favorites list.
2. Right-click an object and select **Rename**.
3. Type a new name for the object and click **OK**.
6.4 Viewing related objects

In Live Office panel, related objects include:

- **Live Office objects**: items inserted into the email message from the SAP BusinessObjects Business Intelligence platform repository.
- **Associations**: documents that have been associated with the current email thread.
- **Suggestions**: other documents that might be relevant to the email message. Suggestions are based on contacts, that is, they include documents that have been inserted or associated with an email thread that includes the same sender or recipients.

From the list of related objects, you can right-click an object for a list of actions available for that object.

6.4.1 To view related objects

1. In Outlook, open or compose an email message.
2. If composing a message, enter the recipients and subject.
3. On the Live Office Panel, click the button to the left of the Search box and click **Related Objects**. The panel shows the Live Office objects, associations, and suggestions for the message.

6.5 Inserting documents in email messages

There are two ways to add content from the Live Office Panel to an email message. You can insert a link to any document found in the Live Office Panel. Recipients can click the link in the email to view the document in a web browser, if they have permission to access the repository.

You can also add content from a Crystal report, Web Intelligence document, or a universe query into the email as a Live Office object. Recipients can view the content without logging on to the repository, but they must log on to refresh the data.

6.5.1 To insert links to documents
When writing an email in Outlook, you can insert links to Crystal reports, Web Intelligence content, and Dashboards models, as well as PDFs and Microsoft Office documents.

1. In Outlook, create a new email message.
2. If the Live Office Panel is not displayed, click **Live Office > Show/Hide Live Office Panel**.
3. On the Live Office Panel, locate the document that you want to link to.
   You can choose a document from the "Associations" or "Suggestions" lists, or search for a document.
4. On the Live Office Panel, right-click the document and click **Insert as Link**.
   A link to the document is inserted into your email message. You can click the link to view the document in a web browser.

### 6.5.2 To insert documents as Live Office objects

After you search for a Crystal report, Web Intelligence document, or a universe document, you can insert it in an email as a Live Office object.

1. In the search results list, right-click and click **Insert as Live Office Object**.
   The "Live Office Insert Wizard" opens.
2. From the "Choose Data" page, select the data that you want to import and click **Next** and then click **Finish**.
   The data is inserted into the email message as a Live Office object, which contains a live connection to the data source. From the email message, you and the email recipients can refresh the object to retrieve the latest data from the SAP BusinessObjects Business Intelligence platform repository.

### 6.6 Associating objects with Outlook activities

The Live Office Panel suggests items that may be relevant to an email message based on the Live Office relationship network. You can also explicitly associate that item with an email thread. When you associate an item with an email thread, the Live Office Panel updates its network to include the relationship between the item and the message participants. The next time you receive or compose a message to one of the participants in that email thread, the Live Office Panel includes the associated item in the "Associations" list.

### 6.6.1 To associate objects with email threads

1. In Outlook, open a message from an email thread that you want to associate with an item.
2. In the Live Office Panel, from the "Search Results" or "Favorites" list, right-click an item and select **Associate with Current Email Thread**.

The item is associated with the email thread and will appear in the "Associations" list for other email messages to and from the participants in the thread.

### 6.7 Suggested documents

The Live Office Panel automatically suggests documents that are relevant to the email you are reading or writing. In this release, the suggestions are based on the email contacts. For instance, if you associate some documents to an email message and send the message to one of your contacts, those documents are included in the "Suggestions" list when you open other emails that include that contact.

### 6.7.1 To access suggested documents

- On the Live Office Panel, click the **Related Objects** button beside the Search box and click **Related Objects** from the list.

The "Suggestions" list displays all the suggested documents.
Sending Excel data to SAP BusinessObjects Explorer

In Live Office, users can directly upload Excel data to SAP BusinessObjects Explorer for analysis. Results from the analysis can be downloaded to other applications, such as Outlook and PowerPoint for further study.

7.1 To send Excel data to SAP BusinessObjects Explorer

If SAP BusinessObjects Explorer is deployed on the same system as SAP BusinessObjects Business Intelligence platform, connecting to the BI platform ensures that Live Office is connected to SAP BusinessObjects Explorer.

Otherwise, you can specify the URL for SAP BusinessObjects Explorer in the "Options" dialog box for Live Office.
1. Open a spreadsheet in Microsoft Excel.
2. Right-click in the spreadsheet, and click one of the following options:
   • To send only a selection of cells to SAP BusinessObjects Explorer, click Live Office > Explore Selection.
   • To send the entire spreadsheet to SAP BusinessObjects Explorer, click Live Office > Explore Sheet.

After the data has been processed, a URL to the selected data appears and SAP BusinessObjects Explorer opens in your default browser. The data to be sent to SAP BusinessObjects Explorer should have at least two columns, and should have one or more columns as number data type.

Related Topics
• To set BI platform options
Working with Live Office objects

After you insert Live Office objects in a Microsoft Office document, you can copy the object to another file or application, refresh data, modify and publish the object to SAP BusinessObjects Business Intelligence platform, manage security, and so on.

8.1 Refreshing data used in objects

When you create a Live Office object from a Crystal report, Web Intelligence document, or universe query, the object is inserted with the data currently available in the SAP BusinessObjects Business Intelligence platform repository. If the data in the repository changes, you can refresh the object to update the data in the Live Office object so it reflects the latest changes to the data source.

You can refresh Live Office objects manually by clicking a refresh button.

Note:
To refresh the objects, users need to have Live Office installed and have access to the source object in SAP BusinessObjects Business Intelligence platform. For more information about concealing data, see Adding security to your documents.

8.1.1 To manually refresh Live Office objects

1. Open the Microsoft Office document and log on to SAP BusinessObjects Business Intelligence platform.
2. Click Live Office > Modify Object > Properties.
3. On the "Live Office Object Properties" dialog box, ensure that Refresh data on exit is selected and click OK.
4. Make any changes you require to your document, and do one of the following to refresh it:
   - To refresh the data for all objects at once, click Live Office > Refresh All Objects.
   - To refresh the selected object, click Live Office > Refresh Object.

Note:
If a custom refresh order has been set, the refresh order will be maintained each time the objects are refreshed.
The data for the object is updated from the data source.

**Note:**
If an error occurs during the refresh operation, click **Detail** on the "Refresh" dialog box for additional information about correcting the error.

**Related Topics**
- Modifying prompt and parameter settings
- Setting Live Office Options

### 8.1.2 Configuring data refresh options

When you refresh an object, the data returned depends on:
- The type of object that was used as the source object.
- The data refresh option specified for the object.

You can change the refresh behavior for Live Office report objects, that is, Crystal reports and Web Intelligence objects, and the refresh order for when you refresh multiple objects.

#### 8.1.2.1 To configure refresh options

1. In your Microsoft Office document, select a Live Office Crystal report or Web Intelligence object.
2. From the **Live Office** menu, click **Refresh Options**.
3. On the "Refresh Options" dialog box, select the one of the following refresh options and click **OK**:
8.1.2.2 To set the refresh order

3. Deselect Consolidate prompts for each document type.
   You cannot set a refresh order if prompts are consolidated.
4. Select Enable refresh order and click Edit.
5. On the "Refresh Order Setting" dialog box, in the "Refresh Order" list, arrange the objects in the proper order.
6. Click OK.
   Each time the data is refreshed, the objects are refreshed in the specified order.

### 8.2 Modifying Live Office object properties

The "Live Office Object Properties" window provides a central location for setting general, refresh and prompt properties for Live Office objects. From this page, you can view all reports and report objects in the document. You can also modify the settings for individual objects or objects based on a report, and adjust global settings.

#### 8.2.1 To configure object properties

1. Open the Microsoft Office application and log on to SAP BusinessObjects Business Intelligence platform.
2. In the Office application, do one of the following:
   - In Office 2003, click Live Office > Properties for All Objects.
   - In Office 2007, click Live Office > Object Properties.
3. In the "Objects/Reports" pane, select the document.
4. To consolidate prompts, select Consolidate prompts for each document type. For more information, see Consolidating prompts and parameters.
   **Note:** If you consolidate prompts, you cannot specify a refresh order.
5. In the "Object/Report" pane, select an object or report.
6. If you are modifying a Crystal report or Web Intelligence object, in the "Objects of the Report" pane, select one or more objects to modify.
7. Click the General tab to view and modify the following properties:
8. If you select a Crystal report or Web Intelligence object with prompts, click the **Prompts** tab to view and modify the prompt settings. For more information, see [Modifying prompt and parameter settings](#).

9. Click the **Refresh** tab to view and modify the following refresh options for the selected object or objects:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply report format when refreshing</td>
<td>Select this option to apply the report format to the Live Office document while refreshing the display. Your customized format will be overwritten when you select this option.</td>
</tr>
<tr>
<td>Conceal data on saving; refresh to redisplay</td>
<td>Select this option to hide data in the saved document. If selected, users must refresh the document and enter their logon credentials before they can see the data. For more information, see <a href="#">Adding security to your documents</a>.</td>
</tr>
<tr>
<td>Refresh Setting</td>
<td>Click <strong>Edit</strong> to set refresh options.</td>
</tr>
</tbody>
</table>

10. Click **OK**.

**Related Topics**
- [To log on to SAP BusinessObjects Business Intelligence platform](#)
- [To configure refresh options](#)
8.2.2 Connecting to a different system

If your site has more than one SAP BusinessObjects Business Intelligence platform system, your administrator may move Crystal Reports or Web Intelligence data to a different CMS. If you open a document that contains objects that are connected to source objects that have been moved, a message indicates that the source objects cannot be found on the current system.

To connect the objects to the appropriate Crystal report or Web Intelligence object on your current system, the objects on the current system must have the same field or dimension names and table names as the original object.

For example, suppose that the New York Sales team has a document with an object that uses a Crystal report called **Global Sales**, and the report is published to the USA BI platform system. The London Sales team also has a version of the "Global Sales" Crystal report, which they have named "World Sales" and have published to the UK BI platform system. If members of the London Sales team want to use the New York Sales team's document, they must manually connect the object to the "World Sales" Report on their system.

8.2.2.1 To reconnect objects after source documents are moved

1. Open the Microsoft Office document that contains the object you want to connect and log on to SAP BusinessObjects Business Intelligence platform.
2. In the Office application, do one of the following:
   • In Office 2003, click **Live Office > Properties for All Objects**.
   • In Office 2007, click **Live Office > Object Properties**.
3. Click the **Choose** button adjacent to the **Document Location** box.
4. On the "Document Location" dialog box, navigate to the report object you want to connect to and click **OK**.
5. Repeat these steps for each object you want to connect.

When you save the document, the links to the new object instance are saved in the document.

8.2.3 Modifying prompt and parameter settings

When you insert a Live Office object into a Microsoft Office document, you specify how the values for prompts and parameters are set when the object is refreshed. After you create the object, you can change the method used to set these values by changing the prompt or parameter settings.
8.2.3.1 To change parameter or prompt values and settings

1. In the Microsoft Office document, right-click the Live Office object and select **Live Office > Prompt Setting**.
2. Click **Prompt Values**. On the "Specify Parameter Values" or "Specify Prompt Values" dialog box, select the parameter or prompt to modify, and set the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Always ask for value** | Each time the object is refreshed, the user must enter the prompt or parameter values.  
**Note:**  
If the document has multiple objects from the same report, you may be able to consolidate prompts to reduce the number of times users must enter the values. For more information, see [Consolidating prompts and parameters](#). |
| **Choose values list** | This setting allows you to bind the prompt or parameter to specific values. Click the Browse button to open the "Specify Parameter Values" dialog box and select the appropriate values. |
| **Choose Excel data range** | This setting is available in Microsoft Excel only. It allows you to bind the prompt or parameter to a range in the spreadsheet.  
**Note:**  
Parameters and prompts that accept multiple discrete values can be bound to a range, or name variable, containing multiple cells.  
To select the cell or range, do one of the following:  
- From the list, select an existing name variable.  
- In the box, type the range address.  
- Click the Specify Range button and, on the "Bind Parameter" or "Bind Prompt" dialog box, select a range in the spreadsheet. Set additional options and click **OK**.  
For more information about binding prompts and parameters to spreadsheet cells, see [To bind prompts or parameters to spreadsheet cells](#). |
3. Click **OK**.
### 8.2.3.2 To bind prompts or parameters to spreadsheet cells

When you set up a Live Office object, you can specify values and options for prompts and parameters. If the object is inserted into a Microsoft Excel document, you have the option to bind the prompts and parameters to cells in the spreadsheet. When the document is refreshed, Live Office checks the associated cells to set the value for the prompt or parameter.

By default, the data is refreshed when you change cell binding settings. To change this behavior, see Configuring data refresh options.

1. In the Microsoft Excel document, right-click the Live Office object and select **Live Office > Prompt Setting**.
2. On the "Specify Parameter Values" or "Specify Prompt Values" dialog box, select the parameter or prompt to modify and select **Choose Excel Data Range**.
3. Click the Specify Range button.
4. On the "Bind Parameter" or "Bind Prompt" dialog box, select the cells in any worksheet in the workbook and set the following options:
### Setting optional and null prompts and parameters

#### Optional prompts and parameters

When refreshing Web Intelligence report prompts, Universe query prompts, or Crystal Reports parameters that are optional (the user is not required to specify a value), Live Office requires the value of `<Not specified>` to be entered in the range if the value is not specified. When the `<Not specified>` value is located, the value setting is bypassed.

#### Null parameters

When refreshing Crystal Reports parameters that allow a NULL value, Live Office requires the value of `<null>` to be entered in the range if the value is NULL. When the `<null>` value is located, the parameter value is set to NULL.
8.2.3.3 Consolidating prompts and parameters

If you have multiple Live Office objects from the same report in a single document and the objects have prompts that are set to always ask for value, each time you refresh the document, you will be asked to enter the prompt and parameter values for each object separately. Rather than entering the same information multiple times (once for each object), you can consolidate the prompts for the document.

When prompts are consolidated, the "Specify Parameter Values" dialog box appears only once when the document is refreshed and the entered values are applied to all objects.

**Note:**
If you set a custom refresh order for the objects, you cannot consolidate prompts.

8.2.3.3.1 To consolidate prompts or parameters for easy updating

1. Right-click a Live Office object in your Microsoft Office document and click **Live Office > Properties**
or, from the **Live Office** menu, click **Properties**.
2. On the "Live Office Object Properties" dialog box, under "Objects/Reports", select the current document name.
3. Select **Consolidate prompts for each document type**.
4. Click **OK**.

8.3 Publishing files to SAP BusinessObjects Business Intelligence platform

If you have the necessary publishing rights, you can use Live Office to publish documents to SAP BusinessObjects Business Intelligence platform. You can use the BI platform to manage any Microsoft Word, Microsoft Excel, Outlook and Microsoft PowerPoint documents even the documents do not have to contain any Live Office objects.

After you publish a document, users with the required viewing rights, can view the document from the BI platform.

8.3.1 To publish Office 2003 documents

From a Microsoft Office 2003 applications, you can save the document to SAP BusinessObjects Business Intelligence platform with the current filename or you can save it with a new filename.

1. With the document open, do one of the following:
8.3.2 To publish Office 2007 documents

From a Microsoft Office 2007 application, you can save the document to SAP BusinessObjects Business Intelligence platform with the current filename or you can save it with a new filename.

1. With the document open, do one of the following:
   • To publish the document with its current name, click Live Office > Publish to SAP BusinessObjects BI platform > Save to Repository.
     
     Note:
     If the file exists on the BI platform repository, it is saved and replaces the existing file. Skip the remaining steps.
     
     • To publish the document with a new name, click Live Office > Publish to SAP BusinessObjects BI platform > Save As New to Repository.
     
     Note:
     If you are not logged on to the BI platform, you are prompted to log on.

2. Specify the name of the document and the folder where you want to save it.
3. Click Save.

8.3.3 To view published documents

To view a document from SAP BusinessObjects Business Intelligence platform, you must have the appropriate software installed on your computer, for example, Microsoft Office Word, Excel, Outlook, or PowerPoint.

Note:
The Microsoft Office security configuration and your rights for the document in the BI platform determine whether you can modify the file.
1. On the **Live Office** menu, for an Office 2007 application, click **Open from Repository**. For an Office 2003 application, click **Live Office > Publish to SAP BusinessObjects BI platform > Open from Repository**.

   **Note:**
   If you are not already logged on to the BI platform, you are prompted to log on. For more information, see [To log on to SAP BusinessObjects Business Intelligence platform](#).

2. In the "Open" dialog box, select the document and click **Open**. The document opens in the appropriate application.

   **Note:**
   If the document contains a Live Office object that was based on a document that has been published to a different SAP BusinessObjects Business Intelligence platform system, a message indicates that the source cannot be found on the current system.

### 8.4 Copying Live Office Objects

Once you have embedded a Live Office object in your Microsoft Office application, you can copy the object and paste it to other locations within the same document, or move it to other Microsoft Office applications. For example, after inserting and configuring part of a sales report within your PowerPoint presentation, you can embed the same object within an email message or a spreadsheet.

Before copying Live Office objects across applications, consider the following restrictions:

- If the target application does not support the same parameter options as the source application, parameter binding options are modified. For example, the binding setting for object parameters bound to a specific cell in Microsoft Excel will be set to **Always ask for value** if the object is copied to a different application.
- By default, when you paste a Live Office object, the connectivity with the database is maintained, which may raise data access and security concerns especially for documents that are distributed with embedded Live Office objects.

**Related Topics**
- Modifying prompt and parameter settings

### 8.4.1 To copy Live Office objects without data connectivity

By default when you paste a Live Office object, the connectivity with the BI platform is maintained. This raises data access and security concerns especially if you plan to distribute documents with embedded...
Live Office objects. To copy Live Office objects embedded in your Microsoft Office applications without BI platform connectivity, follow these steps:

1. Click **Live Office > Application Options**.
   The **Options** dialog box is displayed.
2. In the **General** tab, uncheck the **Copy and paste with Live Office connectivity** option.
3. Click **OK**.

Objects that you copy and paste will not be able to establish connectivity through Live Office, so the data for these objects will no longer be refreshed.

### 8.5 Saving Live Office data locally

After inserting and configuring Live Office objects, you can save the Microsoft Office document to a location on your local system.

For information about saving data objects to the SAP BusinessObjects Business Intelligence platform repository, see [Publishing files to SAP BusinessObjects Business Intelligence platform](#).

### 8.6 Opening local documents without data connectivity

You can open a document that contains Live Office objects and choose not to connect to the SAP BusinessObjects Business Intelligence platform when prompted. However, if you do not connect to the BI platform, you cannot use Live Office functionality to modify the object or refresh the data.

**Note:**
If data is concealed in the document, you must connect to the BI platform and refresh the objects to view the hidden data.

**Related Topics**
- [Publishing files to SAP BusinessObjects Business Intelligence platform](#)
- [To view published documents](#)

### 8.7 To remove a Live Office object from the document

You can remove a report object from your Microsoft Office document. Note that you cannot undo this action.
1. Right click any cell in the Live Office object that you want to remove, and then click Live Office.
2. On the Live Office shortcut menu, click Remove Object.
3. Click Yes to confirm that you want to delete the object.

8.8 Adding security to your documents

If you import and save data in a Microsoft Office document, other users can potentially view data that they are not authorized to view. To ensure data in your document is secure, you can conceal sensitive data in the document and publish the document to SAP BusinessObjects Business Intelligence platform.

When you save the document, the data in the object is replaced with a text string. The default text string is #Concealed.

When users view the document, they must refresh the concealed data before they can view it. To refresh the data, they must have SAP BusinessObjects Live Office installed on their system and they must log on to the BI platform using a user account that has permission to view the data.

8.8.1 To conceal data in documents

1. In the Microsoft Office document, do one of the following:
   • In Office 2003, click Live Office > Properties for All Objects.
   • In Office 2007, click Live Office > Object Properties.
2. On the "Live Office Object Properties" dialog box, click the Refresh tab.
3. Select Conceal data on saving; refresh to redisplay and then click OK.
4. Save the document.

When the document is saved, the concealed data is changed to a text string. To restore the data, the user must log in to SAP BusinessObjects Business Intelligence platform with appropriate permissions and refresh the document.
Troubleshooting Live Office

9.1 Enabling logging for Live Office

Logging for Live Office is enabled by default at installation. This section contains information on how to configure and enable logging.

9.1.1 To configure logging for Live Office

1. Create a config.xml file and save it as LOLogger.config.
2. Store the file in the Live Office UI assembly directory. The default location is C:\Program Files\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win32_x86.
3. Navigate to and open the XML file in your XML editor. Change the level value parameter to one of the following parameters: Debug, Info, Warn, Error, or Fatal.

   **Note:**
   The logger will log any system messages that meet or exceed the parameter value you defined.

4. Change or add any additional configuration parameters you want for your Live Office logging. For example, the `<param name="File" value="log-file.txt"/>` parameter to define the name and location of the .txt file where you can monitor logging activity.

   **Tip:**
   You can change the default time out value of 600 seconds by modifying the string value for the following Live Office registry key: [HKEY_CURRENT_USER\Software\Business Objects\Suite 12.0\Live Office\ENTERPRISE] "DefaultTimeOut"="600"

5. Close all Microsoft Office applications. Next time you launch a Microsoft Office application, logging will be enabled.

   **Note:**
   To disable Live Office logging, delete or rename the LOLogger.config file.
9.1.2 Sample Live Office log files

This section contains both a sample LOLogger.config XML file and a sample log.txt output file.

### Sample LOLogger.config XML file format

```xml
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <configSections>
    <section name="log4net" type="log4net.Config.Log4NetConfigurationSectionHandler, log4net-net-1.0" />
  </configSections>

  <log4net>
    <root>
      <!-- the level value could be: OFF; FATAL; ERROR; WARN; INFO; DEBUG; ALL -->
      <level value="ALL" />
      <appender-ref ref="RollingLogFileAppender" />
    </root>

    <appender name="RollingLogFileAppender" type="log4net.Appender.RollingFileAppender" >
      <file value="${APPDATA}\Business Objects\Live Office\log-file.txt" />
      <appendToFile value="true" />
      <!--use the minimal locking model that allows multiple processes to write log. -->
      <lockingModel type="log4net.Appender.FileAppender+MinimalLock" />
      <!--The file written to will always be called log-file.txt because the StaticLogFileName param
      is specified. The file will be rolled based on a size constraint (RollingStyle). Up to 3 (MaxSizeRollBackups)
      old files of 2 MB each (MaximumFileSize) will be kept. These rolled files will be named: log-file.txt.1,
      log-file.txt.2, log-file.txt.3, etc... -->
      <rollingStyle value="Size" />
      <maxSizeRollBackups value="3" />
      <maximumFileSize value="2MB" />
      <staticLogFileName value="true" />
      <layout type="log4net.Layout.PatternLayout">
        <param name="ConversionPattern" value="%d [%t] %-5p %m%n" />
      </layout>
    </appender>
  </log4net>
</configuration>
```

### Sample log file format

When Live Office runs, it will generate the log-file.txt. A sample .txt file is shown below.

<table>
<thead>
<tr>
<th>Date</th>
<th>Time</th>
<th>PID</th>
<th>Loglevel</th>
<th>Log message</th>
</tr>
</thead>
<tbody>
<tr>
<td>2006-11-03</td>
<td>09:19:34</td>
<td>387</td>
<td>DEBUG</td>
<td>Enter populateAuthComboThreadHelper</td>
</tr>
<tr>
<td>2006-11-03</td>
<td>09:19:35</td>
<td>384</td>
<td>DEBUG</td>
<td>get Session = BusinessObjects.DSWS.Session.Session</td>
</tr>
</tbody>
</table>

**Note:**

You can change the name of the logging output file in the LOLogger.config XML using the `<file value="${APPDATA}\Business Objects\LiveOffice\log-file.txt" />` parameter.
9.2 Troubleshooting Live Office components

This section describes problems that you might encounter when installing or using SAP BusinessObjects Live Office. To view troubleshooting information, click any of the following links.

**Note:**
If this document does not list a solution for the problem you are having, contact Customer Support.

**Related Topics**
- Live Office menu missing
- Object refresh failed
- Object sort and filter settings missing after refreshing
- Access to universe denied
- Live Office object size limitations

### 9.2.1 Live Office menu missing

**Cause:**
The Live Office add-in is not properly enabled.

**Solution:**
You need to run the enable_addin.exe located at `C:\Program Files\Business Objects\BusinessObjects Enterprise XI 4.0\LiveOffice`

For more information, see the *SAP BusinessObjects Live Office Installation Guide* available on your product CD or on the SAP Help Portal.

### 9.2.2 Object refresh failed

**Cause:**
By design, there are known cases where refreshing your Live Office object will fail. The most common cause for these refresh errors is that the underlying structure of the source report has changed since the Live Office object was last refreshed. By design refresh failures could occur because of any of the following.

- The type of report part has changed. For example, from a table to a chart.
• The source Web Intelligence or Crystal Reports file has been deleted from SAP BusinessObjects Business Intelligence platform.

• The source Universe has been changed or deleted.

• SQL database table fields or restrictions have been changed or deleted. For example, the database field type or restriction specified is invalid or unavailable.

• There is not a report instance available.

• Table structure has been changed.

Solution:
An error message should appear and indicate the source of the problem. If it does not or it is not helpful, check to see if there have been any recent changes in report structure.

Note:
You can also find further explanation of error messages in the document Error Messages Explained, located on the SAP Help Portal.

9.2.3 Object sort and filter settings missing after refreshing

Cause:
Microsoft Office Excel based sort and filter operations are not fully supported by Live Office.

Solution:
Reapply these operations after refreshing the Live Office object. Other report formatting is retained.

9.2.4 Access to universe denied

Cause:
You do not have sufficient access rights for the universe. An error message is displayed when you try to refresh a query or you cannot view objects in a displayed Universe.

Solution:
Contact your system administrator to provide you with sufficient rights to access the universe.
9.2.5 Live Office object size limitations

For each Microsoft Office application that Live Office supports, there is a maximum number of rows and columns that can exist in a table or worksheet. This affects how much data you can insert into an object because Live Office inserts the data in the form of a table or as rows and columns in a worksheet. These limits are set by the Microsoft Office applications so it is helpful to know these limits when you plan what data you are going to create an object from.

Microsoft Word
• Maximum rows = 32767
• Maximum columns = 15

Microsoft Excel

Note:
If you are using MS Excel 2007 then the following limitations will not apply.
• Maximum rows = 65536
• Maximum columns = 256

PowerPoint
• Maximum rows = 75
• Maximum columns = 25
10.1 Backward compatibility

The following sections contain backward compatibility information for Live Office 4.1 components. This content includes information about deprecated features, unsupported features, support for previous versions of Live Office and other SAP BusinessObjects products, and Live Office behavior changes between versions.

Related Topics

- Unsupported features

10.1.1 Unsupported features

An unsupported feature is a feature that may or may not ship with the product but for which support is no longer provided. This means that technical support calls and enhancement requests relating to this feature will no longer be accepted. The following Live Office functionality is unsupported for this version of Live Office.

In-place drill functionality in Web Intelligence and Crystal Reports
Live Office does not support in-place drill functionality for either Web Intelligence or Crystal Reports rowsets and report parts. In Live Office, the object refresh reflects the last saved drill state.

Windows NT authentication
Microsoft Corporation has replaced Windows NT authentication with Windows Active Directory.

OLAP Intelligence functionality
Live Office does not support OLAP Intelligence functionality and any OLAP Live Office objects from previous releases are not recognized.

Live Office objects based on Business Views
Live Office does not support inserting and modifying Live Office objects that are based on Business Views. As a workaround, advanced users can still insert from a Crystal report that is based on a Business View.
**Creating Crystal reports from Excel ranges**

To create a Crystal report based on an Excel range, use the Crystal Reports Designer, which provides more comprehensive reporting functionality.

**Inserting rowsets from Web Intelligence data providers**

To insert rowsets from Web Intelligence reports, use the Web Intelligence report part support to insert a table from an existing Web Intelligence report.
# More Information

<table>
<thead>
<tr>
<th>Information Resource</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP Help Portal</td>
<td>Navigate to <a href="http://help.sap.com/businessobjects">http://help.sap.com/businessobjects</a> and on the “SAP BusinessObjects Overview” side panel click <strong>All Products</strong>. You can access the most up-to-date documentation covering all SAP BusinessObjects products and their deployment at the SAP Help Portal. You can download PDF versions or installable HTML libraries. Certain guides are stored on the SAP Service Marketplace and are not available from the SAP Help Portal. These guides are listed on the Help Portal accompanied by a link to the SAP Service Marketplace. Customers with a maintenance agreement have an authorized user ID to access this site. To obtain an ID, contact your customer support representative.</td>
</tr>
</tbody>
</table>
  - Installation guides: [https://service.sap.com/bosap-instguides](https://service.sap.com/bosap-instguides)  
  - Release notes: [http://service.sap.com/releasenotes](http://service.sap.com/releasenotes)  
  The SAP Service Marketplace stores certain installation guides, upgrade and migration guides, deployment guides, release notes and Supported Platforms documents. Customers with a maintenance agreement have an authorized user ID to access this site. Contact your customer support representative to obtain an ID. If you are redirected to the SAP Service Marketplace from the SAP Help Portal, use the menu in the navigation pane on the left to locate the category containing the documentation you want to access. |
| Docupedia                       | [https://cw.sdn.sap.com/cw/community/docupedia](https://cw.sdn.sap.com/cw/community/docupedia)  
Docupedia provides additional documentation resources, a collaborative authoring environment, and an interactive feedback channel. |
| Developer resources             | [https://boc.sdn.sap.com/](https://boc.sdn.sap.com/)  
<table>
<thead>
<tr>
<th>Information Resource</th>
<th>Location</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP BusinessObjects articles on the SAP Community Network</td>
<td><a href="https://www.sdn.sap.com/irj/boc/businessobjects-articles">https://www.sdn.sap.com/irj/boc/businessobjects-articles</a></td>
<td>These articles were formerly known as technical papers.</td>
</tr>
<tr>
<td>Notes</td>
<td><a href="https://service.sap.com/notes">https://service.sap.com/notes</a></td>
<td>These notes were formerly known as Knowledge Base articles.</td>
</tr>
<tr>
<td>Forums on the SAP Community Network</td>
<td><a href="https://www.sdn.sap.com/irj/scn/forums">https://www.sdn.sap.com/irj/scn/forums</a></td>
<td></td>
</tr>
<tr>
<td>Training</td>
<td><a href="http://www.sap.com/services/education">http://www.sap.com/services/education</a></td>
<td>From traditional classroom learning to targeted e-learning seminars, we can offer a training package to suit your learning needs and preferred learning style.</td>
</tr>
<tr>
<td>Online customer support</td>
<td><a href="http://service.sap.com/bosap-support">http://service.sap.com/bosap-support</a></td>
<td>The SAP Support Portal contains information about Customer Support programs and services. It also has links to a wide range of technical information and downloads. Customers with a maintenance agreement have an authorized user ID to access this site. To obtain an ID, contact your customer support representative.</td>
</tr>
<tr>
<td>Consulting</td>
<td><a href="http://www.sap.com/services/bysubject/businessobjectsconsulting">http://www.sap.com/services/bysubject/businessobjectsconsulting</a></td>
<td>Consultants can accompany you from the initial analysis stage to the delivery of your deployment project. Expertise is available in topics such as relational and multidimensional databases, connectivity, database design tools, and customized embedding technology.</td>
</tr>
</tbody>
</table>
A
accessing suggested documents 66
associations
adding for email threads 65
viewing list of 64

B
BI platform options 22

C
cell binding and refresh options 20
CMS
connecting to different 13
logging on 12
conceal data 82
consolidate prompts 78
context 10
specifying for queries 56
specifying for Web Intelligence
objects 40
Crystal Reports
create from Excel ranges 89
drill functionality 89
support for 11
Crystal Reports content
fields, adding and removing in 33,
34
filters, applying 31
filters, modifying in 34
Insert wizard, starting for 27
inserting 27, 29
fields 31
parts 30
locating in the repository 28
modifying 33
rows and columns, adding 33
specifying parameter values 29
working with 27
Crystal Reports objects
adding from same source 32
exclude specific values 35
filtering specific values 35
filters, removing 35

data
concealing 82
error messages, modifying 21
overwriting, prompt before 20
data results, filtering Crystal Reports
content 31
data source
queries, setting for 46
default cell values, setting 21
documents
saving SAP BusinessObjects
Business Intelligence platform
78
securing data in 82
viewing on SAP BusinessObjects
Business Intelligence platform
78
drill functionality 89

e-mail
associate objects with threads 65
inserting documents 64
as links 64
as Live Office objects 65
viewing related objects for a
message 64
error messages, changing 21
Excel data 67
favorites 62
adding to Live Office panel 62
deleting in Live Office Panel 63
renaming in Live Office Panel 63
searching in Live Office Panel 63
viewing in Live Office Panel 63
features, unsupported 89
fields
adding from Crystal Reports 31
Crystal Reports content, adding or
removing in 33, 34
exclude from a Crystal Reports
object 35
excluding from Crystal Reports
content 35

D
fields (continued)
focus on in a Crystal Reports object
35
report parts
support for 11
support for 11
filters
adding specific values for Crystal
Reports content 35
applying for Crystal Reports
content 31
Crystal Reports
adding specific values 35
exclude a value 35
focus on a value 35
modifying in Crystal Reports
content 34
removing from Crystal Reports
content 35

general options 20

I
inserting
Crystal Reports content 27

K
Key Date 39
creating queries with 48
queries, modifying in 59
setting for Web Intelligence 39
Web Intelligence documents,
modifying in 42

L
Live Office
about 9
backward compatibility 89
concepts 10
Insert Wizard
Crystal Reports, starting 27
logging, enabling 83
object size limitations 87
Live Office (continued)

objects
upgrading from previous versions 13
viewing list of 64
refresh options, configuring 70
removing objects 81
shortcut menu 19
troubleshooting tips 85

Live Office Panel 61
about 18
displaying 19
favorites 62
adding 62
deleting 63
renaming 63
searching 63
viewing 63
inserting documents in emails as links 64
as Live Office objects 65
objects, associating with messages 65
options 24
relationship network 61
repository, searching 61
SAP BusinessObjects Business Intelligence platform, searching repository 61
locale, changing viewing 22
logging enabling in Live Office 83

P
panel options 24
parameter values specifying 29
parameter settings changing 75
parameter values consolidating 78
parameters 10
binding to spreadsheet cells 76
specifying values 29
parts
adding from Crystal Reports 30
precondition objects
queries, adding to 48
prompt settings changing 75
prompts 10
binding to spreadsheet cells 76
consolidating 78
specifying values for queries 57
specifying values for Web Intelligence reports 40
publishing
from office 2003 78
from Office 2007 79

Q
queries 45
adding ranking to 49
building in Insert Wizard 46
configuring options 55
context, specifying 56
inserting 45

queries (continued)
Key Dates, modifying 59
modifying context 58
definition 58
modifying content 58
object types 47
objects
filters, setting as 54
objects, adding to 48
prompt values, specifying 57
sorting 50
support for 11
Universe, choosing 46
with Key Date settings 48

R
refresh options 20
configuring 70
refresh order, setting 71
related objects 64
viewing for email messages 64
relationship network 61
report instances 10
report objects 10
report parts 10
adding to Web Intelligence content 42
Web Intelligence, inserting 41
repository
queries, setting as data source for 46
Web Services URL to access 22
reverse proxy, configuring access to 22
ribbon menu, Live Office 16

S
SAP BusinessObjects Business Intelligence platform
connecting to 11, 12
connection options 22
publishing to 78
repository
searching from Live Office Panel 61
saving to local drive 81
to SAP BusinessObjects Business Intelligence platform 78
secured databases, accessing 36
security ensuring data 82
sending Excel data 67
shortcut menu 19
configuring 20
Single Sign On (SSO) 12
enabling 22
suggested documents 66
suggestions
viewing list of 64

T
toolbar, Live Office 13
show or hide 15

U
universe 10

unsupported features 89
upgrading content from previous
versions 13

V
view options 21
viewing documents on SAP
BusinessObjects Business
Intelligence platform 78
viewing locale, changing 22

W
web browser, viewing objects in 22

Web Intelligence
drill functionality 89
Key Date, setting 39
rowsets from data providers 89
support for 11
Web Intelligence content 37
adding more report parts 42
context, specifying 40
inserting 37
inserting report parts 41
Key Date, modifying 42
Key Date, setting 39
locating in the repository 38
prompts, specifying values 40
refreshing 69
Windows NT authentication 89