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Getting Started

2.1 About this documentation

This documentation contains information about working with and managing objects in BI platform, and
about accomplishing these tasks through the Central Management Console (CMC) in particular.
Procedures are provided for common tasks. Conceptual information and technical details are provided
for all advanced topics.

For more information about system administration tasks such as planning your deployment, managing
servers, setting rights, setting up authentication, or managing users and groups, see the SAP
BusinessObjects Business Intelligence Platform Administrator Guide. For more information about
installing BI platform, see the SAP BusinessObjects Business Intelligence Platform Installation Guide.
Both of these guides are available at http://help.sap.com.

2.2 Who should use this documentation?

This documentation is intended for content administrators and power users who manage content in the
repository and distribute updated content to recipients.

2.3 About SAP BusinessObjects Business Intelligence platform

The BI platform is a flexible, scalable, and reliable solution for delivering powerful, interactive reports
to end users via any web application—intranet, extranet, Internet or corporate portal. Whether it is used
for distributing weekly sales reports, providing customers with personalized service offerings, or
integrating critical information into corporate portals, BI platform delivers tangible benefits that extend
across and beyond the organization. As an integrated suite for reporting, analysis, and information
delivery, the platform provides a solution for increasing end-user productivity and reducing administrative
efforts.
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2.4 Licensing

BI platform supports the following types of user licenses:
• BI Viewer
• BI Analyst
• Concurrent user
• Named user

Each license type grants and restricts access to particular tasks and applications. Depending on the
license you have, you may be unable to access some applications, create new content, or add documents
to the repository. To determine which license you have, contact your system administrator. For more
information about licensing, see the SAP BusinessObjects Business Intelligence Platform Administrator
Guide on the SAP Help Portal at http://help.sap.com.

2.5 Key concepts

Before you begin, familiarize yourself with the main concepts in BI launch pad. Depending on the tasks
you perform, some concepts may not apply to you.

Objects
An object is a document or file created in BI platform or other software that is stored and managed in
the BI platform repository.

Categories
A category is an organizational alternative to a folder. Use categories to label objects.

Scheduling
Scheduling is the process of automatically running an object at a specified time. Scheduling refreshes
dynamic content or data in the object, creates instances, and distributes the instances to users or stores
them locally.

Events
An event is an object that represents an occurrence in the BI platform system. Events can be used for
a variety of purposes, including:
• As scheduling dependencies that trigger actions after a scheduled job runs
• To trigger alert notifications
• To monitor BI platform performance
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Calendars
A calendar is a customized list of run dates for scheduling jobs.

Instances
An instance is a snapshot of an object that contains data from the time an object was run.

Publishing
Publishing is the process of making personalized dynamic content publicly available for mass
consumption.

Profiles
A profile is an object that associates users and groups with personalization values. Profiles are used
with Publishing to create personalized content and distribute it to recipients.

Alerting
Alerting is the process of notifying users and administrators when events occur in BI platform.

2.6 Key tasks

This section identifies key tasks you can perform in BI platform and topics that contain information about
the tasks.

How do I add objects to the repository?
See the “Adding objects to BI platform” topic.

How do I modify and manage objects after they have been added to the repository?
See the “Working with content objects” chapter.

How do I organize objects?
See the “Organizing objects” chapter.

How do I distribute content to users?
You can distribute content to users through scheduling, publishing, and alerting.
• Scheduling lets you refresh data in dynamic content documents and distribute the refreshed data

to users at regular intervals. See “Scheduling”.
• Publishing lets you personalize and refresh content in dynamic content documents for specific users

and groups. See the “About publishing” topic.
• Alerting sends alert notifications to subscribers when an event has occurred in BI platform. See the

“Alerting” chapter.

Related Topics
• Adding objects to BI platform
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• General object management
• Scheduling
• Alerting

2012-11-0614

Getting Started



Working with the Central Management Console

3.1 About the Central Management Console

The Central Management Console (CMC) is a web-based tool that you can use to perform almost all
day-to-day administrative tasks, including user management, content management, and server
management.

Any user with valid credentials to BI platform can log on to the CMC and set preferences. Users who
are not members of the Administrators group cannot perform any available management tasks unless
they have been granted access rights to do so.

3.2 To log on to the CMC from your browser

You can access the CMC by typing the URL in a browser or from the Windows Start menu.

When you finish using the CMC, log off to end the session. The Log Off link is located in the upper-right
corner of the CMC.
1. Type the appropriate URL or start the CMC from the Windows Start menu.
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The default URL is http://webserver:8080/BOE/CMC/. Replace webserver with the name of the
web server machine. If a custom URL was configured for your deployment, type that URL. If
necessary, change the default port number to the number that was provided during installation.
On Windows, select Start > Programs > SAP Business Intelligence > SAP BusinessObjects BI
platform 4 >Central Management Console. If your CMC is hosted on a Web Application Container
Server (WACS), select Start > Programs > SAP Business Intelligence > SAP BusinessObjects
BI platform 4 > SAP BusinessObjects BI platform WACS Central Management Console.

2. In the System box, type the name of your Central Management Server (CMS).
3. Type your user name and password.

If you are using LDAP authentication, you can log on using an account that has been mapped to
the Administrators group.

Note:
If this is the first time an administrator from your organization is accessing the CMC, type Adminis
trator as the user name and provide the default password that was created during installation.

4. In the Authentication list, select Enterprise.

Windows AD, LDAP, and other authentication methods also appear in the list. However, you must
map third-party user accounts and groups to BI platform before you can use these types of
authentication.

5. Click Log On.

The CMC home page appears.

3.3 Navigating the CMC

There are many ways to navigate the CMC, starting from the home page:

2012-11-0616

Working with the Central Management Console



• Click icons on the left side
• Click links under the Organize, Define, and Manage headings
• Select options in the list under “Central Management Console”

Note:
Using the tree view, when you navigate to selections with many child objects, not all child objects may
appear. Use the paginated object listing to navigate to child objects.

3.4 To set CMC preferences

Use the "Preferences" area of the CMC to customize your administrative view of BI platform.
1. In the CMC, click Preferences in the upper-right corner.
2. Set the preferences as needed.

CMC preferences work the same as in BI launch pad—except CMC preferences affect both the
CMC and BI launch pad. See also preferences information in the SAP BusinessObjects Business
Intelligence Launch Pad User Guide.

3. Click Save & Close.

Related Topics
• CMC preference options

3.4.1 CMC preference options

ExplanationCMC preference option

Sets the default language options for BI platform. For
more information, see the SAP BusinessObjects Busi-
ness Intelligence Platform Installation Guide.

Product Locale list

Sets the default formatting options for dates, times, and
numbers in CMC.Preferred Viewing Locale list
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ExplanationCMC preference option

Limits the number of objects listed on any page or tab
in CMC

Note:
This value does not limit the number of objects dis-
played—only the number displayed per page.

Maximum number of objects per page
box

If you are managing BI platform remotely, use this list
to specify your time zone. BI platform synchronizes
scheduling patterns and events appropriately.

For example, if you select Eastern Time (US & Canada)
and you schedule a report to run at 5:00 a.m. every day
on a server in San Francisco, the server will run the re-
port at 2:00 a.m. Pacific Time.

Time Zone list

Controls whether you are prompted for confirmation
when you click Cancel or close to close a dialog box
without saving work. Select one of the following options:
• On: The prompt is enabled.
• Off: The prompt is disabled.
• Default: The prompt is determined by values config

ured in the CmcApp.properties file, located in
the C:\Program Files (x86)\SAP Busines
sObjects\Tomcat6\webapps\BOE\WEB-
INF\config\custom folder.

Prompt for Unsaved Data list

3.4.2 Preferred viewing locales

The preferred viewing locale (PVL) sets how dates, times, and numbers are formatted. For multilingual
objects, the PVL also determines the language used to display an object's name and description. If an
object has multiple translated names and descriptions, the display language is determined in the following
way:
1. The system displays the name and description that correspond to the user's PVL.

BI platform may use a default fallback locale, but it is typically a variation of the user's PVL. For
example, if the PVL is French (Canada) and the object does not have a translated name and
description in Canadian French, BI platform will use French (France).
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2. If no PVL is set, BI platform displays the name and description in the same language as the product
locale.

3. If none of the preceding options is feasible, BI platform displays the name and description in the
object's source language.
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Adding Objects to the Repository

4.1 Adding objects to BI platform

This section discusses the process of adding objects to the BI environment and making them available
to authorized users. You can add many types of objects to BI platform, including:
• Reports (from SAP Crystal Reports)
• Documents (from SAP BusinessObjects Web Intelligence)
• Flash objects
• Programs
• Microsoft Excel, Word, and PowerPoint files
• PDF files
• Text files
• Rich text format files

You can add objects to BI platform in the CMC or by saving objects directly to the CMS.

Note:
Depending on your user license, you may not have access rights to add objects. To determine which
license type you have, contact your system administrator. For more information about licensing, see
the SAP BusinessObjects Business Intelligence Platform Administrator Guide on the SAP Help Portal
at http://help.sap.com.

Tip:
In BI launch pad, you can create new objects and add them directly to BI platform. See the SAP
BusinessObjects Business Intelligence Launch Pad User Guide on the SAP Help Portal at
http://help.sap.com.

4.1.1 To add an object in the CMC

If you have administrative rights to BI platform, you can add objects over the Internet from the CMC.
Use the CMC to add single objects or to perform administrative tasks remotely.
1. Go to the "Folders" management area of CMC.
2. Locate and select the folder to which to add an object.
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3. Select Manage > Add, and then select Program File to add a program object or Local Document
to add other types of objects.

4. In the dialog box that appears, specify the properties of the object.
The properties fields that appear vary according to the type of object you chose (program file or
local document). The properties fields are summarized in the table “Object properties in the CMC”.

5. To assign the object to a category, select the category in the list.
6. Click OK.

The CMC refreshes and displays the folder contents, including the object you added.

If necessary, you can modify properties such as title, description, database logon information, scheduling
information, user rights, and so on for an object after it is added to the CMC.

4.1.1.1 CMC object property options

NotesPropertyObject type

Type the name of the object to
add, or click Browse to locate
the object.

Filename

Crystal reports and other object
types

Type the name of the object.Title

Type a description of the object.Description

Type keywords for the object.Keywords

Select this option if you want to
retain the report's saved data.Keep saved data

Crystal reports only
Select this option if you want to
preserve the report's summary
information.

Use description from report
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NotesPropertyObject type

Type the name of the program
object to add, or click Browse
to locate the object.

Browse for an existing Pro-
gram object

Program files only
Select an option to define the
type of program you are adding:
• Executable (binary, batch,

shell script)
• Java
• Script (VBScript,

JavaScript)

Program type

Specify the MIME extension for
the object if needed.MIMEOther object types

4.1.2 Saving objects directly to the CMS

If you installed a BI platform designer component, such as SAP Crystal Reports for Enterprise or SAP
BusinessObjects Web Intelligence, you can use the Save As command to add objects directly to BI
platform from the designer.

For example, after you design a report in SAP Crystal Reports, you can select File > Save As, select
Enterprise, log on to the CMS when prompted, specify a folder in which to save the report, and click
Save. The report is saved from Crystal Reports to the folder in the CMS.

Note:
You can add SAP BusinessObjects Analysis, edition for OLAP workspaces to BI platform; however,
you cannot set them to run on a recurring schedule.
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Organizing Objects

5.1 Folders

Folders are objects that are used to group and organize other objects. For example, you use folders to
separate content into logical groups. Because you can set security at the folder level, you can also use
folders as a tool for controlling access to information.

It is a good practice to set up folders in a structure that already exists in your organization, such as
departments, regions, or your database table structure. You can then use categories to set up an
alternate system of organization.

Each object in BI platform must reside in a folder. By default, new objects that you add to a folder inherit
the object rights specified for the folder.

5.1.1 Working with folders

5.1.1.1 To create a new folder

Before creating a top-level folder, ensure that you are viewing all folders.

To create a subfolder, first select the target folder where you want to create a new folder.
1. Go to the "Folders" management area of CMC.
2. Navigate to where you want to create the folder.
3. Select Manage > New > Folder.
4. In the "Create folder" dialog box, type a name for the new folder.
5. Click OK.

The new folder appears in the list of folders and objects.

Next you can add objects to the folder or edit the folder properties.
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Tip:
To revise the name, description, or keywords for a folder after you create it, select the folder and select
Manage > Properties.

Related Topics
• To add an object in the CMC
• To change the properties of an object

5.1.1.2 To delete a folder

When you delete a folder, all subfolders, reports, and other objects it contains are removed from BI
platform.
1. Go to the "Folders" management area in CMC.
2. Select the folder to delete.

Tip:
To select multiple folders, hold down the CTRL or SHIFT key and click each folder so that you can
delete several folders simultaneously.

3. Select Manage > Delete.
4. Click OK to confirm the deletion.

5.1.1.3 Copying and moving folders

When you copy or move a folder, the objects in the folder are also copied or moved. BI platform treats
object rights differently, depending upon whether you copy or move a folder:
• When you copy a folder, the new (copied) folder does not retain the original folder's object rights.

Instead, the copy inherits object rights from its new parent folder. For example, if you copy a private
Sales folder to a Public folder, the contents of the new Sales folder will be accessible to all users
who have rights to the Public folder.

• When you move a folder, the folder retains all of its object rights. For example, if you move a private
Sales folder to a publicly accessible folder, the Sales folder will remain inaccessible to most users.

5.1.1.3.1 To copy or move a folder
1. Go to the "Folders" management area of CMC.
2. Select a folder to copy or move.

If the folder is not at the top level, locate its parent folder and select the parent folder.
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Tip:
To select multiple folders, hold down the CTRL or SHIFT key and click each folder to move several
folders simultaneously.

3. Select Organize > Copy To or Organize > Move To.
4. Select the destination folder.
5. Click Copy or Move.

The folder you selected is copied or moved to the new destination.

5.1.2 Specifying folder rights

You can change the object rights for new folders you create. By default, new objects you add to a folder
inherit the object rights of the folder. For more information about rights, see information about setting
rights in the SAP BusinessObjects Business Intelligence Platform Administrator Guide available on the
SAP Help Portal at http://help.sap.com.

5.1.3 To limit instances at the folder level

Setting limits allows you to automatically delete report instances in BI platform. The limits you set on a
folder affect all objects in the folder. At the folder level, you can set the following limits:
• The number of instances for each object, user, or user group
• The number of days to retain instances for a user or group

1. Select a folder, and selectActions > Limits.
2. To limit the number of instances per object, select the Delete excess instances when there are

more than N instances of an object check box, and type the maximum number of instances to
retain on the system in the box.
The default value is 100.

3. Under Delete excess instances for the following users/groups:
a. To limit the number of instances per user or group, click Add.
b. Select available users or groups, and click > to add the users or groups to the Selected

users/groups list.
c. Click OK.
d. For each user or group you selected, in the Maximum instance count per object per user box,

type the maximum number of instances to remain on the system.
The default value is 100.

4. Under Delete instances after N days for the following users/groups:
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a. To limit the age of instances per user or group, click Add.
b. Select available users or groups, click > to add the users or groups to the list of Selected

users/groups.
c. Click OK.
d. For each user or group you selected, in the Maximum instance age in days box, type the

maximum age of instances.
The default value is 100.

Related Topics
• To set limits for instances

5.1.4 To view personal folders

BI platform creates a folder for each user on the system, organized in the CMC as personal folders. By
default, there are personal folders for the Administrator and Guest accounts. When you log on to the
CMC and view the list of personal folders, only folders to which you have at least View rights appear.

Note:
In BI launch pad, the folders are called Favorites folders.

• Select Personal Folders in the list on the home page.

A list of subfolders appears. Each subfolder corresponds to a user account on the system. Only folders
and subfolders for which you have at least View access rights appear in the list.

5.2 Categories

Categories provide an alternative way of organizing objects, and therefore an alternative way for users
to navigate to them. For example, you could organize your content into departmental folders, and then
use categories to create an alternate filing system that divides content according to different roles in
your organization, such as managers or VPs. This organizational model allows you set security on
groups of documents based on department or job role.

There are two types of categories: corporate and personal. Corporate categories are created and
administrated by administers with the appropriate rights, and are only visible to groups and users who
have the rights to view them; personal categories are created by individual users, and are only visible
to themselves.

While all objects must reside in folders, category assignment is optional; therefore, it is important to
note that:
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• While you can assign rights to a category as an object (that is, grant groups and users rights to it),
the objects within the category cannot inherit rights set on the category itself.

• An object in a category retains its affiliation with the folder it resides in.
• An object can reside in multiple categories.

5.2.1 Working with categories

Categories provide an alternate way to organize objects. You can associate documents with multiple
categories, and you can create subcategories within categories.

BI platform provides two types of categories:
• Corporate categories are created by the administrator, or other users who have been granted access

to these categories. If you have the appropriate rights, you can create corporate categories.
• Personal categories can be created by each user to organize their own personal documents.

5.2.1.1 To create a new category

1. Go to the "Categories" management area of the CMC.
2. Click Manage > New > Category.
3. Type a name for your category.
4. Click OK.

The new category is added to the system.

Click Manage > Properties to change settings for this category.

5.2.1.2 To delete a category

When you delete a category, all subcategories within it are removed. Unlike folder deletion, the reports
and other objects contained within the category are not deleted from the system.
1. Go to the "Categories" management area of the CMC.
2. Select the category to delete.

If the category is not at the top level, locate the parent category and make your selection.

Tip:
To select multiple categories, hold down the CTRL or SHIFT key and click each category, so that
you can delete several categories simultaneously.
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3. Click Manage > Delete.
4. Click OK to confirm that you want to delete the category.

5.2.1.3 To move a category

When you move a category, any object assigned to the category maintains its association with it. All of
the category's object rights are retained.

For example, you may have a South American Sales category that is accessible only by sales people
in that region. You also have a World Sales category that contains worldwide sales reports needed by
all sales people. For more intuitive organization, you want to move the region categories into the World
Sales category. When you move the South American Sales category into the World Sales category, it
retains its rights settings and associated objects, even though it has become a subcategory of the World
Sales category.
1. Go to the "Categories" management area of the CMC.
2. Select the category that you want move.

If the category you want to move is not at the top level, locate its parent category. Then make your
selection.

Tip:
To select multiple categories, hold down the CTRL or SHIFT key and click each category, so that
you can move several categories simultaneously.

3. Click Organize > Move To.
4. Select the destination category.

Tip:
If there are many categories on your system, use the "Search title" field to search, or click Previous,
Next, and + to browse the category hierarchy.

5. Click Move.

The category you selected is moved to the new destination.

5.2.1.4 To add an object to a category

Follow this procedure to add an object to a category.
1. Go to the "Folders" management area of the CMC.
2. Navigate to the object you would like to add to a category and select it.
3. Click Manage > Categories.
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4. Select the categories to which you want to add the object.
5. Click Save & Close.

5.2.1.5 To remove or delete objects from a category

You can either remove or delete objects from a category. When you remove an object, you remove it
from the category only. When you delete an object, you remove it from the category and also delete it
from the system.
1. Go to the "Categories" or "Personal Categories" management area of CMC.
2. Double-click the category to remove or delete an object from.
3. Select the object or objects to remove or delete.
4. Remove the object from the category or delete the object.

• ClickActions >Remove FromCategory to remove the object from the category only. This does
not remove it from BI platform.

• Click Manage > Delete to remove the object from the category and delete it from BI platform.

5.2.1.6 Specifying category rights

You can change the object rights for a category. While you can assign rights to a category as an object
(that is, grant groups and users rights to it), the objects within the category cannot inherit rights set on
the category itself. Objects within a category inherit their rights from the folders in which they are located.

For more information about rights, see the “Setting Rights” chapter in the SAP BusinessObjects Business
Intelligence Platform Administrator Guide available on the SAP Help Portal at http://help.sap.com.

5.2.1.7 To view the Personal Categories

If you are granted the appropriate rights, you can view, edit, and delete users' personal categories.
1. Go to the "Personal Categories" management area of the CMC.
2. Click the user account whose personal categories you want to view.

A list of the user's personal categories appears.
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5.2.1.8 To add multiple objects to a category

Perform this task to add multiple objects to a single category.
1. In the "Categories" or "Personal Categories" area, navigate to a category.
2. Click Actions > Add to Category.

The "Add to Category" dialog box appears.

3. In the Available Objects area, browse for the objects you want to add and click > to move them to
the Selected Objects list.

4. When you are finished, click OK.

The objects you selected appear in the category.
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Working with Content Objects

6.1 General object management

Many types of objects can exist in BI platform, for example:
• SAP Crystal Reports
• Web Intelligence documents
• Programs
• Microsoft Excel/Word/PowerPoint files
• PDFs
• RTF files
• Text files
• Hyperlinks
• Object packages
• Actions

After adding objects, you manage objects through the Central Management Console (CMC) by going
to the "Folders" management area

6.1.1 To copy an object

1. In the "Folders" area, browse for the object that you want to copy and select it.
2. Click Organize > Copy To.

The "Copy" dialog box appears.

3. In the Select destination(s) area, browse for the destination folder you want to copy the object to,
and click > to move it to the Destinations list.

Note:
In order to move the destination folder, you must select that folder in the details pane on the right.

Tip:
Use SHIFT + click or CTRL + click to select multiple folders.

4. When you are finished, click Copy.
The object you selected is copied to the destination.
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6.1.2 To move an object

1. In the "Folders" area, browse for the object you want to move and select it.
2. Click Organize > Move To.

The "Move" dialog box appears.

3. Select the destination folder.

Note:
In order to move the destination folder, you must select that folder in the details pane on the right.

Tip:
Use SHIFT + click or CTRL + click to select multiple folders.

4. Click Move.
The object moves from the origin folder to the destination folder.

6.1.3 To create an object shortcut

Shortcuts are useful for granting a user access to an object without giving that user access to the entire
folder in which the object is located. After you create the shortcut, users who have access to the folder
where the shortcut is located can access this object and its instances.
1. In the "Folders" area, browse for the object that you want to create a shortcut for and select it.
2. Click Organize > Create Shortcut In.

The "Create Shortcut In" dialog box appears.

3. In the "Select destination(s)" area, browse for the folder you want to create a shortcut in, and click
> to move the folder to the Destinations list.

Note:
In order to move the destination folder, you must select that folder in the details pane on the right.

4. Click Create Shortcut.
A shortcut to the object appears in the folder you specified.

6.1.4 To delete an object

2012-11-0634

Working with Content Objects



This procedure explains how to delete either a single object or multiple objects. You can also delete a
folder, which deletes all of the objects and instances that are stored in that folder. As well, you have
the option of deleting object instances, rather than the object itself.

Note:
When you delete an object, all of its existing instances and scheduled instances will be deleted.

1. Go to the "Folders" management area of the CMC.
2. Select the object that you want to delete.
3. Click Manage > Delete.
4. When you are prompted by a confirmation message, click OK.

Related Topics
• Managing instances

6.1.5 To search for an object or objects

This search feature lets you to search for specific text within object titles or descriptions.
1. Go to the "Folders" management area of CMC.

The Search field is located in the upper right-hand corner of the "Folders" management area. The
search type is set to Search title by default.

2. Specify the search criteria.
a. If you want to search by something other than the file name, click Search title to change the

search type.

Your options are:
• Search all fields

This option searches file names, keywords, and descriptions associated with objects.

• Search title

This option is the default option and searches file names.

• Search keyword

This option searches the keywords that are associated with objects.

• Search description

This option searches the descriptions that are associated with objects.

b. Enter the text that you want to search for in the Search field.

3. Click Search.
When the search is finished, a list of results that match your search criteria appears.
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6.1.6 To create a new hyperlink

1. In the "Folders" or "Personal Folders" area, navigate to the folder in which you want to create a new
hyperlink.

2. Click Manage > New > Hyperlink.
The "Hyperlink" dialog box appears.

3. Enter a title, description, and keywords for your hyperlink.
4. In the navigation pane, click URL.
5. In the URL field, enter the URL.
6. Click OK.

6.1.7 To send an object or an instance to a destination

You can useOrganize > Send to send existing objects or instances of an object to different destinations.
The Send command handles existing objects or instances only. It does not cause the system to run
the object and create new instances, nor does it refresh the data for a report instance.

You can send either a copy of an object or instance, or a shortcut to the object or instance. You can
also select the destination, for example, FTP or BI Inbox. Not all types of objects can be sent to all
destinations.
1. Go to the "Folders" management area of CMC.
2. Select the object or instance that you want to send.

• If you want to send an object, select it, click Organize > Send and choose a destination.
• If you want to send an instance, select the object and click Actions > History. In the "History"

dialog box, select an instance, click Send, and click the destination option that you want.

Select only instances with a status of Success or Failed. Instances with a status of Recurring or
Pending are scheduled and do not contain any data yet.
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DescriptionDestination option

Sends the object to a user's BI launch pad inbox.BI Inbox

Sends the object to a user's email address.Email

Sends the object to an FTP server location.FTP Location

Sends the object to a local disk location.File Location

Sends the object to an activity in SAP StreamWork.

Note:
StreamWork features and capabilities are available in the CMC if your admin-
istrator has configured and enabled the StreamWork Integration Configuration
application.

StreamWork

Note:
Send Web Intelligence documents to BI Inboxes only, or to an Email destination configured within
BI platform.

Tip:
Use SHIFT + click or CTRL + click to select multiple objects.

3. Configure your destination option.

You can choose to use the Adaptive Job Server's default settings or your own settings. If you use
your own settings, you can specify:
• The users and groups who receive the object (if sent to a BI Inbox or an Email destination). You

can send a blind copy to recipients who don't want to be visible to other recipients.
• Whether to send a copy of the object or a shortcut that links to the object.
• The name of the object that is sent.
• Whether to clean up instances after objects have been sent.
• The settings specific to the destination type (for example, a directory for the file location, or the

host name and connection port for the FTP server).

Note:
When sending objects to StreamWork, you can only use the Adaptive Job Server's default settings.

4. When you are finished, click Send.

Related Topics
• Available destinations by object type

6.1.7.1 Available destinations by object type
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Most destinations can be used for most types of objects, but there are some exceptions. In some cases,
recipients must have access to the system to be able to open the object.

Note:
To use a destination, you must have the destination enabled and configured on the Adaptive Job
Servers.

SAP
Stream-
Work

BI InboxEmail (SMTP)

FTPUnm.
Disk

Object
type

LinkFileLinkFile

YesYesYesYesYesYesYesCrystal re-
port

YesYesYes----Object
Package

YesYesYesYesYesYesYesProgram

YesYesYesYesYesYesYes
Web Intel-
ligence
document

-YesYesYes---

SAP Busi-
nessOb-
jects Anal-
ysis, edi-
tion for
OLAP
workspace

YesYesYesYesYesYesYesExcel file

YesYesYesYesYesYesYesWord file

YesYesYesYesYesYesYesPDF file

YesYesYesYesYesYesYesText file

YesYesYesYesYesYesYesRTF file
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SAP
Stream-
Work

BI InboxEmail (SMTP)

FTPUnm.
Disk

Object
type

LinkFileLinkFile

YesYesYesYesYesYesYesPower-
Point file

-YesYesYes---Hyperlink

Related Topics
• To enable or disable destinations for a job server

6.1.8 To change the properties of an object

1. In the "Folders" management area of CMC, select an object.
2. Click Manage > Properties.

The "Properties" dialog box appears.

3. Make your changes.
You can change the object name, keywords, and description.

4. When you are finished, click Save & Close.

6.1.9 Relationships

In BI platform, objects are related to one another in several ways. Folders are related to their children,
connections are related to the universes that use them, and reports and documents are related to
universes.

The interrelation of objects in the BI platform can make it difficult to change an object because doing
so may break links to the object. You can find out which objects are directly related by performing a
relationship query.

Consider a company where a database is being replaced by a new database in a different location.
The administrator must find out which objects depend on the current connection so that these objects
can be edited accordingly. Then, the database connection can be deleted without causing a disruption
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to the content of any objects. The administrator runs a relationship query on the connection, which
returns a list of universes that use the connection. All the universes can then be updated.

However, the company has instead decided to delete all the objects that depend on that connection.
The administrator can run more relationship queries on all of the universes that were returned by the
first query. All objects that use those universes are returned.

Relationship queries can be performed in the following areas of the CMC:
• "Folders"
• "Personal Folders"
• "Categories"
• "Personal Categories"
• "Users and Groups"
• "Profiles"
• "Universes"
• " Access Levels"
• "Servers"
• "Replication Lists"

After you perform the relationship query, you arrive at the "Query Results" area, where the results of
your query are displayed. From the "Query Results" area, you can perform basic object management
tasks on result objects.

6.1.9.1 To check the relationships of an object

1. Navigate to the object for which you would like to run the relationship query.
2. Click Manage > Tools > Check Relationships.

The "Query Results" area with the results of your relationship query is displayed.

Tip:
As required, perform further checks on the relations of result objects by selecting an object and
choosing Manage > Tools > Check Relationships.

3. To navigate back to your original query, select the name of the object from the Tree panel.

6.2 Report object management

Managing report objects includes applying processing extensions, specifying alert notification, changing
database information, updating parameters, using filters, and working with hyperlinked reports. This
section explains report objects and instances and how to manage them through the Central Management
Console (CMC).
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Note:
Most information in this section also applies to Web Intelligence document objects. Any exceptions
have been identified.

6.2.1 What are report objects and instances?

A report object is an object that is created using SAP Crystal Reports. A Web Intelligence document
object is created using BI platform. Both types of objects contain report information (such as database
fields). Both types of objects can also contain saved data.

A report object or a Web Intelligence document object can be made available to everyone or to individuals
in selected user groups.

Scheduled instances
When you schedule an object, the system creates a scheduled instance for the object. A scheduled
instance contains object and schedule information. It does not contain any data yet. Scheduled instances
appear in the History for the respective object and have a status of Recurring or Pending.

You can schedule objects from the CMC, from BI launch pad, or by using a custom web application.

Typically, report objects are designed such that you can create several instances with varying
characteristics. For example, if you run a report object with parameters, you can schedule one instance
that contains report data that is specific to one department and schedule another instance that contains
information that is specific to another department, even though both instances originate from the same
report object.

Object instances
At the specified time, the system runs the object and creates an object instance. The instance contains
actual data from the database. It appears in the History for the object and has a status of Success or
Failed.

Changing default settings for an object
Any changes you make to an object affect the default settings for the object only. Those changes do
not affect any existing scheduled instances or object instances. The next time you schedule the object,
whether you use CMC or an application such as BI launch pad , the new default settings are displayed.
You can then change these settings as needed for the scheduled instance you want to create.

Note:
BI platform supports reports created in versions 6 through 2011 of SAP Crystal Reports. Once added
to the BI platform, reports are saved, processed, and displayed in version 2011 format. However, reports
created in the BI platform remain in “SAP Crystal Reports for Enterprise” format.

Related Topics
• Scheduling
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6.2.2 Setting report refresh options

Note:
This feature applies to SAP Crystal Reports only.

You can set report refresh options that determine which settings of a report object are updated when
you refresh it in BI platform.

When you refresh a report object, BI platform compares the report object stored in the CMC with the
original .rpt file stored in the Input File Repository Server. BI platform deletes or adds report elements
in the report object to make it match the .rpt file, overwriting any changes you've made in the CMC.
Where report elements are the same in the source report and the report object, the report refresh
settings allow you to control which settings in the report object are updated with values from the source
.rpt file.

For example, if a prompt appears only in the source .rpt file, then refreshing the report adds the prompt
to the report object. This holds true no matter which report refresh options you select.

If a prompt appears in both the source .rpt and the report object and you have selected the Current
and default parameter values option, then BI platform updates the default value of the prompt in the
report object. Any changes that you have made to the default value of the parameter in BI platform are
overwritten.

To preserve your changes to the values of report elements when you refresh a report, clear the
appropriate report refresh option. If you clear Current and default parameter values, BI platform
preserves the current or default values of prompts in the report object when the report is refreshed. If
you clear Use Object Repository when refreshing report, repository objects in the report object will
not be refreshed against the repository.

6.2.2.1 To set refresh options for a report

1. In CMC, go to "Folders" management and select a report.
2. Click Actions > Refresh Options.

The "Refresh Options" dialog box appears.

3. Choose report elements to refresh from the source report file.
4. Click Update.

Tip:
Alternatively, click Refresh report to immediately refresh the report according to your specifications.
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6.2.3 Setting report viewing options

Note:
This feature does not apply to Web Intelligence documents.

The report viewing options available in BI platform allow you to balance the need for up-to-date
information with the need to optimize data retrieval times and overall system performance.

BI platform allows you to enable data sharing, which permits different users accessing the same report
object to use the same data when viewing or refreshing a report. Enabling data sharing reduces the
number of database calls, thereby reducing the time needed to generate a report instance for subsequent
users of the same report, while greatly improving overall system performance under load.

You can control data sharing settings on either a per-report or a per-server basis:
• If you specify which servers a report uses for viewing, you can use per-server settings to standardize

data sharing settings for groups of reports, and centrally administer these settings.

• Per-report settings permit you to specify that particular reports will not share data. They also allow
you to tailor the data sharing interval for each report to meet the needs of that report's users. In
addition, per-report settings enable you to decide on a report-by-report basis whether it is appropriate
to allow users to access the database whenever they refresh reports.

Data sharing may not be ideal for all organizations, or for all reports. To get full value from data sharing,
you must permit data to be reused for some period of time. This means that some users may see “old”
data when they view a report on demand, or refresh a report instance that they are viewing.

The default report viewing options for BI platform emphasize data freshness and integrity. By default,
when you add a report to the BI platform, it is configured to use per-server settings for report sharing.
The default server settings ensure that users always receive up-to-date information when they refresh
a report, and guarantee that the oldest data given to any user is 0 minutes old. If you choose to enable
per-report settings, the default settings allow data sharing, allow a viewer refresh to retrieve fresh data
from the database, and ensure that the oldest data given to a client is 5 minutes old.

Tip:
Disabling the sharing of report data between clients is not the same as setting Oldest on-demand data
given to a client to 0 minutes. Under high load, your system may receive more than one request for
the same report instance at the same time. In this case, if the data sharing interval is set to 0 but the
Share report data between clients option is enabled, BI platform shares data between the client
requests. If it is important that data not be shared between different clients (for example, because the
report uses a User Function Library (UFL) that is personalized for each user), disable data sharing for
that report.

6.2.3.1 To set report viewing options for a report
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1. In the "Folders" management area of CMC, select a report.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Viewing Server Group on the navigation list.
4. In the "Data refresh for viewing" area, click Use report specific viewing settings, and then select

the options that you want to set for this report.
5. Click Save & Close.

6.2.4 Specifying default servers

You can specify the default servers that BI platform uses to run an object, and to schedule and process
instances. For report objects and Web Intelligence documents, you can specify the default servers that
the BI platform will use when a user views or modifies a report or a Web Intelligence document.

When specifying your servers, you have three options:
• Use the first available server

The BI platform will use the server that currently has the most available resources.

• Give preference to servers belonging to the selected group (and, if the servers from that group
are not available, use any available server).

Select a server group from the list. This option will attempt to process the object on the servers that
are found within your server group. If the specified servers are not available, then the object will be
processed on the next available server.

• Only use servers belonging to the selected group

This option ensures that BI platforom will use only the specified servers that are found within the
selected server group. If all of the servers in the server group are unavailable, then the object will
not be processed.

Depending on the type of object, BI platform uses the following servers to process objects when you
view them:
• SAP Crystal Reports run on the Adaptive Job Server; Crystal Reports 2011 or Crystal Reports

Processing Server (depending on the designer in which the report was created); and Crystal Reports
Cache Server.

• Web Intelligence documents run on the Web Intelligence Processing Server.

By selecting a particular server or server group, you can balance the load on your system by processing
specific objects on specific job servers. Before you select a server group, however, your system
administrator must first create server groups by using the "Servers" management area in the CMC.
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Note:

• If you choose the Use the first available server option, the Central Management Server (CMS)
will check the job servers to see which one has the lowest load. The CMS does this by checking the
percentage of the maximum load on each job server. If all of the job servers have the same load
percentage, then the CMS will randomly pick a job server.

• You can also set the maximum number of jobs that a server will accept. For more information, see
the SAP BusinessObjects Business Intelligence Platform Administrator Guide.

6.2.4.1 To specify default servers for processing an object

1. In the "Folders" management area of CMC, select an object.
2. Click Manage > Default Settings.
3. In the "Default Settings" dialog box, perform one of the following actions:

• To specify the default servers for scheduling a report object, use Manage > Default Settings >
Scheduling Server Group.

• To specify the default servers for processing an object when you view it, select Viewing Server
Group if the object is a Crystal report or Web Intelligence Process Settings if the object is a
Web Intelligence document.

4. Click Save & Close.

Related Topics
• Specifying default servers

6.2.5 To change the database settings

Note:

• This feature does not apply to Web Intelligence documents.
• If you selected multiple report objects for which you want to change database settings, only those

report objects that have the same data source connection will be updated.

You can select your database type and set the default database logon information by using Manage >
Default Settings. In the "Default Settings" dialog box, you can view the data source or data sources
for your report object and its instances. You can also choose to prompt the user for a logon name and
password when he or she views a report instance.
1. In the "Folders" management area of CMC, select a report object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.
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3. Click Database Configuration on the navigation list.
4. SelectUse original database logon information from the report orUse custom database logon

information specified here.

If you select the first option, you can specify a user name and password to be used with the original
report database.

If you select the second option, you can specify a server name (or a DSN in the case of an ODBC
data source), a database name, a user name, and a password for a number of predefined database
drivers, or for a custom database driver that you've specified. If you've changed the default table
prefix in your database, specify a custom table prefix here.

For information about supported databases and drivers, refer to the Supported Platforms documents
on the SAP Service Marketplace.

5. Select the database logon option you want.
• Prompt the user for database logon

The system will prompt users for a password when they refresh a report.

Note:
This option has no effect on a scheduled instance. Also, BI platform only prompts users when
they first refresh a report; that is, if they refresh the report a second time, they will not be prompted.

• Use SSO context for database logon

The system will use the user's security context, that is, the user's logon and password, to log on
to the database.

Note:
For this option to work, you must have your system configured for end-to-end single sign-on, or
for single sign-on to the database. For more information, see the SAP BusinessObjects Business
Intelligence Platform Web Application Deployment Guide.

• Use same database logon as when report is run

The system will use the same database logon information as was used when the report was run
on the job server.

• Use user database credentials for database logon

The system will use the database credentials that are specified for the user account.

6. Click Save & Close.

6.2.6 To update default prompt values for a Crystal report

Note:
This feature does not apply to Web Intelligence documents.
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Parameter fields (with preset values) enable users to view and to specify the data that they want to
see. If a report contains parameters, you can set the default value for each field or fields (which is used
whenever a report instance is generated). Through a BI platform application such as BI launch pad,
your users are either able to use the report with the preset default value(s) or choose another value or
values. If you do not specify a default value, users will be prompted for a value when they schedule the
report.
1. In the "Folders" management area of the CMC, select a report object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Prompts on the navigation list.

Note:
Prompts is available only if the report object contains parameters.

4. Under the "Default Value" column, click the value associated with the parameter you want to change.

Options appear that allow you to change the default value. Depending on the parameter value type,
you either type a value in the field or choose a value from a list.

5. Click the Clear Value button if you want to clear the current value that is set for the specified
parameter.

6. Select the Prompt when viewing check box if you want your users to be prompted when they view
a report instance through a BI platform application such as BI launch pad.

7. Click Save & Close.

6.2.7 To update the prompts for a Web Intelligence document

Note:
This feature does not apply to Crystal reports. See To update default prompt values for a Crystal report
instead.

Prompt fields (with preset values) enable users to view and to specify the data that they want to see.
If a report contains parameters, you can set the default prompt value for each field or fields (which is
used whenever a report instance is generated). Through an application in BI platform such as the BI
launch pad, your users can either use the report with the preset default value(s) or choose another
value(s). If you do not specify a default value, users will have to choose a value when they schedule
the report.
1. In the "Folders" management area of the CMC, select a Web Intelligence document.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Prompts on the navigation list.

Note:
Prompts is available only if the Web Intelligence document object contains prompts.
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4. Click Modify.
Options appear that let you select a prompt and values.

5. Select the prompt and enter a value for the prompt.

Tip:
If the available values are not displayed, click the Refresh Values button.

6. Repeat steps 5 and 6 for every prompt value you want to change.
7. Click Apply.
8. Click Save & Close.

6.2.8 To use filters

Note:
This feature does not apply to Web Intelligence documents, SAP Crystal reports in RPTR format, or
reports created in SAP Crystal Reports.

You can set the default selection formulas for the report by using Manage > Default Settings. Selection
formulas are similar to parameter fields in that they are used to filter results so that only the required
information is displayed. Unlike parameters, end users will not be prompted for selection formula values
when they view or refresh the report. When users schedule reports through a web-based client such
as BI launch pad, they can choose to modify the selection formulas for the reports. By default, if any
formulas are set in the CMC, they will be used by the web-based client. For more information on selection
formulas, see the SAP Crystal Reports User Guide.

In addition to changing selection formulas, if you have developed your own processing extensions, you
can select the processing extensions that you want to apply to your report.

When you use filters in conjunction with processing extensions, a subset of the processed data is
returned. Selection formulas and processing extensions act as filters for the report.
1. In the "Folders" management area of the CMC, select a report object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Filters.
4. Update or add new selection formulas.

• Record selection

Use the Record selection field to create or edit a record selection formula or formulas that limit
the records used when you or a user schedules a report.

• Group selection

Use the Group selection field to create or edit a group selection formula or formulas that limit
the groups used when you or a user schedules a report.

5. Click Save & Close.
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Related Topics
• How profiles work
• Applying processing extensions to reports

6.2.9 Setting printer and page layout options

Note:
This feature does not apply to Web Intelligence documents.

You can choose to print a report instance when scheduling it; report instances are always printed in
Crystal reports format. When printing a report, you can set the number of copies and the page range.

You can specify whether or not a report instance is printed, and if printed, the printer to use, the number
of copies, and the page range. You can also specify the custom layout settings for changing the page
size and orientation (regardless of whether the report instance is printed or not).

Specifying a printer
You can choose to print a report (each time it runs) using the Crystal Reports Job Server's default
printer or a different printer. BI platform prints your report after it is processed.

Note:
The Crystal Reports Job Server must run under an account that has sufficient privileges to access the
printer you specify. See the “Managing and Configuring Servers” chapter for more information.

Specifying page layout
When viewing or scheduling a report instance to any format, you can specify page layout criteria such
as page orientation, page size, and so on. The settings you choose affect how you'll see a report
instance when displaying it.

Note:
Page layout settings are not specifically related only to scheduling a report to a printer, but also to the
overall look of the report. The overall look is affected by the properties of the device for which the report
is displayed in (that is, the font metrics and other layout settings of the display and/or the printer).

6.2.9.1 To assign a printer

1. In the "Folders" management area of CMC, select a report object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Print Settings on the navigation list.
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4. Select Print Crystal reports when scheduling.

The report is automatically sent to the printer in SAP Crystal Reports format. This does not interfere
with the format selected when scheduling the report.

5. Leave Default printer selected if you want to print to the Job Server's default printer; otherwise,
select Specify a printer.

6. If you selected Specify the printer, enter a printer's path and name.

If your job server is using Windows, in the Specify the printer field, type:

\\printserver\printername

Where printserver is the name of your printer server, and printername is the name of your
printer.

If your job server is running on UNIX, in the Specify the printer field, type the print command that
you normally use. For instance, type:
lp -d printername

Note:
Ensure that the printer you are using (on UNIX) is “shown” and not “hidden”.

7. Set the rest of your print options:
• Number of copies
• Page range
• Collate option
• Page scaling
• Center the page
• Fit horizontal pages into one page

8. Click Save & Close.

6.2.9.2 To set a report's print layout options

1. In the "Folders" management area of CMC, select a report object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Print Settings on the navigation list.
4. Select a default print mode.

• Always print to PDF

This option uses PDF print mode settings when you print the report from a web viewer.

• Follow Crystal Reports preference setting

This option uses settings for Crystal reports defined in CMC user preferences.
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5. On the "Set layout to" list, change your settings for the layout you want.
The options are as follows:
• Report file default

Choose this option if you want the page layout to conform to the settings that were chosen for
the report in SAP Crystal Reports.

• Specify printer settings

Choose this option if you want the page layout to conform to the settings of a specified printer.
You can choose the Job Server's default printer or another printer.

When you choose this option, you can print scheduled report instances only to the printer you
specify in the Print when scheduling area. In other words, you cannot set your report to display
with one printer's setting and then print to a different printer.

• Custom settings

Choose this option if you want to customize all page layout settings. You can then choose page
orientation and page size.

6. Click Save & Close.

Related Topics
• Setting printer and page layout options

6.2.10 Processing extensions

BI platform offers you the ability to further secure your reporting environment through the use of
customized processing extensions. A processing extension is a dynamically loaded library of code that
applies business logic to particular BI platform view or schedule requests before they are processed
by the system.

Note:
On Windows systems, dynamically loaded libraries are referred to as dynamic-link libraries (.dll file
extension). On Unix systems, dynamically loaded libraries are often referred to as shared libraries (.so
file extension). You must include the file extension when you name your processing extensions.

Through its support for processing extensions, the BI platform administration SDK essentially exposes
a “handle” that allows developers to intercept the request. Developers can then append selection
formulas to the request before the report is processed.

A typical example is a report-processing extension that enforces row-level security. This type of security
restricts data access by row within one or more database tables. The developer writes a dynamically
loaded library that intercepts view or schedule requests for a report (before the requests are processed
by the Adaptive Job Server, Crystal Reports Processing Server, or Report Application Server). The
developer's code first determines the user who owns the processing job; then it looks up the user's
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data-access privileges in a third-party system. The code then generates and appends a record selection
formula to the report in order to limit the data returned from the database. In this case, the processing
extension serves as a way to incorporate customized row-level security into the BI platform environment.

Tip:
In BI platform, you can also set and enforce row-level security through the use of Business Views. For
more information, see the Business Views Administrator's Guide.

The CMC provides methods for registering your processing extensions with BI platform and for applying
processing extensions to particular object.

By enabling processing extensions, you configure the appropriate BI platform server components to
dynamically load your processing extensions at runtime. Included in the SDK is a fully documented API
that developers can use to write processing extensions. For more information, see the developer
documentation available on your product CD.

In the current release, processing extensions can be applied only to Crystal report (.rpt) objects.

Related Topics
• Applying processing extensions to reports

6.2.10.1 Applying processing extensions to reports

Note:
This feature does not apply to Web Intelligence documents or reports created in SAP Crystal Reports.

BI platform supports the use of customized processing extensions. A processing extension is a
dynamically loaded library of code that applies your business logic to particular BI platform view or
schedule requests before they are processed by the system. This section shows how to register your
processing extension with the BI platform and how to apply an available processing extension to a
report object.

Note:
On Windows systems, dynamically loaded libraries are referred to as dynamic-link libraries (.dll file
extension). On Unix systems, dynamically loaded libraries are often referred to as shared libraries (.so
file extension). You must include the file extension when naming processing extensions. File names
cannot include the front (/) or back (\) slash characters.

6.2.10.1.1 To select a processing extension for a report

You must register a processing extension in the CMC before you can select it.

Note:
This feature does not apply to Web Intelligence documents or reports created in SAP Crystal Reports.

1. Go to the "Folders" management area of CMC.
2. Select the report object that you want to apply your processing extension to.
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3. On the Manage menu, click Default Settings.
The "Default Settings" dialog box appears.

4. Click Extensions on the navigation list.
5. Select your processing extension from the Available processing extensions list, and click > to

move it to the Use these processing extensions (in the order listed) list.

Note:
Your processing extensions appear in this list only after you have registered them with the system.

Tip:
You may apply more than one processing extension to a report object. Repeat this step for each
processing extension; then use the Move Up and Move Down buttons to specify the order in which
the processing extensions should be used.

6. Click Save & Close.
The processing extension is enabled for this report object.

6.2.11 Working with hyperlinked reports

Note:
This feature does not apply to Web Intelligence documents or reports created in SAP Crystal Reports
for Enterprise.

SAP Crystal Reports lets you use hyperlinks to navigate from one report object to another. You can
move to a Report Part within the report itself, to other report objects or their parts, or to specific instances
of reports or Report Parts. This navigation is available only in script-based DHTML viewers (zero-client,
server-side viewers) included in BI platform and above. By linking directly from one object to another,
the required data context is passed automatically so that you navigate to the object and data that is
relevant.

Initially, when you add hyperlinks between reports in SAP Crystal Reports, you create a link from one
file directly to another. However, when you add linked report files simultaneously to the same object
package, the links are modified to point to managed report objects. (Each link is changed, so that it
references the appropriate destination report by Enterprise ID, rather than by file path.) Also, the modified
links become relative inside the object package. When you schedule the object package, BI platform
processes its reports, and again modifies hyperlinks within each report instance: hyperlinks between
report objects in an object package are converted to hyperlinks between report instances in a specific
instance of the object package.

To view hyperlinked reports, you must add both the home and destination reports to BI platform. (A
home report is one that contains a hyperlink to another report: the destination report.)

Note:
For information about how to create hyperlinks between report objects, see the SAP Crystal Reports
Online Help.
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Related Topics
• Scheduling objects using object packages

6.2.11.1 Adding reports with existing hyperlinks

The recommended method for creating hyperlinked reports is first to publish the individual reports, then
create hyperlinks between them. However, this is not always possible.

To add hyperlinked reports to the repository, use the Report Upload Wizard that comes with SAP Crystal
Reports 2011 designer and add the linked reports to the same object package. When you publish
reports this way, the hyperlinks are converted to relative links.

Note:

• This feature does not apply to Web Intelligence documents.
• If you add hyperlinked reports independently of each other, rather than adding them simultaneously

to the same object package, all hyperlinks between the reports will break. You must re-establish the
links using SAP Crystal Reports and save the report back to BI platform. (For more information, see
the SAP Crystal Reports Online Help.)

Related Topics
• To add reports to the repository and then hyperlink them

6.2.11.2 Viewing hyperlinked reports

Note:
This feature does not apply to Web Intelligence documents or reports created in SAP Crystal Reports
for Enterprise.

SAP BusinessObjects Business Intelligence platform only supports navigation between hyperlinked
reports if you use script-based viewers, specifically the DHTML and Advanced DHTML viewers in BI
launch pad. To change your preferred viewing format in the CMC, click the Preferences link in the
upper-right corner of the CMC, and select the appropriate viewing format. For information on how to
change your preferred viewing format, see the BI launch pad User's Guide.

Parameter information is not carried over between the home and destination reports. That is, when you
view a destination report by clicking a hyperlink in a home report, you are prompted to enter any
parameters that the destination report requires.
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Security considerations
To view hyperlinked reports through BI platform, you must have the appropriate rights both in the
platform and at the database level.

In BI platform, to view a destination report through a hyperlink in a home report, you must have View
rights to the destination report. When the hyperlink points to a report object, you must have View On
Demand rights to be able to refresh the data against the data source.

Database logon information is carried over between hyperlinked reports. If the credentials you specified
to view the home report are not valid for the destination report, you are prompted for a valid set of
database logon credentials for the destination report.

6.2.11.3 To add reports to the repository and then hyperlink them

Note:
This feature does not apply to Web Intelligence documents or reports created in SAP Crystal Reports
for Enterprise.

To avoid breaking hyperlinks between reports, it is best to add the reports first and then to create the
hyperlinks.
1. Create the reports, without hyperlinks, in SAP Crystal Reports.
2. Add them to BI platform.
3. Use SAP Crystal Reports to log on to BI platform.
4. Create the hyperlinks between the home and destination reports.

For more information, see the Crystal Reports Online Help.

SAP Crystal Reports automatically determines what type of link—relative or absolute—to establish
between the reports. In BI platform, relative links are those between reports in the same object package,
and absolute links are links to specific report objects or instances.

6.2.12 To show a thumbnail image of a Crystal report

Perform this task if you want to show a thumbnail image of the report's first page.
1. In the "Folders" management area of CMC, navigate to the report and select it.
2. Click Manage > Default Settings.
3. Click Thumbnail on the navigation list.
4. Select the Show report thumbnail check box.
5. Click Save & Close.

2012-11-0655

Working with Content Objects



6.2.13 To view alerts in Crystal reports

BI platform tracks report instances that trigger alerts.

This task applies only to reports created in SAP Crystal Reports.
1. Locate the folder or category that contains the Crystal report you want to view.
2. Select an object, and click More Actions > Alerts.

The "Alerts" dialog box appears, displaying the instances that triggered an alert.

3. Double-click the title to open the report instance.

6.2.14 To view the universes for a Web Intelligence document

You build queries for Web Intelligence documents using objects in a universe. A universe is a
representation of the information available in the database. In CMC, you can view which universes are
used by a Web Intelligence document.
1. In the "Folders" management area of CMC, select a Web Intelligence document object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Report Universes on the navigation list.

A list of the universes that are used by the document appears.

6.3 Working with reports in an integrated environment

This section contains information about working with reports in SAP NetWeaver Business Warehouse
(SAP NetWeaver BW) and BI platform.

Note:
This section does not apply to reports created in SAP Crystal Reports for Enterprise.

6.3.1 Adding reports from NetWeaver BW to BusinessObjects Enterprise
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There are two standard ways to add reports to the BI platform:
• Add the reports that you create off SAP NetWeaver BW queries to BI platform immediately after the

reports are created.

• In batches, add the reports from SAP NetWeaver BW to BI platform.

If you have SAP Crystal Reports installed on your machine, you can design your own report based on
an SAP NetWeaver BW query. You can then simultaneously save the report to SAP NetWeaver BW
and add it to BI platform from within SAP Crystal Reports. To enable this feature, in SAP Crystal Reports,
select SAP > Settings and select Automatically publish to SAP BusinessObjects Enterprise.

Note:
You can add large numbers of Crystal reports using Content Administration Workbench. For more
information, see the SAP BusinessObjects Business Intelligence Platform Administrator Guide.

6.3.1.1 Adding reports to BI platform

There are two methods to add Crystal reports to BI platform:
• Add them to BI platform in batches. Use this method if you have already added a number of reports

to SAP NetWeaver BW.

• Use the Report Upload Wizard that comes with SAP Crystal Reports 2011 or with the Central
Management Console in BI platform.

Related Topics
• Adding reports in batches from NetWeaver BW

6.3.1.2 Adding reports in batches from NetWeaver BW

You can add large numbers of Crystal reports using Content Administration Workbench. For more
information, see the SAP BusinessObjects Business Intelligence Platform Administrator Guide.

6.3.2 Migrating development content to a production SAP NetWeaver BW system
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If you have deployed BI platform in your development SAP NetWeaver BW environment, you can import
report content to the BI platform that is configured for use with your production SAP NetWeaver BW
environment.

Before importing your content, consider the following:
• SAP NetWeaver BW treats Crystal reports (.rpt files) as native objects. If the Crystal reports are

stored in the repository of your development SAP NetWeaver BW system, you can transport the
SAP NetWeaver BW content and then add the reports in batches to BI platform. (For details about
transporting content between SAP NetWeaver BW systems, see the SAP Library.) This procedure
ensures that the database information for each report is updated by the SAP NetWeaver BW Report
Publisher.

• If you have deleted some or all of the Crystal reports from the repository of your development SAP
NetWeaver BW system, you can use the Life Cycle Manager to import the report objects from one
BI platform installation to another. When using the Life Cycle Manager, be sure to set the correct
database information on each of the report files that you import.

• If the number of report files that you want to migrate is small, you may find it easier to change each
report's database information in the CMC. (Go to the "Folders" management area, locate the report,
and click Actions > Database Configuration.)

After you migrate your content, use the Content Administration Workbench to perform maintenance on
your reports. Report maintenance tasks include synchronizing information about reports between BI
platform and SAP NetWeaver BW (Update status), deleting unwanted reports (Delete reports), and
updating reports migrated from previous versions of BI platform (post-migration).

6.3.3 Viewing reports

You can view Crystal reports through a number of applications depending on how BI platform has been
integrated with SAP NetWeaver BW.
• Log on to BI launch pad using your SAP credentials
• Launch reports in a web browser within the "SAP Easy Access" interface

6.3.3.1 To view a report in BI launch pad

1. In a web browser, type the URL for BI launch pad: http://webserver:portnumber/BOE/BI

Replace webserver with the name of the web server and portnumber with the port number for
BI platform. You may need to ask your administrator for the name of the web server, the port number,
or the URL to enter.
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Tip:
If you have BI platform installed, you can select Start > Programs > SAP Business Intelligence
> SAP BusinessObjects BI platform 4 > SAP BusinessObjects Enterprise Java BI launch pad.

The "Log On to BI launch pad" dialog box appears.

2. In the Authentication list, select SAP.
3. In the SAP System ID box, type the three-character System ID (SID) for your SAP system.

Contact your administrator if you are unsure of the appropriate SID.

4. In the SAP Client box, type your three-digit SAP client number.
5. In the User Name and Password boxes, type your usual SAP logon credentials.
6. Click Log On.

You are logged on to BI launch pad.

7. Click the My Groups folder for quick access to all objects that have been saved in your various SAP
roles and published to BI platform.

Tip:
For more information about using BI launch pad, click Help to access the BI Launch Pad Help.

6.3.3.2 To view a published report through SAP Easy Access

1. Log on to SAP Easy Access.
2. Browse your roles to locate the reports that have been saved to SAP NetWeaver BW.

Tip:

Look for the Crystal report icon that is used in SAP NetWeaver BW.

3. Double-click the report.

The report is displayed in your web browser. You may be prompted to log on to the SAP Web Application
Server and/or BI platform. If so, provide your usual credentials.

6.3.4 Personalizing reports generated from SAP NetWeaver BW queries

BI platform supports personalized variables in reports generated from SAP NetWeaver BW queries.

Reports based off SAP NetWeaver BW queries potentially make use of variables which contain values
that BW queries use to limit or specify returned data. Typically, you can enter the value to run the report
with or choose from a list of predefined values.
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In SAP Business Explorer (BEx), personalization lets you enter a value for the variable and save it as
your personal default value. When the report is run, the data generated is based on the variable value
of your choice. Whenever you run the same report, your saved personalized values are available for
you to use.

Note:
Personalized values are user-specific: you can only set personalized values for yourself and not for
other users. Each user can set his or her own personalized values as an alternative to using preset
values that are given to the variable.

For more information about personalization, see the documentation for your SAP NetWeaver BW system
or contact your system administrator.

6.3.4.1 Parameters

Variables within reports are represented as parameters in BI launch pad. Before viewing or scheduling
a report, choose a value from a dynamic picklist for each parameter. The picklist values were assigned
to the variable in the SAP environment and filtered based on your user rights in SAP.

From the "Enter Prompt Values" dialog box, you have the following options:
• Run the report with its default parameter values.

• Select values from the dynamic picklists and run the report with your chosen parameter values.

• Enter a value for each parameter and run the report with those values.

• Run the report with null values for the parameters.

• Personalize a value for each parameter and run the report with those personalized values.

Note:
Some options are available only if they are enabled in the report's referenced SAP NetWeaver BW
query or in BI platform.

6.3.4.1.1 To view a report with default parameter values

The default value for a report parameter is set in the SAP environment (while the query is being
designed). Because the report in BI platform is based off a SAP NetWeaver BW query, the default value
for the query variable automatically becomes the default value for the report parameter.
1. Log on to BI launch pad.
2. Double-click the object you want to view.

The "Enter Prompt Values" dialog box appears.

3. Click OK.
The report appears in your Crystal report viewer. It contains only data that is based on the default
values that were assigned to the parameter.
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Related Topics
• Personalized parameter values in scheduled reports

6.3.4.1.2 To view a report using parameter values from a dynamic picklist

The items that populate a dynamic picklist for a parameter are based on the values that were assigned
to the variable in the SAP environment. The values that are displayed on BI launch pad correspond to
your user rights; you see only the values for which you have the rights to report.

Note:
This option is only available for SAP NetWeaver BW Query based parameters.

1. Log on to BI launch pad.
2. Navigate to the object that contains variables and double-click it.

The" Enter Prompt Values" dialog box appears.

3. Beside a parameter, click the “…” button.

The Picklist screen appears.

4. Search the list for the value you want for the parameter; when you find it, click its hyperlink.
You return to the "Enter Prompt Values" dialog box. The value that you selected appears in the edit
field for the parameter.

5. Repeat Steps 3 and 4 for other parameters, and then click Execute.

The report appears in your Crystal report viewer showing data based on the parameter values you
selected.

6.3.4.1.3 Null parameter values in scheduled reports

When you schedule a report to run with null as a parameter value, no value is passed to the query when
the report is executed. The report uses the preset default or a personalized value of the variable that
you define.

Note:
Personalized values override default values.

If you change the parameter value used to run the report, you simply click the report in BI platform and
reschedule it with your new parameter. Because the report was initially scheduled to run with a null
parameter value, no value is saved with the report.

The next time you run the report, the new parameter value is used to generate the data.

To view a report with null parameter values

When you run a report with null parameter values, upon execution, no values are passed to the query;
the values that are used to run the report are either the preset default values or the preset personalized
values of the variables. (Personalized values override default values.) If a variable has neither a default
value nor a personalized value, then the report will attempt to run without a value for the variable.
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Depending on your query, you may receive an error if a value for the variable is necessary for the report
to run.

Note:

• This feature is primarily used when scheduling reports.
• This option is only available for SAP NetWeaver BW query-based parameters.
1. Log on to BI launch pad.
2. Navigate to the object that contains variables and double-click it.

The "Enter Prompt Values" dialog box appears.

3. Ensure that Set to null for each parameter.
4. Click OK.

The report appears in your Crystal report viewer. It contains only data that is based on the
default/personalized value that was originally assigned to the variables in SAP.

6.3.4.1.4 Personalized parameter values in scheduled reports

When you set a recurring schedule for a report containing a personalized parameter value, BI platform
uses the personalized value to generate the report every time it is scheduled to run.

Note:
After personalizing a value, BI platform saves the value and sets it as the permanent user-specific
parameter value for the report. Even if you change the personalized value of a parameter, the scheduled
report will still continue to display data based on the original personalized value.

If you change the personalized value of the parameter, follow these steps to ensure your report schedule
doesn't use the original value:
• Reschedule your report with the new parameter value.

• Schedule the report to run with null values for the parameter. This ensures that personalization
values are evaluated when the report runs.

To view a report with personalized parameter values

Personalization is a feature that enables you to set your own default value for a parameter and save it
for future use. When you set a personalized value for a parameter, the personalized value effectively
becomes your new default value for the parameter.

Note:

• This option is only available for SAP NetWeaver BW query-based parameters and only applies to
reports that are based on SAP NetWeaver MDX driver.

• Personalized values are user-specific: the personalized values that users set for themselves are
not implemented for other users. Other users who work with the same report can set their own
personalized values or use any of the preset values that are given for the parameter.

1. Log on to BI launch pad.
2. Navigate to the object that contains variables and double-click it.
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The" Enter Prompt Values" dialog box appears. The default values for the report parameters are
each listed beside “Current value.”

3. Personalize a value for a parameter by doing one of the following:
• Select a value from the list and click the Personalize icon to set it as your personalized

value.
• Click the parameter's edit field, type a value, and then click the Personalize icon to set it as your

personalized value.

You can then view the report with data that is based on the personalized value of your choice. If, in the
future, you decide to view the same report, the personalized value is used to run the report, unless
otherwise specified.

For more information about personalization, see the documentation for your SAP NetWeaver BW system
or contact your system administrator.

6.4 Program object management

This section explains program objects and instances, how to manage them through the Central
Management Console (CMC) and covers type-specific program object configuration, and security
considerations for program objects.

6.4.1 What are program objects and instances?

A program object is an object in BI platform that represents an application. Adding a program object
allows you to schedule and run the program object and to manage user rights in relation to the program
object.

When you add a program object or its associated files to BI platform, the object or files are stored in
the Input File Repository Server (FRS). Each time a program runs, the program and files are passed
to the Program Job Server, and BI platform creates a program instance. Unlike report instances, which
you can view in their completed format, program instances exist as records in the object history. BI
platform stores the program's standard output and standard error in a text output file. This file appears
when you click a program instance in the object History.

To successfully schedule and run a program object, you must provide logon information for the account
that the program object will use when it runs.

Related Topics
• Adding objects to BI platform
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6.4.1.1 Program types

Three types of applications can be added to the repository as program objects:
• Executable

Executable programs are binary files, batch files, or shell scripts. They generally have file extensions
such as .com, .exe, .bat, or .sh. You can add any executable program that can be run from the
command line on the machine that runs the Program Job Server.

• Java

You can add any Java program to the repository as a Java program object.

• Script

Script program objects are JScript and VBScript scripts. They are run on Windows using an embedded
COM object and can—once published—reference BI platform SDK objects.

Note:
Script program objects are not supported on UNIX.

Note:
As the administrator, you can enable or disable any type of program object.

Once you have added a program object to the repository, you can configure it in the "Folders"
management area of the CMC. For each type of program object (Executable, Java, or Script) you can
choose to specify command-line arguments and a working directory. For executable and Java programs,
there are additional ways, both required and optional, to configure the program objects and provide
them with access to other files.

Tip:
Program objects allow you to write, publish, and schedule scripts or Java programs that run against BI
platform, and perform maintenance tasks such as deleting instances from the history. Furthermore, you
can design these scripts and Java programs to accessBI platform session information. This ensures
that the scheduled program objects retain the security rights or restrictions of the user who scheduled
the job. (Your scripts or Java programs require access to the BI platform SDK. For details, refer to BI
platform SDK documentation such as the SAP Business Intelligence Platform Java SDK Developer
Guide.)

6.4.2 Setting program processing options
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6.4.2.1 To specify command-line arguments

For each program object, you can specify command-line arguments with theDefault Settings command
on the Manage menu. You can specify any argument that is supported by the command-line interface
for your program. Arguments are passed directly to the command-line interface, without parsing.
1. In the "Folders" management area of CMC, select the program object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Program Parameters on the navigation list.
4. In the Arguments field, type the command-line arguments for your program, using the same format

you would use at the command line itself.

For example, if your program has a loops option, to set the loops value to 100, you might type -loops
100

5. Click Save & Close.

6.4.2.2 Setting a working directory for a program object

By default, when a program object runs, BI platform creates a temporary subdirectory in the Adaptive
Job Server's working directory and uses this subdirectory as the working directory for the program. The
subdirectory is automatically deleted when the program finishes running.

You can specify an alternative working directory for the program object with the Default Settings
command on the Manage menu. Or, you can modify the default setting for the working directory for the
Adaptive Job Server.

Note:
The account under which the program runs must have appropriate rights to the folder that you set as
the working directory. The level of file permissions required depend on what the program does; however,
the program's account generally needs read, write, and execute permissions to the working directory.

Related Topics
• Authentication and object packages

6.4.2.2.1 To set a working directory for a program object
1. In the "Folders" management area of CMC, select the program.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.
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3. Click Program Parameters on the navigation list.
4. In the Working Directory field, type the full path to the directory that you want as the program

object's working directory.

For example, on Windows, if you created a working directory named working_directory, type
C:\working_directory

On UNIX, type /working_directory

5. Click Save & Close.

6.4.2.2.2 To modify the default working directory for program objects
1. Go to the "Servers" management area of the CMC.
2. Select the Adaptive Job Server that hosts the Program Scheduling Service.

To check whether an Adaptive Job Server hosts the Program Scheduling Service, select the server
and click Manage > Properties.

3. Click Manage > Properties.
The "Properties" dialog box appears.

4. In the Temporary Directory field, type the full path to the directory you want to set as the working
directory.

5. Click Save & Close.

6.4.3 Configuring executable programs

When you add an executable program object to CMC, you can take the following actions:
• Configure the object to have access to external or auxiliary files.

• Customize environment variables for the shell in which BI platform runs the program.

Related Topics
• Configuring Java programs

6.4.3.1 To specify paths to required files

Some binary files, batch files, and shell scripts require access to external or auxiliary files to run. Aside
from setting a working directory for the program object, there are two ways to provide access to these
files:
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• If a required file is on the same machine as the Adaptive Job Server that hosts the Program
Scheduling Service, you can specify the full path to the file.

• Alternatively, if the file is located elsewhere, you can upload the file to the File Repository Server,
which will pass the files to the Program Scheduling Service as necessary.

1. In the "Folders" management area of CMC, select the executable program object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Program Parameters on the navigation list.
4. In the External Dependencies field, type the full path to the required file and click Add.
5. Repeat step 4 for each file required.
6. Click Save & Close.

Tip:
To edit or remove external dependencies that you have specified, select the file path under "External
Dependencies" and click the appropriate button, either Edit or Remove.

6.4.3.2 To upload required files

1. In the "Folders" management area of the CMC, select the executable program object.
2. Click Actions > Associated Files.
3. Click Browse to navigate to the required file, then click Add File.
4. Repeat step 3 for each required file.
5. Click Save & Close.

Tip:
To remove auxiliary files that you have specified, select the file(s) from the Current auxiliary files list
and click Remove File(s).

6.4.3.3 To add an environment variable

In CMC, you can configure your program by adding or modifying environment variables. Modifications
to an existing environment variable override the variable, rather than append to it. Any changes you
make to environment variables exist only in the temporary shell in which BI platform runs the program.
Consequently, when the program exits, the environment variables are destroyed.
1. In the "Folders" management area of CMC, click the program object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.
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3. Click Program Parameters.
4. In the Environment Variables field, type the environment variables you want to set, and then click

Add.

Use the form name=value , where name is the environment variable name and value is the value
for the environment variable. For example, you can set the path variable to append a user's bin
directory to the existing path:
• On Windows, you might type: path=%path%;c:\usr\bin

• On UNIX, you might type: PATH=$PATH:/usr/bin

Note:
BI platform sets your environment variables using the syntax that is appropriate for your operating
system. However, on UNIX you must follow convention, and use the appropriate case. For example,
all name values on UNIX must be typed in upper case.

5. Click Save & Close.

Tip:
To edit or remove environment variables that you have specified, select the variable from the
Environment Variables list, and click the appropriate button, either Edit or Remove.

6.4.4 Configuring Java programs

To successfully schedule and run Java programs in the BI platform, you must specify the required
parameters for the program object.

Additionally, you can provide the Java program with access to other files located on the Adaptive Job
Server machine, and you can specify Java Virtual Machine options.

6.4.4.1 To specify required parameters for Java programs

To successfully schedule and run a Java program, you must provide BI platform with the base name
of the .class file that implements the IProgramBase interface from the BI platform Java SDK.

Note:
The Java Runtime Environment must be installed on each machine that is running an Adaptive Job
Server.

1. In the "Folders" management area of CMC, select the Java program object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.
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3. Click Program Parameters on the navigation list.
4. In theClass to run field, type the base name of the .class file that implements the IProgramBase

from the SAP BusinessObjects Business Intelligence Platform Java SDK (com.businessob
jects.sdk.plugin.desktop.program.IProgramBase).
For example, if the file name is Arius.class, type Arius.

5. Click Save & Close.

Note:
If your scheduled job fails to run due to an OutOfMemoryError error, increase the maximum heap
size allocated to the JVM. JVM arguments can be set in the JVM arguments field in the "Program
Parameters" section. Specify a maximum heap size that is suitable for your Java program to run, for
example: -Xmx1024m. The JVM arguments field should only be used to resolve errors and should be
left blank otherwise.

6.4.4.2 To provide Java programs with access to other files

You can provide Java programs with access to files, such as Java libraries, located on the Program
Scheduling Service machine.
1. In the "Folders" management area of the CMC, select the Java program object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Program Parameters on the navigation list.
4. In the Classpath field, type the full paths to the locations of any Java library files that are required

by the Java program, and stored on the Adaptive Job Server that hosts the Program Scheduling
Service.

You must separate multiple paths with the classpath separator that is appropriate to your operating
system: a semi-colon for Windows, a colon for UNIX.

5. Click Save & Close.

6.4.5 To specify a user account for a program object

1. In the "Folders" management area of CMC, select the program object.
2. Click Manage > Default Settings.

The "Default Settings" dialog box appears.

3. Click Program Logon on the navigation list.
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4. In the User Name and Password fields, type credentials for the user account under which the
program should run.

5. Click Save & Close.

6.5 Object package management

This section explains object packages and instances, how to manage them in the Central Management
Console (CMC), how to create an object package, and how to add objects to an object package.

6.5.1 What are object packages, components, and instances?

Object packages function as distinct objects in the BI platform. Think of them as folders you can schedule,
along with all of their contents. Object packages can be composed of any combination of report and
program objects that are added to the system. Non-BI platform objects, such as Excel, Word, Acrobat,
Text, Rich Text, PowerPoint, and Hyperlink objects, cannot be added to object packages.

Placing multiple objects in a single object package allows you to schedule them simultaneously. For
reports, object packages allow users to view synchronized data across reports. Component objects are
not autonomous: they have more limited configuration options than other objects, and they do not
appear in the list of all objects in the "Folders" management area of CMC. Component objects can only
be seen by opening their object package.

BI platform creates an object package instance each time it runs an object package. The object package
instance contains individual instances of each of its component objects. Component instances are tied
to object package instances, rather than to component objects. For example, if you run an object
package, and thereby create an instance, then remove a report object from the object package, the
existing object package instance does not change; it still contains the report instance from the report
object that you removed. Future instances of the object package, however, will reflect the change.

For hyperlinked report instances in object package instances, the hyperlinks point to the other report
instances in the same object package instance.

Related Topics
• Working with hyperlinked reports

6.5.2 To create a new object package
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1. Go to the "Folders" management area of the CMC and navigate to the folder that you want to create
the object package in.

2. Click Manage > New > Object Package.
The "Object Package" dialog box appears.

3. Enter a title, description, and keywords for your object package.
4. Click OK.

When the object package has been added to the system, you can modify the properties, contents,
scheduling information, destination, user rights, object settings, and notification for the object package.
To do this, use Manage > Properties or Manage > Default Settings.

6.5.3 Adding objects to an object package

In CMC, after you have created an object package, you can add report and/or program component
objects to it. You can add new objects directly to the object package, or you can copy existing objects
into the object package. You can only move copies of existing objects into the object package, or
between object packages; you cannot move the existing objects themselves.

When you copy an object into an object package, the component object retains the same settings as
the original object. However, once you create the copy of the original object inside the object package,
the component and the original are separate entities. Changes in one object are not reflected in the
other.

Related Topics
• To copy an object

6.5.3.1 To add a new object to an object package

1. In the "Folders" management area of CMC, double-click an object package.
The object package's contents are displayed in the Details panel.

2. Click Manage > Add > Local Document or Program File depending on the object you want to add.
Different dialog boxes appear depending on the option you selected.

3. Click Browse and select the object that you want to add.
4. Set the appropriate properties.

• If you are adding a report, do the following:
• SelectUse description from report if you want to preserve the report's summary information.
• Select Keep saved data if you want to keep the report's saved data.
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• If you are adding a program object, set the program type by clicking Executable, Java, or Script.

5. Click OK.

6.5.4 Configuring object packages and their objects

Object packages are intended to save time scheduling objects that have similar scheduling requirements.
As a result, you configure some parameters at the object package level, and some at the object level,
that is, for the individual objects in the object package.

For example, you must specify the destination for an object package, but you cannot specify destinations
for the individual objects in the package. When the system runs the object package, it will save the
output instances to the destination you specified for the object package.

Note:
Because the objects in an object package are copies of objects that exist outside the package, the
changes you make will not affect the objects outside the object package.

6.5.4.1 To set component failure options for an object package

Perform this task to specify how component failure affects an object package at run time.
1. In the "Folders" management area of CMC, navigate to the object package and select it.
2. Click Manage > Default Settings.
3. Click Component Failure on the navigation list.
4. Select or deselect the Scheduled package fails upon individual component failure check box.
5. Click Save & Close.

6.5.5 Authentication and object packages

Object packages simplify both Enterprise and database authentication. You enter your Enterprise
authentication only once to schedule the object package, including all of its component objects.
Consequently, you must have Schedule rights for each of the objects inside the object package. If you
attempt to schedule a package that contains one or more component objects to which you do not have
schedule rights, the component instance(s) fail(s).
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For database authentication, you specify database logon information for each report component object
in the object package. (If you copied the report into the object package, it initially inherits the database
logon information of the original report.)
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Scheduling Objects

7.1 Scheduling

Scheduling is a process which allows you to run an object automatically at specified times. When you
schedule an object, you choose the recurrence pattern that you want and specify additional parameters
to control exactly when and how often the object will be run.

At the time you schedule an object, the system creates a scheduled instance. Although a scheduled
instance appears in the "History" dialog box of a respective object (with a status of Recurring or Pending),
it contains solely object and schedule information—it does not contain any data.

When the system runs the object, it creates an output instance for the object (for example, a report or
program instance). A report instance contains actual data from the database. A program instance is a
text file that contains the standard output and standard error produced when the program object was
run. Output instances also appear in the "History" dialog box of an object and have a status of Success
or Failed.

For end users to schedule and run objects, they must use a web-based client such as BI launch pad
or a custom web application. BI launch pad is designed primarily to schedule objects and view reports,
whereas the CMC enables you to manage and administer objects in addition to scheduling objects and
viewing reports.

Related Topics
• To specify scheduling information

7.1.1 Setting options for scheduling

7.1.1.1 To schedule an object

1. In the "Folders" management area of the CMC, select an object.
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Note:
To change the default schedule settings for the object, click Default Settings when you open the
"Schedule" dialog box. Set the scheduling settings and click Save.

2. Click Actions > Schedule.

The "Schedule" dialog box appears, showing the default settings for the object.

3. Enter an appropriate instance title.
4. Click Recurrence and select the recurrence pattern you want.

For example, select Weekly.

5. Specify the parameters that you want.

For example, specify Monday, Wednesday, and Friday.

6. Set any of the other schedule options and parameters as required.
7. Click Schedule.

The system will create a scheduled instance and run it according to the schedule information you
specified. You can view the scheduled instance on the "History" page for the object.

Related Topics
• Recurrence pattern options
• Run options and parameters
• Viewing instance information

7.1.1.2 To change the Schedule For settings for an object

The Schedule For feature allows you to generate reports that contain data for specific users only. It is
intended to be used for either of the following types of objects:
• Crystal reports that are based on Business Views, Universes, or SAP BEx Queries.
• Web Intelligence documents that use Universes.

Using the Schedule For feature, you can schedule an object and specify for which users you want the
system to run the object. The system will run the object and generate multiple instances of the report
or document. Each instance will contain data that is relevant to the individual user only.

For example, you can schedule a sales report and on the Schedule For page you can specify the user
names of all of your sales representatives. At the specified time, the system runs the report object and
generates the individual report instances. Each instance would contain sales information for the individual
sales representative only.
1. In the "Folders" management area of the CMC, select a report object.
2. Click Actions > Schedule.
3. On the navigation list, click Schedule For.
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4. Select who you want to schedule the object for.
• Schedule only for myself

• Schedule for specified users and user groups

5. If you selected Schedule for specified users and user groups, navigate to and select the users
and groups you would like to schedule for and click > to add them to the Selected list.

Tip:
If you need to remove users or groups from Selected list, select them and click <.

6. Set the rest of your scheduling options and click Schedule.

7.1.1.3 Recurrence pattern options

DescriptionRecurrence pattern

The object is run as soon as the user clicks Schedule.Now

The object is run only once. It can be run now or in the future, or
when a specified event has occurred.Once

The object is run every hour. You specify at what time it will start,
as well as a start and end date.Hourly

The object is run every day. It can be run once or several times
a day. You can specify at what time it will run, as well as a start
and end date.

Daily

The object is run every week. It can be run once a week or several
times a week. You can specify on which days and at what time
it will run, as well as a start and end date.

Weekly

The object is run every month or every several months. You can
specify on which days of the month and at what time it will run,
as well as a start and end date.

Monthly

The object is run on a certain day of every month. You can
specify the day it will run, as well as a start and end date.Day of Month
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DescriptionRecurrence pattern

The object is run on the first Monday of every month. You can
specify a start and end date.First Monday of Month

The object is run on the last day of every month. You can specify
a start and end date.Last Day of Month

The object is run on a particular day of a particular week every
month. You can specify the day and the week, as well as the start
and end date.

Day of Week of Month

The object is run on the dates specified in a calendar that has
previously been created.Calendar

Related Topics
• Calendars

7.1.1.3.1 Run options and parameters

After you choose a recurrence pattern, you must configure the run options and parameters for that
recurrence option. This section describes the Run parameters for scheduling an object. Not all parameters
apply in all cases, but when they apply, their function is the same.

Table 7-2: Run options

DescriptionRun option

Applies to certain Daily and Monthly recurrence
patterns only. When you select a Run option that
contains these variables, the system displays their
default values. You can then change these values
as needed.

For example, if you select the Daily recurrence
pattern and theEvery N hour(s) and Xminute(s)
Run option, you could specify to run the report
every 4 (X) hours and 30 (N) minutes. If you don't
change the X or N value, the system will run the
report every hour.

X and N variables
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DescriptionRun option

These options appear if you select the Weekly
recurrence pattern. You can choose the days of
the week on which you want your job to run by
deleting the checkboxes of the appropriate days.

Run Days

Applies to most but not all recurrence patterns
and Run options. The default is the current date
and time. The system will run the object according
to the schedule that you specified, as soon as it
can, after the Start Time has passed.

For example, if you specify a start time that is
three months into the future, the system won't run
the object until the start date has passed, even if
all the other criteria are met. After that, the system
will run the report at the specified time.

Start Time

Applies to most, but not all, recurrence patterns
and Run options. The default is the current time
and a date in the distant future, to ensure an ob-
ject will be run indefinitely. Specify a different End
Time if required. Once the End Time has passed,
the system no longer runs the object.

End Time

Always applies. The number of times the system
attempts to process an object if the first attempt
is not successful. By default, the number is zero.

Number of retries allowed

Always applies. The period, in seconds, that the
system will wait before it attempts to process the
object again if the first attempt is unsuccessful.

Retry interval in seconds

7.1.1.4 Setting notification for the success or failure of a scheduling job

You can set scheduling options that automatically send notification when an object instance succeeds
or fails. You can send notification using audit or email notification. You can also combine multiple
notification methods, and provide different notification settings for successful and failed instances.
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For example, you may have a large number of reports that run every day. You need to check each
instance to make sure it ran properly, and then send out emails to the users who need to know that the
new report is available. With thousands of reports, it would take too much time to manually check the
reports and contact the users who need the information. Using notification settings in BI platform, you
can set each object to notify you automatically when the report fails to run properly, and you can
automatically inform users when new report instances run successfully.

7.1.1.4.1 Determining the success or failure of a scheduling job

When you schedule an object, the scheduled instance either succeeds or fails. The conditions required
for an instance's success or failure depend on the type of object you schedule:
• Report objects and Web Intelligence documents

A report instance or document object instance runs successfully if it doesn't encounter any errors
while processing the object or accessing the database. An instance may fail if the user does not
provide the correct parameters or logon information.

• Program objects

For program objects, the program must run in order to succeed. If the program does not run, the
instance is considered a failure. If the program runs, but does not perform the tasks it is supposed
to, it is still considered a successful instance because the program object ran. BI platform does not
monitor problems with the program object's code.

• Object packages

An object package may fail if one of its components fails. To change this setting, select the object
and clickManage >Default Settings. ClickComponent Failure, and clear the Scheduled package
fails upon individual component failure option.

You can also set scheduling options for individual objects within an object package. You can do this
by choosing the component you want to set options for in theComponents section of the "Scheduling"
dialog box. You can then set the component's notification, database logon, filters, format, print,
parameters, server groups, and alert settings as applicable to the component.

Note:
You cannot set audit or email notification for object packages, but you can set any type of notification
for the individual objects in the object package. You can also schedule object packages with events.

Related Topics
• Schedule-based events

7.1.1.4.2 Notification types

You can set notification at the object level. You can select unique notification options for each object,
sending different types of notification for different conditions. For object packages, you can set only
event notification, which will trigger an event based on success or failure of the object package. To
monitor object successes and failures from a more general perspective, use the auditing functionality
within BI platform.
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If notification fails, then the object instance fails. For example, if an email notification sends a message
to an invalid email address, then the notification fails and the object instance is recorded as a failure in
the object's history.

You can choose to notify using:
• Audit notification

To use audit notification, you must configure the auditing database and enable auditing for the
servers. If you use auditing to monitor your BI platform system, you can use audit notification. For
more information about configuring the auditing database and enabling auditing, see the SAP
BusinessObjects Business Intelligence Platform Administrator Guide available on the SAP Help
Portal at http://help.sap.com.

When you select audit notification, information about the scheduled object is written to the auditing
database. You can choose to have a notification sent to the auditing database when the job runs
successfully, when it fails to run, or both.

• Email notification

You can send an email as a notification of an object instance's success or failure. You can choose
the sender and recipients of the email message. You can send an email when the instance fails and
when it succeeds. For example, you could send your administrator an email if the report fails, but
when the report succeeds you can automatically send a notification to everyone who needs the
report to let them know it is now available.

Note:
To enable email notification, you must have the Email SMTP destination enabled and configured
on the job servers. For more information, see the SAP BusinessObjects Business Intelligence
Platform Administrator Guide.

Note:
Notification of a scheduled object's success or failure is not the same as alert notification. Alert notification
must be built into the design of the report. For example, alert notification can send an email to you
whenever a specific value in the report exceeds $1,000,000. In this case, the notification has nothing
to do with the contents of the report — it's just about whether or not the report object instance has failed
or succeeded.

7.1.1.4.3 To set notification for an instance's success or failure
1. Select an object in the "Folders" management area of CMC.
2. Click Actions > Schedule.
3. On the navigation list, click Notification.
4. Click the notification type (or types) you want to use.

If the notification type is already being used, it will be labeled “Enabled”. If not, it will be labeled “Not
in use”.
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Table 7-3: Notification types

InstructionNotification type

• To send a record to the auditing database
when the job succeeds, select A job has
been run successfully.

• To send a record when the job fails, select
A job has failed to run.

Audit

• Choose whether you want to send a notifica-
tion when the job fails or when it succeeds.

• To specify the contents and recipients of the
email notification, expand the notification
option(s) you have enabled, select Set the
values to be used here, and provide the
From and To email addresses, the email
subject line, and the message.

Note:
Separate multiple addresses or distribution lists
by using semicolons.

Email

Note:
By default, the notification is sent to the server's default email destination.

7.1.1.5 Selecting a destination

Using BI platform, you can configure an object or instance for output to a destination other than the
default Output File Repository Server (FRS). When the system runs an object, it always stores the
output instance on the Output FRS. Being able to choose an additional destination gives you the flexibility
to deliver instances across your Enterprise system or to destinations outside your Enterprise system.

For example, you can set an object to have its output automatically delivered by email to other users.

Note:
You can also configure object instances to be printed after they have been run.

When you specify a destination other than the default destination, BI platform generates a unique name
for the output file or files. To generate a file name, you can use a combination of ID, name or title of the
object, owner information, or the date and time information.
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The following destinations are available:
• Default destination location
• File location
• FTP location
• Email
• BI Inbox
• SAP StreamWork

Note:
You can change the destination setting for an object or instance either in the CMC or in BI launch pad.
When you specify the destination settings through the CMC, these settings are also reflected in the
default scheduling settings for BI launch pad.

Related Topics
• Setting printer and page layout options
• To set your destination as the default
• To set the destination to a file location
• To set the destination to an FTP server
• To schedule an object to an email destination
• To schedule an object to a BI Inbox destination
• To schedule an object to a StreamWork workspace
• To enable or disable destinations for a job server

7.1.1.5.1 To set your destination as the default

By default, object instances are saved to the Output File Repository Server (FRS). If you want to save
instances to the FRS only and not to any other destinations, select that option.
1. In the "Folders" management area of the CMC, select an object.
2. Click Actions > Schedule and view your destination settings.

For example, for a Crystal report or object package, click Destinations.

3. Select Default Enterprise Location as the destination.
For example, for a Crystal report or object package, select Default Enterprise Location in the
Destination list.

4. Set the remaining scheduling options and click Schedule.

7.1.1.5.2 To schedule an object to a BI Inbox destination

When scheduling objects, you can configure objects for output to the BI Inboxes of users. In this case,
the system will save the instance to both the Output File Repository Server and the BI Inboxes you
specified. Instead of sending the actual file to BI Inboxes, you can choose to send a shortcut.

Note:
To use a destination, you must have the destination enabled and configured on the Adaptive Job
Servers. For more information, see the To enable or disable destinations for a job server.
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1. In the "Folders" management area of the CMC, select an object.
2. Click Actions > Schedule and view your destination settings.

For example, for a Crystal report or object package, click Destinations.

3. Select BI Inbox as the destination.
For example, for a Crystal report or object package, select BI Inbox from the Destination list.

4. Choose whether to use the Job Server's default settings.
For example, for a Crystal report or program object, select or deselect Use default settings.

5. If you chose not to use the Job Server's default settings, complete the following steps:
a. Move users from the "Available Recipients" list to the "Selected Recipients" list.
b. Choose whether to use an automatically generated name or a specific name for the instance.
c. Choose whether to send the instance as a shortcut or a copy.

6. Choose whether to enable instance cleanup.

For example, for a Crystal report or program object, select or deselect Keep an instance in the
history.

When this option is selected, the system automatically deletes the report or program instance from
the Output File Repository Server to keep the number of instances on the server to a minimum.

7. Set your other scheduling options and click Schedule.

7.1.1.5.3 To schedule an object to an email destination

You can send Crystal report instances and other object instances to one or more email destinations
using Simple Mail Transfer Protocol (SMTP) mail support. BI platform sends a copy of the output instance
as an attachment to the email addresses you specified.

When you select the Email (SMTP) destination, BI platform saves the instance to the Output File
Repository Server and emails it to the specified destinations. BI platform supports Multipurpose Internet
Mail Extensions (MIME) encoding.

Note:

• To use a destination, you must have the destination enabled and configured on the Adaptive Job
Servers. For more information, see the To enable or disable destinations for a job server.

• You can change the job server's default settings in the "Servers" management area. For more
information, see the SAP BusinessObjects Business Intelligence Platform Administrator Guide.

1. In the "Folders" management area of the CMC, select an object.
2. Click Actions > Schedule and view your destination settings.
3. On the "Schedule" page, click Destinations to view your destination settings.
4. In the Destination list, select Email as the destination.
5. Select or clear the Use default settings check box to indicate whether to use the job server's default

settings.

If you clear the check box, you must configure the following additional scheduling options:
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DescriptionOption

Select this check box to retain a copy of this instance on the "History" page.
The system automatically deletes the report or program instance from the
Output File Repository Server to keep the number of instances on the server
to a minimum. This check box is selected by default.

Keep an in-
stance in the
history

Type a return email address, or select variables for the email address from
the Add placeholder list. The available variables are Title, ID, Owner,
DateTime, (your) Email Address, and (your) User Full Name. Click a
variable to add it. Separate email addresses with a semicolon (;).

Note:
This option may be unavailable, depending on your system configuration.

From

Type each email address that you want to send the instance to, or select
variables for the email address from the Add placeholder list. The available
variables are Title, ID, Owner, DateTime, (your) Email Address, and
(your) User Full Name. Click a variable to add it. Separate email addresses
with a semicolon (;).

To

Type each email address that you want to send a copy of the instance to, or
select variables for the email address from the Add placeholder list. The
available variables are Title, ID, Owner, DateTime, (your) Email
Address, and (your) User Full Name. Click a variable to add it. Separate
email addresses with a semicolon (;).

Cc

Type the email address of each undisclosed recipient, or select variables for
the email address from the Add placeholder list. The available variables are
Title, ID, Owner, DateTime, (your) Email Address, and (your) User
Full Name. Click a variable to add it. Separate email addresses with a
semicolon (;).

Bcc

Type the subject of the email, or select variables for the subject from the Add
placeholder list. The available variables are Title, ID, Owner, DateTime,
(your) Email Address, and (your) User Full Name. Click a variable to
add it.

Subject

Type the message for the body of the email, or select variables for the mes-
sage from the Add placeholder list. The available variables are Title, ID,
Owner, DateTime, (your) Email Address, (your) User Full Name,
Viewer, and Document Name. Click a variable to add it.

Message
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DescriptionOption

Select this check box if you want to add an attachment to the email message
containing the instance.

AddAttachment
check box

• To use a system-generated file name for the instance, select Use Auto-
matically Generated Name.

• To choose the file name for the instance, select Use Specific Name, and
type a name or select variables for the file name from theAdd placeholder
list. The available variables are Title, ID, Owner, DateTime, (your)
Email Address, (your) User Full Name, and File Extension.

Select the Add File Extension check box to automatically add the file
extension to the instance file name. If you do not add a file extension, you
will be unable to open the document.

File Name

6. Set the remaining scheduling options as needed, and click Schedule.

7.1.1.5.4 To set the destination to a file location

When scheduling objects, you can configure the objects for output to an unmanaged disk. In this case,
the system will save an output instance to both the Output File Repository Server and the specified
destination.

If the object is a Web Intelligence document or an object package, you cannot specify Unmanaged Disk
as a destination. However, for an object package you can configure the individual objects in the object
package for output to Unmanaged Disk.

Note:

• To use a destination, you must have the destination enabled and configured on the Adaptive Job
Servers. For more information, see the To enable or disable destinations for a job server.

• The location must be a local directory on the processing server. For servers using Windows, the
location can either be a Universal Naming Convention (UNC) path or a local directory.

• The processing server must have sufficient rights to the specified location.
1. In the "Folders" management area of CMC, select an object.
2. Click Actions > Schedule and view your destination settings.

For example, for a Crystal report or object package, click Destinations.

3. Select a file location as the destination.
For example, for a Crystal report or object package, select File System from the Destination list.

4. Choose whether or not to use the Job Server's default settings.
For example, for a Crystal report or program object, select or deselect Use default settings.
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If you choose not to use the default settings, you must configure some additional settings to be used
at schedule time. The following table summarizes these settings.

DescriptionSetting

Type a local location, mapped location, or a
UNC path.Directory

• To let the system generate a file name, se-
lect Use Automatically Generated Name.

• To choose a file name, select Use Specific
Name and enter the name you want to use.
For a Web Intelligence document, you can
include placeholders in the file name, or se-
lect Add file extension to include the file
extension in the name.

File Name

Specify a user who has permission to write files
to the destination directory.User Name

Type the password for the user.Password

Note:

• You can specify a user name and password only for servers using Windows.
• You can change the default Job Server settings in the "Servers" management area of the CMC.

For more information, see the SAP BusinessObjects Business Intelligence Platform Administrator's
Guide.

5. Choose whether to enable instance cleanup.
For example, for a Crystal report or program object, select or deselect Keep an instance in the
history.

When you enable instance cleanup, the system automatically deletes the report or program instance
from the Output File Repository Server to keep the number of instances on the server to a minimum.

Note:
These instances are needed for auditing the event, so this setting is overruled if auditing is activated
for the scheduled object.

6. Set other scheduling options as needed, and click Schedule.

7.1.1.5.5 To set the destination to an FTP server

When scheduling objects, you can configure the objects for output to a File Transfer Protocol (FTP)
server. To connect to the FTP server, you must specify a user who has the necessary rights to upload

2012-11-0687

Scheduling Objects



files to the server. If you specify an FTP destination, the system will save an output instance to both
the Output File Repository Server and the specified destination.

Note:
To use a destination, you must have the destination enabled and configured on the Adaptive Job
Servers. For more information, see the To enable or disable destinations for a job server.

1. In the "Folders" management area of CMC, select an object.
2. Click Actions > Schedule and view your destination settings by doing one of the following:

For example, for a Crystal report or object package, click Destinations.

3. Select FTP Server as the destination.
For example, for a Crystal report or an object package, select FTP Server in the Destination list.

4. Choose whether or not to use the Job Server's default settings.
For example, for a Crystal report or program object, select or deselect Use default settings.

If you choose to use the default, BI platform will schedule an object using the Job Server's default
settings. You can change these settings in the "Servers" management area. For more information,
see the SAP BusinessObjects Business Intelligence Platform Administrator Guide.

If you choose not to use the default settings, you must configure some additional settings to be used
at schedule time. The following table summarizes these settings.

DescriptionSetting

Enter the FTP host information.Host

Enter the FTP port number (the default is 21).Port

Specify a user who has the necessary rights to upload an object to the FTP
server.

User Name

Enter the user's password.Password
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DescriptionSetting

Enter the FTP account information, if required.

Account is part of the standard FTP protocol, but it is rarely implemented.
Provide the appropriate account only if your FTP server requires it.

Account

Enter the FTP directory that you want the object to be saved to. To add a
variable, choose a placeholder for a variable property from the list.

Directory

• To let the system generate a file name, select Use Automatically Gener-
ated Name.

• To choose a file name, select Use Specific Name and enter the name you
want to use. For a Web Intelligence document, you can include placeholders
in the file name, or select Add file extension to include the file extension
in the name.

File Name

5. Choose whether to enable instance cleanup.
For example, for a Crystal report or program object, select or deselect Keep an instance in the
history.

When you enable instance cleanup, the system automatically deletes the report or program instance
from the Output File Repository Server to keep the number of instances on the server to a minimum.

6. Set your other scheduling options and click Schedule.

7.1.1.5.6 To schedule an object to a StreamWork workspace

In order to schedule an object to StreamWork you will need an active StreamWork account.

Note:
To use a destination, you must have the destination enabled and configured on the Adaptive Job
Servers. For more information, see the To enable or disable destinations for a job server.

1. In the "Folders" management area of the CMC, select an object.
2. Click Actions > Schedule and view your destination settings.

For example, for a Crystal report or object package, click Destinations.

3. Select SAP StreamWork as the destination.
For example, for a Crystal report or object package, select SAP StreamWork from the Destination
list.

Note:
If you do not have a StreamWork account currently associated with your user name, you will be
asked to authenticate into StreamWork.

4. Update the StreamWorks settings you want to use.
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DescriptionSetting

Set the destination of the report in StreamWork, this can either be an existing
or new activity. The first of the two drop-down fields allows you to filter ac-
tivities by worklist.

Select Destination

If the object will publish to a new activity, enter the name you want to use
here.

Activity Name

Enter a description for the activity the will help participants know what you
want to accomplish.

Activity Objectives

Enter a description for object that will help the StreamWork participants
understand what the object is and how you want it used.

Item Description

Choose the appropriate StreamWork activity type.Select Activity Type

If you are creating a new StreamWork activity, enter the StreamWork IDs
of participants you want added.

Add Participants

For example, for a Crystal report or program object, select or deselect Use default settings.

5. Choose whether to enable instance cleanup.

For example, for a Crystal report or program object, select or deselect Keep an instance in the
history.

When this option is selected, the system automatically deletes the report or program instance from
the Output File Repository Server to keep the number of instances on the server to a minimum.

6. Set your other scheduling options and click Schedule.

7.1.1.5.7 To enable or disable destinations for a job server

By default, when the system runs a scheduled report or a program object, it stores the output instance
it creates on the Output File Repository Server (FRS). However, you can specify a different destination.
If you do, the system will store one output instance on the Output FRS, and one at the specified
destination. You also specify a destination when you use the Send command, which sends an existing
object to a specified destination.

In order for the system to work with destinations other than the default, the destination you are sending
to must be enabled and configured on all Adaptive Job Servers.

For example, to be able to schedule or send send a report instance to an email address, you have to
enable and configure the Email (SMTP) destination on the Adaptive Job Servers.

Note:
On the Adaptive Job Servers, the BI Inbox destination is enabled and configured by default. This allows
you to use the Send command to distribute reports and documents. You can also enable and configure
additional destinations on the Adaptive Job Server.

1. Go to the Servers management area of the CMC.
2. Select the Adaptive Job Server for which you want to enable or disable a destination.
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3. Choose Properties from the Manage menu.
4. In the Properties dialog box, click Destinations in the navigation list
5. To enable a destination, select it in the Destination list and click Add.

Note:
If you enabled the destination, you must also configure the destination.

6. To disable a destination, select it in the Destination list and click Remove.
7. Click Save or Save & Close.

7.1.1.6 Specifying alert notification

Note:
This feature does not apply to Web Intelligence documents.

Alerts are custom messages, created in SAP Crystal Reports, that appear when certain conditions are
met by data in a report. Alerts may indicate actions to be taken by the user or information about report
data. If the alert condition (as defined in SAP Crystal Reports) is true, the alert is triggered and its
message is displayed.

In BI platform, you can choose to send alert notification when scheduling a report. If you enable alert
notification, messages are sent through an SMTP server. You can configure email delivery options,
specify the To, Cc, and From fields for the email, add subject and message information, set a URL for
the viewer you want the email recipient to use, and set the maximum number of alert records to send.

Note:

• The Alert Notification link is available only if the report object contains alerts.
• Alerts are triggered in the report object even if you disable alert notification.
• To enable alert notification, you must have the Email SMTP destination enabled and configured on

the Job Server. For more information, see the SAP BusinessObjects Business Intelligence Platform
Administrator's Guide.

• Alert notifications are different from Alerting.

Related Topics
• Differences between alerting and Crystal report alert notifications

7.1.1.6.1 To set alert notification
1. In the "Folders" management area of the CMC, select a report object.
2. Click Actions > Schedule.
3. On the navigation list, click Alert Notification.
4. Select the Enable alert notification check box if you want to send an alert notification.
5. Select either Use default settings or Custom settings.
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If you select the first option, BI platform will deliver the alert notification using the Job Server's default
settings. You can change these settings in the "Servers" management area. For more information,
see the SAP BusinessObjects Business Intelligence Platform Administrator Guide.

If you select the second option, you can specify the email settings in the software.

6. Type the URL for the viewer in which you want email recipients to view the report, or select the
default viewer by clicking Use default.

The viewer URL appears in the hyperlink that is sent in the alert notification email. You can set the
default URL by selecting the CMC application in the "Applications" management area of the CMC
and selecting Actions > Processing Settings.

Note:
You must use World Wide Web Consortium (W3C) URL encoding when typing the viewer URL. For
example, replace spaces in the path with %20. For more information, see http://www.w3.org/

7. Type the maximum number of alert records to be included in the alert notification.

The hyperlink in the alert notification displays a report page that contains the records that triggered
the alert. Use this field to limit the number of records displayed.

Tip:
The Alert Name and Status information is defined in SAP Crystal Reports.

8. When you have finished setting all your scheduling options, click Schedule.

7.1.1.7 Choosing a format

You can select the format that the document or report instance will be saved in when it is generated.
This format will be saved to the destination you have selected. You can select from the formats
summarized in the following table.

Table 7-6: Instance formats

NotesFormatProduct

• Web Intelligence document
• Microsoft Excel
• Adobe Acrobat
• Comma-separated values

(CSV)

SAP BusinessObjects
Web Intelligence
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NotesFormatProduct

• SAP Crystal Reports produces a nor-
mal editable report; the RPTR option
produces a read-only Crystal report.

• The difference between Excel and Ex-
cel (Data only) is that Excel attempts
to preserve the look and feel of your
original report, while Excel (Data only)
saves only the data, with each cell
representing a field.

• The Tab-separated Values format
places a tab character between values;
the Separated Values format places a
specified character between values.

• If you choose to print the report when
it is scheduled, the report instance is
automatically sent to the printer in SAP
Crystal Reports format. This does not
conflict with the format you select when
scheduling the report.

• For Excel, Paginated Text, Tab Sepa-
rated Text, and Separated Values, you
specify certain formatting properties
for the report. For example, if you se-
lect the CSV option, you can enter
characters for the separator and delim-
iter.

• SAP Crystal Reports
• SAP Crystal Reports read

only (RPTR)
• Microsoft Excel (97-2003)
• Microsoft Excel (97-2003)

(Data Only)
• Microsoft Excel Workbook

Data only
• Microsoft Word (97-2003)
• PDF
• Rich Text Format (RTF)
• Microsoft Word - Editable

(RTF)
• Plain Text
• Paginated Text
• Tab Separated Text (TTX)
• Separated Values (CSV)
• XML

SAP Crystal Reports

Related Topics
• Selecting a destination

7.1.1.7.1 To select a format
1. In the "Folders" management area of CMC, select a report object.
2. Click Actions > Schedule and view the format settings.

For example, for a Crystal report, click Formats.

3. Select the appropriate format.
For example, for a Crystal report, select the format on the Format list.

4. Set the rest of your scheduling options and click Schedule.

Related Topics
• Additional formatting options for Crystal reports
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7.1.1.7.2 Additional formatting options for Crystal reports

When you schedule a Crystal report to some formats, you may need to set additional options. The
following tables describe the additional options for each format.

Table 7-7: Microsoft Excel (97-2003)

DescriptionOption

• To include all pages in a report, click All.

• To include a page range, click Pages from, type the first page you want
to include, and type the last page you want to include in the to box.

Page Range

Click to use the export options defined in a report. You cannot set any other
formatting options.

Use the export op-
tions defined in the
report

• To set the width of Excel columns based on objects in a report, click Col-
umnwidth based on objects in the and choose a report area from which
to take the column width.

• To set a constant column width, click Constant column width (in points)
and type the width.

Set Column Width

• To indicate how to print page headers and footers in an instance, click
Once Per Report or On Each Page.

• To exclude page headers and footers from an instance, click None.
Export page header
and page footer

Click to create a page break after each page in a reportCreate page breaks
for each page

Click to export date values in a report as text stringsConvert date val-
ues to strings

Click to view gridlines in the exported documentShow gridlines
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Table 7-8: Microsoft Excel (97-2003, 2007) (Data Only) and Microsoft Excel Workbook (Data Only)

DescriptionOption

Click to use the export options defined in a report. You cannot set any other
formatting options.

Use the export op-
tions defined in the
report

• To set the width of Excel columns based on objects in a report, click Col-
umnwidth based on objects in the and choose a report area from which
to take the column width.

• To set a constant column width, click Constant columnwidth (in points)
and type the width.

Set Column Width

Click to preserve the object formattingExport object for-
matting

Click to export the images in a reportExport images

Click to use summaries in a report to create worksheet functions in Excel
Use worksheet
functions for sum-
maries

Click to maintain the position of objects, relative to one anotherMaintain relative
object position

Click to preserve the alignment of text in columns of a reportMaintain column
alignment

Click to include the header and footer in an instanceExport page header
and page footer

Click to simplify page headersSimplify page
headers

Click to show group outlinesShow group out-
lines
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Table 7-9: Microsoft Word (97-2003)

DescriptionOption

• To include all pages in a report, click All.

• To include a page range, click Pages from, type the first page you want
to include, and type the last page you want to include in the to box.

Page Range

Table 7-10: PDF

DescriptionOption

• To include all pages in a report, click All.

• To include a page range, click from, type the first page you want to include,
and type the last page you want to include in the to box.

Page Range

Click to use the export options defined in a report. You cannot set any other
formatting options.

Use the export op-
tions defined in the
report

Click to create bookmarks in a PDF file based, on the tree structure of the
report. This makes reports easier to navigate.

Create bookmarks
from group tree

Table 7-11: Rich Text Format (RTF)

DescriptionOption

• To include all pages in a report, click All.

• To include a page range, click Pages from, type the first page you want
to include, and type the last page you want to include in the to box.

Page Range

Table 7-12: Microsoft Word - Editable (RTF)

DescriptionOption

• To include all pages in a report, click All.

• To include a page range, click from, type the first page you want to include,
and type the last page you want to include in the to box.

Page Range
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DescriptionOption

Click to use the export options defined in a report. You cannot set any other
formatting options.

Use the export op-
tions defined in the
report

Click to insert page breaks after each page of the report.
Insert page break
after each report
page

Table 7-13: Plain Text

DescriptionOption

Click to use the export options defined in a report. You cannot set any other
formatting options.

Use the export op-
tions defined in the
report

Type a value between 8 and 16 to indicate the number of characters to include
per inch. This setting determines how text files appear and are formatted.

Number of charac-
ters per inch

Table 7-14: Paginated Text

DescriptionOption

Click to use the export options defined in a report. You cannot set any other
formatting options.

Use the export op-
tions defined in the
report

Type the number of lines of text to include between page breaks.Number of Lines
per Page

Type a value between 8 and 16 to indicate the number of characters to include
per inch. This setting determines how text files appear and are formatted.

Number of Charac-
ters per inch
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Table 7-15: Separated Values (CSV)

DescriptionOption

Click to use the export options defined in a report. You cannot set any other
formatting options.

Use the export op-
tions defined in the
report

Type the character to use as the delimiter.Delimiter

Type the character to use to separate values, or click Tab.Separator

Click standard or legacy mode. In standard mode, you can choose report,
page, and group sections to include in an instance. In legacy mode, you
cannot set the report, page, and group section options.

Mode

If you selected standard mode, indicate whether to export report and page
sections. If yes, indicate whether to isolate the sections.

Report and page
sections

If you selected standard mode, indicate whether to export group sections. If
yes, indicate whether to isolate the sections.Group sections

Table 7-16: XML

DescriptionOption

Click to use the export options defined in a report. You cannot set any other
formatting options.

Use the export op-
tions defined in the
report

Choose an XML export format.XML Exporting for-
mats

7.1.1.8 To select a cache format for Web Intelligence documents
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When the system runs a scheduled Web Intelligence document it stores the instance it generates on
the Output File Repository Server. In addition, you can choose to have the system cache the report on
the appropriate Report Server by selecting a cache format for the document. If you don't select a cache
format, then the system won't cache the document when it runs the document.

Note:
To select a cache option, the output format you specified for the object must be a Web Intelligence
document. If you select a different format, the cache options you specify will have no effect.

1. In the "Folders" management area of the CMC, select a Web Intelligence document object.
2. Click Actions > Schedule and click Caching.
3. Select the format you want to pre-load the cache with.

Your options are:
• Microsoft Excel
• Standard HTML
• Adobe Acrobat

4. Select the locale(s) with which to pre-load the cache.

When you schedule the Web Intelligence document, BI platform generates cached versions of the
document in the locale(s) that you specify.

5. Set the rest of your scheduling options and click Schedule.

7.1.1.9 Scheduling an object with events

When you schedule an object with events, the object is run only when the additional condition (that is,
the event) occurs. You can schedule objects to wait for any of the following event types:
• File-based: Triggered upon the existence of a specified file.
• Custom: Triggered manually.
• Schedule-based: Triggered by another object being run.

If you want a scheduled object to trigger an event, you must choose a schedule-based event.

Scheduling objects based on an event
When you schedule an object that waits for a specified event, the object will run only when the event
is triggered, and only when the rest of the schedule conditions are met. If the event is triggered before
the start date of the object, the object will not run. If you have specified an end date for this object, and
if the event is not triggered before the end date occurs, the object will not run because not all of the
conditions will have been met. Also, if you choose a weekly, monthly, or calendar schedule, the object
will have a specified time frame in which it can be processed. The event must be triggered within this
specified time for the object to run. For example, if you schedule a weekly report object that runs every
Tuesday, the event must be triggered before the end date of the instance (the end of Monday, in this
example).
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Scheduling objects to trigger an event
You can also schedule an object which triggers a schedule-based event upon completion of the object
being run. When the object is run, BI platform will trigger the specified event. For a schedule-based
event, if the event is based on the instance being run successfully, for example, the event won't be
triggered if the instance fails.

Note:
To schedule an object with events, you must first ensure that you have created the event.

Related Topics
• General object management
• Scheduling an object with events

7.1.1.9.1 To schedule an object to run based on an event

Perform this task if you want a scheduled job to run after an event has occurred.
1. In the "Folders" management area of the CMC, select an object.
2. Click Actions > Schedule.
3. Click Recurrence on the navigation list and choose an option on the Run object list.
4. Complete the schedule parameters for your object (start date, end date, and so on).
5. Click Events, select from the list of Available Events, and click > to add the event(s) to the list of

Events to wait for.

Tip:
Click >> to add all the available events.

6. Click the Schedule button to schedule the object.

Related Topics
• Recurrence pattern options
• Run options and parameters
• To schedule an object to run based on an event

7.1.1.9.2 To schedule an object to trigger an event

Perform this task if you want your scheduled job to trigger an event when the job runs.
1. In the "Folders" management area of the CMC, select an object.
2. Click Actions > Schedule.
3. Click Recurrence on the navigation list and choose a run option on the Run object list.
4. Complete the schedule parameters for your object (start date, end date, and so on).
5. Select from the list of Available Schedule Events and click > to add the events(s) to the list of

Events to trigger on completion.

Note:
You can only select schedule-based events in this list.
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Tip:
Click >> to add all the available events.

6. Click the Schedule button to schedule the object.

Related Topics
• Recurrence pattern options
• Schedule-based events

7.1.1.10 To select a server for your scheduling job

You can indicate a specific server on which a scheduling will run. This gives you more control over load
balancing; for instance, you may want to run program jobs on a specific server group so that they do
not monopolize system resources.

You can also choose a server group for BI platform to use when a user refreshes a Crystal report or
Web Intelligence document instance while viewing it. These settings are available when you click
Manage > Default Settings. For Crystal reports, click Viewing Server Group. For Web Intelligence
documents, click Web Intelligence Process Settings.
1. In the "Folders" management area of the CMC, select the object you want to schedule.
2. Click Actions > Schedule.
3. On the navigation list, click Scheduling Server Group.
4. Select the appropriate option:

• Choose Use the first available server to run the object as quickly as possible, regardless of
server groups.

• Choose Give preference to servers belonging to selected group if you would like to use a
specific server group over another in the event that both are available.

• Choose Only use servers belonging to the selected group to ensure that the job runs on the
specified server group.

Note:
If you are scheduling a program object that requires access to files stored locally on the Adaptive
Job Server which hosts the Program Scheduling Service, but you have multiple Adaptive Job Servers,
you must specify which server to use to run the program.

5. Select or deselect Run at origin site to run the object where it is located.
6. Set the rest of your scheduling options and click Schedule.
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7.1.1.11 To select languages for report instances

Note:
This task applies to SAP Crystal Reports only.

Perform this task if you want to generate report instances in different languages.
1. In the "Folders" management area of the CMC, select the object you want to schedule.
2. Click Actions > Schedule.
3. On the navigation list, click Languages.
4. Select one of the following language options:

• Schedule the report in Preferred Viewing Locale

This option schedules the report according to the preferred viewing locale you set in your
preferences, and creates instances using that locale only.

• Schedule the report in Multiple Locales

This options schedules the report in multiple languages. If you choose this option, you must also
select locales by moving them from the All Locales list to the Selected Instance Locales list.

5. Set other scheduling parameters as required, and click Schedule.

7.1.2 To run objects now

As an alternative to scheduling, you can run objects in bulk from the "Folders" management area of the
CMC using Run Now. When you run objects now, they are run instantly using their default scheduling
settings.
1. Go to the "Folders" management area of the CMC.
2. Navigate to the object(s) that you want run and select them.
3. Click Actions > Run Now.

7.1.3 Scheduling objects using object packages

You can schedule objects in batches using the object packages feature. Object packages are distinct
objects in BI platform. They can contain any combination of objects that can be scheduled, such as
reports, program objects, and Web Intelligence documents. Using object packages simplifies
authentication, and allows users to view synchronized data across instances for different objects.
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To schedule objects using object packages, first create an object package. Then copy existing objects
into the object package. Finally, schedule the object package as you would any object.

Note:
You must configure the processing information of each of the components of an object package
individually. For example, if you want a report object in an object package to print when scheduled, you
must configure it by clicking Components in the "Schedule" dialog box and clicking the title of the
component you want to print. You can then expand Print Settings for the component and set it to print
as you would when scheduling the component on its own.

Related Topics
• Object package management
• Configuring object packages and their objects
• Working with hyperlinked reports

7.2 Managing instances

BI platform creates instances from objects. That is, a report instance is created when a report object is
scheduled and run by the Job Server. Essentially, a report instance is a report object that contains
report data that is retrieved from one or more databases. Each instance contains data that is current
at the time the report is processed.

Similarly, BI platform creates a program instance each time that a program object is scheduled and run
by the Job Server. Unlike report instances, which can be viewed in their completed format, program
instances exist as records in the object history. BI platform stores the program's standard output and
standard error in a text output file.

You can view and manage instances in the following places:
• "History" dialog box for an object
• Instance Manager

Related Topics
• Viewing instance information
• To set limits for instances
• Instance Manager

7.2.1 Viewing instance information
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BI platform lets you manage instances through the "Instance Manager" or through the "History" dialog
box for individual objects. The following tables identify the columns in each interface and describe the
instance information that is displayed.

Table 7-17: Instance information displayed in the "History" dialog box

Information displayedColumn

The time and the date of the last update for each instance.Instance Time

The title of the instances.Title

The status of each instance.Status

The user who scheduled the instance.Run By

The format in which report instances are stored. Applies to
report objects only.Format

The parameters that were or will be used for each instance.
Applies to report objects only.Parameters

The command-line options that were or will be passed to the
command line interface for each instance. Applies to program
objects only.

Arguments

Note:
Depending on the object type, other columns may appear which are not listed in the table above.

Table 7-18: Instance information displayed in the "Instance Manager"

Information displayedColumn

The title of the instance.Title

The object type.Type

The status of each instance.Status

The location of the object in the repository.Location

The user who scheduled the instance.Owner

The date and time when the instance completed its run.Completion Time

The next time the object will be run if it is on a recurring schedule and has
a status of pending.Next Run Time

The date and time at which the user scheduled the object.Submission Time

The date and time at which the object began running.Start Time
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Information displayedColumn

The duration of the scheduled job.Duration (seconds)

The frequency of the scheduled job.Recurrence

The date and time when the instance finished running or failed.Expiry

The server on which the instance was run.Server

The errors, if any, that occurred and caused the object to fail.Error

Related Topics
• To view an instance
• Pausing or resuming an instance
• To delete an instance

7.2.1.1 Instance Manager

The "Instance Manager" lets you view and manage all of the instances in your BI platform deployment
from one location. You can use the Instance Manager to perform tasks such as the following:
• Find specific instances.
• Select multiple instances and perform batch operations on them (for example, pause, resume, or

delete them).
• View detailed information for a single instance.
• Diagnose and resolve system problems that are causing instances to fail.

The default view of the "Instance Manager" shows all pending instances, sorted by title. To view detailed
information about an instance, select the instance and click the Instance details icon in the toolbar.

Example: Using the "Instance Manager" for troubleshooting

An administrator logs on to the CMC, checks the "Instance Manager", and notices that several jobs
have failed. The administrator filters the list to show only failed jobs from the last two days, and notices
that they all seem to have run on the same server. The administrator sorts the list by server and verifies
that all of the failed jobs ran on the same server. The error code for each failure is the same. The
administrator views detailed information for an instance and discovers that a database connection
has been reconfigured improperly. The administrator reconfigures the database connection correctly
and returns to the "Instance Manager" to re-run all of the failed jobs.
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7.2.1.1.1 Finding specific instances in the Instance Manager

You can find specific instances in the "Instance Manager" using the options under "Find instances
meeting the following criteria". The following table describes the options that are available.

How to enableOption

Select the Parent Folder check box and browse for a repository folder. BI platform
will list all the instances in that folder.

Parent Folder

Select the Owner check box and type a user name to find instances scheduled
by that user.

Owner

Select the Status check box, and then choose one of the following status options
from the list:
• Success
• Failed
• Running
• Paused
• Pending
• Recurring

Status

Select the Object Type check box, and then choose an object type from the list.Object Type

Select the Completion Time check box, and then set the start and stop times.

Note:
For completed publication instances, it is recommended that you enable Object
Type and set it to Publication as well as setting the completion time.

Completion Time

Select the Next Run Time check box, and then set the start and stop times.Next Run Time

You can use more than one option at a time to find instances. Only instances that meet all the criteria
you have enabled will be displayed. When you have finished, click Find.

Note:
When you schedule an object to BI Inboxes, the documents that users receive in their BI Inboxes are
not considered instances. Therefore, these BI Inbox documents do not appear in the "Instance Manager".
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7.2.1.2 To manage instances for an object

Perform this task if you want to view and manage instances for a specific object. If you want to view
and manage instances for all objects, use the "Instance Manager" instead.
1. In the "Folders" management area of CMC, select an object.
2. Click Actions > History.
3. Select an instance or instances.

Note:
To refresh the list, click Refresh. In this case, you do not need to select an instance first.

4. Click either Run Now, Pause, Resume, Send to, Reschedule, or Delete.

If you click Run Now, the system schedules the object to be run immediately. The scheduled job
will have a status of Pending.

Related Topics
• Instance Manager

7.2.1.3 To view an instance

1. Select an object in the "Folders" management area of CMC.
2. Click Actions > History.
3. In the Instance Time column, click the instance you want to view.

You can also use the "Instance Manager" to view a list of instances by status or by user.

You will need to scroll to the right in order to view all the columns with default width.

Note:
You cannot sort instances using the Submission time, Start time, Duration, Recurrence, or Expiry
columns.

Related Topics
• Instance Manager
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7.2.2 Pausing or resuming an instance

You can pause and then resume an instance as needed. Pause and resume can be applied to scheduled
instances only (that is, instances that have a status of Recurring or Pending).

For example, if a Job Server is down for maintenance reasons, you may want to pause a scheduled
instance. This prevents the system from running the object, and the object from failing because the Job
Server is not running. When the Job Server is running again, you can resume the scheduled object.

7.2.2.1 To pause an instance

1. Go to the "History" dialog box for an object.
2. Select the scheduled instance you want to pause.
3. Click Pause.

7.2.2.2 To resume a paused instance

1. Go to the "History" dialog box for an object.
2. Select the scheduled instance you want to resume.
3. Click Resume.

7.2.3 To delete an instance

You can delete instances from an object as needed. You can delete both scheduled instances, which
have a status of recurring or pending, and report or program instances, which have a status of success
of failed.
1. Go to the "History" dialog box for an object.
2. Select the instance or instances you want to delete.
3. Click Delete.
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7.2.4 To set limits for instances

You set limits to automate regular clean-ups of old instances. At the object level, you can limit the
number of instances that remain on the system for the object or for each user or group; you can also
limit the number of days that an instance remains on the system for a user or group.

In addition to setting the limits at the object level, you can also set limits at the folder level. When you
set limits at the folder level, these limits will be in effect for all objects located within the folder (including
any objects found within the subfolders).

Note:
When you set the limits at the object level, the object limits will override the limits set for the folder; that
is, the object will not inherit the limits of the folder.

1. In the "Folders" management area of CMC, select an object.
2. Click Actions > Limits.

The "Limits" dialog box appears.

3. Configure the limits settings.

DescriptionOption

To limit the number of instances per object, select this check box. Then,
type the maximum number of instances that you want to remain on the
system. (The default value is 100.)

Delete excess in-
stances when there
are more than N in-
stances of an object

To limit the number of instances for users or groups, click Add in this area.
Select from the available users and groups and press > to add them to
your list. Then click OK. Type the maximum number of instances in the
Instance Limit column. (The default value is 100.)

Delete excess in-
stances for the follow-
ing users/groups

To limit the number of days that instances are saved for users or groups,
click Add in this area. Select from the available users and groups and
press > to add them to your list. Then click OK. Type the maximum age
of instances in the Maximum Days column. (The default value is 100.)

Delete instances after
N days for the follow-
ing users/groups

4. Click Update.

Related Topics
• To limit instances at the folder level
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7.3 Calendars

A calendar is a customized list of run dates for scheduled jobs. When you apply the calendar to a job,
BI platform runs the job on the predefined run dates you have specified.

Calendars allow users to create more complex processing schedules than standard scheduling options
allow.

Note:
Calendars can be used for any object you can schedule including report objects, program objects, and
object packages.

You can set up as many calendars as you want in BI platform.

Calendars and processing schedules
Calendars make it easy for you to schedule complex recurring jobs efficiently. Calendars are particularly
useful when you want to run a recurring job on an irregular schedule, or if you want to provide users
with sets of regular scheduling dates to choose from. Calendars also allow you to create more complex
processing schedules, combining unique scheduling dates with recurring ones.

Example: Non-run calendars for holidays

If you want a report object to run every business day except for your country's statutory holidays, you
can create a calendar with the holidays marked as “non-run” days, on which the report object cannot
be run. BI platform will run the job every day you have specified as a “run” day in your calendar.

7.3.1 To create a calendar

Perform this task to create a new calendar.

Tip:
It is good practice to create a calendar for users to use as a template for creating new calendars. They
can copy this template calendar and modify it as necessary. For example, you can create a default
Weekdays calendar that includes all days as run dates except weekends and company holidays.

1. Go to the "Calendars" management area of the CMC.
2. Click Manage > New > New Calendar.
3. Type a name and description for the new calendar.
4. Click OK.

The new calendar is added to the system. You can now add run dates to this calendar.
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When the calendar is created, you can add run dates to it using the Dates tab.

Related Topics
• To add dates to a calendar

7.3.2 To add dates to a calendar

You can add dates to a calendar using a number of different formats. You can choose specific dates
using a yearly, quarterly, or monthly view of the calendar, or you can choose recurring dates using
general formats based on the day of the month or week.
1. Go to the "Calendars" management area of CMC.
2. Select the calendar you want to change.
3. Click Actions > Select Dates.
4. Choose a calendar format option (Yearly,Quarterly, orMonthly); alternatively, if you want to create

a calendar with recurring dates, click By day of month or By day of week.
5. Click the days of the month that you want to include as run days for the calendar.

To remove a run day, click the day again.

Tip:
To select a week, or all of the particular weekdays in a month, you can click the row or column
header.

6. When you are finished, click Save.

Note:
When you change an existing calendar, BI platform checks all currently scheduled instances in your
system. Objects that use the edited calendar are automatically updated to run on the revised date
schedule.

7.3.2.1 Calendar format options
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DescriptionCalendar format option

Yearly displays the calendar's run dates for the
year. To change the year displayed, click the
Previous year and Next year buttons. To add a
date using the Yearly format, click the day,
weekday header, or week row header that you
want to add.

Yearly

Quarterly displays the calendar's run dates for
the current calendar quarter. You can change the
displayed quarter using the Previous quarter
and Next quarter buttons. To add a date using
the Quarterly format, click the day, weekday
header, or week row header that you want to add.

Quarterly

Monthly displays the calendar's run dates for the
current month. You can change the displayed
month using the Previous month and Next
month buttons. To add a date using the Monthly
format, click the day, weekday header, or week
row header that you want to add.

Monthly

7.3.2.2 Specific dates

To add a specific date to a calendar, use the Yearly, Quarterly, and Monthly formats to add dates to
the calendars.

The Yearly format displays the run schedule for the entire year. The Quarterly format displays the run
dates for the current quarter. You can also view the Monthly format for the calendar, which displays
the run dates for the current month. In all three formats, you can change the displayed time range by
clicking the previous and next buttons.

You can add specific dates in any calendar format by clicking on the day you want to add. If you want
to add an entire week, click > in the row header for that week. To add run days on all of a given day of
the week in a month, click the name day of the week.
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For example, if your company ships products according to an irregular schedule that cannot be defined
using the daily or weekly settings, you can create a list of these dates in a “Shipping dates” calendar.
The Shipping department can now check the inventory after each shipment by scheduling a report that
uses the calendar to run at the end of each shipping day.

Related Topics
• Recurring dates

7.3.2.3 Recurring dates

You can add recurring dates based on the day of the week or the day of the month. To view existing
run dates, you must use the Yearly, Quarterly, or Monthly format; the generic formats must be used
to add recurring dates to the calendar. To add the recurring days, click By day of month or By day of
week and select the days you want to add.

Although you can set a recurring schedule using the standard scheduling options, calendars let you
combine different recurring run patterns at once. You can also run instances on dates that do not follow
the pattern by adding individual days to a calendar.

For example, to schedule a report object to run on the first four days of every month, and on the second
and fourth Friday of every month, first create a new calendar object and name it. Then, choose to add
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recurring days by day of month to add the first four days of the month to this calendar. When you update
the calendar, the Yearly format appears with the new run dates.

To add every second and fourth Friday to the calendar, choose to add recurring days by day of week
and select the second and fourth Friday.
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7.3.3 To delete a calendar

When you delete a calendar, any objects that are scheduled according to the deleted calendar will be
run one more time by the system. After that, the system will not be able to schedule the objects again
because the calendar no longer exists. To ensure the objects continue to be run, change the scheduling
information for the objects either by selecting a different calendar or a different recurrence pattern.
1. Go to the "Calendars" management area of the CMC.
2. Select the calendar you want to delete.

Tip:
Select multiple calendars by holding down the CTRL or SHIFT key and clicking on them.

3. Click Manage > Delete.
4. Click OK to confirm.

Related Topics
• To schedule an object
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7.3.4 Specifying calendar rights

You can grant or deny users and groups access to calendars. Depending how you organize calendars,
you can make specific sets of dates available only for certain employees or departments. For example,
your finance team may use a series of financial tracking dates that aren't useful for other departments.

Note:
Users can see only the calendars they have the rights to see; you can use rights to hide calendars that
aren't applicable to a particular group.

By default, calendars are based on current security settings. Calendars inherit rights from the users'
parent folders.

For more information about setting rights, see the “Setting Rights” chapter in the SAP BusinessObjects
Business Intelligence Platform Administrator's Guide available on the SAP Help Portal at
http://help.sap.com.

7.4 Events

Events are objects that represent occurrences in the system. Depending on the event type, they can
be used for scheduling, alerting, or monitoring system health. The "Events" management area of CMC
organizes all events into folders according to event type. Within each event type folder, you can create
subfolders to better store and manage events.

Events and scheduling
Event-based scheduling provides you with additional control over scheduling objects: you can set up
events so that objects are processed only after a specified event occurs. Working with events consists
of two steps: creating an event and scheduling an object with events. That is, once you create an event,
you can select it as a dependency when you schedule an object. The scheduled job is then processed
only when the event occurs.

You can create the following types of events to be used in conjunction with scheduling:
• File events

When you define a file-based event, you specify a filename that the Event Server monitors for a
particular file. When the file appears, the Event Server triggers the event. For instance, you might
want to make some reports dependent upon the regular file output of other programs or scripts. File
events are stored in the System Events folder.

• Schedule events

When you define a schedule-based event, you select an object whose existing recurrence schedule
will serve as the trigger for your event. In this way, schedule-based events allow you to set up
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contingencies or conditions between scheduled objects. For instance, you might want certain large
reports to run sequentially, or you might want a particular sales summary report to run only when a
detailed sales report runs successfully. Schedule events are stored in the System Events folder.

• Custom events

When you create a custom event, you create a shortcut for triggering an event manually. Custom
events are stored in the Custom Events folder.

When scheduling with events, keep in mind that an object's recurrence schedule determines how
frequently the object runs. For instance, a daily report that is dependent upon a file-based event will
run once a day (as long as the file that you specify appears every day). In addition, the event must
occur within the time frame established when you actually schedule the event-based report.

Tip:
Use file-based of events for alerting.

Automatically created events
The system automatically creates corresponding events when certain types of objects (for example,
Crystal reports) are added to the repository.

Note:
You can view these types of events in the "Events" area. However, to manage or modify these types
of events, you must have access to the corresponding event source or the relevant application.

Monitoring events
To monitor the overall health of the system, BI platform offers Monitoring events. These events
correspond to the Monitoring probes that are created and managed in the "Monitoring" area.

Related Topics
• Alerting
• Alerting
• File-based events
• Schedule-based events
• Custom events
• Scheduling an object with events

7.4.1 File-based events

File-based events wait for a particular file (the trigger) to appear before the event occurs. Before
scheduling an object that waits for a file-based event to occur, you must first create the file-based event
in the "Events" management area of the CMC. Then, you can schedule the object and select this event.

File-based events are monitored by the Event Server. When the file that you specify appears, the
Event Server triggers the event. CMC then releases any schedule requests that depend on the event.
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For example, you want daily reports to run after your database analysis program has finished and written
its automatic log file. To do this, you specify the log file in your file-based event, and then schedule your
daily reports with this event as a dependency. When the log file appears, the event is triggered and the
reports are processed.

Note:
If the file already exists prior to the creation of the event, the event is not triggered. In this case, the
event is triggered only when the file is removed and then recreated. If you want an event to be triggered
multiple times, you must remove and recreate the file each time.

Related Topics
• Scheduling an object with events

7.4.1.1 To create a file-based event

1. Go to the "Events" management area of the CMC and open the System Events folder.
File-based events are stored and managed in System Events.

2. Click Manage > New > New Event.
3. In the Type list, select File.
4. Type a name for the event in Event Name.
5. Type a description in Description.
6. In the Server list, select the Event Server that will monitor the specified file.
7. Type a file name in Filename.

Note:
Type the absolute path to the file that the Event Server should look for (for example, C:\fold
er\filename, or /home/folder/filename). The drive and directory that you specify must be
visible to the Event Server. Ideally, the directory should be on a local drive.

8. To enable Alerting for the event, select Alerting Enabled and type a message in Alert Message.
When the event is triggered, the message you enter is included in the alert notification sent to users.

9. Click OK.

7.4.2 Schedule-based events

Schedule-based events depend on scheduled objects. When a particular object has been processed,
an event is triggered based on a job being completed or on the success or failure of a scheduled object.
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Note that you must associate your schedule-based event with at least two scheduled objects. The first
object serves as the trigger for the event: when the object is processed, the event occurs. The second
object is dependent upon the event: when the event occurs, this second object runs.

For example, assume that you want report objects R1 and R2 to run after program object P1 runs. To
do this, first create a schedule-based event in the "Events" management area: specify the Success
option for the event (this means the event is triggered only when program P1 runs successfully). Next,
you schedule reports R1 and R2 with events; select your new schedule-based event as the dependency.
Schedule program P1 with events, and set program P1 to trigger the schedule-based event upon
successful completion. When program P1 runs successfully, the schedule-based event is triggered,
and reports R1 and R2 are subsequently processed.

Related Topics
• Scheduling an object with events

7.4.2.1 To create a schedule-based event

1. Go to the "Events" management area of CMC and open the System Events folder.
Schedule-based events are stored and managed in System Events.

2. Click Manage > New > New Event.

The "New Event" dialog box appears.

3. In the Type list, select Schedule.
4. Type an event name in Event Name.
5. Complete the Description field.
6. Select an event status option.

DescriptionEvent status

The event is triggered only upon successful completion of a specified object.Success

The event is triggered only upon non-successful completion of a specified
object.

Failure

The event is triggered upon completion of a specified object.Success or Fail-
ure

7. To enable Alerting for the event, select Alerting Enabled.
When the event is triggered, an alert notification is sent to users.

8. Click OK.
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7.4.3 Custom events

A custom event occurs only when you explicitly trigger it. As with all other events, an object based on
a custom event runs only when the event is triggered within the time frame established by the object's
schedule parameters. Custom events are useful because they allow you to set up a shortcut that, when
clicked, triggers any dependent schedule requests.

For instance, assume you want to schedule a number of reports to run them after you have updated
information in your database. To do this, create a new custom event, and schedule the reports with
that event. When you update the data in the database and you need to run the reports, return to the
event in the CMC and trigger it manually. BI platform then runs the reports.

Note:
You can trigger a custom event multiple times. For example, you might schedule two sets of event-based
program objects to run daily—one set runs in the morning, and one set runs in the afternoon. When
you first trigger the related custom event in the morning, one set of programs is run; when you trigger
the event again in the afternoon, the remaining set of programs is run. If you neglect to trigger the event
in the morning and trigger it only in the afternoon, both sets of programs run at that time.

Related Topics
• Scheduling an object with events

7.4.3.1 To create a custom event

1. Go to the "Events" management area of the CMC and open the Custom Events folder.
2. Click Manage > New > New Event.
3. Type a name for the event in the Event Name field.
4. Complete the Description field.
5. If you want to enable Alerting for the event, select Alerting Enabled and enter a message in the

Alert Message field.
When the event is triggered, the message you enter is included in the alert notification sent to users.

6. Click OK.

Note:
Before you trigger this custom event, schedule an object that depends on this event.

Related Topics
• To schedule an object
• To enable Alerting for an event
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7.4.3.2 To trigger a custom event

1. Go to the "Events" management area of CMC and open the Custom Events folder.
2. Select a custom event.
3. Click Actions > Trigger Event.

7.4.4 Specifying event rights

You can grant or deny users and groups access to events and event folders. You can specify events
to be available only for certain employees or departments (for example, designating certain events for
management or IT.

Users can only see events their rights allow them to see. Rights can be used to hide events that aren't
applicable to a particular group. For example, by granting only the ITadmin group access to IT-related
events, those events won't appear for a user from the HRadmin group; this makes the event list easier
for the HRadmin group to navigate.

Note:
By default, events are based on current security settings.

Rights are inherited from the users' parent folders.

Tip:
Events are sorted into folders based on event type. Within each event type folder, you can create
subfolders to provide more granular sorting for events.

For more information about rights, see the “Setting Rights” chapter in the SAP BusinessObjects Business
Intelligence Platform Administrator Guide available on the SAP Help Portal at http://help.sap.com.
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Alerting

8.1 Alerting

Alerting is a feature that spans different applications in BI platform. Alerts notify users and administrators
when events are triggered. Alerting lets you manage objects and events on the basis of exception.
Alerts notify you about changes.

For example, Julie works at an auto insurance company and tracks the number of claims filed using a
Crystal report. She subscribes to the Claim Number alert, and chooses to receive her alert notification
by email. The report runs daily. After a week, the number of auto insurance claims reaches 10,000,
meeting the alert's condition and triggering the alert. Julie receives an email notification and realizes
that auto insurance claims have increased dramatically. She informs her manager and recommends
launching a campaign to promote safer driving habits.

Subscribing to alerts
In BI platform, users and administrators can subscribe to alerts using the Central Management Console
(CMC) or BI launch pad.

Enabling alerts
When new reports are created, report designers enable alerts. As events are triggered, notifications
are sent to the subscribers' email addresses or a BI system destination (for example, a BI launch pad
account).

Viewing alert notifications
In BI platform, users and administrators view notifications in BI launch pad or their email.

Right-click on an alert and select See More. The Alert information window appears showing the title,
message and trigger time.

Managing alerts
Content administrators and power users manage alerts in the CMC or BI launch pad. System
administrators manage alerts in CMC and control user access by assigning rights.

8.1.1 Alerting object sources
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DescriptionObject

Crystal reports can contain multiple alerts. When you add a report
containing alerts to the repository, BI platform automatically cre-
ates event objects that correspond to each alert in the report. In
the Central Management Console, these events are listed in the
Crystal Reports Events folder, in the Events area. You
can also search for them using the Content Search option.

Note:
Only reports created in BI platform support alerting and allow
users to subscribe to alert notifications when the reports are
added. To subscribe, navigate to the report and perform the
subscription task on the report object.

Crystal reports

You can enable alerting for any event.Events (file-based, schedule-based,
and custom)

Note:

• Monitoring uses alerting to notify system administrators of changes in the overall health of the system.
Alerts based on monitoring probes can be found in the Monitoring Events folder, in the Events
area. For more information about monitoring, see the SAP BusinessObjects Business Intelligence
Platform Administrator Guide at http://help.sap.com.

• Objects created in applications such as Information Steward and Event Insight also use alerting.
For more information, see the documentation for the application.

8.1.2 Alerting workflow

The alerting workflow involves various steps, applications, and types of users.

The Alerting workflow for Crystal reports
1. The report creator designs a report that contains alerts in SAP Crystal Reports for Enterprise.
2. The report creator or a content administrator adds the Crystal report to a folder in the "Folders" or

"Personal Folders" area of the Central Management Console (CMC). When the report is added, the
system automatically creates report event objects based on the alerts in the report.

3. The user logs on to the CMC or BI launch pad, navigates to the Crystal report, and subscribes to
the alert.

4. The report creator or a content administrator schedules the Crystal report to run. If the alert condition
is met, the alert is triggered and the user receives notification according to their subscription settings.

The Alerting workflow for events
1. The content administrator creates an event in the CMC and enables Alerting on the new event.
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2. The user sees the alert in the "Events" area of the CMC, or searches for the alert by name in BI
launch pad, and subscribes to it.

3. The event occurs, triggering the alert.
4. The user receives notification that the event has occurred according to their subscription settings.

8.1.3 Differences between alerting and Crystal report alert notifications

In previous versions of BI platform, you could configure alert notifications for Crystal reports when you
scheduled them. BI platform still supports this functionality for reports created in Crystal Reports. The
following table summarizes the key differences between the previous alert notification functionality and
alerting.

AlertingCrystal report alert noticationsKey differences

• Reports created in SAP Crystal Re-
ports only

• Events
• Monitoring probes
• Information Steward alerts
• Event Insight alerts

Reports created in SAP Crystal
ReportsSupported objects

• My Alerts in BI launch pad
• EmailEmail onlySupported destinations

You subscribe to alert notifications from
the alert source, and change subscrip-
tions as needed. Recipients can include
Enterprise users and users who do not
have BI platform accounts. You must
enter email addresses manually for
users without accounts.

You configure this functionality
when you configure scheduling
for a Crystal report. All recipients'
email addresses must be entered
manually. Recipients can include
Enterprise users and users who
do not have BI platform accounts.

Usage

8.1.4 Rights required for Alerting

Depending on your role in the Alerting workflow and your responsibilities, the rights you need may vary.
The following tables summarize the rights required for common Alerting tasks.

2012-11-06125

Alerting



Table 8-2: Working with document alerts

Rights requiredTaskRole

• View right on the document
• View right on the corresponding event
• Subscribe right on the user's own account

Note:
If the user intends to view an instance using a
document link in the alert notification, the user
also requires the View Instance right on the
document.

Subscribe to a document
alertUser

• View right on the corresponding event
• Subscribe right on the user's own account

Unsubscribe from a docu-
ment alertUser

• View right on the corresponding event
• View right on the document

Receive notification for a
document alertUser

• Edit right on the document
• Edit right on the event

Manage destination and pa-
rameter settings for a docu-
ment alert

Content administra-
tor

• View and Edit rights on the document
• View and Edit rights on the corresponding

event
• View and Subscribe rights on any users or

groups to be added as subscribers

Note:
If you want to add a user group to the list of
subscribers, you must have View and Subscribe
rights on the user group object. Having View and
Subscribe rights on individual users within the
group is insufficient.

Manage Alerting settings for
a document

Content administra-
tor

• View right on the document
• View right on the corresponding event
• View and subscribe rights on the user

Unsubscribe a user from a
document alert

Content administra-
tor

• View and Schedule rights on the document
• View and Trigger rights on the corresponding

event
Trigger a document alertContent administra-

tor
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Table 8-3: Working with event alerts

Rights requiredTaskRole

• View right on the event
• Subscribe right on the user's own account

Note:
By default, Subscribe rights are granted to users
on their own accounts.

Subscribe to an event alertUser

• View right on the event
• Subscribe right on the user's own account

Note:
By default, Subscribe rights are granted to users
on their own accounts.

Unsubscribe from an event
alertUser

• View and Edit rights on the event
• View and Subscribe rights on any users or

groups to be added as subscribers

Note:
If you want to add a user group to the list of
subscribers, you must have View and Subscribe
rights on the user group object. Having View and
Subscribe rights on individual users within the
group is insufficient.

Manage Alerting settings for
an event

Content administra-
tor

• View and Trigger rights on the eventTrigger an eventContent administra-
tor

Table 8-4: Working with alert notifications

Rights requiredTaskRole

• View right on the corresponding eventReceive an alert notificationUser

• View right on the alert notification
• Subscribe right on the user account

Mark an alert notification as
read or unreadUser

• View right on the alert notificationReread an alert notificationUser

• View right on the alert notification
• Subscribe right on the user account

Delete an alert notification in
BI launch padUser
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8.1.5 Resolving subscription conflicts

As a result of group membership, users can have subscription settings that cause conflicts. When
subscription setting conflicts occur, Alerting resolves them in the following ways:
• A setting made on a user overrides any settings inherited from group membership.
• A setting made on a subgroup overrides any settings inherited from a group.

A user can inherit different subscription settings from two hierarchically equal groups. In this situation,
the user receives alert notifications according to each setting.

Note:
Being listed on the Excluded list overrides all other subscription settings. If a user is subscribed to alerts
but is on the Excluded list, the user does not receive alert notifications.

Example: Subscription settings from two hierarchically equal groups

Julie belongs to the North America Sales group and the South America Sales group, neither of which
is a subgroup of the other. The North America Sales group receives Revenue alert notifications in
their email and BI Inboxes, while the South America Sales group receives Revenue alert notifications
in their email only. As a result of her membership in both groups, Julie receives Revenue alert
notifications in her email and her BI Inbox. If the report has defined parameters (for example, regional
parameter values of “North America” and “South America”), Julie receives separate email alert
notifications; otherwise, the alerts are combined into one email.

8.2 Working with Alerting

8.2.1 Locating alert source objects in the Central Management Console

Alert sources are stored in different locations according to their object type. The following table
summarizes how to locate different alert sources.
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Location in the CMCObject (alert source)

"Folders" or "Personal Folders" area

A list of all Crystal report alerts in the system that support alerting
is available in the Crystal Reports Events folder in the
"Events" area of the CMC. To subscribe to an alert, locate the
Crystal report in the "Folders" or "Personal Folders" area.

Crystal reports

"Events" area

Events are organized by event type. Alerting-enabled events are
indicated by a icon.

Events (file-based, schedule-based,
and custom)

8.2.2 To enable Alerting for an event

Alerting is automatically enabled for a Crystal report that contain alerts: users can subscribe to report
alerts as soon as the report is added to the repository. Enabling alerting for events requires additional
steps such as enabling an alert when a new event is created.
1. In the "Events" area of the CMC, select the event for which you want to enable Alerting.
2. Click Manage > Properties.

The "Properties" dialog box appears.

3. Click Event Settings on the navigation pane.
4. Select Alerting Enabled and enter a message in the Alert Message field.

This message will be sent to subscribers when the alert is triggered.

Note:
You cannot enter messages for schedule-based events.

5. Click Save & Close.

8.2.3 To subscribe to an alert

1. Navigate to the alert source and select it.
For more information, see Locating alert source objects in the Central Management Console.

2. Click Actions > Subscribe.
The "Subscribe" dialog box appears.
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3. Select your destination.

DescriptionOption

Sends the alert notification to a destination in the Business Intelligence system
(for example, BI launch pad).

My Alerts

Sends the alert notification to the email address specified for your user account
in BI platform.

Note:

• This destination is available only if an email address was specified for your
user account.

• Ensure that your email address is valid and entered correctly; otherwise,
you will not receive the alert notification.

Email

4. Configure other settings as required.
Depending on the alert source, you may have to configure additional settings. For example, for
Crystal reports that contain multiple alerts, you must select which alert to subscribe to.

5. Click Save & Close.

The next time the alert is triggered, notification will be sent to the destination you selected. To change
which destinations the alert notification will be sent to, select the alert source and clickActions >Modify
Subscription. You can also use Actions > Modify Subscription to change which Crystal report alerts
to subscribe to.

Notifications are sent using the destination defaults set for the Alerting application unless you specify
custom settings for the alert source.

Related Topics
• To manage Alerting settings for an alert source

8.2.4 To unsubscribe from an alert

Perform this task to unsubscribe yourself from an alert.
1. Navigate to the alert source and select it.
2. Click Actions > Unsubscribe.
3. When prompted for confirmation, click Unsubscribe.

Related Topics
• Locating alert source objects in the Central Management Console
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8.2.5 To subscribe other users to an alert

1. Navigate to the alert source and select it.
2. Click Actions > Manage Subscribers.

The "Manage Subscribers" dialog box appears.

3. Ensure Subscriber List is selected on the navigation pane.
4. If you want to add new subscribers, do the following:

a. Click Add.
b. In the "Add" dialog box, move users and groups from the Available list to the Subscribed list,

and click Add Default Subscription(s).
c. Configure other Alerting settings as required.

For example, you can modify which alerts to subscribe to (if the alert source contains multiple
alerts) and the destinations. Depending on the alert source, other settings may be available.

d. Click Save & Close.

5. If you want to edit settings for a subscriber, do the following:
a. Select a subscriber on the "Subscriber List" and click Edit.

The "Edit Subscriptions" dialog box appears.
b. If you want to edit which alerts the subscriber will receive, click Alerts on the navigation list and

select the relevant alerts.
If the alert source contains multiple alerts, they are all listed here; otherwise only one alert appears.

c. If you want to edit which destinations an alert will be sent to, click Destinations on the navigation
list and select the relevant destinations.

If the email destination has been enabled and configured on the Adaptive Job Server, it will be
available; otherwise, only My Alerts is available.

d. Configure other alerting settings as required.
Depending on the alert source, you may have to configure additional settings.

e. Click Save & Close to return to the Subscriber List.

6. After you have made all your changes, in the "Manage Subscribers" dialog box, click Save & Close.

Related Topics
• Locating alert source objects in the Central Management Console

8.2.6 To unsubscribe others from an alert
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1. Navigate to the alert source and select it.
2. Click Actions > Manage Subscribers.

The "Manage Subscribers" dialog box appears.

3. Ensure Subscriber List is selected on the navigation pane.
4. Select a user or group and click Unsubscribe.

Related Topics
• Locating alert source objects in the Central Management Console

8.2.7 To exclude users from an alert

Follow these steps to exclude users from an alert.

Note:
Excluding users is useful if you want to subscribe only a handful of users in a group. Using this procedure,
you subscribe the entire group and then exclude those users who do not want to receive alert
notifications. Being on the Excluded list overrides all other subscription settings for a user.

1. Navigate to the alert source.
2. Click Actions > Manage Subscribers.

The "Manage Subscribers" dialog box appears.

3. Ensure Excluded List is selected on the navigation pane.
4. Move users and groups from the Available list to the Excluded list.
5. Click Save & Close.

Related Topics
• Locating alert source objects in the Central Management Console

8.2.8 To manage Alerting settings for an alert source

Notifications are sent using the default destination settings set for the Alerting application unless you
specify other settings. Follow these steps to manage settings for an alert source.
1. Navigate to the alert source.
2. Click Actions > Manage Alerting Settings.

The "Manage Alerting Settings" dialog box appears.

3. To enable BI launch pad as a destination, select Enable My Alerts.
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This option allows alert notifications to be sent to subscribers' BI launch pad accounts and allows
subscribers to view them under My Alerts.

4. To enable email as a destination, select Enable Email, and then choose whether to use default or
custom email settings.
The default settings are those set for Alerting in the "Applications" area. For custom email settings,
set the following options, if applicable:
• From
• To
• Cc
• Bcc
• Subject
• Message
• Add Attachment
• "File Name" (Automatically Generated or Specific Name)

5. Click Save & Close.

Related Topics
• Locating alert source objects in the Central Management Console

8.2.9 Alerting management recommendations

Follow these best practices to ensure that Alerting works optimally:
• For Crystal report alerts, avoid renaming alerts. BI platform interprets a renamed Crystal report alert

as a new object; any subscription settings you had made for the alert will be lost.
• Subscribe to specific groups instead of the Everyone group.
• For high-volume alerts, use email as a destination instead of BI launch pad. Alert messages sent

to BI launch pad are stored in the system. Accumulated alert messages can interfere with system
performance.
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Managing Profiles

9.1 How profiles work

Profiles work together with publications to personalize content.

Profiles as objects
Profiles are also objects in BI platform that let you classify users and groups. Profiles link users and
groups to profile values, which are used to personalize data within a report. Profiles also use profile
targets, which describe how a profile is applied to a report. By assigning different profile values, the
data within a report can be tailored to specific users or groups. Many different personalized versions
of the report are then delivered to your users.

Profiles and roles
Often profiles reflect the roles of users and groups in an organizational structure. For example, you
could have a Department profile that includes all employees in an organization. The users and groups
each have profile values that reflect their roles in the organization (for example, “Finance”, “Sales”, and
“Marketing”). When a publisher applies the Department profile to a publication, the employees receive
data that is relevant to their department.

Profiles and document content
Profiles are used to refine or filter a document's content; profiles do not control access to data. When
you use profiles to display a subset of the data to a user, it is not the same as restricting the user from
seeing that data. If users have the appropriate rights and access to the document in its original format,
they may still see the complete data for the document by viewing it in BI launch pad or the CMC. Profiles
filter data views without changing or securing the data being queried from the data source.

9.1.1 Profiles and the Publishing workflow

Using a profile to personalize a publication is a two-part process. First,create the profile in the "Profiles"
area of CMC. Creating a profile involves these tasks:
1. Create a profile.
2. Add users and groups to the profile.
3. Assign profile values to each user and group for that profile.
4. Specify a global profile target if necessary.
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When you create the publication, you perform these tasks:
1. Add users and groups as recipients.
2. Specify a local profile target for the profile to filter (for example, a field in a Crystal report).
3. Specify the profile(s) to use for personalization.

Related Topics
• Personalization

9.1.2 To create a profile

1. Go to the "Profiles" management area of the CMC.
2. Click Manage > New > New Profile.

The "Create New Profiles" dialog box appears.

3. Type a name for the profile in the Title field.
4. Complete the Description field.
5. Click OK.

Related Topics
• Profile targets and profile values
• To specify a profile value
• Specifying profile rights

9.2 Profile targets and profile values

To use a profile to personalize a publication, you must set profile values and profile targets for the
profile.

Profile targets
Profile targets are data sources that profile values filter and interact with to provide personalized
publications. There are two types of profile targets:
• Local profile target

A local profile target can be a variable in a Web Intelligence document, or a field or parameter in a
Crystal report. When you use a local profile target, the source document that contains the local
profile target is filtered for the publication recipients.

• Global profile target
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A global profile target can be a universe. You must also specify an object within that universe. This
type of profile target can filter all source documents that use the universe.

Note:
You can use global profile targets for publications that contain Web Intelligence documents. You
cannot use global profile targets with Crystal reports.

Profile values
Profile values are attributes detailed to specific users or groups when you assign these users and groups
to a profile. When a profile is applied to a publication, the users and groups assigned to that profile
receive versions of the publication that are filtered according to the profile values set for them.

Note:
If you assign profile values to both users and groups, note that inheritance works the same way for
profiles as it does for security settings. For more information, see the “Setting Rights” chapter in the
SAP BusinessObjects Business Intelligence Platform Administrator Guide available on the SAP Help
Portal at http://help.sap.com.

Using profile targets and profile values
Profile targets and profile values enable a profile to personalize a publication for recipients. The users
and groups specified for a profile receive filtered versions of the same publication that only display the
data most relevant to them.

Consider a situation where a global sales report is distributed to a company's regional sales teams in
North America, South America, Europe, and Asia. Each regional sales team only wants to view the
data that is specific to their region. The administrator creates a Regional Sales profile and adds each
regional sales team to the profile as a group. The administrator assigns each regional sales team a
corresponding profile value (for example, the North America Sales group is assigned “North America”).
During Publishing, the publisher uses the Region field in the global sales report as a local profile target,
and applies the profile to the report. The global sales report is filtered according to the profile values
set for each regional sales team. When the global sales report is distributed, each regional sales team
receives a personalized version that only displays regional sales data.

9.2.1 To specify a global profile target

This task lets you specify a global profile target for a profile. Local profile targets are specified during
the Publishing process.
1. In the "Profiles" area of the CMC, select the profile that you want to specify a profile target for.
2. Click Actions > Profile Targets.

The "Profile Targets" dialog box appears.

3. Click Add.
4. Select a universe from the Universe Name list.
5. Enter a class name in the Class Name field, or click Select object from the universe.
6. Enter a variable name in the Variable Name field, or click Select object from the universe.
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7. Click OK.

9.2.2 Specifying profile values

You can use static values, expressions, or variables as profile values.

Static values are the most common profile value type and can be used to filter any source document
type. You can also enter multiple static values for a user or group for one profile. For example, a manager
interested in receiving data from several departments can have “Production”, “Design”, and “Marketing”
as static profile values for a Department profile.

Expressions use syntax that is specific to certain source document types. You can use SAP Crystal
Reports and Web Intelligence expressions to perform more complex personalization and filtering.
Expressions are useful if you want to filter a range of values, or a range of values greater than or less
than a given value, for a user.

If you want to use user information as profile values, you can use variables for user names, full names,
and email addresses. These variables are mapped to user information and act as placeholders. When
you apply the profile to a publication, the system retrieves the most recent information for users.

Profile value variables are useful because they decrease administrative costs and possible errors
associated with entering information manually. Consider a situation where an administrator maps an
AD user to the system and adds the user to two profiles. Instead of entering the information manually
for each profile value and possibly making typographical errors, the administrator can specify which
variables to use for the user's data.

For third-party users, if the user's information changes in an external system, the data in BI platform
can be updated to reflect those changes when a publication is run.

Tip:
If you have a third-party user account with data that should not be overwritten by user attributes in an
external directory, open the "Properties" dialog box for the user object and clear the Import full name
and email address check box.

Note:
Static-value profile values can filter string fields in source documents only. If you map the incorrect type
of field to the profile, personalization will fail.

9.2.2.1 To specify a profile value

This task lets you specify a profile value for a user or group.
1. In the "Profiles" area of the CMC, select a profile.
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Tip:
Alternatively, you can select a user or group in the "Users and Groups" area.

2. Click Actions > Profile Values.
The "Profile Values" dialog box appears.

3. Click Add.
4. Click Choose.
5. Select a user or group or multiple users or groups, and click > to move them into the list on the right

side.
6. Click OK.
7. Enter a profile value for the selected user or group or multiple users or groups.

You can use several different types of profile values. You can enter a static profile value or an
expression. You can also specify variable profile values for third-party users and groups mapped to
the system.
• If you want to use a value:

a. Click Value.
b. Enter a value in the New Value field.
c. Click Add.

Tip:

• You can add multiple static values for a user or group. Repeat steps 1-3 for each static value
that you want to add.

• You can use %NULL% as a static profile value if the user or group does not have values that
the profile can filter for personalization.

• If you want to use a filter expression:
a. Click Filter Expression.
b. Depending on the type of expression you want to use, enter an expression in the Web

Intelligence formula expression field or the Crystal reports expression field.

Note:
To use a Web Intelligence expression, you must first specify a global profile target for the
profile.

Tip:
If you want to apply the profile to multiple document types, you can enter filter expressions in all
three fields.

8. Click OK.

Related Topics
• To use variables as profile values
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9.2.2.2 To use variables as profile values

This task lets you specify variable profile values for users when you add them to a profile. You can
specify variable profile values for the user's full name, account name, or email address.
1. In the "Profiles" area of CMC, select the profile that you want to add the user or group to.
2. Click Actions > Profile Values.

The "Profile Values" dialog box appears.

3. Click Add.
4. Click Choose.
5. Select the user or group from the list on the left, and click > to move the user or group to the list on

the right.
6. Click OK.
7. Click Value.
8. Select a placeholder variable from the Add placeholder list, and click Add.

The following table summarizes the variables that can be used for the externalization of profiles.

DescriptionVariable

This variable is associated with the user's account name.Title

This variable is associated with the user's full name.User's full name

This variable is associated with the user's email address.E-mail address

Tip:
These variables can also be used for groups. You can map the E-mail address variable to a
common email address for the entire group. When you do this, the system resolves the variable and
retrieves individual email addresses for each member of the group.

The placeholder appears in the Existing values field.

9. Click OK.

When you use the profile to personalize a publication, the profile value for the third-party user will update
itself with the most recent user information. For example, if the user's email address has changed since
the last time the publication was run, the email address used for the profile value will change the next
time the publication runs.

9.3 Resolving conflicts between profiles
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Conflicts between profiles can arise when users and groups are assigned to multiple profiles. If a
document is delivered to a user that has two profiles that conflict, the conflict must be resolved.

For example, Tony is a product manager in the Mexico office. He is assigned a profile called Region
that personalizes his documents to show only data from Mexico. He is also assigned a profile called
Management that personalizes his documents to show data for product managers.

If a document uses both of these profiles, which data will Tony see? According to one profile, he'll see
data for Mexico. According to the other profile, he should see only data for product managers.

You can resolve this conflict in two ways in BI platform:
• Do not merge

BI platform determines all possible views of a publication and produces a unique view for each one.
In the example, Tony would receive one publication personalized to show data for Mexico, and
another publication that shows product manager data.

• Merge

If you choose Merge, BI platform determines the different possible data views and merges
non-conflicting profiles. This type of profile resolution is designed for role-based security. In the
example, Tony would receive a single publication personalized to show data for Mexican product
managers.

Note:
This “do not merge/merge” scenario applies to inherited profile values only. If a user is assigned two
profile values explicitly, the publication instances are always merged.

Related Topics
• To specify a profile resolution method

9.3.1 Conflicts between profile values

Conflicts between profile values can arise when a user inherits two contradictory profile values as a
result of group membership. In general, explicitly assigned profile values override profile values inherited
from group membership. A profile value assigned to a user or a subgroup overrides the profile value
inherited from group membership.

For example, David belongs to the North America Sales and Canada Sales groups. The Canada Sales
group is a subgroup of the North America Sales group. These groups are both added to the Region
profile. From the North America Sales group, David inherits a Region profile value of “North America”,
and from the Canada Sales group, David inherits a Region profile value of “Canada”. In this case, the
profile value that is assigned to the subgroup overrides the profile value that is assigned to the group,
and David receives a publication with data for Canada.

Conflicts between profile values can also arise when a user is explicitly assigned a profile value that
contradicts a profile value inherited from group membership. For example, Paula belongs to the North
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America Sales group, which has a Region profile value of “North America”. The administrator also
assigns Paula a Region profile value of “Spain”. In this case, the profile value that is assigned to the
member overrides the profile value that is inherited from the group, and Paula receives a publication
with data for Spain.

However, sometimes a user can inherit different profile values from two different groups for one profile.
Both groups are hierarchically equal; one group is not a subgroup of the other group, so one profile
value does not override the other. In this case, both profile values are valid and the user receives a
publication instance for each profile value.

As a result of this profile value conflict, sometimes duplicate report instances are included in different
publication instances and sent to the same user. For example, Sandra is a manager in two North
America offices and receives a publication via email that contains two reports. Report 1 is personalized
using the Region profile, for which Sandra inherits the conflicting profile values “USA” and “Canada”
from group membership. Report 2 is personalized using the Role profile, for which Sandra inherits the
profile value “Manager”. If there is no profile value conflict, after personalization, Sandra receives one
email with a merged Report 1 instance (USA and Canada data) and a Report 2 instance (Manager
data). Instead, Sandra receives two emails: one email includes a Report 1 USA instance, the other
email includes a Report 1 Canada instance, and both emails have the same Report 2 Manager instance.

Tip:
To avoid profile value conflicts that result in duplicate publication instances being sent, when possible,
explicitly assign profile values to users instead of allowing users to inherit profile values from group
membership.

9.4 Specifying profile rights

You can grant or deny users and groups access to profiles. Depending on how you organize your
profiles, you may have specific profiles that you want to be available only for certain employees or
departments.

Users with access to CMC will only be able to see profiles they have the rights to see, so you can use
rights to hide profiles that aren't applicable to a particular group. For example, by granting only the
ITadmin group access to IT-related profiles, those profiles won't appear for a user from the HRadmin
group; this makes the profile list easier for the HRadmin group to navigate.

For more information about the rights model in BI platform, see the “Setting Rights” chapter in the SAP
BusinessObjects Business Intelligence Platform Administrator Guide available on the SAP Help Portal
at http://help.sap.com.
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Publishing

10.1 About publishing

Publishing makes documents, such as Crystal reports and Web Intelligence documents, available
automatically via email or FTP server, saved to disk, and managed through BI platform (for web viewing,
archiving, retrieval, and scheduling). In BI launch pad or the CMC, you can tailor documents for different
users or recipients, schedule the documents to run at intervals, and send the documents to a multiple
destinations, including BI Inboxes and email addresses.

10.2 What is a publication?

A publication is a collection of documents intended for distribution to a mass audience. Before the
documents are distributed, the publisher defines the publication using a collection of metadata. This
metadata includes the publication source, its recipients, and the personalization applied.

Publications can help you send information through your organization more efficiently:
• They allow you to easily distribute information to individuals or groups of users and personalize the

information each user or group receives.

• They provide delivery of targeted business information to groups or individuals through a
password-protected portal, across an intranet, an extranet, or the Internet.

• They minimize database access by eliminating the need for users to send process requests
themselves.

You can create different types of publications based on Crystal reports or Web Intelligence documents.

10.3 Publication concepts

2012-11-06143

Publishing



10.3.1 Report bursting

During Publishing, the data in documents is refreshed against data sources and personalized before
the publication is delivered to recipients. This combined process is known as “report bursting”. Depending
on the size of the publication and how many recipients it is intended for, you have several report bursting
methods to choose from:
• One database fetch for all recipients

When you use this report bursting method, all documents in the publication are refreshed once, and
then the documents are personalized and delivered to each recipient. This report bursting method
uses the data source logon credentials of the publisher to refresh data.

This is the default option for Web Intelligence document publications. It is also the recommended
option if you want to minimize the impact of Publishing on your database. This option is secure only
when the source documents are delivered as static documents. For example, a recipient who receives
an Web Intelligence document in its original format can modify the document and view the data
associated with other recipients. However, if the document is delivered as a PDF, the data would
be secure.

Note:

• This option is secure for most Crystal reports regardless of whether the Crystal reports are
delivered in their original format.

• The performance of this option varies depending on the number of recipients.
• One database fetch for each batch of recipients

When you use this report bursting method, the publication is refreshed, personalized, and delivered
to recipients in batches. This report bursting method uses the data source logon credentials of the
publisher to refresh data. The batches are based on the personalization values you specified for the
recipients. The batch size varies depending on the specified personalization value and is
non-configurable.

This is the default option for Crystal report publications. It is also the recommended option for
high-volume scenarios. With this option, you can process batches concurrently on different servers,
which can greatly decrease the processing load and time required for large publications.

Note:
This option is unavailable for Web Intelligence documents.

• One database fetch per recipient

The data in a document is refreshed for every recipient. For example, if there are five recipients for
a publication, the publication is refreshed five times. This report bursting method uses the data
source logon credentials of the recipient to refresh data.

This option is recommended if you want to maximize security for delivered publications.
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Note:
Crystal reports that are based on universes or Business Views support One database fetch per
recipient only to maximize security.

Related Topics
• To specify a report bursting method

10.3.2 Delivery rules

Note:
This feature is unavailable for Web Intelligence documents.

“Delivery rules” affect how documents in publications are processed and distributed. When you set
delivery rules on documents, you indicate that the publication will be delivered to recipients only if the
content in the documents meets certain conditions. There are two types of delivery rules:
• Recipient delivery rule

If the data in the recipient's instance meets the delivery rule, the instance is delivered to the recipient.

• Global delivery rule

If the data in a designated document meets the delivery rule, the publication is delivered to all
recipients.

Note:
The designated document for a global delivery rule can be different from the document or documents
used in a publication. For example, you can set a global delivery rule on a document used as a
dynamic recipient source instead of a document in the publication.

If a publication has recipient and global delivery rules, the global delivery rule is evaluated first to
determine whether the publication will be processed. If the publication meets the global delivery rule,
the system then evaluates the recipient delivery rules to determine which instances to process and
distribute for each recipient.

How you set delivery rules depends on the document type that you want to publish. For Crystal reports,
you specify a delivery rule based on a named alert that the report designer creates in the Crystal report.
You can also set a delivery rule based on whether the personalized publication contains any data.

The diagram “Global delivery rule met” illustrates how an alert-based global delivery rule works. Here
the global delivery rule is set on a document in the publication. The Crystal report has a Revenue alert
for values greater than 100,000. The publisher creates a global delivery rule based on the Revenue
alert so that the Crystal report is only delivered to all recipients if revenue exceeds 100,000. In this case
the delivery rule is met, so the Crystal report is delivered.
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Figure 10-1: Global delivery rule met

The diagram “Recipient delivery rule unmet” illustrates how a recipient delivery rule works. The publisher
sets a recipient delivery rule for the Crystal report so that the report is delivered to recipients only if the
report contains data for that recipient. When the report is personalized for each recipient, Green Recipient
does not have data in the Crystal report. This means that only Blue Recipient and Orange Recipient
receive the publication.

Figure 10-2: Recipient delivery rule unmet

For publications that contain multiple documents and objects, each document can have its own recipient
delivery rule. When you do this, you have the following options for processing and delivery:
• If a document in the publication fails to meet its recipient delivery rule for a recipient, the entire

publication will not be delivered for that recipient.
• If a document in the publication fails to meet its recipient delivery rule for a recipient, that document

will not be delivered, but all other documents in the publication will be delivered for that recipient.

Delivery rules are useful because they allow publications intended for a large number of recipients to
be processed and distributed more efficiently. Consider a situation in which a publisher at an insurance
company creates a publication for its clients that contains the following objects:
• An insurance bill (personalized Crystal report).
• A monthly statement (personalized Crystal report).
• A payment methods brochure (PDF).
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In the insurance bill, there is an Amount Due alert for values greater than zero. The publisher creates
an Amount Due recipient delivery rule for the insurance bill so that the insurance bill is published and
distributed only if a client owes a payment. The publisher also specifies that the entire publication will
not publish if the insurance bill fails to meet the delivery rule because he does not want clients to receive
a monthly statement and a brochure when they do not have to pay a bill. When the publication is run,
the publication is processed and distributed only to clients who owe payments.

Note:
If a Crystal reports publication is scheduled to print when the publication runs, the print job occurs
regardless of whether a document in a publication fails to meet a delivery rule and is not delivered to
a recipient. This is because print jobs are processed during personalization, and delivery rules are
applied to publications after personalization.

Related Topics
• To set a global delivery rule on a Crystal report
• To set a recipient delivery rule on a Crystal report

10.3.3 Dynamic recipients

Dynamic recipients are publication recipients who exist outside of BI platform. Dynamic recipients
already have user information in an external data source, such as a database or an LDAP or AD
directory, but do not have user accounts in BI platform

To distribute a publication to dynamic recipients, use a dynamic recipient source which is a document
or custom data provider that provides information about publication recipients outside of BI platform.
Dynamic recipient sources allow you to easily maintain information for dynamic recipients by linking
directly to the external data source and retrieving the most recent data. They also decrease administrative
costs because you do not have to create BI platform user accounts for dynamic recipients before you
distribute publications to them.

Consider a situation in which a billing company distributes bills to customers who are not BI platform
users. The customer information already exists in an external database. The publisher creates a
document based on the external database and uses the document as a dynamic recipient source for
a publication. Customers receive the billing publication, and the dynamic recipient source allows the
publisher and the system administrator to maintain up-to-date contact information.

You can do the following with a dynamic recipient source:
• Deliver a single publication to dynamic recipients and BI platform users simultaneously.

Note:

• Only one dynamic recipient source can be used per publication.
• Dynamic recipients cannot unsubscribe themselves automatically from a publication.

• Preview dynamic recipients list when you create a publication.
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• Specify whether you want to deliver a publication to all dynamic recipients, or to include or exclude
certain dynamic recipients.

• Deliver publications to external destinations such as email or an FTP server.

Note:
BI Inboxes are invalid destinations for dynamic recipients because they do not have user accounts
in BI platform.

To use a dynamic recipient source, specify a column for each of the following values:
• Recipient ID (required)
• Full name of recipient
• Email address

The recipient ID column determines the number of dynamic recipients who will receive the publication.
It is recommended that you sort the dynamic recipient source according to recipient ID.

For general information about creating reports, see the SAP Crystal Reports User Guide. For information
about creating a custom-coded dynamic recipient source, see the SAP BusinessObjects Business
Intelligence Platform Java SDK Developer Guide.

Related Topics
• To specify dynamic recipients

10.3.4 Destinations

Destinations are locations you deliver publications to. A destination can be the BI platform location in
which a publication in stored, a BI Inbox, an email address, an FTP server, or a directory on the file
system. You can specify several destinations for a publication.

If you publish multiple Crystal reports, you can merge them into a single PDF on a per destination basis.

If you publish a publication as a single ZIP file, you can zip or unzip instances on a per destination basis
(for example, zip the instances for email recipients and leave them unzipped for BI Inboxes).

10.3.4.1 Possible destinations
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DescriptionDestination

The publication is accessible from the folder it was created in. For the default
destination, you have these options:
• Merge all PDF documents (Crystal reports only).
• Package the publication as a ZIP file.

Note:
If you distribute to the default location or a shortcut to a recipient's BI Inbox,
choose a folder accessible to all recipients.

Default Enterprise
location

To send to a recipient's BI Inbox, you have these options:
• Deliver objects to each user.
• Type a name, use placeholders or use the default name.
• Have the publication sent as a shortcut or as a copy.
• Merge all PDF documents (Crystal reports only).
• Package the publication as a compressed (.zip) file.

BI Inbox

Email
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DescriptionDestination

The publication is emailed to recipients with a message. Check that email
settings are configured correctly on the Adaptive Job Server. The publication
is sent to recipients via email. For email recipients, it is recommended that
you complete the From field. If you do not complete the From field, BI platform
uses the email address associated with the publisher's account. If the publish-
er's account has no email address, BI platform uses the Adaptive Job Server's
settings.

Note:

If there is no From value provided by the From field, the publisher's account,
or the Adaptive Job Server, the publication will fail.

You also have these choices:
• Deliver objects to each user.
• Complete the To field or enter a placeholder for the email address.
• Complete the Cc field.
• Complete the Bcc field.
• Enter the subject or select a placeholder to use for the Subject field.
• Enter text in the Message field to be delivered with your publication. You

can also choose from a list of placeholders to use in the Message field and
embed a dynamic content document in the body of the email.

• Attach source document instances to the email.
• Have the attachment name automatically generated, to enter a specific

name for it, or to choose from a list of placeholders.
• Merge all PDF documents (Crystal reports only).
• Package the publication as a compressed (.zip) file.

Note:
Before you use this destination, ensure that your email settings are configured
properly on the Adaptive Job Server. If you are sending publications to recipi-
ents via email, ensure the placeholder %SI_EMAIL_ADDRESS% is in the To
field and Deliver objects to each user is selected.

For FTP server, complete the Host field. If you do not complete the Host field,
the option configured for the Adaptive Job Server will be used. Choose from
these options:
• Specify a port number, a user name and password, and an account.
• Enter a directory name.
• Have the file name automatically generated, type a custom name or to

choose from a list of placeholders. If Specific name is selected, you can
also choose to add a file extension.

• Merge all PDF documents (Crystal reports only).
• Package the publication as a compressed (.zip) file.

FTP server
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DescriptionDestination

Local disk If you choose local disk as the destination, you must enter the directory for
your publication. You also have these choices:
• Deliver objects to each user.
• Have the file name automatically generated for you. Or, enter a specific

name for the file, or to choose from a list of placeholders. If you select a
specific name, you can also choose to add a file extension.

• Enter a user name and password to access the file location.
• Merge all PDF documents (Crystal reports only).
• Package the publication as a compressed (.zip) file.

Note:

• Deliver objects to each user is selected by default for all destinations. However, in some cases,
you may not want to deliver objects to each user. For example, three recipients have identical
personalization values and thus receive the same data in their publication instances. If you clear
Deliver objects to each user, one publication instance is generated and delivered to all three
recipients. If you select Deliver objects to each user, the same publication instance is delivered
three times (once for each recipient). Additionally, if you are sending the publication to an FTP server
or local disk destination and some recipients share identical personalization values, you can clear
Deliver objects to each user to decrease overall processing time.

• If you clear Deliver objects to each user, any placeholders that you use when you configure your
destinations will contain the publisher's information and not the recipient's.

10.3.5 Personalized placeholders for publication source document names

If you used "Personalization" to filter data in the source documents, you can use personalized
placeholders to name publication instances.

Incorporating personalized placeholders into file names helps recipients easily identify the data that
has been filtered. Recipients who belong to multiple user groups with different personalization values
can distinguish between multiple versions of the same source document without viewing its contents.
Once personalization has been set up for a publication, personalized placeholders appear in the Add
placeholder list on the Destinations page.

Note:
If your publication contains more than one source document, theAdd placeholder list forUse Specific
Name shows personalized placeholders only if all source documents have been filtered on the same
field.

For every filter of a report, the following personalized placeholders appear:
• One placeholder is for the field name. Represented as %<field name>-NAME%, it will be replaced

by the name of the field at run time. This placeholder appears for all recipients.
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• One placeholder is for the personalized value of the field. Represented as %<field name>-VALUE%,
it will be replaced by the value of the field used to filter the report. Note that this placeholder is specific
for each recipient.

To use personalized placeholders, make the following selections in the Show options for selected
destinations area:
1. For the publication name, select the Use Specific Name option and choose the placeholder you

want from the Add placeholder list. To add several placeholders, repeat this step. To combine text
and a placeholder, first enter text and then choose the placeholder.

2. For individual documents, choose the Specific Name per Document option. Beside the title of each
document, choose the placeholders you want from the Add placeholder list. To add several
placeholders, repeat this step. To combine text and a placeholder, first enter text and then add the
placeholder.

3. To save and exit, select Save & Close. To save your selections but choose another destination or
choose additional options, select Save.

Example:

Assume you are publishing a quarterly sales report for two user groups: Canadian sales managers
and American sales managers. The Crystal report is named Quarterly Sales by Country. Personalization
has been applied to the country field; each group receives data for its respective country. For the
American sales managers, the profile value for the country field is "US" while for the Canadian sales
managers, the profile value for the country field is "Canada".

These three personalized placeholders appear in the Add placeholder list:
• Document Name. The code %SI_DOCUMENT_NAME% is inserted into the field.
• %Country - Query 1-NAME. The code %SI_field name-NAME% is inserted into the field.
• %Country - Query 1-VALUE%. The code %SI_field name-VALUE% is inserted into the field.

The report sent to American sales managers (filtered to show only US data) is named Quarterly Sales
by Country_US.pdf. The report sent to Canadian sales managers (filtered to show only Canadian data)
is named Quarterly Sales by Country_Canada.pdf.

10.3.6 Personalized placeholders for email fields

If all source documents in a publication have been personalized using the same field, you can use
personalized placeholders in Subject and Message fields when you email the publication.

For each filter used on the report during personalization, these two placeholders are displayed in the
Add placeholder list:
• %Field - Query 1-VALUE%. This is the personalized value of the field. At run time, this is replaced

by the value of this field used to filter the report. Note that this placeholder is specific to each recipient.
• %Field - Query 1-NAME%. This is the name of the field. At run time, this is replaced by the actual

name of the field. Note that this placeholder is identical for all recipients.
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Note:
If your publication contains several source documents, the Add placeholder list for Subject and
Message fields displays personalization parameters only if all source documents have been filtered on
the same field(s).

10.3.7 Formats

Formats define the file types that a publication's documents will be published in. A single document
can be published in multiple formats, and these instances can be delivered to multiple destinations. For
publications with multiple documents, you can specify a different format for each. For publications that
contain Web Intelligence documents, you can publish the whole document or a report tab within the
document to different formats.

Any formats you choose for a document apply to all recipients of the publication. For example, you
cannot publish a document as a Microsoft Excel file for one recipient and as a PDF for another. If you
want the recipients to receive instances in those formats, each recipient will receive a Microsoft Excel
file and a PDF.

10.3.7.1 Possible formats
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DescriptionFormatDocument type

This option publishes the document in mHTML format.
You can also embed a document's content as mHTML in
an email:
• For Crystal reports, you can embed the content of one

report in an email.
• For Web Intelligence documents, you can embed the

content of one report tab in an email.

When mHTML is selected, the output will reflect the order
in which the source documents are arranged on the docu-
ment selection screen. For example, the documents dis-
played at the top of the screen will appear at the top of
the email.

mHTML

All document types

This option publishes a document as a static PDF.

Note:
When this is used together with the PDF merging option,
the output will reflect the order in which the source docu-
ments are arranged on the document selection screen.
For example, the documents displayed at the top of the
screen will appear at the top of the merged PDF.

PDF (.pdf)

This option publishes a document as a Microsoft Excel
file and preserves as much of the original format of the
document as possible.

Microsoft Excel file (.xls)
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DescriptionFormatDocument type

This option publishes a Crystal report as a Microsoft Excel
file that contains data only.

Data only Microsoft Excel
file (.xls)

Crystal reports

This option publishes a Crystal report in XML format.XML

This option publishes a Crystal report in its original format.Crystal report (.rpt)

This option publishes a Crystal report in read-only format.Crystal report read-only
(.rptr)

This option publishes a Crystal report as a Microsoft Word
file and preserves the original formatting of the Crystal
report. This option is recommended if you expect recipients
to view the publication without making many changes to
it.

Microsoft Word file (.doc)

This option publishes a Crystal report as a Microsoft Word
file that you can edit more easily. This option is recom-
mended if you expect recipients to view the publication
and edit its content.

Editable Microsoft Word
file (.rtf)

This option publishes a Crystal report in rich text format.Rich text (.rtf)

This option publishes a Crystal report in plain text format.Plain text (.txt)

This option publishes a Crystal report in plain text format
and paginates the content of the publication.Paginated text (.txt)

This option publishes a Crystal report in plain text format
and separates the content in each column using tabs.Tab-separated text (.txt)

This option publishes a Crystal report as a character-
separated values file.

Character-separated val-
ues (.csv)

This option publishes a Web Intelligence document in its
original format.

Web Intelligence docu-
ment (.wid)

Web Intelligence doc-
uments

10.3.8 Personalization

Personalization is the process of filtering data in source documents so that only relevant data is displayed
for publication recipients. Personalization alters the view of the data, but it does not necessarily change
or secure the data being queried from the data source.
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The following diagram illustrates how personalization works. An unpersonalized report contains data
types 1, 2, and 3. When the personalization is applied to the report, users receive only the data that is
relevant to them: User 2 receives only data type 2, User 1 receives only data type 1, and User 3 receives
only data type 3.

Figure 10-3: Personalization

To personalize source documents for recipients, you can do the following:
• If the recipients are Enterprise recipients, you can apply a profile when you design the publication.

Profiles for Enterprise recipients must be configured in BI platform, before you can personalize a
publication.

• If the recipients are dynamic recipients, you can map a data field or column in the source document
to data in the dynamic recipient source. For example, you can map a Customer ID field in a source
document to the Recipient ID field in the dynamic recipient source.

Note:
To view a list of recipients who will receive unpersonalized publication instances after personalization,
click Advanced on the navigation list and select Display users who will receive the complete
publication with no personalization applied.

10.3.9 Publication extensions

A publication extension is a library of code that applies business logic to publications. Use extensions
when you need automated customization of publications after processing or delivery.

Use publication extensions to perform the following tasks after processing:
• Merge documents of the same type (for example, merging multiple Excel spreadsheets into a single

Excel workbook).
• Add password protection to or encrypt a document.
• Convert a document to a different format.
• Create custom log files for the publication job.
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Note:
You can specify publication extensions only in CMC. You cannot do this if you are designing a publication
in BI launch pad.

For more information about publication extensions, see the SAP BusinessObjects Business Intelligence
Platform Java SDK Developer Guide.

Related Topics
• To specify publication extensions

10.3.10 Subscription

A subscription lets users who are not publication recipients sign up to view the latest instance. Subscribers
can also unsubscribe from a publication at any time. If users have the appropriate rights,they can
subscribe and unsubscribe other users.

To subscribe to or unsubscribe from a publication, you need a BI platform account and the following
rights:
• Access to BI launch pad or the CMC
• “View” rights to see the publication
• “Subscribe” rights for the user account (for Enterprise recipients)

Note:
Dynamic recipients can't subscribe and unsubscribe themselves automatically.

Related Topics
• To subscribe to or unsubscribe from a publication

10.3.11 PDF merging for Crystal reports

You can merge PDF instances of Crystal reports and static PDF documents into a single PDF for
convenience. All static PDF source documents are included in the merged PDF. Static source documents
that are not PDF files are excluded from the merged PDF.

With a merged PDF you can also:
• Add and format a table of contents.
• Insert running page numbers.
• Add user and owner passwords to view and edit the PDF.
• Set restrictions on what recipients can do with the PDF.
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10.4 Rights required for Publishing

Rights requiredTaskRole

NoneCreate the document on which
the publication is based

Document designer

• “View” and “Add” rights on the folder or
category to which the document will be
added

Add the document to BI platformDocument designer

• “View” and “Add” rights on the folder or
category to which the document will be
added

Create a document to be used
as a dynamic recipient source

Document designer

• “Add” rights on the folder where the
publication is saved

• “View” rights on users and groups intend-
ed as recipients

• “View” rights on the profile that is used
for personalization

• “View” rights on documents for the pub-
lication

• “Schedule” rights on documents
• “Subscribe” rights on the Enterprise re-

cipients

Create a publicationPublisher
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Rights requiredTaskRole

Note:
It is recommended that only the publisher
has these rights.

• “View”, “Schedule”, “Add”, and “Modify
Security” rights on the publication

• “Delete Instance” rights on the publica-
tion

• “View” rights on users and groups intend-
ed as recipients

• “View” rights on the profile that is used
for personalization

• “View” and “Schedule” rights on the
documents

• “View” and “Refresh” rights on the dy-
namic recipient source

• “View” and “Refresh” rights on the docu-
ment on which a delivery rule is set

• “Data Access” rights on any universes
used by the publication's objects

• “Data Access” rights on any universe
connections used

• “View” and “Add” rights on recipients' BI
Inboxes (when you schedule to inboxes)

• “Modify the rights users have to objects”
on the folder containing the publication

• “Subscribe” rights on the recipients
• “Print” rights on Crystal report source

documents, if the publisher wants to print
publication instances

• “Schedule on behalf of other users”
rights on Enterprise recipients (if you use
One database fetch per recipient)

Schedule a publicationPublisher

• Same rights required to schedule a
publication

• “Edit” rights on the publication instance

Retry a failed publication instancePublisher
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Rights requiredTaskRole

• “View”, “Add”, “Schedule”, and “Modify
Security” rights on the publication

• “View” and “Add” rights on recipients' BI
Inboxes

• “View Instance” and “Edit” rights on the
publication instance

Redistribute a publication in-
stance

Publisher

• “View” rights on the publication
• “View Instance” rights on the publication

Note:
You need these rights to view a publication
object in BI platform. You do not need these
rights to view content that is sent to a BI In-
box.

View a publicationRecipient

• “View” rights on the publication
• “Subscribe” rights on the Enterprise re-

cipients

Subscribe to or unsubscribe from
a publication

Recipient

10.4.1 Publishers and recipients: Who has rights to view what?

A publisher (who owns and schedules the publication) can view all publication instances for all recipients;
recipients can view their personalized publication instances only. This rights setup ensures maximum
security for publication data because it reserves the rights to schedule publications and to view all
publication instances for the publisher only.

Tip:
If you are a publisher and want to add yourself to a publication as a recipient, use two user accounts
for yourself, a Publisher account and a Recipient account. The Publisher account grants you the rights
you require when you design and schedule publications, while the Recipient account grants you the
rights of a typical recipient.
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Working with Publications

11.1 Designing publications

To design a new publication, you first access the Publishing feature in BI platform. You can do this in
the Central Management Console (CMC) or in BI launch pad depending on the rights that you have
and your access to the web-based applications in BI platform.

At any point during the publication design process, you can save changes you made to the publication,
close it, reopen it, and make further changes.

11.1.1 Designing publications for use with SAP BusinessObjects Live Office

When you design publications intended for use with SAP BusinessObjects Live Office, consider the
following information:
• Dynamic content documents can consist only of Crystal reports or Web Intelligence documents in

their original format.
• Dynamic recipients are not supported.
• The only destination option you can use is the default enterprise location.
• If recipients receive multiple publication instances after personalization, only the first publication

instance can be viewed in the SAP BusinessObjects Live Office Client. This issue can occur if a
recipient inherited multiple profile values from group membership. To work around this issue, assign
only the necessary profile values to recipients.

Related Topics
• Personalization

11.1.2 Designing publications for SAP recipients

A publication intended for SAP recipients works the same way as a publication intended for Enterprise
and dynamic recipients except for two important differences exist in the publishing workflow:
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• You do not use the settings in the "Personalization" area to personalize source documents for SAP
recipients. SAP recipients already have profile values mapped to their user accounts outside of the
BI platform. This serves as a built-in personalization method for SAP recipients. You do not need
to create profiles and profile values for SAP recipients in the BI platform, or to map profiles to source
document fields.

• The only report bursting method that works for a publication intended for SAP recipients is One
database fetch per recipient. This method maximizes security and ensures that the database logon
credentials of each publication recipient are processed individually.

For more information about single sign-on configuration and authentication, see the SAP BusinessObjects
Business Intelligence Platform Administrator Guide.

11.1.3 To create a new publication in the CMC

1. Go to the Folders area of the CMC.
2. In the "Group Tree", browse for the folder in which you want to create the publication.
3. Select the folder so that its contents appear in the "Details" panel.
4. Click Manage > New > Publication.

The "New Publication" dialog box appears.

In the "New Publication" dialog box, you can specify all the information required for your publication,
including source documents, recipients, delivery formats and destinations, and how documents are
personalized.

11.1.4 To create a new publication in BI launch pad

1. In BI launch pad, on the "Documents" tab, expand the Folders drawer, and locate and select the
folder in which to create the publication.
The folder contents appear in the list panel.

2. Select New > Publication.
The "New Publication" dialog box appears.

In the "New Publication" dialog box, you can specify information for a publication, including source
documents, recipients, delivery formats and destinations, and how documents are personalized.

11.1.5 To open an existing publication
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Use this procedure to open an existing publication and edit its metadata.
1. Select the publication.

• If you are in BI launch pad, on the Documents tab, expand the Folders drawer and browse for
the publication.

• If you are in the CMC, go to the Folders area and browse for the publication.

2. Open the publication's properties.
• If you are in BI launch pad, select the publication and click View > Properties.

• If you are in the CMC, select the publication and click Manage > Properties.

You can now edit the metadata for the publication.

11.1.6 To enter general properties for a new publication

1. Click General Properties.
2. In the Title field, enter a title for the publication.

Note:
A title is mandatory for the publication design process.

3. In the Description field, enter a description for the publication.
4. In the Keywords field, enter keywords that are associated with the publication's content.

11.1.7 To select source documents

After you enter general properties for the publication, choose source documents to include. Subsequent
options vary depending on the dynamic content document type.
1. Click Source Documents.
2. Click Add.

The "Select Source Documents" dialog box appears.

3. Browse for the source documents you want to include and select them.

Note:
Dynamic content documents must be the same document type.

Tip:
Use CTRL + click or SHIFT + click to select multiple source documents, or double-click a single
source document to select it.

4. Click OK.
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The "Select Source Documents" dialog box closes. The source documents that you selected appear
in the Selected list.

5. Select or clear the Refresh At Runtime check boxes that are next to the source documents.
Your selections determine whether a particular source document is refreshed against the data source
when the publication runs. If you do not need to refresh a source document, it is recommended that
you clear theRefresh At Runtime check box for that document to improve publication performance.

If you plan to send the source documents as attachments or as a merged PDF, you can change the
order in which the documents appear. To do this, select a document on the Selected list, and click
Move Up or Move Down.

11.1.7.1 To replace static source documents

Before you can replace a static source document, you must have "Edit" access rights for the document.

A static (agnostic) source document is a third-party document that does not originate in BI launch
pad—for example, a Microsoft Word, Adobe PDF, or Microsoft Excel file.

Although you cannot update the content of static documents, you can replace a static source document
with a more recent version of the document. This enables you to view the latest source information in
documents that originate outside of BI launch pad.

Note:
If the Replace File menu option is unavailable for a static source document, you do not have "Edit"
rights for the document.

1. Right-click a static source document and select Organize > Replace File.
2. In the "Replace File" dialog box, click Browse, and select a more recent version of the source

document file on your computer.

Note:
If a message appears, stating that the file does not match the source document's file format, you
have chosen a file in a different format than the original source document. Click OK to close the
message, and then click Browse, and select the correct source document.

3. Click Replace.
4. In the confirmation message, click OK to update the source document.

11.1.8 To select Enterprise recipients

Perform this task if you want Enterprise recipients to receive the publication.
1. Click Enterprise Recipients.
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2. In the "Available" area, browse for the users or groups that you want to include or exclude as
recipients.
a. Click User List to display a list of all users in BI platform, or click Group List to display a list of

all groups.
b. Select the users and groups.

Tip:
Use Shift + click or CTRL + click to select multiple users or groups.

3. If you want to include the recipients you selected, move them to the Selected list.
4. If you want to exclude the recipients you selected, move them to the Excluded list.

11.1.9 To specify dynamic recipients

To specify dynamic recipients, you must have a dynamic recipient source already designed and ready
for use. The dynamic recipient source contains recipient data and can be a Crystal report, a Web
Intelligence document, or a custom-coded data provider.

For information about creating a custom-coded dynamic recipient source, see the SAP BusinessObjects
Business Intelligence Platform Java SDK Developer Guide.

Tip:
It is recommended that you sort the recipient data according to the recipient ID field to enable more
efficient processing of the publication.

Perform this task if you want recipients who are not BI platform users to receive the publication.
1. Click Dynamic Recipients.
2. On the Choose the source for the dynamic recipients list, choose the format of the dynamic

recipient source.

Note:
Crystal report dynamic recipient sources cannot be in RPTR format.

3. In the right-hand pane, browse for the object you want to use as a dynamic recipient source, select
it, and click OK.

4. If you chose to use a Web Intelligence document as a dynamic recipient source, on the Select the
datasource name for the document list, select a query that appears in the document.

Note:
Dynamic recipient data comes from the query and may not match the data that appears when you
view the document. Depending on how the query is built, dynamic recipient sources created in the
Web Intelligence component may contain values that do not correspond to data in the publication's
source documents. For example, a filter in the report may exclude relevant values, or duplicate
records may appear because the query has been set to retrieve duplicate rows. It is recommended
that you review the full list of dynamic recipients during the publication design process.

5. On the Recipient Identifier list, select a field that contains the recipient identity values.
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6. If necessary, on the Full Name list, select a field that contains the full names of recipients.
7. If you intend to deliver the publication to email addresses, on the Email list, select a field that contains

the recipient email addresses.
8. Decide whether you want to distribute the publication to all dynamic recipients listed by the dynamic

recipient source.
• If you want to distribute the publication to all dynamic recipients, ensureUse entire list is selected.
• If you want to include or exclude some dynamic recipients:

a. Clear Use entire list.
b. On the Available list, select the check boxes next to the recipients you want to include or

exclude.
c. If you want to include the recipients you selected, move them to the Selected list.
d. If you want to exclude the recipients you selected, move them to the Excluded list.

After you specify dynamic recipients for the publication, you can personalize the publication for dynamic
recipients by mapping a field in the source document to a column in the dynamic recipient source.

Related Topics
• To specify dynamic recipients
• To personalize a Crystal report by filtering fields
• To personalize a Web Intelligence document by filtering fields

11.1.10 To specify a destination for the publication

1. Click Destinations.
2. Under Select Destinations, choose a destination check box.

Note:
Each destination provides a variety of options relating to how the publication is delivered

3. To avoid keeping publication instances on your system, do not select Default Enterprise location.

Tip:
Set a low instance limit on the publication object.

4. Choose a destination in the Show options for selected destinations list.
Additional configuration options for the destination appear.

5. As an option, specify a name for your publication by choosing Use Specific Name. (By default, a
system-generated name will be assigned to the publication unless you choose this option.) Enter a
name or select from a list of placeholders in the Add placeholder list.
A placeholder is a container for variable data. At run time, the value is inserted into the placeholder.

6. If your publication contains multiple documents, you can specify a name for each one by choosing
Specific Name per Document.
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By default, each document will be assigned the same system-generated name unless you select
this option. Enter a name or choose from a list of placeholders in the Add placeholder list.

7. If you are sending a publication to the default Enterprise location and to recipient email addresses,
you can embed a link to the Enterprise location in the email body.
Enterprise recipients must have View rights on the publication to view publication instances. To do
this, position the cursor in the Message box and click Viewer Hyperlink in the Add placeholder
list that is under the Message box. The placeholder %SI_VIEWER_URL% is inserted in the email.
This placeholder is replaced by a link when the publication is run.
Dynamic recipients are unable to access the publication instance because they do not have BI
accounts.

11.1.11 Personalized placeholders for publication source document names

If you used "Personalization" to filter data in the source documents, you can use personalized
placeholders to name publication instances.

Incorporating personalized placeholders into file names helps recipients easily identify the data that
has been filtered. Recipients who belong to multiple user groups with different personalization values
can distinguish between multiple versions of the same source document without viewing its contents.
Once personalization has been set up for a publication, personalized placeholders appear in the Add
placeholder list on the Destinations page.

Note:
If your publication contains more than one source document, theAdd placeholder list forUse Specific
Name shows personalized placeholders only if all source documents have been filtered on the same
field.

For every filter of a report, the following personalized placeholders appear:
• One placeholder is for the field name. Represented as %<field name>-NAME%, it will be replaced

by the name of the field at run time. This placeholder appears for all recipients.
• One placeholder is for the personalized value of the field. Represented as %<field name>-VALUE%,

it will be replaced by the value of the field used to filter the report. Note that this placeholder is specific
for each recipient.

To use personalized placeholders, make the following selections in the Show options for selected
destinations area:
1. For the publication name, select the Use Specific Name option and choose the placeholder you

want from the Add placeholder list. To add several placeholders, repeat this step. To combine text
and a placeholder, first enter text and then choose the placeholder.

2. For individual documents, choose the Specific Name per Document option. Beside the title of each
document, choose the placeholders you want from the Add placeholder list. To add several
placeholders, repeat this step. To combine text and a placeholder, first enter text and then add the
placeholder.
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3. To save and exit, select Save & Close. To save your selections but choose another destination or
choose additional options, select Save.

Example:

Assume you are publishing a quarterly sales report for two user groups: Canadian sales managers
and American sales managers. The Crystal report is named Quarterly Sales by Country. Personalization
has been applied to the country field; each group receives data for its respective country. For the
American sales managers, the profile value for the country field is "US" while for the Canadian sales
managers, the profile value for the country field is "Canada".

These three personalized placeholders appear in the Add placeholder list:
• Document Name. The code %SI_DOCUMENT_NAME% is inserted into the field.
• %Country - Query 1-NAME. The code %SI_field name-NAME% is inserted into the field.
• %Country - Query 1-VALUE%. The code %SI_field name-VALUE% is inserted into the field.

The report sent to American sales managers (filtered to show only US data) is named Quarterly Sales
by Country_US.pdf. The report sent to Canadian sales managers (filtered to show only Canadian data)
is named Quarterly Sales by Country_Canada.pdf.

11.1.12 Personalized placeholders for email fields

If all source documents in a publication have been personalized using the same field, you can use
personalized placeholders in Subject and Message fields when you email the publication.

For each filter used on the report during personalization, these two placeholders are displayed in the
Add placeholder list:
• %Field - Query 1-VALUE%. This is the personalized value of the field. At run time, this is replaced

by the value of this field used to filter the report. Note that this placeholder is specific to each recipient.
• %Field - Query 1-NAME%. This is the name of the field. At run time, this is replaced by the actual

name of the field. Note that this placeholder is identical for all recipients.

Note:
If your publication contains several source documents, the Add placeholder list for Subject and
Message fields displays personalization parameters only if all source documents have been filtered on
the same field(s).

11.1.13 To embed content from a dynamic content source document in an email
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You can embed content from dynamic content documents in the body of an email. For Crystal reports,
you can embed content from a report. For Web Intelligence documents, you can embed an entire
document or a single report tab.
1. Click Formats.

The "Formats" section appears.

2. Select the dynamic content document that you want to embed in the email.

Selection methodDocument type

On the Title list, select the report.Crystal report

On the Document list, select the document.Web Intelligence document

3. Select mHTML as a publication format for the dynamic content document that you selected.

Selection methodDocument type

On the Format Options list, select the mHTML checkbox.Crystal report

On the Output Format list, select the mHTML checkbox.Web Intelligence document

4. For Web Intelligence documents, choose whether to publish the entire document or one report tab
in the document.
a. Ensure mHTML is selected on the Output Format list.
b. If you want to publish the entire document, leave All reports selected; if you want to publish a

single report tab, click Select one report and choose a report tab on the list.

5. On the navigation list, click Destinations.
The "Destinations" section appears.

6. In the "Select Destinations" area, select Email.
7. On the Show options for list, click Email.

Additional configuration options for the email destination option appear.

8. In the From box, type a name or email address or choose Email from the Add placeholder list.
For example, you can type Robert, Publisher, or publisher@sap.com. If you type a name, it will be
appended to your email server (for example, Publisher@emailserver).

9. Type a subject in the Subject box. To insert a placeholder, choose an option such as Title from the
Add placeholder list. If you personalized the report, personalized placeholders are available in the
the Add placeholder list.

10. Type any message text you want the body of the mail to contain in the Message box.
11. To embed dynamic content into the Message box, position the cursor in the Message box where

you want to embed the document content, go to the Add placeholder list under the Message box
and choose Report HTML Content.
%SI_DOCUMENT_HTML_CONTENT% appears in the Message box. When the publication is run, this
placeholder is replaced by the personalized content of the dynamic content document you specified.
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12. If your publication contains other source documents, ensure Add Attachment is selected and the
attachment options are configured properly.
The other source documents in the publication will be added to the email as attachments when the
publication is run.

11.1.14 To specify scheduling information

Perform this task to specify scheduling information for the publication.
1. Expand Additional Options, and click Recurrence.
2. In the Run object list, choose a recurrence pattern.
3. For the recurrence pattern, specify run options and parameters as required.

11.1.15 Design tasks for Crystal reports publications

11.1.15.1 To personalize a Crystal report using parameter values

Note:
To perform this task, the Crystal report must contain parameters. Before you can use profiles to
personalize data for Enterprise recipients, the profiles must be configured in BI Platform.

The "Personalization" section lets you personalize a Crystal report for recipients based on the predefined
parameter values for each recipient.

Personalizations that are based on parameter values may be overridden by other personalization
methods. For example, if a profile is mapped to a parameter, and the profile value for an Enterprise
recipient conflicts with the parameter value, the profile value will override the parameter value when
the publication runs. Similarly, if a personalization value in the dynamic recipient source conflicts with
a parameter value for a dynamic recipient, the parameter value will be overridden when the publication
runs.

Note:
It is recommended that you personalize Crystal reports with local profile targets when possible.
Parameter-based personalization requires one database fetch per recipient when the parameter is used
in a record selection formula, command, table or stored procedure. This can increase publication
processing time.

1. Click Personalization.
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2. In the "Parameters" area, ensure the default values for the listed parameters are correct.
If you want to change a default value, click the Edit Values button that is next to the parameter
value. Select or enter the parameter value, and click OK.

3. If you want to override the default parameter personalization with Enterprise recipients' profile values,
choose a profile from the list in the Enterprise Recipient Mapping column.

Note:
This option only appears if your publication is intended for Enterprise recipients.

If this profile is not configured in BI platform, personalization will fail. If you need profiles added to
BI platform, contact your system administrator.

Note:
If you are only using default parameter values to personalize a report, it is recommended that you
set Enterprise Recipient Mapping to Default value for all recipients.

4. If you want to override the default parameter personalization with dynamic recipients' personalization
values, choose a dynamic recipient source column from the list in the Dynamic Recipient Mapping
column.

Note:

• This option only appears if your publication is intended for dynamic recipients.
• If you are only using default parameter values to personalize a report, it is recommended that

you set Dynamic Recipient Mapping to Not Specified.

11.1.15.2 To personalize a Crystal report by filtering fields

Before you can use profiles to personalize data for Enterprise recipients, the profiles must be configured
in BI Platform.

Perform this task if you want to personalize a Crystal report by filtering a field in the Crystal report.
When you use filters, a ViewTime selection formula is added to the report to filter data. This formula is
applied when the publication runs and is not saved in the report. You can filter multiple fields in a Crystal
report.

Note:

• Static-value profile values can filter string fields in Crystal reports only. To filter other types of fields,
use expression profile values. If you map the incorrect type of field to the profile, personalization will
fail.

• This feature is unavailable for Crystal reports in RPTR format.
1. Click Personalization.
2. In the "Filters" area, choose a Crystal report field from the list in the Report Field column.

The list of available fields includes all database fields and recurring formulas in the main report or
non-on-demand subreports.

3. Choose a profile from the list in the Enterprise Recipient Mapping column.
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This setting maps the report field to the profile values that are defined for Enterprise recipients.

Note:
This option only appears if your publication is intended for Enterprise recipients.

If this profile is not configured in BI platform, personalization will fail. If you need profiles added to
BI platform, contact your system administrator.

4. Choose a dynamic recipient source column from the list in theDynamic Recipient Mapping column.

This setting maps the report field to a column in the dynamic recipient source that contains
corresponding values.

Note:
This option only appears if your publication is intended for dynamic recipients.

5. Repeat steps 2 to 4 for every report field that you want to filter.

11.1.15.3 To specify formats for a Crystal report

1. Click Formats.
2. On the Documents list, select a Crystal report.

The "Format Options" area appears and lets you select the publication formats for the Crystal report
you selected.

3. On the Format Options list, select the check boxes next to the formats you want.
The formats are selected.

4. On the Format Options list, click the name of a format you selected.

Note:
Depending on the format option, the subsequent steps may not apply.

Additional options appear that let you customize the format.

5. If you want to use the default export options defined in the source document, leave Use the export
options defined in the report selected; otherwise, clear Use the export options defined in the
report

6. Enter additional information to customize the appearance of the format you chose.
7. Repeat steps 4 to 6 for each format in which you want to publish the Crystal report.

After you finish, you must repeat steps 2 to 7 for each Crystal report in the publication.

11.1.15.3.1 Additional customization options for Crystal reports formats

This section summarizes the formats for which additional customization options are available.

Microsoft Excel (97-2003)
The following options are available for Crystal reports that are published as Excel files:
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• Page Range

Click All to publish the entire report as an Excel file. Alternatively, click Pages and enter page range
numbers in the from and to fields to publish specific report pages.

If you clear Use the export options defined in the report, the following options are also available:
• Set Column Width

Click Column width based on objects in the and choose an option on the list to define column
widths relative to objects in the report. Alternatively, click Constant column width (in points) and
enter a numerical value in the field to define a constant width for all columns.

• Export page header and page footer

Choose an option on the list to set how frequently headers and footers appear in the Excel file.

• Create page breaks for each page

Select this option to create page breaks that reflect the page breaks in the report.

• Convert date values to strings

Select this option to convert date values to text strings.

• Show gridlines

Select this option to include gridlines in the Excel file.

Microsoft Excel (97-2003) (Data Only)
If you clear Use the export options defined in the report , the following options are available:
• Set Column Width

Click Column width based on objects in the to define column widths relative to objects in the
report, and choose an option on the adjacent list. Alternatively, click Constant column width (in
points) to define a constant width for all columns and enter a numerical value in the adjacent field.

• Export object formatting

Select this option to preserve object formatting.

• Export images

Select this option to publish report images in the Excel file.

• Use worksheet functions for summaries

Select this option to use the report summaries to create worksheet functions for the Excel file.

• Maintain relative object position

Select this option to preserve the relative position of report objects.

• Maintain column alignment

Select this option to preserve the column alignment from the report.
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• Export page header and page footer

Select this option to include headers and footers in the Excel file.

• Simplify page headers

Select this option to simplify page headers.

• Show group outlines

Select this option to show group outlines from the report.

Microsoft Excel Workbook Data-only
If you clear Use the export options defined in the report , the following options are available for
Crystal reports published as Excel 2007 files:
• Set Column Width

Click Column width based on objects in the to define column widths relative to objects in the
report, and choose an option on the adjacent list. Alternatively, click Constant column width (in
points) to define a constant width for all columns and enter a numerical value in the adjacent field.

• Export object formatting

Select this option to preserve object formatting.

• Export images

Select this option to publish report images in the Excel file.

• Use worksheet functions for summaries

Select this option to use the report summaries to create worksheet functions for the Excel file.

• Maintain relative object position

Select this option to preserve the relative position of report objects.

• Maintain column alignment

Select this option to preserve the column alignment from the report.

• Export page header and page footer

Select this option to include headers and footers in the Excel file.

• Simplify page headers

Select this option to simplify page headers.

• Show group outlines

Select this option to show group outlines from the report.

Microsoft Word (97-2003)
The following options are available for Crystal reports that are published as Word files:
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• Page Range

Click All to publish the entire report as a Word file. Alternatively, click Pages and enter page range
numbers in the from and to fields to publish specific report pages.

PDF
The following options are available for source documents that are published as PDF files:
• Page Range

Click All to publish the entire source document as a PDF file. Alternatively, click Pages and enter
page range numbers in the to and from fields to publish specific pages.

If you clear Use the export options defined in the report, the following options are also available:
• Create bookmarks from group tree

Note:
If you plan to publish a Crystal reports publication as a merged PDF that contains a table of contents,
you must select this option.

Rich Text Format (RTF)
The following options are available for Crystal reports that are published as rich text files:
• Page Range

Click All to publish the entire source document as a PDF file, or click Pages and enter page range
numbers in the to and from fields to publish specific pages.

Microsoft Word - Editable (RTF)
The following options are available for Crystal reports that are published as editable Word files:
• Page Range

Click All to publish the entire report as a Word file. Alternatively, click Pages and enter page range
numbers in the from and to fields to publish specific report pages.

If you clear Use the export options defined in the report, the following options are also available:
• Insert page break after each report page

Select this option to create page breaks that reflect the page breaks in the report.

Plain Text
If you clear the Use the export options defined in the report check box, the following options are
available for Crystal reports that are published as plain text files:
• Number of characters per inch

Enter a value to define how many characters appear per inch in the plain text file.
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Paginated Text
If you clear the Use the export options defined in the report check box, the following options are
available for Crystal reports that are published as paginated text files:
• Number of Lines per Page

Enter a value to define how many lines will be on each page of the paginated text file.

• Number of Characters per Inch

Enter a value to define how many characters appear per inch in the paginated text file.

Separated Values (CSV)
If you clearUse the export options defined in the report, the following options are available for Crystal
reports that are published as comma-separated value files:
• Delimiter

Enter the character you want to use as a delimiter.

• Separator

Enter the character you want to use to separate values, or select Tab.

• Mode

Select either standard or legacy mode. Standard mode lets you control how report pages and group
headers and footers display in the CSV output and is the default option.

• Report and page sections

Use the options in this area to set whether report and page sections are exported, and whether to
isolate report and page sections.

• Group sections

Use the options in this area to set whether group sections are exported and whether to isolate group
sections.

XML
If you clearUse the export options defined in the report, the following options are available for Crystal
reports that are published in XML format:
• XML Exporting Formats

Select an option on the list to specify the XML format.

11.1.16 Design tasks for Web Intelligence document publications
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11.1.16.1 To specify formats for an Web Intelligence document

1. Click Formats.
2. On the Document list, select a document.
3. On the Output Format list, select the check boxes for the format or formats in which you want to

publish the document.
4. With the format option highlighted on the Output Format list, in the "Output Format Details" area,

choose whether to publish the entire document or one report tab in the document.
• If you want to publish the entire document, leave All reports selected.
• If you want to publish a single report tab, click Select one report and choose a report tab on the

list.

5. Repeat step 4 for every format in which you want to publish the document.

After you finish this task for one document, you must repeat steps 2 to 5 for the other dynamic content
source documents in the publication.

11.1.16.2 To personalize an Web Intelligence document using a global profile
target

Before you can use profiles to personalize data for Enterprise recipients, the profiles must be configured
in BI Platform. The profile selected in this task must also have a global profile target.

You can use theGlobal Profiles area of the"Personalization" dialog box to personalize a Web Intelligence
document for Enterprise recipients by filtering a global profile target.

Tip:
If you use the personalization options in the "Global Profiles" area, it is not necessary to use the
personalization options in the "Filters" area.

1. Click Personalization.
2. In the Global Profiles area of the "Personalization" dialog box, select a profile from the list in the

Enterprise Recipient Mapping column.
This profile maps the document to the universe field (the global profile target) that is filtered for
Enterprise recipients.

Note:
If the profile you select is not configured in BI platform, personalization will fail. If you need profiles
added to BI platform, contact your system administrator.
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11.1.16.3 To personalize a Web Intelligence document by filtering fields

Before you can use profiles to personalize data for Enterprise recipients, the profiles must be configured
in BI platform.

Perform this task to personalize a Web Intelligence document by filtering a field in the document.

Note:
Static-value profile values can filter string fields in source documents only. To filter other types of fields,
use expression profile values. If you map the incorrect type of field to the profile, personalization will
fail.

1. On the navigation list, click Personalization.
2. In the "Local Profiles" area, choose a field from the list in the Report Field column.
3. Choose a profile from the list in the Enterprise Recipient Mapping column.

This setting maps the report field to the profile values that are defined for Enterprise recipients.
If this profile is not configured in BI platform, personalization will fail. If you need profiles added to
BI platform, contact your system administrator.

4. Choose a dynamic recipient source column from the list in theDynamic Recipient Mapping column.
This setting maps the field in the source document to a column in the dynamic recipient source that
contains corresponding values.

5. Repeat steps 2 to 4 for every field that you want to filter.

11.1.17 Using additional publication features

The tasks in this section are optional (not required to design and schedule a publication) but can improve
the performance of your publication.

11.1.17.1 Additional publication features for Crystal report publications

11.1.17.1.1 To set print options for a Crystal report in a publication

If you plan to use the default printer, ensure that the printer is installed and configured properly.
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Note:
The Crystal Reports Job Server must run under an account that has sufficient privileges to access the
printer you specify. See the SAP BusinessObjects Business Intelligence Platform Administrator Guide
for more information.

You can choose to print instances in Crystal reports format each time the publication runs using the
Crystal Reports Job Server's default printer or a different printer. The BI platform prints the instances
after the publication is personalized but before delivery.
1. Expand Additional Options and click Print Settings.
2. On the Documents list, select a Crystal report that you want to print when the publication is run.
3. Select Print Crystal reports when scheduling.
4. Leave Default printer selected if you want to print to the job server's default printer; otherwise,

select Specify a printer.
5. Enter a printer's path and name.

• If your job server is on Windows, in theSpecify a printer box, type \\printserver\printername

Replace printserver with the name of your printer server and printername with the name
of your printer.

• If the job server runs on Unix, confirm that the Unix is shown (not hidden), and type the print
command that you usually use in the Specify a printer box.

For example, type lp -d printername

6. Select the number of copies and choose the print page range.
7. Set the collation and page scaling options.
8. If you want to center report content on the page, select Center the page.
9. If the Crystal report is wide and you want it to fit on one page when it prints, select Fit horizontal

pages into one page.

11.1.17.1.2 To set a recipient delivery rule on a Crystal report

Recipient delivery rules determine whether a publication is delivered to a particular recipient after
processing and personalization.
1. Expand Additional Options and click Delivery Rules.
2. In the "Recipient Delivery Rule" area, click Deliver individual document when condition is met

or Deliver all documents only when all conditions are met.
3. On the list next to each report, specify a condition that must be met for the publication to be delivered.

The default delivery rule settings are summarized in the following table. If a report contains alerts,
options that are based on alert values are also available.
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DescriptionDelivery rule option

The report is always delivered to the recipient.Always deliver

The report is never delivered to the recipient. This option is useful if
you want to exclude a Crystal report from a particular publication run
without redesigning the entire publication.

Never deliver

The report is delivered to the recipient only if it contains data for that
recipient after personalization. This option is useful if you want to
decrease the processing load for large publications.

Deliver only if report con-
tains data

11.1.17.1.3 To set a global delivery rule on a Crystal report

Note:
The Crystal report that you want to set a global delivery rule for must contain an alert.

Global delivery rules determine whether a publication will be processed and delivered for all recipients.
You can set a global delivery rule on any Crystal report in the BI platform.
1. Expand Additional Options and click Delivery Rules.
2. In the "Global Delivery Rule" area, click Browse.

A dialog box appears and lets you select the Crystal report on which the global delivery rule will be
set.

3. Browse for the Crystal report, select it, and click OK.
The dialog box closes.

4. On the Condition list, select the alert value that the report must have for the global delivery rule to
be met.

11.1.17.1.4 To format the merged PDF

• The Crystal reports that you want to include in the merged PDF must have titles. To set the title for
a report, open the report in SAP Crystal Reports and go to File > Summary Info. On the Summary
tab, in the Title box, type a title for the report. Save the report and re-export it to the repository.

• In the "Source Documents" area, the Crystal reports and PDF files that you want to merge must
appear in the correct order.

• In the "Formats" area, PDF must be selected as a format for each Crystal report that you want to
include in the merged PDF file.

• In the "Destinations" area, Merge Exported PDF must be selected for each destination to which
you want to send the merged PDF file.

Set options in the Merged PDF Options area to customize the merged PDF instance generated from
a Crystal report publication.
1. Expand Additional Options and click Merged PDF Options.
2. Create and format a table of contents for the merged PDF file:
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Note:
To enable this format option, in the "Formats" area, select a Crystal report on the Documents list.
Clear Use the export options defined in the report and select Create bookmarks from group
tree. Do this for each Crystal report on the list. If you do not do this, the Crystal report does not
appear in the table of contents for the merged PDF file.

a. Select Create Table of Contents.
The format options for the table of contents are available.

b. In the Title box, enter a title for the table of contents.
c. Format the font, font size (in points), and font color that the title and the items in the table of

contents will have.

3. Set the page number format options for the merged PDF file:
a. Select Apply Running Page Numbers.

The format options for page numbers are available.
b. In the Number Format box, enter the format in which you want the page numbers to appear.

By default, the format is set to Page &p of &P. You can change this format, but you must use &p
as a placeholder for the current page number and &P as a placeholder for the total number of
pages.

c. On the Number Location list, choose the page number orientation for the merged PDF file.
d. Format the font, font size (in points), and font color that the page numbers will have.
e. If you want the table of contents to have page numbers, select Apply page numbers to Table

of Contents pages.

4. Set recipient logon credentials and permissions for recipient actions:
a. In the User Password box, enter a password that recipients must enter to view the merged PDF

file.
b. In the Owner Password box, enter a password that recipients must enter to edit the merged

PDF file.
c. Select or clear the following check boxes to set permissions for user actions:

2012-11-06181

Working with Publications



DescriptionOption

Select to allow recipients to print the PDF fileAllow Printing

Select to allow recipients to modify the PDF fileAllowModification of Contents

Select to allow recipients to copy and paste content in the
PDF file

Allow Copy and Paste

Select to allow recipients to modify annotations in the PDF
file

Allow Modification of Annota-
tions

11.1.17.1.5 To configure database logon information for a Crystal report

Before you begin, it is recommended that you ensure the database settings for the Crystal report are
correct. In the "Folders" area of the CMC, select the Crystal report and go toManage >Default Settings
> Database Configuration to check the database information or enter new information.

In some cases, you may need to modify the data source information that a Crystal report references in
the Crystal report itself. To do this, open the Crystal report in SAP Crystal Reports and go to Database
> Set Datasource Location. In the "Set Datasource Location" dialog box, select a connection or create
a new connection.

This task lets you modify the database logon information that recipients require to log on to the database
and refresh the data in the Crystal report.
1. Expand Additional Options and click Database Logon.
2. On the Title list, select a Crystal report .

The database information for that Crystal report appears below the Title list.

3. Ensure the information that appears in the Database Server and Database boxes is correct.
4. In the User box, type a user name that recipients must use to log on.
5. In the Password box, type a password.

11.1.17.2 Additional publication features for Web Intelligence document
publications

11.1.17.2.1 To change the prompt value for a Web Intelligence document

Note:
The document must already contain a prompt.

This task is optional. You can keep the predefined prompt value that the document contains or edit the
list of prompt values.
1. Expand Additional Options and click Prompts.
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Note:
Only Web Intelligence documents that contain prompts appear.

2. Click Modify.
The "Prompts" dialog box appears.

3. Click Refresh Values.
A list of possible prompt values appears in the list on the left.

4. Move the prompt value or values from the list on the left to the list on the right.
5. Click Apply.

The "Prompts" dialog box closes, and the list of prompt values is updated.

11.1.17.3 To specify publication extensions

Before you use a publication extension, the extension must be deployed on any machines that run the
Adaptive Processing Server. The location varies depending on the operating system.

LocationOperating system

INSTALL DIR\SAP BusinessObjects\SAP BusinessObjects
Enterprise XI 4.0\java\lib\

Windows

INSTALLDIR/sap_bobj/enterprise_xi40/java/lib/Unix

After the extension is deployed, you must restart the Adaptive Processing Server and any other servers
that host a Publishing Service.

For more information about publication extensions, see the SAP BusinessObjects Business Intelligence
Platform Java SDK Developer Guide.
1. Expand Additional Options and click Publication Extension.
2. In the Publication Extension Name field, enter the name of the extension.
3. In the Class Name field, enter the fully qualified class name for the extension.
4. If necessary, enter a parameter in the Parameter field.
5. If you want the extension to be used after processing but before delivery, click the Add button above

Before Publication Delivery.
The extension is added to the Before Publication Delivery list.

6. If you want the extension to be used after delivery, click the Add button above After Publication
Delivery.
The extension is added to the After Publication Delivery list.

7. Repeat steps 2 to 6 for each extension that you want to add.
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Tip:
Click Move Up or Move Down under each list to configure the order in which the extensions will be
executed.

11.1.17.4 To configure email notification for successful or failed publication jobs

If you want to use the Adaptive Job Server defaults for email notification, the Adaptive Job Server must
have been configured properly.

Perform this task if you want to receive email notification after a publication job has run.

Note:
This feature is available in the CMC only.

1. Expand Additional Options and click Notification.
2. Expand Email Notification: Not in use.
3. If you want to receive email notification for successful publication jobs, select A job has been run

successfully and configure the options that appear below.
• Click Use the Job Server's defaults if you want to use the Adaptive Job Server defaults.
• Click Set the values to be used here if you want to use your own settings and enter your settings

in the appropriate fields.
• In the From field, enter an email address or a name.
• In the To field, enter an email address to which the email will be sent.
• In theCc field, enter email addresses for any users whom you want to receive email notification.
• In the Subject field, enter a subject line for the email.
• In the Message field, enter a message that will accompany the notification email.

4. If you want to receive email notification for failed publication jobs, select A job has failed to run
and configure the options that appear below.
• Click Use the Job Server's defaults if you want to use the Adaptive Job Server defaults.
• Click Set the values to be used here if you want to use your own settings and enter your settings

in the appropriate fields.
• In the From field, enter an email address or a name.
• In the To field, enter an email address that the email will be sent to.
• In theCc field, enter email addresses for any users whom you want to receive email notification.
• In the Subject field, enter a subject line for the email.
• In the Message field, enter a message that will accompany the notification email.
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11.1.17.5 To enable auditing notification for publication jobs

Perform this task if you want to enable auditing notification for publication jobs. For more information
about auditing, see the SAP BusinessObjects Business Intelligence Platform Administrator Guide.

Note:
This feature is available in the CMC only.

1. Expand Additional Options and click Notification.
2. Expand Audit Notification: Not in use.
3. If you want to audit successful publication jobs, select A job has been run successfully.
4. If you want to audit failed publication jobs, select A job has failed to run.

11.1.17.6 To specify events

Event-based scheduling provides you with additional control over scheduling publications: you can set
up events so that publications are processed only after a specified event occurs.

Perform this task if your publication job runs after an event occurs, or if your publication job triggers
other events upon completion.
1. Expand Additional Options and click Events.
2. If you want to specify file-based and custom events for your publication, move them from theAvailable

Events list to the Events to wait for list.
These events trigger the publication job to run.

3. If you want to specify schedule events for your publication, move them from theAvailable Schedule
Events list to the Events to trigger on completion list.
These events occur after the publication job has run.

11.1.17.7 To set a server group option

Perform this task if you want to use a specific server to process the publication. For more information
about server groups, see the SAP BusinessObjects Business Intelligence Platform Administrator Guide.

Note:
You cannot schedule publications across sites in federations.

1. Expand Additional Options and click Scheduling Server Group.
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2. Choose a server group option.

DescriptionOption

The publication job is processed by the first available server
with sufficient capacity. This option is selected by default.

Note:
This is the only available option if no server groups exist in
the CMC.

Use the first available server

The publication job first tries to run using the servers in the
server group you specify. If these servers have insufficient
capacity, the publication then tries to run using the servers
in other server groups. When you choose this option, you
also must choose a server group on the list of available
server groups.

Give preference to servers belong-
ing to the selected group

The publication job only uses the servers in the server group
you specify. When you choose this option, you also must
choose a server group on the list of available server groups.

Only use servers belonging to the
selected group

11.1.17.8 To specify a profile resolution method

The profile resolution method you specify determines whether instances will be merged or delivered
as separate documents if a profile conflict occurs.
1. Expand Additional Options and click Advanced.
2. Under Profile Resolution Method, click Merge or Do not merge.

11.1.17.9 To specify a report bursting method

The report bursting method you specify determines how the source documents are personalized,
processed, and delivered.
1. Expand Additional Options and click Advanced.
2. Click one of the options under Report Bursting Method.

Note:
If your publication is intended for dynamic recipients only, One database fetch per recipient is
unavailable.
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Caution:

Choose your report bursting method carefully if your publication meets the following criteria:
• The publication contains Web Intelligence documents intended for Enterprise recipients.
• The profiles that are used for personalization have filter expressions.

Different report bursting methods use different filter types to personalize and process the documents.
One database fetch for all recipients uses a report filter; One database fetch per recipient uses
a query filter. Each filter type in turn supports a different set of operators. If the filter expression uses
an operator that the report bursting method does not support, the publication may fail.

11.2 Post-design publication tasks

Tasks in this section are optional and can be performed after the publication design process.

11.2.1 Finalizing the publication

At any point during or after the design process, use the "Summary" page to view a summary of the
publication's properties: the publication's title, location, description, source documents, you how many
recipients will receive the publication according to recipient type (Enterprise or dynamic), how the
publication is personalized, the distribution format and destination.

To access the "Summary" page, click Summary. You can use the other options on the navigation list
to change the properties, or save the publication and schedule it.

11.2.2 To test a publication

Test mode allows you to test a publication by sending it to yourself before sending the publication to
its actual recipients. You will receive the same information that recipients receive. The destinations are
automatically updated so that your BI Inbox or your email address is used instead of those belonging
to the publication recipients. You can also exclude some recipients from the original group of recipients
for test mode.
1. Click Test Mode.
2. If necessary, modify the list of Enterprise recipients.

a. Click Enterprise Recipients.
b. Under "Email Recipients", in the To field, enter your own email address.
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This field only appears if your publication is intended for an email destination. BI platform sends
all email publication instances generated during test mode to the email address you specify here.

c. Move users or groups from the Available list to the Selected list or Excluded list.

3. If necessary, modify the list of dynamic recipients.
a. Click Dynamic Recipients.
b. Under "Email Recipients", in the To field, enter your own email address.

This field only appears if your publication is intended for an email destination. BI platform sends
all email publication instances generated during test mode to the email address you specify here.

c. Ensure the columns that are mapped to recipient IDs, full names, and email address are correct.
d. Select or clear Use entire list.
e. If Use entire list is cleared, move the users or groups that you want to include or exclude from

the Available list to the Selected list or Excluded list.

4. Click Test.
The publication is run in test mode.

11.2.3 To subscribe to or unsubscribe from a publication

Enterprise recipients with the appropriate rights can subscribe to or unsubscribe themselves from a
publication. They can also do this with publication instances. For instance, if a publication is scheduled
to run twice a week, recipients can subscribe to the first publication instance but not the second.

Note:
Dynamic recipients cannot subscribe and unsubscribe themselves automatically.

1. Browse for the publication and select it.
2. Subscribe to or unsubscribe from the publication by doing one of the following:

• If you are in the CMC, click Actions > Subscribe or Actions > Unsubscribe.
• If you are in BI launch pad, click More Actions > Subscribe or More Actions > Unsubscribe.

Tip:
To subscribe to or unsubscribe from publication instances, select the publication and click Actions >
History in the CMC orMore Actions > History in BI launch pad. In the "History" window, select an
instance and subscribe to it or unsubscribe from it.

11.2.4 To schedule a publication to run

After you have designed a publication and saved it, you can schedule it to run.
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When you schedule the publication, you can use the settings that you made in the "Recurrence" section,
or you can enter new settings. You can also change the recipients each time you schedule a publication.
1. Close the publication design page.
2. Select the publication.
3. Select Actions > Schedule in the CMC or More Actions > Schedule in BI launch pad.
4. Ensure that the recurrence information is correct.
5. Click Schedule.

The publication runs.

Tip:
To view the progress of a publication job as it runs, select Actions > History in the CMC or More
Actions >History in BI launch pad. In the Status column, click the status (Success, Failed, or Running),
and then click the View Log File link at the bottom of the "Publication History" dialog box.

11.2.5 Viewing publication results

Viewing publication results as a publisher
You can view the results of a publication in various ways. When the publication runs, you are taken to
the publication history, which lists publication instances, the times at which the publication was run,
and whether the publication succeeded or failed. In the Instance Time column, you can click the link
for a publication instance to view the instances that were generated for all recipients when the publication
was run at that time.

Tip:
To access the publication history at any time, select the publication and go to Actions > History in
the CMC or More Actions > History in BI launch pad.

Viewing log files for publication jobs
Log files are useful if you need to troubleshoot a publication or identify which recipients did not receive
publication instances. BI platform logs the publication job details as each batch of personalized publication
instances is processed, and then consolidates these details into one or more log files. The maximum
log file size is 10 MB and is non-configurable. If you run a high-volume publication with many details,
the publication instance can have several log files.

You can view log files for a publication instance in two ways:
• To view the last log file in a series, click Actions > History. In the Status column, click the status

(Success, Failed, or Running), and then click the View Log File link at the bottom of the "Publication
History" dialog box.

Tip:
You can also do this as the publication is running.

• To view all log files, click Actions > History. In the Instance Time column, click the link for a
publication instance. The log files are listed after the personalized instances.
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Log files are updated with new details every two minutes. If your publication job has been running less
than two minutes, the log file may have a status of Pending.

Viewing publication results as a recipient
The ways in which you can view a publication are summarized in the following table.
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How to view the publication resultDestination

As a recipient, you can view only your personalized publication instance
inBI platform. You cannot view publication instances that have been per-
sonalized for other recipients.

Note:
Dynamic recipients cannot log into BI platform to view publication results.

1. Launch the CMC.
• In Windows, go to Programs > SAPBusiness Intelligence > SAP

BusinessObjects BI platform 4 > SAP BusinessObjects BI
platform Central Management Console.

• Alternatively, open your web browser and type the following:

http://servername:connectionport/CMC

Here servername represents your CMS name and connection
port represents the connection port number that was specified
during installation. The default connection port number is 8080.

2. Enter your logon credentials.
• In the System field, ensure the CMS name and CMS port are cor-

rect.
• Enter your user name and password.
• On the Authentication list, select the authentication type.

3. Click Log On.
4. Go to the "Folders" area, navigate to the publication, and select it.
5. Click Actions > History.
6. Click the link in the Instance Time column.
7. Double-click the instance that you want to view.

Default Enterprise location

BI Inbox
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How to view the publication resultDestination

Note:
Dynamic recipients cannot log onto BI launch pad to view publication re-
sults.

1. Launch BI launch pad.
• In Windows, go to Programs > SAPBusiness Intelligence > SAP

BusinessObjects BI platform 4 > SAP BusinessObjects BI
platform Java BI Launch Pad.

• Alternatively, open your web browser and type the following:

http://servername:connectionport/BOE/BI

Here servername represents your CMS name and connection
port represents the connection port number that was specified
during installation. The default connection port number is 8080.

2. Enter your logon credentials.
• In the System field, ensure the CMS name is correct.
• Enter your user name and password.
• On the Authentication list, select the authentication type.

3. Click Log On.
4. Click My Inbox.
5. Double-click the instance that you want to view.

Log on to your email to view the embedded publication content or down-
load the attachment or attachments.

Email

Log on to your FTP host.FTP server

Navigate to the location that was specified when the publication was de-
signed.

Local disk

11.2.6 To redistribute a publication instance

You can redistribute successful publication instances to Enterprise and dynamic recipients that were
specified for the original publication run. This feature is useful if you want to resend an instance to a
recipient but you do not want to rerun the entire publication.
1. Browse for the publication and select it.
2. Click Actions > History if you are in the CMC, or More Actions > History if you are in BI launch

pad.
The history of the publication is displayed.

3. Select a successful publication instance.
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4. Click Actions > Redistribute if you are in the CMC, or More Actions > Redistribute if you are in
BI launch pad.

5. Choose the recipients who will receive redistributed instances.

Note:
Only recipients that were specified when the publication was run originally can receive redistributed
instances.

• If you want to redistribute an instance to an Enterprise recipient:
a. Expand Enterprise Recipients.
b. Move the Enterprise recipient from the Available list to the Selected list.

• If you want to redistribute an instance to a dynamic recipient:
a. Expand Dynamic Recipients.
b. Ensure the columns that are mapped to recipient IDs, full names, and email addresses are

correct.
c. If you want to redistribute the publication to all dynamic recipients, select Use entire list;

otherwise, clear it.
d. Move the dynamic recipient from the Available list to the Selected list.

6. Click Redistribute.
The history of the publication is displayed, and the instance that you chose to redistribute has a
status of Running. The date displayed in the Instance Time column is updated to reflect the
redistribution time.

11.2.7 To retry a failed publication

Before you begin, it is recommended that you view the log file for the failed publication instance, address
any errors, and reschedule the publication.
1. Select the publication that has the failed publication instance.
2. Click Actions > History if you are in the CMC, or More Actions > History if you are in BI launch

pad.
The publication history is displayed.

3. Select the failed publication instance.
4. Click Actions > Retry if you are in the CMC, or More Actions > Retry if you are in BI launch pad.

The instance status changes to Running.

If your publication fails again, refer to the new log file and fix any errors that occurred.
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11.3 Improving publication performance

Adaptive Processing Server
If both CPU and memory for the Adaptive Processing Server are heavily utilized during publication runs:
• Move the Adaptive Processing Server to a faster machine that has more available CPUs and SAP

BusinessObjects Business Intelligence platform 4.0 Feature Pack 3 or later installed. The server
will automatically scale to use more CPUs.

• Isolate the Publishing Service and the Publication Post Processing Service on dedicated Adaptive
Processing Server instances and remove unused services hosted on the server. Each service will
consume more shared resources (request thread pool, memory, and CPU consumption) on the
Adaptive Processing Server, and publishing performance may improve.

Publishing Service
• In deployments where many publication instances execute concurrently—if the underlying CMS,

FRS, Adaptive Job Server, and report processing servers have been scaled
appropriately—horizontally "scaling out" the Publishing Service across multiple Adaptive Processing
Server instances (on one or multiple machines) will enable more publication instances to be processed
concurrently.

In contrast, a single publication job (for example, one with 1,000,000 recipients) is not shared across
Publishing Services hosted on different Adaptive Processing Servers. Horizontally scaling out the
Publishing Service will not improve processing time for a single publication, regardless of the number
of recipients.

• For publications with many recipients, vertically scale the Adaptive Processing Server on machines
that have more CPUs and RAM. This will enable the Publishing Service to concurrently process
more recipients and the Adaptive Processing Server to generate more jobs. The Adaptive Job Server
and report processing servers may need to be scaled accordingly to increase throughput.

Note:
You may need to increase the Adaptive Processing Server heap size (that is, set -Xmx to 2 GB or
more) when the server runs on a machine that has more than eight CPU cores. The larger number
of CPU cores will enable the Adaptive Processing Server to spawn more threads and increase
throughput. Note that more threads will require more RAM.

• Because publishing is a disk-heavy process, use a machine with fast I/O or SAN disks for the FRS.
• Use the publishing cleanup option. For a large publication that does not need redistribution or to

view artifacts in the report, do not select the default destination.
• (Crystal report publications) Select One database fetch for each batch of recipients if you do not

need to apply unique refresh security for each recipient. Database access will be batched into multiple
concurrent, smaller queries.

• (Web Intelligence publications) Select One database fetch for all recipients or One database
fetch per recipient. When you select One database fetch for all recipients for a large publication,
to break up the database query into multiple smaller atomic queries, enter -Dcom.businessob
jects.publisher.scopebatch.max.recipients=<integer> on the command line of all
Adaptive Processing Servers that host the Publishing Service.
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• For large publications, disk delivery to a single folder on Windows can slow overtime. The workaround
is to disable short file-name generation. For instructions, see http://support.microsoft.com/kb/210638
and http://technet.microsoft.com/en-us/library/cc778996%28WS.10%29.aspx. For information about
disabling short file-name generation when a single folder contains more than 300 KB of files, see
http://technet.microsoft.com/en-us/library/cc781134(WS.10).aspx.

Publishing Post Processing Service
The Publishing Post Processing Service is called when the Package as ZIP File check box ("Schedule"
page) and/or the Merge Exported PDF check box ("Destinations" page) is selected or when custom
post-processing plugins are enabled on a publication. For publications with both check boxes selected,
you must create additional Publishing Post Processing Services to improve publication processing time.
However, the amount of work the Publishing Post Processing Service receives is limited by how the
Publishing Service is scaled.

Horizontally scaling out the Publishing Post Processing Service spreads the ZIP- and PDF-merging
workload across multiple Publishing Post Processing Services hosted on different Adaptive Processing
Servers.

11.3.1 Recommendations for adding source documents

This section contains recommendations for adding dynamic content documents in publications.

Use publication log files to troubleshoot errors in failed publications.
When you schedule publications to run, log files are generated that record any errors that may occur
when the publications are processed. To view all log files for a publication instance, click Actions >
History. On the "History" page, click the instance link in the Instance Time column.

If you are using parameter-based personalization for Crystal reports, set parameters to
default.
Parameter-based personalization may lead to slower publication performance. It is highly recommended
that you personalize Crystal report publications by mapping fields to Enterprise recipient profiles or to
dynamic recipient personalization values. However, if you need to personalize Crystal reports using
parameters, in the "Personalization" section, set parameters to Default.

Note:
Before you can use Enterprise recipient profiles, your system administrator must configure the profiles
in BI platform.

View and schedule dynamic content documents individually before you add them to a
publication.
If you can view and schedule dynamic content documents successfully, the data source connection is
working properly and the source document data can be refreshed when the publication is scheduled.
If you cannot view and schedule dynamic content documents, ensure the data source connection
settings are correct. The following table summarizes how to check the settings.
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How to check data source connection settingsDocument type

In the CMC, select the Crystal report and go to Manage > Default Settings.
In the "Default Settings" dialog box, click Database Configuration on the
navigation panel.

Crystal report

In the CMC, select the Web Intelligence document and go toManage >Default
Settings. In the "Default Settings" dialog box, click Report Universes on the
navigation panel.

Web Intelligence docu-
ment

In some cases, you may have to open the dynamic content document in the appropriate designer to
configure the data source connection and re-export the file to the CMS repository to overwrite the
previous copy. For more information about configuring data source connections for dynamic content
documents, refer to the documentation for the designer.

Avoid unnecessary data refreshes.
If a data refresh is unnecessary for a dynamic content document, in the "Source Documents" section,
clear the Refresh At Runtime check box for that document. This will improve overall publication
performance.

11.3.2 Recommendations for using dynamic recipient sources

This section contains recommendations for using dynamic recipient sources.

Sort dynamic recipient sources according to the recipient ID column.
In general, it is recommended that you sort dynamic recipient sources according to the recipient ID
column. This is especially important when you are running a high-volume publication or when you
enableOne database fetch for each batch of recipients because it can reduce the number of deliveries
for recipients who have multiple personalization values.

For Crystal report dynamic recipient sources, ensure the database configuration information
is correct.
In the CMC, select the dynamic recipient source and go to Manage > Default Settings to ensure the
following:
• In the "Database Configuration" section, the database logon information is correct and Use same

database logon as when report is run is selected.
• In the "Parameters" section, all parameters have parameter values, and all Prompt when viewing

check boxes for parameters are cleared.
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If you use Crystal report dynamic recipient sources, consult your administrator to ensure
the Report Application Server (RAS) is configured correctly.
The RAS must be configured to read at least the same number of database records as the number of
recipients in the dynamic recipient source. For instance, to process a dynamic recipient source with
data for 100,000 recipients, the RAS must be set to read more than 100,000 database records.

11.3.3 Recommendations for sending and receiving email publication instances

This section contains recommendations for email publication instances.

If possible, view embedded content email publication instances in Outlook 2003.
Embedded content in email publication instances may have formatting issues when viewed in Outlook
2007 or in web email accounts such as Hotmail or Gmail.

Consult your administrator to ensure that the email settings are configured properly for
the Destination Job Server.
Publications that are intended for email destinations may fail because email has not been configured
properly as a destination for the Adaptive Job Server. For more information, see the SAP BusinessObjects
Business Intelligence Platform Administrator Guide.
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More Information

LocationInformation Resource

http://www.sap.comSAP BusinessObjects product infor-
mation

Navigate to http://help.sap.com/businessobjects and on the "SAP Busi-
nessObjects Overview" side panel click All Products.

You can access the most up-to-date documentation covering all SAP
BusinessObjects products and their deployment at the SAP Help Portal.
You can download PDF versions or installable HTML libraries.

Certain guides are stored on the SAP Service Marketplace and are not
available from the SAP Help Portal. These guides are listed on the Help
Portal accompanied by a link to the SAP Service Marketplace. Customers
with a maintenance agreement have an authorized user ID to access
this site. To obtain an ID, contact your customer support representative.

SAP Help Portal

http://service.sap.com/bosap-support > Documentation
• Installation guides: https://service.sap.com/bosap-instguides
• Release notes: http://service.sap.com/releasenotes

The SAP Service Marketplace stores certain installation guides, upgrade
and migration guides, deployment guides, release notes and Supported
Platforms documents. Customers with a maintenance agreement have
an authorized user ID to access this site. Contact your customer support
representative to obtain an ID. If you are redirected to the SAP Service
Marketplace from the SAP Help Portal, use the menu in the navigation
pane on the left to locate the category containing the documentation you
want to access.

SAP Service Marketplace

https://cw.sdn.sap.com/cw/community/docupedia

Docupedia provides additional documentation resources, a collaborative
authoring environment, and an interactive feedback channel.

Docupedia

https://boc.sdn.sap.com/

https://www.sdn.sap.com/irj/sdn/businessobjects-sdklibrary
Developer resources
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LocationInformation Resource

https://www.sdn.sap.com/irj/boc/businessobjects-articles

These articles were formerly known as technical papers.
SAP BusinessObjects articles on
the SAP Community Network

https://service.sap.com/notes

These notes were formerly known as Knowledge Base articles.
Notes

https://www.sdn.sap.com/irj/scn/forumsForums on the SAP Community
Network

http://www.sap.com/services/education

From traditional classroom learning to targeted e-learning seminars, we
can offer a training package to suit your learning needs and preferred
learning style.

Training

http://service.sap.com/bosap-support

The SAP Support Portal contains information about Customer Support
programs and services. It also has links to a wide range of technical in-
formation and downloads. Customers with a maintenance agreement
have an authorized user ID to access this site. To obtain an ID, contact
your customer support representative.

Online customer support

http://www.sap.com/services/bysubject/businessobjectsconsulting

Consultants can accompany you from the initial analysis stage to the
delivery of your deployment project. Expertise is available in topics such
as relational and multidimensional databases, connectivity, database
design tools, and customized embedding technology.

Consulting

2012-11-06200

More Information

https://www.sdn.sap.com/irj/boc/businessobjects-articles
https://service.sap.com/notes
https://www.sdn.sap.com/irj/scn/forums
http://www.sap.com/services/education
http://service.sap.com/bosap-support
http://www.sap.com/services/bysubject/businessobjectsconsulting


Index
A

access
\folders 26
calendars 116
categories 30, 31
events 121
folders 27
profiles 142

Adaptive Job Server 197
enabling destinations 90

Add placeholder
personalized values 152, 168

administration 15
categories 31
events 121
folders 27
profiles 142
tools 15

agnostic source documents
replacing 164

alert notifications 91
alerting

alert sources 124, 125
overview of 123
subscriptions 131
workflow 124

Alerting 128
enabling 129
excluding others 132
rights conflicts 128
rights required 125
settings 132
subscriptions 129, 130, 132

alerts 129, 130, 131, 132
viewing 56

areas, management 16
audit notification 80, 185
authentication, object packages 72

B

BI Inbox
scheduling objects to 83
sending publications to 148

BI launch pad 58
categories 31
creating publications in 162
folders 28
publication results, viewing 189

C

cache format, Web Intelligence
documents 98

Cache Server
for viewing reports 44

calendars 110
creating 110
dates 111, 112
deleting 115
format options 111
recurring dates 113
specifying rights 116

categories 28
adding objects 30
creating 29
deleting 29
moving 30
removing/deleting objects 31
rights 31

CMC
creating publications in 162
logging on 15
management areas 16
navigating 16
publication results, viewing 189
setting preferences 17

CMC preference options 17
CMS, saving objects to 23
command line arguments, specifying

65
copying

folders 26
objects 33

creating
folders 25

Crystal reports
adding from SAP NetWeaver BW

57
adding with existing hyperlinks 54
alerts 56, 129, 130, 131, 132
alerts settings 132
database logon, configuring 182
database settings 45
delivery rules 145, 179, 180
dynamic recipient sources,

troubleshooting 196
filters 48
formats

additional options 172
specifying 172

Crystal reports (continued)
from SAP NetWeaver BW 58
job server for scheduling 44
PDF file merging

formatting 180
PDF merging 157
personalizing

with local profile targets 171
with parameters 170

printing 178
processing extensions 52
Publishing formats 153
refresh options 42
scheduling formats 94
specifying prompt values for 46
thumbnails 55
troubleshooting 195
viewing options 43

CSV, scheduling formats 94
custom events 116, 120

D

data refresh 144, 195
static source documents 164

database
logon, Crystal reports 182
settings 45

database fetches 144, 186
default values 60
delivery rules 145

global 180
recipient 179

destinations
available, by object type 37
BI Inbox 83
default settings 83
email 84, 168
enabling or disabling 90
FTP 87
publication names 151, 167
publications 148
scheduling 82
sending to 36
specifying 166
unmanaged disk 86

DLL files 51
dynamic recipients 147

adding 165
sources 147
troubleshooting 196

2012-11-06201



dynamic-link libraries, processing
extensions 51

E

email
embedding publication content in

168
notification 80, 184
publication instances,

troubleshooting 197
scheduling objects to 84
sending publications to 148

Emailing publications
using personalized placeholders

152, 168
Enterprise locations, publications 148
Enterprise recipients, adding 164
environment variables 67
events

access to 121
Alerting, enabling 129
alerts 129, 130, 131, 132
alerts settings 132
custom 120
file-based 117
managing 116
notification 80
publications 185
schedule-based 118
scheduling 99

Excel, scheduling formats 94
executable programs 64

configuring 66
exporting, objects to CMS 23
extensions, processing 51
external recipients 147

F

failed publications, retrying 193
Favorites folders 28
file events 116, 117
filtering

publication data 155
filters, for Crystal reports 48
folders 25

copying/moving 26
creating 25
default user folders 28, 31
deleting 26
Favorites folder 28
rights 27
setting instance limits 27

formats 177
Crystal reports 172

formats (continued)
mHTML 168
publications 153
Web Intelligence documents 177

FTP destination
publications 148
scheduling 87

G

global delivery rules 180
global profile targets 136, 137, 177

H

high-volume publications 144, 194
hyperlinks, between reports 53

I

importing 57
SAP NetWeaver BW content 57

Instance Manager 105
instances 108

columns 107
deleting 108
finding 106
managing 103, 105, 107
notification 80
object 41
object packages 70
pausing 108
program objects 63
redistributing 192
report objects 41
resuming 108
scheduled 41
sending 36
setting limits at the folder level 27
viewing 107

J

Java programs 64
configuring 68
providing access to other files 68
setting parameters 68

L

languages
viewing reports in 58

Life Cycle Manager 57
limits, folder level instances 27
local disk 148

local profile targets 136
Crystal reports 171
Web Intelligence documents 178

log on, CMC 15

M

management areas 16
merged PDF files, formatting 180
mHTML 168
migrating reporting content in SAP

NetWeaver BW 57

N

navigation, between reports 53
notification

audit 80
email 80
event 80

notifications
alerts 91
scheduled object 79

null values 61

O

object instances 41
object packages 71

adding objects to 21, 71
authentication 72
component failure 72
configuring 72
creating 71
instances 70
managing 70
scheduling 102

object properties in CMC 22
object shortcuts 34
objects

adding
to an object package 71
with CMC 21

changing
default settings 41
properties 39

copying 33
creating shortcuts to 34
deleting 34
exporting to CMS 23
failure notification 79
format 92
managing 33
moving 34
Run Now 102

2012-11-06202

Index



objects (continued)
saving to CMS 23
scheduling 75
search 35
sending 36
success notification 79

objects rights, when moving categories
30

P

parameters
and personalization 62
and variables in SAP NetWeaver

BW queries 60
Crystal reports 170
default values 60
dynamic picklists 61
Java programs 68
null values 61

passwords 17
PDF

merging 157
scheduling formats 94

performance, improving 194
personal categories 31
personalization 59
Personalized placeholder 152, 168
personalizing

Crystal reports 170, 171
publications 155
Web Intelligence documents 177, 

178
picklists 61
placeholder 151, 155, 167
plain text, scheduling formats 94
preferences

options for 17
preferences, setting in the CMC 17
preferred viewing locale 18
printing

assigning printers 49
Crystal report publications 178
Crystal reports 49

processing extensions 51
applying to reports 52
selecting 52

Processing Server 44, 195
processing settings 101
profiles 135

access to 142
conflicts 141
creating 136
global profile targets 137
profile resolution 186
profile targets 136

profiles (continued)
profile values 136

conflicts 141
types 138
variables 140

role in Publishing 135
program objects 63

authentication 69
environment variables 67
executable programs 66
Java programs 68
managing 63
working directory 65

prompts 46, 47, 182
publication extensions 156, 183
publication files

personalizing publications for 151, 
167

publication instances, redistributing
192

publication names
personalization 151, 167
placeholder 151, 167

publications 143, 161
additional options 178
creating

in BI launch pad 162
in CMC 162

delivery rules 145
destinations 148
dynamic recipients 147, 165
embedding content in email 168
Enterprise recipients, adding 164
finalizing 187
for SAP BusinessObjects Live

Office 161
formats 153
general properties 163
opening 163
personalization 155
personalizing names 151, 167
placeholder 155
publication extensions 156
redistributing instances 192
report bursting 144
scheduling 170, 188
source documents, adding 163
subscribing and unsubscribing

157, 188
testing 187
viewing results 189

publishing
rights 158
SAP integration 161

Publishing 143
profiles, role of 135

Publishing (continued)
rights 160

PVL 18

Q

queries, relationships 39, 40

R

recipients
delivery rules 179
dynamic 147
personalizing publications for 155
redistributing instances to 192

recurrence patterns, object scheduling
77

refreshing
reports 42
source document data 144, 195
static source document data 164

relationship queries 39, 40
Report Application Server 44, 196
report bursting 144, 186

agnostic source documents 164
static source documents 164

report instances
columns 107
history 103
managing 40, 107
setting limits 109
viewing 107

report objects
adding and hyperlinking 55
adding with existing hyperlinks 54
database settings, specifying 45
destination 82
filters, specifying 48
hyperlinking 53
hyperlinks, viewing 54
managing 40
processing extensions 52
prompt values 46
refresh options 42
scheduling with events 99
setting instance limits 109
specifying Job Servers for 44
specifying servers 44
viewing options 43

report tabs, publishing 177
reports 30

migrating with SAP NetWeaver BW
content 57

rich text, scheduling formats 94
rights

Alerting 125, 128

2012-11-06203

Index



rights (continued)
calendars 116
categories 31
events 121
folders 27
profiles 142
publishing 158
Publishing 160
when copying/moving folders 26

row-level security, processing
extensions 51

run options, object scheduling 78

S

SAP BusinessObjects Enterprise 59
personalization in 59

SAP BusinessObjects Enterprise SDK
51

SAP BusinessObjects Live Office 161
SAP BW

adding reports from 57
SAP Easy Access 58
SAP NetWeaver BW

adding reports from 57
migrating systems 57

schedule events 116, 118
scheduled instances 41
scheduling 75

events 99
formats 94
notification 79
object packages 102
objects 75

for group 76
for user 76
in batches 102
recurrence patterns 77
run options 78

scheduling (continued)
publications 170, 188
server group settings 101
server groups 185
specifying server for 44
with events 185

script programs 64
search 35
security, processing extensions 51
selecting

Enterprise recipients 164
separated values, scheduling formats

94
server groups, for scheduling 185
servers

default, for scheduling objects 44
for viewing and modifying reports

44
troubleshooting 194

shared libraries, as processing
extensions 51

source documents, troubleshooting
195

static source documents
replacing 164

subfolders, deleting 26
subscription 157, 188
Summary page, publications 187

T

test mode 187
third-party source documents

replacing 164
thumbnails, Crystal reports 55
tools, administration 15
top-level

creating new folders 25

translated reports
viewing 58

troubleshooting
dynamic recipient sources 196
email publication instances 197
failed publications 193
performance 194
source documents 195

TXT, scheduling formats 94

U

unmanaged disk destination 86
user folders 28

V

variables, for profile values 140

W

Web Intelligence documents
formats, specifying 177
personalization 177, 178
prompts 47
Publishing formats 153
selecting cache options 98
server for scheduling 44
troubleshooting 195
viewing universes 56

Word, scheduling formats 94
workflows

alerting 124
profiles and Publishing 135

X

XML, scheduling formats 94

2012-11-06204

Index


	Business Intelligence Platform User Guide
	Contents
	Document history
	Getting Started
	About this documentation
	Who should use this documentation?
	About SAP BusinessObjects Business Intelligence platform
	Licensing
	Key concepts
	Key tasks

	Working with the Central Management Console
	About the Central Management Console
	To log on to the CMC from your browser
	Navigating the CMC
	To set CMC preferences
	CMC preference options
	Preferred viewing locales


	Adding Objects to the Repository
	Adding objects to BI platform
	To add an object in the CMC
	CMC object property options

	Saving objects directly to the CMS


	Organizing Objects
	Folders
	Working with folders
	To create a new folder
	To delete a folder
	Copying and moving folders
	To copy or move a folder


	Specifying folder rights
	To limit instances at the folder level
	To view personal folders

	Categories
	Working with categories
	To create a new category
	To delete a category
	To move a category
	To add an object to a category
	To remove or delete objects from a category
	Specifying category rights
	To view the Personal Categories
	To add multiple objects to a category



	Working with Content Objects
	General object management
	To copy an object
	To move an object
	To create an object shortcut
	To delete an object
	To search for an object or objects
	To create a new hyperlink
	To send an object or an instance to a destination
	Available destinations by object type

	To change the properties of an object
	Relationships
	To check the relationships of an object


	Report object management
	What are report objects and instances?
	Setting report refresh options
	To set refresh options for a report

	Setting report viewing options
	To set report viewing options for a report

	Specifying default servers
	To specify default servers for processing an object

	To change the database settings
	To update default prompt values for a Crystal report
	To update the prompts for a Web Intelligence document
	To use filters
	Setting printer and page layout options
	To assign a printer
	To set a report's print layout options

	Processing extensions
	Applying processing extensions to reports
	To select a processing extension for a report


	Working with hyperlinked reports
	Adding reports with existing hyperlinks
	Viewing hyperlinked reports
	To add reports to the repository and then hyperlink them

	To show a thumbnail image of a Crystal report
	To view alerts in Crystal reports
	To view the universes for a Web Intelligence document

	Working with reports in an integrated environment
	Adding reports from NetWeaver BW to BusinessObjects Enterprise
	Adding reports to BI platform
	Adding reports in batches from NetWeaver BW

	Migrating development content to a production SAP NetWeaver BW system
	Viewing reports
	To view a report in BI launch pad
	To view a published report through SAP Easy Access

	Personalizing reports generated from SAP NetWeaver BW queries
	Parameters
	To view a report with default parameter values
	To view a report using parameter values from a dynamic picklist
	Null parameter values in scheduled reports
	To view a report with null parameter values

	Personalized parameter values in scheduled reports
	To view a report with personalized parameter values




	Program object management
	What are program objects and instances?
	Program types

	Setting program processing options
	To specify command-line arguments
	Setting a working directory for a program object
	To set a working directory for a program object
	To modify the default working directory for program objects


	Configuring executable programs
	To specify paths to required files
	To upload required files
	To add an environment variable

	Configuring Java programs
	To specify required parameters for Java programs
	To provide Java programs with access to other files

	To specify a user account for a program object

	Object package management
	What are object packages, components, and instances?
	To create a new object package
	Adding objects to an object package
	To add a new object to an object package

	Configuring object packages and their objects
	To set component failure options for an object package

	Authentication and object packages


	Scheduling Objects
	Scheduling
	Setting options for scheduling
	To schedule an object
	To change the Schedule For settings for an object
	Recurrence pattern options
	Run options and parameters

	Setting notification for the success or failure of a scheduling job
	Determining the success or failure of a scheduling job
	Notification types
	To set notification for an instance's success or failure

	Selecting a destination
	To set your destination as the default
	To schedule an object to a BI Inbox destination
	To schedule an object to an email destination
	To set the destination to a file location
	To set the destination to an FTP server
	To schedule an object to a StreamWork workspace
	To enable or disable destinations for a job server

	Specifying alert notification
	To set alert notification

	Choosing a format
	To select a format
	Additional formatting options for Crystal reports

	To select a cache format for Web Intelligence documents
	Scheduling an object with events
	To schedule an object to run based on an event
	To schedule an object to trigger an event

	To select a server for your scheduling job
	To select languages for report instances

	To run objects now
	Scheduling objects using object packages

	Managing instances
	Viewing instance information
	Instance Manager
	Finding specific instances in the Instance Manager

	To manage instances for an object
	To view an instance

	Pausing or resuming an instance
	To pause an instance
	To resume a paused instance

	To delete an instance
	To set limits for instances

	Calendars
	To create a calendar
	To add dates to a calendar
	Calendar format options
	Specific dates
	Recurring dates

	To delete a calendar
	Specifying calendar rights

	Events
	File-based events
	To create a file-based event

	Schedule-based events
	To create a schedule-based event

	Custom events
	To create a custom event
	To trigger a custom event

	Specifying event rights


	Alerting
	Alerting
	Alerting object sources
	Alerting workflow
	Differences between alerting and Crystal report alert notifications
	Rights required for Alerting
	Resolving subscription conflicts

	Working with Alerting
	Locating alert source objects in the Central Management Console
	To enable Alerting for an event
	To subscribe to an alert
	To unsubscribe from an alert
	To subscribe other users to an alert
	To unsubscribe others from an alert
	To exclude users from an alert
	To manage Alerting settings for an alert source
	Alerting management recommendations


	Managing Profiles
	How profiles work
	Profiles and the Publishing workflow
	To create a profile

	Profile targets and profile values
	To specify a global profile target
	Specifying profile values
	To specify a profile value
	To use variables as profile values


	Resolving conflicts between profiles
	Conflicts between profile values

	Specifying profile rights

	Publishing
	About publishing
	What is a publication?
	Publication concepts
	Report bursting
	Delivery rules
	Dynamic recipients
	Destinations
	Possible destinations

	Personalized placeholders for publication source document names
	Personalized placeholders for email fields
	Formats
	Possible formats

	Personalization
	Publication extensions
	Subscription
	PDF merging for Crystal reports

	Rights required for Publishing
	Publishers and recipients: Who has rights to view what?


	Working with Publications
	Designing publications
	Designing publications for use with SAP BusinessObjects Live Office
	Designing publications for SAP recipients
	To create a new publication in the CMC
	To create a new publication in BI launch pad
	To open an existing publication
	To enter general properties for a new publication
	To select source documents
	To replace static source documents

	To select Enterprise recipients
	To specify dynamic recipients
	To specify a destination for the publication
	Personalized placeholders for publication source document names
	Personalized placeholders for email fields
	To embed content from a dynamic content source document in an email
	To specify scheduling information
	Design tasks for Crystal reports publications
	To personalize a Crystal report using parameter values
	To personalize a Crystal report by filtering fields
	To specify formats for a Crystal report
	Additional customization options for Crystal reports formats


	Design tasks for Web Intelligence document publications
	To specify formats for an Web Intelligence document
	To personalize an Web Intelligence document using a global profile target
	To personalize a Web Intelligence document by filtering fields

	Using additional publication features
	Additional publication features for Crystal report publications
	To set print options for a Crystal report in a publication
	To set a recipient delivery rule on a Crystal report
	To set a global delivery rule on a Crystal report
	To format the merged PDF
	To configure database logon information for a Crystal report

	Additional publication features for Web Intelligence document publications
	To change the prompt value for a Web Intelligence document

	To specify publication extensions
	To configure email notification for successful or failed publication jobs
	To enable auditing notification for publication jobs
	To specify events
	To set a server group option
	To specify a profile resolution method
	To specify a report bursting method


	Post-design publication tasks
	Finalizing the publication
	To test a publication
	To subscribe to or unsubscribe from a publication
	To schedule a publication to run
	Viewing publication results
	To redistribute a publication instance
	To retry a failed publication

	Improving publication performance
	Recommendations for adding source documents
	Recommendations for using dynamic recipient sources
	Recommendations for sending and receiving email publication instances


	More Information
	Index


