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Typographic Conventions 

Type Style Description 

Example Words or characters quoted from the screen. These include field names, screen titles, 

pushbuttons labels, menu names, menu paths, and menu options. 

Textual cross-references to other documents. 

Example Emphasized words or expressions. 

EXAMPLE Technical names of system objects. These include report names, program names, 

transaction codes, table names, and key concepts of a programming language when they 

are surrounded by body text, for example, SELECT and INCLUDE. 

Example Output on the screen. This includes file and directory names and their paths, messages, 

names of variables and parameters, source text, and names of installation, upgrade and 

database tools. 

Example Exact user entry. These are words or characters that you enter in the system exactly as 

they appear in the documentation. 

<Example> Variable user entry. Angle brackets indicate that you replace these words and characters 

with appropriate entries to make entries in the system. 

EXAMPLE  Keys on the keyboard, for example, F2  or ENTER . 
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1 About this Document 

This document provides information about the following topics: 

¶ Onboarding of users into SAP Asset Strategy and Performance Management 

¶ Business Process Integration - Systems such as PdMS, C4C, IoT, ERP 

¶ Creation of Extensions in SAP Asset Strategy and Performance Management 

You can find the following on SAP Help Portal at: 

¶ Application Help (how to use SAP Asset Strategy and Performance Management) 

¶ API Tutorial with API references 

¶ Security Guide 

 

1.1 Target Audience 

This guide is intended for users who handle the administration and configuration of SAP Asset Strategy and 

Performance Management. 

1.2 Support 

BCP component:  

¶ IOT-ASM-APL (Applications related) 

http://help.sap.com/ain


 

6 

PUBLIC  

© 2018 SAP SE or an SAP affiliate company. All rights reserved. 

Administrator's Guide for SAP Asset Strategy and Performance Management 

General Information 

 

2 General Information 

SAP Asset Strategy and Performance Management is available in the following languages: 

¶ English 

¶ German 

¶ French 

¶ Spanish 

¶ Italian 

¶ Japanese 

¶ Polish 

¶ Danish 

¶ Russian 

¶ Simplified Chinese 

 

2.1 Supported Browsers and Devices Requirements 

Device Name Supported Operating System Supported Browser 

iPad Mini 4/5 iOS 8.X/7.X Safari 7.x, Safari 8.x, SAP Fiori 

client 1.2 

iPad 2 iOS 8.X/7.X Safari 7.x, Safari 8.x, SAP Fiori 

client 1.2 

iPad 4 iOS 8.x/7.x Safari 7.x, Safari 8.x, SAP Fiori 

client 1.2 

Samsung Galaxy S4 Android 5.0/4.X Chrome 39.X, SAP Fiori client 1.2 

iPhone 5 iOS 8.x/7.x Safari 7.x, Safari 8.x, SAP Fiori 

client 1.2 

PC Windows 32 bit/64 bit Windows 7.1 / Windows 8.1 IE9, Chrome39.X, Fire Fox34.X, 

SAP Fiori client 1.2 
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Mac iOS 10.9/10.10 Safari 7.x, Safari 8.x, SAP Fiori 

client 1.2 
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3 Getting Started 

This section gives an overview of the steps required to grant access to SAP Asset Strategy and Performance 

Management. 

¶ Onboarding: The master user receives an e-mail with an invitation to join the SAP Asset Strategy and 

Performance Management, as an administrator. The administrator can then invite users to join the 

application and restrict the areas of the application they can access by assigning specific roles. For more 

information, see: ,Application Help -> Configuration Tasks -> Roles. 

¶ Preliminary Steps Before User Authorization: As an administrator, you must perform the following before 

granting user authorization. For more information, see: Mapping Assertion Groups in the Trusted Identity 

Provider 

¶ User Authorization in SAP Asset Strategy and Performance Management: As an administrator, you can 

adopt one of these two approaches in granting authorization: 

o Assigning Users to Authorization Groups in IDP: This is the recommended approach to authorize users in 

bulk. 

o Assigning Individual Users to Authorization Groups: Use this approach when you need to authorize users 

individually. 

¶ Activating User IDs in SAP Asset Strategy and Performance Management after Authorization: The procedure 

that users must follow after authorization. 

3.1 Mapping Assertion Groups in the Trusted Identity 
Provider 

This procedure is a prerequisite for assigning users to authorization groups in IDP. 

Prerequisites 

You are the organization administrator. 

Procedure 

1. Log in to your HANA Cloud Platform consumer account. 

2. Navigate to Trusted->Trusted Identity Provider and open your default trusted identity provider. 

3. Choose the Groups tab and click Add Assertion-Based Group. 

4. In the Assertion-based Groups section, map the authorization group as shown in the figure: 

http://help.sap.com/ain
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Note: For the Mapping Rules section, use the assertion attributes that you have configured in IDP. Refer 

to the figure below: 

5. Choose Save. 

 

3.2 Assigning Users to Authorization Groups in IDP 

This procedure is the recommended approach to assign users to authorization groups in bulk. 

Prerequisites 

You are assigned the role of an organization administrator 

The assertion groups are mapped in the Trusted Identity Provider in the HANA Cloud Platform cockpit. For more 

information see: Mapping Assertion Groups in the Trusted Identity Provider. 

Procedure 

1. Log on to the IDP Administration Console. 

2. Using the CSV template, import users along with authorization groups. 
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The users are added in the IDP. 

3. Log on to SAP Asset Strategy and Performance Management. 

4. Launch the Application Settings app. 

5. Choose Users->Add->Mass Upload Users. 

6. Upload the CSV template with the user information. 

Users get added to the IDP, and an account activation e-mail is sent to the newly-added users. 

Note: After you have added the user to the IDP, the users must set their passwords and activate their 

account in SAP Asset Strategy and Performance Management. Refer to: Activating User IDs in SAP Asset 

Strategy and Performance Management after Authorization  

 

3.3 Assigning Individual Users to Authorization Groups 

You perform this procedure in the HANA Cloud Platform cockpit to assign individual users to authorization 

groups. 

Prerequisites 

The relevant user has already been added in the IDP. 

 

Procedure 

1. Log on to your HANA Cloud Platform consumer account. 

2. Navigate to Security->Authorizations -> Groups. 

3. From the Individual Users section, choose Assign to enter user ID of the user (obtained from IDP). Refer to 

the figure below: 

4. Log on to SAP Asset Strategy and Performance Management. 

5. Launch the Application Settings app. 

6. Navigate to Users->Add->Single User 
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7. Enter the user ID, first and last name, email address and the organization name. 

Note: To add multiple users, perform the following substeps: 

1. Download the CSV template provided by SAP. 

2. Enter the user ID, first and last name, email address and organization name in the template. 

3. Log on to SAP Asset Strategy and Performance Management. 

4. Launch the Application Settings app. 

5. Navigate to Users->Add->Mass Upload Users. 

6. Upload the CSV template with the user information. 

8. Share the SAP Asset Strategy and Performance Management link with the user. 

Note: After you have added users, the users must set their password and activate their account in SAP 

Asset Strategy and Performance Management. Refer to: Activating User IDs in SAP Asset Strategy and 

Performance Management after Authorization . 

 

3.4 Activating User IDs in SAP Asset Strategy and 
Performance Management after Authorization 

 

Then users must perform the following activity after they have been added to SAP Asset Strategy and 

Performance Management. 

Context 

The user must perform the following procedure only after you have added the user information in the Application 

Settings app in the Users tab. 

Procedure 

1. Open the account activation e-mail from your inbox and set your password as suggested in the e-mail. 

2. Log on to SAP Asset Strategy and Performance Management using the organization’s e-mail ID and the 

password you have set from the account activation mail. 

Results 

Your user profile page opens up where you can view and edit your profile. 
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4 Business Process Integration 

It is possible to integrate SAP Asset Strategy and Performance Management with external systems. This is 

achieved by configuring SAP Asset Strategy and Performance Management in HANA Cloud Integration system. 

By this configuration, external systems such as SAP Cloud for Customer, SAP HANA Cloud Platform Internet of 

Things, SAP Predictive Maintenance and Services, can be configured in SAP Asset Intelligence Network. 

4.1 Configuring HANA Cloud Integration System in SAP 
Asset Strategy and Performance Management 

You perform this procedure as a prerequisite to configuring external systems such as SAP Cloud for Customer 

(C4C), SAP HANA Cloud Platform Internet of Things (HCP IoT), SAP Predictive Maintenance and Services (PdMS) 

with SAP Asset Strategy and Performance Management. 

Prerequisites 

¶ You have the role ORG_ADMIN configured to your user ID. 

¶ You have access to the HANA Cloud Integration (HCI) account. 

¶ You have the link to access the Integration_Flow file. 

Procedure 

1. Log on to your HCI account. 

2. On the HANA Cloud Integration landing page, click Discover (icon with spectacles). 

3. From the HCI Content Hub, choose the SAP Asset Strategy and Performance Management Integration 

Scenarios package. 

4. Choose AIN IoT Integration for PdMS and HCP IoT systems. Choose C4C Service Requests Integration for 

C4C integration. 

5. Click Import. 

6. From the HANA Cloud Integration landing page, choose the Design tab. 

7. From the Integration Flow Package, choose Actions->Deploy. 

The Integration_Flow file gets deployed to the HCI system 

.Note: To check for deployment status, choose the Monitor tab and verify. 

8. Log on to SAP Asset Strategy and Performance Management. 

9. Launch the Application Settings app. 

10. Navigate to Systems->Add->HCI. 

Note: You can configure only one HCI system in SAP Asset Strategy and Performance Management. 

11. In the Add System pop-up window, fill in the following: 
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Field Description 

System Type HCI (autopopulated) 

System Name Enter a unique system name 

System Status Set to Active 

URL Information Provide the host URL of the HCI system. For 

example:https://cd2ain1-

iflmap.hcisb.hana.ondemand.com/ 

Additional Information Fill in additional information as necessary 

Is System Primary Not relevant for this procedure 

12. Choose OK. 

You have configured the HCI system in SAP Asset Strategy and Performance Management. As next steps, 

you can configure SAP PdMS, C4C, and HCP IoT systems in SAP Asset Strategy and Performance 

Management. 

 

4.2 Maintaining Client ID by Adding User Credentials 

You perform this procedure to input the Client ID while configuring an external system in SAP Asset Strategy and 

Performance Management. 

Prerequisites 

You have access to the SAP HANA Cloud Integration (HCI) account. 

Procedure 

1. Log on to your HCI account. 

2. From the HCI landing page, choose Monitor->Manage Security Material. 

3. Choose Add->User Credentials. 

4. In the Add User Credentials pop-up window, enter the following: 
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Field Description 

Name Enter a name denoting the system you are going to 

configure. For example: PdMS 

Description Provide a meaningful description 

User Provide the external system ID 

Password Provide the external system password 

Note: Use the Name that you have provided in the Add User Credentials pop-up as the Client ID while 

configuring an external system in SAP Asset Strategy and Performance Management. 

5. Choose OK. 
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4.3 Retrieving Links from the Internet of Things Services 
Cockpit 

You perform this procedure to be able to input the URL information while configuring the SAP HANA Cloud 

Platform Internet of Things with SAP Asset Strategy and Performance Management. 

Context 

Using this procedure, you can retrieve the Remote Device Management Service (RDMS) and Message 

Management Service (MMS) links from the Internet of Things Services cockpit. 

Procedure 

1. Log on to Internet of Things Services Cockpit. 

2. Navigate to My User->About IoT Services. 

The SAP HCP Internet of Things Services screen displays. 

 

3. Under the section Device Management API, you find the RDMS link. For example: https://iotrdmsiotservices-

i041491trial.hanatrial.ondemand.com 

4. Go to the Application Data screen and click OData API. 

The link corresponding to Service Root pertains to the MMS link. For example: 

https://iotmmsi041491trial.hanatrial.ondemand.com 

Note: You use the above links while configuring the HANA Cloud Platform Internet of Things with SAP 

Asset Strategy and Performance Management. 

https://iotmmsi041491trial.hanatrial.ondemand.com/
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4.4 Configuring External Systems in SAP Asset Strategy and 
Performance Management 

You use this procedure to configure external systems with SAP Asset Strategy and Performance Management. 

Context 

For simplicity, this procedure explains configuring SAP Predictive Maintenance and Services (PdMS) in SAP Asset 

Strategy and Performance Management. Use the same procedure to configure other external systems such as 

SAP Cloud for Customer (C4C) and SAP HANA Cloud Platform Internet of Things (SAP HCP IoT). 

Prerequisites 

¶ You have configured the SAP HANA Cloud Integration system in SAP Asset Strategy and Performance 

Management. For more information see: Configuring HANA Cloud Integration System in  SAP Asset Strategy 

and Performance Management. 

¶ You have obtained the Client ID of the external system. For more information, see Maintaining Client ID by 

Adding User Credentials. 

Procedure 

1. Log on to SAP Asset Strategy and Performance Management. 

2. Launch the Application Settings app. 

3. Choose the Systems tab. 

4. Choose Add. 

5. Choose the external system. For example: SAP PdMS. 

6. In the Add System pop-up window, provide the details as listed: 

https://help.sap.com/viewer/DRAFT/d89bac86aa294f75afdc40dca457dd7b/1711/en-US/cefb7442466248b38833ecc4014972a0.html
https://help.sap.com/viewer/DRAFT/d89bac86aa294f75afdc40dca457dd7b/1711/en-US/be54af5128b1470aa0d448d3b96e2791.html
https://help.sap.com/viewer/DRAFT/d89bac86aa294f75afdc40dca457dd7b/1711/en-US/be54af5128b1470aa0d448d3b96e2791.html
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Field Description 

System Name Provide a unique system name 

Client As provided while adding user credentials in your HCI 

account. For more information, see:  Maintaining 

Client ID by Adding User Credentials 

System Status Active or Inactive 

URL Information URL of the external system.NoteIf you are 

configuring the SAP HCP IoT Services, input the 

RDMS and MMS links. For more information, 

see Retrieving Links from the Internet of Things 

Services Cockpit 

Additional Information As necessary 

7. Choose OK. 

The external system with details gets populated in the Systems list in the Application Settings window. 

 

4.5 Integration of SAP Asset Strategy and Performance 
Management with Enterprise Asset Management (On-
premise) 

The following are achieved when SAP Asset Strategy and Performance Management and Enterprise Asset 

Management (on-premise) (EAM) are integrated: 

¶ SAP Asset Strategy and Performance Management Model Information Display: SAP Asset Strategy and 

Performance Management model information corresponding to the objects in the EAM system display on a 

side panel in the EAM system. The corresponding objects in EAM can related to equipment, functional 

location, announcements or work orders. 

¶ Creation of SAP Asset Strategy and Performance Management Model Attachments: You can replicate 

attachments for SAP Asset Strategy and Performance Management models in the EAM system. These 

attachments are available from the relevant EAM equipment or functional locations. 

Integration Prerequisites and Implementation 

To integrate SAP Asset Strategy and Performance Management with Enterprise Asset Management, follow the 

prerequisites and implementation guidance provided in SAP Notes: 

¶  2327152 Information published on SAP site 

¶ 2366582 Information published on SAP site 
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¶ 2413805 Information published on SAP site 

¶ 2422598 Information published on SAP site 

¶ 2405074 Information published on SAP site  

¶ 2487705 Information published on SAP site. 
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5 Extension to Applications of SAP Asset 
Strategy and Performance Management 

An extension is a dynamic section or plug-in that you can create on the object page of SAP Asset Strategy and 

Performance Management. 

An extension is any section that you want to add to the existing object pages of Equipment and Models. As an 

administrator, you can create an extension and customize it to suit your business requirements. Here are a few 

points about an extension in SAP Asset Strategy and Performance Management: 

¶ You can create the extension for a model or an item of equipment. 

¶ To create an extension, you must code a View-Controller file based on the MVC architecture of UI5, and 

upload the file on the network for approval. 

¶ Upon approval from the SAP Operations team, you can use this extension on the network. 

¶ The new extension you created is available to all the organizations that the Equipment or Model is associated 

with. 

 

5.1 Coding the View-Controller Files 

You perform this procedure as a prerequisite to creating an extension in SAP Asset Strategy and Performance 

Management. 

Procedure 

1. Create a UI5 view for the extension. 

2. To create a UI5 controller, follow these substeps: 

1. Use the same name in the controller as you specified in the view file. 

2. Ensure that the controller inherits an ExtensionBaseController. You can achieve this by following this 

example: 

Sample Code 

sap.ui.define([ 

 "sap/iot/ain/lib/reusable/view/ExtensionBaseController" 

], function(Controller) { 

 "use strict"; 

 

 return Controller.extend("myCompany.equipment.customSection", {}); 

}); 

This enables your controller to access the following using controller instance variables: 

o The Object Page Controller (this._oParentController) 

o The Router of the application (this._oRouter) 
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o The Event Bus (this._oEventBus) 

o The Object Page (this._ oObjectPage) 

o Application Component (this. _oComponent) 

Note 

o When initializing the controller, you can use the _initSection method if necessary. 

o To refresh the section and fetch data each time, use the function fnRenderSection. 

o Both methods _initSection and fnRenderSection have an object parameter containing the ID and the 

version of the model or equipment. 

Sample Code 

{ 

id:32-char Id,  

status: statusCode //("1" - Unpublished, "2" - Published, "3" - In revision), 

version: versionNumber 

} 

3. You can add event handlers and other required methods as per standards and conventions of UI5/openUI5. 

4. To ensure that the added functionality works fine, wrap each function in a try-catch block. An example is 

shown here: 

Sample Code 

onAddButtonClick: function(){ 

 try{ 

 //Function Execution Statements 

}catch(err){ 

 this.oView.destroy(); 

} 

} 

5. Make service calls in your custom sections through the AIN services. Use the following method to make the 

service call: 

Sample Code 

URL: “/ain/rest/testCall” 

Type: “PUT”, 

Payload: { 

 “url”:”YOUR URL”, 

 “payload”:{YOUR PAYLOAD, if any}, 

 “type”:”GET/PUT/POST”, 

 “headers”:”REQUEST HEADERS, if any” 

} 

Results 

You have the coded View-Controller files. 
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6 Creating an Extension for Business 
Objects 

You create an extension to business objects when you want to customize the the respective applications to suit 

your business requirements. The extension acts as a plug-in and is available to all organizations associated with 

the relevant business object. 

Prerequisites 

You have coded the view and controller files. For more information, see Coding the View-Controller Files. 

Procedure 

1. Log on to SAP Asset Strategy and Performance Management. 

2. Launch the Application Settings app. 

3. Go to the Extensions tab. 

4. Choose New. 

5. In the New Extension pop-up, enter a name and description for the extension. 

The name you enter here shows up as the title on the object page. 

6. Upload the View and Controller files. For more information, see  Coding the View-Controller Files 

7. Mention if the extension is relevant for a model, equipment, locations or spare parts. 

8. Choose OK. 

9. Choose Submit. 

Note: Upon choosing Submit, your new extension is sent to the SAP Operations team for approval. Upon 

approval, you will find your new extension in the respective object page as a new tab. 
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7 Other Configuration Tasks 

As an administrator, you can perform a few more configurations tasks other than the ones described in this 

document. They are: 

1. Configuring document upload size. 

2. Prefix for objects created in SAP Asset Strategy and Performance Management 

Objects created in the SAP Asset Strategy and Performance Management will have IDs generated for them. 

You have to define the prefix in the Application Settings app. For example, for instruction the ID can be I. 

ABCD.1, where <ABCD> is the prefix defined by you. Another example for ID for a document can be D.ABCD.1. 

For details regarding these tasks, refer to: http://help.sap.com/ -> SAP Asset Strategy and Performance 

Management ->Application Help->Configuration Tasks. 

http://help.sap.com/ain
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