What's New

Core

Core Components, 2019

Technical Component

Capability

Environment

Title

Description

Type

Available as of

Cloud Foundry Environment DevOps Cloud Foundry Version 11.0.0

Cloud Foundry has been updated from version 9.5.0 to 11.0.0

New 2019-09-05
SAP Java Buildpack Application Runtime Cloud Foundry Version 1.16.2 The SAP Java buildpack has been updated from version 1.15.1 to 1.16.2. New 2019-09-05
SAP Java Buildpack Application Runtime Cloud Foundry XS Security Library Version 2.16.4 XS Security Library has been updated to version 2.16.4. New 2019-09-05
SAP Java Buildpack Application Runtime Cloud Foundry DNS Caching

From buildpack version 1.15.1 onwards the SAP JVM/SAPMachine DNS caching is disabled by default and BOSH DNS caching is applied instead.

From version 1.16.2 applications can now choose to switch back to SAPJVM/SAPMachine DNS caching instead of BOSH DNS caching by using the following environment variable - JBP_CONFIG_DNS_CACHE: "[enabled: false]".

Changed 2019-09-05
SAP Java Buildpack Application Runtime Cloud Foundry Error Handling with "skiperrors" Flag Error handling for the “skiperrors” flag is now fixed and it handles all errors during the download of an agent. You can use it by adding "skiperrors" : "true" to the Dynatrace service instance credentials. As a result, when staging an application with a bound Dynatrace service instance, you can skip potential errors during the download of the agent, so that the application is staged successfully. Changed 2019-09-05
Support Components DevOps Cloud Foundry Cleanup of BC-NEO-CF The component BC-NEO-CF and all its subcomponents BC-NEO-CF-* are renamed to BC-CP-CF and BC-CP-CF-*. For example, component BC-NEO-CF-ACS is changed to BC-CP-CF-ACS. Changed 2019-08-15
Cloud Cockpit User Experience
  • Neo
  • Cloud Foundry
Exporting Cost Information for Global Accounts When you export data to a Microsoft Excel file in the Global Account Overview page, information about the costs for global accounts that use the consumption-based commercial model is now included. See Monitoring Usage and Cloud Credits Balance [AWS, Azure, or GCP]. New 2019-08-15
Cloud Cockpit User Experience
  • Neo
  • Cloud Foundry
Filtering Subaccounts for Assigning Entitlements When configuring entitlements and quotas from a global account, you can now filter subaccounts by role, environment and region. This option is available for global accounts with more than 20 subaccounts. See Configure Entitlements and Quotas for Subaccounts. New 2019-08-01
SAP Java Buildpack Application Runtime Cloud Foundry Version 1.15.1 The SAP Java buildpack has been updated from version 1.14.0 to 1.15.1. New 2019-08-01
Email Notifications User Experience Neo Direct Link to DB When you receive an email about a required database migration, you will be able to open the respective system in the cockpit with one click directly from the email message. New 2019-08-01
SAP Java Buildpack Application Runtime Cloud Foundry Disable Default DNS Caching You can now disable the default SAP JVM/SAPMachine DNS caching instead of the BOSH DNS caching. Changed 2019-08-01
SAP Java Buildpack Application Runtime Cloud Foundry Fix for Escaping Whitespaces Whitespaces in the names of organizations and spaces are no longer escaped in versions 1.15.1 and above of SAP Java buildpack. In earlier versions, the staging of an application fails when a whitespace exists in the organization or space name. If you are using whitespaces in your orgs and spaces, switch to the latest buildpack version, or replace the whitespaces with other characters. Changed 2019-08-01
Cloud Foundry Environment DevOps Cloud Foundry Version 9.5.0

Cloud Foundry has been updated from version 9.3.0 to 9.5.0

New 2019-08-01
Cloud Foundry Environment DevOps Cloud Foundry Version 9.3.0

Cloud Foundry has been updated from version 9.2.0 to 9.3.0

v9.3.0Information published on non-SAP site

New 2019-07-18
Cloud Cockpit User Experience Cloud Foundry Consuming Non-SAP Commercial Services

You can now consume remote services from non-SAP cloud vendors in SAP Cloud Platform. Currently, you can consume only PostgreSQL from Amazon Web Services. Additional supported vendors and service consumables are in the pipeline.

See Managing Resource Providers [AWS, Azure, or GCP] and Configure Entitlements and Quotas for Subaccounts.

New 2019-07-18
SAP Java Buildpack Application Runtime Cloud Foundry SapMachine You can now use SapMachine, instead of the default SAP JVM. See SapMachine. New 2019-07-18
SAP Java Buildpack Application Runtime Cloud Foundry Version Update

Apache Tomcat has been updated from version 8.5.40 to 8.5.42

Apache TomEE 7 has been updated from version 7.0.5 to 7.0.6

New 2019-07-18
Go Buildpack Application Runtime Cloud Foundry Deprecating Go Versions 1.11.x

The Cloud Foundry Go buildpack is planning to remove the support for Go versions 1.11.x and no longer include them. See https://lists.cloudfoundry.org/g/cf-dev/message/8674Information published on non-SAP site.

The new buildpack release containing this change is expected to become available in the SAP Cloud Platform Cloud Foundry environment by the end of August 2019. Please migrate your Go applications to supported versions of Go before that time. Unless you are manually specifying a version of Go for the buildpack to use, no action is required.

Announcement 2019-07-18
PHP Buildpack Application Runtime Cloud Foundry Deprecating nginx Versions 1.15.x

The Cloud Foundry PHP buildpack is planning to remove the support for nginx versions 1.15.x and no longer include them. See https://lists.cloudfoundry.org/g/cf-dev/message/8673Information published on non-SAP site.

The new buildpack release containing this change is expected to become available in the SAP Cloud Platform Cloud Foundry environment by the end of August 2019. Please migrate your PHP applications to supported versions of nginx before that time. Unless you are manually specifying a version of nginx for the buildpack to use, no action is required.

In addition, the default version of nginx will be bumped to 1.17.x at this time.

Announcement 2019-07-18
Staticfile Buildpack Application Runtime Cloud Foundry Deprecating nginx Versions 1.15.x

The Cloud Foundry Staticfile buildpack is planning to remove the support for nginx versions 1.15.x and no longer include them. See https://lists.cloudfoundry.org/g/cf-dev/message/8672Information published on non-SAP site.

The new buildpack release containing this change is expected to become available in the SAP Cloud Platform Cloud Foundry environment by the end of August 2019. Please migrate your staticfile applications to supported versions of nginx before that time. Unless you are manually specifying a version of nginx for the buildpack to use, no action is required.

In addition, the default version of nginx will be bumped to 1.17.x at this time.

Announcement 2019-07-18
R Buildpack Application Runtime Cloud Foundry Deprecating R Versions 3.4.x & 3.5.x

The Cloud Foundry R buildpack is planning to remove the support for R versions 3.4.x & 3.5.x and no longer include them. See https://lists.cloudfoundry.org/g/cf-dev/message/8671Information published on non-SAP site.

The new buildpack release containing this change is expected to become available in the SAP Cloud Platform Cloud Foundry environment by the end of August 2019. Please migrate your R applications to supported versions of R before that time. Unless you are manually specifying a version of R for the buildpack to use, no action is required.

Announcement 2019-07-18
.NET Buildpack Application Runtime Cloud Foundry Deprecating .NET Versions 1.0.x & 1.1.x

The Cloud Foundry .NET Core buildpack is planning to remove the support for dotnet-runtime versions 1.0.x & 1.1.x and no longer include them. See https://lists.cloudfoundry.org/g/cf-dev/message/8670Information published on non-SAP site.

The new buildpack release containing this change is expected to become available in the SAP Cloud Platform Cloud Foundry environment by the end of August 2019. Please migrate your .NET applications to supported versions of dotnet-runtime before that time. Unless you are manually specifying a version of dotnet-runtime for the buildpack to use, no action is required.

Announcement 2019-07-18
Region DevOps Neo US West (Colorado Springs) US West (Colorado Springs) (neo-us4) is available as a new region for use with enterprise accounts. See Regions and Hosts Available for the Neo Environment. New 2019-07-04
SAP Java Buildpack Application Runtime Cloud Foundry Version Update

SAP HANA drivers have been updated to version 2.5.6 and 1.120.52.

Instance Manager has been updated to version 1.15.4.

cf-java-logging-support has been updated to version 3.0.0.

Announcement 2019-07-04
Cloud Foundry Environment DevOps Cloud Foundry Version 9.2.0

Cloud Foundry has been updated from version 9.1.0 to 9.2.0

v9.2.0Information published on non-SAP site

New 2019-07-04
Planning and Lifecycle Management DevOps
  • Neo
  • Cloud Foundry
  • ABAP
Best Practices

We've added two sections on how to plan and implement failover on SAP Cloud Platform to the SAP Cloud Platform Planning and Lifecycle-Management Guide.

See Planning Failover on SAP Cloud Platform and Implementing Failover.

New 2019-06-20
Cloud Foundry Environment DevOps Cloud Foundry Version 9.1.0

Cloud Foundry has been updated from version 9.0.0 to 9.1.0

v9.1.0Information published on non-SAP site

New 2019-06-20
SAP Java Buildpack Application Runtime Cloud Foundry Memory Calculator V2

Memory Calculator V2 is now the default memory calculator instead of SAP JVM Memory Calculator. See Memory Calculator V2.

In case of problems with staging an application that is using the new default memory calculator, try the following:

  • Pin the application to a previous verison of the buildpack;

  • Switch the application to the SAP JVM Memory Calculator: set the environment variable MEMORY_CALCULATOR_V1: true.

Announcement 2019-06-20
SAP Java Buildpack Application Runtime Cloud Foundry Version Update

SAPJVM has been updated to version 81.55.55.

JCo has been updated from version 3.0.3 to version 3.2.0.

Announcement 2019-06-20
Node.js System Buildpack Application Runtime Cloud Foundry Deprecating Node.js v11.x

The Cloud Foundry Node.js system buildpack is planning to remove support for Node.js versions 11.x and no longer include them. See https://lists.cloudfoundry.org/g/cf-dev/message/8631Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of June or July 2019. If you are manually specifying a version of Node.js for the buildpack to use or if you have customized your Node.js buildpack, you need to change your applications before that. Otherwise, no action is required.

Announcement 2019-06-20
Cloud Cockpit User Experience
  • Neo
  • Cloud Foundry
Show Costs of Global Account

In global accounts licensed with the consumption-based commercial model (CPEA), you can now view and monitor the costs of services in the Global Account overview page in the cockpit.

See Monitoring Usage and Cloud Credits Balance [AWS, Azure, or GCP].

New 2019-06-20
Multitenancy Developer Experience Cloud Foundry Improved Error Handling for Subscriptions to Multitenant Applications The background process for subscribing to subaccount to multitenant applications in the cockpit have been optimized to improve error handling. In the event of an error, the job ID, component, dependencies, and error details are provided thus allowing application owners to report an incident with more precise details to help expedite the resolution of the incident. Changed 2019-06-20
Cloud Foundry Environment DevOps Cloud Foundry Version 9.0.0

Cloud Foundry has been updated from version 8.1.0 to 9.0.0

v9.0.0Information published on non-SAP site

New 2019-06-06
Cloud Cockpit DevOps
  • Neo
  • Cloud Foundry
Redesigned Entitlements Page

Managing entitlements and quotas in the cockpit just got a lot easier!

You now have a completely redesigned Entitlements page that is simpler and more intuitive to use, as well as a brand new Subaccount Entitlements page accessible directly from your subaccount.

See Configure Entitlements and Quotas for Subaccounts.

New 2019-06-06
Cloud Foundry Environment DevOps Cloud Foundry Version 8.1.0

Cloud Foundry has been updated from version 7.9.0 to 8.1.0

v8.1.0Information published on non-SAP site

v8.0.0Information published on non-SAP site

v7.11.0Information published on non-SAP site

v7.10.0Information published on non-SAP site

New 2019-05-23
TLS Security Neo TLS protocol ciphers

The following protocol ciphers are weak. Avoid using them for your applications. Instead, use the strong TLS protocol ciphers that SAP Cloud Platform supports. They are set to be used by default.

Weak protocol ciphers for TLS 1.2:

  • TLS_RSA_WITH_AES_128_CBC_SHA256 (0x3c), 128 bit

  • TLS_RSA_WITH_AES_256_CBC_SHA256 (0x3d), 256 bit

  • TLS_RSA_WITH_AES_128_CBC_SHA (0x2f), 128 bit

  • TLS_RSA_WITH_AES_256_CBC_SHA (0x35), 256 bit

Weak protocol ciphers for TLS 1.0/1.1:

  • TLS_RSA_WITH_AES_128_CBC_SHA (0x2f), 128 bit
  • TLS_RSA_WITH_AES_256_CBC_SHA (0x35), 256 bit

Your application may communicate via a weak cipher in one of the following cases:

  • The application process is pinned to a weak cipher using the -Dhttps.cipherSuites JVM parameter. To switch to a strong cipher, unpin the process from the weak cipher.
  • The application communicates with an ABAP system that was not updated with SAP Note 2450794Information published on non-SAP site. To switch to a strong cipher, update the ABAP system with the latter note.

    There is a security patch available allowing SAP NetWeaver systems to communicate via the strong TLS 1.2 ciphers. See SAP Note 2708581Information published on SAP site.

Announcement 2019-05-23
Documentation DevOps
  • Neo
  • Cloud Foundry
  • ABAP
Simplification

We have restructured and simplified the following sections in the SAP Cloud Platform documentation:

[Customer feedback]

Announcement 2019-05-23
SAP Java Buildpack Application Runtime Cloud Foundry Version Update Apache Tomcat has been updated from version 8.5.38 to version 8.5.40. Announcement 2019-05-23
Nginx Buildpack Application Runtime Cloud Foundry Deprecating Nginx v1.14.x

The Cloud Foundry Nginx buildpack is planning to remove support for Nginx version 1.14.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8596Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of June 2019. Please make any necessary changes to your applications before that, if you are manually specifying a version of Nginx for the buildpack to use, or you have customized your Nginx buildpack.

Announcement 2019-05-23
PHP Buildpack Application Runtime Cloud Foundry Deprecating PHP v1.10.x

The Cloud Foundry PHP buildpack is planning to remove support for Nginx version 1.14.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8597Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of May or June 2019. Please make any necessary changes to your applications before that, if you are manually specifying a version of PHP for the buildpack to use, or you have customized your PHP buildpack.

Announcement 2019-05-23
Node.js System Buildpack Application Runtime Cloud Foundry Deprecating Node.js v6.x

The Cloud Foundry Node.js system buildpack is planning to change the default Node.js version from 6.x to 10.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8530?p=,,,20,0,0,0::relevance,,node.js,20,2,0,30403008Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of May or June 2019. Please make any necessary changes to your applications before that, if you are manually specifying a version of Node.js for the buildpack to use, or you have customized your Node.js buildpack.

Announcement 2019-05-23
Cloud Foundry Environment DevOps Cloud Foundry Version 7.7.0

Cloud Foundry has been updated from version 7.7.0 to 7.9.0

v7.9.0Information published on non-SAP site

v7.8.0Information published on non-SAP site

New 2019-04-25
Cloud Foundry Environment DevOps Cloud Foundry Stack Removed The cflinuxfs2 stack, based on Ubuntu Trusty 14.04, has been removed. All applications that were still running on cflinuxfs2 have been centrally switched to cflinuxfs3. New 2019-04-25
Ruby Buildpack Application Runtime Cloud Foundry Deprecating Ruby 2.2.x and 2.3.x

The Cloud Foundry Ruby buildpack is planning to remove support for Ruby versions 2.2.x and 2.3.x. See https://lists.cloudfoundry.org/g/cf-dev/topic/notice_end_of_support_for/31034989?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,31034989Information published on non-SAP site.

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of May or June 2019. Please make any necessary changes to your applications before that, if you are manually specifying a version of Ruby for the buildpack to use, or you have customized your Ruby buildpack.

Announcement 2019-04-25
Go Buildpack Application Runtime Cloud Foundry Deprecating Go v1.10.x

The Cloud Foundry Go buildpack is planning to remove support for Go version 1.10.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8588Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of May or June 2019. Please make any necessary changes to your applications before that, if you are manually specifying a version of Go for the buildpack to use, or you have customized your Go buildpack.

Announcement 2019-04-25
Cloud Foundry Environment DevOps Cloud Foundry Version 7.7.0

Cloud Foundry has been updated from version 7.5.0 to 7.7.0

v7.7.0Information published on non-SAP site

v7.6.0Information published on non-SAP site

New 2019-04-11
Cloud Foundry Environment DevOps Cloud Foundry Stack Switch

All applications have been switched from cflinuxfs2 to cflinuxfs3. The old stack, cflinuxfs2 based on Ubuntu Trusty 14.04, is still available. Applications that specify cflinuxfs2 explicitly in the application manifest or use the -s option on the CF CLI, use the cflinuxfs2 stack again after the next deployment. See Changing StacksInformation published on non-SAP site.

On 25 April 2019 support for cflinuxfs2 ends and the stack is removed.

Announcement 2019-04-11
Java Runtime Application Runtime Neo Deprecating Java EE 6 Web Profile

The Java EE 6 Web Profile runtime is deprecated. Support will be discontinued on 1 November 2019. See Java EE 6 Web Profile.

We recommend that you migrate your Java applications in the Neo environment to:

Announcement 2019-04-11
Cloud Cockpit User Experience Cloud Foundry New Registration Process for Cloud Foundry Trial

As part of the registration for a new trial account in the Cloud Foundry environment, you must now verify your phone number by using a one-time SMS verification.

When you choose the Cloud Foundry Trial tile in the cockpit for the first time, you will be prompted to verify your phone number and log in again to finalize the trial account creation process.

New 2019-03-28
SAP Java Buildpack Application Runtime Cloud Foundry Version Updates

SAPJVM has been updated to version 81.52.52.

JCo has been updated to version 3.0.3.

The SAP HANA drivers have been updated to version 2.4.52.

The application name is set on CONNECT for the SAP HANA DataSource, this is required by the SAP HANA Trust Initiative.

Announcement 2019-03-28
Cloud Cockpit User Experience
  • Neo
  • Cloud Foundry
Web Assistant: Your New In-App Help for the Cockpit

Your cockpit in-app help is now much easier and faster to use, giving you support exactly where you need it.

Simply enable the Web Assistant from the help icon in the header () and choose a hotspot or a tile from the carousel on the right side to get information about a specific element.

New 2019-03-28
Cloud Foundry Environment DevOps Cloud Foundry Stack Switch

Support for cflinuxfs2 ends on April 25, 2019.

To guarantee a smooth transition, please upgrade the stack to cflinuxfs3 before April 11, 2019. If the stack isn’t updated, your Cloud Foundry application might stop working during the planned automated switch from cflinuxfs2 to cflinuxfs3.

For more information about how to change the stack of your application , see Changing StacksInformation published on non-SAP site.

Announcement 2019-03-14
Cloud Foundry Environment DevOps Cloud Foundry Version 7.5.0

Cloud Foundry has been updated from version 7.2.0 to 7.5.0

v7.5.0Information published on non-SAP site

v7.4.0Information published on non-SAP site

v7.3.0Information published on non-SAP site

New 2019-03-14
SAP Java Buildpack Application Runtime Cloud Foundry Version Updates

SAPJVM has been updated to version 81.50.50.

XS Tomcat version 1.2.0 has been adopted with Apache Tomcat version 8.5.38.

Announcement 2019-03-14
Node.js System Buildpack Application Runtime Cloud Foundry Deprecating Node.js v6.x

The Cloud Foundry Node.js system buildpack is planning to remove support for Node.js versions 6.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8530Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of May or June 2019. Please make any necessary changes to your applications before that, if you are manually specifying a version of Node.js for the buildpack to use, or you have customized your Node.js buildpack.

Announcement 2019-03-14
Node.js System Buildpack Application Runtime Cloud Foundry Deprecating Node.js v6.x

The Cloud Foundry Node.js system buildpack is planning to change the default Node.js version from 6.x to 10.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8531Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of May or June 2019. Please make any necessary changes to your applications before that, if you are manually specifying a version of Node.js for the buildpack to use, or you have customized your Node.js buildpack.

Announcement 2019-03-14
Cloud Cockpit Developer Experience Cloud Foundry Introducing Recipes: Guided Interactive Steps to Start Using Platform Services

With enterprise accounts you can now select, configure and consume services more easily through recipes - sets of guided interactive steps that help you achieve specific technical goals.

See Recipes.

New 2019-02-28
Cloud Foundry Environment DevOps Cloud Foundry Version 7.2.0

Cloud Foundry has been updated from version 6.10.0 to 7.2.0

v7.2.0Information published on non-SAP site

v7.1.0Information published on non-SAP site

v7.0.0Information published on non-SAP site

With this update SAP Cloud Platform, Cloud Foundry environment adds the NGINX and R community buildpacks.

New 2019-02-28
Multitenancy Developer Experience Cloud Foundry Registering Multitenant Business Applications in the Cloud Foundry Environment

You can now register multitenant business applications and services to the SaaS Provisioning service with their XSAppName instead of the AppID.

See Register the Multitenant Business Application to the SaaS Provisioning Service.

Changed 2019-02-14
Node.js System Buildpack Application Runtime Cloud Foundry Deprecating Node.js v9.11.x

The Cloud Foundry Node.js system buildpack is planning to remove support for Node.js versions 9.11.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8469Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of April or May 2019. Please make any necessary changes to your applications before that, if you are manually specifying a version of Node.js for the buildpack to use, or you have customized your Node.js buildpack.

Announcement 2019-02-01
Go Buildpack Application Runtime Cloud Foundry Deprecating Go v1.8.x and v1.9.x

The Cloud Foundry Go buildpack is planning to remove support for Go versions 1.8.x and 1.9.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8467Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of April or May 2019. Please make any necessary changes to your applications before that.

Announcement 2019-02-01
Console Client Developer Experience Neo Support for Java 9 and Above When working with the console client, you can now also use JRE 9 and above. See Console Client for the Neo Environment. Changed 2019-01-31
Node.js System Buildpack Application Runtime Cloud Foundry Version 1.6.38 The Node.js system buildpack has been updated from v1.6.34 to v1.6.38. See v1.6.38Information published on non-SAP site. New 2019-01-31
Node.js System Buildpack Application Runtime Cloud Foundry Reduced Application Maximum Header Size The Node.js system buildpack reduces the maximum supported header size for applications to 8kB, see https://github.com/cloudfoundry/nodejs-buildpack/issues/176Information published on non-SAP site. Please plan accordingly to adopt it in your applications. Announcement 2019-01-31
Cloud Foundry Environment DevOps Cloud Foundry New Stack Available as Default

The stack cflinuxfs3 based on Ubuntu Bionic 18.04 is configured as the default stack. Support for cflinuxfs2 ends in April 2019. Applications that are still running on cflinuxfs2 at this time will be centrally switched to cflinuxfs3.

Newly pushed applications will run on cflinuxfs3 unless they explicitly specify cflinuxfs2. See Changing StacksInformation published on non-SAP site.

New 2019-01-31
Cloud Foundry Environment DevOps Cloud Foundry Version 6.10.0

Cloud Foundry has been updated from version 6.5.0 to 6.10.0

v6.10.0Information published on non-SAP site

v6.9.0Information published on non-SAP site

v6.8.0Information published on non-SAP site

v6.7.0Information published on non-SAP site

v6.6.0Information published on non-SAP site

New 2019-01-31
Planning and Lifecycle Management DevOps
  • Neo
  • Cloud Foundry
  • ABAP
Best Practices We've updated the set of best practices and recommendations to help you plan and set up your cloud landscape and manage applications. See SAP Cloud Platform Planning and Lifecycle-Management Guide. Announcement 2019-01-31
SAPUI5 User Experience Neo SAPUI5 Distribution 1.69.0

Release of SAPUI5 distribution 1.69.0 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-08-29
SAPUI5 User Experience Neo SAPUI5 Distribution 1.68.1

Release of SAPUI5 distribution 1.68.1 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-08-01
SAPUI5 User Experience Neo SAPUI5 Distribution 1.67.0

Release of SAPUI5 distribution 1.67.0 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-07-04
SAPUI5 User Experience Neo SAPUI5 Distribution 1.66.0

Release of SAPUI5 distribution 1.66.0 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-06-06
SAPUI5 User Experience Neo SAPUI5 Distribution 1.65.0

Release of SAPUI5 distribution 1.65.0 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-05-23
SAPUI5 User Experience Neo SAPUI5 Distribution 1.64.0

Release of SAPUI5 distribution 1.64.0 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-04-11
SAPUI5 User Experience Neo SAPUI5 Distribution 1.63.0

Release of SAPUI5 distribution 1.63.0 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-03-14
SAPUI5 User Experience Neo SAPUI5 Distribution 1.62.0

Release of SAPUI5 distribution 1.62.0 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-02-14
SAPUI5 User Experience Neo SAPUI5 Distribution 1.61.2

Release of SAPUI5 distribution 1.61.2 for Java and HTML5 applications.

See What's New in SAPUI5 and Change Log.

New 2019-01-17
Cloud Foundry Environment DevOps Cloud Foundry Version 6.5.0

Cloud Foundry has been updated from version 5.5.0 to 6.5.0

v6.5.0Information published on non-SAP site

v6.4.0Information published on non-SAP site

v6.3.0Information published on non-SAP site

v6.2.0Information published on non-SAP site

v6.1.0Information published on non-SAP site

v6.0.0Information published on non-SAP site

New 2019-01-17
SAP Java Buildpack Application Runtime Cloud Foundry SAP Java Connector Usage The SAP Java buildpack has an option to activate SAP Java Connector, which will provide all relevant libraries in the application container, so the application can use the Java Connector API. See SAP Java Connector. New 2019-01-17
SAP Java Buildpack Application Runtime Cloud Foundry Buildpack Versions

The SAP Cloud Foundry environment provides three versions of the SAP Java Buildpack as part of its system buildpacks, see the Versioning section in Developing Java in the Cloud Foundry Environment.

The output of the cf buildpacks command with the current update would be:

Getting buildpacks...

buildpack position enabled locked filename

sap_java_buildpack_1_7_11 13 true false sap_java_buildpack-v1.7.11.zip

sap_java_buildpack_1_8_0 14 true false sap_java_buildpack-v1.8.0.zip

sap_java_buildpack 15 true false sap_java_buildpack-v1.8.0.zip

New 2019-01-17
PHP Buildpack Application Runtime Cloud Foundry Deprecating PHP 5.x and 7.0.x

The Cloud Foundry PHP buildpack is planning to remove support for PHP versions 5.x and 7.0.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8440Information published on non-SAP site .

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of March or April 2019. Please make any necessary changes to your applications before that.

Announcement 2019-01-17
.NET Buildpack Application Runtime Cloud Foundry Deprecating .NET 2.0.x

The Cloud Foundry .NET Core buildpack is planning to remove support for .NET Core versions 2.0.x. See https://lists.cloudfoundry.org/g/cf-dev/message/8439Information published on non-SAP site.

The new buildpack release containing this change is expected to become available on the Cloud Foundry environment as of March or April 2019. Please make any necessary changes to your applications before that.

Announcement 2019-01-17