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Business Function Item Hierarchies 

PS_GOVPROC_ITEMTYPES: Item Hierarchies 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the business function Item Hierarchies is available. With this 
business function, you can produce complex contractual arrangements with a flexible 
grouping of line items. This business function also supports configurable line item numbering 
(CLIN). Capabilities such as grouping like items, splitting the procurement process into 
phases, and representing task structures are enabled through item hierarchies. This feature is 
available for the following SAP Supplier Relationship Management (SAP SRM) procurement 
documents: 

o Shopping cart 

o RFx 

o Purchase order 

o Contract 
 
For more information, see the release note Replication of Hierarchies from SAP SRM (New).  

Effects on Existing Data 

You have SAP Supplier Relationship Management 2006 (SAP SRM 2006) and SAP 
Procurement for Public Sector 2007 (SAP PPS 2007) installed on your system. 



PS_GOVPROC_ITEMTYPES: Replication of Hierarchies from SAP SRM 
(New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, Business Function Item Hierarchies 
(PS_GOVPROC_ITEMTYPES), hierarchical line item structures are replicated from SAP 
Supplier Relationship Management (SAP SRM) procurement documents to their counterparts 
in the ERP system. This includes the replication of both statistical and functional line items, 
including material and service line items. The hierarchical line item number is also transferred 
to the backend system, as well as the position of the line item in the hierarchy. For each line 
or subline item in the SAP SRM document, a corresponding line item is created in the SAP 
ERP document. This feature also supports configurable line item numbering (CLIN). 

This feature is available for the following procurement documents: 

o Purchase order 

o RFx 

o Contract 

o Shopping cart 
 

Effects on Existing Data 

To use this feature, you must have SAP Supplier Relationship Management 6.0 (SAP SRM 
6.0) and SAP Procurement for Public Sector 2007 (PPS 2007) installed on your system. 

The following transactions are affected by the replication of line item hierarchies from SAP 
SRM to the SAP ERP system: 

o You can now display a replicated purchase order created in the SAP SRM 
Extended Classic Scenario in the Create Purchase Order transaction (ME21N). 
The hierarchical line item numbers in the purchase order are visible, and the line 
items are displayed in the correct hierarchical sequence. You can also navigate 
using the hierarchical line item number. 

o You can use hierarchical line item numbers as reference when entering a goods 
receipt (GR) in the Goods Movement transaction (MIGO). 

o You can use hierarchical line item numbers as reference when entering a service 
entry sheet in the Service Entry Sheet transaction (ML81N). 

o You can use hierarchical line item numbers as reference when entering an 
invoice receipt (IR) in the Enter Incoming Invoice transaction (MIRO). 

 

Effects on Customizing 

You make the Customizing settings for this function in the Materials Management 
Implementation Guide (IMG) by choosing: 

o General Settings for Materials Management -> BAdI to Activate Configurable 
Line Item Numbering 

Use this Business Add-In (BAdI) to activate configurable line item numbering in goods 
receipts and invoice verifications. 

o Logistics Invoice Verification -> Incoming Invoice -> Aggregation -> Preset 
Aggregation Criteria for Hierarchies 

Use this IMG activity if you want to aggregate line items according to hierarchies in 
invoice receipts displayed in transaction MIRO. 



 

o External Services Management -> Activate Recalculation of Gross Price in 
Service Entry Sheet 

Use this IMG activity if you want to activate recalculation of the gross price at line item 
level in service entry sheets. The price is recalculated by determining the difference 
between the original gross price and the amount called off by other service entry sheets 
posted against the line item. 

See also 

For more information, see the main release note for business function Item Hierarchies. 

 



Business Function Shopping Cart Commitment 

PS_GOVPROC_SCCMT: Shopping Cart Commitment 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the business function Shopping Cart Commitment is available. With 
this business function, you can enable a financial commitment to be recorded in Funds 
Management (FM) upon approval of an SAP Supplier Relationship Management (SAP SRM) 
shopping cart. 

For more information, see release note Funds Commitment on Shopping Cart Approval 
(Enhanced).  

Effects on Existing Data 

You have SAP Supplier Relationship Management 2006 (SAP SRM 2006) and SAP 
Procurement for Public Sector 2007 (SAP PPS 2007) installed on your system. 



PS_GOVPROC_SCCMT: Funds Commitment on Shopping Cart Approval 
(Enhanced) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, Business Function Shopping Cart Commitment, you can record a 
funds commitment in Funds Management (FM) as soon as your SAP Supplier Relationship 
Management (SAP SRM) shopping cart is approved. Public sector organizations are required 
to commit funds at the time of their purchase request. By recording the funds commitment, 
this feature enables public sector organizations to have appropriate accounting controls 
throughout the SAP SRM requisitioning process. 

Effects on Existing Data 

To use this feature, you must have SAP Supplier Relationship Management 6.0 (SAP SRM 
6.0) and SAP Procurement for Public Sector 2007 (SAP PPS 2007) installed on your system. 

See also 

For more information, see the main release note for business function Shopping Cart 
Commitment. 

 

 



Business Function PSCD, Collections Management 

PSCD_COLLECTIONS_MANAGEMENT: PSCD, Collections Management 
(New) 

Use 

As of SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03, the 
Business Function PSCD, Collections Management is available. 

This Business Function provides you with comprehensive functions for processing 
customers and for collecting due receivables that are especially suited to the 
requirements of the tax authorities. You can use this Business Function to process 
large amounts of data in environments where manual processing is not suitable. You 
also have functions for processing open tax receivables and functions which you can 
use to ensure the submission of missing tax returns.  You can do the following with this 
Business Function: 

o dun receivables in Collections Management in accordance with flexible 
collection strategies and create, manage, and work through collection workitems 

o monitor dates by which the taxpayer must submit a tax return with the help of 
inbound correspondence requests in the system. 

o put together balance variants for the account balance display in Customizing 

o extract business partner items and dunning histories in SAP NetWeaver - 
Business Intelligence 

o connect external cash desks 

o send data to external systems using information containers 

o Update the creditworthiness of a business partner on creation of an installment 
plan 

o display information such as the last payment of a customer in SAP CRM  
Financial Customer Care Interaction Center 

o post back an incorrectly assigned on account payment to the clarification 
account with the clarification processing the payment lot 

o consider posting limit in payment run 

o create and evaluate promise to pay 

New Enterprise Services are also available as XI interfaces in Contract Accounts 
Receivable and Payable: 

o CashPointPaymentCreateNotification_In 

o CashPointPaymentReverseNotification_In 

o CashPointClosingDocumentNotification_In 

o CashPointOpenItemSummaryNotification_In 

o CashPointOpenItemSummaryByElementsQueryResponse_In 

o CollectionsWorkListNotification_Out 

o CollectionsWorkListItemCancellationNotification_Out 

o CollectionsWorkListItemStatusByCollectionsWorkListItemIDQueryResponse_Out 

See the following release information for more information: 

o HyperLink: RELN.FICAX_602_CM Collections Management 



o PSCD_COLLECTIONS_MANAGEMENT: Enhanced Inbound 
Correspondence 

o HyperLink: RELN.FICAX_602_PROM2PAY Promise to Pay 

o HyperLink: RELN.FICAX_602_PAYTRNS Payment Transactions 

o Processing Incoming and Outgoing Payments 

o Invoicing in Contract Accounts Receivable and Payable 

o Integration with Customer Relationship Management 
o HyperLink: RELN.FICAX_602_INSTPLN Installment Plan 

o HyperLink: RELN.FICAX_602_INFCON Information Container 

o HyperLink: RELN.FICAX_602_XI Enterprise Services 

o HyperLink: RELN.FICAX_602_EXTCASHD External Cash Desk 
Services 

o HyperLink: RELN.FICAX_602_CLOSOP Closing Operations 

o Billing in Contract Accounts Receivable and Payable 

o Integration with Business Intelligence 

o HyperLink: RELN.FICAX_602_ARCH Archiving 

o HyperLink: RELN.FICAX_602_ACCBALA Account Balance Display 

o  Business Partner Items in SAP Contract Accounts Receivable and Payable 
in the BI system 

o Dunning in SAP Contract Accounts Receivable and Payable in the BI system 

Effects on Existing Data 

With this Business Function there are changes to the following automatic roles (PFCG-
Rollen): 

o SAP_EP_ISPSCA_FICA_COLL 

For more information on the use of automatic roles, see the SAP Library under Roles -> 
Automatic Roles. 

See also 

For more information, see the SAP Library under SAP ERP Central Component -> 
Business Function Sets and Business Functions -> Industry Business Function Sets -> 
Public Services -> PSCD, Collections Management 



PSCD_COLLECTIONS_MANAGEMENT: Collections Management 
Use 

Dunning by Collection Strategy 

If collection grouping is active for a company code, dunning is by collection strategy 
instead of by dunning procedure. To dun by collection strategy, you have to make the 
following new Customizing settings: 

o Define Collection Step 
Configure the derivation of the collection step (event 0315 and event of 
Business Rules Framework (BRF)) 

o Define Collection Strategy and Assign BRF Event 

o Maintain Collection Grouping 

Collection Grouping 

Collection grouping can be at contract account or contract level. In Customizing, you 
define the master data object type that a collection unit can be used for. You can also 
restrict individual collection units to specific contract account categorires. 

The properties of a collection unit always refer to a business partner. In a new 
maintenance transaction in the SAP menu under Master Data -> Business Partners -
> Data for Collections Management -> Maintain Master Data Groups, you can 
maintain the collection unit, collection strategy, and contact person of the business 
partner. This information is saved in the master data objects. 

To get an overview of the master data of a business partner that is processed by 
Collections Management, call the display transaction in the SAP menu under Master 
Data -> Business Partner -> Data for Collections Management -> Display Master 
Data Groups. 

You can use posting area 0040 to enter the initial values for the collection unit and 
collection strategy. As standard, this is processed in the new event 1044 and creates a 
proposal value. For the migration you can use report  
RFKK_UPDATE_MASTERDATA. In addition to event 1044, it also processes 
event 1045 to determine a contact person of the business partner. 

When you are processing collection workitems, in Contract Accounts Receivable and 
Payable you may have to enter new contact persons for specific business partners. 
You enter the contact person in the Interaction Center WebClient - this then updates 
a trigger in Contract Accounts Receivable and Payable. You process this trigger 
regularly with the transaction Update Contact Persons in the SAP menu under Master 
Data -> Business Partners -> Data for Collections Management. 

Collection Workitem: 

Collection workitems are created when processing by a clerk is required. Using the 
dunning activity FKK_0350_WLI_CREATE_AND_DELETE, you can create collection 
workitems for a collection unit. Collection workitems are created for collection units and 
can be differentiated by their categories. You can use these categories to map different 
processing options for the clerk. 

The workitem category Customizing defines whether a workitem is assigned to a 
worklist automatically when it is created in the dunning activity or whether the manager 
does this later in the corresponding transaction in the SAP Menu under Periodic 
Processing -> For Contract Accounts -> Dunning -> By Collection Strategy -> 
Manage Worklists. 

In the dunning activity, at least one collections department is assigned to each 
collection workitem. You can also assign a work group and a clerk to the collection 



workitem in the dunning activity. If only a collections department or a collections 
department and a work group are assigned to the collection workitem, either the 
manager makes the assignment in the Manage Worklists transaction or during 
processing of the worklists. 

The workitem category Enforcement Work Item defines that an item list is defined to 
the work item when it is created. In Interaction Center WebClient, the clerk can 
manually add to the item list of a work item or deactivate items in the item list. 

Work items with no item list are closed if they do not have a final status at the time of 
the next dunning activity run and a new work item is created for the same master data 
group. The next dunning run does not automatically close work items with a fixed item 
list; you can only close them manually. 

API function modules process workitems and worklists further in the Interaction 
Center WebClient. Further processing of the workitems and worklists in Contract 
Accounts Receivable and Payable is not supported. 

Worklist Management: 

The worklists are managed in the transaction Manage Worklists. In this transaction, a 
manager (person responsible for collections department) or a group leader (person 
responsible for work group) can perform the following tasks: 

o Creation of new worklists by grouping of workitems 

o Assignment of workitems to work groups and/or clerks 

o Maintenance of attributes of a worklist 

o Reversal of workitems 

o Reopening of workitems 

 

Collection History 

The collection history (see SAP menu: Account -> Further Information) is an analysis 
tool that that collects specific business transactions in a total view with reference to the 
business partner(s) concerned. Business transactions are considered as events in the 
collection history. In Customizing you can place events (business transactions) in 
context and assign specific transactions to one another. 

Example 

o The system assigns a correspondence to a specific installment plan if the 
correspondence is an installment plan notification for this installment plan. 

o The system assigns a work item to a specific dunning notice if the work item has 
arisen from a dunning activity for this dunning notice. 

o The system assigns a payment to a specific promise to pay if the promise to pay 
was closed by this payment. 

 

SAP delivers events of the following category: 

o Dunning 

o Correspondence 

o Work item 

o Payment 

o Promise to Pay 

o Installment Plan 



 

In addition, you can integrate further events using a customer enhancement. 

To display the collection history, you can choose between a tabular and a hierarchical 
view of the events. 

 

New Events 

In event 1040, the system determines all contracts of a business partner that 
participate in Collections Management. For each contract, the system determines the 
collection unit, collection strategy, and the contact person. 

In event 1041, you can define, for Collections Management, which contract is 
responsible for an open item if the item was posted with no contract reference (on 
account). The contract determined then determines the collection unit, collection 
strategy, and the contact person. 

In event 1042, the system saves the data of the contracts of a business partner that 
were determined in event 1040. 

In event 1043 you can define how the contract account name is to be displayed in the 
new transactions FPCG and FPCGA. (See SAP menu Master Data -> Business 
Partners -> Data for Collections Management -> Maintain/Display Master Data 
Groups). 

In event 1044 you can define the initial values of the collection unit and the collection 
strategy for Collections Management. In the standard, the new posting area 0400 and, 
if necessary, an industry-specific posting area are processed here. 

In event 1045 you can define the initial values of the contact person for Collections 
Management. 

In event 1046 the system determines all contracts of a business partner that were 
summarized to a specific master data group for Collections Management. 

In event 1047 the system checks whether the master data group is permitted for a 
contract. 

You can use event 2844 to search for workitems using customer-specific fields. The 
event can be used for the workitem search from the Interaction Center WebClient. 

Event 2845 determines the last collection contact of the master data group. 

Event 2846 enables you to fill customer-specific fields of a work item when you create it 
in the dunning activity FKK_0350_WLI_CREATE_AND_DELETE. 

Event 2847 enables customer-specific checks when a workitem is changed in the 
Interaction Center WebClient. 

Event 2848 enables you to fill customer-specific fields of a workitem when a 
subsequent workitem is created from the Interaction Center WebClient. 

Event 2849 prepares the data for displaying the progress of a worklist in the 
Interaction Center WebClient. 

Effects on Customizing 

You activate the collection grouping in the Implementation Guide for Contract Accounts 
Receivable and Payable under Organizational Units -> Configure Company Codes 
for Contract Accounts Receivable and Payable in the Master Data Grouping Level 
column. 

You make the settings for Collections Management in the Implementation Guide for 



Contract Accounts Receivable and Payable under Business Transactions -> 
Dunning -> Dunning by Collection Strategy. 

You make the settings for the collection history in the Implementation Guide for 
Contract Accounts Receivable and Payable under Business Transactions -> 
Dunning. 

You define installation-specific function modules in the Implementation Guide for 
Contract Accounts Receivable and Payable under Program Enhancements -> Define 
Customer-Specific Function Modules. 



PSCD_COLLECTIONS_MANAGEMENT: Enhanced Inbound 
Correspondence (New) 

Use 

As of SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03, 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can use the functions for enhanced inbound correspondence. In order to use the 
enhanced functions, you must activate the enhanced inbound correspondence in 
Customizing. 

You can continue to display and process the inbound correspondence requests created 
in the system before this change, but you cannot recreate them. You can also still 
display the specifications defined for the contract object for inbound correspondence. 

Several inbound correspondence categories for each contract object 

Until now there was only one inbound correspondence per contract object. As of this 
release you can generate different inbound correspondence for a contract object. 
These are then mapped in the system with inbound correspondence categories. You 
can use inbound correspondence categories to define that you expect a different 
inbound correspondence for trade tax than for income tax for example. You can also 
request different inbound correspondence for a revenue type. For example, it is 
possible to request two different pieces of information from taxpayers for the tax return: 
one concerning the submission of the tax return (inbound correspondence category 
"income tax return") and to request that missing information also be submitted (inbound 
correspondence category "income tax return: additional data"). Inbound 
correspondence requests can also be mapped using different time periods (for 
example, quarterly or annually). 

Each inbound correspondence category is assigned to a revenue type in the 
Customizing of Contract Accounts Receivable and Payable. When processing the 
contract object you activate certain inbound correspondence categories for a contract 
object and thereby define for which revenue types you expect a tax return for this 
contract object. The example above assumes that an income tax return is expected 
from each taxpayer, and as such generates an inbound correspondence request 
automatically, whereas missing data is only relevant for some taxpayers. Therefore the 
inbound correspondence request is created manually in this case. 

The inbound correspondence categories are time-dependent and are created or 
processed in the Customizing of Contract Accounts Receivable and Payable. 
Furthermore, inbound correspondence refers directly to periods. This enables time limit 
changes to be mapped easily for example. You can overwrite the Customizing setting 
when processing the contract object. You can define the following when doing this: 

o Which inbound correspondence category is active, in other words, is created 
automatically. 

o Exception periods for which you do not expect any inbound correspondence. 
Exception periods apply to all inbound correspondence categories 
simultaneously and for each year. 

o Alternative periods that subdivide the standard periods. 

Process 

1. The system generates inbound correspondence requests based on the entries in 
Customizing or in the contract object. They can either be generated individually 
when processing the contract object or during a mass activity. Inbound 
correspondence requests are created for periods. When an inbound 
correspondence request is generated, the system posts a sample document at 
the same time. 



2. If the inbound correspondence is not submitted by the time limit, you start 
dunning for it. Dunning is based on the posted sample documents if the dunning 
by collection strategy is active for this company code, otherwise normal inbound 
correspondence dunning takes place. 

3. The system automatically assigns received inbound correspondence when 
running program  Validation and Billing of Tax Returns and Requests  to the 
open inbound correspondence requests thereby flagging the request as 
completed. The sample document is thereby cleared automatically. Alternatively 
you can perform this manually in the inbound correspondence history. 

 

Effects on Customizing 

You define the Customizing settings for this function in the Customizing of Contract 
Accounts Receivable and Payable in section  Business Transactions -> Inbound 
Correspondence -> Inbound Correspondence (enhanced): 

To use the enhanced inbound correspondence functions, activate them in IMG activity  
Activate Enhanced Inbound Correspondence. 

See also 

For more information, see the SAP Library under SAP ERP Central Component -> SAP 
Public Sector Tax and Revenue Management -> Collection and Disbursement (PSCD) 
-> Enhanced Inbound Correspondence. 



PSCD_COLLECTIONS_MANAGEMENT: Promise to Pay 
Use 

Promise to Pay: Overview 

A promise to pay is an agreement from a business partner to pay receivables that are 
in his account. The promise to pay defines which amounts are to be paid by which 
dates. 

Promises to pay can involve payments by the business partner or in the form of debit 
memos or direct debits. 

Since the payment dates defined in the promise to pay are generally after the due 
dates of the items covered by the promise to pay, charges and interest on late 
payments can be added. 

Promise to Pay: Processing Functions 

You can create, approve, withdraw, change, and valuate promises to pay. With the 
exception of the valuation, these all take place in dialog. The valuation is realized as a 
mass activity that you use to determine the extent to which promises to pay made have 
been fulfilled. If a promise to pay is not fulfilled, the creditworthiness of the business 
partner concerned can be updated. 

For dialog processing, you can use a user interface in the Interaction Center Web 
Client. A classic ERP user interface is also available. 

Promise to Pay: Create 

A promise to pay is always created with reference to open items of the business 
partner. Creating a new promise to pay involves the following steps: 

o Selection of currency, responsible company code, reason for the creation, 
and a category 
You define the reasons and categories in Customizing. Reasons could be Call 
by customer, Call by us, Letter from customer, for example. 
The categories indicate proposal values for the number and the interval of the 
payment dates of the individual partial payments, specifications for the 
determination and posting of interest and charges, and specifications for the 
effect on the creditworthiness, interest, and charges where a promise is not 
fulfilled. 

o Selection of the open items to be included in the promise to pay. 
An open item can be included in a promise to pay completely or only a partial 
amount can be included. The selection options generally correspond to the 
options given for clearing processing in dialog. 
Open items that are already assigned to another promise to pay, a collective bill, 
or an installment plan cannot be included in a new promise to pay. 
The selected open items can be posted to different contract accounts of the 
business partner and can have different currencies. You define the payment 
currency in the promise to pay itself. 

o Determination of the total amount, including interest and charges 
The system does this automatically once the selection of open items is 
completed. 

o Selection of the due dates and the amounts to be paid 
The system uses the category you have previously selected to propose dates 
and amounts. You can change this proposal in the dialog processing. The 
starting date (first due date), the interval between the due dates, and either the 
number of installments required or the maximum amount of an installment can 
be defined. 



Using these details, the new total amount is determined (for example, the 
interest might change) and corresponding partial amounts are created. 

o Specifications for direct debit or debit memo 
These specifications are only required if the amounts are to be automatically 
debited when they are due. You have to specify a contract account of the 
business partner that is to be used for payment processing. 
In no payment method is defined for incoming payments in the contract account 
specified, you have to specify a payment method in the promise to pay itself. 
Further optional specifications are credit card data (if collection is to be made 
using a credit card not defined in the contract account) and, if necessary: 

- Alternative payer 

- Alternative bank details 

- Alternative card ID 
For each due date, you can define different details for the direct debit or debit 
memo. 
In event 0121, when you collect an installment of a promise to pay you can 
distribute the payment amount to the related open items (as for an installment 
plan). 

o Save 
When you save, the system automatically assigns a number for the promise to 
pay. The data of the promise to pay is saved, and a link to the promise to pay is 
saved in the previously selected open items. 

 

You can use events to trigger individual checks on the creation of a promise to pay. At 
event 0183, you can restrict the categories permitted dependent on the business 
partner. If no category is permitted, then no new promise to pay can be created for this 
business partner. At event 0187, you can check the promise to pay with all detail 
data. For example, here you could prevent promises to pay being created with a long 
life. 

Promise to Pay: Approve 

You can trigger an approval workflow when a promise to pay is created. The decision is 
taken automatically. To enable this, you must provide a function module for event 
5516 in your installation that decides whether the promise to pay is to be approved by 
another person. 

If a workflow is started, you can enter a comment for the promise to pay in dialog. The 
clerk determined in the workflow can then accept or reject the promise to pay. 

Promise to Pay: Withdraw 

A promise to pay can be withdrawn by the business partner or by you. You have to 
specify where triggered the withdrawal and select a reason. You define the possible 
withdrawal reasons in Customizing. 

The withdrawal reason defines whether interest and changes are to be retained, 
reversed, or – for interest only – adjusted to the payments already made. You also 
define whether the creditworthiness is to be updated for a withdrawal. If you require an 
update, the level of fulfillment of the promise is determined up to the date of the 
withdrawal. If the level of fulfillment would lead to the status Promise Broken, the 
creditworthiness is updated with the value defined for the category of the Customzing 
for broken promises. 

The withdrawal makes the promise to pay inactive; the relevant items can then be 
included in another promise to pay, for example. 



You can still display the data of the withdrawn promise to pay. 

Promise to Pay: Change 

If only the data required for the direct debit or debit memo is changed in a promise to 
pay, the promise is retained. The status before the change is documented in a history 
management. 

If the installments or the items involved in a promise to pay are changed, a new 
promise is created and the old promise receives a link to the new promise. Since the 
changes can be complicated (include new items or remove items, change due amounts 
and dates), no change documents are created or displayed that show the old and new 
data. Instead, the data of the old promise to pay is stored historically so that you can 
display the old status at any time. 

To make it clear that a new promise is created when data changes, the dialog function 
is called Replace Promise and not Change Promise. 

The replacement of a promise can be seen as a combination of Withdraw Promise to 
Pay and Create Promise to Pay. However, when a promise is replaced, the 
creditworthiness is not updated, even if the withdrawal reason would normally require 
an update. 

Promise to Pay: Valuate 

The valuation determines a level of fulfillment for the promise to pay (as percentage 
rate between 0.00% and 100.00%), and, using the level of fulfillment, a status. The 
valuation takes place once the promise to pay is closed, normally a few days after the 
last partial payment is due. 

The valuation can lead to one of the following statuses: 

o Promise fulfilled 

o Promise fulfilled with accepted variances 

o Promise not fulfilled 

 

In Customizing, you define the level of fulfillment from which a promise is deemed to be 
fulfilled or fulfilled with accepted variances. 

You can use a mass activity to valuate and close promises to pay. You must assign a 
check date in this mass activity. Promises to pay whose next check date is before or on 
this check date are valuated. Using the valuation data determined, you can decided 
whether the valuation is saved and the promise to pay closed or whether there should 
be a further check at a later date. 

The first check date is automatically set when a promise to pay is created. The date is 
specified via event 0184. In the standard, a date is set that is 7 days after the due 
date of the middle installment. 

Example 

For five installments, a check is scheduled seven days after the due date of the third 
installment. If the number of installments is an equal number, the later of the two middle 
installments is used. 

During the check, the decision must be taken whether a further check is necessary at a 
later date, and the promise is open until then, or whether the promise is to be closed in 
its current status. This takes place via event 0189. In the standard version, a new 
check date is set if the old check date was not after the due date of the last installment; 
otherwise the promise is closed. In the standard version, the new check date is seven 
days after the due date of the last installment. If the date thus determined should not be 
in the future, the promise to pay is also closed. 



Promise to Pay: Valuation Logic 

In the valuation, the following is considered: How much of the promised amount has 
actually been paid, and how late the payments were. With regard to the delay in 
payment, in Customizing, you can define a number of tolerance days and what 
reduction in the valuation is made for each day in excess of these tolerance days. You 
define this per company code. 

Example 

In Customizing, you have agreed 2 tolerance days and 1.0% reduction for each further 
day late. The following promise to pay has been given: 

EUR 100.00 on 01.03.08 

EUR 100.00 on 01.04.08 

The following payments have been made: 

 EUR 80.00 on 08.03.08 

EUR 100.00 on 09.04.08 

 

The payments are always attribted to the oldest due dates. Therefore, after the 
deduction of 2 tolerance days, the following assignments arise: 

Amount Delay 

EUR 80.00 5 days Payment from 08.03.08 

EUR 20.00 37 days Payment from 04/09/2008 

EUR 80.00 6 days Payment from 04/09/2008 

 

Each of these assignments contributes to the level of fulfillment that is calculated from 
the percentage amount portion and the reduction due to the delay: 

Amount portion Reduction factor Contribution to level of fulfillment 

40,00% (80/200) 0.95 (5 days) 38,00% 

10,00% (20/200) 0.63 (37 days)  6,30% 

40,00% (80/200) 0.94 (6 days) 37,60% 

Overall  81,90% 

 

If items that were included in a promise to pay are cleared in another way (for example, 
due to a reversal, transfer, clearing of credit memos), the business partner only has to 
pay a reduced amount to fulfill the promise to pay. In the valuation these other 
clearings are used to reduce the oldest due dates of the promise to pay. A valuation is 
then made as described above using the reduced installments. 

Example 

The following promise to pay has been given: 

EUR 100.00 on 01.03.08 

EUR 100.00 on 01.04.08 

EUR 100.00 on 05/01/2008 

 



Of the receivables due, 120.00 is reversed. In the valuation, the promise to pay is 
treated as if the following installments had been agreed: 

EUR 80.00 on 01.04.08 

EUR 100.00 on 05/01/2008 

 

Write-offs are not other clearings, since they are not deemed to be a waiver of the 
receivable; instead, they reflect the opinion that the receivable will probably not be 
collected. 

Promise to Pay: Valuation and Creditworthiness 

For promises to pay that are not fulfilled, you can write an entry to the creditworthiness 
of the business partner. In the standard version, the system checks whether a 
creditworthiness weighting is specified in Customizing in case of non-fulfillment. You 
can define these for each promise to pay category. If a creditworthiness weighting is 
specified, a new creditworthiness record is created with this value and the total 
creditworthiness of the business partner is reduced. Using event 0188 you can 
change the creditworthiness weighting determined in the standard. 

Promise to Pay: Subsequently Change the Valuation 

As soon as a promise to pay is closed, all further payments, withdrawals, or other 
clearings no longer influence the valuation. Therefore, a promise to pay should not be 
closed too soon after the last due date; on the other hand, it must be possible to make 
an adjustment for promises to pay where the valuation is later determined to be 
incorrect. In particular, this should prevent a business partner receiving a bad 
creditworthiness where this is not justified. 

With a special authorization, you can subsequently change the level of fulfillment and 
the status of a promise to pay manually. You have to justify the change with a 
comment. All subsequent changes are recorded. The creditworthiness is adjusted 
automatically. 

Promise to Pay: Charges and Interest 

You can agree a charge for a promise to pay. The charged is determined, posted, and 
added to the total amount of the promise to pay automatically. You can define the 
amount of the charge in event 0186. In the standard system, no charge is calculated. 

You can calculate interest on the period between the due date of the receivables and 
the due dates of the promise to pay. For the interest calculation, you always assume 
that the installments of the promise to pay will be paid on time and the payments are 
assigned to the open items with the oldest due date. 

You define the interest key to be used in Customizing for each category. 

If a promise to pay is closed and not deemed to be broken at this time, there is no 
change to the interest and charges. 

If the promise to pay is deemed broken, dependent on the category you can 

o Retain, reverse, or adjust the interest 

o Retain or reverse the charges 

 

Adjusting the interest means that the original interest is reversed and instead, interest 
is calculated on all items involved again as follows: 

o Cleared items up to clearing date 

o Open items up to the day of the withdrawal of the promise 



 

If a promise to pay is withdrawn, the same decision options apply. However, in this 
case, the treatment of charges and interest is dependent on the withdrawal reason and 
not on the category of the promise. 

If a promise to pay is replaced, changes and interest for the old promise to pay are 
treated according to the withdrawal reason; the charges and interest of the new 
promise to pay are treated according to the category selected. 

If the same charges are to be levied for the new promise to pay as for the old one, 
there is no new posting. The charges receivable already posted is automatically added 
to the new promise. 

A similar rule applies if the interest amounts agree. Since a new interest calculation is 
only not necessary if the items subject to interest and the periods remain the same, the 
interest receivable can only be added to the new promise if both the items and the 
installments remain the same. However, this is an exception when replacing a promise 
to pay since then only payment data can have changed, which would also hav been 
possible without replacement. 

Promise to Pay: Correspondence 

You can send correspondence to the business partner when a promise to pay is 
created and in the case where a promise to pay is not fulfilled. 

The correspondence type for printing a promise to pay is 0045 (Promise to Pay). 

The correspondence request is created in event 0806. In this event, an entry is created 
in the correspondence container. This can be printed immediately or in mass printing. 
Event 0805 prints the correspondence type. In this event, the print parameters are 
adjusted specific to the correspondence and the Print Workbench is called. In the Print 
Workbench the correspondence-specific form class FI_CA_P2P_CORR is used. As 
example form, SAP delivers the application formFI_CA_P2P_CORR_SAMPLE, 
category SAPscript. 

The following details are used for printing: 

o Amounts with their due dates 

o Charges and interest on arrears 

o Receivables cleared by payments 

o Amounts collected using the debit memo procedure 

Effects on Customizing 

You make the system settings for promises to pay in the Implementation Guide for 
Contract Accounts Receivable and Payable under  Business Transactions -> 
Promises to Pay. 



PSCD_COLLECTIONS_MANAGEMENT: Payment Transactions 
Use 

Payment Run: Consideration of Direct Debit Limit 

For a contract account with an incoming payment method, you can define a direct debit 
limit for each period. This enables you to prevent that, in the specified period, a higher 
amount than desired is collected (even though there are due items, an incoming 
payment method, and bank details). 

You activate the direct debit limit per paying company code and you should define the 
direct debit limit in the currency of the paying company code since otherwise the 
system translates all payments into the currency of the direct debit limit). 

In the definition of the direct debit period, you can define that all payments of the last N 
months are to be considered or all payments since the first day of the current month or 
since the first day of a specific previous month. 

Each direct debit executed is recorded in a separate table  you can display a list of the 
direct debits from the master data transactions. Returns for recorded direct debits are 
indicated accordingly and no longer contribute to the degree of utilization. 

The payment run determines and adds together the direct debits in the period under 
consideration. The payment run checks whether the current amount to be collected can 
be collected in total or only in part, or not at all. If it cannot be collected at all, the items 
are displayed as an exception with the new indicator 80 (direct debit limit reached). If 
the amount can be partially collected, the new event 0613 is processed. Here, for 
example, the call of the clearing control (with clearing type 06D) can distribute the 
collectible amount to the items. The items that cannot be collected become payment 
exceptions with the indicator 80. 

Effects on Customizing 

You define the direct debit limit for a paying company code in the Implementation 
Guide for Contract Accounts Receivable and Payable under Business Transactions -
> Payments -> Creation of Incoming/Outgoing Payments -> Define Specifications 
for Paying Company Code. In the view Company Codes, set the new indicator 
Direct Debit Limit Active. 

In the master data maintenance, the fields for the direct debit limit are not visible until 
this indicator has been set in the paying company code. 

When you create a new contract account, because no paying company code is known 
yet, the fields are not visible until the indicator is set in at least one paying company 
code. 



PSCD_COLLECTIONS_MANAGEMENT: Processing of 
Incoming/Outgoing Payments 

Use 

Payment Lot: Return Payment on Account to Clarification 

If a payment has been assigned to different partners, contract accounts, and contracts, 
and some of these assignments are incorrect, the amounts concerned are to be 
returned to the clarification account. 

If open items are cleared by the payment, there may be a partial reset of the clearing. 
However, until Release 6.02 there was no same option if the payment had been posted 
on account. 

You can now use the new transaction Return Payment on Account to Clarification to 
return individual items posted on account to the clarification account. 

In the menu you can access the transaction under Account -> Return Payment on 
Account to Clarification. 



PSCD_COLLECTIONS_MANAGEMENT: Invoicing in Contract Accounts 
Receivable and Payable 

Use 

As of SAP ERP 6.0 Enhancement Package 2 (Release 6.02), you can use the following 
new functions in Invoicing in Contract Accounts Receivable and Payable: 

o Release/Adjustment of Cash Security Deposits 
In the invoicing process, you can do the following with the new invoicing 
function Release/Adjustment of Cash Security Deposits: 

- Release cash security deposit credits for clearing and for outgoing 
payment 

- Adjust cash security deposit amounts (for example, dependent on the 
consumption behavior of the customer) 

 
You can view the documentation for this invoicing function under 
Release/Adjust Cash Security Deposit. 

 

o Transfer Open Items 
In the invoicing process, you can use the new invoicing function Transfer 
Open Items to transfer open items from any contract account to the contract 
account to be invoiced. 
During the invoicing, you can further process the posting items resulting from this 
transfer. For example, the items could be cleared as part of the account 
maintenance of invoicing. 

 
You can view the documentation for this invoicing function under Transfer 
Open Items. 

 

o Activating Line Items Posted before Invoicing 
The selection option Selection via Invoicing Order (table DFKKINV_TRIG) has 
been added to the existing invoicing function Activation of Line Items Posted 
before Invoicing. 
If you want certain open items that are to be activated to be able to trigger 
invoicing themselves, there must be an invoicing order of the source document 
category ACTIT for these items. 
The invoicing order can then be created automatically when the open item to be 
activated is posted. This is controlled by means of posting area 2627. 
As a result, the items are activated by the invoicing processes that can process 
the source document category ACTIT. 
You can view the documentation for this invoicing function under Activate 
Open Items. 

 

o Stamp Tax  
In the invoicing process, you can calculate, post, and forward stamp tax using 
the new invoicing function Stamp Tax. 
If the stamp tax is passed on to the business partner, then the resulting posting 
document has the posting date, document date, and due date of the invoice. For 
this document, reference document type 0BOL is used in the invoicing 
document. The business partner items posted are shown in the invoicing 
document as items with type of invoicing item 0BOLLO. These items can be 



considered in the final invoice amount. 
In the invoicing reversal, you can use the corresponding function to process 
stamp tax; at event 2669, you can calculate, post, and forward stamp tax. 
At event 2668, you can prevent the receivable being reversed in the invoice 
reversal by a stamp charges created during invoicing and forwarded to the 
customer. 

o Clarification 
You can create clarification cases manually or automatically in various processes 
of Invoicing in Contract Accounts Receivable and Payable. There is a 
clarification process for the asynchronous manual postprocessing of clarification 
cases. You can also clarify clarification cases automatically. 
In the invoicing process you can use the new invoicing functions Plausibility 
Checks for Source Document and Plausibility Checks for 
Invoicing Document to determine and run checks for source or invoicing 
documents. Dependent on the result of the check, this can lead to the creation of 
a clarification case. Contract account checks and error messages in the invoicing 
process can trigger the creation of a clarification case. In the mass creation, the 
clarification case is created automatically; in the individual creation, you can 
decide in dialog whether to create a clarification case. Clarification cases can be 
clarified automatically in the invoicing process. 
In the transfer of billing documents from external billing systems using a BAPI 
or IDoc interface, billing documents can be checked, recognized as implausible, 
and clarification cases can be created. Use the interface parameter 
CFCVALIDATION to check billing documents when they are transferred. When 
you import a billing document reversal or adjust a billing document, you can 
complete unclarified clarification cases of the billing document automatically. 
In the analysis of invoicing orders you can check the source documents and 
create clarification cases for the source document or contract account manually. 
With the clarification processing in dialog, you can process and complete 
clarification cases. It provides the clarification worklist, supports your individual 
selection of clarification cases, and displays the data of the clarification case on 
a detail screen. 

Effects on Customizing 

You make the system settings required to activate the invoicing functions in the 
Implementation Guide of Contract Accounts Receivable and Payable under Integration 
-> Invoicing in Contract Accounts Receivable and Payable -> Invoicing -> 
Invoicing Processes -> Define Invoicing Processes. 

You define the system settings for posting stamp tax (Bollo) in the Implementation 
Guide for Contract Accounts Receivable and Payable under Basic Functions -> 
Special Features of Tax Processing -> Stamp Tax (Bollo) (Italy). 

You make all system settings required for clarification in Invoicing in Contract Accounts 
Receivable and Payable in the Implementation Guide for Contract Accounts Receivable 
and Payable under Integration -> Invoicing in Contract Accounts Receivable and 
Payable -> Clarification Processing and under Integration -> Invoicing in Contract 
Accounts Receivable and Payable -> Program Enhancements -> Define 
Clarification Case Categories. 



PSCD_COLLECTIONS_MANAGEMENT: Integration with Customer 
Relationship Management 

Use 

In Financial Customer Care, you can display information such as the last customer 
payment in Additional Information. This information is displayed using function 
modules registered in Customizing. The function module that you assign to CRM 
profiles in another step determines the necessary data in FI-CA. 

A prerequisite for this is that you have defined search profiles in Customizing for 
Customer Relationship Management under Interaction Center WebClient -> 
Industry-Specific Functions -> Integration with Contract Accounts Receivable 
and Payable (FI-CA) -> Define Search Profile for Account Balance. 

Effects on Customizing 

In the Implementation Guide of Contract Accounts Receivable and Payable under 
Integration -> Customer Relationship Management -> Additional Information in IC 
WebClient, you define the function modules for displaying additional information and 
assign them to CRM profiles. 



PSCD_COLLECTIONS_MANAGEMENT: Installment Plan 
Use 

Update or Reverse Creditworthiness 

For each installment plan category, you can define a creditworthiness value that is 
assigned to the relevant business partner (see Define Categories for Installment 
Plan IMG activity). Using the deactivation reason, you can reverse the creditworthiness 
value if necessary (see Define Deactivation Reasons for Installment Plan IMG 
activity). 

Effects on Customizing 

In the Implementation Guide for Contract Accounts Receivable and Payable under 
Business Transactions -> Deferral and Installment Plan, you can make the 
following settings: 

o Define Categories for Installment Plan In this activity you can define a 
creditworthiness number for each installment category. On the creation of an 
installment plan it is assigned to the related business partner. 

o Define Deactivation Reasons for Installment Plan Using the deactivation 
reason, you can define whether a creditworthiness entry that was updated on the 
creation of an installment plan should be reversed. 



PSCD_COLLECTIONS_MANAGEMENT: Information Container 
Use 

As of SAP ERP 6.0, Enhancement Package 2 (Release 6.02), you can use the 
information container as a tool to save information within a specific process, such as 
returns processing, to send it to an external system later using a mass activity. 

You can define the processes for which information container entries can be created in 
the Implementation Guide for Contract Accounts Receivable and Payable under 
Integration -> Information Container ->  Settings of Information Container 
Categories. There you can also restrict the creation of information container entries 
to a period. 

The data contained in the information container entries is sent via a mass activity in the 
SAP menu under Periodic Processing -> Transfer Data -> Information Container -> 
Forward Information (transaction  FPINFCO1). 

You define the type of forwarding in Customizing in the activity Make Settings for 
Information Container Categories. You can use the following send types for 
each process: 

o XI Interface 
The prerequisite is that there is an XI interface for the corresponding information 
container category. 

o Remote Function Call (RFC) 
The data is sent by the call of event 3703. To use the send type RFC, you have 
to call an RFC-capable function module in the external system at event 3703. 

o Save in File 
If you select the send type Save in File, event 3704 is called. In order to save 
the data in a file, the implementation of the event function module must return file 
content. This content is created from the send data. 

 

You receive information about the information container entries saved and the status of 
the send in the SAP menu under Periodic Processing -> Transfer Data -> 
Information Container -> Display Information Container (transaction FPINFCO2). 

You can reset the send status for test purposes. To do this, in the SAP menu choose 
Periodic Processing -> Transfer Data -> Information Container -> Reset Send 
(transaction FPINFCO3). 

You can define own information container categories in addition to those delivered by 
SAP. 

You can add your own data to the data of the individual information container 
categories. To add data saved for an information container entry, you can use event 
3701. 

To add down data to the send data, you can use event 3702. 

Using event 3701, you can also: 

o Change the number of days up to which data can no longer be sent. In the 
standard the value is set to 100 days. 

o Define the recipient to which the data of the information container entries is sent. 
If several recipients are specified, the same data is sent to the different 
recipients. 

o For specific situations, define that no new information container entry should be 



created. 

You can use the functions of the information container in the following processes: 

o Returns (information container category 0001) 
Within returns processing, you can create information container entries, provided 
you have entered the category 0001 in the IMG activity  Make Settings for 
Information Container Categories and activated the information 
container in the Returns: Specifications for Changing Returns 
Reasons activity. 
You cannot send data using an XI interface for the information container 
category Returns. 

Effects on Customizing 

In the Implementation Guide for Contract Accounts Receivable and Payable, under 
Integration -> Information Containers -> Define Information Container Categories, 
you can define further information container categories. 

In the Implementation Guide for Contract Accounts Receivable and Payable under 
Integration -> Information Containers -> Make Settings for Information Container 
Categories, you can activate information container categories and define the send 
type. 

In the Implementation Guide for Contract Accounts Receivable and Payable under 
Integration -> Information Containers -> Settings for Processes -> Returns: 
Specifications for Changing Returns Reasons, you can activate the creation of 
information container entries within the returns activities. 



PSCD_COLLECTIONS_MANAGEMENT: Enterprise Services 
Use 

As of SAP ERP 6.0 Enhancement Package 2 (Release 6.02), in Contract Accounts 
Receivable and Payable, you can use new Enterprise Services as XI interfaces. 

In Enterprise Service Repository, for the software component FI-CA, under FI-CA 
700 -> http://sap.com/xi/FICA/Global -> Service Interfaces, you can use the 
following XI interfaces: 

o CashPointPaymentCreateNotification_In 

o CashPointPaymentReverseNotification_In 

o CashPointClosingDocumentNotification_In 

o CashPointOpenItemSummaryNotification_In 

o CashPointOpenItemSummaryByElementsQueryResponse_In 

o CollectionsWorkListNotification_Out 

o CollectionsWorkListItemCancellationNotification_Out 

o  
CollectionsWorkListItemStatusByCollectionsWorkListItemIDQueryRespons
e_Out 

o CustomerInitiatedPaymentReceivedBulkNotification_Out 

 

Namespace FICA/Global/Testing 

SAP provides corresponding test interfaces for the XI interfaces named above. 



PSCD_COLLECTIONS_MANAGEMENT: External Cash Desk Services 
Use 

Payments via External Cash Desk Services 

As of SAP ERP 6.0, Enhancement Package 2 (Release 6.02), Contract Accounts 
Receivable and Payable enable you to process payments from your customers using  
external cash desk services. 
FI-CA differentiates between two branch categories for the external cash desk 
services - branches of the category Offline and Agent. You can continue to use the 
full functions of the cash journal in FI-CA; it is completely independent of the external 
cash desk services. In the cash journal you can enter and post payments directly in the 
SAP system. 

The external cash desk services consist of the following services, whereby the transfer 
of the data between the SAP system and the external cash desk system can be 
synchronous or asynchronous via the SAP Exchange Infrastructure (XI). 

• CashPointPaymentCreateNotification 
The CashPointPaymentCreateNotification service is an asynchronous process that 
sends payments to an external cash desk to FI-CA. 

• CashPointPaymentReversalNotification 
The CashPointPaymentReversalNotification service is an asynchronous process 
that sends the reversal of a payment to an external cash desk to FI-CA. 

• CashPointClosingActivityNotification 
The CashPointClosingActivityNotification service is an asynchronous process that 
sends the cash desk closing of an external cash desk to FI-CA. 

• CashPointOpenItemSummaryNotification 
The CashPointOpenItemSummaryNotification service is an asynchronous process 
that sends a list of open items from FI-CA to the external cash desk system. A mass 
activity extracts the data in FI-CA. 

• CashPointOpenItemGetSummaryQuery 
The CashPointOpenItemGetSummaryQuery service is a synchronous process. The 
external cash desk sends a query to FI-CA; for example, all open items for a business 
partner are selected in FI-CA and sent to the external cash desk system. 

 

The cash desks of the cash journal in FI-CA are linked directly with the SAP system. In 
FI-CA, you can use the cash journal to enter payments directly in the system, evaluate 
them, and run follow-on postings such as deposits, withdrawals, differences and 
reversals to the cash desk balance. 

In the case of the offline branch or an   agent, the cash desks where the 
payments are processed are not permanently connected to FI-CA in the SAP system. 
For an offline branch and an agent, currently only XI messages can be received that 
refer to incoming payments to external cash desks. Outgoing payments to external 
cash desks are currently not supported. 

Post Payments: CashPointPaymentCreateNotificationService 

For incoming XI messages that refer to incoming payments, the system tries to post the 
payments directly. Dependent on the specifications for clearing control and the 
selection specifications, the payment can be posted directly. Payments that could not 
be posted directly receive the status R. 

Post Payments in Repetition Mode 

You can automatically select payments received via XI and that could not be posted 



directly via the repetition process and trigger their posting again. If the repetition 
process also fails, the incoming payments are transferred to a payment lot. For a 
repetition process you can define whether unsuccessful payments are to be transferred 
to an existing or new (to be created) payment lot and whether the payment lot created 
is to be closed and, if necessary, also posted. 

Reverse Payments: CashPointPaymentReversalNotificationService 

The external cash desk system can reverse payments received via XI. An XI message 
that refers to a reversal of an existing external payment is received by the SAP system 
and posted directly in FI-CA. Reversals that could not be executed directly receive the 
status D. 

Swap Open Items to Be Paid 

You can swap open items for a business partner between the external cash desk 
system and the SAP system using SAP Exchange Infrastructure (XI). 

Agent Posting 

For the reconciliation between the SAP system and the external cash desk system you 
can create an agent posting receivable from the external cash desk system or the  
agent. The agent postings are posted to a separate contract account that you can 
define in the master data for external cash desk services. 

Monitor for External Cash Desk Services 

The Monitor for External Cash Desk Services (see SAP menu: Payments -> 
External Cash Desk Services) enables you to manage and monitor payments 
received via the SAP Exchange Infrastructure. For example, you can access master 
data, agent postings, and successful messages for external payments. You can make 
the data selection at the level of the external cash desk or the agent and using further 
selection criteria. 

On the Overview, XI Monitor, Payments, and Agent Postings, you can use the 
following functions: 

o Overview 
Here you can select the grouping key and the master data by date and date 
intervals. 
The selection by master data delivers all payments with their respective status as 
well as the specification of the agent or the cash desk. 
The selection by grouping key delivers the status of all grouping keys for external 
payments. 
If the status is incorrect, here you can, for example, repeat postings to correct 
the error and then determine the new status via a refresh. 

o XI Monitor 
Here you can navigate directly to the XI messages for a message category. 

o Payments 
On this tab page you receive information about all payments according to their 
respective status. In addition, you can also, for example, repeat postings, add 
payments to payment lots and display payment lots, agent information, and the 
note to payee. 

o Agent Postings 
This tab page displays all payments for a grouping key. Here you can monitor 
individual payments of a grouping or individual XI messages. To reach a specific 
balance, you can manually post differences for a grouping key. 

Effects on Customizing 

You make the required settings in the Implementation Guide of Contract Accounts 
Receivable and Payable under Business Transactions -> Payments -> Processing 



of Incoming/Outgoing Payments -> External Cash Desk Services. Here you define: 

o HyperLink: SIMG._FICABTPY_EXTCDS Cash desk structure 

o Master data for external cash desk services 

o HyperLink: SIMG._FICABTPY_FQH4 Cash desk clearing accounts 

o HyperLink: SIMG._FICABTPY_FQEXC1 Specifications for agent 
posting 

o Document types for postings for external cash desk services 

o Clearing accounts for payment lot for external cash desks 



PSCD_COLLECTIONS_MANAGEMENT: Closing Operations 
Use 

Foreign Currency Valuation 

You can assign a ledger group to a valuation area. This has the following effects for the 
foreign currency valuation: 

o The adjustment documents created are assigned to a ledger group as far as 
possible. 

o Where there is a 1:1 assignment between valuation area and ledger group, you 
no longer have to define separate adjustment accounts per valuation area. 

o The importing parameter Ledger Group has been added to the interface of 
event 0580. 

o Transaction FPW2 for displaying the log records also displays the ledger group 
(see SAP menu: Periodic Processing -> Closing Preparations -> Foreign 
Currency Valuation). 

Effects on Customizing 

Valuation Areas 

You define valuation areas in the activity Define Valuation Areas in the 
Implementation Guide for Contract Accounts Receivable and Payable under Closing 
Operations. Assign a ledger group to each valuation area. 



PSCD_COLLECTIONS_MANAGEMENT: Billing in Contract Accounts 
Receivable and Payable 

Use 

As of SAP ERP 6.0 Enhancement Package 2 (Release 6.02), billing is accommodated 
in Contract Accounts Receivable and Payable. 

Billing in Contract Accounts Receivable and Payable allows you to import and bill 
Event Detail Records (EDR) from different external rating systems. The billing function 
creates billing documents that are invoiced using Invoicing in Contract Accounts 
Receivable and Payable. Contract Accounts Receivable and Payable thus supports the 
invoice creation process as follows: 

o Billing in Contract Accounts Receivable and Payable 

- Transfer for EDRs that were valuated in the rating system 

- Aggregation of EDRs with regard to the service products defined in the 
service contract, based on a stipulated billing cycle 

o Invoicing in Contract Accounts Receivable and Payable 

- Cross-service invoicing of different billing flows 
You can invoice billing documents from Billing in Contract Accounts 
Receivable and Payable as well as billing documents from external billing 
systems. 

- Create an invoice that can be transmitted to the customer on paper or 
electronically 

o Contract Accounts Receivable and Payable 

- Monitoring of the payment of the open items associated with the invoice 

 

The billing process in Contract Accounts Receivable and Payable comprises the 
following steps: 

o Import billing accounts from an external CRM system by means of a BAPI 
interface 
EDRs are imported and billed in Billing in Contract Accounts Receivable and 
Payable with reference to billing accounts. These billing accounts must first be 
imported. The billing accounts exist in an external CRM system (for example, 
SAP CRM) and can be transferred to Billing in Contract Accounts Receivable 
and Payable by means of a BAPI. The BAPI 
BAPI_FKKBI_BILLACCOUNT_UPDATE is provided for this purpose. You also 
use the BAPI to make changes to the billing accounts. You cannot make 
changes to billing accounts in Billing in Contract Accounts Receivable and 
Payable itself. 
The components of an invoice to be billed for a billing account are defined using 
billing account items. 

o Import the EDRs from external rating systems by means of a BAPI interface 
You can process EDRs of different EDR categories in Billing in Contract 
Accounts Receivable and Payable. Each EDR category has a defined data 
structure. The standard SAP contains the EDR category TOLLCOLL for billing 
tolls. You can transfer EDRs for the EDR category TOLLCOLL from external 
rating systems by means of the BAPI BAPI_EDR_TCOLL_CREATEMULTIPLE. 
A comprehensive enhancement concept allows you to define project-specific 
EDR categories. 

o Create billing orders 



Billing cycles enable you to bill billing accounts at regular intervals with Billing in 
Contract Accounts Receivable and Payable. To this end, you create billing 
orders that are executed by the billing process. The billing order relates to a 
contract account. 

o Billing of billing orders 
When you execute a billing order, the system bills the billing accounts that have 
the same billing cycle, which are assigned to a contract account.  When billing is 
performed for a billing account, a billing period, which determines which EDRs of 
the billing account are billed, is created. Thus, for example, all of the EDRs, 
which have been transferred to Billing in Contract Accounts Receivable and 
Payable since the last billing run and until the 15th of the current month, are 
billed for the billing account. 
Besides EDR billing, Billing in Contract Accounts Receivable and Payable also 
supports the billing of non-EDR-based invoice components, such as the basic 
charge of a service contract based on the contract term, or the charge for 
providing a technical device. To this end, you define billing account items for 
non-EDR-based billing for the relevant billing accounts in Billing in Contract 
Accounts Receivable and Payable. 
Executing a billing order creates a billing document that is invoiced using 
Invoicing in Contract Accounts Receivable and Payable. 

Effects on Customizing 

You make the system settings required for Billing in Contract Accounts Receivable and 
Payable in the Implementation Guide for Contract Accounts Receivable and Payable 
under Integration -> Billing in Contract Accounts Receivable and Payable. 



PSCD_COLLECTIONS_MANAGEMENT: Integration with Business 
Intelligence 

Use 

Extraction of Business Partner Items 

You can now extract all business items, both real and statistical items, for evaluation of 
receivables and payables in Business Intelligence (BI). You can run the extraction as 
full update, delta initialization, and delta update. 

Prerequisites 

If you want to use the delta procedure, you first have to activate it in the Implementation 
Guide for Contract Accounts Receivable and Payable under Integration -> Business 
Intelligence-> Maintain Central Settings. Run the delta extractions as soon after the 
activation as possible. 

If you also want to extract the write-off reason of individual business partner items, you 
have to specify this under Integration -> Business Intelligence -> Make Central 
Settings. 

Extrakt structure 

The extract structure FKKOPBW_DELTA contains all fields that could be relevant for 
the evaluations in BI, but the DataSource delivered with the BI content only extracts the 
most important of these fields. If you need additional fields for your individual 
evaluation, you have to adjust the DataSource accordingly and replicate it in your BI 
system. 

Delta Update 

The delta procedure is realized with the update of a delta queue. Transactions that 
create or change the business partner items do not update the delta directly (for 
example, Post Document (FPE1)). Instead, they only save the document numbers in a 
trigger table. A new mass activity enables the update in the delta queue (see SAP 
menu Periodic Processing -> Extraction for Business Intelligence -> Business 
Partner Items with Delta Procedure -> Delta Queue for Business Partner Items). 
The delta procedure After Image via Delta Queue (AIM) is used. 

The parallelization object of the mass activity is a three character figure. If the last three 
figures of the document number are numerical, the system uses these for the 
parallelization object. Otherwise the system uses a randon generator to generate a 
three character figure for each document. 

Connection to Archive 

The extractor 0FC_BP_ITEMS supports the connection to archives. For the extraction 
from archives you can create and schedule InfoPackages in full update. Note that 
with selection by date of entry of a document (CPUDT), you cannot access the archive 
and you have to preselect the archive files to be selected when you create info 
packages. 

T

Deletion of Triggers 

You can delete the document numbers that trigger the delta update from the trigger 
table after the extraction (see SAP menu Periodic Processing -> Extraction for 
Business Intelligence -> Business Partner Items with Delta Procedure -> Delete 
Triggers). However, you should not delete triggers for documents that will probably be 
changed again in the future. For example, receivables documents or documents with 
repetitions that are cleared periodically. 

You can restrict the document numbers to be selected by the date the document was 
created or last changed. The final date of the selection must not be after the date of the 



last successful delta extraction. For security purposes, we also recommend a safety 
interval of 90 days between the final date of the selection and the current date. You can 
also restrict the triggers to be delete by selection of the document number. If you define 
an own number range for documents with repetitions that are to be cleared periodically, 
you can exclude these directly, for example. 

Reconciliation with General Ledger 

You can reconcile the business partner items extracted with the balances of the 
corresponding G/L accounts in the general ledger in the BI system. The prerequisite for 
the reconciliation is that the extractions of the FI-CA business partner items and the 
G/L items in the general ledger take place in close succession and that you only run the 
reconcilation for closed posting periods. 

Extraction of Dunning History and Dunning Activities 

As of SAP ECC 6.0, Enhancement Package 2 (Release 6.02), you can extract all 
dunning headers, dunning items, and dunning activities for the evaluation of dunning 
notices in Business Intelligence (BI). The extraction takes place with the dunning run. 

You can run the extraction as full update, delta initialization (with/without data transfer), 
and delta update. 

The extract structures FKKMAKOBW_DELTA, FKKMAZEBW_DELTA, and 
FKKMACTBW_DELTA contain all fields relevant for the valuation in BI. The 
DataSource delivered with the BI content only extracts the most important of these 
fields. If you need additional fields for your individual evaluation, you have to adjust the 
DataSource accordingly and replicate it in your BI system. 

Full Update/Delta Initialization with/without Data Transfer 

The extractor supports the selection by date ID in both modes where dunning histories 
and dunning activities are transferred from the ERP system to the BI system. 

Delta Update 

Transactions that create or change dunning activities (such as FPVB, FPVV) call 
function modules for the update of the delta queue. You must have run a delta 
initialization once before you can run a delta update. The delta procedure After Image 
via Delta Queue (AIM) is used. 

Update after termination of the dunning run 

If a dunning run terminates, the system also terminates the update of the delta queue. 
Once you have restarted the terminated dunning run and completed it successfully, in 
the SAP menu under Periodic Processing -> Extraction for Business Intelligence -
> Dunning History/Dunning Activities with Delta Procedure -> Update Delta 
Queue after Termination, you can write the data transferred after the termination to 
the delta queue and thus remove the data inconsistency caused by the termination. 

Effects on Customizing 

You make the settings for the extraction of data from Contract Accounts Receivable 
and Payable (FI-CA) in the Implementation Guide for Contract Accounts Receivable 
and Payable under Integration -> Business Intelligence -> Make Central Setting. 

In this activity you activate the delta extraction for business partner items and the 
dunning history. For the dunning history you can activate the delta extraction for 
dunning items and dunning activities (both optional); the dunning headers are always 
extracted. Here you can also define whether the information about the write-off reason 
of individual business partner items is to be selected in the extraction. 



PSCD_COLLECTIONS_MANAGEMENT: Archiving 
Use 

New Archiving Object: Promise to Pay 

You can archive promises to pay with the new archiving object FI_MKKPP. The 
prerequisites for the archiving are described in the documentation of report 
RFKKPPAR01 (see SAP menu: Periodic Processing -> Archive Data). 

New Archiving Object: External Payment Information 

You can archive data for external payment information with the new archiving object 
FI_MKKEXC. The prerequisites for the archiving are described in the documentation of 
report RFKKEXCAR01 (see SAP menu: Periodic Processing -> Archive Data). 

New Archiving Object: Totals Records for External Payment Information 

You can archive totals records for external payment information with the new archiving 
object FI_MKKEXCS. The prerequisites for the archiving are described in the 
documentation of report RFKKEXCSAR01 (see SAP menu: Periodic Processing -
> Archive Data). 

New Archiving Object: Collection Worklist 

With the new archiving object FI_MKKWL you can archive data for collection worklists. 
The prerequisites for the archiving are described in the documentation of report 
RFKKWLAR01 (see SAP menu: Periodic Processing -> Archive Data). 

New Archiving Object: Collection Work Item 

With the new archiving object FI_MKKWLI you can archive data for collection work 
items. The prerequisites for the archiving are described in the documentation of report 
RFKKWLIAR01 (see SAP menu: Periodic Processing -> Archive Data). 

New Archiving Object: Information Container 

With the new archiving object FI_MKKINF you can archive data for information 
containers. The prerequisites for the archiving are described in the documentation of 
report RFKKINFAR01 (see SAP menu: Periodic Processing -> Archive Data). 

Enhancement for Business Partner Archiving (Archiving Object CA_BUPA) 

The notes for master data groups are also archived. There are no additional checks. 

Enhancement to Archiving of Dunning History (Archiving Object FI_MKKDUNN) 

In addition, database table FKKMACTIVITIES is archived with no further checks. 

Enhancement to Archiving of Convergent Invoicing (Archiving Object FI_MKKTHI) 

History entries contained in database table DFKKTHI_HIST are also archived. 

Enhancement to Document Archiving (Archiving Object FI_MKKDOC) 

In the archiving of FI-CA documents, the entries of the database table DFKKOPWH are 
also archived. 

 

Effects on Customizing 

You maintain the archiving lives and the respective archive information structure for the 
following archiving objects in the Implementation Guide for Contract Accounts 
Receivable and Payable. 

o Promise to pay (FI_MKKPP) 
Choose Business Transactions -> Promise to Pay -> Archiving 



o External payment information (FI_MKKEXC) 
Choose Business Transactions -> Payments -> Processing of 
Incoming/Outgoing Payments -> External Cash Desk Services -> Archiving. 

o Totals records for external payment information (FI_MKKEXCS) 
Choose Business Transactions -> Payments -> Processing of 
Incoming/Outgoing Payments -> External Cash Desk Services -> Archiving. 

o Collection worklist (FI_MKKWL) 
Choose Business Transactions -> Dunning -> Dunning by Collection 
Strategy -> Worklists and Work Items -> Archiving. 

o Collection work item (FI_MKKWLI) 
Choose Business Transactions -> Dunning -> Dunning by Collection 
Strategy -> Worklists and Work Items -> Archiving. 

o Information container (FI_MKKINF) 
Choose Integration -> Information Container -> Archiving 



PSCD_COLLECTIONS_MANAGEMENT: Account Balance Display 
Use 

Balances variants in account balance 

In addition to the existing totals in the account balance display, you can configure 
balances variants in Customizing. The individual balances are summarized to balances 
groups and displayed as tables. This means that a balances category (row), for 
example, receivables or items in an installment plan, subdivided further by a balances 
grid (column) such as open, due, or due in 30 days. 

You have to calculate additional balances using event 1299. 

 

Effects on Customizing 

Maintenance of Balances Variants in Customizing 

You configure balances groups in the Implementation Guide for Contract Accounts 
Receivable and Payable under Basic Functions -> Account Balance Display -> 
Define Balances Groups. Here you define which balances categories are to be used 
in the rows for the table display and which balances grid is to be used in the columns. 

You summarize the balances groups into balances variants in the activity Define 
Balances Variants. You can also hide individual balances for a balances variant. 



Business Function PSM, Grantor Integration (PSCD) 

PSCD_GRANTOR, PSM Grantor Integration (PSCD) (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, Grantor Management (GM-GTR) is fully integrated with 
Public Sector Collections and Disbursements (PSCD). This means you can: 

Create/change precommitments and forecast of revenue documents based on a CRM 
application 

Create/change commitments and forecast of revenue documents base on a CRM 
agreement 

Use the new multi-funding feature to define various funding sources that, in turn, define 
the percentage distribution and the relevant account assignments 

Use automatic creation of a funded program based on a CRM program 

Create/change open items in PSCD 

Effects on Customizing 

Use the following steps in Customizing to configure GM-GTR integration with PSCD: 

Master Data 

o Maintain Grantor Derivation Strategies 

o Maintain Customer-Specific Condition Fields 

o Maintain Grantor Rule-Based Account Assignment 
Distribution 

o Business Add-Ins for Grantor Management Master Data 

- BAdI: Grantor Management Derivation Enhancement 
- HyperLink: SIMG.BADI_PSM_MEASURE_REPL BAdI: Funded 

Program Wrapper 

Integration with Public Sector Collections and Disbursements (PSCD) 

o HyperLink: SIMG.GTR_PREPARE_INT Integration Scenarios 

o HyperLink: SIMG.SIMG_GTR_PROGPROFIL Edit Program Profile 

o HyperLink: SIMG.SIMG_GTR_BILLINV Define Invoicing Parameters 

o Business Add-Ins for Integration 

- BAdI: Summarize CRM Data for Creating/Changing Funds 
Reservations 

- BAdI: Extract and Use Enhanced Data from CRM 



Business Function PSCD, Tax Return Processing 

PSCD_TRM_RETURN_PROCESSING: PSCD, Tax Processing (New) 
Use 

As of  SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03 , the 
Business Function PSCD, Tax Processing is available. This Business Function 
supports the registration of taxpayers and the processing of tax returns. You can use it 
to create taxpayers and/or contract accounts for taxpayers in the system. Map the 
dates by which the taxpayer must submit a tax return with the help of inbound 
correspondence requests in the system. 

SAP supports different channels through which the submitted tax returns can reach the 
system. For example, you can scan tax forms into the system.  The data on the tax 
returns is validated in the system automatically. Follow-on activities can be triggered 
and the tax owed is calculated by the Business Rule Framework. You can then invoice 
the billing documents that the system generates with this. The system includes the 
billing results in the invoicing document fort his and derives the postings from the billing 
data in Contract Accounts Receivable and Payable. 

See the following release information for more information: 

o PSCD_TRM_RETURN_PROCESSING: Registration of 
Taxpayers (New) 

o  PSCD_TRM_RETURN_PROCESSING: BRF (Tax Validation/ 
Calculation (New) 

o  PSCD_TRM_RETURN_PROCESSING: Billing for TRM (New) 
o  PSCD_TRM_RETURN_PROCESSING: Invoicing of Billing 

Documents in TRM (New) 
o PSCD_TRM_RETURN_PROCESSING: Generating Forms (New) 
o PSCD_TRM_RETURN_PROCESSING: Processing Tax Returns 

(New) 
o PSCD_TRM_RETURN_PROCESSING: Revenue Types (New) 
o PSCD_TRM_RETURN_PROCESSING: Uploading Forms (New) 
o PSCD_TRM_RETURN_PROCESSING: Portal Content(New) 

Effects on Existing Data 

There are changes in the following automatic roles with this Business Function (PFCG 
roles): 

o SAP_EP_ISPSCA_FICA_TAX 

For more information on how automatic  roles are used, see the SAP Library under 
Roles -> Automatic Roles. 

See also 

For more information, see the SAP Library under SAP ERP Central Component -> 
Business Function Sets and Business Functions -> Industry Business Function Sets -> 
Public Services -> PSCD, Tax Processing. 



PSCD_TRM_RETURN_RROCESSING: Registration of Taxpayers (New) 

Use 

As of SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03 , 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can register taxpayers using a Web Dynpro application. It leads the tax 
officer through the registration process step by step. The main advantage of this Web 
Dynpro application is that the tax officer does not need any special knowledge about 
master data, structures, or transactions of the back-end system. The program creates 
the necessary master data (business partner, contract accounts, contract objects) 
automatically once the registration process has been completed. 

The information relevant for the taxation of an object is saved in theFacts. The 
different aspects of the taxation are mapped using fact types. The different fact types 
are grouped into a fact set and each fact set is assigned to a contract object type. This 
ensures that the information on the contract object relevant for taxation can be entered 
on registration. 

The aspects of a vehicle relevant for taxation can be the tax bracket (for private 
vehicles), engine size, CO2 emissions, fuel type (petrol or diesel), registration date, 
payment scheme, and, not to be forgotten, the registration data for example. This data 
is stored in fact type RG01 which is delivered by SAP. RG01 contains the following 
data: business partner, contract account, contract object, status, and tax period. 

In order to access the registration data relevant for a contract object, you must assign 
fact type RG01 to the corresponding fact set. 

SAP delivers different processing statuses for each registration that control the 
processing options available for a registration. You can define more statuses in the 
Customizing of Contract Accounts Receivable and Payable and then program a 
workflow. 

If you need to change master data after you have created the registration, do this in the 
corresponding transactions in the backend system. 

For more information, see the following release information: Portal Content for 
Tax Officers. 

Effects on Existing Data 

This function does not affect the data that you have already saved in your system. 

Effects on Customizing 

You define the Customizing settings for this function in the Customizing of Contract 
Accounts Receivable and Payable under the following IMG activities: 

o HyperLink: SIMG._ISPSCA_TFMCA_REVTYPE Define Revenue Type 

o  Assign Contract Object Type to Revenue Type 

o Define Specifications for Tax Periods 

o In order to configure the facts that you want to use, you must configure the Facts 
section. Make sure that fact type RG01 delivered by SAP is included in the fact 
sets. 

o To define sample values that the program should use when creating contract 
objects and contract accounts, perform the following IMG activities: 

-  Define Sample for Contract Account Categories 

- Define Sample for Contract Account Types 



See also 

For more information, see the SAP Library under Registration of Taxpayers. 



PSCD_TRM_RETURN_PROCESSING: BRF Tax Validation/Calculation 
(New) 

Use 

As of  SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03 , 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can use the  Business Rules Framework(BRF) to map rules for the 
validation and calculation of object-based and form-based taxes in the system. For 
object-based tax, the tax liability constitutes an object (such as, vehicle tax). Taxes for 
which the taxpayer has to submit a tax return (such as income tax) are known as form-
based taxes. The BRF is called in the single and mass transactions for calculating 
object and form-based tax and also for the validation of forms from the application for 
processing tax returns. Information on the latter can be found in the release information  
PSCD_TRM_RETURN_RROCESSING: Processing Tax Returns 
(New). 
Each application used in the BRF is assigned to an application class. This ensures that 
different applications do not affect each other. 
SAP delivers the following application classes that contain all implementing classes 
that you can use for the tax validation and calculation. 

o TRM_TEMPLATE_FORM for form-based tax 

o TRM_TEMPLATE_OBJECT for object tax 

o TRM_TEMPLATE_OBJECT_TIME for object tax with time-dependent data 

You can copy these implementing classes into your own application classes in IMG 
activity  Copy Implementing Classes. The name of the implementing classes in the 
following list are the names in the application classes delivered. 

In addition to the expression and action types that are available in the BRF as 
standard, there are a number of additional functions that you can use. 

Context Information 

When calling the BRF for the tax calculation, the system writes the data that it needs 
for the calculation and validation in a buffer by default which you can access. You can 
also load more data from each table to the context buffer. You can then access this 
data the same way. 

Container of the context is an event. To define events in Tax and Revenue 
Management (TRM) always use the implementing class 0FICAEVENT. 

Actions 

Actions map manipulations of datasets and are used to map rules in the BRF. SAP 
delivers the following actions for tax validation and calculation that you can use as well 
as the actions that are available in the BRF as standard. 

Description of Action Implementing Class 

Get context data 0FICAIN001 

Create billing document 0TRMBI001 

Create additional item of billing document 0TRMAI001 

Set block 0TRMSL001 

Issue message 0TRMMSG001 

Create inbound correspondence request 0TRMIC001 



Set date of receipt 0TRMSR001 

Define form rules 0TRMFO001 

Define values for revenue distribution 0TRMRD001 

Implicit registration 0TRMIR001 

Start workflow 0TRMWF001 

Expressions 

In an expression, data of the application or data of objects related to the application (for 
example, business partner data) are processed in accordance with a rule (such as a 
calculation rule) you can define yourself.  Once the system has processed the data, the 
expression returns any primitive type (such as a date) as a result. SAP delivers the 
following expressions for tax validation and calculation that you can use as well as the 
expressions that are available in the BRF as standard. 

Description of expression Implementing class 

Calculate 

charges 0TRMPEN001  
Calculate interest 0TRMIN001 

Read fact value 0TRMRF001 

Request from/to date of a period  0TRMRP001 

Request XML value  0TRMRX001 

Gradual calculation 0TRMPC001 

Time-dependent expressions 

You can create expressions that are time-dependent, this means that they return 
different values for different time segments (time slices). Implementing classes 
available as standard in the BRF were copied and enhanced for this so that they 
provide time-dependent return values. The following implementing classes for time-
dependent expressions are available for this. 

o 0TRMAO001 (and/or of Boolean expressions) 

o 0TRMFM001 (calling a function module) 

o 0TRMCE001 (CASE expression) 

o 0TRMPM001 (truth tablle) 

o 0TRMAO001 (Boolean expression with three variables) 

o 0TRMFB002 (SAP formula interpreter) 

o 0TRMRE001 (range expression) 

If you use an expression with implementing class 0TRMTSM001, you can multiply a 
value by the length of the time slice in which it is valid. Define the corresponding time 
unit for this (for example, month or year). 

With an expression with implementing class 0TRMTSA001, you can use time slices to 
aggregate, for example, map the total of all time slices. The return value of the 
expression is then no longer time-dependent. 

If you use a time-dependent expression in the action when creating billing documents, 
you can create your own billing document for each time slice. 



Events 

Events P300 and P301 are available when creating additional items for the billing 
document. For more information, see the documentation on the sample function 
modules. 

FMCA_SAMPLE_P300 (Derive texts for maintaining additional items) and 

FMCA_SAMPLE_P301 (Substituting additional items) 

Effects on Customizing 

You define the Customizing settings for this function in the Customizing of Contract 
Accounts Rceivable and Payable in the following IMG activities: 

Create Application Class Client-Independent 
Copy Application Class 

Define Additional Settings for Application Class 

Copy Implementing Classes 

Define Time Units for Time Slices 

Define Main/Sub-Transaction for Open Items 

Generate Expressions for Forms 



PSCD_TRM_RETURN_RROCESSING: Billing for TRM (New) 
Use 

As of SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03, 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can create billing documents for form-based and object-based tax. The programs 
use the  Business Rules Framework (BRF) to validate the relevant revenue 
type and calculate the billing amount. You can use the following functions: 

The program Create Billing Documents for Object-Based Tax (FMCABILLI) creates 
billing documents for object-based tax for individual business partners, contract 
accounts or contracts. You can choose whether you want to create billing documents 
only (or simulated billing documents), or also invoicing and posting documents, and 
whether you want to trigger the printing of tax assessments. You can also generate 
adjustment billing for objects already billed. 

For the transaction for individual billing, see the menu of Contract Accounts Receivable 
and Payable, under  Invoicing -> Dialog Processing -> Generate Billing Documents 
for Object-Based Tax (Individual Creation). 

The program Create Billing Documents for Object-Based Tax  (FMCABILLM) is a 
mass activity that enables billing documents to be created for object-based tax for a 
large number of business partners, contract accounts, or contracts. You can choose 
whether you want to create adjustment billing for objects already billed and billing 
documents only simulated. You can also stipulate that objects should only be selected 
using billing orders. The system creates billing orders when changes to master data 
make a recalculation of tax necessary. 

For the transaction for mass billing, see the menu of Contract Accounts Receivable and 
Payable, under Invoicing -> Parallel Processing -> Create Billing Documents for 
Object-Based Tax. 

If an object for the taxpayer was already billed and an adjustment billing takes place, 
the system creates adjustment billing documents. 

So that contracts cannot be billed more than once when they are assigned to different 
business partners and contract accounts, the billing-relevant master data must be 
defined in the facts. SAP delivers fact type BILL for this. Assign the BILL fact type to 
the relevant fact set. You can also define that contracts should be billed proportionally 
for different business partners and contract accounts by specifying a percentage. Note 
that the proportionate distribution does not take place automatically; the facts have to 
be evaluated accordingly in BRF. The BILL fact type contains the following data: 
business partner, contract account, contract object, and percentage. 

The program Validation and Billing of Tax Returns and Requests (Individual 
Creation) (FMCAFOBIS) creates billing documents for form-based tax for individual 
business partners, contract accounts, or contracts. You can choose whether you only 
want to create billing documents (or simulated billing documents), or also invoicing and 
posting documents and whether you want to trigger the printing of tax assessments. 

For the transaction for individual billing, see the menu of Contract Accounts Receivable 
and Payable, under  Invoicing -> Dialog Processing -> Validation and Billing of Tax 
Returns and Requests (Individual Creation). 

The program Validation and Billing of Tax Returns and Requests (FMCAFOBI) is a 
mass activity that enables billing documents or simulated billing documents for form-
based tax to be created for a number of business partners, contract accounts, or 
contracts. 

For the transaction for mass billing, see the menu of Contract Accounts Receivable and 
Payable, under Invoicing -> Parallel Processing -> Validation and Billing of Tax 



Returns and Requests. 

Effects on Customizing 

You define all system settings necessary for billing in Contract Accounts Receivable 
and Payable in the Implementation Guide for Contract Accounts Receivable and 
Payable under  Integration -> Invoicing in Contract Accounts Receivable and 
Payable . 

Note: 
In IMG activity  Define Error Messages for Billing Clarification Cases, you 
can define error messages that result in clarification cases in billing. 

Settings must be defined in the following IMG activities before you can generate billing 
documents: 

o HyperLink: SIMG._ISPSCA_TFMCA_REVTYPE Define Revenue Type 

o Assign Contract Object Type to Revenue Type 

o HyperLink: SIMG.ISPSCA_TFMCA_BRFEVEN Assign BRF Events to 
Revenue Type 

o Define Specifications for Tax Periods 

See also 

For more information, see the SAP Library under SAP ERP Central Component -> SAP 
Public Sector Tax and Revenue Management -> Billing/Invoicing in Tax and Revenue 
Management (TRM). 



PSCD_TRM_RETURN_PROCESSING: Invoicing of Billing Documents in 
TRM (New) 

Use 

As of SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03 , 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can invoice billing documents that were created in Tax and Revenue Management 
(TRM). 

You must distinguish between object-based and form-based tax when creating billing 
documents. For object-based tax, the tax liability constitutes an object (such as, vehicle 
tax). Taxes for which the taxpayer has to submit a tax return (such as income tax) are 
known as form-based taxes. Different functions are available for this when creating 
billing documents. 

The billing results are included in the invoicing document; postings are derived from the 
billing data in Contract Accounts Receivable and Payable. 

An invoicing history is updated for the processed billing document. 

Several billing documents can be processed in an invoicing document. A joint posting 
document is posted by default for all these billing documents. Alternatively you can 
define that a separate posting document is posted for each billing document when 
configuring the invoicing process. You can also define the following in event 2610: 

o in which order the billing documents should be processed and displayed in the 
invoice 

o for which billing documents a joint posting document should be created 

The functions for creating invoicing documents can be found in the SAP Easy Access 
Menu: 

o Single processing 
 Accounting -> Financial Accounting  -> Contract Accounts Receivable and 
Payable -> Invoicing -> Dialog Processing -> Create Invoicing Document  

o Mass processing 
 Accounting -> Financial Accounting  -> Contract Accounts Receivable and 
Payable -> Invoicing -> Parallel Processing -> Create Invoicing Document  

Effects on Customizing 

You define the Customizing settings for this function in the Customizing of Contract 
Accounts Receivable and Payable under Integration -> Invoicing in Contract 
Accounts Receivable and Payable. 



PSCD_TRM_RETURN_PROCESSING: Generating Forms (New) 
Use 

As of SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03, 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can generate forms. You can use these to create forms based on inbound 
correspondence requests in order to map the delivery of forms for income tax returns in 
the system. These forms are sent to customers who fill them in and then send them 
back. After receipt of the filled-in form, it is processed in the system and fulfils the 
above-mentioned inbound correspondence request amongst others. 

To generate forms you use mass activity Generate Inbound Correspondence: 
Generate Forms  and the general mass activity for printing. Both functions can be 
found in the application menu of Public Sector Contract Accounts Receivable and 
Payable under Periodic Processing -> For Contract Accounts -> Correspondence. 
The system selects all existing inbound correspondence requests for each master data 
record (business partner, contract account, contract object) and creates forms. The 
system prints a cover sheet and the corresponding form for each inbound 
correspondence request at the same time. 
The program runs event P703 to create the print information for forms. The printout 
itself is performed using event P702. 

Effects on Customizing 

You define the Customizing settings for this function in the Customizing of  Contract 
Accounts Receivable and Payable in the following IMG activities: 

o  Define Inbound Correspondence Category 

o  Status for Generating Inbound Correspondence 

o  Assign Form to Inbound Correspondence  

o  Define Postings Specifications for Posting Sample 
Documents 

To use the enhanced inbound correspondence functions, activate them in IMG activity 
Activate Enhanced Inbound Correspondence. 

See also 

For more information, see the SAP Library under SAP ERP Central Component -> SAP 
Public Sector Tax and Revenue Management -> Collection and Disbursement (PSCD) 
-> Enhanced Inbound Correspondence -> Generate Forms. 



PSCD_TRM_RETURN_PROCESSING: Processing Tax Returns (New) 
Use 

As of SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03, 
Business Function  TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can process tax returns. For the manual processing of submitted tax returns, a 
business package was created that models a working environment with a worklist for a 
tax officer, for example. There is also now an application based on the Web Dynpro for 
ABAP for the processing of individual tax returns. 

The interactive forms were implemented using the internal service request in Tax and 
Revenue Management (TRM). For information on the functions of internal service 
requests, see the SAP Library under internal service request . Note that in Tax and 
Revenue Management (TRM) only scenarios that can be entered using Adobe PDF 
forms can be mapped. 

With the application for processing tax returns, you can check tax returns or change 
form field values and header data of a tax return. The data for processing as an 
interactive form is provided for this. With this application you can continue to compare 
forms and form field values that create notes and create or simulate a tax 
assessments. In Customizing for  Contract Accounts Receivable and Payable , you can 
define More Links  and More Options irrespective of the revenue type. 

Effects on Customizing 

You define the Customizing settings for this function in the Customizing of Contract 
Accounts Receivable and Payable in section Tax Returns and Requests in the 
following IMG activities: 

o HyperLink: SIMG.ISPSCA_FMCA_TRM_SCENARIO Define Forms 

o HyperLink: SIMG.ISPSCA_SFP Edit Form Layout 
o HyperLink: SIMG.ISPSCA_VC_FMCA_TRM_FORMTYPES Define Form 

Types 

o HyperLink: SIMG.ISPSCA_VC_FMCA_TRM_RCODES Maintain 
Processing Reasons 

o HyperLink: SIMG.ISPSCA_FMCA_TRM_REL_LINKS Useful Links for Tax 
Processing 

o Define Other Options for Tax Processing 

o HyperLink: SIMG.ISPSCA_VC_FMCA_TRM_REVTYPES_FB Define Form-
Based Revenue Types 

o Define Status Schema for User Status for Tax Returns 

o HyperLink: SIMG.ISPSCA_V_TFMCA_FPROC Define Form-Based 
Processes 

o Activate Change Documents for Form Views 

See also 

For more information, see the SAP Library under ERP Central Component -> SAP 
Public Sector Tax and Revenue Management -> Processing Tax Returns. 



PSCD_TRM_RETURN_PROCESSING: Revenue Types (New) 
Use 

As of SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03, 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can use the revenue types for new functions. 
 Generally, the use of revenue types enables the system to map different types of 
revenue types (tax and fees) such as income tax, vehicle tax, or nursery school fees. 
The revenue types support the process of revenue collection in different ways. 
You can use forms, that you assign to the revenue type, to help you define which 
information you expect from a taxpayer for a particular revenue type. You can find more 
information on forms here. 
You need the revenue types when determining the relevant BRF event for the 
automatic validation of tax returns and the calculation of tax amounts using Business 
Rule Framework(BRF). You can find more information about the Business Rule 
Framework here. Irrespective of this, you can use revenue types as input parameters 
for programs that calculate tax. 
You can also use revenue types with enhanced inbound correspondence. In this case 
you can assign your own revenue type to each inbound correspondence category. This 
way you can define that you expect a different inbound correspondence for trade tax 
than for income tax for example. You can find more information on enhanced inbound 
correspondence here. 
If you map information on a contract object that is relevant for tax using Facts  in the 
system, you can assign your own revenue type to each part of the fact set.  You can 
find more information on facts here. 
When defining revenue types in the Customizing of  Contract Accounts Receivable and 
Payable you can define specifications for the update of revenues. 

Effects on Customizing 

You define the Customizing settings for this function in the Customizing of Contract 
Accounts Rceivable and Payable in the following IMG activities: 

Define Form Types 

Maintain Processing Reasons 

Define Form-based Revenue Types 

Define Revenue Type 

Assign BRF Events to Revenue Type 



PSCD_TRM_RETURN_PROCESSING: Uploading Forms (New) 
Use 

As of  SAP ECC 6.0, Industry Extension Public Sector,  Enhancement Package 03 , 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING), 
you can update the data of the scanned tax forms or tax returns to the SAP system for 
further processing. 
 For uploading you can use migration object PS_RETURN for the migration workbench 
(transaction EMIGALL). This workbench enables you to upload, split, and process files 
using parallel jobs. 

See also 

For more information on this procedure, see the test catalog for the Business Function 
in test case Data Entry - Migration Workbench. 



PSCD_TRM_RETURN_PROCESSING: Portal Content (New) 
Use 

As of  SAP ECC 6.0, Industry Extension Public Sector, Enhancement Package 03, 
Business Function TRM: Return Processing (PSCD_TRM_RETURN_PROCESSING)  
SAP delivers a Business Package for tax officers. It provides functions for the manual 
processing of submitted tax returns that you can call from the Portal. 

See also 

For more information, see the SAP Library under SAP ERP Central Component -> SAP 
Public Sector Tax and Revenue Management -> Business Package for Tax Officers 
1.3. 

 



Business Function PSM, Sales Order Services 

PSM_ESOA_SDINT: PSM, Sales Order Services (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials , Enhancement Package 3 
(EA-PS 603), the business function PSM, Sales Order Services is available. With this 
business function, you can use Public Sector account assignments within the 
enterprise services to create, change and query sales orders. 

 

Effects on System Administration 

The activation of the Business Function PSM, Sales Order Services is necessary if 
you use the enterprise services for the sales order and you have activated PSM with 
additional dimensions ( such as fund, funds center, etc.). 

To use the enterprise services in Sales and Distribution (SD), you also have to activate 
the Business Function LOG_ESOA_OPS_2, which is a prerequisite of the Business 
Function PSM, Sales Order Services. 

 

See also 

For more information, see SAP Library under Business Function Sets and Business 
Functions -> Enterprise Extensions -> Public Sector Management -> PSM , Sales 
Order Services. 



Business Function PSM, Expenditure Certification 

PSM_EXP_CERT: Expenditure Certification 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the Expenditure Certification (PSM-EC) solution is available. 

PSM-EC has been developed to enable accurate tracking of incurred expenditures 
made out of public funding obtained by a government agency or local public sector 
organization. The data on these expenditures is subsequently collected, in order to 
create a report to external sponsors, such as the European Union (EU). 

Certification involves justifying an incurred expenditure by means of a statement 
confirming that this expenditure complies with the terms and conditions of the financial 
assistance given by a sponsor. The budget the sponsor provides is linked to financing 
sources. These are linked to the expenditure documents by means of operations. 
Operations represent the sponsored project in PSM-EC. 

 

Effects on Customizing 

Most customizing for PSM-EC is carried out in the Implementation Guide (IMG). To 
access this, go to the IMG and choose Public Sector Management -> Expenditure 
Certification. Then maintain the activities there, in sequence. All activities are required, 
except where flagged as Optional below. 

o In the Maintain Accounting Objects activity, specify whether you want to work 
with either the accounting object Work Breakdown Structure (WBS) or with the 
Public Sector funded program. This information is used subsequently for the 
posting of expenditure documents. 

o In the Derivation Strategy for Expenditure Certification Operations activity, 
create and edit the strategy for deriving operations in PSM-EC. This creates the 
link between documents and operations. 

o In the Define Certification Procedure activity, you define the procedure to be 
used for certifying the expenses of your public organization. 

o In the Define Document Group activity, you define document groups and assign 
them to specific document types for purposes of expenditure certification 
(Optional) 

o In the Define Time Slices and Patterns activity, you can the define the time 
slices and patterns to be used. 

o Next, define the financing source types you want to use. Note that, for each 
financing source type, you must maintain detailed information in a separate 
screen. This information includes the certification procedure and the individual 
phases to be maintained. 

o In the Define Levels activity, you define the certification levels to be used in the 
modeling of a hierarchy of political initiatives and actions. 
This activity is optional if you did not select levels as an attribute for your 
financing source types. 

o In the Define Funding Category activity, you define the funding categories to be 
used for a financing source. 

o In the Define Performance Indicators activity, you define performance 
indicators for use in a financing source. 



o In the Define Intervention activity, you define the national or regional 
interventions as well as the external interventions coming from international 
organizations to be used in Expenditure Certification. 
This activity is optional if you did not select interventions as an attribute for your 
financing source types. 

o In the Change Message Control activity, you can set system messages to 
appear as you require them in PSM-EC (Optional). 

o In the Define Regional Code activity, you define the regional codes and 
descriptions to be used in the certifying operation. 

o In the Define Tax Handling activity, you make the settings for sales tax, or 
withholding tax, to be used for the certification of your expenditure documents 

o Portal Roles 

- Two roles are available - Certification Manager and Certification 
Accountant - which complete the range of functions. You must implement 
the roles to be able to use all the functions. 
For detailed information on the roles, see the related Business Package 
documentation 

- Business Add-Ins (BAdIs) (Optional) 
BAdI: Checks for Expenditure Certification Objects 
BAdI: Document Selection for Expenditure Certification 

 



Business Function PSM-FM, Funds Management 

PSM_FM_CI_1: PSM-FM, Funds Management (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials , Enhancement Package 3 
(EA-PS 603), the business function PSM-FM, Funds Management  is available. With 
this business function, you have an improved use of funds management within an ERP 
environment that uses other components like MM, CO, and project system. 

For more information, see the following release notes: 

o Creation or update of FM master data 

o Enhanced features of FM deriviation tool FMDERIVE 

o Rule-based account assignment distribution 

o Plan data transfer to Budget Control System 

o Integration of material reservations with FM 

o HyperLink: RELN.PSM_603_FM_CI_1_BUDG Budgeting 

o Business Process in Activity/Based Costing as Statistical Cost 
Object 

See also 

For more information, see SAP Library under Business Function Sets and Business 
Functions -> Enterprise Extensions -> Public Sector Management -> PSM -FM, 
Funds Management. 



PSM_FM_CI_1: Creation or Update of FM Master Data (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials, Enhancement Package 3 (EA-PS 
603), Business Function PSM_FM_CI_1 you can use the new report 
RFFMMD_AUTOCREATION (Automatic creation of FM master data). With this 
program you can create and/or update commitment items, funds centers, and funded 
programs from master data objects coming from other applications (FI, CO, Project 
System). 

Effects on Existing Data 

The area menu has been enhanced by the following new entries: 

o Funds Management  -> Master Data -> Account Assignment Elements ->  
Generate Account Assignment Elements 

The following source fields can be the source for the following target fields: 

o G/L accounts or cost elements can be the source for commitment items. 

o Cost centers, internal orders or WBS elements can be the source for funds 
centers. 

o Internal orders or WBS elements can be the source for funded programs. 

Effects on Data Transfer 

The source master data is passed through a derivation strategy to get the attributes of 
the new FM master data element. The standard FM derivation is used to obtain the 
name of the new FM master data from the source FI or CO master data element. 

Effects on Customizing 

The following new IMG activities have been created: 

All BAdIs under Funds Management Government  -> Master Data ->  Allocations to 
Account Assignments from Other Components -> Business Add-Ins (BAdIs) -> 
BAdIs for Automatic Generation of Master Data. 

See also 

For more information, see the main release note for business functionPSM-FM, 
Funds Management (PSM_FM_CI_1). 



PSM_FM_CI_1: Enhancements of FMDERIVE (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials, Enhancement Package 3 
(EA-PS 603), Business Function PSM_FM_CI_1, you can derive FM master data by 
means of new features of the FM derivation tool FMDERIVE: 

o You can now define derivation strategies for which groups (sets) of cost centers, 
cost elements, internal orders, and WBS elements are possible as source 
parameters. 

o With report Update FM Derivation Rules in Accordance with Group Change 
(RFFM_ENH_DERIVATION_TOOL) you can reconstruct the rules for the 
derivation strategies in which groups occur as source parameters with your 
values if the values of the groups have changed. 

o Several users can now work on the same rule of the same derivation strategy at 
the same time. Prerequisite for this is that the maintenance of the data of the 
derivation rule differ in at least one of the values of the source account 
assignment. 

Effects on Existing Data 

The report RFFM_ENH_DERIVATION_TOOL is available in the area menu under 
Funds Management -> Master Data -> Tools -> Adjust Derivation Rules in 
Accordance with Changes to CO Object Groups  

Effects on Customizing 

The following new IMG activity has been created:Define Account Assignment 
Derivation 

See also 

For more information, see the main release note for business functionPSM-FM, 
Funds Management (PSM_FM_CI_1). 



PSM_FM_CI_1: Rule-based account assignment distribution (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials, Enhancement Package 3 
(EA-PS 603), Business Function PSM_FM_CI_1, you can use a rule-based account 
assignment distribution during the transfer of  time sheet data to Project System and 
Controlling. 

With the existing rule-based account assignment tool you can now generate a rule-
based distribution of account assignments with the transfer of time recording to Project 
System and Controlling. 

You define rules which stipulate the distribution of the account assignment (COBL 
object) entered on the receiver object originally in time recording for the transfer.  As a 
result you can generate several lines with different account assignments. 

Effects on Existing Data 

You can find the Rule-Based Account Assignment Distribution in the area menu under 
Public Sector Management ->Funds Management->Master Data->Use of Account 
Assignment Elements->Maintain Rules for Rule-Based Acct Assmnt Distribution. 

Effects on Customizing 

The following new IMG activity has been created:Derivation Strategy for CATS 
Controlling Area 

See also 

For more information, see the main release note for business functionPSM-FM, 
Funds Management (PSM_FM_CI_1). 



PSM_FM_CI_1: Enhancement of report RFFMCY_CO_COPI (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials, Enhancement Package 3 
(EA-PS 603), Business Function PSM_FM_CI_1, you can transfer CO Plan data 
posted with real estate objects into the Budget Control System (BCS) using the already 
existing report for CO Plan Data Transfer to BCS (RFFMCY_CO_COPY). The report 
has been enhanced to include real estate objects and the FM derivation tool 
FMDERIVE is used to replace the real estate account assignments with the respective 
FM account assignments. 

Effects on Existing Data 

You can find the existing program under the following area menu: 

Public Sector Management  -> Funds Management  -> Budgeting -> Tools  -> 
Planning -> Plan Data Transfer from CO (Transaction FMCYCOPI_CO). 

See also 

For more information, see the main release note for business functionPSM-FM, 
Funds Management (PSM_FM_CI_1). 



PSM_FM_CI_1: Integration of Material Reservations with FM (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials, Enhancement Package 3 
(EA-PS 603), Business Function PSM_FM_CI_1,  the function of material reservations 
integration with Funds Management (FM) is available. With this function, it is possible 
to consume budget and perform budget checks for a material reservation document. 

The value of the budget is calculated by taking into consideration the material sprice 
(standard or moving price) from the material master and the quantity. The system 
generates an earmarked funds document in the background and takes the item 
account assignment of the material reservation document as the account assignment in 
the earmarked funds document. 

When a goods issue references this material reservation, the earmarked funds 
document is copied into the goods issue and the account assignment is taken from that 
document. 

Effects on Existing Data 

If you want to generate a funds reservation document for an existing material 
reservation document, you can use the program Generate Earmarked Funds for 
Material Reservations (RFFMRP_MAT_RESERVATION). Funds reservation 
documents are generated only for material reservation documents that do not have a 
goods issue document posted against them. This program is also used to generate the 
earmarked funds documents for material reservations that are generated from Material 
Requirements Planning (MRP) since as these are not integrated directly with FM. 

Effects on Data Transfer 

This function applies only to newly created material reservations and has no impact on 
data transfer. 

Effects on Customizing 

You make the necessary Customizing settings in FM in the IMG activityMaintain 
Data for Integration Scenario. To do so, proceed as follows: 

1. Assign the document category funds reservation to the scenario Reservation 
Integration (Without Scenario Variant). 

2. To each company code group that you need, you have to assign the following: 

- a document type for funds reservation: 
We recommend that you first define a new document type and set up a 
separate number range interval, so that these documents can be more 
easily identified from other earmarked funds documents. 

- a blocking reason: 
We strongly recommend that you define a blocking reason in order to 
prevent the manual processing of the generated documents. This 
precludes possible data inconsistencies. 

See also 

For more information, see the main release note for business functionPSM-FM, 
Funds Management (PSM_FM_CI_1). 



PSM_FM_CI_1: Budgeting (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials, Enhancement Package 3 
(EA-PS 603), Business Function PSM_FM_CI_1, there are several changes in the area 
of Budgeting Workbench (BWB), which are summarized in this release note. 

Budget Type Group (New) 

You can use the budget type group to: 

o Assign budget type for budget to process 

o Assign statistical budget type to process 

o Assign budget type for budget and statistical to status 

Budgeting Workbench Layout (Changed) 

o You have a new option Header: same in sender and receiver to define the 
fields in the layout in IMG activityDefine Layout for Budgeting 
Workbench. If you use the two sides process and the field in the header is the 
same in the sender/source and receiver/target, you can use this new option in 
layout customizing. The system then copies the value of the field from 
sender/source to receiver/target automatically. 

o You have a new choice Hide Automatically Generated Lines to make the 
default settings that regulate whether additional lines are displayed when the 
document is loaded into the Budgeting Workbench. You can display or hide the 
automatically generated additional document lines using the button Hide/Display 
Autom. Lines in Budgeting Workbench if they exist in the budget document. 

Allow setting some fields changeable or not in preposted documents by means 

of customizing (New) 

As well as text fields (which are changeable in preposted documents), other fields may 
be changeable in preposted documents. You can define a profile to specify which fields 
are changeable in the preposted documents, then assign this profile to your document 
types in Customizing. The settings are then applied to all the preposted documents 
which use one of these document types. By default, only text fields are changeable. 

Allow setting text fields changeable or not in posted document by means of 

customizing (New) 

Text fields in posted documents can be set changeable or not in Customizing. You can 
define a profile to specify which text fields are changeable in the posted documents, 
then assign this profile to your document types. The settings are then applied to all the 
posted documents which use one of these document types. By default, all text fields 
are changeable. 



Allow some fields changeable in preposted document in BCS Workflow: 

Templates WS12300025 and WS12300026 (Changed) 

o The budgeting workflow templates (WS12300025 and WS12300026) are 
adapted to use changeable fields. 

o The standard task TS12300025 is not used anymore in any of the templates. 
Instead, two new tasks are used in both templates, TS12300079 and 
TS12300080. The step Approve Budgeting Document is used in both 
templates and executes the rule 12300004 to determine the workflow agents and 
uses task TS12300079 (that substitutes task TS12300025) to deliver the 
workflow object to the correct agents. What is new in this release is that the user 
can navigate from the workflow object to the budgeting document and change 
certain fields in it via customizing settings. 

Change log of preposted document (New) 

- You can activate the change log to record changes to the preposted 
documents, either for the document header only or for the whole 
document (document header and document lines). 

- You can display and delete the change logs for preposted documents. 

Effects on Existing Data 

UI Change Activity UI Change Description 

IMG activity Define Layout for Budgeting Workbench  New selection options 

Header the same in sender and receiver for all fields and new checkbox Hide 

Automatically Generated Lines 

Transaction FMBB New button Hide/Display Automatic Lines are 

available in the line item ALV when the document includes automatically generated 

lines, fields in the receiver/target part will display only when you use layout which 

includes the setting Header: the same in sender and receiver, some fields in 

preposted documents can be changed via Customizing, and the text fields in posted 

document can be unchangeable via customizing 

IMG Activity Edit Status  The two dialogue controls Status control settings 

using BT Group(budget) and Status control settings using BT Group(stat.) are 

appended. 

Workflow for preposted document The fields in preposted document workflow can be 

changed in Customizing 

Effects on Customizing 

Carry out the following IMG activities as required: 

Budget Type Group 

o Assign Budget Type Group to Processes (Mass Maintenance) 
o Define Budget Type Group for Statistical Budget 



o Assign Statistical Budget Type Group to Budgeting Processes 

o HyperLink: SIMG._ISPSFFM_N_VC_FMSTAT Edit Status 

Budgeting Workbench Layout 

o Define Layout for Budgeting Workbench. 

Changeable fields for preposted document with/without workflow 

o Define Profile for Changeable Fields in Budget Documents 

o Assign Profile of Changeable Fields to Document Types 

o Activate Change Log for Preposted Budget Documents 

o Display Change Log for Preposted Budget Documents 

o Delete Change Log for Preposted Budget Documents 

See also 

For more information, see the main release note for business functionPSM-FM, 
Funds Management (PSM_FM_CI_1) and SAP Library under <path to the 
application documentation for this function>. 



PSM_FM_CI_1: Business Process in ABC as Statistical Cost Object 
Use 

As of SAP ECC 6.0, Enterprise Extension Financials, Enhancement Package 3 
(EA-PS 603), Business Function PSM_FM_CI_1, you can now also define the business 
process in Activity-Based Costing (ABC) as statistical. 

Effects on Existing Data 

Business process master record can now be flagged statistical . 

In parallel to posting to the true cost object (for example Cost Center, Internal Order, 
Work breakdown structure) the statistical business process can be posted to in actual 
external transactions (in FI, MM, etc.) as well as actual internal primary transactions 
(transfer postings). As a result of such parallel postings, the CO document contains an 
additional line with value type 11 which is posted to the statistical business process, 
while the true cost object is reflected in a document line with value type 01. 

In the past, only internal orders and WBS elements could be classified as statistical. 
With EhP3, a classification of the business process as statistical is possible in a similar 
fashion. Excluded from postings with statistical business process are secondary 
postings in CO. A statistical business process can not be used as a sender in activity 
allocation. 

See also 

For more information, see the main release note for business functionPSM-FM, 
Funds Management (PSM_FM_CI_1). 



Business Function PSM, Grants Management for Grantee 
Enhancements 

PSM_GM_GTE_CI_1, Grantee Management 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the Grantee Management (GM-GTE) solution includes the 
following new features: 

o Budget Splitting Rule Enhancement 
The new function automatically creates budget validity periods for yearly time 
slices. The first time slice starts with the grant valid-from date and ends after 12 
months. The next time slice starts at the grant valid-from date plus one year. 

o Subtractive Cost Sharing Method 
This cost-sharing method relates to how cost sharing is calculated in the 
budgeting workbench and considers how cost sharing relates to the total budget 
(external and internal funds) instead of only external funds. 

o IDC Calculation from and to Grantee's contribution 
IDC expense and recovery posting is based on IDC-relevant postings to the 
grant's postings to external and internal funds (total expenses). This IDC method 
is used in conjunction with the subtractive cost-sharing method. IDC caps are still 
used to determine the maximum reimbursement by the sponsor. 

o Accrual and Deferral Calculation and Posting 
Valuates the grant's billable and revenue postings to determine whether an 
accrued or deferred revenue posting is needed based the grant's financial 
disposition. The calculation can be based on resource-related billing accrual or 
cash-based billing methods. 

o Revaluation and Currency Conversion Enhancement 
New Business Add-In (BAdI) GM_CURRENCY_CONVERSION, provided to 
allow additional flexibility to revalue GM postings based upon the sponsor#s 
currency. 

o Archiving 
Archiving strategies have been introduced for GM master data and budgeting 
documents. See the separaterelease note for details. 

See also 

Accrual Engine in Grantee Management 



Business Function Financial Integration with EA-PS 

PSM_GOVPROC_JFMIP: Financial Integration with EA-PS 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the business function Financial Integration with EA-PS is available. 
With this business function, period of performance, acceptance period, and prompt payment 
data from SAP Procurement for Public Sector (SAP PPS) purchasing documents is 
transferred to the replicated purchasing documents in the SAP ERP system. The data is 
checked in the SAP ERP system to ensure, for example, that it complies with Unites States 
federal government procurement regulations. 

For more information, see the following release notes:  

o Period of Performance in SAP SRM Documents(New) 

o Prompt Payment Enhancements in SAP SRM (New) 

Effects on Existing Data 

You have SAP Supplier Relationship Management 6.0 (SAP SRM 6.0) and SAP Procurement 
for Public Sector 2007 (SAP PPS 2007) installed on your system. 



PSM_GOVPROC_JFMIP: Period of Performance in SAP SRM Documents 
(New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, Business Function Financial Integration with EA-PS, you can enter 
a period of performance (PEROP) on SAP Supplier Relationship Management (SAP SRM) 
procurement documents (shopping carts, purchase orders, contracts, and RFx documents). 
The period of performance defines a start date and end date for goods delivery or service 
performance and is therefore the period during which commitment and spending is valid. 

The period of performance is used in receipt, invoice, and payment documents to validate the 
dates that goods were delivered or services performed against the validity period defined in 
the purchase order. This prevents, for example, the payment of invoices where the period of 
performance does not match that of the spending document. 

Checks are made against the period of performance at various stages of the business 
process, including during processing of goods receipt (GR) and invoice receipt (IR) in the 
SAP ERP backend system. You receive error or warning messages if a goods receipt or an 
invoice receipt is posted outside of the period of performance dates for the purchase order 
line item. 

For more information about other period of performance functions in Enhancement Package 
3, see the release note PSM_USFED_PEROP_1, Period of Performance (New). 

Effects on Existing Data 

You have SAP Supplier Relationship Management 6.0 (SAP SRM 6.0) and SAP Procurement 
for Public Sector 2007 (SAP PPS 2007) installed on your system. 

See also 

For more information, see the release note for business function Financial Integration with 
EA-PS. 



PSM_GOVPROC_JFMIP: Prompt Payment Act Enhancements in SAP 
SRM (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, Business Function Financial Integration with EA-PS, the following 
Prompt Payment Act (PPA) functions are supported: 

o Fast Pay as defined in the U.S. federal government's Prompt Payment Act and 
the Federal Acquisition Regulation 

You can specify for a line item in a SAP Supplier Relationship Management (SRM) contract or 
purchase order that it is subject to Fast Pay procedures. This means that payment is made 
within a limited time period of receipt of an invoice without proof of receipt of goods or 
services. If payments are not made within this time period, they are subject to a PPA interest 
penalty. When you identify a line item as subject to Fast Pay procedures, prompt pay terms 
are set in ERP. When the invoice is paid in ERP, the line items are checked in accordance 
with the Prompt Payment Act. 

o A user-defined acceptance period for SAP SRM contracts and purchase orders 
You can define an acceptance period in days for a contract or purchase order. This 
acceptance period defines the time period that a purchaser has to accept goods, after which 
the acceptance period is used to determine a PPA-constructed acceptance date. This 
acceptance period is also used in the calculation of PPA payment due dates and PPA interest 
calculations. You use this function if you want to specify an acceptance period longer than the 
default seven days as specified in the PPA. If no acceptance period is specified, the default 
value of seven days is used. The acceptance period that you enter is checked in ERP at 
goods receipt. 
 
For more information about other Prompt Payment Act enhancements in Enhancement 
Package 3, see release note Enhancements to Prompt Payment Act (Changed). 

Effects on Existing Data 

You have SAP Supplier Relationship Management 6.0 (SAP SRM 6.0) and SAP Procurement 
for Public Sector 2007 (SAP PPS 2007) installed on your system. 

Effects on Customizing 

You make the Customizing settings for this function in Customizing in the Public Sector 
Management Implementation Guide (IMG) by choosing Functions for US Federal Government 
-> Payment Processing ->Prompt Payment Act 

See also 

For more information, see the main release note for business function Financial Integration 
with EA-PS. 

 



Business Function Pricing Arrangements for EA-PS 
Integration 

PSM_GOVPROC_PA: Pricing Arrangements EA-PS Integration 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the business function Pricing Arrangements EA-PS Integration is 
available. With this business function, you can enable the transfer of pricing arrangement data 
from SAP Procurement for Public Sector (SAP PPS) procurement documents to the replicated 
procurement documents in the SAP ERP system. 

For more information, see release note Pricing Arrangements from SAP PPS (New). 

Effects on Existing Data 

You have SAP Supplier Relationship Management 6.0 (SAP SRM 6.0) and SAP Procurement 
for Public Sector 2007 (SAP PPS 2007) installed on your system. 



PSM_GOVPROC_PA: Pricing Arrangements from SAP PPS (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, Business Function Pricing Arrangements EA-PS Integration, 
pricing arrangement data from SAP Procurement for Public Sector (SAP PPS) procurement 
documents can be transferred to replicated procurement documents in the SAP ERP system. 
In SAP PPS, you can assign pricing arrangements to line items in a procurement document. 
Each pricing component belonging to a line item can be assigned separate accounting 
information. It is also possible to post follow-on documents separately for each pricing 
component. 
 
You can apply the following attributes to a pricing arrangement: 

o A ceiling amount, or hard limit, on the total amount 

o A maximum fee that the supplier can earn 

o A minimum fee that the supplier can make 

o How the supplier's target fee is reduced for exceeding the cost estimate 

o How the supplier's target fee is increased when costs are less than estimated 
 
You can use pricing arrangements in the following SAP PPS purchasing documents: 

o Shopping cart 

o RFx 

o RFx response 

o Contract 

o Purchase order 

Effects on Existing Data 

You have SAP Supplier Relationship Management 6.0 (SAP SRM 6.0) and SAP Procurement 
for Public Sector 2007 (SAP PPS 2007) installed on your system. 

Effects on Customizing 

You make Customizing settings for this function in the Public Sector Management 
Implementation Guide (IMG) by choosing Government Procurement ->BAdI: Change 
Descriptions of Pricing Arrangement Components 
 
Use this Business Add-In (BAdI) to change the descriptions of the pricing arrangement 
components you assign to your procurement documents. You can change the component 
descriptions during invoice verification. 

See also 

For more information see the main release note for business function Pricing Arrangements 
EA-PS Integration. 

 



Business Function PSM, Grantor Integration (AP/AR) 

PSM_GRANTOR_APAR, PSM, Grantor Integration (AP/AR) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, Grantor Management (GM-GTR) is fully integrated with 
Accounts Payable and Accounts Receivable (AP/AR). This means you can: 

o Create/change precommitments and forecast of revenue documents based on a 
CRM application 

o Create/change commitments and forecast of revenue documents base on a 
CRM agreement 

o Use the new multi-funding feature to define various funding sources that, in turn, 
define the percentage distribution and the relevant account assignments 

o A Customer/Vendor Integration scenario  for the Business Partner Replication 
Process, including Customer/Vendor templates, has been provided. 

o Create/change AP/AR open items 

o Use automatic creation of a funded program based on a CRM program 

o Have the system notify CRM when an open item or a cleared item is created in 
AP/AR. 

Effects on Customizing 

Use the following steps in Customizing to configure GM-GTR integration with AP/AR: 

Master Data 

o Maintain Grantor Derivation Strategies 

o Maintain Customer-Specific Condition Fields 

o Maintain Grantor Rule-Based Account Assignment 
Distribution 

o Business Add-Ins for Grantor Management Master Data 

- BAdI: Grantor Management Derivation Enhancement 
- HyperLink: SIMG.BADI_PSM_MEASURE_REPL BAdI: Funded 

Program Wrapper 

Integration with Accounts Receivable and Accounts Payable 

o HyperLink: SIMG.GTR_PREPARE_INT2 Prepare Integration 

o Default Financial Execution Interface 

o HyperLink: SIMG.SIMG_GTR_PROGPROFIL2 Edit Program Profile 

o HyperLink: SIMG.GTR_VC_GTRFIAPAR Define Invoicing Paramters 

o Maintain Number Range Interval for GTR Billing Documents 

o PSM Earmarked Funds 

- HyperLink: SIMG.SIMG_GTR_INTEGRATE1 Integration Scenarios 



- Business Add-Ins for PSM Earmarked Funds Integration 
BAdI: Summarize CRM Data for Creating/Changing Funds 
Reservations 

o Customer/Vendor Integration 

- Customer Integration 
Settings for Customer Integration 
Determine Template for Customer Account for 
Replication 

- Vendor Integration 
Settings for Vendor Integration 
Determine Template for  Vendor  Account for Replication 

o Business Add-Ins for Integration 

- BAdI: Extract and Use Enhanced Data from CRM  
- BAdI: Enhance AP/AR Billing Interface 

See also 

o HyperLink: RELN.PSM_603_GTR_REPORT Reporting in Grantor 
Management 

o HyperLink: RELN.PSM_603_GTR_MENU Menu for Grantor 
Management 



Business Function PSM, U.S. Federal - Reimbursable Orders 

PSM_REIMB_1, Reimbursable Orders 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the following enhancements regarding were made to 
processing for reimbursable orders: 

o The system now provides configuration options to control message types for 
down payments. Two messages were created under message class FICUSTOM 
and put in a table where they can be customized as information, warning, and 
error messages for a specific user or for all the users creating Reimbursable 
Orders. In order to configure the new messages (FICUSTOM 234 and 
FICUSTOM 235), access Customizing and choose >Public Sector 
Management -> Funds Management Government -> Basic Settings -> 
Change Message Control. 
Both messages display the following text:  "For non-federal customers, full down 
payment is required" 

o The system now executes the standard FMDERIVE routine call for commitment 
items to support sales orders with down payments. With this enhancement, you 
can ensure that the commitment item is available for the down payment request 
transaction, resulting in the correct FM postings. 

o The system now provides configurable options to determine the FM 
impact/update for sales orders. This new feature uses status management to 
control the timing of the FM update. The FM posting was not previously an 
option, but it now is. 

 



Business Function PSM, U.S. Federal: Business Partner 
Network 

PSM_USFED_BPN_1, Business Partner Network 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the Business Function for Business Partner Network has 
been created to integrate external US Federal Business Partner information (such as 
CCR) and make it available for Vendor and Customer processing in SAP. 

The DUNS and DUNS+4 fields have also been added to customer master records. 

See also 

Enhancements to Central Contractor Registration 

Central Contractor Registration Archiving 



Business Function PSM, U.S. Federal 

PSM_USFED_CI_1: US Federal, General Enhancements 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the US Federal Government (USFG) solution includes the 
following new or changed features: 

Budgetary Ledger 

o Budgetary Ledger Adjustment Posting on Fund Level 

Budgeting Using the Budget Control System 

o New Fields in Header of Budget Entry Documents 

Cancelled Asset Transfer 

o HyperLink: RELN.PSM_603_FMFG_AA_CANF Cancelled Asset Transfer 

Information System 

o Payment Related 
The FMFS 1219/1220 accountability report is now available. Agencies use this 
report to collect transactions and accountability information about their own 
payments and reports it for the Treasury Financial Management Service (FMS). 
The report shows increases and decreases in an agency's accountability and its 
total accountability for the given period. 
See the reportdocumentation for more details. 

o Other 
USFG now includes a document chain feature. See the separaterelease note 
for details. 



PSM_USFED_CI_1: Budgetary Ledger Adjustment Posting on Fund 
Level (New) 

Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, you can use this feature to summarize adjustments posted in 
one transaction at fund level. For example, if one line in a transaction posts an upward 
adjustment of $10 to Fund A and another line posts a downward adjustment of $7 to 
Fund A a net upward adjustment of $3 is posted. 

The function takes no previously posted values into account; only adjustments in the 
current transaction are used for the calculation of the net adjustment value. 

Effects on Customizing 

The feature needs to be activated. 



PSM_USFED_CI_1: New Fields in Header of Budget Entry Documents 
(New) 

Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the following fields have been added to the header of budget 
entry documents: 

o Trading Partner 

o Transfer Account 

o Transfer Agency 

These fields are offered in all transactions that create budget entry documents using: 

o Budgeting Workbench, Multiple Budget Entry 
Mass transactions such as generation of budgeting data, transfer data, and 
budget release. 

o Entry of individual budget documents 

o From external applications using the BAPI 'Create entry documents' 

Reporting on these new fields using BW or the budget entry document display is fully 
integrated. 

Effects on Customizing 

You can use Field Status Management to control field appearance. Access this in the 
Public Sector Management section of the IMG by using the activities under Budgeting 
-> Budget Entry -> Budget Entry Documents -> Field Status. 



PSM_USFED_CI_1: Additional Line Items Created for Asset Transfer 
Transactions (New) 

Use 

In US Federal accounting, when a Fund cancels, its assets must be transferred to the 
new Fund. 

In addition to the standard Asset Management (FI-AA) Intercompany Asset Transfer 
posting, there are several additional accounts to which the transaction should be 
posted. 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, this configuration creates the US Federal required additional 
line items. 

In particular, this function is used to transfer the assets from a cancelled fund to a new 
fund. 

Effects on Existing Data 

Standard FI-AA should be configured before you complete this additional configuration. 

Note that in transaction AO90 (Configuration of Balance Sheet Accounts for FI-AA), the 
field "Contra Account: Acquisition Value" (field KTANSG) is overwritten by this US 
Federal FI-AA additional account derivation. 

The standard GL entries created when doing an intercompany asset transfer posting 
(when using standard FI-AA and US Federal is inactive) are illustrated below. The 
example assumes that that asset was originally purchased for $1,000 and depreciated 
by $200. 

FUND 1 

Debit Acct  1010 Fund Balance Treasury   $800 (configured in FI-AA as 
"Contra account: Acquisition value" -which is the contra account for asset transfers 
inward; FM-relevant) 

Debit Acct  1759.00 Accumulated Depreciation   $200 (configured in FI-AA 
as "Acc.dep. accnt.for ordinary depreciation" ; not FM-relevant) 

Credit Acct 1750.00 Equipment Account    $1000 (configured in FI-AA 
as "Acquisition and production costs"; FM-relevant] 

FUND 2 

Debit Acct 1750.00 Equipment Account    $1000 (configured in FI-AA 
as"Acquisition and production costs"; FM-relevant) 

Credit Acct  1759.00 Accumulated Depreciation   $200  (configured in FI-AA 
as "Acc.dep. accnt.for ordinary depreciation"; not FM-relevant) 

Credit Acct  1010 Fund Balance Treasury   $800 (configured in FI-AA as 
"Contra account: Acquisition value" -which is the contra account for asset transfers 
inward; FM-relevant) 

Effects on Customizing 

If you configure the additional US Federal Asset Accounts, additional line items are 
created to match the USSGL mandated transactions. 

The additional accounts are configured in the stepAdditional Account 
Determination. The configuration is based on the following: 

o Chart of Accounts     KTOPL 

o Asset Account Determination   KTOGR 



o Asset Depreciation Area    AFABE 

Then after this key,  the configurable accounts are: 

01 Asset Tfr Out Contra Account    

02 Asset Tfr In Contra Account 

03 Depreciation Tfr In Contra Account 

04 Depreciation Tfr Out Contra Account 

Note 

The memorandum accounts (8801 and 8802) should be derived using the Budgetary 
Ledger (BL) derivation tool (configure a new BL area and base the derivation on the 
CO Business Transaction ) 

See also 

USSGL (US Federal Government Standard General Ledger). 

The specific US Federal accounting entries associated with this transaction are: 

Transfer the asset out of the cancelling fund 

USSGL transaction E510 Transfer Out      

DR   1759.00 Accumulated Depreciation 

 CR  1750.00 Equipment 

DR   5730.01 Transfer Out (FM relevant) 

 CR 5730.02 Transfer Out (Not FM Relevant) 

USSGL transaction  G120 Memo Account Entries 

DR  8801 Offset for Purchases of Capitalized Assets 

 CR 8802 Purchases of Capitalized Assets 

 

Transfer the asset into the new fund 

USSGL transaction  E606 Transfer In    

DR   1750 Equipment 

 CR  1759 Accumulated Depreciation 

DR  5720.01 Transfer In (FM relevant) 

 CR 5720.02 Transfer In (Not FM Relevant) 

USSGL transaction  G120 Memorandum Account Entries 

DR  8802 Purchases of Capitalized Assets 

 CR 8801 Offset for Purchases of Capitalized Assets 

 

Sample configuration in this case would be: 

01  Asset Tfr Out Contra Account GL Account  5730.0100 

02  Asset Tfr In Contra Account GL Account  5720.0100 

03  Depreciation Tfr In Contra Account GL Account  5720.0200 

04  Depreciation Tfr Out Contra Account GL Account  5730.0200 



PSM_USFED_CI_1: Document Chain Feature in Transaction Register 
(New) 

Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3 , the transaction register includes a document chain 
feature. 

The concept of the document chain is to select a document in the transaction register 
and to display all the predecessor documents and successor documents related to the 
selected document.  Due to the wide range of business processes and possible types 
of documents, the document chain display provides a best-effort to construct and 
display the documents in a processing chain using various information sources. 

The document chain has a default overview display that lists the documents/items 
involved in the processing chain, as well as ledger views that display the ledger entries 
from General Ledger, Special Ledgers or Funds Management related to each 
document/item in the chain. 

The following functions are available during document chain display: 

o Display document 

o Own document chain (construct/display the document chain of one of the 
predecessor/successor items in the current document chain) 

o Overview/ledger views: switch between views 

o Show accounting documents 

The document chain is designed to provide a basic level of support for any documents 
that post to General Ledger (G/L) Accounting or Funds Management (FM). It has 
extended support for certain document types to enable more document type specific 
data to be displayed for the document (such as status values dependent on the 
document type) as well as finding predecessor and successor documents using 
methods other than those available for all documents through the G/L Accounting and 
FM. 

o For documents that post to FM open items or FM actuals, successor and 
predecessor documents can be identified through predecessor references in the 
FM data tables. 

o For documents that post to accounting, successor and predecessor documents 
can be identified through: 

- Clearing: the cleared and clearing documents have a 
predecessor/successor relationship 

- Reversal: the reversed and reversal documents have a 
predecessor/successor relationship 

- Invoice reference: certain types of invoice reference (BSEG-REBZG) are 
used to determine relationships 

o Document types for which extended support is available include: 

- FM: Earmarked funds documents 

- Purchasing: Purchase orders, purchase requisitions, outline agreements 

- Inventory Management: Goods movements 

- Logistics Invoice Verification: Invoices 

- Sales and Distribution: Orders and billing documents 



Effects on Customizing 

The document chain report supports customer enhancements to fill gaps in the 
construction of the chain. Through enhancement implementations, the customer can 
provide additional methods of finding successor and/or predecessor documents; modify 
the information displayed for a document; and provide additional ledger views if 
required. 

Enhancements can be implemented through the following enhancement spots: 

o FM_DC_DOCITEM (Enhancements to basic doc info) 

o FM_DC_SOURCE (Methods for finding successor / predecessor documents) 

o FM_DC_LEDGER (Ledger data providers for document chain) 

See also 

The programdocumentation describes the processing in detail. 



Business Function PSM, U.S. Federal: Debt Management 

PSM_USFED_DEBT_1, Debt Management (New) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the US Federal Government solution includes a feature for 
managing the fees that arise as part of Debt Management. 

Payment: Special Features 

Update of Incoming Payments for Invoices with Fee Schedule 

 

Effects on Customizing 

You access customizing for fees in the Public Sector Management IMG by choosing 
Functions for US Federal Government -> Debt Management: 

o HyperLink: SIMG.SIMG_PSMFG_FEESCHED Define Fee Schedule 

o HyperLink: SIMG.SIMG_PSMFG_VT056R Define Reference Interest 
Rates 

o Enter Interest Values for Reference Interest Rates 

o HyperLink: SIMG.SIMG_PSFMG_V_FM023R Define Interest Rates and 
CVFR 

o Define Alternative Reconciliation Accounts 

o Business Add-Ins 

- HyperLink: SIMG.FMFEES_GET_CONVERSION_DATE BAdI: Get 
Date for Currency Conversion  

- BAdI: Post Partial Invoice Amount as Residual or Partial 
Payment 

- HyperLink: SIMG.FMFEES_CHANGE_AA_BADI BAdI: Change Fee 
Account Assignments 

- HyperLink: SIMG.BADI_FMFG_CHANGE_AGING BAdI: Change 
Aging Parameters 

- HyperLink: SIMG.FMFG_ITEM_SELECT_CHG BAdI: Change 
Selected Line Items 

 



Business Function PSM, , U.S. Federal: Period of Performance 

PSM_USFED_PEROP_1, Period of Performance (New) 
Use 

Background 

Federal Acquisition Regulation (FAR) and Defense Federal Acquisition Regulation 
Supplement (DFARS) mandate the specific handling of 'Period of Performance' 
(PEROP) within various obligation documents as well as related spending documents. 

The PEROP represents a date range as contractually agreed with the business partner. 
This date range defines the validity date of the agreement with the business partner 
and checks against it can be made at various stages of the business process. 

New Features 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management (EA-PS 603), 
Enhancement Package 3, the following changes have been made: 

o The following documents now allow the entry of 'Period of Performance' in the 
form of a date range: 

- Earmarked funds line item 

- MM contract (when using commitment plan) 

- Purchase requisition (PR) line item 

- Purchase order (PO) line item 

- Service-related PR and PO (service line) 

- Logistics Invoice Verification (LIV) line item (MIRO and MIR7) 

- FI General Ledger line items (Enjoy transactions and Parked Documents) 

- SD contract (header and item) 

- Sales order (header and item) 

- Billing plan (item) 

- Debit memo request (header and item) 

o Validation of the above documents against immediate predecessor documents is 
provided in the following implementations and customers can do additional 
customer specific checks in customer BAdIs: 

- Earmarked Funds: Exits from Program LFMR_AD1F01 are used to 
perform the checks and a configurable message (FICUSTOM 120) is 
issued. You can perform additional checks from exits 
EXIT_SAPLFMFR_004 (when posting a parked document) and 
EXIT_SAPLFMFR_008. 

- Contract: Implementation FMFG_CHECK_CONTRACT is used to perform 
the checks and a configurable message(FICUSTOM 120) is issued. You 
can perform additional checks by implementing the BAdI 
FMFG_PEROP_CHECKS_OA_CUST. 

- PR: Implementation FMFG_PROCESS_PR is used to perform the checks 
and a configurable message (FICUSTOM 120) is issued. You can perform 
additional checks by implementing the BAdI  



ME_PROCESS_REQ_CUST. 

- PO: Implementation FMFG_PROCESS_PO is used to perform the checks 
and a configurable message (FICUSTOM 120) is issued. You can perform 
additional checks by implementing the BAdI  ME_PROCESS_PO_CUST. 

- Goods receipt (GR) documents: The GR documents are checked using 
the implementation FMFG_PEROP_CHECKS. You can perform additional 
checks by implementing the BAdI MB_CHECK_LINE_BADI. 

- Service Entry Sheets : The BAdI BADI_MMSRV_PEROP is used to 
perform the checks and the customers can use the same BAdI to perform 
additional checks. Configurable messages (FICUSTOM 136, 137, 138, 
139, and 140) are issued. 

- LIV invoices: The implementation FM_NEW_LIV_FIELDS_VALIDATION is 
used to perform the checks and a configurable message (FICUSTOM 120) 
is issued. Customers can perform additional checks by implementing the 
BAdI FMFG_PEROP_CHECKS_MIRO_CUST. 

- FI Documents : The FI Documents are checked using the function module 
FMFG_PEROP_CHECKS. You can perform additional checks by 
implementing the BAdI FMFG_PEROP_CHECKS_FI_CUST. 

- For Sales and Distribution (SD) documents: 
You can choose to enter values for Period of Performance Start and End 
dates on the Sales tab of the header. The values are replicated (as default 
values) to items and to generated header billing plan items. You can 
subsequently overwrite the values. 
You can enter values for Period of Performance Start and End dates on 
the Sales A tab of the items. Item values within sales documents are 
validated against values of the predecessor document. For this, you must 
customize messages 132 and 133 of message class FICUSTOM. 
Billing plan item values are validated against associated item values of the 
current sales document when values are changed or when the document 
is saved.  For this, you must customize messages 130, 131 and 135 of 
message class FICUSTOM. Note that defaulted values are not replicated 
to billing plan items created manually or generated during copying of a 
predecessor document. For manually-created billing plan items, validation 
does not take place unless you enter a value or you save the document.  
For items generated during copying, the replication of default values does 
not take place until you navigate to the Billing plan tab. Also note that 
Period of Performance values input within the Date Proposal Maintenance 
for Billing Plan Type: Details screen of the Implementation Guide are not 
validated.  For this reason, SAP does not recommend proposing Period of 
Performance values. 
The delivery date of an outbound delivery is validated against the Period 
of Performance values of the items of the predecessor sales document. 
The implementation uses customizable message FICUSTOM 134. The 
logic is contained within implementation 
FMFG_LE_SHP_DELIVER_PROC_PEROP of Business Add-In definition 
LE_SHP_DELIVERY_PROC. You can choose to create your own 
implementation. 

- For Resource-Related Billing (RRB): 
The date retrieval option is used by the Dynamic Item Processor (DIP) to 
determine Period of Performance Start and End dates. The dates are 
derived from the earliest and latest posting date values of associated 
Controlling items or copied from the sales order document item or 
milestone. The resulting data is stored and displayed in the debit memo 
request. The enhancement of RRB to enable the Period of Performance 



feature is, however, subject to restrictions or limitations: 
RRB is always in the full amount (as proposed in the Billing Request for 
Billing Plan <new>: Expenses screen) in order to ensure the complete 
billing of expenses in the appropriate period. 
For the same reason, even though you may choose to enter a Posting 
date to value on the initial screen of the RRB Request selection screen, 
the value is ignored. 
New billing milestones must be dated later than milestones already billed. 
No changes in DIP profile customizing that lead to additional selection of 
older records are allowed. 
In the Set Period pop-up screen of the RRB Request selection screen, 
values for fields From Period and From Fiscal Year can be entered but are 
checked to determine whether they fall before the period for which the last 
valid debit memo request was created. 
If items in the debit memo request are rejected, the whole request is 
rejected. 
The enhancement of the RRB logic to enable the Period of Performance 
feature only targets data source Actual costs - Line items maintained in 
DIP profile customizing. 
Introduction of new Item Blocking Reason in LIV invoice as a result of 
unsuccessful PEROP match between invoice and predecessor 
documents. Blocking reason included in 'Release blocked Invoice' 
transaction (MRBR). 

- For Logistic Invoice Verification (LIV): 
Message Type INVOIC_PS has been created 
Idoc Type INVOIC02_PS has been created. This idoc type is identical to 
INVOIC02 with the exception of an additional segment. Segment 
E1BPPAREX was added to this idoc type to accommodate the period of 
performance information plus additional US Federal indicators. 
These are the instructions for using this new Idoc type: 

a) Fill all segments as you would with idoc type INVOIC02 

b) For segment E1BPPAREX,  enter FMFG_NEW_MM_FIELDS in the 
structure field of the segment 

c) Value Part 1 of the segment corresponds to the fields existing in the 
structure defined above. This means that the first two characters are the 
Fast Pay and PPA Exclude indicators. The next are the Period of 
Performance Begin and End dates. Dates should be entered as 
YYYYMMDD. 

d) It is possible to use all fields of structure FMFG_NEW_MM_FIELDS in the 
idoc 

e) Value Part 2 is unused 

f) Value Part 3 describes either the header or the item. For the header, leave 
it blank; for the item, assign the number of the item with 5 digits starting 
with 00001. 

Effects on Customizing 

For SD and RRB, you must perform the following customizing activities: 

1. Activate Period of Performance 

2. Retrieval Options - Period of Performance for SD 

3. Change Message Control 
4. You can also perform the following using fields PEROP_BEG and PEROP_END 

of table VBKD: 



a) Define Incompleteness Procedures 

b) Assign Incompleteness Procedures 

 



Business Function PSM, U.S. Federal - PPA and Payments 

PSM_USFED_PPAP_1: Postings to FI with up to 9999 items (new) 
Use 

As of SAP ECC 6.0, Enterprise Extension Public Sector Management, Enhancement 
Package 3 (EA-PS 603), Business Function PSM, US Federal - PPA and Payments 
(PSM_USFED_PPAP_1) the system can generate postings to FI with up to 9999 line 
items. Through a split after 990 line items each time, several FI documents occur for a 
goods receipt or invoice document. The system generates a clearing item with this in 
the last line of the FI document that is written off on a clearing account. 

Note: 
To be able to use this function, you must activate the Enterprise Extension Public 
Services (EA-PS) and the functions for US Federal Government in the implementation 
guide (IMG). 

The system splits FI documents that were generated when entering valuated goods 
receipts (transaction MIGO with transaction type goods receipt for purchase order or 
goods receipt other) and when entering and changing invoices (transaction MIRO or 
MIR7 or MIR6). Even when you enter, change or reverse goods receipts and invoices 
using BAPIs, the system can generate postings to FI with up to 9999 items. 

In addition to this, the system generates postings to FI with up to 9999 line items in the 
following situations: 

o For invoices that arrive via EDI or are entered with the evaluated receipt 
settlement (transaction MRRL). 

o For invoices that you park or that the system posts in the background 
(transaction MRBP) 

o For automatic settlement of the planned delivery costs (transaction MRDC) 

o For the invoicing plan settlement and with the revaluation with the Logistics 
Invoice Verification (transactions MRIS and MRNB) 

For all FI document types for which you want to use this function, the internal number 
assignment must be active. An automatic posting must also take place for the clearing 
account to which the clearing lines of the split FI documents are posted. 

Effects on Existing Data 

This new function does not affect existing data. There are no UI changes. 

 

Effects on Customizing 

To be able to use this function in the Enterprise Extension Public Services, you set the 
corresponding indicator in the Customizing of Public Sector Management, to activate 
the functions for US Federal Government. To do this, choose Functions for US 
Federal Government --> General Settings --> Activate Functions for US Federal 
Government). 

See also 

Restrictions 

If you terminate consignment documents, the system generates only one FI document 
with up to 999 items. 

The split of FI follow-on documents is only possible if the tax rate in the tax code 
amounts to 0%. 



The split of FI follow-on documents is only possible if the setting that tax is calculated 
per line (transaktion OBCO) is not active. 

Note 

If you make postings to FI with a high amount of data, it can impede performance. 
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