Error: Connection to the Universe service failed

Creating a Universe Connection fails with "Connection to the Universe service failed. Please ensure SAP Analytics Cloud Agent is configured correctly."

Reproducing the Issue
  1. Log in to the SAP Analytics Cloud tenant.
  2. From the main menu, choose Connection.
  3. Choose the + in the top-right corner and select Start of the navigation pathImport Data Connection Next navigation step SAP UniverseEnd of the navigation path.
  4. Enter details for the connection and choose Create.
  5. The error is displayed.
Cause

The error is displayed because the SAPCP cloud connector is not configured correctly.

Resolution
  1. Open the Access Control page of your SAPCP cloud connector deployment.
  2. Select the System Mapping for your SAP Analytics Cloud agent.
  3. Update the Access Policy Access control to "Path and all sub-paths".