Error: [Enabling SAML Single Sign-On] We were not able to verify your account. Check your login credential and try again.
Account verification fails with "We were not able to verify your account. Check your login credential and try again”.
Reproducing the Issue
- Log in to SAP Analytics Cloud.
- Go to .
- Follow steps 1-11 in the following procedure: Enabling a Custom SAML Identity Provider.
- The following error is displayed when you select Check Verification: “We were not able to verify your account. Check your login credential and try again” .
- If you select Verify Account again, another error is displayed: “We have encountered an error during the account verification setup. Please check that your login credential is not used by another user and try again.”.
- If you retry Enabling a Custom SAML Identity Provider from scratch, Verify Account still fails with “We have encountered an error during the account verification setup. Please check that your login credential is not used by another user and try again.”.

Cause
You did not use a private session to verify your account.
Resolution
- Log out of SAP Analytics Cloud and clear the browser cache.
- Follow steps 1-9 in the following procedure: Enabling a Custom SAML Identity Provider.
- At step 10, use a private session to log onto the URL provided in the Verify Your Account dialog; for example, Incognito mode in Chrome. This ensures that when you log on to SAP Analytics Cloud, you are prompted to log in and do not reuse an existing browser session.