
Steps:

General introduction

Connecting to User Interface API (UI API)

Implementing functionality required to ensure seamless integration (events, menus etc)

Modifying existing forms (how and when)

Developing and connecting own forms

…how to connect own forms to data from the database











The UI API exposes user interface elements of the SAP Business One front-end:

Respond to internal events in the SAP Business One client application

Add or modify menus

Add new forms

Modify existing forms

Get or set values on a form

By using the event mechanism a 3rd party application can react to user interactions with the SAP
Business One application.





Multiple add-ons (from several vendors) may be used alongside the SAP Business One application to
provide a complete solution

3rd party applications can modify SAP Business One GUI through UI API

3rd party applications can get events from SAP Business One through UI API to react to user interaction



Always test an add-on thoroughly before deploying in a productive environment

Due to bug fixes in the SDK, incorrect code might “work” on an older version, but it might encounter
exceptions after an upgrade



The User Interface API (UI API) is a collection of COM objects that provide access to:

forms

controls within these forms

menus

Note:
The “Main Menu” and the status bar are forms as well



The Application object (reflecting the IApplication interface on the UI API DCOM server side) provides
access to forms, controls within forms, menus and the main window (desktop)

“Forms” and “Menus” are collections accessible via the Application object.

„Menus“ holds a snapshot of the menu items currently available – both visible and not visible)

„Forms“ holds the collection of the currently available forms – both visible and not visible.

It is not possible to explicitly display a new instance of a specific type of system form, e.g. Sales
Quotation.  New system forms can be instantiated indirectly, for example by activating the
corresponding menu item

„Form“ object is a representation of a form, both system and user-defined

„Item“ object represents a window control - contents, position, size, visibility and other attributes can
be modified

„DataSources“ collection - objects which hold data for form items, designed to provide efficient data
handling separately from UI presentation

Desktop object/property - use it to change e.g. the background image









When SAP Business One is launched, it starts the UI API and connects with it before any add-ons are
started

If add-ons are registered to start within a user session:

1. SAP Business One links to the UI API and establishes an event-sink for them

2. SAP Business One starts 3rd party application A and passes a command line parameter to it

2.a 3rd party application A creates an Application object that has a counterpart in the UI API

2.b 3rd party application A provides an event sink for events to be fired from the Application object
on the UI API side

2.c The UI API application object registers itself in the IAppLink object for bidirectional
communication

3. The same set of steps is repeated for 3rd party application B



UI API add-ons are launched by SAP Business One and then have to connect to the UI API within a
timeout limit of approx. 10 seconds.

“SAP Business One checks for registered add-ons”

Add-On Administration settings control which add-ons are started for a user – Refer to the „Add-On
Packaging, Administration & Licensing“ unit



Your application connects to the SAP Business One client through the SboGuiApi object using the
Connect method

If a connection has been established, the GetApplication method of the SboGuiApi object grants access to
an application instance, which must be used to access the application’s containers (for example, menus or
forms) for event manipulation and for property settings

The user interface can be accessed using the objects that exist within User Interface API objects

Using the connection string supplied by the SAP Business One application as a command line parameter
for Connect() makes sure that the add-on gets connected to the correct instance of the SAP Business One
application



In VB.NET, the SBO_Application object has to be declared with the WithEvents modifier for it to
support event handling

The connection to the UI API requires:

Connection String

Development mode - supplied by SAP; preferrably use in MS Visual Studio debug project settings as
“command line parameter” rather than hard-coding it.  See the “How to” section in the SDK
Helpcenter.

Runtime mode - supplied by the SAP Business One application as a command line parameter

An Add-On Identifier String - allows the SAP Business One License Service to recognize your Add-On.
To create the identifier, use the Add-On Identifier Generator  available from the SAP Business One
application (License Administration).

Licensing and AddOnIdentifiers are discussed later in the course





User credentials are not directly available

Documentation and sample code is included in the SDK help: Getting Started -> Single Sign On

Single sign on is a recommended option to connect to both UI API and DI API, because the performance
is better than multiple add-on. unless you have memory issue, you can choose multiple add-on

















Using FormCreationParams is the preferred method, although version 6.5 style still works:

Dim oForm As SAPbouiCOM.Form

oForm = oApp.Forms.Add("myForm" & oApp.Forms.Count)

'Set the form title, by assigning a value to the title-property

oForm.Title = "Hello World“

'Set the visible-property of the form object to TRUE to make the form visible

oForm.Visible = True



Form item types are the same as controls in Visual Basic forms from a user perspective - except the
LinkedButton which is specific to SAP Business One

Technically, the SAP objects are unrelated to VB form controls

Examples of form item types are:

Button

CheckBox

ComboBox

EditText

LinkedButton

Grid

Matrix (most tables in system forms)

OptionBtn ("Radio Button")

PictureBox

StaticText



The Form.PaneLevel property is used with the Item.FromPane and Item.ToPane values to create multiple
panes or “layers” within a form, in which different items are visible on different panes

Typically used with Folder tabs to display different items on different tabs

Set FromPane and ToPane properties for each item

If both properties are set to 0, the item will be visible on all panes

Example: If item oEdit1.FromPane = 1 and oEdit1.ToPane = 3, then the item will be visible when
oForm.PaneLevel is 1, 2, or 3



For more information, see the User Interface API online help for the Form object



The code snippets

oEdit = oItem.Specific

oEdit.String = "Hello World"

and

oItem.Specific.String = "Hello World"

are equivalent.

In the latter case, however, IntelliSense will not automatically display EditText members, so it is easier to
use a reference to the specific object (e.g. EditText) to work with.

Note:
Setting the String property of the EditText item will (technically) cause a COM event to be fired to UI
API.  Changing many properties from add-on code results in a lot of calls through the UI API and may
cause performance issues. It is recommended to set the value through DataSource. Refer to DataBinding
with Datasources for details.



This feature is available in ScreenPainter where you can select the PaneLevel to have only the
appropriate items visible.









The Screen Painter is a graphical design tool that enables you to quickly and easily create user forms for
SAP Business One

The Screen Painter is part of SDK and installs and runs as an add-on application

Launch it from Tools > Screen Painter



page 36, we can mention screen painter is replaced by b1 studio (I think from 10.0, we will stop screen
painter maintenance, btw, how shall we announce it? let’s follow up.) => Maybe we can say: B1 Studio
covers all ScreenPainter features with a more user friendly interface, consider using B1 Studio from now
on. @Mostafa: Maybe you can see where it can fit. OK this is adjusted! I put it in the





New forms should not be created using the LoadBatchAction method of the Application object (see next
slide for the preferred method)

Existing forms can be modified using LoadBatchAction with “action” = “update” (see UI API help file
or SDN Developer Area for SAP Business One for more)

Add your changes to the XML and keep the XML e.g. in a resource file

Since LoadBatchAction just takes an XML string you could of course just load the XML as a text file –
or from the DB (as a string); using XML libraries facilitates handling and makes it possible to modify the
XML before loading



















Using data binding, you can easily add data to matrix columns. The SAP Business One Software
Development Kit provides several objects that support data binding to form items.





To create a data-bound form:

Define the form

Define data sources within the form

Link data sources to matrix columns or individual items/controls

Populate data source values – this will display the data in the data bound items



The Form object contains a collection of DataSources which holds all data sources within the form.

A DBDataSource object represents a database data source (i.e. a table in the SAP Business One scope of
tables) attached to a form.

A table can be attached only once to a form using method Add of the DBDataSources collection.

User data sources can also be attached to a form using the Add method of the UserDataSources
collection. For more information, see the documentation for the UserDataSources collection.

A DataTable can be used to read data from any database/table or be used in the same way as a
UserDataSource.

In conjunction with a Grid item, the DataTable enables the display of tabular data with collapse/expand
functionality.



Having added a data source to a form, then specify which form items to link to it.

For a simple item such as an EditText, the item‘s Specific property contains the DataBound object.

Use its SetBound method to bind the item to a data source.

For matrices, data is binded column-by-column.





This code fragment will populate a matrix from table OUSR based on the data binding of individual
matrix columns.

The Query method retrieves all data.  Optionally, a Conditions argument can be specified to implement a
WHERE clause.

The matrix can be populated row-by-row using the AddRow method or populated in one step with
LoadFromDataSource.  When some matrix columns are user data bound, LoadFromDataSource is only
useful if all rows contain the same value for any user data bound column.

To reference a user data source and set its value:

oUserDataSource = oForm.DataSources.UserDataSources.Item("Remarks")

oUserDataSource.Value = "my user data"



To populate your DataTable “manually”:

Dim oDataTable as SAPbouiCOM.DataTable

Dim oCol As SAPbouiCOM.DataColumn

‘ Add the columns to the Grid manually

oDataTable = oForm.DataSources.DataTables.Item("MyDataTable")

oCol = oDataTable .Columns.Add("XX_Col0", SAPbouiCOM.BoFieldsType.ft_AlphaNumeric)

oCol = oDataTable . Columns.Add("XX_Col1", SAPbouiCOM.BoFieldsType.ft_AlphaNumeric)

oCol = oDataTable . Columns.Add("XX_Col2", SAPbouiCOM.BoFieldsType.ft_AlphaNumeric)

‘ Add a first row

oDataTable.Rows.Add()

oCol = oDataTable . Columns.Item("XX_Col0")

oCol.Cells.Item(0).Value = "MyVal0"

oCol = oDataTable .Columns.Item("XX_Col1")

oCol.Cells.Item(0).Value = "MyVal1"

oCol = oDataTable .Columns.Item("XX_Col2")

oCol.Cells.Item(0).Value = "MyVal2”

oGrid.DataTable = oForm.DataSources.DataTables.Item("MyDataTable")















SAP Business One starts add-on applications registered for automatic start-up in the order determined by
the system administrator (see section “Creating a package”)

The add-ons establish connections to the UI API and register event sinks

When an event occurs in SAP Business One UI, it is passed to add-ons which created event sinks for
such events, one at a time



Every add-on action is reflected in the SAP Business One application via the UI API

The same mechanism is used in the other direction, from the SAP Business One application to add-ons



Most UI API code is event driven.  Events are usually fired in response to user actions within the SAP
Business One application.

AppEvent, ProgressBarEvent + StatusBarEvent will always be forwarded to add-ons, i.e. they cannot be
filtered out.

Other types of events can be filtered (ItemEvent) or must be added to the (ItemEvent) event filter (click
on menu).

Note:

It is the developer’s responsibility to make sure that their code will handle each application event
successfully

AppEvent events must be processed by your application. Refer to the Standards & Guidelines
document for more information





BubbleEvent

BubbleEvent specifies whether the event will continue to be processed by SAP Business One

Default value is True

By setting BubbleEvent = False, you are canceling the event. This is similar to setting Cancel = True in a
VB application.

BubbleEvent is only valid when BeforeAction = True





The parameter BubbleEvent is available for the ItemEvent as well as for the MenuEvent



You can view technical information related to forms, items (controls), and corresponding database
tables/fields by selecting View > System Information and mouse over the items(controls) in question.

The information is shown in the lower left corner of the screen:

Form Type (string, but appears as a number for system forms)

Item UID (string, but appears as a number for system items)

Pane - current layer linking items with folders (tabs) – see later in this unit

Database table name

Database field name

Menu item unique id

Note:

Database details are not available for items which display information that is:

Calculated within the user interface

Sourced from more than one database field – for example amounts combine the float value with the
currency code, e.g. „EUR 7.59“. The information in the status bar will contain a „variable“ ID.

The information displayed relates to the position of the mouse pointer, not necessarily the item which
currently has input focus



This example adds a button to a Business Partner Master Data form when it loads

Do not confuse UI API Item object with Items in general collections (such as UI API Items or Forms)

Note:
Changes to SAP system forms occur only at runtime and are not persisted in any way.  The method
shown uses explicit low-level code – the alternative is to use XML batch actions.



Handling this event will make sure that your add-on is called whenever data are displayed or changed.

Several types of lower-level events may cause a FormDataEvent.  Add-on code is clearer when it handles
a FormDataEvent instead of a mixture of ItemEvents and MenuEvents which underlie it.



et_ITEM_PRESSED and et_FORM_LOAD are often used to add additional validation checks before
saving a document or to manipulate a form before it’s shown (e.g. make some fields invisible depending
on business logic)

et_KEY_DOWN might be useful for a special kind of „help“ (when key „X“ is pressed some detail is
shown)

other form events are usually used less frequently



By default, the UI API receives all events triggered by the SAP Business One application.

Without event filtering, all events are sent to your add-on application.  Your event handler is getting
called each time an event is raised. This can result in poor performance overall.

If you use event filtering, only the selected events are sent to your add-on application.  Significantly
fewer COM calls will be made and performance improves.

AppEvents are not affected.

Note:

Once you define an EventFilter, add it to the EventFilters object and assign it to the Application
object, your add-on will start to only receive events specified in the filters.

To continue to receive MenuEvents, don’t forget to include et_MENU_CLICK in the filter.



Event is filtered by event type and form type.

The add-on notifies the list of required events through the SetFilter() method of the Application object

The event list contains event types for:

form events, listing all form types for which they will be raised

menu click event

The event list cannot contain:

AppEvents (aet_ShutDown...)

ProgressBarEvents

StatusBarEvents

Note:
Most UI API events are notified twice – before they take place in the user interface (BubbleEvent =
True) and after they have taken place



You can remove a particular form type from the filter by using RemoveEx(„FormType“)

You can also remove all filters through a Reset() of the Filters collection





















Note:
If you are reusing a MenuCreationParams object for several menu items, set all properties, including
Position, every time – AddEx() does not change/increase any properties implicitly



















Code sample – Add menu:
Private Sub SBO_Application_RightClickEvent(ByRef contextMenuInfo As

SAPbouiCOM.contextMenuInfo, ByRef
BubbleEvent As Boolean) Handles SBO_Application.RightClickEvent

If (contextMenuInfo.BeforeAction = True) Then
Dim oCreationPackage As SAPbouiCOM.MenuCreationParams =

SBO_Application.CreateObject _

(BoCreatableObjectType.cot_MenuCreationParams)
oCreationPackage.Type = SAPbouiCOM.BoMenuType.mt_STRING
oCreationPackage.UniqueID = "MyMenu1"
oCreationPackage.String = "My Menu1"
oCreationPackage.Enabled = True
‘ Adding new menu to Data menu in B1
Dim oMenuItem As SAPbouiCOM.MenuItem =

SBO_Application.Menus.Item("1280")
Dim oMenus As SAPbouiCOM.Menus = oMenuItem.SubMenus
oMenus.AddEx(oCreationPackage)

End If
Code sample – Remove menu:
Private Sub SBO_Application_RightClickEvent(ByRef contextMenuInfo As

SAPbouiCOM.contextMenuInfo, ByRef
BubbleEvent As Boolean) Handles SBO_Application.RightClickEvent

If (contextMenuInfo.BeforeAction = True) Then
‘ In Before Action – Remove menu from context menu only
contextMenuInfo.RemoveFromContent(“4870”)                 'Data->Filter

& Grid
‘ Remove menu from context menu by disabling menu
‘Edit menu
Dim menuItem As SAPbouiCOM.MenuItem =

SBO_Application.Menus.Item(“768”)
' Edit->Paste
Dim menuItem1 As SAPbouiCOM.MenuItem = oMenuItem .SubMenus.Item(“773”)
menuItem1.Enabled = False

End If
End Sub
Code sample – Cleanup:
Private Sub SBO_Application_RightClickEvent(ByRef contextMenuInfo As

SAPbouiCOM.contextMenuInfo, ByRef
BubbleEvent As Boolean) Handles SBO_Application.RightClickEvent

If (contextMenuInfo.BeforeAction = False) Then
‘Retrieve Edit->Paste menu that was removed in before action
Dim menuItem As SAPbouiCOM.MenuItem =  _

SBO_Application.Menus.Item(“768”) ‘Edit menu
Dim menuItem1 As SAPbouiCOM.MenuItem = oMenuItem .SubMenus.Item(“773”)

' Edit->Paste
menuItem1.Enabled = True

‘ Remove user menu that was added to Data menu in ‘Before’ Right Click event
oMenuItem = SBO_Application.Menus.Item("1280")   ' Data menu

menuItem1 = oMenuItem.SubMenus.Item ("MyMenu1")
oMenus.Remove(menuItem1)

End If
End Sub



























Column with sum cell is supported,  Hebrew is supported





BLOB, Binary Large Object





Public Sub MergeCell( _ ByVal RowNum As Long, _ ByVal startCol As Long, _ Optional ByVal
bMerge As Boolean = True _ )

Merge cells in a row, from the first one you want until the last one you want.

The text displayed in a merged cell is the content from the first cell.

Public Sub SeparateLine( _ ByVal RowNum As Long, _ ByVal color As Long, _ ByVal
separateLineType As BoSeparateLineType, _ Optional ByVal bDraw As Boolean = True _ )

The SeparateLine feature and the MergeCell feature cannot be used in the same row.

























Beware of “unexpected” behavior when multiple forms of the same types are open simultaneously or
when the user is logged in multiple sessions




















