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Payroll in a Background Operation
Use
When you have checked all the settings for the payroll run, and have tested the run in a
simulation run, you can perform the payroll run in a background job.

Scope of Functions
There are several possibilities for creating background jobs:

•  Using the payroll calendar you can create and schedule payroll jobs.

•  You can use report RPCSC000 to split the personnel numbers into small sets and run
them simultaneously in the background.

•  Using the process model workbench you can easily plan all payroll jobs and the
subsequent activities.

•  With the function System→Services→Jobs→Define Jobs, you can establish individual
jobs or a series of jobs. For more information see Managing Background Processes
[Ext.].
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Payroll Calendar
Use
Using the payroll calendar you can create payroll jobs and follow how they are executed. The
payroll jobs are grouped into tasks according to payroll areas.

Prerequisites
In Customizing for Payroll all the necessary settings must be made under Payroll Calendar.

Scope of Functions
The payroll calendar provides you with the following functions:

•  Calendar

You can flag one or more schedules and display the tasks which belong to them.

You can display the payroll jobs for a task.

You can schedule tasks that have already been defined.

You can display tasks that have already been processed.

You can display the way in which tasks are assigned to a schedule.

•  Job Scheduling:

You can edit payroll jobs.

The report documentation describes how you create a payroll job.
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Viewing the Payroll Job
Procedure
1. In the Payroll menu choose Tools→ Payroll Calendar.

2. Specify a schedule.

3. Choose Calendar

The calendar is displayed in two parts:

- The upper section contains a three month period, beginning with the month of the
selected start date. You can change this section month by month or select any month
directly. Weekends, public holidays and the days for which payroll jobs are scheduled
have a different background color.

- The tasks for all dates are displayed in the lower part of the screen. These tasks contain
the planned payroll jobs for a payroll area.

To display completed payroll jobs, choose Settings → Hist. Data On. This menu
entry is changed dynamically to Hist. Data Off. To hide previous payroll jobs, choose
Settings → Hist. Data Off.

Viewing Payroll Jobs for a Specific Task
4. Select a task.

5. Choose Display Selected Tasks.

The system lists all the payroll jobs assigned to this task.

6. For more information on individual payroll jobs, select a payroll job and choose Goto →
Scheduled Task

You then have a job overview for the selected payroll job. The following functions are
available:

- You can view the job definition and the individual steps of the job.

- You can delete the payroll job.

- You can view the job log and the spool list with the payroll log, for payroll jobs that have
already been carried out.

Viewing Payroll Jobs for a Specific Date
4. Select a date.

5. Choose Display Selected Tasks.

The system then displays all of the payroll jobs scheduled for this day.

Viewing Payroll Jobs for a Specific Week
4. Select a week number
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5. Choose Display Selected Tasks.

The system then displays all of the payroll jobs scheduled for this week.
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Processing Payroll Jobs
Prerequisites
You are in the initial screen of the Payroll Calendar.

Procedure
1. Choose Job Scheduling.

 You enter the selection screen for job scheduling. The report documentation for this
selection screen describes how you create a payroll job.

 Deleting Data
2. To delete incorrect payroll jobs or tasks from the payroll calendar proceed as follows:

- To delete a payroll job, select the payroll job and call up the job overview. Select the
payroll job that you want to delete, then delete it.

- To delete a task, choose Environment →→→→ Configuration →→→→ Task. Select the payroll job
that you want to delete, then delete it.

3. Choose Back.

You come back to the payroll calendar.

4. Choose Schedule → Refresh

The deleted payroll jobs and tasks are no longer displayed.



Payroll in a Background Operation  SAP AG

Parallel Payroll for Personnel Numbers

10 December 1999

Parallel Payroll for Personnel Numbers
Use
If you have to run payroll for a large number of personnel numbers in a payroll period, you can
use report RPCSC000 to split the personnel numbers into several background jobs. The system
then processes the background jobs simultaneously, using different application servers.

Integration
Report RPCSC000 is used exclusively in Payroll.

Report RPCS0000 [Ext.] can also be used if you want to run parallel evaluations for payroll.

Prerequisites
You must note the following prerequisites:

•  The payroll program is called up using a symbolic name. You must define these symbolic
names and the program names in view T596F.

•  You must define a suitable program variant in the programs assigned to the symbolic names.

Scope of Function
You specify the number of personnel numbers to be included in the background payroll run, or
how many background jobs should be created. Report RPCSC000 selects the personnel
numbers to be included in the payroll run from the database, and groups them together in
background jobs. You can release each background job for payroll separately, or you can release
them together.

You can enter a short title for each payroll run. Each background job contains this short title and
a sequential number. The short title can be helpful if you want to display the background jobs in
the general job overview.

The program displays a log after the payroll run has been completed.
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Parallel Payroll for Personnel Numbers
Prerequisites
You have defined the symbolic names to be used to call the payroll program and the program
names in table T596F. You must use the following naming conventions: the symbolic name starts
with CALC and contains the country modifier (for example, CALC02).

The system takes the first entry with the symbolic name into account and does not
use the date in the table.

You have defined a program variant in the payroll program that is assigned to the symbolic
name.

You are in the ABAP Execute Program screen.

Procedure
1. Enter Program RPCSC0000.

2. Choose Execute.

3. Enter the program and a variant.

The system uses the payroll schema for the variant you have selected for the payroll run.

4. Enter the number of personnel numbers to be included in the parallel payroll run, or enter
the number of jobs for which the payroll run should be split.

5. Choose one of the following steps:

•  Program → Execute

•  Program → Execute + Print

•  Program → Execute in Background

Result
The system performs payroll and prints a log. This contains the following information:

•  Date and time of the individual program steps

•  Error messages

•  Warnings

•  Overview of generated background processes

You can clearly identify the jobs using the job numbers and the job names.
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Process Model
Definition
A process model defines a sequence of programs that automatically follow one another. The
process run can be interrupted with breakpoints.

Use
Process models are used as templates for the execution of processes [Page 27]. Several
processes can be based on the same process model. Implementation of process models has the
following advantages:

•  Processing of the programs can be easily monitored.

•  You can check each personnel number during the complete process run.

•  You can repeat individual process steps.

•  You can reduce the process runtime by running programs in parallel.

•  You can specify that a message is sent in specific conditions.

Structure
In the attributes, you use the personnel number selection program [Page 16] to specify which
personnel numbers are used in the process model.

You define the behavior of the program in the process model by specifying a program category
that defines this program. The specifications for the program categories are documented in the
system under Edit → Program category. You can assign any number of programs to a program
category.
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Process Model: Example

 

Create documents

1
-1000
1
-1000

1001
-2000
1001
-2000

2001
-3000
2001
-3000

Print form
Program: RPCEDTX0
Variant  : SAP&PM99

Print form
Program: RPCEDTX0
Variant  : SAP&PM99

Unconditional 
breakpoint

Unconditional 
breakpoint

Personnel number selection
H99_SELECT_PERNR

Personnel number selection
H99_SELECT_PERNR

Payment
Program: RPCDTAX0
Variant  : SAP&PM99

Payment
Program: RPCDTAX0
Variant  : SAP&PM99

Program: RPCIPE00
Variant  : SAP&PM99

Payroll

1
- 500
1
- 500

501
-1000
501
-1000

1001
-1500
1001
-1500

2001
-2500
2001
-2500

2501
-3000
2501
-3000

Program: RPCALCX0
Variant  : SAP&PM99

Personnel Number Selection
The selection program H99_SELECT_PERNR transfers the personnel numbers to be processed
to the process model.

Programs
The program RPCALCX0 with selection variant SAP&PM99 belongs to the PY-Payroll program
category.

Form printing and payment are processed together, therefore, the total runtime is reduced.

Sets of personnel numbers
The payroll program simultaneously processes sets of 500 personnel numbers and the transfer
program processes sets of 1000 personnel numbers. This means that the runtimes of the
programs are reduced.

Programs that process sets of personnel numbers cannot follow programs that split the selected
personnel numbers, and vice versa.

Breakpoint
The unconditional breakpoint interrupts the process each time it is run and before any documents
are created.
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Programs that select personnel numbers can only follow programs that also work on
the personnel number level. For example, the payment program cannot transfer
personnel numbers to the check printing program as a selection criterion.
Only a program that does not select personnel numbers can follow the check printing
program. The system documentation for the program categories specifies which
categories select personnel numbers.
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Technical Processing of a Process Model
Purpose
For more information on using a process model, see Process Model [Page 12].

Prerequisites
A workflow user must be set up in SAP Business Workflow  [Ext.]to enable the program to be
executed correctly.

Process flow
1. The process starts with a selection program which determines the personnel numbers for

processing. The selection program can either be started in the background or directly from
the HR Process Workbench. It exports a workflow event and transfers the process control to
the Process Manager. This means that the following information is sent to a container:

− StepID

− ProcID

− ParaID

− RunID

2. The Process Manager determines the next step, and starts the accompanying program in the
background.

3. At the end of the program, control is given back to the Process Manager. The system checks
the status of the process step and checks whether other steps follow. The container is filled
with the above information again. The content of the container is always saved so that the
information on the individual steps is never lost.

4. The next program is started with the information from the container and from the results
tables for the preceding program.

Result
An overview of the status for the individual process steps is displayed in the HR Process
Workbench. A message can be sent to a particular person, depending on the definition of the
individual process steps.
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Personnel Number Selection
Use
The process model must start with a program that selects the personnel numbers for the
complete process run. Each process model starts with a specific selection program.

You specify the selection program when you create the process model.

Integration
Personnel numbers that have not been selected using the selection program defined in the
process model can still be included in a process containing payroll. For example, you can include
new employees in a process. If the process is repeated, they are read from matchcode W [Ext.].

SAP provides an international selection program H99_SELECT_PERNR.

If you use your own selection program, base it on the following structure. The given source text
must remain.

REPORT MY_SELECTION_PROGRAM.

INCLUDE RPUPMDP1.

RANGE: PROCESS_EMPLOYEES FOR PERNR-PERNR.

DATA: This_report like sy-repid

...

START-OF-SELECTION.

This_report = sy-repid

CALL FUNCTION 'HRPY_PROCESS_INIT_SELECTION’

EXPORTING

IMP_PROGRAM = This_report

CHANGING

CHAN_PROCESSID = STPROCID

CHAN_STEPID = STSTEPID

CHAN_CONNECT = CONNECT

CHAN_CONT = CONT

... Specific processing: In the PROCESS_EMPLOYEES table, enter the

 personnel numbers to be processed.
END-OF-SELECTION.

CALL FUNCTION 'HRPY_PROCESS_CLOSE_SELECTION'

EXPORTING
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IMP_PROCESSID = STPROCID

IMP_STEPID = STSTEPID

IMP_CONNECT = CONNECT

IMP_CONT = CONT

TABLES

IMP_PERNR_INDEX = PROCESS_EMPLOYEES

LEAVE PROGRAM.
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Mail Connection
Use
During a process, the individual steps can have different statuses. When you create a process
model, you can define the situations in which you are notified about the status of a process step.

You can send a message by mail or by pager. For more information on communicating by pager,
see Sending Messages by Pager [Ext.].

Features
You can send a message in the following situations:

•  Some personnel numbers contain errors

•  Some personnel numbers have no data

•  Processing of a set of personnel numbers was canceled

•  A step was completed

•  A process was canceled

•  A process was not canceled

There are standard texts for these mails. The texts are assigned when the process is defined.
Each mail has an attachment. If you double-click this attachment, you access the HR Process
Workbench at the place where the process was canceled.

Activities
When you create a process model, you specify who should receive the message and which
standard text should be used for the mails.

You can change the standard texts under Tools → SAPScript → Standard text. For more
information, see the Implementation Guide (IMG) for Payroll under Create Process Model [Ext.].
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Copying or Creating a Process Model
Prerequisites
SAP recommends that you copy the standard process models and then edit the copied process
models.

Copying a Process Model
1. In the Payroll menu, choose Tools → Flow control → Maintain process model.

You access the Maintain Process Models screen.

2. In the Process model field, enter a process model.

− If you want to display the process model before you copy it, choose Model → Display.

− If you want to display information on the model, choose Goto → Documentation on
model.

3. Choose Model → Copy.

4. In the Target model field, enter the name of your process model. You can use names that
begin with the digits 0 to 9 or with Z.

Result
The process model has been copied to the new name and is now ready for editing. To create
information on the model, choose Goto → Documentation for model.

Creating a Process Model
1. In the Payroll menu, choose Tools → Flow control → Maintain process model.

You access the Maintain Process Models screen.

2. Enter a name and choose Model → Create. You can use names that begin with the digits 0
to 9 or with Z.

3. Maintain the attributes for your model and choose Save.

The model attributes assign a name and selection program to your model. This selection
program provides your model with the personnel numbers to be processed.

4. Choose Continue.

Result
The process model has been created and can be edited [Page 20].
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Editing a Process Model
Prerequisites
You have created or copied a process model [Page 19] and are in the Maintain Process Models
screen.

Procedure
1. Enter the name of the model that you want to edit.

2. Choose Model → Change.

You access the change mode. The following areas are displayed in the change mode:

− Display area

The model you have called is displayed and can be changed.

− Navigation area

The section of the display area is defined.

− Insertable objects

The Program and Breakpoint templates are displayed.

•  To change the size and overview of the areas, choose Settings → Change
partitioning.

•  To change the sequence of the areas, choose Settings → Change sequence.

•  To choose between your own and standard settings, choose View → User or
View → Standard.

Result
You can insert the Program and Breakpoint objects as process steps in the process model. See
also Inserting and Changing Process Steps [Page 21].

For more information, see Documentation on Model.
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Inserting a Process Step
Prerequisites
You are in the Maintain Process Model screen.

The templates for programs and breakpoints are available in the Insertable objects area.

Procedure
1. In the Insertable objects area, select the object that you want to insert.

2. Click in the display area.

The object appears.

3. Create the program [Page 22] or the breakpoint [Page 23].

4. To include the object in the model, choose Include.

5. Use the cursor to draw a line from the parent object to the child object.

Result
The object is inserted in the process model as a new process step.
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Defining a Process Step
Prerequisites
You are in the Maintain Process Model screen.

You have inserted a process step in your process model and you must now specify the
characteristics for this step.

Procedure
1. Enter the program category that you want to use.

If you are creating a new category, enter the name of the category and define the
following characteristics:

− Unconditional breakpoint before program start

− Whether the status can be reset

− Personnel number selection

− Parallel processing

− Parent category

− Child category

For an overview of the existing program categories and their characteristics, see
Maintenance of process models under Edit → Program categories. You can also
maintain the characteristics here.

2. Enter the program that you want to use.

3. Enter the program variant that you want to use with this model. You can also enter the name
of a new variant and create the variant directly.

4. If the program processes personnel numbers at the same time, enter the size of the
personnel number set.

5. If applicable, specify whether somebody should be informed of the status of the process step.

Result
The process step is displayed under the program, variant and set size information.
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Defining a Breakpoint
Prerequisites
You are in the Maintenance of Process Models screen.

You have inserted a breakpoint in your process model and you must now define the
characteristics for this step.

Procedure
1. Enter the condition under which the breakpoint will interrupt the process run.

2. If applicable, specify whether somebody should be informed of the status of the breakpoint.

Result
The process step is displayed.
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Breakpoint
Definition
Specifies whether a process must be interrupted. There are conditional and unconditional
breakpoints.

Structure
A breakpoint is defined by a function module. SAP provides the function module
HRPY_PROCESS_STOP_CONDITIONAL  (conditional breakpoint) and
HRPY_PROCESS_STOP_ABSOLUTE  (unconditional breakpoint).

You can define your own conditions for a breakpoint in a function module. The function module
interface has the following structure:

•  Import parameter

− IMP_PROCESSID LIKE T52SPS-PROCESSID (process object key)

− IMP_STEPID LIKE T52SPS-STEPID (process step object ID)

− IMP_RATE LIKE T52SMS-PERCENTAGE (percentage rate)

•  Exception

− STOP_PROCESS (If this exception occurs, the process is interrupted.)
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Changing a Process Step
1. Select the process step that you want to change.

2. Choose Edit → Choose.

3. Make the changes. If you are changing a program, you can create new program categories
here.
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Changing the Sequence of Process Steps
You have the following options:

1. Select the process step that you want to move.

2. Choose Edit → Nodes → Remove to buffer.

3. Choose Edit → Nodes → Remove to buffer.

The object is displayed separately in the display area and can then be inserted again.

Or:

1. Choose Edit → Nodes → Connect.

2. Use the cursor to draw a line from the new parent object to the process step that you want to
move.

The process step and the accompanying child objects are now subordinate to the new
parent object.
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Process
Definition
Each process is created and given a unique number using a process model [Page 12]. The
process comprises all steps defined in the process model. Closed processes are locked for
changes, however they can still be displayed. This ensures that the complete process history is
available.

Use
If a process model is used periodically, you create a new process each time. The process ID
uniquely identifies each process.

You use the same process model each month to create the bank transfer for an
employee and print the forms. Each month you use the process model to create a
new process. In December, you may need to use a different process model since
additional evaluation reports are required at the end of the year.

Structure

Process step
2

Process stepProcess step
22

Process step
3

Process stepProcess step
33

Process step
1

Process stepProcess step
11

Run 2Run 2

Run 1Run 1

Run 2Run 2

Run 1Run 1

PerNo. 3PerNo. 3

PerNo. 1PerNo. 1

PerNo. 2PerNo. 2

PerNo. 1PerNo. 1

PerNo. 3PerNo. 3

PerNo. 4PerNo. 4

PerNo. 2PerNo. 2

PerNo. 1PerNo. 1

PerNo. 3PerNo. 3

PerNo. 4PerNo. 4

OKOK

OKOK

OKOK

ErrorErrorError

OKOK

ErrorErrorError

OKOK

ErrorErrorError

OKOK

OKOK

You can check the processing steps using the Status Display [Page 33] function.

Process step
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A process step corresponds to the processing of a program in the process model. The process
step includes:

•  The program category, whose specifications have been defined in the process model [Page
12].

•  The assigned program with a variant

You can repeat a process step as often as required. If you do repeat a step, the child program
that processes the results of the parent program is also repeated. You start and repeat [Page 30]
processes and process steps in the same way.

Run
A run is equivalent to starting or repeating a process step. The runs in a process step are
displayed and numbered sequentially. If a process is repeated, all process steps will also be
repeated.

Set
If personnel numbers are processed at the same time in the process step, sets of personnel
numbers are processed in each run. The number of sets is determined each time the process
step is repeated. The numbering starts at one each time.

If the personnel numbers cannot be processed at the same time, they automatically form one
set.

If you repeat a process step or process, only personnel numbers without the
Successful status or with the Not Selected status will processed again.

You can only repeat processes, process steps and personnel number sets if you
change the status [Page 35] for the personnel numbers in question.
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Creating a Process
Prerequisites
You have created the process model [Page 12] to be used in the process.

Procedure
1. In the Payroll menu, choose Tools → Flow control → HR Process Workbench.

2. Choose Edit → Process → Create.

The process number that uniquely identifies the process is assigned automatically. The
number range object, which controls the assignment of the numbers, is delivered with the
Process Workbench.

3. Enter a process name and the process model that you want to use.

Result
The process has been created. It has the status [Page 33] Still to run. You can start the process.

To check which process model is used in your created process, flag the process and
choose Goto → Additional information.
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Starting or Repeating a Process
Use
You start and repeat processes and process steps in the same way. The status [Page 33]
indicates whether you need to start or repeat the process.

You can start a process for the first time or repeat a process for the following reasons:

•  Breakpoint

A process step follows either a conditional or unconditional breakpoint.

•  Process termination

Process steps can be terminated due to a program or technical error. You can see the
reason for the program termination by displaying the job log [Page 36].

•  Personnel numbers with errors

Use the spool list [Page 36] and job log [Page 36] to check the process step. Remove
the error and repeat the process step.

Prerequisites
You are in the HR Process Workbench.

Procedure
1. Select the process that you want to start and choose Edit → Process → Start/repeat.

2. Specify whether the process will run immediately or at a later point.

− Immediately: In the personnel number selection screen, either specify a variant or enter
the payroll area and payroll period.

− Later: Enter the start date and time. Select the variant for starting the personnel number
selection program.

A process is always processed in the background.

Result
The process is run at a specified time.

You can control the process run using process control [Page 36].
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Closing a Process
You can close a process when you have locked it for changes and do not want to repeat it again.
You can close a process even it still contains incorrect personnel numbers.

Prerequisites
You are in the HR Process Workbench.

Procedure
1. Select the process that you want to close.

You cannot reverse the Close process activity. You can only display a closed
process.

2. Choose Edit → Process → Close.

Result
All process data remains unchanged so that you can see the process history.
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Deleting a Process
Prerequisites
Processes that you want to delete must already be closed.

You are in the HR Process Workbench.

Procedure
1. Select the process that you want to delete.

2. Choose Edit → Process → Delete.

Result
You can no longer access the history for processes that have been deleted.

The application log shows who deleted a process and at what time it was deleted. To
access the application log selection screen, choose Goto → Display application log.
If you want to accept the default settings, choose Continue. An overview of the
processes deleted in the previous year is displayed. If you want to restrict the
overview, enter the necessary data in the selection screen.
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Status Display
You can use the status display to check the status of a process.

For more information on checking the processing status, see Process Control [Page
36].

Features
The status display enables you to display the status of the process and the status of the
personnel number.

Process status
The process status is displayed on the process, process step, run, and set level. The icons given
to the levels during and after a process run provide information on the processing status. The
icon legend can be found in the HR Process Workbench under Utilities.

The process status can be as follows:

•  Stopped

A process step follows either a conditional or unconditional breakpoint. To continue the
process, select the process step and choose Edit → Process → Start/Repeat.

•  Successful

You can now close the process [Page 31].

•  Provisionally ended

•  Ended with errors

If process steps are provisionally or incorrectly ended, display the spool list [Page 36] to
analyze the problem. Remove the error and repeat the process step.

•  Canceled

Display the job log [Page 36]. Remove the error and repeat the process step.

Personnel number status
During the process flow, each personnel number receives information on the processing status.
This means you can follow the status of a personnel number through the complete process flow.
Only correctly processed personnel numbers are transferred from one process step to the next.

You can display the status of a personnel number for all process levels. Select the corresponding
process level, choose Goto → Display personnel numbers and specify whether particular
personnel numbers or personnel numbers with a particular status are to be displayed.

The status can be as follows:

•  Successful

•  Provisional

Personnel numbers receive this status if they are processed using incomplete data and
the process step was performed correctly.
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•  Incorrect

•  Blank

This status is for personnel numbers that were incorrect in the previous process step
and, as a result, could not be edited.

•  Not selected

Activities
In the status display, you can restrict which processes are displayed by choosing Process
overview → Set filter.

If you have selected a process and you then choose Goto → Display process model, the
accompanying process model is displayed.
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Changing the Status
Use
If you repeat [Page 30] processes or process steps, only personnel numbers without the
Successful or Not selected status are processed. To be able to select successfully processed
personnel numbers, you must change the status.

Prerequisites
You are in the HR Process Workbench.

Procedure
1. Select the appropriate level in the process.

2. Choose Edit → Personnel number → Set to ‘Incorrect’.

You can only reset the status if this action is permitted for the process step category in question.

You have changed the value of a wage type in a table for the process step Payroll.
The personnel numbers affected by this change are not grouped in matchcode W,
however, when the payroll process is repeated, they should be corrected. Change
the status and start the process again.
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Process Control
Use
You can run processes immediately or later, in other words, at any time. This information refers
to starting the selection program [Page 16].

The process steps are processed in the background. The following tools help you to monitor the
processing:

•  Status management [Page 33]

•  Job log

The job log contains the processing start date and time and also the processing end or
termination date and time.

To display detailed information on the program termination, double-click the Job
interrupted message in the job log. Either a short dump or a termination message
text will inform you of the cause of the termination.

To display the job log, select the set of personnel numbers and choose Goto → Job
overview for set.

•  Spool list for sets of personnel numbers

If the log function is activated, you can use the spool list to display the program output of
individual process steps.

To display the spool list, select the set of personnel numbers and choose Goto → Spool
list for set.
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