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Human Resources Information System
The Human Resources Information System provides you with a broad range of functions that
enable you to perform standard reporting from all Human Resource areas. In addition, it lets you
define your own reports quickly and efficiently.

The Human Resources Information System consists of the HIS and Ad Hoc Query components.
Each of these components includes functions that meet specific reporting requirements by giving
first priority to swift report access (HIS) or detailed reporting (Ad Hoc Query):

• HIS
HIS is the fastest way to perform reporting for HR data. A special method of accessing
reports is employed. A graphical display enables you to select the object to be reported
on. You then start reporting without entering data in a selection screen. These settings
are made in HIS by the system itself. The system uses a standard setting that is based
on general usage.

For more information, see:
HIS [Page 10]

• HR Ad Hoc Query
Ad Hoc Query is a reporting tool that was specially developed for Human Resources
Management. It is intended for reporting requirements that are not met by standard
reports. Ad Hoc Query enables you to perform reporting right down to the infotype field
level, that is, the lowest level of information in Human Resources Management.

Reports defined using Ad Hoc Query can be saved, which means they are reusable.

Ad Hoc Query serves a dual function. It is used to

• Quickly define and execute very specific reports that are seldom required

• Define specific reports that need to be reused

For more information, see:
Ad Hoc Query in Human Resources Management [Page 15]

• Standard Reporting in Human Resources Management
Each component within Human Resources Management includes standard reports that
can be accessed using the SAP Easy Access menu. You can access all of the standard
reports in Human Resources Management by choosing Human resources → Information
system → Reports.

You can access the specific reports of various components by going to an individual
component's Info system.

Examples:

Personnel management → Administration → Info system → Reports

Payroll → International → Info system
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For more information, see:
HR Standard Reports [Ext.]

Finding Standard Reports [Ext.]
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Human Resources Information System
The Human Resources Information System provides you with a broad range of functions that
enable you to perform standard reporting from all Human Resource areas. In addition, it lets you
define your own reports quickly and efficiently.

The Human Resources Information System consists of the HIS and Ad Hoc Query components.
Each of these components includes functions that meet specific reporting requirements by giving
first priority to swift report access (HIS) or detailed reporting (Ad Hoc Query):

• HIS
HIS is the fastest way to perform reporting for HR data. A special method of accessing
reports is employed. A graphical display enables you to select the object to be reported
on. You then start reporting without entering data in a selection screen. These settings
are made in HIS by the system itself. The system uses a standard setting that is based
on general usage.

For more information, see:
HIS [Page 10]

• HR Ad Hoc Query
Ad Hoc Query is a reporting tool that was specially developed for Human Resources
Management. It is intended for reporting requirements that are not met by standard
reports. Ad Hoc Query enables you to perform reporting right down to the infotype field
level, that is, the lowest level of information in Human Resources Management.

Reports defined using Ad Hoc Query can be saved, which means they are reusable.

Ad Hoc Query serves a dual function. It is used to

• Quickly define and execute very specific reports that are seldom required

• Define specific reports that need to be reused

For more information, see:
Ad Hoc Query in Human Resources Management [Page 15]

• Standard Reporting in Human Resources Management
Each component within Human Resources Management includes standard reports that
can be accessed using the SAP Easy Access menu. You can access all of the standard
reports in Human Resources Management by choosing Human resources → Information
system → Reports.

You can access the specific reports of various components by going to an individual
component's Info system.

Examples:

Personnel management → Administration → Info system → Reports

Payroll → International → Info system
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For more information, see:
HR Standard Reports [Ext.]

Finding Standard Reports [Ext.]
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Start Human Resources Information System
Procedure
In the SAP Easy Access menu:

1. Choose Human resources → Information system → Reporting tools.

2. Start the required reporting tool.



Human Resources Information System  SAP AG

HIS

10 December 1999

HIS
Purpose
HIS constitutes a simplified method of requesting reports by letting you start them directly from
structural graphics. HIS always displays two windows for processing. In the first window,
structural graphics is active and you can select an object. In the second window, a list of
available reports is displayed. You use the second window to start a report for the selected
object. This procedure has the following advantages:

• You are not required to enter data in a report selection screen.

If you want to start a report anywhere other than HIS, you must enter data in the report
selection screen before starting the report. In HIS, the system sets the required selection
parameters automatically whenever possible.

The parameters set by the system correspond to the selection parameters that are most
commonly used when the reports are run. In other words, they are an efficient method of
presetting reports. You can check and change these settings at any time by using the
Change/Display Standard Settings [Page 11] function.

HIS also enables you to start a report from the selection screen, if required.

• You are not required to switch between applications to access different reports.

The reports included in HIS belong to different HR components (such as Organizational
Management, Personnel Administration, and Personnel Development). Accessing these
reports usually requires you to follow specific menu paths in a particular component. In
HIS, this is not the case. You can start and execute reports that belong to different
components from a single, central function.

The reports on offer are a selection from all areas of Human Resources Management. If you
want to add more reports to those offered by HIS, access Customizing, choose Human
Resources Information System →=HIS →=Define Task Functions, and add them to the required
area.

A description of the reports is included in application help. If you require further information, see
Request Report Documentation [Page 13].
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Standard Settings
Use
In the Human Resources Information System, reports are started directly. For this reason, certain
parameters must be set automatically by the system. The Standard settings function enables you
to display and, if necessary, change these parameter settings.

Features
The parameters in questions are as follows:

• Start

This parameter enables you to determine whether the report is executed directly, or
whether the report selection screen is displayed first.

• Reporting depth

This parameter enables you to determine whether the report only runs for the object
selected in structural graphics, or whether the report also runs for all of the underlying
objects.

• Data retrieval

This parameter enables you to determine whether the report only retrieves data for the
selected objects, or whether the report also retrieves data for all of the underlying
objects.

• Object selection and period indicator

These parameters enable you to restrict the number of objects selected for the report
according to their periods of validity.

− Object selection

The object selection parameter enables you to enter a period for the required periods
of validity. If you do not make an entry in this field, the restriction is made in
accordance with the validity period using the value selected for the validity indicator.

− Period indicator

This parameter enables you to select the following values for a restriction according
to validity period: D (current day), M (month), Y (year), P (past), F (future).

• Data selection

This parameter enables you to determine data output depending on data validity. If you
enter a period, for example, several data records are displayed if changes were made to
data during this period.
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Change Standard Settings
You can change the standard settings at two points within the Human Resources Information
System.

• On the initial Human Resources Information System screen

• In structural graphics.

Prerequisites
If you want to change or display the standard settings, you must first enter a root object in the
initial Human Resources Information System screen. In other words, you need to enter an
organizational unit for the Standard view, or a business event group for the Training view.

Procedure
If you have accessed the initial Human Resources Information System screen, proceed as
follows:

1. Choose Settings → Defaults.

This takes you to the defaults dialog box.

2. The procedure from this point is the same as when accessing from structural graphics.

If you have accessed Structural Graphics, proceed as follows.

1. In the Reporting group box, choose Defaults.

Under task functions, choose Defaults.

2. This takes you to the Defaults dialog box.

3. Make the settings that you require for the Start, Reporting depth, Data retrieval, Object
selection, Period indicator, and Data selection parameters. For more information on the
meaning of these parameters, see Standard Settings [Page 11].

4. To save your entries, choose Continue.
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Request Documentation
Procedure
In HIS structural graphics:

1. On the Reporting screen, select an area.

Your selection determines which reporting options are available under Task functions.

2. Under Task functions, select a report.

3. Choose Help.

A description of the selected report is displayed.

4. To print the report documentation, choose .

5. To exit the report documentation, choose  or .
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Perform Reporting Using HIS
Procedure
1. In the SAP Easy Access menu, choose Human resources → Information system →

Reporting tools → HIS.

This takes you to the initial screen for HIS.

2. In the View field, select the Standard entry. If you want to report on data from Training and
Event Management, use the Training view.

3. In the Graphical display group box, select the required display option for structural graphics.
These options enable you to determine the objects that are displayed in structural graphics,
and the objects that you can use as root objects for reporting.

For more information on the standard settings in HIS and their meaning, see Standard
Settings [Page 11].

4. In the Organizational unit field, enter the organizational unit as of which the organizational
structure must be displayed.

5. Choose .

Structural graphics starts, and the Reporting screen is displayed. The upper section of
this screen enables you to determine the area within Human Resources from which
reports are offered. The list of reports available for this area is displayed in the lower
Task functions section.

6. Select an organizational unit, position, or person in structural graphics.

7. To start the report you require, double-click on it in the Task functions section.

Note that you cannot print reports from HIS if you work with the Latin 2 character set.
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Ad Hoc Query in Human Resources Management
Purpose
Ad Hoc Query is used to report on Human Resources data that is not covered by standard
reports. By selecting selection fields and output fields, you can access data stored anywhere
within the Human Resources System. You do not require programming skills to create reports
using Ad Hoc Query.

Integration
• You can use Ad Hoc Query to continue processing sets of persons that were selected using

Manager's Desktop or HIS. When you call Ad Hoc Query, they are transferred as a reporting
set, from which you can make further selections.

• You can branch directly from Ad Hoc Query:

− To general reporting

In this case, you only use the first Ad Hoc Query level, that is, you select an object
set. To report on this resulting set, you use a standard report.

− To SAP Query

You can use SAP Query to enhance queries defined in Ad Hoc Query by adding
features that are only supported by SAP Query. If you require further information,
see SAP Query [Ext.].

Features
The Ad Hoc Query procedure consists of two steps:

• In the first step, you select a set of objects in accordance with one or more selection criteria
that you can specify as required (= hit list). You can then process the hit list. You can also
use Ad Hoc Query to create two hit lists. You can add them together, subtract one from the
other, or use them to create intersections.

• In the second step, you enter data as required for the objects selected in the first step. To
display and forward reports, you can use the options provided by SAP Query. You can select
the type of output list (basic list, statistics, or ranked list) and the output type (such as
interactive list, simple list, export to MS Word, MS Excel, mail dispatch, and save to PC file).

For more information on working with Ad Hoc Query, see the following sections:

Graphical Overview of Functions [Page 17]

Functional Areas for Ad Hoc Query [Page 42]

Selection [Page 20]

Restrict Reporting Set [Page 25]

Set Operations [Page 26]

Output [Page 28]

Reuse Queries [Page 37]
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Graphical Overview of Functions
Purpose
Ad Hoc Query is used to report on Human Resources data that is not covered by standard
reports. Unlike SAP Query with its broader range of functions, Ad Hoc Query is also suitable for
end users with little experience of HR Reporting. Even beginners are quickly able to use it,
thanks to its clear list of available fields and preview of output function.

Prerequisites
If you want to be able to use all of the functions included in Ad Hoc Query, you must be assigned
to at least one user group to which at least one functional area is assigned.

User groups are created in SAP Query. If you require further information, see Functions for
Managing User Groups [Ext.], Functions for Managing Functional Areas [Ext.], and the individual
sections in Create and Change Functional Areas [Ext.].

If you start Ad Hoc Query from the SAP menu, an appropriate functional area is used
automatically in the information systems of several HR components (for example, the
information system for Personnel Administration). If you use this method to start Ad
Hoc Query and have access to the functional area without a user group, settings are
not required in SAP Query. However, you cannot save queries. If you require further
information, see Tips and Tricks [Page 44].

Process Flow
The graphical overview of functions represents the initial screen of Ad Hoc Query.

• On the left side of the initial screen, the current functional area is displayed with its functional
groups in an overview tree. Each functional group corresponds to an HR infotype. This
overview tree enables you to choose selection fields and output fields.

If the checkboxes for the selection fields and output fields are not visible, you can
adapt the display width to the width of the screen section by choosing View → Adjust
tree.

An ActiveX control is used to display the overview tree. If your system does not
support ActiveX controls, you can deactivate the use of ActiveX control for the entire
system. In this case, you choose selection fields and output fields by using the
additional Field selection pushbutton. If ActiveX control has been activated, this
pushbutton is not visible.

The functional area that you use determines the object type that can be selected with
Ad Hoc Query. If you use a functional area from Personnel Administration, for
example, the result of a selection is always a set of persons. However, if you use a
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functional area from Personnel Planning, the result of a selection is always a set of
objects whose object type is determined by the functional area (for example, a set of
business events or a set of positions). If you require further information, see
Functional Areas for Ad Hoc Query [Page 42] and Functional Areas in the HR
Application [Ext.].

• On the right side of the screen, the reporting period, reporting set, and list of selection fields
and options are displayed. You can open and close the Reporting period and Reporting set
screen sections.

• After you have selected your output fields, a preview of output is displayed with example data
in the lower section of the screen. You can also process the output at this point. For example,
you can change the order of the columns, or determine the output type.

Ad Hoc Query    Edit    Goto    View    System    Help

Output

Key fields
Func. groups

Addresses

-

+

Personal data

-
City
Street
House number

Se. V.. Te.

x

   34 persons   

1-
Last name x

4

HR Ad Hoc Query

Hit list
3

City London
O... Value

2

OSelection fields

Last name
Last name 1
Last name 2

Last name 4
Last name 3

Today 12.05.1999

Unrestricted
Restrict by: Current hit list

 =

Reporting set

Reporting period

5

General Process Flow of Ad Hoc Query
The numbering represents the principle of reporting using Ad Hoc Query. For detailed
instructions, see the specific sections.

1. Selection fields and output fields are chosen from functional groups

2. Values and selection options are entered for the selection fields

3. All of the objects that meet the selection criteria are selected (for example, persons)

4. Output is formatted, and the output type is chosen

5. The information defined using the output fields is output for the selected objects

See also:
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Selection [Page 20]

Output [Page 28]
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Selection
Use
When the selection is made, the system determines which objects meet the specified selection
criteria in the reporting period. The result of the selection is a set of objects. After the selection
has been made, you can continue processing this set or output data on the objects as required.

Ad Hoc Query only enables you to select one object type. The functional area that is
used determines the object type that is selected. If you use a functional area from
Personnel Administration or Recruitment, for example, the result of a selection is
always a set of persons. Functional areas from Personnel Planning can only be used
to select an object type, such as business events or positions. If you require further
information, see Functional Areas for Ad Hoc Query [Page 42] and Functional Areas
in the HR Application [Ext.].

This section gives you an overview of options available for selecting objects, and continuing to
process this set.

Activities
Selection Using One Selection Criterion
In the simplest possible scenario, you use one selection criterion as required for Ad Hoc Query.
To do so, you choose a selection field from the overview tree, choose a selection option, and
enter a value. You then start the selection. The result of the selection is the objects that meet the
selection criterion (such as all of the business events taking place in New York).

You can also make a selection without any selection criteria whatsoever. The result
of the selection is all of the objects in the system that can be selected with the
functional area you have used, and which are valid in the specified reporting period.

Selection Using Several Selection Criteria
You can make a selection using several selection criteria. To do so, you choose the selection
fields from the overview tree, choose the required selection options, and enter the required
values. You then start the selection. The result of the selection is all of the objects that meet all of
the selection criteria (for example, all of the business events taking place in New York with a
maximum of 20 attendees).

Restriction of the Reporting Set
Unless you restrict the reporting set, the selection is made for all of the objects in the system that
can be selected with the functional area you have used. However, reporting is often required for
a specific set of objects only, such as the employees in a particular department or the business
events taking place in a particular period. To achieve this aim, you must restrict the reporting set
accordingly.

You can restrict the reporting set as follows:

• Using the current hit list, which you obtained by making a specific selection
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• Using a set of persons, which you selected using the organizational structure

You can define further restrictions of the reporting set yourself. If you require further information,
see Restrict the Reporting Set [Page 25].

Processing the Selected Set of Objects
Once the selection has been made, you can continue processing the selected set of objects. You
can:

• Display the list of selected objects

• Delete objects from the list

• Branch to HR master data or detail maintenance

If you require further information, see Process the Selected Set of Objects [Page 24].
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Make Selection
Prerequisites
If you want to be able to use all of the functions included in Ad Hoc Query, you must be assigned
to at least one user group to which at least one functional area is assigned.

User groups are created in SAP Query. If you require further information, see Functions for
Managing User Groups [Ext.], Functions for Managing Functional Areas [Ext.], and the individual
sections in Create and Change Functional Areas [Ext.].

If you start Ad Hoc Query from the SAP menu, an appropriate functional area is used
automatically in the information systems of several HR components (for example, the
information system for Personnel Administration). If you use this method to start Ad
Hoc Query and have access to the functional area without a user group, settings are
not required in SAP Query. However, you cannot save queries. If you require further
information, see Tips and Tricks [Page 44].

Procedure
Before working with Ad Hoc Query for the first time, you are advised to see the Graphical
Overview of Functions [Page 17] to get a basic idea of how Ad Hoc Query is used.

1. Choose Human Resources → Information system → Reporting tools → Ad Hoc Query.

Ad Hoc Query is started. If you are starting Ad Hoc Query for this first time since logging
on the system, the dialog box for selecting functional areas is displayed. In this case,
continue with step 2.

Ad Hoc Query immediately starts with a functional area under the following conditions:

• You have already used Ad Hoc Query since logging on the system

• You started Ad Hoc Query from the information system for Personnel Administration
or Compensation Management

• You have set SET/GET parameters for Ad Hoc Query

In this case, continue with step 4.

2. If necessary, choose a query area and a user group.

The system displays a list of functional areas that are assigned to the selected user
group. If you require further information, see Tips and Tricks [Page 44].

3. Select the required functional area, and confirm by choosing .

4. Expand the overview tree with functional groups and functional group fields.

5. Use the Selection column to select one or more fields as selection fields.

6. The system transfers the selection fields to the list on the right of the screen. The value field
in question can be maintained.

7. In the Value field, enter selection values for the selection field you have chosen.
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The value types (numeric, alphanumeric, date) that you can enter for the selection fields
depend on the type of selection field.

8. In the Options field, choose selection options (such as < or =), if necessary.

9. Choose a reporting period, if necessary.

10. Choose  Hit list.

Result
In the Hit list field, the system displays the number of objects that meet your selection criteria.

You can now

• Process the selected object set [Page 24]

• Use the set of objects selected as a reporting set for further selections (see Restrict the
Reporting Set [Page 25])

• Output information on the objects selected (see Output [Page 28]).

If you want to define a new query using the same functional area, you can delete all
of the fields in the Ad Hoc Query by choosing Edit → Delete all.
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Edit Selected Set of Objects
Use
Ad Hoc Query enables you to list the contents of the hit list. You can use this list to delete
objects, and execute a detail display function for selected objects. If you select a set of persons,
you branch to HR master data. If you select different objects, you branch to detail maintenance
for Personnel Planning. If you remove objects from the set, they are not included in output.

The same editing options are available for all other sets of objects that you can use in Ad Hoc
Query, such as the reporting set and the set of objects for set operations.

Prerequisites
A set of objects exists.

Procedure
1. Choose  for the set that you want to display.

This takes you to the list of objects.

2. To branch to HR master data, select a person and choose HR master data (this is only
possible if you select a person). To branch to detail maintenance, select an object and
choose Detail maintenance.

3. To delete an object from the list (because you do not want it to be included in the following
report, for example), select the object and choose .

4. To accept changes, choose . To cancel changes, choose .

Result
You go back to the Ad Hoc Query screen. If you deleted objects, the set of objects is reduced by
the corresponding number.
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Restrict the Reporting Set
Use
Restrict the reporting set if you only want to report on a specific set of objects, such as a specific
group of persons.

In addition to the options described here, your system can include other, customer-
defined restriction options. If you require further information on the restriction options
for the reporting set, access Customizing for the Human Resources Information
System and see Selections IDs [Ext.], Define Selection IDs [Ext.], and Define
Groupings [Ext.].

Procedure (Restriction Using Organizational Structure)
You use a functional area from Personnel Administration, that is, a functional area based on
logical database PNP.

1. Under Restrict reporting set by, choose the Organizational structure entry.

2. To access the organizational structure, click on the Organizational structure entry.

3. Select the required organizational unit(s). You can select one or more organizational units,
entire branches of an organizational structure, or a complete organizational structure.

4. Confirm by choosing .

The persons who belong to the selected organizational unit are transferred as the
reporting set. The number of persons is displayed in the Reporting set field.

If you make your selection by using the organizational structure, the system selects
the persons who belong to the selected organizational unit or an underlying
organizational unit. However, if you select the Organizational unit as a selection field
in the overview tree, you must enter the upper-level and underlying organizational
units as values to ensure that the same set of persons is selected.

Procedure (Restriction Using Current Hit List)
You use a functional area as required.

1. Make your selection as described in Make Selection [Page 22].

2. Under Restrict reporting set by, choose the Current hit list entry.

3. To transfer the current hit list as a reporting set, click on the Current hit list entry.

The current hit list is transferred as a reporting set, and can be used for further
selections. The number of objects is displayed in the Reporting set field.
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Set Operations
Use
You can use set operations to relate two sets of objects to each other.

Features
You can show the Set operations tab page for the set operations. The set operations process the
sets from the Object set A and Object set B fields, and write the result to the Resulting set field.

You can perform one of the following set operations:

• Create intersection

• Create union

• Set A minus set B

• Set B minus set A

If you want to use the resulting set for output, you must copy it to the Hit list.

If you require further information, see Execute Set Operations [Page 27].

Example
You want to run a report to determine which employees at your enterprise do not have a
temporary residence. You cannot select non-existent data records, so you implement the report
according to the following logic:

• First, you select all of the employees at your enterprise and copy this set to Object set A.

• You select all of the employees with a temporary residence and copy them to Object set B.

• Set operation Set A minus set B enables you to subtract all of the persons with a temporary
residence from the set of all employees. The resulting set contains all of the persons who do
not have a temporary residence.
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Execute Set Operations
Use
You can use set operations to relate two selection results (create intersection, create union,
subtract sets).

Prerequisites
You have made a selection, and the system has displayed a hit list.

Procedure
1. Choose View →= Show set operations.

The additional Set operations tab page is provided by the system. Both of the additional
 and  pushbuttons are added to the Selection tab page.

2. On the Selection tab page, choose .

The hit list is copied to the Object set A field.

3. Make a second selection.

4. On the Selection tab page, choose .

The hit list is copied to the Object set B field.

5. Choose the Set operations tab page.

The Object set A field contains the hit list from your first selection. The Object set B field
contains the hit list from your second selection.

6. To perform the required set operation, select it and then confirm by choosing Perform
operation.

The Resulting set field contains the result of the set operation. You can now process the
resulting set as follows:

− Copy to the hit list for output

− Copy to Object set A or Object set B for further set operations

− Copy to the reporting set, and then use it for further selections

7. To copy data, select the destination to which the resulting set needs to be transferred, and
confirm by choosing  Copy resulting set.

Result
The resulting set is available for further use.
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Output
Use
Ad Hoc Query enables you to output data on selected objects as required.

Features
You can select the type of output list to determine whether data is aggregated for output and if
so, how. You can select one of the following options:

• Basic list

• Statistics

• Ranked list

You can also choose the type of output. This determines how data is displayed when output:

• Interactive list

• Simple list

• Word processing

• Spreadsheet

• Private folder

• Graphic

• Crystal Reports

• Info Zoom

For more information on the types of output list and types of output, access the documentation on
SAP Query and see Interactive List Display Functions [Ext.] and Interactive Functions for Further
List Processing [Ext.]. For detailed information on how to output data as an interactive list, see
ABAP List Viewer (ALV) [Ext.].

You can also format output. This enables you to determine how data is arranged when output (for
example, the sequence of columns and output list sorting), and whether data is also aggregated
(for example, summation of numerical columns).

Activities
1. To select output fields in the overview tree, enter flags in the Value display and/or Text

display columns. You can determine the output fields at the same time as the selection fields,
or after you have made your selection. You can choose output fields from the functional
groups as required.

You can output all data on the selected persons as Values (the Value display
column), and you can also output some of the data as Texts (the Text display
column). For example, the form-of-address key: value: 01, text: Mr; value: 02, text:
Ms. If in doubt, specify both.
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2. Define output as required. For example, select a type of output list. See Define Output [Page
34].

3. Use the output preview to format output as required. See Format Output [Page 31]. If you
export data to Crystal Reports, you also determine whether a new Crystal Report is
generated or an existing Crystal Report used when data is exported. See Determine Special
Output Options [Page 35].

4. Start output.
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Output Data for Selected Objects
Prerequisites
You are advised to use data output after you have entered selection criteria. It is possible to start
output without selection criteria so that all of the objects that can be selected by the current
functional area are selected and output. However, this can result in extremely long runtimes.

Maybe you have already made a selection and edited the hit list. If you do not want to edit the hit
list, you can start output without a prior selection. The selection is made automatically before
data is output.

Procedure
1. In the overview tree, navigate to the required functional groups and functional group fields.

2. Select the required output fields by setting flags in the Value display or Text display columns.

The system transfers the fields to the output preview as columns.

3. Define output as required, and determine special output options as necessary. See Define
Output [Page 34] and Determine Special Output Options [Page 35].

4. Format output as required (by selecting the output type, for example; see Format Output
[Page 31]).

5. Choose  Output.

Result
The information on the selected objects is output in accordance with your entries.

In the standard system, the data records that meet the selection conditions are output for each
selected object. However, if you want to output all of the records that exist for each selected
object, choose Edit → Define output and deactivate the Use selection conditions indicator.

In the first step, you select all persons whose permanent residence is New York. The
result is the set of all persons whose permanent residence is New York.

If the indicator has been set, all records are output whose permanent residence is
New York. If the indicator has not been set, all other places of residence are also
output for the selected persons (for example, Tokyo and Munich as well as New
York).
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Format Output
You can format the output list before output. The output preview includes the following functions:

Function Procedure/icon What you need to know

Sort ascending

Sort descending

Select a column, and sort
ascending by choosing  or
descending by choosing .

You can use several sort
criteria.

To do so, do not select a
column, and then choose  or

. This takes you to the
Define Sort Order dialog box.
You can select output fields as
a sort criterion as required, and
determine whether the sort
performed in accordance with
this criterion is ascending or
descending.

Total Select the required column,
and choose .

A total is output at the end of
the column.

You can only create totals for
columns that contain numerical
values.

If you also want to output
subtotals, you must first create
totals using the numerical
column.

Subtotals Select the column that
contains the criterion for
subtotals, and choose .

If the criterion for subtotals
changes, a subtotal is output.

You can only use columns as a
criterion for subtotals if they
contain non-numerical values.
The list is automatically sorted
in accordance with this criterion.

If you report on the annual
salaries of your employees, for
example, you can create totals
for the annual salary column
and output a subtotal for each
organizational unit.

Delete all output fields Choose . Use this function if you want to
reuse the selection fields but
require different output fields.
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Initialize formatting Choose . This resets output formatting to
its original state. Use this
function if you no longer need to
create subtotals or totals.

The column sequence and
output type are not reset.

Determine output type Use the list to choose the type
of output required, for
example:

• Interactive list

• Word processing

Change column sequence Select the column whose
position you want to change,
and use drag & drop to move it
to the required position.

Output / do not output
currency or unit

In the basic list, currencies or
units are output automatically
in an additional column after
the value column.

To change the position of this
column, choose the following
in the context menu of the
value column:

Currency → Before the value
or After the value

Unit → Before the value or
After the value

To prevent the currency or unit
column from being output,
choose the following in the
context menu of the value
column:

Currency → Do not output

Unit → Do not output

An additional column for
currencies or units is not output
in statistics or ranked lists.

If you want to enter a reference
currency to which all currency
fields are converted, choose
Edit → Define output.



 SAP AG Human Resources Information System

Format Output

December 1999 33

Enhance statistics You can enhance statistics
with the following columns:

• Mean values

• Percentage-based
distributions

• Number of processed data
records

In the context menu of the
value column, choose Output
mean value, Output share in
%, or Output total number.

These enhancements are only
possible for numerical columns.

The various output lists include further options to enable you to edit output. For more information
on how to edit output lists, see Interactive List Display Functions [Ext.] and Interactive Functions
for Further List Processing [Ext.]. For more information on how to output data as an interactive
list, see ABAP List Viewer (ALV): Grid Control [Ext.].
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Define Output
Use
When defining output, you determine whether data is output as a list (basic list) or aggregated
before output (statistics, ranked list). You determine whether the query is started using a
selection screen and whether it includes the selection criteria that you specified. When setting up
statistics and ranked lists, you can also determine a reference currency for the conversion of
currency fields, and activate an automatic counter.

Procedure
1. On the Ad Hoc Query screen, choose Edit � Define output.

The Define Output dialog box is displayed.

2. If necessary, choose the Type of output list.

3. Enter the required options.

4. Choose .

Result
Your entries are transferred. The output functions in SAP Query are available for all types of
output. For more information on the output functions, see Interactive List Display Functions [Ext.],
Interactive Functions for Further List Processing [Ext.], and ABAP List Viewer (ALV) [Ext.].
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Determine Special Output Options
Use
The special output options enable you to determine how data is exported to Crystal Reports.
Each time data is exported, you can

• Create a new Crystal Report

• Export the data to an existing Crystal Report on your local PC

Prerequisites
Crystal Reports must be installed on your local PC.

Procedure
1. Choose Edit � Special output options.

This takes you to the Special Output Options dialog box.

2. Select the required option, and specify the menu path for the Crystal Reports template, if
required.

3. Choose .

Result
The entries are transferred for the current query. When you save the query, the path for the
Crystal Report template is saved too. However, the template itself is not saved.

It you want to be able to use the query and the Crystal Reports template together
with other users, you must put the template in a directory that can also be accessed
by these users. The template is not saved with the query, which prevents other users
from using the query and template otherwise.
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Process Selection Result in General Reporting
Use
You can only process the set of objects in reports that are based on the same logical database
as the functional area used in the Ad Hoc Query. Furthermore, you can only use reports that can
process the same object type as the one you selected in Ad Hoc Query.

Procedure
1. Make a selection (see Make Selection [Page 22]).

2. Choose Goto → Start report.

This takes you to a dialog box in which you can enter a report name, or choose a report
using input help.

You can only process the set of objects in reports that are based on the same logical
database as the functional area used in the Ad Hoc Query. Furthermore, you can
only use reports that can process the same object type as the one you selected in Ad
Hoc Query.

3. Enter a report name, or choose a report.

4. If you want to start the report via the selection screen so you can restrict particular
values, for example, you must select the Start via selection screen indicator.

5. Choose .

Result
The report you have chosen is executed for the selected objects.
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Reuse Queries
Use
You can save frequently used queries, and then reopen and execute them in Ad Hoc Query.

• If you frequently use a query with the same selection fields but different values, you should
save it without values.

• If you frequently use a query with the same selection fields and values, you should save it
with a variant, that is, with values and selection options.

You can also use saved queries as a template for new queries. To do so, open an existing query,
edit it, and save it with a new name.

Integration
You can access SAP Query directly from Ad Hoc Query by choosing Goto → SAP Query. You
can continue to process and then save the current query, if necessary. SAP Query also enables
you to access and process queries defined in Ad Hoc Query.

For more information on processing data in SAP Query, see SAP Query [Ext.].



Human Resources Information System  SAP AG

Create New Query

38 December 1999

Create New Query
Use
When a query is created, you can select the query area [Ext.], user group, and functional area.
You have access to all of the functional areas that you can access via a user group.

Prerequisites
User groups and functional areas that you can access have been created in SAP Query.

Procedure
1. Choose .

This takes you to the Create New Query - Functional Area Selection dialog box.

2. Select the query area in which you want to create the new query.

The User Groups selection list contains all of the user groups to which you are assigned.

3. Select the user group for which you want to create the new query.

The Functional Areas area lists all of the functional areas that can be accessed by the
selected user group.

4. Select the functional area that you want to use for the query.

5. Choose .

You can use the functional area to create queries.

6. Define the query as described in Make Selection [Page 22] and Output [Page 28].

7. To save the query, proceed in accordance with the instructions in Save Query [Page 39].

Result
The new query is available.
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Save Query
Prerequisites
You have defined a query. You are assigned to a user group with access to the current functional
area. If this is not the case (if you started Ad Hoc Query from the Personnel Administration info
system, for example), you cannot save queries. If you require further information, see Tips and
Tricks [Page 44].

Procedure
1. Choose .

This takes you to the Save Query dialog box. It contains a default technical name and
title for the query, which you can change as required.

2. If necessary, change the name or title of the query.

3. Choose the User group to which the new query must be assigned. At this point, you can
switch between user groups to which you are assigned and have access to the current
functional area.

4. To confirm your entries, choose .

Result
The query is saved and assigned to the selected user group.

You can save a changed query with the same name by choosing Ad Hoc Query →
Save, or with a new name by choosing Ad Hoc Query → Save as.
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Load Query
Use
Ad Hoc Query enables you to access saved queries.

Procedure
1. Choose .

This takes you to the Open Query dialog box. It contains a list of all queries and variants
that are assigned to the current user group.

2. If you want to load a query that was created in a different query area or user group, change
the query area and/or user group.

3. Select the required query.

4. Choose .

Result
The query is opened. You can now execute the query. You can also change and save the query
as required. If you want to overwrite the original version, choose Ad hoc query → Save or . If
you want to assign a new name to the changed version, choose Ad hoc query → Save as.
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Delete Query
Use
Ad Hoc Query enables you to delete queries that are no longer required.

Procedure
1. Choose .

This takes you to the Open Query dialog box. It contains a list of all queries that are
assigned to the current user group.

2. If you want to delete a query that was created in a different query area and/or user group,
change the query area and/or user group.

3. Select the query you want to delete.

4. Display the context menu (right mouse button), and choose Delete.

5. To confirm, choose Yes.

Result
The query is deleted.
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Functional Areas for Ad Hoc Query
To access data stored in the system, Ad Hoc Query uses a functional area [Ext.]. It provides you
with a view of data in specific parts of HR that is structured by infotype. On the initial Ad Hoc
Query screen, the functional area is displayed with its functional groups as an overview tree. This
overview tree enables you to choose selection fields and output fields.

The functional areas used in Ad Hoc Query are created and managed in SAP Query. When you
create a functional area, you select a logical database on which the functional area is based, and
determine which infotypes are included in the functional area. They are subsequently displayed
in the functional area as functional groups. After you have selected the infotypes, you can
determine which fields are included in the functional group for each infotype.

In the standard system, all infotype-specific fields of the selected infotypes are
included in the respective functional areas. You are advised to check the selection of
fields carefully, and adapt the selection to your reporting concept. Appropriately
adjusted functional areas are user-friendly, which makes working with Ad Hoc Query
much simpler.

The functional area determines the objects that you can select with Ad Hoc Query. The following
scenarios are possible:

• The functional area is based on logical database PNP
Functional areas based on this logical database enable you to use Ad Hoc Query to
select employees. You can use data from Personnel Administration and Time
Management as selection criteria. From a technical perspective, this means you can use
fields from infotypes 0000 to 0999 and 2000 to 2999 as selection criteria. For example,
you can use the functional area to run a report that determines which employees have a
particular place of residence.

You can also use this logical database to create functional areas that enable Ad Hoc
Query to output person-related data from Personnel Planning (infotypes 1000 to 1999),
for example, the qualifications or booked training courses of employees assigned to a
particular organizational unit. To do this, you must select infotypes from Personnel
Planning as well as infotypes from Personnel Administration when you create the
functional area.

• The functional area is based on logical database PAP
Functional areas based on this database enable you to use Ad Hoc Query to select
applicants. You can use data from Recruitment as selection criteria and for output. From
a technical perspective, this means you can use fields from specific Personnel
Administration infotypes (such as 0000, 0001, and 0002) and fields from infotypes 4000
to 4999 as selection and output fields.

• The functional area is based on logical database PCH

Functional areas based on this database enable you to use Ad Hoc Query to select
objects of one object type, such as business events, qualifications, and positions. You
can use all of the fields from the infotypes allowed for the object in question as selection
criteria and for output.
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When you create a functional area, you determine the object type that you can select
using a functional area. The generated functional area can only be used to select this
particular object type. If you want to create reports for business events, qualifications, or
positions, for example, you must create three separate functional areas. This means the
reports can only be executed separately. If you do not select an object type when you
create the functional area, you cannot use the functional area for Ad Hoc Query.

See also:
Functional Areas in the HR Application [Ext.]
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Tips and Tricks
Set User Parameters
You can set user parameters for each individual user to determine how Ad Hoc Query is started.
By doing so, you specify the query area, user group, and functional area that are started in Ad
Hoc Query for this user.

When you specify parameters and names of functional areas, make sure your entries
are entered correctly with regard to uppercase/lowercase letters.

User parameters can be overridden by starting Ad Hoc Query with report
H00_ADHOCQUERY Start HR Ad Hoc Query (see the section on accessing
customer functional areas).

Enter the following parameters and values:

• Parameter AQW for the query area

Enter one of the following values:

− Leave the field blank for the standard query area

− Enter G for the global query area

• Parameter AQB for the user group

Value: Enter the short name of the user group to be used when Ad
Hoc Query is started.

• Parameter AQS for the functional area

Value: Enter the short name of the functional area to be used
when Ad Hoc Query is started.

Access Customer Functional Areas
To ensure that the functional area you require is immediately available when Ad Hoc Query is
accessed, you can start Ad Hoc Query using report H00_ADHOCQUERY Start HR Ad Hoc
Query. When Ad Hoc Query is started this way, the system uses the specified values for the
query area, user group, and functional area.

If you want to access Ad Hoc Query with your own functional areas, you can integrate variants of
this report as transactions in area menus, or use them in activity groups.

Whenever Ad Hoc Query is started in the Personnel Administration info system, you want it to
access a functional area that is relevant specifically to Personnel Administration. Therefore, you
first define a variant with the appropriate query area, the functional area you want to use, and a
standard user group. You also activate the Ignore SET/GET parameters indicator, which ensures
that existing user parameters are overridden by the values entered at this point when Ad Hoc
Query is started. If you want to prevent the variant from being changed, you can protect it when
you save it.
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Using area menu maintenance, you can integrate the report together with the variant in the
Personnel Administration info system. Alternatively, you can include it in a user menu using an
activity group.

If you require further information on area menu maintenance, see Area Menu Maintenance [Ext.].

If you require further information on profile maintenance, see Profile Generator [Ext.].

If you do not enter a user group, Ad Hoc Query can be started for reporting purposes
by every user who has logged on using the specified functional area.

When it starts, the system determines whether the user can access the specified
functional area using a different user group. If this is the case, the user group is
specified automatically and the user can save queries for this user group. If the user
does not belong to a user group with access to the specified functional area, he or
she can create queries as required, but cannot save them.


