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Crystal Reports for Eclipse Release Notes
About these release notes

About these release notes

These notes contain important information about this product release,
including installation issues, other known issues, and information for existing
customers upgrading from an earlier release. Please read the entire document
before you install this product.

These notes were updated for Crystal Reports for Eclipse version 2.0.3. The
version number is displayed in the Eclipse Help > About dialog.

Documentation errata

The following report part preference attributes are listed in the Crystal Reports
for Eclipse Developer Guide. These attributes have been deprecated.

* enablelmageForMobileDevices
*  MobileDevicesCharSet

Installing or updating Crystal Reports for
Eclipse

You can install or update Crystal Reports for Eclipse to your Eclipse 3.4
environment, or you can add Crystal Reports for Eclipse to your Eclipse 3.5
environment.

To install Crystal Reports for Eclipse to an Eclipse
3.4 environment

Use the following steps to install Crystal Reports for Eclipse to your Eclipse
3.4 environment.

1. From the Help menu, click Software Updates.

2. Select the "Available Software" tab and then click Manage Sites.

3. Click Add, type the following URL: http://downloads.businessob
jects.com/akdlm/crystalreportsforeclipse/2 0/up
date site, and then click OK.
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Click OK.

On the "Available Software" tab, expand the downloads.businessob
jects.com check box.

Select Crystal Reports for Eclipse and the language packs that you
wish to install.

Click Install.
The "Progress Information" dialog box will be displayed.

When the "Install" dialog box appears, verify that the correct items are
selected and then click Next.
Accept the license agreement and then click Finish.

The Crystal Reports for Eclipse install will begin.

Restart Eclipse when prompted to do so.

To update Crystal Reports for Eclipse in an Eclipse
3.4 environment

Use the following steps to update Crystal Reports for Eclipse.

1.
2.
3.

From the Help menu, click Software Updates.
Select the "Available Software" tab and then click Manage Sites.
Select the following node: http://downloads.businessob

jects.com/akdIm/crystalreportsforeclipse/2_0/update _site

Click OK.

Select the" Installed Software" tab and then select "Crystal Reports for
Eclipse".

Click Update.

To install Crystal Reports for Eclipse to an Eclipse
3.5 environment

If you would like to add Crystal Reports for Eclipse to your Eclipse 3.5
environment, use the following steps.

1.

In Eclipse, select Help > Install New Software.
The "Install" dialog box is displayed.
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Click Add and fill in the following details:
+ "Name: "SAP Business Objects - Crystal Reports for Eclipse

+ "Location: "http://downloads.businessobjects.com/akdim/crystalreports
foreclipse/2_0/update_site

Click OK.
Eclipse willl connect to the URL and search for software.

. When updates are found, select the Crystal Reports for Eclipse check

box; this will automatically select all the items in the hierarchy: the product
and language packs.

Click Next.
The program will calculate requirements and dependencies.

Verify that the correct items have been selected and then click Finish.

Crystal Reports for Eclipse will be installed to your Eclipse 3.5
environment.

Restrictions

The following restrictions apply to this version of Crystal Reports for Eclipse:

Crystal Reports Java will only process reports created using Crystal
Reports 9 or later.

Reports cannot be used that access the following data sources:

+ OLAP

* Business Views

* Universes

The following capabilities are not supported in this release:

*  Report templates.

» Geographic mapping.

» Crystal Reports Repository.

* Report alerts.

Reports containing groups with the group sort option set to “original order”

can be opened, but the sort order will not change automatically. If you
require a different sort order, you must manually change the sort order.

To export a report with Crystal Reports Java, java.io.tmpdir must
be set to an absolute path.
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Crystal Reports Designer

The Crystal Reports Designer does not allow you to edit the same report
in multiple windows at the same time.

Reports that contain a named group condition with fields other than the
<group by> field will not be displayed properly in previous versions of
the Crystal Reports Designer.

The "Interactive Sort" feature, including the sorting controls, is not
supported on the report designer's Preview page.

OLE images with a transparent background do not show up correctly in
the viewers; they will be displayed with a black background.

Workaround: Before adding the object to the report, set the background
color to white or another suitable color.

The following capabilities are not supported in this release:
+  Embedding and editing integrated Flash objects.

* Creating a Saved Data Selection Formula.
» Creating or editing crosstab calculated members.

Crystal Reports Java

The JSF viewer must be in server-side state saving mode.

Web applications that store the runtime instance of a report object in a
Session object to improve efficiency, may find that reloading the jsp page
does not show report changes.

Workaround: To resolve the issue, load a new browser window to get a
new HTTP session, or restart the application server to clear the current
session cache.

Report functionality

FormulaSyntax does not support SQL syntax. (This feature is known as
SQL Expressions in the Crystal Report 2008 Designer.)

Original-order sorting is not supported for groups in crosstabs.
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The problem view will not display the list of unsupported features in your
report if you open the report outside of the workspace (for example, using
File > Open).

Workaround: To see the list of unsupported features, import your report
into the workspace before opening it.

If there is an error while generating saved data (for example, a Database
error or missing parameter values exception), the report will be saved
without the saved data. However, you will not be notified that there is an
error. This is a known limitation.

Changes to the crosstab "Column Totals on Top" property are not updated
or shown in the Preview page.

"Set location" during refresh of a subreport as a resolution will fail.

Workaround: From the Layout page, go to Crystal Reports > Set
Database Location and change the subreport's datasource location.

If you attempt to create or change a sort order on a customized group,
you will encounter a NullPointerException.

When you are working in the "Preview" page, if CanGrow is set to true
you may not be able to move an object such as a memo field to a different
section.

Workaround: Switch to the "Layout” page and then move the object.

The "Custom Grouping" setting on the "Properties" panel does not get
saved if sorting is set to "Sort by Summary Field" with Ascending or
Descending sort order.

When you insert an image object and then undo the action, the object
will not be removed from the report canvas.

Workaround: To remove an object, select it and then click the delete key.

Report objects that were created using new features in Crystal Reports
2008 cannot be modified if the feature that was used to create them is
not part of Crystal Reports for Eclipse.

When you open a report that contains an unsupported object in Crystal
Reports 2008 and in Crystal Reports for Eclipse, the unsupported object
may not be in the same position in both versions.
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Platform-specific issues

* On Sun’s JVM, the following error message may appear:
“java.lang.OutOfMemoryError: PermGen space”

Workaround: update your eclipse.ini file with the following settings:

* -vmargs
e -Xms40m
o -Xmx512m

¢ -XX:MaxPermSize=256m

Refer to Eclipse Bugzilla bugs 129490 and 92250 for more details.

»  Removing a facet removes files from the lib directory but not from the
build path. This may cause errors to appear in the Problems view.

»  On IBM Websphere 6.0, exporting doesn’t work for all export formats.

* On Sun JVMs before version 1.5.0_07, a java.awt.color. CMMException
may occur in a multi-threaded environment when loading a report that
contains an OLE Object image.

*  When using the BEA WebLogic server, it may be unable to resolve the
report location and you may see the error, “Report cannot be found”.
There are two ways to resolve this problem.

Workaround 1:

1. Remove the <reportlocation> element from the CRConfig.xml file.

2. Place your .rpt files in the WEB-INF/classes folder of the WAR file.
Alternatively, package the .rpt files in a JAR file and place it in the
WEB-INF/lib folder.

3. Wheninvoking the ReportClientDocument . open method to obtain
a report client document, use the report name as the value of the
report location parameter. For example, the report location could be
specified as /myReport. rpt, where myReport. rpt is either located
inthe /WEB-INF/classes folder orin a JAR file located in the /WEB-
INF/1ib folder.

Workaround 2:
1. Remove the <reportlocation> element from the CRConfig.xml file.
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2. Modify your JSP to use the absolute path to the report name. For
example, you could call clientdoc.open (application.getRe
alPath("") + "\\" + "YourReport.rpt", 0).

Note:
For workaround 2, you do not need to move the report files.

When running JSP code to view a report in Konqueror, an error message
may appear. Konqueror is not a supported browser.

Workaround: Use a supported web browser.

Viewing Crystal Reports applications with the Crystal Reports DHTML
Viewer on installations of Business Objects Enterprise using the Tomcat
web server results in the following error: NoClassDefFoundError .

Workaround: Include the xalan. jar library when deploying DHTML
Viewer applications on Business Objects Enterprise installations with
Tomcat.

When running web applications through the Eclipse IDE using the JBoss
server, some files may not be deployed and some JSP pages may appear
to be blank.

Workaround: restart the JBoss server.

On Microsoft Vista, you cannot use the default double-click speed for the
mouse to open a subreport.

Workaround: Set the double-click speed to a slower speed, such as
twenty-five percent (25%).

Formatting and rendering

Vertical text object rendering in the DHTML Viewer is not supported for
Firefox. It is supported only for Internet Explorer.

To undo a drag and drop action within a text object, click Undo twice.

In text-object editing mode, the first tab mark inserted before a field object
at the beginning of a paragraph is not displayed.

When you create a new text object in a report, if the property “first line
indentation” of the text object is set to a negative value, the text will be
displayed only after the cursor has passed the left indentation.
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Formatting and rendering

When editing a paragraph in a text object, the text object displays the first
tab mark but not any other tab marks.

In a text object, formatting the text in a multi-line paragraph will cause the
text being formatted to break away as a new line.

The following table describes how Crystal Reports Java behaves when
opening and saving reports at runtime with the following unsupported

features:

Feature

Report alerts

Crystal Reports Java
behavior when open-

ing a report with this
feature

Alerts are not triggered

Crystal Reports Java behav-
ior when saving a report with
this feature

Alerting information in the re-
port definition is preserved.
However, alerting views are not
preserved.

Geographic maps

Converted to a text
object.

The original state is not pre-
served.

Crystal Reports 9
report charts with
textures and pic-
tures

Converted to a text
object.

The original state is not pre-
served.

Chart label place-
ment

If labels are moved,
they are reset to their
default positions.

Preserved in the report defini-
tion.

sorting

Parameterized Supported. Full support.
sorting
Hierarchical group | Supported. Full support.
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Feature Crystal Reports Java Crystal Reports Java behav-
behavior when open- ior when saving a report with

ing a report with this this feature

feature
Formula function | Supported (except Full support.
additions Crystal Enterprise time
zone)
Dynamic prompts | Supported. You cannot edit a dynamic

cascading prompt. If the
prompt is not a parameter, it
will be converted to a parame-

ter.
Grid enhance- Supports flattening Flattened column headings are
ments column headings for |preserved. Drill-through view
crosstabs. is not preserved.

Printing and exporting issues

Exporting to Excel (page based) issues

Crystal Reports for Eclipse may not have the same results as Crystal Reports
2008 when you use a page-based Export to Excel feature.

When there is a cross-tab in the report, column truncation may not be at
the same point.

Report outputs may take up more rows in Java due to differences in how
characters are rendered in Java and Windows. For example, a description
field that would export to 21 rows in Crystal Reports 2008 may take 23
rows in Crystal Reports for Eclipse.

If the report contains a subreport, only the information that is displayed
on the current page will be exported ("What you see is what you get").
For example, if you have a text object in your subreport, but it is in a field
that is not displayed when you choose to export the report, it will not be
included in the output

If you use System Default Format for the date and time style in your report,
you may notice a slight difference in the appearance of the date format
in your exported report.

For content that crosses pages, there will no longer be a blank row where
the page end would have been in the report.
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The blank space between the last object and the page footer is ignored.

Other printing and exporting issues

The Export button is enabled from the "Preview" page only, not from the
"Layout" page.

You may experience problems when exporting images to Excel (Data
only) if you are using a version of Java that is older than Java 5 update
7.

Workaround: Ensure that you are using Java 5 or Java 6 with Crystal
Reports for Eclipse.

The print outputs from Mac OS X 10.4 (Tiger) may have problems such
as improper scaling or unclear text.

You should be notified that licensed fonts are not embedded when
exporting a report to PDF format. However, no warning message is
displayed.

When exporting to PDF format, Right-to-Left languages may not be
exported properly.

Printing reports with mixed page orientation using the Java Applet Viewer,
Java Bean Viewer, or Java Print Control may not print correctly or may
freeze the application.

Workaround: To print these reports, please export the report to PDF.

When you export to PDF on a Unix machine, the text will not be exported
properly if the font is not found.

Workaround: Place the font in a location where it can be loaded. For
example, place the fonts in JRE/1ib/fonts .

The "ActiveX Print Control" does not work for DHTML viewers in web
applications deployed on the Netweaver (SAP) Web Application Server.

Workaround: Either export the report to PDF and then print, or use Print
to PDF from within the DHTML viewer.

When you export a report with snippet code (for example, CRJava
Helper.exportXXX ()) using the Report Page Viewer's runtime, the
viewer jsp will not check or prompt for database logon. A Logon Error will
be encountered if database logon credentials are not supplied in the code.
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Workaround: Use the following Crystal Reports code snippet to specify
the logon information when creating the report viewer jsp

Set Runtime database credentials

Relational databases and SQL statements

When loading a report on the SunOne8 application server or the Oracle
10g application server, you must specify the absolute path instead of a
relative path.

Using the Crystal Reports Java Set Location commands to change the
location of a table from ODBC to JDBC/JNDI enables the report to be
refreshed only in Crystal Reports Java.

Workaround: To enable a report refresh to work in the Crystal Reports
Designer, provide the JNDI server information in the Set Location
command.

If the Datafields field in a report is a formula field, the Don’t summarize
option will be absent from the field’s properties.

When adding multiple SQL statements into a SQL scrapbook page
(right-click Crystal Reports > Add to New Report ), only the first SQL
statement is added to the report. This problem happens when using a
Derby database.

Searching a list of values (LOV) is case sensitive when using an Oracle
reporting database. This is due to a limitation in Oracle.

Picture, memo, and other blob fields will not be mapped to a new location
when you use the Data Source Explorer to change the datasoure location.
This is a known issue for the Data Source Explorer within Eclipse specific
to Microsoft SQL Server with blob fields.

Refer to Eclipse Bugzilla #201120 for more details.

Language-specific issues

Crystal Reports Java interprets right-to-left text at the paragraph level,
but not at the character level; therefore a mix of right-to-left and left-to-right
texts in a paragraph may be displayed incorrectly.
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When exporting to RTF format, Arabic and Hebrew characters will be
encoded properly if you use Unicode. If you use a different character set,
they may not be encoded properly.

In operating system locales that use a comma as the decimal separator,
such as German or Italian, decimal alignment doesn’t work properly due
to a Swing bug.

The Numeric Format selection choices show the decimal separator
characters as they appear in the EN locale. However, the numeric formats
in the reports are displayed with the correct decimal separator character
for your locale.

The following locale-dependent functions are supported in the EN locale
only:

« Totext() -- Number, Currency, Date, Time, and DateTime
* CStr() -- Number, Currency, Date, Time, and DateTime

» CDate(String)

»  CTime(String)

» CDateTime(String)

+ IsDate(String)

* IsTime(String)

» IsDateTime(String)

+ DateTimeValue(String)

*  TimeValue(String)

» DateValue(String)

Developer issues

Before you can open a report using a relative path, you must first verify
that your web server expanded the .WAR files during deployment.
Projects created by the Crystal Reports Java wizard contain a helper
class, CRJavaHelper. The methods in this class are not thread-safe. If
you call the methods in the CRJavaHelper class from your application
at the same time another thread is accessing the report engine (for
example, from a viewer) a ConcurrentAccessException may be
thrown.

Note:
CRJavaHelper class and its methods are intended to be used as samples
only.
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To use ws-security with the XML and Web Services driver, you must add
the BouncyCastle security provider to the project and the CRConfig.xml
file.

1. Download the BouncyCastle provider, bcprov-jdk15-132.jar,
from http://www.bouncycastle.org and copy it to your classpath (for
example, JRE\1lib\ext ).

2. Editthe JRE\1lib\security\java.security file to include the
following line:

security.provider.n=org.bouncycas
tle.jce.provider.BouncyCastleProvider

3. Editthe CRConfig.xml file to add the <AdditionalClasspath> element.
If a rampart password handler is used, replace pathname with the
system path to the rampart password handler:

<Javaserver-configuration>
<XML>
<AdditionalClasspath> pathname <AdditionalClass
path>

</XML>
</Javaserver-configuration>

Report Functionality
» Crosstab charts and group-level charts are not supported by the SDK.

Workaround: You can simulate group-level charts and crosstab charts
by creating detail-level charts with similar grouping.

* The writeExternal method of the ReportClientDocument class is
not supported.

* Loading a crosstab object with the XxMLObjectSerializer class
does not preserve Border and ObjectFormat properties of the crosstab
object.

* The getCurrentValues method of the ParameterField class
returns integer values as strings when they are set as strings. This
differs from previous releases, where integer values set as strings
were returned as integers.
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Example:

setCurrentValue ("1234") ;

Old behavior:

getCurrentValue (); returns the integer 1234

Current behavior:

getCurrentValue (); returns the String "1234"

When using specified grouping with dates, times, or date/times, use
the SpecifiedDateGroupOptions classinstead ofthe Specified
GroupOptions class.

Using the SubreportController class to add or remove subreport
links changes the client model but does not maintain the change when
the report is saved and reloaded.

Workaround: Clone the SubreportLinks object before modifying the
subreport links.

Example: The following code snippet modifies subreport links, but
does not maintain the change when the report is saved and reloaded:

String subrptName = "Employee";

SubreportLinks subrptlLinks = null;

subrptLinks = rptDoc.getSubreportController () .get
SubreportLinks (subrptName) ;
subrptLinks.remove (0) ;
rptDoc.getSubreportController () .setSubre
portLinks (subrptName, subrptLinks);

Workaround: Clone the SubreportLinks object before using the
controller to modify the links:

SubreportlLinks newSubrptLinks = (SubreportLinks)
subrptLinks.clone (true) ;
newSubrptLinks.remove (0) ;
rptDoc.getSubreportController () .setSubre
portLinks (subrptName, newSubrptLinks) ;

When changing the order of a group to specified order, you must
change the sort direction to noSort in order for the changes to take
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effect. In previous versions, setting the sort direction to noSort
happened automatically.

Example:

IGroup oldGroup = ..;

IGroup newGroup = (IGroup) ((IClone)old
Group) .clone (true) ;
ISpecifiedGroupOptions sOpt = ..;

newGroup.setOptions (sOpt) ;

ISort sort = new Sort():;
sort.setDirection (SortDirection.noSort) ;
newGroup.setSort (sort) ;

rptdoc.getDataDefController () .getGroupCon
troller () .modify (oldGroup, newGroup) ;

Crystal Reports for Eclipse does not support modifying Flash objects.
If a Flash object is bound to a dropped or changed Database field,
then you will see a NullPointerException error when you try to
call DatabaseController.verifyDatabase () or DatabaseCon
troller.checkDatabaseAndUpdate ().

Sometimes there are more values in the list of values then are available
when prompting.

When retrieving an LOV (List of Values) , the fields from lower-level
LOVs are not included in the generated query in order to improve
performance by retrieving less data for each row. However, if a field
in a lower-level LOV is joined to the table used by the LOV, then
excluding the lower-level field has the side-effect of excluding the join
operation.

Workaround: If the join operation is required in order for the LOV to
return the desired results, then define the LOV to a use a command
table (SQL Command) which includes the required fields and joins.

The parameter field usage returned is “not in use” after a subreport
parameter field is added to a saved data formula and the reportdoc
ument is refreshed.

Workaround: You will need to resync the subreports by setting the
database logon and using ReportClientDocument.verify
Database ()
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Importing an existing project that uses the Crystal Reports components
may cause errors such as the following:

<classname> cannot be resolved to a type.

<classname> is a Crystal Reports Java SDK class. There are two
ways to resolve this problem.

Workaround 1:

1. Uncheck the Build Automatically option in the Project menu.
2. Import the project.

3. Recheck the Build Automatically option.

Workaround 2:

1. Delete the imported project.
2. Re-import the project.

Note:
Before deleting the project, verify that you have a backup of the original
project.

To avoid ConcurrentAccessExceptions, applications that use
the Crystal Reports DHTML viewer should always ensure that the
same ReportSource object is used for each request. Cache the report
source object returned from the ReportClientDocument in the
current session and re-use it until the document is properly closed.

*  Formatting and rendering

Crystal Reports Java does not currently process page headers or page
footers in the drill-down views.

If you have a print-time side-effecting formula in the page header or
page footer, it will not be evaluated. Formulas that depend on the
side-effect will show different results in the drill-down view than in the
main report view.

Web pagination functions are not supported in the Crystal Reports for
Eclipse SDK at this time.

* Relational databases and SQL statements

SDK does not correctly set null values for stored procedure parameters.
Verify on reports with stored procedures - or command objects that
use parameters - will only work if the stored procedure or command
can be executed with empty/default values.
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As of Crystal Reports for Eclipse version 2.0 SP2, setTableLoca
tionand replaceConnection can be used to change a database
connection for a parameterized table (for example, a stored procedure)
or to change an SQL command. However, adding new parameters is
not supported.

When using the setDataSource method of the DatabaseController
class with a report that uses POJO datasources, setting both
oldTableAlias and newTableName parameters to the empty string
causes the POJO data source to be returned as the data source for
all tables in the report.

When you use the setDataSource for an XML table and the table
name in the new schema does not match eitherthe o1dTableAlias
or the newTableName value, the table will be removed from the report.

Where possible, ensure that the table name in the new schema is the
same as the original table name.

The mapFields method of the DatabaseController class does not
support mapping a string field to a memo field.

The XML driver does not support the case where the XML and XSD
logon information is not identical. The XML driver uses the same user
name and password for both XML and XSD access.

The CONNINFO CRQE LOGONPROPERTIES property of the Proper
tyBagHelper class is no longer supported. To access the server
name, server type, and database name, use the following properties:

© CONNINFO CRQE SERVER NAME
© CONNINFO CRQE SERVER TYPE
© CONNINFO CRQE DATABASENAME

Migrated applications that use the CONNINFO CRQE LOGONPROPER
TIES property will need to be modified to access these properties
individually.

Example:

PropertyBagHelper.getAttributes () .getStringVaue (CON
NINFO CRQE SERVER NAME) ;
PropertyBagHelper.getAttributes () .getStringVaue (CON
NINFO CRQE SERVER TYPE) ;
PropertyBagHelper.getAttributes () .getStringVaue (CON
NINFO CRQE DATABASENAME) ;
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The setTablelLocation, replaceConnection, and mapFields
methods of the DatabaseController class should not be used in an
application that uses the designer SDK (extension points), as a user
is able to undo these actions from the Edit menu. Undoing these
actions is not supported.

Language-specific issues

If any of the following fields in a report are formatted using the System
Default format (long or short), some languages may not format the
values correctly in Crystal Reports Java:

+ Date

« Time

+ DateTime
* Number

Workaround: To maintain the same formatting result, the report
designer should specify the actual format.

When you use GroupController.modify to set the conditional formula
for group sort order, you will need to make a deep clone of the old group
to create your new group.

1. Type the following to create a new group:

IGroup theNewGroup = (IGroup) theGroup.clone (true);

. To modify the new group, type something like the following command:

theNewGroup.setOptions (dateGrpOption) ;

. Then modify the group using GroupController.modify asin the

following example:

rptDoc.getDataDefController () .getGroupCon
troller () .modify (theGroup, theNewGroup) ;

The sample code that follows shows how to use this information:

public static void setDataGroupOption (ReportClientDoc
ument rptDoc, String text)

{

DataDefController m dataDefController = null;
IGroup theGroup = null;
try
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m_dataDefController = rptDoc.getDataDefCon
troller();

theGroup = m dataDefController.getDataDef
inition () .getGroups () .getGroup (0) ;

IGroup theNewGroup = (IGroup) the
Group.clone (true) ;
IGroupOptions newGrpOption = theNew
Group.getOptions () ;
GroupOptionsConditionFormulas conditionFor
mulas = null;

IDataConditionFormula conditionalFormula
= (IDataConditionFormula) new DataConditionFormula () ;

conditionalFormula.setText (“1”) ;

conditionFormulas = (GroupOptionsCondition
Formulas) theNewGroup.getOptions () .getConditionFormu
las();

conditionFormulas.setFormula (GroupOption
sConditionFormulaType.sortDirection, conditionalFormu
la);

newGrpOption.setConditionFormulas (condi
tionFormulas) ;

theNewGroup.setOptions (newGrpOption) ;

rptDoc.getDataDefController () .getGroupCon
troller () .modify (theGroup, theNewGroup) ;

}

Accessibility

To have a screen reader, such as JAWS, work properly with the Crystal
Reports Designer, you must install the Java Access Bridge. You can
download the Java Access Bridge from the following location:
http://www.sun.com/accessibility/downloads. jsp.

To use the Java Access Bridge with IBM JVM 1.5, you must redistribute
some jar files. For more information, see the readme.txt file at the following
location: http://java.sun.com/javase/technologies/accessi
bility/accessbridge/.
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Viewer issues

Viewer

The screen reader, JAWS, maps shortcut keys that are different than the
key combinations used in Crystal Reports.

Workaround: In the JAWS Keyboard Manager, reset the key bindings of
Alt+Up Arrow, Alt+Down Arrow, Ctrl+Home, and Ctrl+End to match the
functionality of those key combinations in Crystal Reports

The drill-down feature in the Preview page is unavailable from the
keyboard.

JAWS fails to announce the fields in the Crystal Reports designer palette.
For more information, see Eclipse Bugzilla bug 146620.

JAWS announces the Crystal Reports designer palette label as a slider.
For more information, see Eclipse Bugzilla bug 146859.

issues

Characters that should be displayed vertically in a report may not be
exported to PDF format with the correct orientation.

In order to properly view Flash objects in reports, you must first have a
flash player installed on your system.

An empty chart will show up as a grey rectangle when you use Internet
Explorer 6 to view the report, and as a white rectangle when you use
either Internet Explorer 7 or FireFox.
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