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Introduction to Dashboards and Presentation Design

Dashboards is data visualization software that allows you to create and export interactive dashboards
from Excel spreadsheets or other external data sources. These dashboards contain various components,
such as charts, gauges, and dials, that are bound to data sources. The components display the data
in a compact and visual manner.

Presentation Design is a presentation tool that enables users to create and export interactive dashboards
from Excel spreadsheets.

Both products have much in common and are documented in this single user guide. Both products use
the term “model” to describe the dashboard that is being designed.

Both products also include a fully functioning Excel spreadsheet. Data and supported Excel formulas
can be imported or entered directly into the embedded spreadsheet and then modified as required. In
addition, Dashboards includes the ability to link external data sources, such as data stored in SAP
BusinessObjects Business Intelligence platform (the “BI platform”) repositories, directly to the embedded
spreadsheet or components in the model.

2.1 Product editions

This section lists the features included in each product edition. All editions have the same basic
functionality; the main differences between editions are the formats that models can be exported to,
the ability to access and configure external data connections, and the number of external data
connections that are supported.
• SAP Crystal Presentation Design enables users to create models with Microsoft Excel spreadsheets.

These models cannot be exported to Flash.
• SAP Crystal Dashboards, personal edition includes all the features of SAP Crystal Presentation

Design, plus it enables users to create models and connect them to a maximum of two external data
sources. These models can also be exported to Flash.

• SAP Crystal Dashboards, departmental edition includes all the features of the personal edition, plus
it enables users to create models with an unlimited number of data sources and deploy them as a
standalone model, or to SAP Crystal Reports Server.

• SAP BusinessObjects Dashboards enables users to create models with an unlimited number of data
sources and deploy them as standalone models or to SAP BusinessObjects Business Intelligence
platform (the "BI platform"), SAP BusinessObjects Edge Series, or SAP NetWeaver BW environments.

Throughout this guide, these four product versions are collectively referred to as Dashboards.

The following table summarizes the components available in each edition of the software:
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SAP BusinessOb-
jects Dashboards

SAP Crystal Dash-
boards, depart-
mental edition

SAP Crystal Dash-
boards, personal
edition

SAP Crystal Pre-
sentation DesignComponent

Basic data presen-
tation components

Themes and color
schemes

Play Control, Play
Selector, and Ac-
cordion Menu

Interactive Calen-
dar, Panel Set,
History, Trend An-
alyzer

Reporting Ser-
vices button

Slide Show, Con-
nection Refresh
button, SWF
Loader

Query Refresh
button, Query
Prompt Selector

The following table summarizes miscellaneous features available in each edition of the software:
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SAP BusinessOb-
jects Dashboards

SAP Crystal Dash-
boards, depart-
mental edition

SAP Crystal Dash-
boards, personal
edition

SAP Crystal Pre-
sentation DesignFeature

Departmental Edi-
tion connections
plus:

Query as a Web
Service

SAP NetWeaver
BW

Personal Edition
connections plus:

Web Service (un-
limited)

XML Data (unlimit-
ed)

Portal Data

LCDS Connec-
tions

Live Office

Web Service (2
connections maxi-
mum)

XML Data (2 con-
nections maxi-
mum)

Flash Variables

Crystal Reports

FS Command

External Interface

NoneData connectivity

SAP BusinessOb-
jects Business In-
telligence platform
4.0

SAP Crystal Re-
ports Server 2011Not availableNot availableBI platform con-

nectivity

Xcelsius Interac-
tive viewing li-
cense

SAP Crystal
Dashboard View-
ing option

Not availableNot available

Viewing license
required for con-
nected dash-
boards

None

Maximum of 100
named users can
view a given
dashboard

SAP Busines-
sOne is the only
supported SAP
application

Cannot be used
with SAP Busines-
sObjects Busi-
ness Intelligence
platform or SAP
Edge BI

Maximum of 2
Web Service or
XML Data connec-
tions total in any
one model

Does not support
external data con-
nections

Limitations
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2.2 File formats and object types

Dashboards models conform to the Adobe Flash file format, SWF. SWF is the vector-based graphics
format designed to run in the Adobe Flash Player. Because a Flash file is vector-based, its graphics
are scalable and play back smoothly on any screen resolution, and the file usually has a smaller file
size than other animation formats.

When saved locally, Dashboards files are stored in a zipped format with an XLF extension. The XLF
file format contains the model information and its associated embedded spreadsheet file. This file must
be opened in the designer (Dashboards or Presentation Design).

Note:
Newer Abode Flash versions have security features that may prevent models from connecting to an
external data source when running them outside the designer. If you cannot connect to an external data
source, see Adobe Flash Player Security Restrictionsfor more information.

When saved to a BI platform repository, Dashboards models are saved as Dashboards objects. These
objects contain both the design document (XLF) and the Flash file (SWF) in a single object.

If the object is opened in Dashboards or in the translation management tool and modified, the SWF
cached in the Dashboards object is automatically updated to reflect the changes. You do not need to
re-export the Flash object separately for users to receive the latest changes.

Note:
The BI platform repository may also contain Xcelsius objects and Flash objects created in earlier versions
of the software. For more information about using and importing these documents to Dashboards, see
Importing files created in previous versions of the software.

Related Topics
• Adobe Flash Player Security Restrictions
• Importing files created in previous versions of the software
• To import XLF files created in Xcelsius 4.5 or Xcelsius 2008

2.3 About this document

Since SAP BusinessObjects Dashboards, SAP Crystal Dashboards, and SAP Crystal Presentation
Design share many of the same features, they are documented together in this user guide. If a feature
or function is available only in a specific product edition, a note at the beginning of the procedure
indicates those restrictions. In addition, the table in the product edition section outlines the features and
functions available in each edition.
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This document includes procedures for creating models including: adding and configuring components,
linking components to data, configuring external data sources, and exporting models to different formats.
Use this document as a reference for creating basic and advanced models.

Locate information quickly
• Access online help from the program's Help menu.
• Access a PDF version of the Dashboards and Presentation Design documentation on the SAP Help

Portal at http://help.sap.com/, under SAP BusinessObjects > All Products.

Related Topics
• Product editions

2012-03-1513

Introduction to Dashboards and Presentation Design

http://help.sap.com/


2012-03-1514

Introduction to Dashboards and Presentation Design



Getting Started

This section provides general information regarding: the Dashboards workspace; file extensions; sample
models to help you learn the program's features; and notes on backwards compatibility.

3.1 Sample models

As you are learning how Dashboards works and what it can do, it can be helpful to examine sample
models as they appear during runtime, as well as the underlying configuration and bindings of their
components.

The software includes several sample models that illustrate how some of the components and functions
work. Each sample includes its own embedded spreadsheet data, so you can see how the components
are bound to the data in the spreadsheet. Use these samples to help you understand how to configure
similar functions in your own model, or even use them as a starting point and customize them for your
own needs.

Note:
Since samples include their own sample spreadsheet data, opening a sample file overwrites any data
currently in the embedded spreadsheet.

3.1.1 To view the sample models

1. Click File > Samples.
The "Samples" dialog box opens.

2. In the Category list, click User Guide Samples.
A list of the available samples opens in the Items list.

3. In the Items list, click a sample.
A fully interactive preview of the model is displayed in the "Preview" pane.

4. Click OK.
The sample file opens.

5. To view the model as the dashboard consumer would see it, click Preview.
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3.2 Understanding the workspace

Before you begin designing models, take a moment to familiarize yourself with the interface. The
workspace and its major features are illustrated below:

1. "Components Browser"
2. "Object Browser"
3. "Query Browser"

Note:
This is not available in Presentation Design.

4. Canvas
5. Embedded spreadsheet
6. "Properties" panel

Note:
The title of this panel reflects the component you currently have selected.
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The first four of the above features are discussed in this section. See the related topics below for
information regarding the embedded spreadsheet, and see each individual component category section
for specific component properties.

Related Topics
• Understanding the embedded spreadsheet
• Using components

3.2.1 Toolbars and buttons

The software includes five toolbars that you can use when working with models: standard, theme,
export, format, and start page.

To show or hide toolbars
• To toggle between showing and hiding a toolbar, click View > Toolbars and click the toolbar name.

A checkmark beside a toolbar name indicates that the toolbar is currently showing.

Standard toolbar
The standard toolbar contains buttons for completing general tasks. The following table describes the
available buttons and their keyboard shortcuts, if any:

Keyboard ShortcutDescriptionIcon

CTRL + NNew Document

CTRL + OOpen File

CTRL + SSave

CTRL + PPrint

CTRL + XCut

CTRL + CCopy

CTRL + VPaste

CTRL + ZUndo

CTRL + YRedo

Selection Tool

Component Tool

CTRL + Shift + IImport Spreadsheet
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Keyboard ShortcutDescriptionIcon

CTRL + MManage Connections

Increase Canvas

Decrease Canvas

Fit Canvas to Components

Fit Canvas to Window

Quick Views

CTRL + EnterToggle Preview Mode

Themes toolbar
The themes toolbar contains the following buttons for working with themes:

DescriptionIcon

Change Theme

Change Color Scheme

Export toolbar
The export toolbar contains the following buttons for exporting your model to specific formats:

DescriptionIcon

Export to PowerPoint

Export to Microsoft Word

Export to Microsoft Outlook

Export to Adobe PDF

Format toolbar
The format toolbar contains buttons for adjusting components on the canvas. The following table
describes the available buttons and their keyboard shortcuts, if any:
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Keyboard ShortcutDescriptionIcon

CTRL + GGroup Components

CTRL + Shift + GUngroup Components

Align Left

Center Horizontally

Align Right

Align Top

Center Vertically

Space Evenly Across

Space Evenly Down

Make Same Width

Make Same Height

Make Same Size

CTRL + NumPad +Bring to Front

CTRL + NumPad -Send to Back

NumPad +Bring Forward

NumPad -Send Backward

Start Page toolbar
The start page toolbar only contains one button, which is used to toggle the start page. The start page
provides shortcuts to create new files or to open existing files, and it also displays any online news
relevant to Dashboards.

DescriptionIcon

Open Start Page

3.2.2 To set global font options
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By default, you can specify different fonts for different components. However, you can set up a global
font so the same font is used for all components. The global font can be based on device fonts (fonts
available on your machine) or on embedded fonts (fonts embedded in the exported SWF file).

When device fonts are used, the exported file is smaller, but the text cannot be rotated and does not
use anti-aliasing. When fonts are embedded, you can rotate text and the text uses anti-aliasing, but the
exported file size is larger and the model takes longer to load.

Note:
If you set different fonts for different components, the fonts used are all device fonts. So, if the specified
fonts are not available when the model runs (on a different computer), another font is substituted for
the missing font and the model may appear different than when it was created.

1. Click File > Document Properties.
The "Document Properties" dialog box opens.

2. In the "Document Properties" dialog box, select Use Global Font.
The options for setting up global fonts are enabled.

3. From the list, select the font you want to use for all components.
4. Select one of the following options:

DescriptionOption

Fonts are not embedded in the exported file. Device fonts use the Flash player
to render the specified TrueType fonts. If a specified font is not available at the
time the model runs, another similar font is used. By default, the software uses
device fonts.

Tip:
If a model requires the extended character set defined by Unicode, it is recom-
mended that you use device fonts.

UseDevice Fonts

Fonts used in models will always be available when the model runs, text can
be rotated, and anti-aliasing is used.

Note:
Embedding the fonts increases the file size and the amount of time required
to load the model.

To change the text characters that are embedded in the exported file, click
Advanced, select the characters you want to embed, and click OK.

Restriction:
Asian characters sets cannot be embedded.

Use Embedded
Fonts

5. Click OK.
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3.2.3 Using the Components browser

The "Components" browser lists all the components that are available to add to your model. From this
list you can drag components onto the canvas to add them to your model.

You can view the list of components grouped into functional categories (Category or Tree view) or as
an alphabetical list (List view). Components are grouped into the following functional categories:

DescriptionCategory

A list of components you added to this list.

Note:
The "Favorites" category is available only in Category and Tree views.

• To add components to the favorites list, in Category or Tree view, right-click
the component and select Add to Favorites.

• To remove components from the favorites list, in the favorites list, right-click
the component and select Remove From Favorites.

Favorites

Chart components allow you to create visual representations of data to make it
easy for dashboard consumers to see comparisons, patterns, and trends.

Charts

Container components group and display other components.

Note:
Container components are not available in Presentation Design.

Containers

Selector components allow the dashboard consumer to dynamically select data
at runtime.

Selectors

Single-value components can be linked to a single cell in the spreadsheet and
can either allow dashboard consumers to change the value in that cell or display
the product of a formula from that cell.

Single Value

Map components provide geographical representations that allow you to display
data by region.

Maps

Text components can be used to add labels to your model, or to allow the dash-
board consumer to enter text at runtime.

Text

The Other category includes various components that can enhance the model,
such as calendars, trend icons, panel sets, and print buttons.

Other
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DescriptionCategory

Art & Backgrounds components allow you to visually enhance your model by
adding images and backgrounds.

Art & Backgrounds

Web connectivity components allow data retrieval at runtime to by linking models
to the Internet.

Web Connectivity

Universe connectivity components allows users to interact with Universe connec-
tions such as refreshing data and entering prompt values.

Note:
Universe Connectivity components are not available in Presentation Design.

Universe Connectiv-
ity

Category view
In Category view, the components are grouped in a sliding accordion menu. To navigate to the
components, click a category title or scroll down to open each category in sequence. Each category
displays a visual representation of the components.

Tree view
In Tree view, the components are organized in folders according to their category. To navigate to
components, click the folders to expand the categories and see the list of available components.
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List view
In List view, all components are organized alphabetically and are not grouped by functionality.

To navigate to components in this view, click anywhere within the window, and type the first letter of
the component or scroll up or down to find the desired component.

3.2.4 Using the Object Browser

The "Object Browser" provides a list of the components that are currently part of your model. You can
use the "Object Browser" to select and manipulate these components, as well as to lock or hide them
on the canvas.

2012-03-1523

Getting Started


