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Introduction to SAP Crystal Reports for Enterprise

Introduction to SAP Crystal Reports for Enterprise

1.1 About Crystal Reports

Crystal Reports is designed to work with your database to help you analyze and interpret important
information. Crystal Reports makes it easy to create simple reports, and, it also has the comprehensive
tools you need to produce complex or specialized reports.

Create any report you can imagine

Crystal Reports is designed to produce the report you want from virtually any data source. Formulas,
cross-tabs, subreports, and conditional formatting help make sense of data and uncover important
relationships that might otherwise be hidden. Geographic maps and graphs communicate information
visually when words and numbers are simply not enough.

Extend reporting to the Web

The flexibility of Crystal Reports doesn't end with creating reports — your reports can be published in
a variety of formats including Microsoft Word and Excel, E-mail, and even over the Web. Advanced
Web reporting lets other members of your workgroup view and update shared reports inside their web
browser.

Incorporate reports into applications

Application and web developers can save time and meet their users needs by integrating the report
processing power of Crystal Reports into their database applications. Support for most popular
development languages makes it easy to add reporting to any application.

Whether it's the web master in IT, the promotion manager in marketing, the database administrator in
finance or the CEO, Crystal Reports is a powerful tool designed to help everyone analyze and interpret
the information that's important to them.

1.2 Ahout the online help

The online help includes procedures for typical reporting tasks such as placing objects, formatting
reports, and sorting records. It also contains information on more specific areas of interest such as
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advanced formula creation and accessing different types of data. Use the online help as a reference
for your basic reporting needs as well as an introduction to new concepts in report creation.

1.3 Understanding examples in the documentation

The Crystal Reports documentation describes how to connect to a variety of data sources and how to
add information to the report designer from those data sources. It also provides example code for the
functions. Although the terminology may refer to databases and fields, the instructions also apply to
data sources such as universes and queries that contain result objects.

For the sake of simplicity, sample folder and object names are used in the instructions and in the function
code examples. The following code sample shows how the folder and object names may be used:

Average ({orders.ORDER AMOUNT}, {customer.CUSTOMER ID})

Many examples use objects from a Customer folder and numeric values from an Internet Sales folder.
There may be other objects in the documentation, but the following table shows the most commonly
used objects.

Customer
Customer string
City string
State-Province string
Country string
Internet Sales Amount numeric
Internet Order Quantity numeric

These objects will usually be displayed as follows:
*  Customer

 Internet Sales Quantity

+  Country
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Iintroduction to Reporting

This section shows you the basics of creating a report in SAP Crystal Reports for Enterprise. First you
will learn about the report design environment, and then about how to select result folders, place
elements on a report, and how to sort, group, and total your report data.

2.1 About the report design environment

This section introduces you to some of the important areas of Crystal Reports that you will use most
when creating reports.

2.1.1 Report design canvas

The report design canvas is the area where you design the structure of your report. You can place
various elements on the canvas including data objects, charts, and text elements.

Two views are available for laying out the information and previewing it. One view shows the structure
only ("Structure" mode) and the other view is a page that includes data ("Page" mode).

2.1.1.1 Structure mode

"Structure" mode is where you do most of the initial work when creating a report. It is where you do the
initial formatting and place objects in the sections where you want them to appear.

"Structure" mode provides an efficient environment for designing a report because you work with data
representations, not with data itself. When an object is placed on the report, the program identifies the
object but does not retrieve the data. The object is represented by a frame. You can add and delete
objects and other elements, move them around, set up complex formulas, and more, without using the
computer or network resources needed to gather the data.

The report created in "Structure" mode contains only the structure and instructions for creating the final
report. To see how the report looks as a report with data, view it in "Page" mode.
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2.1.1.1.1 Structure mode areas

When you create a new report, Crystal Reports automatically creates five essential report areas in
"Structure" mode:

+ "Report Header"

This area is generally used for the report title and other information you want to appear at the
beginning of the report. It can also be used for charts and cross-tabs that include data for the entire
report.

+ "Page Header"

This area is generally used for information that you want to appear at the top of each page, such as
chapter names, the name of the document, and other similar information. This area can also be
used to display object titles above the objects on a report.

. llBodyll

This area is used for the body of the report, and is printed once per record. The bulk of the report
data generally appears in this section.

+ "Report Footer"

This area is used for information you want to appear only once at the end of the report (such as
grand totals) and for charts and cross-tabs that include data for the entire report.

+ "Page Footer"

This area usually contains the page number and any other information you want to appear on the
bottom of each page.

If a group is added to the report, the program creates two additional areas:

*  "Group Header"

This area typically holds the group name object, and can be used to display charts or cross-tabs
that include data specific to the group. It is printed once at the beginning of a group.

+ "Group Footer"

This area generally holds the summary value, if any, and can be used to display charts or cross-tabs.
It is printed once at the end of a group.

When a group is added, the "Group Header" area appears directly above the "Body" area and the
"Group Footer" area appears directly below the "Body" area.

If you set up additional groups, the program creates new group areas between the "Body" area and the
existing "Group Header" and "Group Footer" areas.
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2.1.1.2 Page mode

"Page" mode shows the report structure and its data. In this mode you can see how your report will
look when it is printed or published.

"Page" mode allows you to edit the formatting of your report using the actual data. You can see the
direct results of your changes on the report, allowing you to fine-tune the formatting until the report
looks exactly as you want it to.

2.1.2 Side panels

Use the side panels to add connections, manage objects, insert folders, and so on.

The side panel area is located to the left of the report canvas. You can navigate between the side panels
by clicking the vertical row of icons on the side panel sidebar.

2.1.2.1 Data Explorer

Use the "Data Explorer" side panel to insert, modify, or delete objects in your report. When you
create a new report or open an existing report, the "Data Explorer" side panel opens adjacent to the

report canvas. Objects that you add in the Query Panel are stored in the "Data Explorer" where they
can be added to the report.

The "Data Explorer" side panel is separated into five areas. Expand the area by clicking the area name.

Result Ohjects

This area shows the universe elements that have been selected for use in the report. Drag elements
to the report canvas to add them to the report.

Click Edit Query to add a new universe element to the report.

Formulas

This area shows the formulas that have been created for the report. Drag formulas to the report canvas
to add them to the report. Right-click the side panel, and then click New Formula to add a new formula.
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This area shows the parameters that have been created for the report. Right-click the side panel and
click New to add a new parameter or a new cascading parameter group.

Running Totals

This area shows the running totals that have been created for the report. Right-click the side panel and
click New Running Total to add a new running total.

Predefined Objects

This area shows the predefined objects you can add to your report. Drag objects to the report canvas
to add them to the report.

2.1.2.2 Outline

L4 Use the "Outline" panel to view the content of the report in a tree view. The root node is the report
itself, while the first-level nodes represent the sections of the report. Within each section, the report's
objects and elements are listed.

You can modify report objects and elements by right-clicking them in the "Outline" panel and clicking
Format <object>. The Format dialog box shows the actions you can take on the object.

2.1.2.3 Group Tree

i Use the "Group Tree" panel to see a tree view of groups and subgroups in the report. Any item
you select in the "Group Tree" is selected on the report canvas.

2.1.2.4 Find
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i Use the "Find" side panel to search the report for any specific value. Type a word or phrase into
the text box and press Enter. The search results appear in the side panel.

2.1.3 Format dialog box

The "Format" dialog box displays the formatting options for the selected element. The "Format" dialog
box appears when you right-click an element and click "Format"<object>.

Use the "Format" dialog box to make formatting changes to the different areas of your report. For
example, when you right-click the "Report Header" section on the report canvas and click
"Format"<Section>, the "Format" dialog box displays the changes you can apply to that section.

2.1.4 Show Problems

The "Problems" panel displays a list of errors found in your report. It includes a description, the context,
and the category of the error.

When you click the Show Problems |I| icon at the bottom of the report canvas, the "Problems" panel
appears.

2.1.5 Keyhoard shortcuts

You can navigate the report structure using the keyboard instead of the mouse.

2.1.5.1 Structure, page, and side panel access

Side Panels

The following shortcut keys allow access to the side panels:
- Data Explorer: CTRL + 1.

* Outline: CTRL + 2.

* Group Tree: CTRL + 3.
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+ Find: CTRL + 6.

Report Modes
The following shortcut keys allow access to the Structure and Page modes:

« Structure mode: CTRL + ALT + L.
+ Page mode: CTRL + ALT + P.

2.1.5.2 Navigating the report canvas

Use the following options to navigate the main window.

*  Press F6 to move the keyboard focus around to the main areas of the screen.

» Press Shift + F6 to cycle back in the reverse direction.

» Pressing F6 and Shift + F6 jumps between blocks: Side Panel, Report Editor Area, Tab Toolbar,
and Top Left Toolbar.

Top Left Toolbhar
* Access the Top Left Toolbar by cycling through F6.

+  To access the second row of buttons, use Tab.
» To switch between buttons, use the arrow keys.

+ To select buttons, use Space.

Tab Toolbar
» Access the Tab Toolbar by cycling through F6. The initial focus is set on selected tab.

»  To switch between tabs use the right and left arrow keys.
+ To go to the buttons, use Tab.
+ To switch between buttons use the right and left arrow keys.

+ To select buttons, use Space.

Editing Keys

* To close a current document: CTRL + W.
+ Copy: CTRL + C.

* Paste: CTRL + V.

* Cut: CTRL + X.
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2.1.5.3 Navigating objects

Common navigation

Use the following keys to navigate objects:

+  To move forward and back: Alt + Left and Alt + Right.

+ To go to the Previous and Next page: Page Up and Page Down.
» To go to the First and Last page: Home and End.

+ To go to Page selection box: CTRL + Shift + N.

»  To refresh report: F5.

Activating hyperlinks in report content

With the report canvas focused, select a report element with a hyperlink so that the element is the
primary selection and press the Space bar.

Copying and Pasting elements
Items can be copied and pasted onto the canvas using the keyboard.

Copy a result object from the "Data Explorer" using Ctrl + C and set the keyboard focus back to the
report canvas using F6. Select a section or a result object on the report where you want to paste the
object. Once selected, paste the object by using Ctrl + V and using Enter.

2.1.5.3.1 To insert an element using keyboard commands
. Press Tab to move the focus to the "Insert" tab.

. Use the arrows to navigate to the required element.

. Press Ctrl + C to copy the element.

. Press Tab to return to the "Structure" mode.

A OON -

Use the arrows to move to the section where you want to place the element.

5. Press Ctrl + V to paste the element.

2.1.5.3.2 To insert an object from a list

. Press Tab to move the focus to the "Insert" tab.
. Use the arrows to navigate to an object list.

. Press Space to activate the drop list.

. Use Tab to navigate between controls.

. Press Enter to select the controls and buttons.

a b ON -
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2.1.5.4 Selecting, moving, and resizing ohjects

When no object is selected on the current page, pressing the UP or DOWN arrow will select the first
visible section.

Once a section is selected, pressingAlt + UP will select its parent area. Or pressing Alt + DOWN will
select the first report object in the section. Or pressing UP and DOWN (no Alt) will select adjacent
sections.

Once a report object is selected, pressing the arrow keys will move the selection to adjacent report
objects. The period (dot) key will cycle through the available handles and allow the object to be resized
or moved.

If a complex report object such as a crosstab is selected, pressing Alt + DOWN will select the first field
within the crosstab (and the arrow keys will move to adjacent elements). Pressing Alt + UP will move
back to the parent.

2.1.5.5 Navigating charts

You can use keyboard shortcuts to modify a chart:

To select elements within a chart, use Alt + Down.

To select other regions within the chart, use the arrow keys.

To modify chart data, use Shift+F10 to activate the context menu and then select Edit Chart Data.
Press the arrow keys to select the drop zones. You may have to press Down, Up, Right, or Left to

move to all of the drop zones. Once a drop zone is selected, press Alt + Down to select an element
within the drop zone.

Note:

Though it is not currently possible to access the check boxes in the data mode page using only the
keyboard, there is an equivalent function inside the Format chart dialog box.

Press Tab to move the focus to the data mode overlay.

To switch back to the "Show" chart mode, with a chart element selected, use Shift+F10 to activate
the context menu and then select Show Chart.

2.1.5.6 Navigating the Groups and Sorts dialog box

22
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The "Groups and Sorts" dialog box can be activated from the "Data" toolbar or directly from the context
menus of various elements on the report canvas such as group areas, sections, result objects, total
elements within groups, and so on.

In the "Groups and Sorts" dialog box, use the standard keys (Tab, Enter, Space, Alt + Down, and the
arrow keys) to navigate through the dialog box.

To select a group or sort, press Space when the group or sort area is focused.

2.1.5.7 Navigating miscellaneous ohjects

Combo drop list

When a combo drop list is selected anywhere in Crystal Reports, use Alt + Down to cause the list to
drop.

Using Esc will cancel the dropdown or using Enter will select the current drop list selection and close
the drop list.

2.1.5.8 Navigating statement editors

The following options allow you to edit statement editors, interactive filters, and conditional formatting:
+ To select the previous or next statement in a group, use the Up and Down arrow keys.

» To cycle through all keyboard-navigable parts in the editor, use Tab and Shift + Tab.

» To apply the relevant delete action for the selected part, use Delete.

»  To go into edit mode for the selected part, use F2.

+ To toggle a join part between "OR" and "AND" operators, use F2.

+ To cancel an option in the editor dialog box, use Esc.

+ To activate an option in the editor dialog box, use Enter.

2.2 Logging on to SAP BusinessOhjects Business Intelligence platform

Before you can create a report with SAP Crystal Reports for Enterprise, you must be connected to an
SAP BusinessObjects Business Intelligence platform server.

Check with your system administrator for the proper server name to use for the connection.

23 2012-08-15



Introduction to Reporting

2.2.1To log on to SAP BusinessOhjects Business Intelligence platform for the first

Get the correct Web Services server name from your SAP BusinessObjects Business Intelligence
platform administrator.

If you have not connected to SAP BusinessObjects Business Intelligence platform before, you will need
to add the server connection before you can log on.

Note:
If you cannot connect to the Bl platform server, refer to your Web Services administrator to ensure the
connection to the Web Services server is configured properly.

1.

Click File > Log on to SAP BusinessObjects Business Intelligence platform.
The "Log on to SAP BusinessObjects Business Intelligence platform" dialog box appears.

Click New Connection.

Note:
When you have created at least one connection, this button displays as Manage Connections.

In the "Server Connections" dialog box, click Add to add a server connection.
In "Connection Display Name", type a descriptive name for the connection.
For example, type “Test server” or “Human Resources server”.

In "Bl platform Web Services Server Name", type the server name of the SAP BusinessObijects
Business Intelligence platform system that you want to connect to.

Note:

* You do not need to type the complete URL here, only the server name.

- If the server requires an encrypted connection, select the This server requires an encrypted
connection (SSL) check box.

« The server name and port number are for where the Bl platform Web Services is installed and
configured. This is not where the Bl platform servers are installed.

In "Bl platform Web Services Server Port Number", type the web server port number that is associated
with the SAP Business Intelligence platform server name.

Note:

» Your system administrator can tell you the value to use for the web port number.

»  The server name and port number are for where the Bl platform Web Services is installed and
configured. This is not where the Bl platform servers are installed.

In "Bl platform Web Services Server Context", type the server context information.

Note:
* Your system administrator can tell you the value to use for the server context information.

24
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+ The server context information refers to the server path of the SAP BusinessObjects Business
Intelligence platform Web Service. The default value is /dswsbobje/services.

8. Type your User Name.
9. Select the correct Authentication Type.
- "Enterprise" authentication requires a user name and password that are recognized by the Bl
platform.

- "LDAP" authentication requires a user name and password that are recognized by an LDAP
directory server.

+ "Windows AD" (Active Directory) authentication requires a user name and password that are
recognized by Windows AD.

- "SAP" authentication requires a user name and password that are recognized by SAP.

Note:
Your system administrator can tell you which authentication type to use.

10. Click OK.

11. In the "Log on to SAP BusinessObjects Business Intelligence platform", type your Password and
click OK.

If you selected "Windows AD" from the "Authentication Type" list, you can select the Enable Single
Sign-On check box if you want to enable single sign-on.

Note:
The server must be configured for single sign-on.

You are now logged on to the Bl platform server. You can create new reports or edit existing ones.

Related Topics
 To import server connection information
» To export server connection information

2.2.2 To log on to SAP BusinessObhjects Business Intelligence platform

Follow these steps if you have already set up server connections to SAP BusinessObjects Business
Intelligence platform.

Note:
If you cannot connect to the SAP BusinessObjects Business Intelligence platform server, refer to your
Web Services administrator to ensure the connection to the Web Services server is configured properly.

1. Click File > Log on to SAP BusinessObjects Business Intelligence platform.
The "Log on to SAP BusinessObjects Business Intelligence platform" dialog box appears.

2. From the "Select a connection” list, click the server name for the server that you want to connect to.
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3. Type in your User Name and Password and then click OK.

You are now logged on to the SAP BusinessObjects Business Intelligence platform server. You can
create new reports or edit existing ones.

Related Topics
 To import server connection information
 To export server connection information

2.2.3 Connection error messages

When you attempt to connect to the SAP BusinessObjects Business Intelligence platform, you may
encounter a connection error.

This section describes how to view connection error details, how to resolve connection errors, and the
most common types of connection error messages.

2.2.3.1 To view connection error details

If you encounter a connection error, an error message will appear in the "Log on to SAP BusinessObjects
Business Intelligence platform" dialog box.
The following section describes how to view connection error details and copy them to the clipboard.

1. Click View Details.

The "SAP BusinessObjects Bl Platform Connection" dialog box appears. Here, you can see the
settings used to connect to the Bl platform.

2. Click View Error Log.
3. In the "Error Details" dialog box, click Copy to Clipboard.
The contents of the "Error Details" dialog box are copied to the clipboard.

4. Click OK.

2.2.3.2 Resolving a connection error

You can resolve a connection error in three ways:
*  Modify the server connection information.
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* Modify the network settings.
» Connect without a proxy.

Related Topics

» To modify server connection information
» To modify network settings

 To connect without a proxy

2.2.3.2.1 To modify server connection information

If you encounter a connection error, an error message will appear in the "Log on to SAP BusinessObjects
Business Intelligence platform" dialog box.

The following section describes how to modify the server connection information to resolve the connection
error.

1. Click View Details.

The "SAP BusinessObjects Bl Platform Connection" dialog box appears. Here, you can see the
settings used to connect to the Bl platform.

2. Click Change beside the "Enterprise Service Information" section.

3. In the "Server Connections" dialog box, change your server connection information and click OK.
Note:
For assistance, contact your network administrator.

4. In the "Log on to SAP BusinessObjects Business Intelligence platform" dialog box, type your
Password, and click OK.

If you continue to receive an error message, modify your network settings or connect without a proxy.

Related Topics
* To modify network settings
 To connect without a proxy

2.2.3.2.2 To modify network settings

If you encounter a connection error, an error message will appear in the "Log on to SAP BusinessObjects
Business Intelligence platform" dialog box.
The following section describes how to modify the network settings to resolve the connection error.

1. Click View Details.

The "Bl Platform Connection" dialog box appears. Here, you can see the settings used to connect
to the BI platform.

2. Click Change beside the "Network Settings" section.
3. In the "Preferences" dialog box, change your network settings and click OK.

27

2012-08-15



Introduction to Reporting

4. In the "Log on to SAP BusinessObjects Business Intelligence platform" dialog box, type your
Password, and click OK.

If you continue to receive an error message, modify your server connection information or connect
without a proxy.

Related Topics

» To modify server connection information
* To connect without a proxy

2.2.3.2.3 To connect without a proxy

If you encounter a connection error, an error message will appear in the "Log on to SAP BusinessObjects
Business Intelligence platform" dialog box.

If you attempted to connect to the Bl platform with a proxy, you will now attempt to connect to the system
without a proxy.

1. Click View Details.
The "SAP BusinessObjects Bl Platform Connection" dialog box appears. Here, you can see the
settings used to connect to the Bl platform.

2. Click Try to connect without proxy.
The "Connect without Proxy" dialog box appears, indicating the success or failure of the attempt.
+ If the connection is unsuccessful, proceed to step 3.
+ If the connection is successful, proceed to step 4.

3. Click OK.

Note:
Check your network configuration. For assistance, contact your network administrator.

4. Click either Yes or No.
» Click Yes to save the changes.

» Click No to discard the changes.

5. In the "Log on to SAP BusinessObjects Business Intelligence platform™ dialog box, type your
Password, and click OK.

If you continue to receive an error message, modify your server connection information or network
settings.

Related Topics

» To modify server connection information
» To modify network settings
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2.3 Creating a new report

This section provides you with information on the report creation process, including the following options:

+ Creating a report from a data source or from a web template.
+ Selecting the data source.

* Adding elements.

«  Formatting data.

+ Selecting records.

+  Grouping, sorting, and totaling data.

2.3.1 To create a new report from a data source

To create a new report from a data source, you can place text elements or predefined objects on a
blank report, or you can connect to a data source and select result objects to display data on your
report.

1. Click File > New > From Data Source.
The "Choose a Data Source Connection" dialog box appears.

2. Select the data source that you want to connect to.
3. Choose one of the following options to select data for your report.

SAP BusinessObjects Business | ; - select a universe or query and then click Next.
Intelligence platform b. Select the Result Objects and then click Finish.

Connection by Vendor a. Select a data source and click Finish.

You have created a new report.

Related Topics

* Logging on to SAP BusinessObjects Business Intelligence platform
* Selecting a data source

» Selecting folders and result objects

« Selecting tables for your report

* Placing data on the report

29
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2.3.2 To create a new report from a web template

1. Click File > New > From Web Template.
The "Open Template" dialog box appears.

2. Select a template and click OK.

The template is loaded into Crystal Reports and you are prompted to either Preview the report layout
or to set the data source location. Setting the data source location means you need to choose which
data source to use for the report.

3. Click Set Data Source Location.
The "Set Data Source Location" dialog box appears.

4. In the Target Data Source area, click Add Connection.
The "Choose a Data Source Connection" dialog box appears.

5. Choose one of the following options to select data for your report.

Previous Connection a. Select an existing data source connection.
b. Click Finish.

SAP BusinessObjects Business In- |,  sglect a universe or query.

telligence platform b. Click Finish.

Connection by Vendor a. Fill in the data source details.
b. Click Finish.

6. Map the result objects from the "Current Data Source" to result objects in the "Target Data Source".
You may need to expand folders or tables in the target data source area before you can map the
objects.

7. Click Done.

The report is updated with data from your data source.

Related Topics

* Web-based report templates

 Logging on to SAP BusinessObijects Business Intelligence platform
» Selecting a data source

» Selecting folders and result objects

» Selecting tables for your report

* Placing data on the report
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2.3.3 Selecting a data source

Crystal Reports supports connecting to several data sources, including the following:

+  Universe

+  SAP BEx Query

* Analysis view

- ODBC

- JDBC

+  Excel Spreadsheet

2.3.3.1 To select a data source from the Bl platform server

Connect to an SAP BusinessObjects Business Intelligence platform server.

1. You can select a data source when creating a new report, or add a data source later.

+ To add a data source to a new report, click Blank Report.
+  To add a data source to an existing report, click Data > Choose Data Source.

The "New Data Source Connection" dialog box appears.

2. Select a data source type and click Next.
The following are valid data source types:
* Universe
- SAP BEx Query
* Analysis View

3. If you are not already logged on, log on to your SAP BusinessObjects Business Intelligence platform

server and click Next.

Note:
If you are already logged on, the login screen is not displayed.

4. Select the data source that you want to connect to, and then click Next.
The "Edit Query" panel appears. You can now select elements to include in your query.
Note:

If you connect to an Analysis View, the query panel will not appear because Analysis Views contain

pre-designed queries. The report canvas will appear.

Related Topics
* Logging on to SAP BusinessObjects Business Intelligence platform
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2.3.3.2 To select a data source from a vendor

1. You can select a data source when creating a new report, or add a data source later.
+  To add a data source to a new report, click Blank Report.
- To add a data source to an existing report, click Data > Choose Data Source.
The "Choose a Data Source Connection" dialog box appears.

2. Select Connection by Vendor.
A list of vendors is displayed.

3. Select the data source vendor that you want to connect to, and then click Next.
The Set up your connection dialog box appears.

4. Fill in the connection details and click Next.

The "Select Tables for your Report" panel appears. You can now select elements to include in your
report.

2.3.4 Selecting folders and result ohjects

After selecting a data source, you can select one or more folders or result objects within the folders to
include in your report.

2.3.4.1 To select folders and result obhjects

1. You can select folders when creating a new connection to a data source, or when a connection is
already set up.

+ When creating a new connection in a blank report, select the data source in the "Choose a Data
Source Connection" dialog box and click Next.

+ If a connection is already set up, click Edit Data Sources in the "Result Objects" area of the
"Data Explorer" side panel.

The "Query Panel" dialog box appears.

2. Select a folder or an object from the "Universe" pane and double-click it or drag it to the "Result
Objects for Query #1" pane.

3. Repeat the previous step for each object that you want to include in the query.
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Note:

It is recommended to avoid including both a hierarchy object and associated level objects in the
same report. A hierarchy object contains all of the hierarchy nodes in a hierarchy form, whereas a
level object contains only the hierarchy nodes that match the level index in a flattened form. If both
kinds of objects are included in a report, the hierarchical data and flattened data will both be included
in the query.

4. Click Finish.
The folders and objects appear in the "Result Objects" area of the "Data Explorer" side panel.

Note:
SAP BW hierarchies will be displayed in a flat format, not a nested format, in the "Result Objects" area.

Related Topics
* Quick reference to objects

2.3.5 Selecting tables for your report

After selecting a data source, you can select one or more tables to include in your report. Links between
tables may be automatically created, or you may have to add them yourself.

Related Topics
* Linking tables

2.3.5.1 To select tables for your report

1. You can select tables when creating a new connection to a data source, or when a connection is
already set up.

+ When creating a new connection in a blank report, select the data source in the "Choose a Data
Source Connection" dialog box and click Next.

+ If a connection is already set up, click Edit Data Sources in the "Result Objects" area of the
"Data Explorer" side panel.

The "Choose a Data Source Connection" dialog box appears.

2. Select a table and double-click it or drag it to the "Selected Tables" pane.
3. Repeat the previous step for each table that you want to include.
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Note:

If you include more than one table, the tables need to be linked together. Some table combinations
will create automatic links on fields that are common to both tables. For other combinations, you will
have to create the link.

a. To create links manually, drag a field from one table to a field in another table.
You will not be able to create a link if the fields have different data types.

4. Click Finish.

The tables appear in the "Result Objects" area of the "Data Explorer" side panel.

2.3.6 Placing data on the report

Placing data on a report is a very important task. To produce reports that are clear and effective, you
need to know what type of data to place on the report and where on the report to place it.

Note:

A report (.rpt) file might contain sensitive business data. You are advised to protect access to the file
by using one of these methods:

+  Manage the file with SAP BusinessObjects Enterprise server.

*  Apply file security.

*  Apply operating system-level encryption.

2.3.6.1 Result ohjects

Result objects are objects that display data from the data source. Much of the data displayed on a report
is from result objects. Normally, result objects will be placed in the "Body" area, but under certain
circumstances, they will be placed in other sections of the report.

Note:

If you are using a relational universe, OLAP universe, or SAP BEx query, delegated measures may be
available. If you place a delegated measure in the "Body" area, it will appear as a result object. However,
if you place a delegated measure in the "Report Header", "Report Footer", "Group Header", "Group
Footer", a Cross-tab, or a chart, it will be displayed as a total.

2.3.6.1.1 To insert result objects
1. Inthe "Result Objects" area of the "Data Explorer" side panel, click the folders to expand the objects.
2. Drag objects to the desired location on the report canvas.
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Note:
You can also insert an object by right-clicking the object in the "Data Explorer" and clicking Insert.

2.3.6.2 Formulas

To display data that is a calculated value, you need to create a formula and place that formula on the
report. For example, if the data source stores only the order dates and ship dates for orders, but you
need to display the number of days it takes to ship the order, you must create a formula that will calculate
the number of days between ordering and shipping.

Related Topics
* Formulas

2.3.6.3 Parameters

Parameters allow you to filter report data for specific users. For example, in a report used by salespeople,
you might create a parameter that prompts the user to choose a region. When the user chooses a
region, the report returns the results for the specific region instead of returning the results for all regions.

Related Topics
* Parameters and Prompts

2.3.6.4 Running total elements

To display a total that evaluates each record and provides a running sum of all values in an object (or
all values in a certain set of values), a running total element needs to be created and placed in the
report. If the first three values in an object were 2, 4, and 6, a running total would print 2, and then 6
(the sum of 2 + 4), and then 12 (the sum of 2 + 4 + 6).

Related Topics
* Running Totals
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2.3.6.5 Predefined objects

Predefined objects include "Page Number", "Record Number", "Group Number", "Print Date", and "Total
Page Count" objects. Use the commands in the "Predefined Objects" area of the "Data Explorer" side
panel to add predefined objects to your report.

2.3.6.5.1 To insert a predefined object
1. In the "Data Explorer" side panel, expand Predefined Objects.
2. Drag a predefined object to the desired location on the report canvas.
Each predefined object is inserted into the report as an element. An element frame appears. You can
now move it on the report.

Tip:
You can also right-click a predefined object, and then click Insert.

2.3.6.6 Text elements

Text elements are mostly used to hold text, but they can also hold result objects to create custom form
letters and more. You can use text elements to combine result objects, insert titles, label totals, and
other data on your report.

2.3.6.6.1 To insert a text element
1. Click Insert > Text, and then click the report canvas to place the text box.
An empty text box appears.

2. Type your text into the text box.
A text element is added to the report.

Tip:
Click once on the border of the text element to select it for resizing and moving.

2.3.6.6.2 To insert a result object in a text element
1. Insert a text element into the report.
2. Type the text that you want to appear before the first result object, if any.
3. In the "Data Explorer" side panel, click the result object you want to insert, and drag it towards the
text element.

As you move the cursor over the text element, you will see a movable insertion point.
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4. Drag the object so the insertion point is where you want the result object to appear, and place the
object.

Tip:
The result object can also be moved by selecting and moving it in the text element.

2.3.6.7 Picture elements

When designing reports, there will be times when you want to include a picture. For example, you may
want to insert a company logo in the "Report Header".

2.3.6.7.1 To insert a picture
1. Click Insert > Picture.

The "Open" dialog box appears.
2. Select the desired picture file from the file list and click Open.

An element frame appears with the picture inside, ready to be positioned.

3. Position the picture element where you want it to appear on the report and click to place it.

2.3.6.8 Hyperlink elements

You can add a hyperlink to any report element on the report canvas.

The hyperlink is saved with your report and is available to other users as a way of viewing additional
information.

Note:
Crystal Reports also lets you create hyperlinks with Relative URLs, so your web reports retain
independence from their location on any particular server.

2.3.6.8.1 To create a hyperlink element
1. Right-click the report element on the report canvas, and click Format <Element>.
The Format dialog box opens.
2. Click the Advanced option.

Note:
Not all hyperlink types are available at all times. The element you select and its location on the report
determine which types are available.
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3. From the "Type" list, select one of the following:

No Hyperlink This is the default option. There is no hyperlink associated with the selected
report element.

A Website on the | Select this option if you want your report element to be linked to a static web

Internet address.

An E-mail Ad- Select this option if you want to create a "mailto" address from the object you

dress selected. Use the Conditional Formula button to create an address based
on a object value.

A File Select this option if you want to create a hyperlink to a file on a specific com-
puter or networked computer.

Another Report | Select this option if you want to create a hyperlink to another element on the

Element report.

A text box will appear below the "Type" menu.

4. Enter the website address, email address, or the file name of the hyperlink, depending on the type

you selected.

5. Close the "Format" dialog box.

A hyperlink is inserted on the report.

2.3.6.9 Alerts

Alerts are custom messages created in Crystal Reports that appear when certain conditions are met
by the data in a report. Alerts indicate action to be taken by the user, or information about report data.

Alerts are created from formulas that evaluate conditions that you specify. If the condition is true, the
alert is run and its message is displayed. Messages can be text strings or formulas that combine text
and report objects. Once an alert is run, it's not evaluated again until you refresh your report's data.

Because alerts are specific to each report, you decide when to use them and when not to. They can
be useful to point out important information such as sales that are above or below a limit. The message
is created by you, so it can be specific to your data.

2.3.6.9.1 To add a new alert
1. On the standard toolbar, click Data > Alerts.
The "Alerts" dialog box opens.

2. Click New.

3. Enter a name for your alert in the "Name" text box.

38

2012-08-15



Introduction to Reporting

4.
Click the Condition Formula icon next to "Condition".

The "Formula Workshop" appears.

. Enter your alert condition formula.

If an alert formula is based on a total element, any recurring elements used must be constant over
the total element. For example, if you are grouping on Country and Region, you might create the
following alert:

Sum ({Customer.Last Year's Sales}, {Customer.Region}) > 10000

In this case, your formula can refer to either Country or Region, but not City or Customer Name
since these are not constant.

Note:

Alert formulas can be based on recurring records or on total elements, but cannot be based on
print-time elements, such as running totals or print time formulas. Alert formulas cannot have shared
variables.

. Click Save and Close to exit the "Formula Workshop".
. You can add a message to appear with your alert.

There are two options for adding an alert message.

+ If you want the same message to appear every time your alert is run, type the message in the
"Message" box.

+ If you want the message to appear customized with data elements, create a message formula.
a.
Click the Conditional Formula icon next to "Message".
The "Formula Workshop" appears.
b. Enter your alert message formula.

For example, if you want to see the message “<Country> is a star performer” (where
<Country>is the name of a specific country), you might create the following formula:
({Customer.Country}) + "is a star performer".

c. Click Save and Close to exit the "Formula Workshop".
Note:
The result of an alert message formula must be a string.

The DefaultAttribute function can be used to refer to a message added in the "Message"
box. For example, if the message in your message box is “is a star performer”, your alert message
formula might be:

({Customer.Country}) + DefaultAttribute

This formula relies on the text you type in the "Message" box; that text becomes the default
attribute.
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8. Click OK.

A new alert is added to the report.

2.3.7 Formatting data

At this point in creating a report, you may want to do some basic formatting. Perhaps you would like to
change the font size and style of a text element used as a title. Or, if you have a number element, such
as a sales figure, you might want to place a dollar sign before the number or change the number of
decimal places displayed.

2.3.7.1 To format elements using the Format dialog hox

The Format dialog box shows the options for editing report elements. You will use the Format dialog
box to make detailed formatting changes to almost all elements in your report.
Tip:
You can also format elements through the "Format" tab in the tab bar, or by clicking Format on the
standard toolbar.
1. Right-click the element you want to reformat, and click Format <Element>.
The Format dialog box appears.
2. The Format dialog box displays a quick view of commonly used formatting options for the element.
Click Advanced to view more options.
3. Click the options on the panel to view the different sections of the dialog box.
4. Make the desired changes.

Related Topics
* Report Layout and Formatting

2.3.7.2 Inserting page headers and footers

You can use page headers and footers by placing the information in the "Page Header" or "Page Footer"
sections of the "Structure" mode.

+ Information to appear only on the first page of the report goes in the "Report Header".
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» Information to appear only on the last page of the report goes in the "Report Footer".
» Information to appear at the top of every page goes in the "Page Header".

+ Information to appear at the bottom of every page goes in the "Page Footer".

Text, objects, or formulas can be used in these sections just as in the "Body" section.

2.3.8 Grouping, sorting, and totaling data

Once a basic report is created, you will want to organize the data by grouping related information,
sorting individual records, totaling, subtotaling, and grand totaling.

2.3.8.1 Grouping records

To organize the data, you may want to group related data together. For example, after grouping a
customer list by region, you might divide the list into regional groups. That way, a sales manager for
one region could quickly locate the appropriate region group and focus exclusively on the customers
within that region.

Related Topics
» Grouping data

2.3.8.2 Sorting records

Crystal Reports allows you to specify the order in which you want the records on your report displayed.
For example, after grouping by region, you might sort the records within each region in alphabetic order
by Customer Name. Many of your reports will use some type of sorting. Depending on the report, you
will sort the records in a list or sort in conjunction with grouping.

Note:

Crystal Reports will automatically sort the first column in a report alphabetically.

Related Topics

» Sorting records within groups
* Totaling grouped data

2012-08-15



Introduction to Reporting

2.3.8.3 Totals, subtotals, and grand totals

Many reports use some sort of totaling. For example, in a North American sales report grouped by
state, you might want to calculate the total dollar amount sold in each state. You do this by creating a
subtotal on the sales object. Totals are also used at the group level, allowing you to calculate averages,
counts, and other group (aggregate) values. For example, in a sales report you may want to calculate
an average of sales per state (average total on the sales object) and calculate the number of products
sold in the state (distinct count of the product name object).

2.3.8.4 Using the isolate feature on grouped data

Crystal Reports allows you to isolate grouped or totaled information. While in the "Page" mode, right-click
the group title or total element in the "Group Header" area that you want to isolate, and click Isolate
Information.

The report now shows only the group or total you isolated. To return to your main report, click the title
above the report canvas.

Tip:

You can also isolate information on the "Group Tree" side panel, right-click the desired group and click
Isolate Information.

Related Topics
» Sorting, Grouping, and Totaling

2.3.9 Adding a title page to the report

You can add a title page to a report by inserting "Report Title" from the "Predefined Objects" area of
the "Data Explorer" side panel.

In order to use this object, you must have a title entered in the Title text box for the report. You can add
a report title using the "Summary Info" dialog box.
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2.3.9.1 To add a title page to the report

1. Click File > Summary Info.

2. In the "Summary Info" dialog box, enter a report title in the Title text box, if you have not done so
already.

3. Close the "Summary Info" dialog box.

4. In the "Predefined Objects" area of the "Data Explorer" side panel, drag the Report Title object to
the "Report Header" section of the report canvas.

5. Click the "Report Title" element to select it.

6. Format the font of the "Report Title" element from the "Format" tab.

7. Set the "Report Title" values, such as font size, font type, and position.

8. In the "Outline" side panel, right-click "Report Header" and click Format Report Header.

The Format dialog box shows the formatting options for the "Report Header" section.

9. Select the Page Break After check box.
10. Click Close.

The title appears on the first page and the report begins on the second page.

2.3.10 Adding comments to the report

There may be times when you want to include non-printing comments with a report (a personal note to
the report recipient, a note to explain more thoroughly the data on which the report is based, a report
title, a comment about some particular data on the report, and so on).

You can use the "Comments" text box in the "Summary Info" dialog box to add comments. The comments
do not print with the report; however, you can add comments to the report output if you want to.

2.3.10.1 To add comments to the report

1. Click File > Summary Info.
2. In the "Summary Info" dialog box, enter your comments in the "Comments" box.

Note:
The "Comments" box does not allow for paragraph breaks.

3. Close the "Summary Info" dialog box.
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Your comments are added to the report.

2.3.10.2 To add comments to the report output

1. In the "Predefined Objects" area of the "Data Explorer" side panel, click "Report Comments" and
drag it onto the "Report Header" section of the report canvas.

2. Right-click the "Report Comments" object on the report canvas and click Format object.
3. In the Format dialog box, set the report comment values, such as font size, font type, and position.
4. Close the Format dialog box.

The report comments now appear in the "Report Header" section of the report output.

2.3.11 Using the zoom feature

You can easily zoom in on a report. You can choose any magnification from 20% to 400%.

The zoom feature is located on the bottom right corner of the screen. Slide the bar to the left to zoom
out, and to the right to zoom in. You can also edit the zoom percentage manually by entering a
percentage into the text box. For example: 65%.

It is helpful to view reports at low magnifications in order to get an overall picture of the structure of your
report. Views at higher magnifications focus attention on the details of the report.
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Report Design Concepts

This section describes the basic concepts of report design and helps you decide what information you
want to include in your report.

3.1 Basic report design

The purpose of this section is to suggest a structured approach to preparing a Crystal Reports report.
This approach includes the following:

+ Deciding on the content of the report.

- Developing a prototype on paper.

This section has been designed to provide a conceptual understanding of the reporting process.

3.2 Deciding on the content of the report

Before you do anything else, you should outline the information you want the report to provide. The
following sections provide a guide to making that outline.

Note:

A report (.rpt) file might contain sensitive business data. You are advised to protect access to the file
by using one of these methods:

+ Manage the file with SAP BusinessObjects Enterprise server.
*  Apply file security.

+  Apply operating system-level encryption.

3.2.1 Stating the purpose
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What is the overall purpose of the report?

Reports are management tools. Their purpose is to help you quickly grasp the essential elements and
relationships found in raw data, to help you make effective decisions. For a report to be effective, it has
to present the correct data in a logical way. If it presents the wrong data, or if it presents the right data
in a haphazard manner, the report may slow the decision-making process or may even encourage
incorrect decisions.

A good starting place in the development of a report is to write out the purpose of the report in a sentence
or two. The purpose statement helps you focus on your primary needs, and it gives the report both a
starting point and a goal.

Here are some examples of purpose statements:

» The purpose of this report is to show monthly and year-to-date sales by sales representatives,
compare this year's numbers to last year's, and flag representatives whose sales figures do not
meet company standards.

»  The purpose of this report is to show sales activity for each item in inventory, and to suggest reorder
quantities based on that activity.

» The purpose of this report is to calculate bowling averages and handicaps for each member of the
bowling league.

Defining the purpose of the report before you start is a critical step in the overall process.

Who is going to read the report?

A single report is often used by many individuals. A detailed, company-wide sales report, for example,
may be used by sales representatives, the regional sales manager, the national sales manager, and
the Chief Operating Officer (COO).

These individuals will be interested in different aspects of the report:

+ A sales representative will use the report to evaluate individual sales performance and compare this
performance to that of other representatives in the region.

+ The regional sales manager will use the report to evaluate regional representatives and compare
the region's performance to that of other regions.

+ The national sales manager will use the report to evaluate the performance of regional managers
and compare overall sales to the current sales forecasts.

+  The COO will use the report to evaluate the performance of the Vice-President of Marketing and
the sales department as a whole, and to project such things as manufacturing needs and warehouse
locations.

Since each user of the report has different interests, it is important to plan the report so it includes the
information each user is looking for.

3.2.2 Determining the structure of the report
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What is the report title going to he?

Write out a working title for the report. You may decide to change it later, but at least you will have a
title to use when creating the prototype report.

What identifying information is needed in the header and footer?

You may want to include the print date, information on who prepared the report, a block of text to
describe the purpose of the report, the range of data covered, or something similar. If you are going to
include such information, write it down so you can use it in preparing your prototype.

The information can come from a variety of sources, depending on the kind of information you plan to
use.

» Information on who prepared the report might be drawn from individual result objects in the result
folder(s) used. If it is to be drawn from a result folder, which folder? Or, which combination of folders?

* A block of text can be created as a text element and placed anywhere on the report.

+  Crystal Reports can generate information such as the print date or page numbers.

3.2.3 Finding the data

What data do you want to use in the report?
Do you know the type of data source you are reporting from? If you do not know, ask the data source
administrator in your organization for help in setting up the data source type and location of the data.

Are you familiar enough with the data to find the necessary information? When looking for a Customer
Contact name, can the object be found in a result folder?

If not, your MIS professional, data source administrator, or co-workers will have to help you become
familiar with the data.

What specific data should appear in the hody of the report?

The body should contain all of the data needed to fulfill the statement of purpose you wrote for the
report. It should also contain all of the data needed by the various users that you have identified.

This step requires you to look at the available result folder(s). Crystal Reports allows you to combine
data from different data sources when you create reports, so you have a great deal of flexibility in your
work.

* Much of the data in a typical report is taken directly from result objects. Which result objects will be
used, and where are they located?

+ Other data will be calculated based on result objects. Which result objects will be used in the
calculations?

- Still other data will be placed directly into the report using text elements (headings, notes, labels,
and so on).
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Does the data exist or does it need to he calculated?

Some report information can be drawn directly from result objects (sales information, for example);
other information will have to be calculated based on result object values (for example, sales commission,
based on the relationship of sales to quota). In your planning, it can be helpful to segregate or flag data
that needs to be calculated from that which can be used directly.

What types of objects contain data?

You should take the time to get to know the data type for result objects that will be used in your
calculations. Since formula functions and operators work with specific kinds of data, it is important to
recognize the data type you are working with, before you start any calculations. For example, some
functions require numeric data, while others work with only string objects.

3.2.4 Manipulating the data

Do you want the data organized into groups?

How? By customer? By date? By hierarchy? Or by other criteria? Crystal Reports provides several
options for grouping data in a report.

Do you want the data sorted hased on record or group values?
Crystal Reports gives you both alternatives.

Do you want the report to contain only specific records or groups?

Crystal Reports gives you the opportunity to base a report on all of the records in a given data source,
or on a limited set of records from the data source. Crystal Reports can be used to filter records based
on simple date ranges or comparisons, or to create complex formulas to identify the records to be
included. Filtering data can be done in the Query Panel, or on your report with parameters and interactive
filters. Take a few minutes to determine the records needed for the report and list the criteria to be used
for filtering those records.

Do you want to total the data?

Do you want to total, average, count, or determine the maximum or minimum value included in all of
the values in any column on the report?

Crystal Reports allows you to do this, and it also allows the grand total (or the grand total average,
grand total count, and so on) to be placed at the bottom of the selected column.

What information should be flagged on the report?

You may want to call attention to some data by flagging it on the report. For example, non-moving
inventory items are often flagged on inventory reports so they can be given special attention. You might
want to flag each item that has shown no activity during the last month, during the last three months,
or during some other defined period. To flag information, identify it and any conditions that will trigger
the flagging.
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How do you want information flagged?

You may want to flag items with an asterisk or some other symbol, or you may want a word to appear
as a flag. In any case, you should write out flagging instructions so they are handy.

Crystal Reports gives you the opportunity to underline report elements, and change the font type, size,
or color used for specific report elements. It allows you to put borders around elements and to draw
lines and boxes (to break the report into sections), set off headings, and so on. All of these formatting
tools can be used to highlight key data on a report.

3.2.5 Determining printing area characteristics

Each report area has its own printing characteristics. It is important to understand these characteristics
because they affect when and how often different report elements get printed.

In what order will the areas print on the report?

Areas print in the order they appear in "Structure” mode (top to bottom). If there is more than one section
in an area, the sections print in the order they appear. For example, if you have three "Report Header"
sections, all three of those sections will print, in order, before the section(s) in the "Page Header" area
begin to print.

Howr often do report elements print?

The way elements print will determine how you design your report. This will help you decide where to
place charts, Cross-Tabs, and formulas to get specific results.

Report Header
Elements placed in the "Report Header" area print once, at the beginning of the report.

» Charts and Cross-Tabs placed in this area contain data for the entire report.

Note:
Both charts and Cross-Tabs can filter report data by using a Group Sort; in such cases, the data
shown in the chart or Cross-Tab is a subset of the data for the entire report.

+  Formulas placed in this area are evaluated once, at the beginning of the report.

Page Header
Elements placed in the "Page Header" area print at the beginning of each new page.

»  Charts or Cross-Tabs cannot be placed in this section.

+  Formulas placed in this area are evaluated once per page, at the beginning of each new page.

Group Header
Elements placed in the "Group Header" area print at the beginning of each new group.

»  Charts and Cross-Tabs placed in this area contain data just for the group.
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+  Formulas placed in this area are evaluated once for each group, at the beginning of the group.

Body
Elements placed in the "Body" area print with each new record.

»  Charts or Cross-Tabs cannot be placed in this area.

- Formulas placed in this area are evaluated once for each record.

Group Footer
Elements placed in the "Group Footer" area print at the end of each group.

»  Charts and Cross-Tabs placed in this area contain data just for the group.

+  Formulas placed in this area are evaluated once for each group, at the end of the group.

Report Footer
Elements placed in the "Report Footer" area print once at the end of the report.
+ Charts and Cross-Tabs placed in this area contain data for the entire report.

Note:
Both charts and Cross-Tabs can filter report data by using a Group Sort; in such cases, the data
shown in the chart or Cross-Tab is a subset of the data for the entire report.

- Formulas placed in this area are evaluated once, at the end of the report.

Page Footer
Elements placed in the "Page Footer" area print at the bottom of each page.
»  Charts and Cross-Tabs cannot be placed in this area.

+  Formulas placed in this area are evaluated once per page, at the end of each new page.

3.3 Developing a prototype on paper

While a paper prototype is useful regardless of your level of expertise with Crystal Reports, it is particularly
valuable when you are first learning the program. With the paper prototype in hand, you can put your

full effort into learning and using the commands, rather than into trying to design and learn at the same
time.

3.3.1 To design a paper prototype

1. Use the same size paper you will be using for the finished report.
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. Position the title and other descriptive header information, using boxes or lines to represent report

elements.

. Position the footer information.

Review the page structure for balance.

. Look at the information you intend to include in the body of the report:

+  Count the number of objects being used and estimate the appropriate spacing between objects.
+ Use rectangles to pencil in the objects within the estimated spacing.

» Change the spacing if you need to.

- Decide on a logical sequence for presenting the data in the body of the report.

+ Label the objects to indicate that sequence.

Use small boxes to indicate group values and totals.

Place random flags in the column where you want flags to appear.

Darken any elements you want highlighted to make them stand out from the rest of the prototype.
Review the finished product for structure and balance, and make changes as needed.
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Weh-based report templates

The "From Web Template" option in Crystal Reports provides a quick way of creating reports with
access to data sources such as universes and databases.

You can browse through the templates to find one that works for you, or you can search the report
repository for a specific report type.

4.1 Report Repository on the Web

Crystal Reports provides a link to the Report Repository on the Web, where the various report templates
are available for download.

The repository contains links to the report templates and search tools (which can also be used to search
for report-specific elements).

4.2 Selecting a report template and mapping data objects

The specialized report templates offered in Crystal Reports can be selected to create different types of
projects.

Select the appropriate report template from the following template options:
*  Featured Templates

*  Most Downloaded Templates

* Recently Added Templates

- Highest Rated Templates (user-rated)

You can also search for keywords using the search tool. Each report template type is briefly described
under each report template icon.

Once you have chosen a report template to use, you wll be prompted to connect to a data source so
that you can use the report with your own information.

53

2012-08-15



Web-based report templates

4.2.1 To select a report template and map data objects

. You can access the report template repository from the start page or from the File menu.

File menu Click File > New > From Web Templates .
The "Open Templates" dialog box appears.
Start page From the Start page, select the Templates tab.

. Select a template from one of the template groups.

The report opens and the "Report Repository on the Web" dialog box is displayed.

. Select an action to proceed:

- Select Preview if you would like to preview the report template before selecting a data source.
- Select Set Data Source Location to select a data source.

The "Set Data Source Location" dialog box appears.

. From the "Target Data Source" panel, click the Add Connection icon.

The "Choose a Data Source Connection" dialog box appears.

. Select your data source connection from one of the following options:

- Previous Connections: This option lets you use previously connected data sources.

- Browse Repository: This option lets you choose your data source from the "Data Source Type"
list.

+ Connection by Vendor: This option connects to data sources sorted by a vendor or software
provider.

. Click Finish.

The new data source files appear in the "Target Data Source" column.

. Select an object from the "Current Data Source" panel, and connect it to an object in the "Target

Data Source" panel.

Note:
Data sources with a data compatibility rating of fifty percent or more are preferred. String data types
require textual information and Number data types require numerical information.

. Click the Map icon.

Tip:
To see only the objects that still need to be mapped, in the "Data Mapping" section, click Show
Unmapped Fields.
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Note:

- All objects in the current data source need to be paired with an object in the target data source
or the objects need to be converted to a placeholder formula. You will not be able to close the
dialog box until all objects have been mapped.

- Ifyou attempt to map a target object a second time, the "Replace Mapping" dialog box will appear
and warn that the target object is already mapped; you will be prompted to replace the connection.
Select Yes to replace the mapping, or No to return to the menu and select another object.

9. Click Done when you are finished creating data connections.

4.3 Changing data sources

If you are no longer able to connect to your original data source, or you have a need to connect to a
different data source, you will have to change your data source connection and remap your data objects
to objects in the new data source. If the new data source does not have all the data objects in the same
folder or table as in your original data source, you will need to manually remap the objects.

If you encounter a situation where a result object on your report does not have a match in the new data
source, you can use a placeholder formula until you decide how to resolve the problem.

Note:
When changing a universe data source to another universe data source, the query filters will not be
carried forward. You must edit the new data source to recreate any query filters that you need.

Incompatible data sources

If you try to map objects to two incompatible data sources, you will be informed that they are incompatible.
You cannot mix relational database fields (direct-to-data) with semantic layer result objects in the same
report, nor can you mix result objects from different types of semantic layer data sources.

When changing the data source for a direct-to-data report that does not have subreports, use the
following guidelines:

Data mapping option Fields in the report

To a universe All fields must be mapped to the same universe.

To an SAP BEx Query All fields must be mapped to the same SAP BEx Query.

To an Analysis View All fields must be mapped to the same Analysis View.

To another direct-to-data data Fields can be mapped across several direct-to-data connections.
source

When changing the data source for a direct-to-data report that does have subreports, use the following
guidelines:
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Data mapping option Fields in the report

Any report mapped to a universe | Fields within any given report must all be mapped to the same uni-
verse, though subreports can be mapped to different universes than
the main report.

Any report mapped to an SAP | Fields within any given report must all be mapped to the same SAP
BEx Query BEx Query, though subreports can be mapped to different SAP BEx
queries than the main report.

Any report mapped to an Analy- | Fields within any given report must all be mapped to the same
sis View Analysis View, though subreports can be mapped to different Anal-
ysis Views than the main report .

To another direct-to-data data | Fields can be mapped across several direct-to-data connections.
source

If you have a report that is based on a common semantic layer data type that you want to map to a
direct-to-data data source, you must map the entire report and any subreports to direct-to-data
connections.

Related Topics
* Using a placeholder formula
» Remapping unbound objects

4.3.1 To add a data source and map data

1. Click Data > Set Data Source Location.
The "Set Data Source Location" dialog box appears.

2. Inthe "Target Data Source" panel, select the Add Connection icon to add a data source connection
to your report template.
The "Choose a Data Connection" dialog box appears.

3. Select your data source connection from one of the following options:

»  Previous Connections: This option lets you use previously used data sources so that you don't
have to map them again.

- Browse Repository: This option lets you choose your data sources from the "New Data Source
Connection" list.

+ Connection by Vendor: This option connects to data sources sorted by vendor or software
provider.

4. From the "New Data Source Connection" dialog box, select the data source type and click Finish.
The data source files appear in the "Target Data Source" column.

5. Click Map.
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Fields or result objects that have a matching data type in the "Target Data Source" are mapped.

6. For the items that could not be automatically mapped, use the following procedure.

a. Expand a table or folder in both the "Current Data Source" and the "Target Data Source" panels.

b. Select an object from the "Current Data Source" panel and match it with an object in the "Target
Data Source" panel.

When you select an object in the "Current Data Source", potential matches in the "Target Data
Source" are highlighted. A percentage is used to indicate the probablility of a good match; the
higher the percentage value, the higher the compatibility.

All the objects in both the "Current Data Source" and the "Target Data Source" panels include
their data type. For string values, the length of the string is also displayed.

Note:
String data types require textual information and number data types require numerical information.
If you try to match a string data item to a number data item, a formula field is created.

c. Click the Map icon to map the objects.

Tip:
Instead of clicking "Map", you can double-click an item in the "Target Data Source" to complete
the mapping.

Note:

+ All data objects that appear in the "Current Data Sources" panel need to be paired with an
item in the "Target Data Source", or they need to be converted to a placeholder formula.

* You cannot map two data objects to one target object. If you attempt to map an object in the
"Current Data Source" field a second time, the "Replace Mapping "dialog box appears to warn
that this object is already mapped. Select Yes to replace the mapping, or No to return to the
menu and select another target data object.

7. You can change object mapping by doing one of the following actions:

Remove all fields in a direct-to-data | In the "Current Data Source" panel, right-click a table and
table from the report. then click Remove All from Report.

In the "Current Data Source" panel or the "Data Mapping"

Unmap one object. panel, select an object and then click Remove from Report.

Unmap all objects. In the "Data Mapping" panel, click Clear All.

8. When you are finished creating data connections, click Done.

Related Topics
* Using a placeholder formula
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4.3.2 To remove a data source

1. Click Data > Set Data Source Location .
2. From the "Target Data Source" column, select the unwanted data source.
3. Click the Remove Connection icon.

The data source has now been removed.

4.4 Using a placeholder formula

When using or editing a report template or when connecting to a new data source, you may have result
objects or fields on the report canvas that are not in your new data source. You can use a placeholder
formula to keep the location in the report for these unbound objects. When you are ready, you can
remap the unbound object to a result object or remove it from the report.

For direct-to-data reports, you can also choose to replace all fields in a table with placeholder formulas.

4.4.1 To use a placeholder formula

1. Click Data > Set Data Source Location.
The "Set Data Source Location" dialog box appears.

2. To replace an object with a placeholder formula, use one of the following procedures.

Set a result object or direct-to-data In the "Current Data Source" panel, right-click the result
field to a placeholder formula. object or field and click Replace with Placeholder
Formula.

Set all fields in a direct-to-data table to | In the "Current Data Source" panel, right-click a table
a placeholder formula. and click Replace All with Placeholder Formula.

The result object name will have "Placeholder Formula" listed next to it in the "Data Mapping" field.

Note:
This method can be used for both report templates and reports with mapped data sources.
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Related Topics
» To add a data source and map data

4.5 Remapping unhound objects

Unbound objects are placed in placeholder formulas, allowing you time to decide how to proceed.
When you are ready, you can remap the unbound object to an object in your data source.

Note:
When using the "Set Data Source Location" workflow, you must remap all your objects, not just the
placeholder formula objects.

Related Topics
* Using a placeholder formula

4.5.1 To remap unhound ohjects

1. ClickData > Set Data Source Location.
The "Set Data Source Location" dialog box appears.

Select your "Target Data Source" and remap the already mapped objects.

Select a placeholder formula object and map it to an object in the "Target Data Source".

Continue until all placeholder formula objects are mapped.

Click Done.

Objects that were placed under placeholder formulas have now been re-integrated into the report.

a0 eN
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Data Source Connections and Queries

5.1 Data Source Connections

You can use several different data sources to create reports in Crystal Reports, including the following:

*  Universes

*  SAP BEx queries

* Analysis views

- JDBC connections

»  ODBC connections

»  Microsoft connections

For data sources such as universes and queries, you can use the "Query Panel" to design a query for
your report.

5.1.1 Connecting to a universe

Universes include data from one or more relational data sources or OLAP cubes.

You can base new documents and queries only on universes for which you have been granted the
right.

5.1.1.1 To connect to a universe

Before you connect to a universe, log on to the Bl platform server.
1. Click File > New Report.
The "Choose a Data Source Connection" dialog box appears.
2. From "SAP BusinessObjects Business Intelligence platform", click Browse Repository.

Tip:
If you had previously connected to your universe, you can select it from "Previous Connections".
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3. From the "Data Source Type" list, click Universe.
4. On the "Name" panel, select a universe and select Next.
The "Query Panel" appears. You can now select objects from the universe to include in your query.

5. Click Finish.

5.1.2 Connecting to an SAP BEx query

Each SAP BEx query contains a group of pre-designed result objects that you can run reports on.
Though the queries are pre-designed, you can use the "Query Panel" to sort and filter the query before
you run the report.

SAP BEXx queries are hierarchy-based and can have multiple hierarchies. For example, a query on
expenses by region will create a different report than a query on expenses by employee. After you
insert the result objects in your query, if your SAP BEx query includes a variable hierarchy, you must
specify a hierarchy in order to run the report.

Note:

SAP BEx and SAP BW (Business Warehouse) refer to the same OLAP provider. For more information
on how to manage OLAP data source connections, see the “SAP BusinessObjects Analysis, edition
for OLAP Administrator Guide”.

Crystal Reports can only access BEx queries that have the Allow External Access to this Query
checkbox selected.

5.1.2.1 To connect to an SAP BEx query

Before you connect to an SAP BEx query, log on to the Bl platform server.

1. Click File > New > From Data Source.
The "Choose a Data Source Connection" dialog box appears.

2. From the "Data Source Type" list, under "SAP BusinessObjects Business Intelligence Platform",
click Browse Repository.
The "New Data Source Connection" dialog box appears.

3. From the Data Source Type menu, select SAP BEx Query Data Access.
4. On the "Name" panel, select an OLAP Connection and select Next.
The "Select BEx Query" dialog box appears.

5. Select a BEx Query and click OK.

The "Query Panel" dialog box appears. You can now select objects from the data source to include
in your query.
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6. Click Finish.
If the SAP BEXx query you connected to is designed to include an SAP server-side variable, a dialog
box appears prompting you to enter the variable option for your query.

Related Topics
» Selecting folders and result objects

5.1.3 Connecting to an Analysis View

Each Analysis View contains a pre-designed query containing pre-designed result objects. Unlike
universes or BEx queries, queries in an Analysis View cannot be edited in Crystal Reports. You can
manipulate the data from an Analysis View by using the various Crystal Reports filtering and grouping
features. To change the query itself, you need to open the Analysis View in SAP BusinessObjects
Advanced Analysis.

5.1.3.1 To connect to an Analysis View

Before you connect to an Analysis View, log on to the Bl platform server.

1. Click File > New Report.
The "New Data Source Connection" dialog box appears.

2. From the "Data Source Type" list, click Analysis View.

3. On the "Name" panel, select a pre-defined analysis view and select Next.
The report canvas appears. You can now add result objects from the "Data Explorer" side panel to
your report.

5.1.4 Connecting to other data sources

You can create connections to data sources such as ODBC, JDBC, SQL Server, and so on.

5.1.4.1 To connect to a data source
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. Click File > New > From Data Source.

The "Choose a Data Source Connection" dialog box appears.

. Click Connection by Vendor.
. Expand a vendor list, select a data source, and then click Next.
. Provide the "Data Source Name" and your login parameters.

You can verify the connection by clicking Test Connection.

If necessary, fill in the details in the "Configuration Parameters" and "Custom Parameters" tabs.

. Click Next.
. After you have selected your tables, click Finish.

5.1.4.2 To connect to an ODBC database table

. From the Data menu, click Choose Data Source.

The "Choose a Data Source Connection" dialog box appears.

. Click Connection by Vendor.
. Click Generic > Generic ODBC datasource > ODBC.

The "Set up your connection" dialog box appears.

. Provide the "Data Source Name" and your login parameters.

You can verify the connection by clicking Test Connection.

If necessary, fill in the details in the "Configuration Parameters" and "Custom Parameters" tabs.

. Click Next.
. Select and link database tables as usual.

5.1.5 Connecting to a relational connection

Relational connections use relational databases. In a relational database, data is organized in a system
of rows and columns, which are stored in a database table. The rows are called records, and the columns
are called fields.

Often, data in two different tables can be related by a common field. For example, a Customers table
will have a “Customer ID” for each customer, and an Orders table will have the “Customer ID” of each
customer who placed an order, demonstrating a relationship between tables. The two tables can be
linked by a common field.
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With relational connections, you can create reports directly on a data source without first creating a
universe. You can manage the data source connection for multiple reports in a single object. The
middleware must be installed on the SAP BusinessObjects Business Intelligence (BI) platform.

5.1.5.1 To connect to a relational connection

Before you connect to a relational connection, log on to the Bl platform server.

1. Click File > New > From Data Source.
The "Choose a Data Source Connection" dialog box appears.

2. From "SAP BusinessObijects Business Intelligence platform", click Browse Repository.

Tip:
If you had previously connected to your relational connection, you can select it from "Previous
Connections".

3. From the "Data Source Type" list, click Relational Connection.
4. On the "Name" panel, select a relational connection and click Next.

The "Selected Tables" panel appears. You can now select tables from the relational connection to
add to your query.

Note:

- Ensure all your tables are linked. Linking is needed to match records of one table with
corresponding records of another table.

* When you add multiple tables to your query, Crystal Reports attempts to link tables. Unlinked
tables appear with a red border.

5. Click Finish.

5.1.6 To import server connection information

You can import files containing server connection information. You can connect to such servers the
next time you connect to the Bl platform.

1. Click Edit > Server Connections.

2. In the "Server Connections" dialog box, click Import.

3. Select the server configuration file you want to import and click Open.
4. Click OK.

You have imported the server connection information.
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5.1.7 To export server connection information

You can save your server configuration settings to a file. Other users can share and import the file.
Click Edit > Server Connections.

In the "Server Connections" dialog box, select the name of the server you want to export.

Click Export.

Select the destination of the server configuration file and click Save.

Click OK.

o prwDd-=

You have exported the server connection information.

5.2 Changing data sources

If you are no longer able to connect to your original data source, or you have a need to connect to a
different data source, you will have to change your data source connection and remap your data objects
to objects in the new data source. If the new data source does not have all the data objects in the same
folder or table as in your original data source, you will need to manually remap the objects.

If you encounter a situation where a result object on your report does not have a match in the new data
source, you can use a placeholder formula until you decide how to resolve the problem.

Note:
When changing a universe data source to another universe data source, the query filters will not be
carried forward. You must edit the new data source to recreate any query filters that you need.

Incompatible data sources

If you try to map objects to two incompatible data sources, you will be informed that they are incompatible.
You cannot mix relational database fields (direct-to-data) with semantic layer result objects in the same
report, nor can you mix result objects from different types of semantic layer data sources.

When changing the data source for a direct-to-data report that does not have subreports, use the
following guidelines:
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Data mapping option Fields in the report

To a universe All fields must be mapped to the same universe.

To an SAP BEx Query All fields must be mapped to the same SAP BEx Query.

To an Analysis View All fields must be mapped to the same Analysis View.

To another direct-to-data data Fields can be mapped across several direct-to-data connections.
source

When changing the data source for a direct-to-data report that does have subreports, use the following
guidelines:

Any report mapped to a universe | Fields within any given report must all be mapped to the same uni-
verse, though subreports can be mapped to different universes than
the main report.

Any report mapped to an SAP | Fields within any given report must all be mapped to the same SAP
BEx Query BEx Query, though subreports can be mapped to different SAP BEx
queries than the main report.

Any report mapped to an Analy- | Fields within any given report must all be mapped to the same
sis View Analysis View, though subreports can be mapped to different Anal-
ysis Views than the main report .

To another direct-to-data data | Fields can be mapped across several direct-to-data connections.
source

If you have a report that is based on a common semantic layer data type that you want to map to a
direct-to-data data source, you must map the entire report and any subreports to direct-to-data
connections.

Related Topics

» Using a placeholder formula
» Remapping unbound objects

5.2.1 To add a data source and map data

1. Click Data > Set Data Source Location.
The "Set Data Source Location" dialog box appears.

2. Inthe "Target Data Source" panel, select the Add Connection icon to add a data source connection
to your report template.
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The "Choose a Data Connection" dialog box appears.

3. Select your data source connection from one of the following options:
- Previous Connections: This option lets you use previously used data sources so that you don't
have to map them again.

- Browse Repository: This option lets you choose your data sources from the "New Data Source
Connection" list.

+ Connection by Vendor: This option connects to data sources sorted by vendor or software
provider.
4. From the "New Data Source Connection" dialog box, select the data source type and click Finish.
The data source files appear in the "Target Data Source" column.

5. Click Map.

Fields or result objects that have a matching data type in the "Target Data Source" are mapped.

6. For the items that could not be automatically mapped, use the following procedure.

a. Expand a table or folder in both the "Current Data Source" and the "Target Data Source" panels.

b. Select an object from the "Current Data Source" panel and match it with an object in the "Target
Data Source" panel.

When you select an object in the "Current Data Source", potential matches in the "Target Data
Source" are highlighted. A percentage is used to indicate the probablility of a good match; the
higher the percentage value, the higher the compatibility.

All the objects in both the "Current Data Source™" and the "Target Data Source" panels include
their data type. For string values, the length of the string is also displayed.

Note:
String data types require textual information and number data types require numerical information.
If you try to match a string data item to a number data item, a formula field is created.

c. Click the Map icon to map the objects.

Tip:
Instead of clicking "Map", you can double-click an item in the "Target Data Source" to complete
the mapping.

Note:

- All data objects that appear in the "Current Data Sources" panel need to be paired with an
item in the "Target Data Source", or they need to be converted to a placeholder formula.

* You cannot map two data objects to one target object. If you attempt to map an object in the
"Current Data Source" field a second time, the "Replace Mapping "dialog box appears to warn
that this object is already mapped. Select Yes to replace the mapping, or No to return to the
menu and select another target data object.

7. You can change object mapping by doing one of the following actions:
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Remove all fields in a direct-to-data | In the "Current Data Source" panel, right-click a table and
table from the report. then click Remove All from Report.

In the "Current Data Source" panel or the "Data Mapping"

Unmap one object. panel, select an object and then click Remove from Report.

Unmap all objects. In the "Data Mapping" panel, click Clear All.

8. When you are finished creating data connections, click Done.

Related Topics
* Using a placeholder formula

5.2.2 To remove a data source

1. Click Data > Set Data Source Location .
2. From the "Target Data Source" column, select the unwanted data source.
3. Click the Remove Connection icon.

The data source has now been removed.

5.2.3 Using a placeholder formula

When using or editing a report template or when connecting to a new data source, you may have result
objects or fields on the report canvas that are not in your new data source. You can use a placeholder
formula to keep the location in the report for these unbound objects. When you are ready, you can
remap the unbound object to a result object or remove it from the report.

For direct-to-data reports, you can also choose to replace all fields in a table with placeholder formulas.

5.2.3.1 To use a placeholder formula

1. Click Data > Set Data Source Location.
The "Set Data Source Location" dialog box appears.
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2. To replace an object with a placeholder formula, use one of the following procedures.

Set a result object or direct-to-data In the "Current Data Source" panel, right-click the result
field to a placeholder formula. object or field and click Replace with Placeholder
Formula.

Set all fields in a direct-to-data table to | In the "Current Data Source" panel, right-click a table
a placeholder formula. and click Replace All with Placeholder Formula.

The result object name will have "Placeholder Formula" listed next to it in the "Data Mapping" field.

Note:
This method can be used for both report templates and reports with mapped data sources.

Related Topics
* To add a data source and map data

5.2.4 Remapping unbhound objects

Unbound objects are placed in placeholder formulas, allowing you time to decide how to proceed.
When you are ready, you can remap the unbound object to an object in your data source.

Note:
When using the "Set Data Source Location" workflow, you must remap all your objects, not just the
placeholder formula objects.

Related Topics
+ Using a placeholder formula

5.2.4.1 To remap unbound objects

1. ClickData > Set Data Source Location.
The "Set Data Source Location" dialog box appears.

2. Select your "Target Data Source" and remap the already mapped objects.
3. Select a placeholder formula object and map it to an object in the "Target Data Source".
4. Continue until all placeholder formula objects are mapped.
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5. Click Done.
Objects that were placed under placeholder formulas have now been re-integrated into the report.

5.3 Designing a Query

Universe and SAP BEx data source connections allow you to design the query to run reports on in
Crystal Reports.

5.3.1 Universe query design

Universe query designs include data from both relational and OLAP data sources.

To design a query using a universe, you need to first define the data selection using the Query Panel.
You then use the "Member Selector" to choose which members and hierarchies to include in the query.
Finally, you can refine your query further by adding sorts, filters, and prompts to your query.

Common Semantic Layer (CSL) best practices when designing your universe query:

+ Avoid including both a hierarchy object and associated level objects in the same report. A hierarchy
object contains all of the hierarchy nodes in a hierarchy form, whereas a level object contains only
the hierarchy nodes that match the level index in a flattened form. If both kinds of objects are included
in a report, the hierarchical data and flattened data will both be included in the query.

+ Use delegated measure as much as possible (in group headers, charting, cross-tab, and so on)
because delegated measures push down data from within the data source. This will improve
performance and data correctness.

- Define your filters and sorts in the Query Panel to achieve better performance. Filtering and sorting
defined in the Query Panel will push down data from within the data source. Filtering and sorting
defined in the Crystal Reports designer will be calculated locally.

» For report designers, set the filter in the Query Panel before previewing the report for optimized
performance. When migrating a report from the C++ stack to the Java stack through a set data
source location, all filter information is kept in a selection formula, which is calculated locally. CSL
will bring back the data to be filtered on the designer side.

5.3.1.1 Defining the data selection for a universe query
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You build queries in the "Query Panel" by using objects in a universe. The objects in the universe are
a graphical representation of the information available in a data source.

The "Query Panel" is divided into several panes:

The "Universe" pane shows a tree view of the objects that your universe contains. You cannot add
new objects or edit existing objects in the universe from the "Query Panel".

Note:

You can see all available objects in this pane by clicking Expand all. If you want to see how objects
relate to each other, click Collapse all. This option provides you with a visual representation of the
hierarchical structure of objects if such a structure is present in the universe.

The "Result Objects" pane is where you place the objects that you want as part of your query.

The "Query Filters" pane is where you place the objects that you want to use to filter the data that
is returned from your universe. You can add predefined filters from your Universe, or create custom
filters by adding objects and using the list boxes to define your filter.

5.3.1.1.1 Quick reference to objects

An object is a named component that maps to data or a derivation of data in the data source. For
example, an object may represent a column in a result folder, or it may be the summary of the values
in a column.

You use objects in a query to retrieve data for your reports. For example, some of the objects in a
human resources universe might be Names, Addresses, and Salaries.

Objects can represent different types of information.

Note:

Analysis Dimension

Object properties are defined in the SAP BusinessObjects Designer, but are not taken into account
by the "Query Panel" in Crystal Reports.

Objects cannot be defined directly in the "Query Panel". Use the SAP BusinessObjects Designer to
define objects in a universe.

Object Examples Description

This object is a logical grouping
» of columns from one or more
dimension tables that describes
a similar set of characteristics.

r

Time Dimension [ analysis in a report. Time Dimen-

This object retrieves the data
that provides the time basis for

sion objects typically retrieve
date-type data.
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Object

Attribute

Examples

Description

This object provides descriptive
data about a dimension. A detail
is always attached to the dimen-
sion for which it provides addi-
tional information. For example,
Address, Birth Date and Com-
mute Distance are detail objects
that are associated with the
Customer dimension.

Measure

This object retrieves numeric
data that is the result of calcula-
tions on data in the data source.
Measure objects are often locat-
ed in a Measures class.

Default Hierarchy

This object provides a specific
default sorting order of the di-
mension data.

Level-based Hierarchy

This object provides a sorting
order of the dimension data
based upon a specific level.

based Hierarchy

Self-referenced and Value-

This object provides a sorting
order of the dimension data
based upon a value.

Named Set

This object is a group of mem-

bers that you select and save as
a personalized set of members.
They would not normally appear
together in a hierarchy, but cor-
respond to queries or parts of

queries that you frequently use.

Filters

An object that allows you to se-
lect a subset of objects based
on query criteria provided.
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Ohject

Dimension

Examples

Description

This object represents an axis
of analysis in a query. It can
map to one or more columns or
calculations that are used as a
key element for analysis in a
query. Dimensions based on a
data foundation or an OLAP
cube differ as follows:

* A dimension based on an
OLAP cube contains hierar-
chies organized by levels.
Each level can contain an
attribute.

+ Adimension based on a data
foundation contains at-
tributes. Hierarchies are
constructed across related
tables as flat hierarchies.

Level

This object retrieves a subset of
the data from the parent hierar-
chy object where all of the re-
turned values come from the
same depth in the hierarchy.

Folder

This object is a container that
holds a group of related objects.
This is equivalent to the Class
in Universe Designer.

5.3.1.1.2 Universe member selection

Use the "Member Selector" to select members of OLAP universe hierarchies to:

« Create named sets of members when creating a universe.
« Create queries based on hierarchies or members of hierarchies.
«  Define members that will be excluded from queries.

The "Member Selector" consists of the following panes:
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"Member Selector" | This is the top pane of the "Member Selector", there are three tabs:

pané + "Members" tab: Select or exclude members according to specific relationships
in the hierarchy.

+  "Metadata" tab: Select or exclude by metadata criteria. This tab displays objects
by hierarchy levels, named sets, and calculated members.

+ "Prompt" tab: Create prompts so that the user selects members or metadata
at run-time.

"Summary" pane | This shows the selected members, prompts, and excluded members of the query
that you are building. The information you see in the "Summary" pane appears
in the "Result Objects" pane of the "Query Panel".

About hierarchies

A hierarchy is an ordered series of related objects (dimensions). An example of a hierarchy is Geography,
which may group dimensions such as Country, Region, and City. Users can observe data related to
the hierarchy from various viewpoints (all cities for a selected region, all cities for a selected country,
the country and region for a selected city, and so on).

To select a member by a hierarchal relationship

Use the member relations functions of the "Member Selector" to choose members by their relationship
or position within a hierarchy. The different relationships you can select are available when you select
a member in the "Member Selector" pane.

Note:

Children/Descendants and Parents/Ancestors are mutually exclusive pairs. You cannot choose both
the children and descendants of a member, and you cannot choose the parents and ascendants of a
member.

1. In the "Members" tab of the "Member Selector”, click in the selection box on the left of the member
name.

2. In the "Member Selector", click the name of the selected member.
The list of available options appears.

3. Choose the appropriate relation function from those described below:
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Self Use only the selected member. This is the default setting.

Children Selects members of the same level in a branch of a hierarchy.

Descendants Selects the members below the active member in a hierarchy.

Siblings Selects all of the members of the same level in different branches of the hier-
archy set.

Ancestors Selects all of the members above the active member in a hierarchy.

Parent Selects the member directly above a member.

The selection is displayed in the "Summary" pane, preceded by the function button.

To select members by level

You can select all of the members of the same level in different branches of a hierarchy. For example,
select all of the quarters in a time dimension, or cities in a geography dimension.

1.
2,

4.
5.

Drag a hierarchy into the "Result Objects" pane.
Launch the "Member Selector".
The "Member Selector" displays the hierarchy members in a tree view.

In the "Member Selector", click the Metadata tab.
The "Member Selector" displays the available Levels, Calculated Members, and Named Sets.

Select a level.
Click OK.

When you run the query, the members from the selected level are computed dynamically when the
report is created.

About named sets

A named set is a group of members that you select and save as a personalized set of members. They
would not normally appear together in a hierarchy, but correspond to queries or parts of queries that
you frequently use. The named set is available in the "Query Panel" for creating queries for the end-user.

To select named sets

The hierarchy object you have placed in the "Result Objects" pane of the "Query Panel" contains one
or more named sets.

1.
2,
3.

Drag a hierarchy into the "Result Objects" pane.

Launch the "Member Selector".

In the "Member Selector", click the Levels tab.

The "Member Selector” displays the available levels, calculated members, and named sets.
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4.
5.

Select a named set.
Click OK.

About calculated members

A calculated member is a complex calculation that you create in the data source. The calculated member
is available on the "Metadata" tab of the "Member Selector".

To select a calculated member

Before you begin, drag and drop a hierarchy or hierarchy member of an OLAP universe into the "Result
Objects" pane of the "Query Panel". The hierarchy you have selected contains one or more calculated
members.

1.
2,
3.

Drag a hierarchy into the "Result Objects" pane.

Launch the "Member Selector".

In the "Member Selector", click the Metadata tab.

The "Member Selector" displays the available Levels, Calculated Members, and Named Sets.

Select a member.

. Click OK.

About selecting universe members

Use the "Member Selector" to select a part of a hierarchy, or members of a hierarchy of an OLAP
universe. You can:

Select members according to their level or relationship within a hierarchy.
Select named sets.

Select calculated members.

Specify members that you want to exclude from the query.

Create a prompt for the end user to select criteria or members for a query.

When you have defined the members that are used in the query, you can use the query panel to add
filters and to preview the query.

Note:
When a member is selected along with a child node, all of the children of the member are included in
the query.

To sort members

By default the selected members are not sorted, they appear in the order they are stored in the data
source. You can sort lists in ascending or descending alphabetical order. This is the order that appears
in the query.

1.

Click a list of members.

2. Click the Sort order button and select the sort order from the list.
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The sort is performed locally, and is displayed in the "Member Selector".

Note:
The sorted list does not correspond to the order in the data source, the sort is performed locally.

Excluding a member or member set from a selection

You can exclude members from a query in order to restrict results. Use the Exclude function to accurately
define a member or member set that you do not want to appear in the query. For example, you could
exclude one town from a query that returns sales figures for all states in a region.

You can exclude the following types of members:

+ Explicit members.

+ Implicit members resulting from member functions.
+ Implicit members resulting from hierarchy levels.

» The hierarchy default member.

You must create a report in order to observe the results.

To exclude a member or member set from a selection
1. Click a hierarchy in the "Result Objects" pane to launch the "Member Selector".

2. Use the appropriate functions in the "Member Selector" to define the members that you want to
exclude.

The defined member appears in the "Summary" pane.
3. Select the member to exclude.
4. Click the Exclude checkbox.

The excluded member name displays in the "Summary" pane (and in the "Result Objects" pane)
with a line through the name to indicate that it is excluded from the query.

To insert a prompt in a selection

The prompt will appear when the selected member is used as a result object or filter object in a query.
You can prompt the user to select a member for the query.
1. In the query panel, double-click a member of a hierarchy.
The "Member Selector" appears.
2. Click Prompt.
3. Edit the prompt.
4. Click OK.

5.3.1.2 Defining sorting
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You can use the Sort dialog button in the "Query Panel" to define how the data is retrieved from the
data source. When the query is run, a sort defined in the "Query Panel" will affect the order and amount
of data that is retrieved from the data source.

You can sort locally, using Crystal Reports features which sort the data retrieved from the query. Using
the sorting option in the "Query Panel" is recommended to define your sort more efficiently since it sorts
the data from the data source.

5.3.1.3 Defining query filters and prompts

You can add filters and prompts to your query to limit the data shown in the report.

Note:

Filters and member selection allow you to sort your data in different ways. Member selection does not
have an effect on the measure value of your data. For example, if you select a single city or all cities
for a country, the value for the measure for that country will not be affected by the member selection.

Filtering data does have an effect on the measure value. For example, if you filter your data for a
particular city, the value for the related country will be reduced to the value of that city.

5.3.1.3.1 Creating query filters
You can use the following types of filters in a query:
* Predefined filters
These filters are created by your administrator.

«  Custom filters

You define these filters while you are creating the query.

* Prompts

Prompts are dynamic filters that you define to display a question or a list of values; users can select
different filter values each time they refresh the report.

To add a predefined filter to a query
1. Double-click the objects you want to use in your report, or drag them to the "Result Objects" pane.
2. Drag a predefined filter to the "Query Filters" pane.
Note:

Predefined filters are created and edited by your administrator. As a user of the "Query Panel", you
cannot view the component parts of predefined filters, neither can you edit them.

When you run the query, the data corresponding to the query filters you selected is returned to the
report.

79 2012-08-15



Data Source Connections and Queries

To create a custom filter

1. Select the object you want to filter and drag it to the "Query Filters" pane.

2. Select an operator from the list.
3. Select Constant, LOV (list of values), or Prompt.
4. The value you enter depends on the option you selected in step 3:

Description

Constant +  Type a value into the text box.

LoV a. In the "Prompt(s)" dialog box, add members to your list by double-clicking
them, or by selecting them in the "Members" pane and clicking the arrow
in the center.

b. Click OK.
Prompt a. In the "Edit Prompt" dialog box, select "New Prompt" to add a new prompt,
or "Use Universe Parameters" to select a parameter from your universe.
b. If you selected a "New Prompt", enter prompt options, or if you selected
"Use Universe Parameters", select a parameter.
c. Click OK.

The filter is added to the report. You can edit or remove the filter in the "Query Panel".

Related Topics

* Quick reference to query filter operators

5.3.1.3.2 Building prompts

A prompt is a dynamic filter that displays a question every time you refresh the data in a report. You
respond to prompts by typing or selecting the values you want to view before you refresh the data.
Crystal Reports retrieves only the values you specified from the data source and returns those values

to the report.
Tip:

Prompts allow multiple users to view a single report but specify a different sub-set of the data source
information. Prompts also reduce the time it takes for the data to be retrieved from the data source.

To create a prompt

1. Select the object you want to apply a prompt to and drag it to the "Query Filters" pane.

For example, if you want to allow users to specify the geographical region for the report, drag the
Region object to the "Query Filters" pane.

2. Select an operator from the list.
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7.

Note:

You cannot use the following operators for prompts: Is null or Is not null.

. Select Prompt.

In the "Edit Prompt" dialog box, select New Prompt.

. Enter a prompt message in the "Prompt Text" box.

For example, you might ask “Which region do you want to see data for?”

. Select "Select only from list" if you want your prompt to display a list of values from which users can

select values.

Click OK to confirm the prompt.

The prompt appears at each report refresh.

Related Topics

* Quick reference to query filter operators

Combining query filters and prompts

You can apply multiple filters and prompts on a single query.

Quick reference to query filter operators

The following table will help you select the operator you need to define a query filter.

Values to retrieve Example Select Filter created

Values equal to a value | Retrieve data for the

you specify. US only. Equal to <Country> Equal to US

Values different from a | Retrieve data for all <Quarter> Different
Not Equal to

value you specify.

quarters except Q4.

from Q4

Values greater than a
value you specify.

Retrieve data for cus-
tomers aged over 60.

Greater than

<Customer Age>
Greater than 60

Values greater than or
equal to a value you
specify.

Retrieve data for rev-
enue starting from
$1.5M upward.

Greater than or equal
to

<Revenue> Greater
than or equal to
1500000

Values lower than a
value you specify.

Retrieve data for exam
grades below 40.

Less than

<Exam Grade> Less
than 40

81

2012-08-15



Data Source Connections and Queries

Values to retrieve

Values lower than or
equal to a value you
specify.

Example

Retrieve customers
whose age is 30 or
less.

Select

Less than or equal to

<Age> Less than or
equal to 30

Values between two
values you specify that
includes those two val-
ues.

Retrieve the weeks
starting at week 25 and
finishing at 36 (includ-
ing week 25 and week
36).

Between

<Weeks> Between 25
and 36

Values outside the
range of two values

you specify.

Retrieve all of the
weeks of the year, ex-
cept for weeks 25
through 36 (week 25
and week 36 are not
included).

Not between

<Weeks> Not Between
25 and 36

Values that are the

Retrieve data for only
the following countries:

<Country> In list 'US;

values you specify.

the US, Japan, and the
UK.

same as §everal values the US, Japan, and the In list Japan; UK’
you specify. UK
. Don't retrieve data for
Values that are differ- . . -
ent from the multiple the following countries: Not in list <Country> Not in list

'US; Japan; UK’

Values that includes a
specific string.

Retrieve customers
whose date of birth is
1972.

Matches pattern

<DOB> Matches pat-
tern, '72'

Values that don't in-
clude a specific string.

Retrieve customers
whose date of birth is
not 1972.

Different from pattern

<DOB> Different from
pattern, '72'

Using And or Or to combine query filters

This table explains the difference between the And and the Or operators.
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Retrieve this data Example Select

Customers who ordered sup-
plies in Q1 and in Q2 (the data
Data true for both filters. you retrieve will include: cus- And
tomers who placed orders in
both Q1 and Q2).

Customers who ordered sup-
plies in: Q1 or Q2 (the data you
retrieve will include: customers
Data true for any one of the fil- | who placed orders in Q1 only;
ters. customers who placed orders
only in Q2, and; customers who
placed orders in both Q1 and
Q2).

Or

Note:
Some OLAP data sources do not support the Or operator.

To combine filters and/or prompts
1. Create each query filter and/or prompt.

By default, the "Query Panel" combines the filters and prompts with the And operator. You can leave
the And operator or change the operator to Or.

’V 4 Country |Equal v| |USP. v |l

and
% State-Prawince |Equal v| |CP- v |l

2. If necessary, change the operator to Or by double-clicking the And operator.

Note:
Some OLAP data sources do not support the Or operator.

The prompts appear when you click OK, or when you refresh the report data.

5.3.1.3.3 Incompatible queries

Incompatible queries contain objects from two different contexts that are combined in a query. Crystal
Reports for Enterprise does not support incompatible queries. If your query is an incompatible query,
in the "Query Panel", re-design the query to avoid incompatibilities before you run the report.
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5.3.1.3.4 Selecting query context

Relational data sources can include data that is displayed in different ways depending on which context
is selected. The data retrieved from the data source is based upon the selected context.

Crystal Reports requires you to determine a specific context for your query to run the report if the query
contains multi-context options.

You can change the query context in the "Query Properties" dialog box.

5.3.1.3.5 To build a simple query
1. Select an object in the "Universe" pane and double-click it or drag it to the "Result Objects" pane.

Objects that are placed in the "Result Objects" pane become the objects that your report will be
based on.

2. Repeat the previous step for each object that you want to include in the query.

3. (Optional) If you want to filter your query, select an object in the "Universe" or "Result Objects" pane,
and drag it to the "Query Filters" pane.

Add filters to the objects in the "Query Filters" pane to restrict the data your query returns. Filtering
limits the data that a user can see and reduces the runtime of queries.

4. Click Finish.

The report is generated. The data from the objects in the "Result Objects" and "Query Filters" panes
are automatically formatted onto the report. The formatting time will vary depending on the size of
your report.

5.3.1.3.6 To create a combined query

In order to create a combined query, you must be connected to a relational universe with allow combined
operators enabled.

1. After you create a simple query, click (Show/Hide) the combined query pane.
The combined queries pane appears below the "Universe" pane.

2. Click Add a Combined Query.

A new query is added to the pane and the two queries are combined with a Union join. To change
the type of join, double-click the join button to choose between the following options:

*  Union
* Minus
* Intersect
*  Union All

3. Repeat Step 2 for any additional queries you want to add.

You can switch between your query definitions by clicking the buttons in the "Combined Queries"
pane.
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5.3.1.4 Query panel functions

The Query Panel consists of the following elements:

Table 5-4: The Query Panel elements

"Universe" panel

This pane shows the available classes and ob-
jects, organized in a tree structure. Click a node
(+) to open a branch or hierarchy, click the node
again to close or collapse the hierarchy. Select
the display mode (caption, technical name, or
both caption and technical name for each object).
You can search for objects in this panel by clicking
Filter and entering the search string. To build a
query, drag objects from this panel to the "Result
Objects" or "Query Filters" panel.

"Combine Queries" panel

This panel only displays when you are combining
queries. When you click (Show/Hide) Combined
Queries Panel, the panel shows the structure of
the queries you are combining. You can move
the query icons to reorganize the way that the
queries are combined. Click a query icon to dis-
play the query properties in the "Result Objects"
and "Query Filters" panels.

"Result Objects" panel

Select the objects you want to include in the query
from the "Universe" panel and drag them into this
panel. These objects are returned as column
headers in the resulting report. When you place
hierarchical objects here, use the "Member Selec-
tor" tool to display and select the members of the
hierarchy that you want to include in the query.
You can also select members that you want to
exclude from the query.

"Query Filters" panel

When you click (Show/Hide) Filter Panel, you
can drag objects into this panel to restrict the re-
sult data by limiting the query. For example, you
can limit the results returned to specific values or
value ranges.
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Query Panel element Description

When you click (Show/Hide) Data Preview
Panel, this panel allows you to test the results of

"Data Preview" panel the query. You can preview the results that the
user will see, and modify the query and preview
the effects of the modification.

Use the query panel to create the following types of queries:

« Hierarchical queries for OLAP universes.

« Non-hierarchical queries for relational universes.

»Non-hierarchical queries for SAP BusinessObjects Enterprise XI 3.X universes.

The "Query Panel" also has the following buttons:

- Combine Queries shortcut button to combine queries for a relational universe.
*  Query Properties to view and edit the query properties.
« View Script to view the structure of the query.

5.3.1.4.1 About query properties

You can set the following properties for a query:
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Retrieve duplicate rows

When this option is selected, the query returns all related
rows, even if there are duplicate rows. If you do not want
duplicate rows in the result set, deselect this option.

Retrieve non empty rows

(only supported in OLAP universes)

An empty row occurs typically in multidimensional
queries when the data for the intersection of two or more
dimensions does not exist.

When this option is selected, the result set will contain
only rows that contain data.

When this option is deselected, the result set includes
rows that do not contain data.

Max retrieval time

Defines the maximum time (in milliseconds) that a query
can run before the query is stopped. By default, this
value is the same as the Limit Execution Time parameter
in the universe parameters.

When you set this value to 0, this option is disabled.

When the Limit Execution Time parameter is lower than
this setting, the Limit Execution Time value is used for
limiting the query execution time.

Max rows retrieved

Defines the maximum number of rows of data that are

displayed when the query runs. The query retrieves all
possible rows, but displays only the first n rows, where
n is the maximum number of rows set for this parameter.

The administrator can override this setting in the user
security profile settings.

Sample result set

This parameter (when supported by the data source)
samples n data source rows, where n is the value set
for the sample result set. This method is faster than using
the Max rows retrieved parameter.
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Reset contexts on refresh When this option is selected, when a user refreshes a
query that contains contexts, the user must choose the
context(s). The user can clear the previously selected
contexts by clicking Clear Contexts.

When this option is not selected, the query is refreshed
using the original contexts. If the contexts have been
edited since the last run for the query, the user must
choose the contexts again since the query is considered
as a new query.

Allow other users to edit all queries When selected, other users can access Query View and
modify queries in the document. When cleared, only the
report creator can modify the document. This option
applies to all queries in the document.

(interactive analysis only)

Prompt order When there are several prompts in a query, use this
feature to set the order in which prompts are executed
in a query. Click a prompt and use the up or down arrow
to change the position of the prompt.

5.3.1.4.2 View script

Use the "View Script" button to view the query specifications. The query specification is viewable in an
XML format that shows the query design.

5.3.1.4.3 About copying query specifications

Use the "Copy query specifications in clipboard" button to copy your current query specifications in the
"Result Objects" panel to a clipboard. The clipboard is viewable in XML format in the "QuerySpec XML"
dialog box.

5.3.1.4.4 About pasting query specifications

Use the "Paste query specifications from clipboard" button to paste your copied query specifications
from the clipboard to the "Result Objects" panel. Query specifications can be executed without defining
any object in the Query Panel.

5.3.1.4.5 Editing an existing query

You can return to the "Query Panel" to edit an existing query. Queries can be edited by adding or
removing an object, or you can add, edit, or remove a filter.
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To edit an existing query

Before the query can be edited, you must first log on to the Bl platform server.

1. To edit your report query, click Data > Edit Query.
The "Query Panel" appears.

2. In the "Query Panel", edit your query as necessary.
3. When you have finished editing your query, click Finish.

Changes that you made in your query are reflected in your report.

Note:

If you remove objects from your query that you have used in your report, the objects will automatically
be removed from the report.

5.3.1.5 Auto generate report with default layout

The "Generate Report" check box in the "Query Panel", when selected, will automatically generate the
report using the result objects placed in the "Result Objects" panel.

Note:

The "Generate Report" feature will work differently if you are connected to a relational data source or
an OLAP data source.

5.3.1.5.1 Relational data sources

When connected to a relational data source, the selected "Generate Report" check box will automatically
generate a report containing all report objects positioned in the "Result Objects" panel.

The objects will appear on the report canvas in the "Body" section in the same order they positioned
in the "Result Objects" panel.

5.3.1.5.2 OLAP data sources

When connected to an OLAP data source, the selected "Generate Report" check box will only
automatically generate a report containing all report objects positioned in the "Result Objects" panel if
a hierarchy is not selected.

If a hierarchy is selected, the hierarchy and the members the hierarchy contains will not automatically
be added to the "Body" section of the report canvas.
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5.3.2 SAP BEx query design

SAP BEXx queries contain pre-designed result objects to run reports on.

5.3.2.1 Active hierarchies

SAP BEXx queries are often hierarchical and can have more than one hierarchy to choose from. As a
report designer, you need to choose a hierarchy to report on. This is referred to as the active hierarchy.

An active hierarchy is a hierarchy that is currently being used. The hierarchy represents a different
hierarchy from the data source, but with the same name. If the hierarchy variable is changed when the
report is refreshed, the report will change the underlying hierarchy represented by the active hierarchy.

For example if you have two hierarchies from an SAP BEx query: country_hierarchy_01 and
country_hierachy_02 the "Query Panel" will display a single hierarchy named country. The country
hierarchy represents the active hierarchy. When this hierarchy is used in a report, the name will remain
unchanged. If this hierarchy is mandatory to the BEx query to run the report, when the report is refreshed,
Crystal Reports will prompt you to select the hierarchy variable. Your selection of country_hierarchy_01
or country_hierachy_02 will change the underlying hierarchy represented by the country hierarchy, but
the name of the country hierarchy will not change.

It is recommended to use an active hierarchy (such as country) instead of a specific hierarchy (such
as country_hierarchy_01 or country_hierachy_02).

5.3.2.2 Defining the data selection for an SAP BEx query

You build queries in the "Query Panel" by using objects in an SAP BEx query. The objects in the SAP
BEx query are a graphical representation of the information available in a data source.

The "Query Panel" is divided into several panes:

+  The "Universe" pane shows a tree view of the objects that your universe contains. You cannot add
new objects or edit existing objects in the universe from the "Query Panel".

Note:

You can see all available objects in this pane by clicking Expand all. If you want to see how objects
relate to each other, click Collapse all. This option provides you with a visual representation of the
hierarchical structure of objects if such a structure is present in the universe.

+  The "Result Objects" pane is where you place the objects that you want as part of your query.
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+  The "Query Filters" pane is where you place the objects that you want to use to filter the data that
is returned from your universe. You can add predefined filters from your Universe, or create custom
filters by adding objects and using the list boxes to define your filter.

5.3.2.2.1 SAP BEx query member selection

Use the "Member Selector" to select members of SAP BEx query hierarchies to:

+ Create named sets of members when creating an SAP BEx query
» Create queries based on hierarchies or members of hierarchies
+ Define members that will be excluded from queries

The "Member Selector" consists of the following panes:

Pane Description

"Member Selector"

pane Members tab: Select or exclude members according to specific relationships in

the hierarchy.
Levels tab: Select or exclude members according to level.

Prompt tab: Set and configure prompts to associate with the members.

"Summary" pane | This shows the selected members, prompts, and excluded members of the query
that you are building. The information you see in the "Summary" pane appears
in the "Result Objects" pane of the "Query Panel".

Note:

Universe and SAP BEx Query member selection differ in their behavior when restricting members. In
a universe member selection, there is no restriction of member selection. However, for an SAP BEx
Query, if you select a parent node and one of its child nodes, all children nodes will be selected in the

query.

About hierarchies

A hierarchy is an ordered series of related objects (dimensions). An example of a hierarchy is Geography,
which may group dimensions such as Country, Region, and City. Users can observe data related to
the hierarchy from various viewpoints (all cities for a selected region, all cities for a selected country,
the country and region for a selected city, and so on).

To select a member by a hierarchical relationship

Use the member relations functions of the "Member Selector" to choose members by their relationship
or position within a hierarchy. The different relationships you can select are available when you select
a member in the "Member Selector" pane.

1. In the "Members" tab of the "Member Selector", click in the selection box on the left of the member
name.

2. In the "Member Selector", click the name of the selected member.
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The list of available options appears.

3. Choose the appropriate relation function from those described below:

Self Use only the selected member. This is the default setting.
Children Selects members of the same level in a branch of a hierarchy.
Descendants Selects the members below the active member in a hierarchy.

The selection is displayed in the "Summary" pane, preceded by fx.

About named sets

A named set is a group of members that you select and save as a personalized set of members. They
would not normally appear together in a hierarchy, but correspond to queries or parts of queries that
you frequently use. The named set is available in the "Query Panel" for creating queries for the end-user.

To select named sets

The hierarchy object you have placed in the "Result Objects" pane of the "Query Panel" contains one
or more named sets.

1.
2,
3.

Drag a hierarchy into the "Result Objects" pane.

Launch the "Member Selector".

In the "Member Selector", click the Levels tab.

The "Member Selector” displays the available levels, calculated members, and named sets.

Select a named set.

. Click OK.

About selecting universe members

Use the "Member Selector" to select a part of a hierarchy, or members of a hierarchy of an OLAP
universe. You can:

Select members according to their level or relationship within a hierarchy.
Select named sets.

Select calculated members.

Specify members that you want to exclude from the query.

Create a prompt for the end user to select criteria or members for a query.

When you have defined the members that are used in the query, you can use the query panel to add
filters and to preview the query.
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Note:
When a member is selected along with a child node, all of the children of the member are included in
the query.

To sort members

By default the selected members are not sorted, they appear in the order they are stored in the data
source. You can sort lists in ascending or descending alphabetical order. This is the order that appears
in the query.
1. Click a list of members.
2. Click the Sort order button and select the sort order from the list.

The sort is performed locally, and is displayed in the "Member Selector".

Note:
The sorted list does not correspond to the order in the data source, the sort is performed locally.

Excluding a member or member set from a selection

You can exclude members from a query in order to restrict results. Use the Exclude function to accurately
define a member or member set that you do not want to appear in the query. For example, you could
exclude one town from a query that returns sales figures for all states in a region.

You can exclude the following types of members:

+ Explicit members.

» Implicit members resulting from member functions.
+ Implicit members resulting from hierarchy levels.

» The hierarchy default member.

You must create a report in order to observe the results.

To exclude a member or member set from a selection
1. Click a hierarchy in the "Result Objects" pane to launch the "Member Selector".

2. Use the appropriate functions in the "Member Selector" to define the members that you want to
exclude.

The defined member appears in the "Summary" pane.
3. Select the member to exclude.

4. Click the Exclude checkbox.

The excluded member name displays in the "Summary" pane (and in the "Result Objects" pane)
with a line through the name to indicate that it is excluded from the query.

5.3.2.2.2 Quick reference to objects

An object is a named component that maps to data or a derivation of data in the data source. For
example, an object may represent a column in a result folder, or it may be the summary of the values
in a column.
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You use objects in a query to retrieve data for your reports. For example, some of the objects in a
human resources universe might be Names, Addresses, and Salaries.

Objects can represent different types of information.
Note:

+  Object properties are defined in the SAP BusinessObjects Designer, but are not taken into account
by the "Query Panel" in Crystal Reports.

+  Objects cannot be defined directly in the "Query Panel". Use the SAP BusinessObjects Designer to
define objects in a universe.

Object Examples Description

This object is a logical grouping
of columns from one or more
dimension tables that describes
a similar set of characteristics.

A

Analysis Dimension

This object retrieves the data
that provides the time basis for
Time Dimension |E| analysis in a report. Time Dimen-
sion objects typically retrieve
date-type data.

This object provides descriptive
data about a dimension. A detail
is always attached to the dimen-
sion for which it provides addi-
Attribute tional information. For example,
Address, Birth Date and Com-
mute Distance are detail objects
that are associated with the
Customer dimension.

This object retrieves numeric
data that is the result of calcula-
Measure tions on data in the data source.
Measure objects are often locat-
ed in a Measures class.

This object provides a specific
Default Hierarchy default sorting order of the di-
mension data.
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Object

Level-based Hierarchy

Examples

Description

This object provides a sorting
order of the dimension data
based upon a specific level.

Self-referenced and Value-
based Hierarchy

This object provides a sorting
order of the dimension data
based upon a value.

Named Set

This object is a group of mem-

bers that you select and save as
a personalized set of members.
They would not normally appear
together in a hierarchy, but cor-
respond to queries or parts of

queries that you frequently use.

Filters

An object that allows you to se-
lect a subset of objects based
on query criteria provided.

Dimension

This object represents an axis
of analysis in a query. It can
map to one or more columns or
calculations that are used as a
key element for analysis in a
query. Dimensions based on a
data foundation or an OLAP
cube differ as follows:

A dimension based on an
OLAP cube contains hierar-
chies organized by levels.
Each level can contain an
attribute.

+ Adimension based on a data
foundation contains at-
tributes. Hierarchies are
constructed across related
tables as flat hierarchies.
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Object Examples Description

This object retrieves a subset of
the data from the parent hierar-
Level chy object where all of the re-
turned values come from the
same depth in the hierarchy.

This object is a container that

- holds a group of related objects.
Folder L_ This is equivalent to the Class
in Universe Designer.

5.3.2.3 Defining sorting

You can use the Sort dialog button in the "Query Panel" to define how the data is retrieved from the
data source. When the query is run, a sort defined in the "Query Panel" will affect the order and amount
of data that is retrieved from the data source.

You can sort locally, using Crystal Reports features which sort the data retrieved from the query. Using
the sorting option in the "Query Panel" is recommended to define your sort more efficiently since it sorts
the data from the data source.

5.3.2.4 Defining query filters and prompts

You can add filters and prompts to your query to limit the data shown in the report.

Note:

Filters and member selection allow you to sort your data in different ways. Member selection does not
have an effect on the measure value of your data. For example, if you select a single city or all cities
for a country, the value for the measure for that country will not be affected by the member selection.

Filtering data does have an effect on the measure value. For example, if you filter your data for a
particular city, the value for the related country will be reduced to the value of that city.
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5.3.2.4.1 Creating query filters
You can use the following types of filters in a query:
* Predefined filters
These filters are created by your administrator.
+ Custom filters
You define these filters while you are creating the query.

* Prompts

Prompts are dynamic filters that you define to display a question or a list of values; users can select
different filter values each time they refresh the report.

To add a predefined filter to a query
1. Double-click the objects you want to use in your report, or drag them to the "Result Objects" pane.
2. Drag a predefined filter to the "Query Filters" pane.

Note:
Predefined filters are created and edited by your administrator. As a user of the "Query Panel", you
cannot view the component parts of predefined filters, neither can you edit them.

When you run the query, the data corresponding to the query filters you selected is returned to the
report.

To create a custom filter

-—

. Select the object you want to filter and drag it to the "Query Filters" pane.
2. Select an operator from the list.

3. Select Constant, LOV (list of values), or Prompt.

4. The value you enter depends on the option you selected in step 3:
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Constant +  Type a value into the text box.

LoV a. In the "Prompt(s)" dialog box, add members to your list by double-clicking
them, or by selecting them in the "Members" pane and clicking the arrow
in the center.

b. Click OK.

Prompt a. In the "Edit Prompt" dialog box, select "New Prompt" to add a new prompt,
or "Use Universe Parameters" to select a parameter from your universe.

b. If you selected a "New Prompt", enter prompt options, or if you selected
"Use Universe Parameters", select a parameter.

c. Click OK.

The filter is added to the report. You can edit or remove the filter in the "Query Panel".

Related Topics
* Quick reference to query filter operators

5.3.2.4.2 Building prompts

A prompt is a dynamic filter that displays a question every time you refresh the data in a report. You
respond to prompts by typing or selecting the values you want to view before you refresh the data.
Crystal Reports retrieves only the values you specified from the data source and returns those values
to the report.

Tip:
Prompts allow multiple users to view a single report but specify a different sub-set of the data source
information. Prompts also reduce the time it takes for the data to be retrieved from the data source.

To create a prompt

1.

Select the object you want to apply a prompt to and drag it to the "Query Filters" pane.

For example, if you want to allow users to specify the geographical region for the report, drag the
Region object to the "Query Filters" pane.

. Select an operator from the list.

Note:
You cannot use the following operators for prompts: Is null or Is not null.

Select Prompt.
In the "Edit Prompt" dialog box, select New Prompt.

. Enter a prompt message in the "Prompt Text" box.
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For example, you might ask “Which region do you want to see data for?”

6. Select "Select only from list" if you want your prompt to display a list of values from which users can
select values.

7. Click OK to confirm the prompt.

The prompt appears at each report refresh.

Related Topics
* Quick reference to query filter operators

Combining query filters and prompts

You can apply multiple filters and prompts on a single query.

Quick reference to query filter operators

The following table will help you select the operator you need to define a query filter.

Values to retrieve

Values equal to a value
you specify.

Example

Retrieve data for the
US only.

Select

Equal to

<Country> Equal to US

Values different from a
value you specify.

Retrieve data for all
quarters except Q4.

Not Equal to

<Quarter> Different
from Q4

Values greater than a
value you specify.

Retrieve data for cus-
tomers aged over 60.

Greater than

<Customer Age>
Greater than 60

Values greater than or
equal to a value you
specify.

Retrieve data for rev-
enue starting from
$1.5M upward.

Greater than or equal
to

<Revenue> Greater
than or equal to
1500000

Values lower than a
value you specify.

Retrieve data for exam
grades below 40.

Less than

<Exam Grade> Less
than 40

Values lower than or
equal to a value you
specify.

Retrieve customers
whose age is 30 or
less.

Less than or equal to

<Age> Less than or
equal to 30
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Values to retrieve

Values between two
values you specify that
includes those two val-
ues.

Example

Retrieve the weeks
starting at week 25 and
finishing at 36 (includ-
ing week 25 and week
36).

Select

Between

<Weeks> Between 25
and 36

Values outside the
range of two values

you specify.

Retrieve all of the
weeks of the year, ex-
cept for weeks 25
through 36 (week 25
and week 36 are not
included).

Not between

<Weeks> Not Between
25 and 36

Values that are the

Retrieve data for only
the following countries:

<Country> In list 'US;

values you specify.

the US, Japan, and the
UK.

same as §evera| values the US, Japan, and the In list Japan: UK’

you specify. UK

Values that are differ- tl?]znfélzswiivecgiﬁrggg <Country> Not in list
ent from the multiple 9 | Notin list Y

'US; Japan; UK

Values that includes a
specific string.

Retrieve customers
whose date of birth is
1972.

Matches pattern

<DOB> Matches pat-
tern, '72'

Values that don't in-
clude a specific string.

Retrieve customers
whose date of birth is
not 1972.

Different from pattern

<DOB> Different from
pattern, '72'

Using And or Or to combine query filters

This table explains the difference between the And and the Or operators.
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Retrieve this data Example Select

Customers who ordered sup-
plies in Q1 and in Q2 (the data
Data true for both filters. you retrieve will include: cus- And
tomers who placed orders in
both Q1 and Q2).

Customers who ordered sup-
plies in: Q1 or Q2 (the data you
retrieve will include: customers
Data true for any one of the fil- | who placed orders in Q1 only;
ters. customers who placed orders
only in Q2, and; customers who
placed orders in both Q1 and
Q2).

Or

Note:
Some OLAP data sources do not support the Or operator.

To combine filters and/or prompts
1. Create each query filter and/or prompt.

By default, the "Query Panel" combines the filters and prompts with the And operator. You can leave
the And operator or change the operator to Or.

’V 4 Country |Equal v| |USP. v |l

and
% State-Prawince |Equal v| |CP- v |l

2. If necessary, change the operator to Or by double-clicking the And operator.

Note:
Some OLAP data sources do not support the Or operator.

The prompts appear when you click OK, or when you refresh the report data.

5.3.2.5 Query panel functions

The Query Panel consists of the following elements:
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Table 5-8: The Query Panel elements

This pane shows the available classes and ob-
jects, organized in a tree structure. Click a node
(+) to open a branch or hierarchy, click the node
again to close or collapse the hierarchy. Select
the display mode (caption, technical name, or
both caption and technical name for each object).
You can search for objects in this panel by clicking
Filter and entering the search string. To build a
query, drag objects from this panel to the "Result
Objects" or "Query Filters" panel.

"Universe" panel

This panel only displays when you are combining
queries. When you click (Show/Hide) Combined
Queries Panel, the panel shows the structure of
the queries you are combining. You can move
the query icons to reorganize the way that the
queries are combined. Click a query icon to dis-
play the query properties in the "Result Objects"
and "Query Filters" panels.

"Combine Queries" panel

Select the objects you want to include in the query
from the "Universe" panel and drag them into this
panel. These objects are returned as column
headers in the resulting report. When you place
"Result Objects" panel hierarchical objects here, use the "Member Selec-
tor" tool to display and select the members of the
hierarchy that you want to include in the query.
You can also select members that you want to
exclude from the query.

When you click (Show/Hide) Filter Panel, you
can drag objects into this panel to restrict the re-
"Query Filters" panel sult data by limiting the query. For example, you
can limit the results returned to specific values or
value ranges.

When you click (Show/Hide) Data Preview
Panel, this panel allows you to test the results of
"Data Preview" panel the query. You can preview the results that the
user will see, and modify the query and preview
the effects of the modification.

Use the query panel to create the following types of queries:
« Hierarchical queries for OLAP universes.
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* Non-hierarchical queries for relational universes.
»Non-hierarchical queries for SAP BusinessObjects Enterprise Xl 3.X universes.

The "Query Panel" also has the following buttons:

- Combine Queries shortcut button to combine queries for a relational universe.
* Query Properties to view and edit the query properties.

+ View Script to view the structure of the query.

5.3.2.5.1 View script

Use the "View Script" button to view the query specifications. The query specification is viewable in an
XML format that shows the query design.

5.3.2.5.2 About copying query specifications

Use the "Copy query specifications in clipboard" button to copy your current query specifications in the
"Result Objects" panel to a clipboard. The clipboard is viewable in XML format in the "QuerySpec XML"
dialog box.

5.3.2.5.3 About pasting query specifications

Use the "Paste query specifications from clipboard" button to paste your copied query specifications
from the clipboard to the "Result Objects" panel. Query specifications can be executed without defining
any object in the Query Panel.

5.3.2.5.4 Editing an existing query

You can return to the "Query Panel" to edit an existing query. Queries can be edited by adding or
removing an object, or you can add, edit, or remove a filter.

To edit an existing query
Before the query can be edited, you must first log on to the Bl platform server.
1. To edit your report query, click Data > Edit Query.
The "Query Panel" appears.
2. In the "Query Panel", edit your query as necessary.
3. When you have finished editing your query, click Finish.

Changes that you made in your query are reflected in your report.

Note:
If you remove objects from your query that you have used in your report, the objects will automatically
be removed from the report.
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5.4 Working with databases

This section introduces several common procedures related to accessing database files from within
Crystal Reports. Where practical, step-by-step instructions are provided.

5.4.1 Opening Access queries through ODBC

ODBC gives you more control over which parts of a database you can use. For this reason, using an
Access query through ODBC may require a few extra steps.

5.4.1.1 To open an Access gquery through ODBC

1. Create a new report.
2. From the Data menu, click Choose Data Source.
The "Choose a Data Source Connection" dialog box appears.

3. Click Connection by Vendor.
4. Click Microsoft > MS Access year > ODBC.

The "Set up your connection" dialog box appears.
5. Provide the "Data Source Name" and your login parameters.
You can verify the connection by clicking Test Connection.
If necessary, fill in the details in the "Configuration Parameters" and "Custom Parameters" tabs.

6. Find your query in the Views folder and drag it to the "Selected Tables" list.
7. Click Finish.

Note:
You cannot use Access Action queries or Update queries in Crystal Reports. However, you can use
Access Select queries and Cross-tab queries.

5.4.1.2 Opening Access Parameter gqueries
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Access Parameter queries can be opened only when you open an Access database via ODBC. Make
sure you have an ODBC data source set up for your Access database before attempting this procedure.
See Setting up an ODBC data source.

Note:

When you design a Parameter query in Access, you must provide a prompt for the query and specify
a data type for the parameter. First, with your query open in Design View in Microsoft Access, enter a
prompt in the Criteria cell for the field that will act as a parameter. Then, choose Parameters from the
Query menu in Access, and specify a data type for the parameter you just created. Make sure the
prompt appears exactly as it does in the Criteria cell. For complete instructions, refer to your Access
documentation. If you do not set up your Parameter query correctly, Crystal Reports will not be able to
use it.

5.4.1.2.1 To open an Access Parameter query
1. On the Start Page, click From Data Source.

2. Locate and select the ODBC data source that contains the Access Parameter query you want to
use.

Note:
If your database requires a user name and password, or any other log on information, click Next to
go to the Connection Information dialog box.

Tip:
Choosing an ODBC data source and entering connection information automatically logs you onto
the server.

3. Select your Parameter query from the Stored Procedures folder and drag it to the Selected Tables
list.

4. Click Finish.
5. Create your report using the fields in the Parameter query.

Click Refresh to update the report's data.
The Enter Prompt Values dialog box appears.
7. Assign a value by typing into the field and then click OK.

Your report appears. Only the records that satisfy the parameter values you specified in the Enter
Parameter Values dialog box are used in your report.

Note:
You cannot use Access Action queries or Update queries in Crystal Reports. However, you can use
Access Select queries and Cross-tab queries.

5.4.2 Using ODBC data sources
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5.4.2.1 Setting up an ODBC data source

To set up an ODBC data source, you must first have an ODBC driver installed for the type of data you
want to use. Many DBMS applications automatically install and set up ODBC drivers. If you are not
sure whether ODBC drivers have been installed for your data, refer to the documentation that came
with your DBMS application.

5.4.2.1.1 To set up an ODBC data source

1. Open the ODBC Data Source Administrator, which is usually found under Start > Programs >
Administrative Tools > Data Sources (ODBC).

2. Click Add to add a new ODBC data source.

The Create New Data Source dialog box appears.
3. Choose the ODBC driver appropriate for your data type from this list.
4. Click Finish when finished.

If a driver does not appear for your data type, then the ODBC driver has not been correctly installed.
Refer to the documentation for your DBMS application.

An ODBC Data Source Setup dialog box that is specific to the ODBC driver you selected appears.

Note:
If an error message appears instead of the Setup dialog box, you may not have the correct ODBC
drivers installed on your system for the type of data you selected.

5. Type the name for your new ODBC data source in the Data Source Name box.

Note:

The dialog box that appears may look different from the one shown here, depending on the type of
data you are using. This dialog box is specific to the Access ODBC driver. For more information
about using the dialog box that appears for your data, click Help.

6. Click OK when finished.

5.4.2.2 Checking settings for an ODBC data source

1. Open the ODBC Data Source Administrator, which is usually found under Start > Programs >
Administrative Tools > Data Sources (ODBC), or Start > Settings > Control Panel > Data Sources
(ODBC).

2. Highlight the appropriate data source from the User Data Sources list (on the User DSN tab).
3. Click Configure.
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The ODBC Data Source Setup dialog box that appears is specific to the data source you selected,
and contains controls and information for setting up your data source.

4. Check the settings in this dialog box to make sure the information matches your system and database.
5. Make any changes necessary, and then click OK.
6. Click OK to close the ODBC Data Source Administrator dialog box.

5.4.2.3 Logyging off an ODBC data source

1. Choose Log On or Off Server from the Database menu.

If no report is open, choose Log On of Off Server from the File menu.
The Data Explorer dialog box appears.

2. Highlight the ODBC data source you want to log off from this list.
3. Click Log Off.
4. Click Close when finished with the Data Explorer dialog box.

5.4.3 Stored procedures

In addition to the common relational database attributes (tables, fields, records, and so on) many SQL
DBMS systems support stored procedures. A stored procedure is a compiled SQL program consisting
of one or more SQL statements. A stored procedure can be used to define an SQL query that you can
use over and over again. Furthermore, variables, conditional expressions, and variable arguments can
be defined in the stored procedure so that you are prompted to provide information before the procedure

is executed.
Exscutes Querles Database Returns Data Set
saL Dialog barx that
x appears
Statement to the usar requesting
walues for parameters in
that o one the stored procadura.
or mare SQL
emts

Since stored procedures can return a result set, they can provide a specific set of data when executed.
In fact, Crystal Reports allows you to execute a stored procedure on an SQL database and use the
returned data to design a report. If the stored procedure is designed to prompt a user for information
to base its query on, Crystal Reports will prompt you for that information when you select the stored
procedure for your report.
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5.4.3.1 To select an SQL stored procedure

1. On the Start Page, click From Data Source.
The "Choose a Data Source Connection" dialog box appears.

2. Locate and select the SQL Server data source that contains the stored procedure that you want to
use.

3. Click Next to go to the "Set up your connection" dialog box.

4. Enter the required information to log in, and then click Next.
The "Select Tables for your Report" dialog box appears.

5. Drag a stored procedure to the Selected Tables list.
6. If prompted, select a parameter from the list.
set to Null is supported if no value is specified.

7. Click Finish and create your report using the fields in the stored procedure.

5.4.4 Linking tahles

You link tables so records from one table will match related records from another. For example, if you
activate an Orders table and a Customers table, you link the tables so that each order (from the Orders
table) can be matched up with the customer (from the Customer table) that made the order.

When you link, you are using a field that is common to both tables. Crystal Reports uses the link to
match up records from one table with those from the other. In this example, the link assures that the
data in each row of the report refers to the same order.

5.4.4.1 Smart linking

When you select tables for your report, any existing links between the tables will be applied automatically.
Do the following to verify that all links are applied:

+ In the Selected Tables area, click the Perform Smart Linking button.

108 2012-08-15



Data Source Connections and Queries

5.4.4.2 To change link properties

1. Click Edit Data Sources.

2. In the Selected Tables pane, select the link between two tables, and click Change this link’s
properties.

3. Change the properties and then click OK.

Related Topics
* Link Properties dialog box

5.4.4.3 To clear all links

1. Click Edit Data Sources.
2. Click in the "Selected Tables" pane.
3. Click Clear Links.

All the table links are removed.

4. Click Finish.

5.4.4.4 Link Properties dialog box

The "Link Properties" dialog box appears when you select a link and click Edit Link Properties. It
contains the following sections:
* From
To
Join Type
+ Enforce Join
» Link Type

Related Topics
* Link from and link to
* Linking options

109 2012-08-15



Data Source Connections and Queries

5.4.4.5 Link from and link to

When you link two tables, you link from one table to another table. The from table is used as a primary
table, while the to table acts as a lookup table where records are looked up by the primary table. In a
simple link, the Report Designer examines the first record in the primary table and finds all matching
records in the lookup table. Once all matches have been found in the lookup table for the first record
in the primary table, all matches in the lookup table for the next record in the primary table are found.

5.4.4.6 Link relationships

When you link records from one table to another table, the records will typically fall under one of two
relationship types: one-to-one or one-to-many.

5.4.4.6.1 One-to-one relationships

In a one-to-one relationship between records in two linked tables, for every record in the primary table
there is only one matching record in the lookup table (based on the linked fields). For example, in the
Xtreme.mdb database, the Employee table can be linked to the Employee Addresses table based on
the Employee ID field in each table. The Employee table contains information about employees at the
company, the positions they hold, their salaries, hiring information, and so on. The Employee Addresses
table contains each employee's home address. There is only one record for each employee in each of
these tables. Therefore, if the Employee table is linked to the Employee Addresses table, only one
record will be found in the Employee Addresses table for each record in the Employee table. This is a

one-to-one relationship.

5.4.4.6.2 One-to-many relationships

In a one-to-many relationship between records in two linked tables, for every record in the primary table,
there may be more than one matching record in the lookup table, based on the linked fields. In the
Xtreme.mdb database, the Customer table can be linked to the Orders table based on the Customer
ID field in each table. The Customer table contains information about each customer that has placed
an order with the company. The Orders table contains information about orders that customers have
placed. Since customers can place more than one order, there may be more than one record in the
Orders table for each customer record in the Customers table. This is a one-to-many relationship.

5.4.4.7 Linking options
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Crystal Reports enables you to specify the type of join and type of link you want to use when linking
tables. You can also enforce the use of tables in your joins. Joins and links indicates how linked fields
in two tables are compared when records are read. Join, enforce, and link options can be specified in
the Link Options dialog box. Using the various join enforcement options can ensure that linked tables
are included in the SQL query, even when none of the fields in the table are used in the report.

Note:
When you link fields using joins, no indexed fields are required.

The join types are:

= Inner join

« Left Outer join

* Right Outer join

»  Full Outer join

The enforce join options are:
* Not Enforced

« Enforced From

«  Enforced To
« Enforced Both

The link types are:

« Equal [F] link

* Greater Than [>] link

« Greater Than Or Equal [>=] link
* Less Than [<] link

* Less Than Or Equal [<=] link

* Not Equal ['=] link

5.4.4.7.1 Inner join

An Inner join is the standard type of join. The result set from an Inner join includes all the records in
which the linked field value in both tables is an exact match. For instance, you can use an Inner join to
view all customers and the orders they have placed. You will not get a match for any customer who
has not placed orders.

Customer Table Customer Table Orders Table
Customer ID Customer Name Order Amount
52 Allez Distribution 25141.50

53 BG Mountain Inc. 19164.30
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Customer Tahle Customer Table Orders Table
Customer ID Customer Name Order Amount
53 BG Mountain Inc. 1683.60

57 Hansen MTB Inc. 15716.40

58 La Bomba de Bicicleta 1956.20

60 Mountain Toad 24580.50

62 SFB Inc. 7911.80

63 Sierra Bicycle Group 19766.20

63 Sierra Bicycle Group 12763.95

64 Sierra Mountain 8233.50

5.4.4.7.2 Left Outer join

The result set from a Left Outer join includes all the records in which the linked field value in both tables
is an exact match. It also includes a row for every record in the primary (left) table for which the linked
field value has no match in the lookup table. For instance, you can use a Left Outer join to view all
customers and the orders they have placed, but you also get a row for every customer who has not
placed any orders. These customers appear at the end of the list with blanks in the fields that would
otherwise hold order information:

Customer Table Customer Table Orders Table
Customer ID Customer Name Order Amount
52 Allez Distribution 25141.50

53 BG Mountain Inc. 19164.30
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Customer Tahle Customer Table Orders Table
Customer ID Customer Name Order Amount
53 BG Mountain Inc. 1683.60
57 Hansen MTB Inc. 15716.40
58 La Bomba de Bicicleta 1956.20
60 Mountain Toad 24580.50
62 SFB Inc. 7911.80
63 Sierra Bicycle Group 19766.20
63 Sierra Bicycle Group 12763.95
64 Sierra Mountain 8233.50
54 Bicicletas Aztecas
55 Deely MTB Inc.
Note:

Left Outer and Right Outer joins are handled differently in the SQL language from other join types. If
the database is accessed through ODBC, Crystal Reports uses ODBC syntax in the SQL statement.
If you are connecting to an SQL database directly (not through ODBC), Crystal Reports uses a syntax
native to the database. For more information about what an Outer join looks like in an SQL statement,
refer to Microsoft ODBC documentation or to the documentation for your SQL database.

5.4.4.7.3 Right Outer join

The result set from a Right Outer join includes all the records in which the linked field value in both

tables is an exact match. It also includes a row for every record in the lookup (right) table for which the
linked field value has no match in the primary table. If you link the Customer table to the Orders table,
you get one row in the table for each order a customer has placed. You also get a row for every order
found that cannot be linked to a customer. Theoretically, this should not happen, but if an inexperienced
sales person forgot to assign a customer ID to an order, you can quickly locate that order with a Right
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Outer join. The resulting table leaves a blank in any of the Customer fields for the order without a
customer.

Customer Table Orders Table Orders Table
Customer ID Order 1D Order Amount
52 6 25141.50
53 11 19164.30
53 21 1683.60
57 4 15716.40
58 20 1956.20
60 16 24580.50
62 19 7911.80
63 28 19766.20
63 32 12763.95
64 14 8233.50
25 10320.87
Note:

Left Outer and Right Outer joins are handled differently in the SQL language from other join types. If

the database is accessed through ODBC, Crystal Reports uses ODBC syntax in the SQL statement.

If you are connecting to a SQL database directly (not through ODBC), Crystal Reports uses a syntax

native to the database. For more information about what an Outer join looks like in an SQL statement,
refer to Microsoft ODBC documentation or to the documentation for your SQL database.
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5.4.4.7.4 Full Outer join

A Full Outer join is a bidirectional outer join where you can see all records in your linked tables. The
result set from a Full Outer join includes all the records in which the linked field value in both tables is
an exact match. It also includes a row for every record in the primary (left) table for which the linked
field value has no match in the lookup table, and a row for every record in the lookup (right) table for
which the linked field value has no match in the primary table. If you link the Customer table to the
Orders table, you get one row in the table for each order a customer has placed. You also get a row
for every order found that cannot be linked to a customer, and a row for every customer for whom an

order cannot be found.

Customer Tahle

Orders Table

Orders Tahle

Customer ID Order ID Order Amount
52 6 25141.50
53 11 19164.30
53 21 1683.60
57 4 15716.40
58 20 1956.20
60 16 24580.50
62 19 7911.80
63 28 19766.20
63 32 12763.95
64 14 8233.50
65

66
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Customer Tahle Orders Table Orders Tahle

Customer ID Order 1D Order Amount

25 10320.87

5.4.4.7.5 Not Enforced

When you select this option, the link you've created is used only if it's explicitly required by the Select
statement. Your users can create reports based on the selected tables without restriction (that is, without
enforcement based on other tables). This is the default option.

5.4.4.7.6 Enforced From

When you select this option, if the to table for the link is used, the link is enforced. For example, if you
create a link from TableA to TableB using Enforce From and select only a field from TableB, the Select
statement will still include the join to TableA because it is enforced. Conversely, selecting only from
TableA with the same join condition will not cause the join to TableB to be enforced.

Note:
For an explanation of from and to tables, see Link from and link to.

5.4.4.7.7 Enforced To

When you select this option, if the from table for the link is used, the link is enforced. For example, if
you create a link from TableA to TableB using Enforce To and select only a field from TableA, the join
to TableB will be enforced, and the Select statement that is generated will include both tables.

Note:
For an explanation of from and to tables, see Link from and link to.

5.4.4.7.8 Enforced Both

When you select this option, if either the from table or the to table for this link is used, the link is enforced.

5.4.4.7.9 Equal [=] link

The result set from an Equal link includes all the records where the linked field value in both tables is
an exact match. In the following example, the Customer table is linked to the Orders table by the
Customer ID field. When the program finds a Customer ID in the Orders table that matches a Customer
ID in the Customer table, it displays information for the corresponding records in both tables.
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SQL uses the following syntax to describe an Equal link:

SELECT Customer.'Customer ID',
Customer. 'Customer Name',
Orders.'Order Amount'

FROM 'Customer' Customer,
'Orders' Orders

WHERE Customer.Customer ID =
Orders.Customer ID

This statement produces the following data:

Customer Tahle Customer Table Orders Table
Customer ID Customer Name Order Amount
52 Allez Distribution 25141.50

53 BG Mountain Inc. 19164.30

53 BG Mountain Inc. 1683.60

57 Hansen MTB Inc. 15716.40

58 La Bomba de Bicicleta 1956.20

60 Mountain Toad 24580.50

62 SFB Inc. 7911.80

63 Sierra Bicycle Group 19766.20

63 Sierra Bicycle Group 12763.95

64 Sierra Mountain 8233.50

5.4.4.7.10 Greater Than [>] link

The result set from a Greater Than link includes all records in which the linked field value from the
primary table is greater than the linked field value in the lookup table. As an example, a company may
want to compare the salaries made by all their sales representatives to the salaries made by all their
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sales managers. The company executives want to make sure no sales representative is making more
money than any manager.

With this in mind, you can link the SalesRep table to the Manager table by the Salary field in each table
using a Greater Than link:

SELECT SalesRep.'Last Name',
SalesRep. 'Salary’,
Manager. 'Last Name',
Manager. 'Salary'

FROM 'SalesRep' SalesRep,
'Manager' Manager

WHERE SalesRep.'Salary' >
Manager. 'Salary'

This SQL statement might produce data similar to this:

SalesRep Table SalesRep Table Manager Tahle Manager Table
Last Name Salary Last Name Salary
Davolio $35,000.00 Fuller $32,000.00
Davolio $35,000.00 Brid $30,000.00
Davolio $35,000.00 Buchanan $29,500.00
Dodsworth $48,300.00 Hellstern $45,000.00
Dodsworth $48,300.00 Fuller $32,000.00
Dodsworth $48,300.00 Brid $30,000.00
Dodsworth $48,300.00 Buchanan $29,500.00
Dodsworth $48,300.00 Martin $35,000.00
Patterson $30,000.00 Buchanan $29,500.00

In this table, there is no relationship established between sales representatives and sales managers.
Since all managers have seniority over all sales representatives, a company might find it necessary to
check if any representatives make more money than any managers, evidence of a salary problem that
needs to be remedied.
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5.4.4.7.11 Greater Than Or Equal [>=1] link

The result set from a Greater Than Or Equal link includes all records in which the linked field value in
the primary table is greater than or equal to the linked field value in the lookup table. The example here
is identical to the example for the Greater Than join, except that it uses the Greater Than Or Equal link:

SELECT SalesRep.'Last Name',
SalesRep. 'Salary’,
Manager.'Last Name',
Manager. 'Salary'

FROM 'SalesRep' SalesRep,
'Manager' Manager

WHERE SalesRep.'Salary' >=
Manager. 'Salary'

This statement might produce data such as this:

SalesRep Tahle SalesRep Table Manager Tahle Manager Table
Last Name Salary Last Name Salary
Davolio $35,000.00 Fuller $32,000.00
Davolio $35,000.00 Brid $30,000.00
Davolio $35,000.00 Buchanan $29,500.00
Davolio $35,000.00 Martin $35,000.00
Dodsworth $48,300.00 Hellstern $45,000.00
Dodsworth $48,300.00 Fuller $32,000.00
Dodsworth $48,300.00 Brid $30,000.00
Dodsworth $48,300.00 Buchanan $29,500.00
Dodsworth $48,300.00 Martin $35,000.00
Patterson $30,000.00 Brid $30,000.00
Patterson $30,000.00 Buchanan $29,500.00
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5.4.4.7.12 Less Than [<] link

The result set from a Less Than link includes all records in which the linked field value in the primary
table is less than the linked field value in the lookup table. Using the Less Than link, you can compare
sales representative and manager salaries in a different direction. Once again, the Salary field in each
table is used as the link field. This time, though, you link from the Manager table to the SalesRep table
using a Less Than link on the linked Salary fields:

SELECT Manager.'Last Name',
Manager. 'Salary',
SalesRep. 'Last Name',
SalesRep. 'Salary'

FROM 'Manager' Manager,
'SalesRep' SalesRep

WHERE Manager.'Salary' <
SalesRep. 'Salary’

This SQL statement produces a slightly different table than that produced by the Greater Than link:

Manager Tahle Manager Tahle SalesRep Table SalesRep Table
Last Name Salary Last Name Salary
Fuller $32,000.00 Davolio $35,000.00
Fuller $32,000.00 Dodsworth $48,300.00
Brid $30,000.00 Davolio $35,000.00
Brid $30,000.00 Dodsworth $48,300.00
Buchanan $29,500.00 Davolio $35,000.00
Buchanan $29,500.00 Dodsworth $48,300.00
Buchanan $29,500.00 Patterson $30,000.00
Martin $35,000.00 Dodsworth $48,300.00
Hellstern $45,000.00 Dodsworth $48,300.00
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5.4.4.7.13 Less Than Or Equal [<=] link

The result set from a Less Than Or Equal link includes all records in which the linked field value in the
primary table is less than or equal to the linked field value in the lookup table. The example here is
identical to the example for the Less Than link, except that it uses the Less Than Or Equal link:

SELECT Manager.'Last Name',
Manager. 'Salary',
SalesRep. 'Last Name',
SalesRep. 'Salary'

FROM 'Manager' Manager,
'SalesRep' SalesRep

WHERE Manager.'Salary' <=
SalesRep. 'Salary’

This SQL statement produces data similar to the following:

Manager Tahle Manager Tahle SalesRep Table SalesRep Table
Last Name Salary Last Name Salary
Fuller $32,000.00 Davolio $35,000.00
Fuller $32,000.00 Dodsworth $48,300.00
Brid $30,000.00 Davolio $35,000.00
Brid $30,000.00 Dodsworth $48,300.00
Brid $30,000.00 Patterson $30,000.00
Buchanan $29,500.00 Davolio $35,000.00
Buchanan $29,500.00 Dodsworth $48,300.00
Buchanan $29,500.00 Patterson $30,000.00
Martin $35,000.00 Davolio $35,000.00
Martin $35,000.00 Dodsworth $48,300.00
Hellstern $45,000.00 Dodsworth $48,300.00
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5.4.4.7.14 Not Equal ['=] link

The result set from a Not Equal link includes all records in which the linked field value in the primary
table is not equal to the linked field value in the lookup table. This type of link can be used to find possible
combinations of items when a table is joined to itself (a self-join). For example, a company can have a
table listing all products they sell. When they decide to hold a sale where their customers buy one item
and get the second item half price, they may need a list of all possible two item combinations:

SELECT Productl.'Product Name',
Product2. 'Product Name',

FROM 'Product' Productl
'Product' Product2

WHERE Productl.'Product Name' !=
Product?2. 'Product Name'

In this SQL statement, the Product table is opened twice. The first time, it is given the alias name
Product1. The second time, it is given the alias name Product2. Then the Product Name field is used
to link from the Product1 table to the Product2 table. This is the same table, but since it has been opened
twice using different aliases, Crystal Reports considers it two separate tables. A Not Equal link is used
to link the tables by the Product Name field. As a result, each product is paired with every other product
offered, but is not paired with itself:

Producti Product2

Product Name Product Name

Xtreme Adult Helmet Xtreme Mtn Lock

Xtreme Adult Helmet InFlux Lycra Glove

Xtreme Adult Helmet Roadster Micro Mtn Saddle
Xtreme Mtn Lock Xtreme Adult Helmet
Xtreme Mtn Lock InFlux Lycra Glove

Xtreme Mtn Lock Roadster Micro Mtn Saddle
InFlux Lycra Glove Xtreme Adult Helmet
InFlux Lycra Glove Xtreme Mtn Lock

InFlux Lycra Glove Roadster Micro Mtn Saddle
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Producti Product2

Product Name Product Name

Roadster Micro Mtn Saddle Xtreme Adult Helmet

Roadster Micro Mtn Saddle Xtreme Mtn Lock

Roadster Micro Mtn Saddle InFlux Lycra Glove
Note:

The symbol != is used to represent a Not Equal link, if the ODBC data source driver for the data being
accessed supports this symbol. If not, the default symbol <> is used to represent a Not Equal link.

5.5 Process to Verify Data Source on First Refresh

When you open a report, Crystal Reports automatically checks for changes in the metadata of the active
data source the first time you refresh your report data. Active data sources include universes and SAP
BEX queries.

If any changes in the metadata are detected, a dialog box will appear indicating that a change has been
made to the data source and the report must be updated. Changes to a data source could include any
of the following:

«  Changes to properties or attributes of a result object, for example, the result object name.

« Changes to data types of the result objects in the data source.

« Changes to the number of inherited parameters in the data source.

Depending on the changes made to the data source, you may have to remap result objects and reformat
your report.

Note:
When the set of result objects are updated, any saved data will be discarded.

Example: A parameter has been added or removed to filter data from a data source:

A universe designer may choose to add an inherited parameter to a result object to ensure all reports
are run on time during peak report periods. "Crystal Reports" will detect this change to the number of
parameters in the source data. The inherited parameter will restrict the amount of available data in

each report by prompting users to specify information, such as by department, region, or sales quarter.
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If the universe designer removes the inherited parameter from the data source, "Crystal Reports" will
detect this change, but the parameter will remain in the report. It will appear in the "Parameters" area
of the "Data Explorer" as a local parameter which you can delete.

In this case, once you have refreshed the result objects in your report, save the report so that you do
not need to verify the metadata again the next time you open it.

5.6 Indexing the correct result ohjects

These guidelines describe the best ways to index saved data and what to avoid when indexing:

Index result objects that users frequently add to their record selection formulas.
Index result objects that are referred to by the report's record selection formula.

Don't index all of the result objects in the report.

Indexing all of the result objects can result in increased processing times. It is best to index only on
the result objects that meet the criteria specified above. If all of the result objects meet these criteria,
then you should prioritize the result objects and index only some of them.

Don't index result objects that contain unique values only.

For instance, don't index a result object such as "Last Year's Sales," whose values are likely to be
distinct from one another. If you do so, a separate index is created for each and every value in the
result object.

5.6.1 To index saved data

. Open your report in Crystal Reports.

From the Data menu, click Report Bursting Indexes.

In the "Report Bursting Indexes" dialog box, select the result objects that you want indexed within
the saved data.

Click OK to return to Crystal Reports.
If you want to create the index immediately, refresh and save the report.
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Report Layout and Formatting

This chapter refers to changes you can make to the layout and design of a report, as well as the
appearance of text, objects, or entire report sections.

You can use formatting to do many things, including:

Dividing a report into sections.

Calling attention to certain data.

Changing the presentation of dates, numbers, Boolean values, currency values, and text strings.
Hiding unwanted sections.

Giving the report a professional appearance.

The following topics describe the types of formatting you can do with Crystal Reports, giving step-by-step
instructions for performing a variety of formatting tasks.

6.1 Using the report design environment

6.1.1 Understanding section characteristics

A report consists of several sections, including the "Report Header", "Page Header", "Group Header",
"Body", "Group Footer", "Page Footer", and "Report Footer".

For more information about sections, see Structure mode areas.

6.1.2 Creating multiple-column reports

Instead of having the data in the "Body" section of your report print straight down the page, you can set
up multiple columns and have the data flow from column to column.
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6.1.2.1 To create a multiple-column report

1. Open the report you want to format with multiple columns.
2. Right-click in the "Body" heading area and click Format Body.
The Format dialog box appears.

3. Select Multiple Columns.
4. Set the Column Width for your column.
Keep in mind the width of your paper when deciding your column width. For example, if you have

three elements in your Body section, and they take up four inches of space, limit the width of the
column to under four and a half inches so that all of the element information can be seen.

5. Choose a Flow Direction for your data.

6. If the report you're formatting contains grouping, select Multi-Column Groups.

7. Set the Horizontal and Vertical gaps you want to maintain between each record in your column.
When you preview the report, you will see that the data appears in columns. If your report has element

headers, they appear only for the first column. To have element headers for the second column, insert
a text element in the Crystal Reports editor.

6.1.3 Using smart guidelines

Smart guidelines help you format report columns in the Crystal Reports designer canvas. The columns
and the objects within them can be moved and rearranged simultaneously as the smart guidelines

calculate associated objects based upon similar alignment. The grids that appear on the report depend
on the element you have selected and the feature automatically selects related elements in the column.

The smart guidelines feature can be turned off in the "Report Options" dialog box. If you want to
deactivate the feature temporarily to resize a specific element, select the element and then press and
hold the Alt key while resizing it.

Note:
Smart guidelines do not work with elements that are already formatted, such as cross-tab elements.

6.1.3.1 To insert a column using smart guidelines
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Smart guidelines allow you to insert new result object columns without having to manually move the
surrounding columns over. If smart guidelines are disabled, the inserted result object will overlap the
existing result object.

1. Select a result object from the "Data Explorer" side panel and drag the object to the report canvas.

2. Align the result object frame in the desired column until the smart guideline grids appear to indicate
the column position and place the result object.

Note:
If you insert a column between two existing columns, the blue smart guideline grid will change to a
dark blue to indicate the column will be positioned between the existing columns.

6.1.3.2 Adjusting columns using smart guidelines

You can reorder, remove, and resize columns using the column side cursors and handles on the top
of the report canvas. Smart guidelines allow you to delete and adjust columns without having to manually
move the surrounding columns over.

6.1.3.2.1 To adjust column width
1. Click the column you want to adjust.
Smart guideline grids appear.
2. Move the pointer over the right side of the column.
The cursor changes into a resizing cursor.

3. Click and drag the column width to decrease or increase the size.

6.1.3.2.2 To adjust column position

You can move a single column horizontally on the report canvas or multiple columns simultaneously.

1. Click a column you want to move.
Smart guideline grids appear.

2. Click the column handles on top of the report canvas and drag the column:

+  To move a single column, drag the column to the left or right. Smart guidelines will adjust the
existing columns to accommodate the re-positioned column.

+  To move multiple columns, use a single column to push the existing columns over, or use the
left side edge to drag a row of columns.

6.1.3.2.3 To swap columns using smart guidelines
1. Click the column you want to swap to select it.
Smart guideline grids appear.
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TKHROXPRVLWURAZY SSHG

6.1.3.3 To create subcolumns using smart guidelines

<R¥DBOUHDWXEFRCGXRQLQVS D Q KHIIGHIH PV RORK\DE RR W H{W H P W& YW
VSD@NVZRPRUFROXPQV
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6.1.4 Hiding report sections

&U\VWHDIR K IWWVH Y HUWRDS H W\K\IRMYD § HWRL GRHY X S SUHWVYRHKAWLRQV

6.1.4.1 Show on Drill Only

7KH6KRR QU LDPOS UR S KU BBWH F WZKRHID HYRHUXW KHH SRRW[DP S D®
VXPPDWNSRWUKWBKRRQULDIOSUR S IFD WA V HEBE L V SRO@ONKHX P P D UE K@R W

W KGHH W B H & MRIGHK P P D ULKHHVQV K BK RR QU LDA@OS UR S H W\W § OW RGH F WIL\R Q
EHFRPHW LMY KHLO O BRIZOXY HEE UG R DRYQV KHH F WFLRRIDV H R BV R S H U W\
LVWEVROLAD D ERMR QG LWDEB S ODIARUR UP X O D

6.1.4.2 Hide
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